ISL9.5 CM2150 SN

Last Modified: 02 May 2017

Copyright © 2017
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware failures or internal ECM voltage supply circuits. | Engine may not start.
Engine Control Module

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM mounting location varies depending on engine model and can be mounted either on or off engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111.

Last Modified: 08-Aug-2012
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect. The ECM has detected the primary and backup speed sensor signals are connected backwards. | The engine could possibly not start.
Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM detects the reversed sensors and continues to operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code indicates the crankshaft position sensor and the camshaft position sensor wiring harness connectors are reversed.

Refer to Troubleshooting Fault Code t05-115.

Last Modified: 08-Aug-2012


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The intake manifold pressure sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • The torque output of the engine will be reduced

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with selective catalytic reduction (SCR) aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-122.

Last Modified: 08-Aug-2012


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The intake manifold pressure sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Engine power will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with selective catalytic reduction (SCR) aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-123.

Last Modified: 08-Aug-2012


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 125

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 125 PID: 102 SPN: 102 FMI: 18 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Intake manifold pressure is below the minimum operating limit. | Engine power derate.
Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold.

If the ECM detects that the necessary charge flow into the engine is below the minimum limit for a period of time, this fault code is logged.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic only performs when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal reading is below the expected level for the present engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the engine is able to achieve the desired oxygen level necessary for complete combustion and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too low for the present engine operating conditions. The ECM commands a charge flow command and the variable geometry turbocharger and exhaust gas recirculation valve move to meet this command. If the engine is unable to achieve the desired oxygen level necessary for complete combustion, this fault code is logged.

Possible causes of this fault are:

  • Leaks in the air intake system between the turbocharger and intake manifold
  • A damaged intake manifold pressure sensor
  • A damaged barometric pressure sensor
  • Restriction in the charge-air cooler
  • Restriction in the air filter
  • Restriction in the exhaust system.
Refer to Troubleshooting Fault Code t05-125.

Last Modified: 06-Sep-2012


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3/3 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 1 circuit. | Severe derate in power output of the engine. Limp home power only.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

When the ECM senses a signal voltage higher than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal or lever. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Failed accelerator pedal or lever position sensor.

The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-131.

Last Modified: 08-Aug-2012


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 1 signal circuit. | Severe derate in power output of the engine. Limp home power only.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is less than a calibratible value for more than 1 second

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed. If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Failed accelerator pedal or lever position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-132.

Last Modified: 08-Aug-2012


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3/3 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate. Remote accelerator position will be set to 0 percent.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the remote accelerator pedal signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open remote accelerator pedal or lever return circuit in the harness or connections
  • Remote accelerator supply shorted to battery
  • Failed remote accelerator pedal or lever position sensor.

The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-133.

Last Modified: 08-Aug-2012


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate. Remote accelerator position will be set to 0 percent.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the remote accelerator pedal signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Validate the repair. Start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Failed remote accelerator pedal or lever position sensor
  • Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-134.

Last Modified: 08-Aug-2012


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
Engine Oil Rifle Pressure Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is greater than 4.75-VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-135.

Last Modified: 08-Aug-2012


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P0522 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
Engine Oil Rifle Pressure Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is less than 0.25-VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used of the engine oil pressure reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-141.

Last Modified: 08-Aug-2012


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P0524 SPN: 100 FMI: 18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Engine power derate.
Engine Oil Rifle Pressure Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

If the ECM detects low signal voltage, indicating low engine oil pressure, this fault code sets.

Component Location

The engine oil pressure sensor is located on the left side of the engine block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the engine oil pressure is less than the engine protection limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A torque derate issued by the ECM limits the power output of the engine.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light and the torque derate will be removed when the oil pressure reading is detected to be within the normal operating range.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code t05-143.

Last Modified: 08-Aug-2012


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for engine coolant temperature circuit faults.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and emissions control.

Component Location

The engine coolant temperature sensor is located near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the coolant temperature signal voltage is greater than 5.13-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque can possibly be reduced.
  • A default value is used for the coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-144.

Last Modified: 08-Aug-2012


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for engine coolant temperature circuit faults.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine coolant. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and emissions control.

Component Location

The engine coolant temperature sensor is located near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value is used for the coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

On some engines, the coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-145.

Last Modified: 08-Aug-2012


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than the maximum operating limits set in the ECM calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut off if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the coolant temperature decreases below the engine protection limit.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code t05-151.

Last Modified: 08-Aug-2012


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for intake manifold air temperature.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The ECM supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the intake manifold temperature signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque can possibly be reduced.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
Refer to Troubleshooting Fault Code t05-153.

Last Modified: 08-Aug-2012


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the electronic control module (ECM). No engine protection for intake manifold air temperature.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the ECM for the engine protection system and engine emission control. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature signal voltage is less than 0.41-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque can possibly be reduced.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-154.

Last Modified: 08-Aug-2012


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after Red Stop Lamp starts flashing.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the ECM for the engine protection system and engine emission control. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manfiold air temperature is greater than 132°C [270°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut off if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-155.

Last Modified: 08-Aug-2012


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The electronic control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-195.

Last Modified: 08-Aug-2012


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P2558 SPN: 111 FMI: 4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to ground in the engine harness, connector, or sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-196.

Last Modified: 08-Aug-2012


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P2560 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The electronic control module (ECM) supplies 5 volts to the coolant level signal circuit. The resistance of the engine coolant level sensor changes, based on the coolant level. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the original equipment manufacturer (OEM) service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminated the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) after 20 seconds when low engine coolant level has been detected.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after 20 seconds of detecting the correct engine coolant level.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code becomes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-197.

Last Modified: 08-Aug-2012


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on elevation that the engine is presently operating at. The ambient air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure signal voltage is greater than 4.75-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately, when the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value of the ambient pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-221.

Last Modified: 08-Aug-2012


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at barometric pressure circuit. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the ambient air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure signal voltage is less 0.25-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value of the ambient pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with SCR aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-222.

Last Modified: 08-Aug-2012


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Fuel injection disabled until engine speed falls below the overspeed limit.
Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The electronic control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used to determine the position of the engine by the ECM.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects the engine speed has exceeded the calibration limit for excessive engine speed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the engine speed drops to normal operating speeds.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-234.

Last Modified: 08-Aug-2012


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Possible hard starting and rough running.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 3 signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor 5-VDC supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible cause of this fault code is a short circuit to ground in the engine harness, sensor, or ECM.

Refer to Troubleshooting Fault Code t05-238.

Last Modified: 08-Aug-2012


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Possible hard starting and rough running.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Not applicable.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 3 signal voltage is more than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code t05-239.

Last Modified: 08-Aug-2012


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P084 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect. The ECM lost the vehicle speed signal. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion.

Conditions for Setting the Fault Codes

The ECM detects a loss of vehicle speed when other engine operating conditions indicate that the vehicle could possibly be in motion.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.

Conditions for Clearing the Fault Code

  • Start the engine and let it idle for 1 minute to validate the repair.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid engine speed signal from the vehicle speed sensor.
  • The ECM will turn off the Malfunction Indicator Lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault code is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault code can also become active if there is a series of clutch, service brake, or throttle movements, with no vehicle movement. The fault code is set inactive when the ECM receives a vehicle speed signal greater than zero.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not catch all malfunctions of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors, and tachographs are not fully covered under this procedure.

Refer to Troubleshooting Fault Code t05-241.

Last Modified: 08-Aug-2012


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: SPN: 84 FMI: 10 LAMP: Amber SRT: | Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change. Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to maximum engine speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission.

Conditions for Running the Diagnostics

  • The adjustable parameter “VSS Anti-Tampering” must be enabled.
  • This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The ECM detects a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.
  • Cruise Control, Gear-Down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

  • The ECM detects a valid engine speed signal from the vehicle speed sensor.
  • The keyswitch must be turned ON, and the vehicle speed and engine speed must be zero for 30 seconds.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.

Shop Talk

Verify the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

When the speed signal has been restored, the fault code will go inactive, once the keyswitch is on for 30 seconds and the ECM senses zero vehicle and engine speed.

Refer to Troubleshooting Fault Code t05-242.

Last Modified: 08-Aug-2012


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S033 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can possibly stay on continuously or not run at all.
Fan Clutch Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the electronic control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is presently set up for use. The fan control circuit varies by the OEM. OEMs can use a solenoid return that is wired to the ECM or use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is getting energized or de-energized. In some cases, the diagnostics can also run at certain fixed intervals.

Conditions for Setting the Fault Codes

The fan control circuit PWM signal is not detected to be system voltage when the PWM signal is turned ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The fan will not be enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The fan control logic can be adjusted with INSITE™ electronic service tool. There are two choices: 12-VDC or 24-VDC ON, or 0-VDC ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12-VDC or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12-VDC or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

Refer to Troubleshooting Fault Code t05-245.

Last Modified: 08-Aug-2012


Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 249

Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at ambient air temperature circuit. | None on performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is used by the electronic control module (ECM) to monitor ambient air temperature. This can be used to sense the temperature inside the cab of a vehicle or the air temperature outside of the vehicle. The ambient air temperature signal is used by the ECM for the Idle Shutdown Ambient Air Temperature Override feature.

The ambient air temperature sensor is used by the ECM to monitor the ambient air temperature. The ambient air temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air temperature signal voltage is greater than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • Engine torque will be reduced.
  • The Idle Shutdown Ambient Air Temperature Override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-249.

Last Modified: 08-Aug-2012


Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 256

Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at ambient air temperature circuit. | None on performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air to determine if heating of the selective catalytic reduction (SCR) system is required. The electronic control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The location of the ambient air temperature sensor can vary, and is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • Engine torque will be reduced.
  • The Idle Shutdown Ambient Air Temperature Override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The ambient air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 256.

Last Modified: 08-Aug-2012


Antitheft Password Valid Indicator - Data Erratic, Intermittent, or Incorrect

FAULT CODE 269

Antitheft Password Valid Indicator - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 269 PID: SPN: 1195 FMI: 2 LAMP: Red SRT: | Antitheft Password Valid Indicator - Data Erratic, Intermittent, or Incorrect. Engine ignition attempt without authorization from the immobilizer anti-theft device. | The engine will not start.
Engine Control Module

Circuit Description

The immobilizer antitheft device is connected to the primary engine electronic control module (ECM) through a J1939 data link network.

Messages sent from the immobilizer antitheft device are received by the ECM and used for controlling the antitheft features. The ECM and immobilizer antitheft device must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and location of original equipment manufacturer (OEM) installed J1939 devices varies by OEM. The immobilizer antitheft device is installed by the OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is active when the immobilizer antitheft device has not been deactivated.

Action Taken When the Fault Code is Active

The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM turns off the appropriate fault lamp when the diagnostic runs and passes.

Shop Talk

This fault code is active when the immobilizer anti-theft device has not been deactivated. The engine will not start until proper authorization has been activated.

Refer to Troubleshooting Fault Code 269.

Last Modified: 08-Aug-2012


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: SPN: 1347 FMI: 4 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage is detected at the fuel pump actuator circuit. | Engine will run poorly at idle. Engine will have low power. Fuel pressure will be higher than commanded.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the electronic control module (ECM) that controls the electronic fuel control actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the electronic fuel control actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump actuator is located on the engine-mounted fuel pump. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Fuel rail pressure will be higher than the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code becomes active when the ECM detects a short circuit in the electronic fuel control actuator circuit. Causes for this fault code are short circuit to ground or low resistance (fuel control actuator coil is shorted internally) in the circuit for the fuel pump actuator. When excessive current or a short circuit is detected, the ECM driver to the fuel control actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test again for the cause of the fault code. The ECM driver is enabled at key ON; if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Fault Code 2311 can have high counts if the fault condition is or was intermittent.

Refer to Troubleshooting Fault Code 271.

Last Modified: 08-Aug-2012


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: SPN: 1347 FMI: 3 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit is detected at the fuel pump actuator circuit. | Engine will not run or engine will run poorly.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse width modulation (PWM) driver in the electronic control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump actuator is located on the engine-mounted fuel pump housing. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit PWM signal is detected to be greater than 0-VDC when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Fuel rail pressure will be higher than the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes. To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

  • This fault becomes active when the ECM detects an open in the fuel pump actuator circuit. Causes of this fault code are a short circuit to positive voltage or an open circuit in the fuel pump actuator circuit. If there is high harness resistance or an intermittent open circuit, Fault Code 2311 can have high inactive counts. If the fault code is intermittent, look closely for causes of an intermittent open circuit such as loose pins, bad connections, or loose wire connections at the ECM connector. Also, if the fault code is intermittent, wiggle the harness while monitoring the fault code state to check for a wiring issue internal to the harness.
Refer to Troubleshooting Fault Code 272.

Last Modified: 08-Aug-2012


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | One or more multiplexed devices will not operate properly.
Engine Control Module

Circuit Description

Normally, switches, accelerators and other components are connected to the electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

Not Applicable

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second.

The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged Cummins® ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code 285.

Last Modified: 08-Aug-2012


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
Engine Control Module

Circuit Description

Normally, switches, accelerators and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

Not Applicable

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM expects to receive a valid J1939 message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code 286.

Last Modified: 08-Aug-2012


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

FAULT CODE 287

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 287 PID: P91 SPN: 91 FMI: 2/19 LAMP: Amber SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error. The original equipment manufacturer (OEM) vehicle electronic control unit (VECU) detected a fault with its accelerator pedal. | Engine can only idle or engine will not accelerate to full speed.
Engine Control Module

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from the OEM VECU or transmission electronic control unit are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent, but the secondary throttle position sensor indicates it is in the idle position.

When the accelerator is released and the OEM VECU reads accelerator position as 0 percent, but the secondary throttle position sensor indicates it is not in the idle position.

The OEM VECU determines that the accelerator signal wire is shorted high or shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault can occur when the OEM VECU detects an error on the accelerator. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the idle validation switch states and accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component.

The three types of errors that can occur for this fault are:

  • When the accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent, but the idle validation switch indicates it is in the idle position. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • When the accelerator is released and the OEM VECU reads accelerator position as 0 percent, but the idle validation switch indicates it is not in the idle position. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • The OEM VECU determines that the accelerator signal line is shorted high or shorted low.

It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins® ECM, for other components, or the accelerator and idle validation switch, or if the data link is damaged. The OEM configurations must multiplex the accelerator and idle validation switch inputs together to allow the use of the J1939 multiplexing and limp home feature for these components. Use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code 287.

Last Modified: 08-Aug-2012


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P372 SPN: 974 FMI: 2/19 LAMP: Red SRT: | SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error. The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | The engine will not respond to the remote throttle. Engine could possibly only idle. The primary or cab accelerator could possibly be able to be used.
Engine Control Module

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit (ECU) in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from the OEM VECU or transmission ECU are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

Not Applicable

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The OEM VECU determines that the remote throttle signal wire is shorted high or shorted low. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.

When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU. This fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with the INSITE™ electronic service tool.

Shop Talk

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

  • The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU. This fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM. Most OEM VECUs will not incorporate fault detection on a switch.

It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins® ECM for other components, or the remote throttle and remote throttle switch, or the data link is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. The INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code 288.

Last Modified: 08-Aug-2012


Proprietary Data Link Error (OEM/Vehicle Data Link) - Abnormal Update Rate

FAULT CODE 291

Proprietary Data Link Error (OEM/Vehicle Data Link) - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 291 PID: SPN: 625 FMI: 9 LAMP: Red SRT: | Proprietary Data Link Error (OEM/Vehicle Data Link) - Abnormal Update Rate. The immobilizer anti-theft system will not operate properly. The engine could possibly not start. | The immobilizer anti-theft system will not operate properly. The engine could possibly not start.
Engine Control Module

Circuit Description

The immobilizer anti-theft device is connected to the primary engine electronic control module (ECM) through a J1939 data link network.

Messages sent from the immobilizer anti-theft device are received by the Cummins® ECM and are used to control the anti-theft features. The Cummins® ECM and immobilizer anti-theft device must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and location of OEM installed J1939 devices varies by OEM. The immobilizer anti-theft device is installed by the OEM. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM is not able to communicate with the immobilizer anti-theft system via the J1939 data link.

Action Taken When the Fault Code is Active

The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM turns off the appropriate fault lamp when the diagnostic runs and passes.

Shop Talk

This fault can occur for the following reasons:

  • When the ECM is set up properly to receive information from an immobilizer anti-theft device, but the immobilizer anti-theft device could possibly not be transmitting the message for that component. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the immobilizer anti-theft device source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the immobilizer anti-theft device is not set up to transmit the multiplexed component message.
  • This fault can be caused by a malfunctioning J1939 data link connection between the immobilizer anti-theft device and Cummins® ECM, a malfunctioning connection between the component and the immobilizer anti-theft device, malfunctioning immobilizer anti-theft device or malfunctioning Cummins® ECM. It could be necessary to contact the OEM for proper multiplexing configuration.
Refer to Troubleshooting Fault Code 291.

Last Modified: 08-Aug-2012


Barometric Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 295

Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2/2 LAMP: Amber SRT: | Barometric Pressure - Data Erratic, Intermittent, or Incorrect. An error in the barometric pressure sensor signal was detected by the engine control module (ECM). | Possible reduced engine performance.
ISL9 CM2150 SN - Barometric Pressure Circuit

Circuit Description

The barometric air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on elevation where the engine is presently operating. The barometric air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The ECM provides a 5 volt supply to the barometric air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The barometric air pressure sensor provides a signal to the ECM on the barometric air pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness, near the ECM.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. One part runs when the keyswitch is initially turned on before the engine is started.

The other part runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the barometric pressure reading is higher or lower than the other absolute pressure sensors on the engine, or an in-range malfunction of the sensor has been detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced after 50 hours of engine operation.
  • A default value is used for the barometric pressure reading.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range barometric pressure sensor reading
  • High resistance in the barometric pressure sensor signal or return lines.
Refer to Troubleshooting Fault Code t05-295.

Last Modified: 01-Dec-2015


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S006 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 1 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside the ECM. The injectors for cylinder numbers 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinder numbers 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinder(s).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 322.

Last Modified: 08-Aug-2012


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 5 when voltage is turned off. | Current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault code will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injector event for the cylinder(s) that is malfunctioning.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

• Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code t05-323.

Last Modified: 08-Aug-2012


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S006 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. Current detected at injector Number 3 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside the ECM. The injectors for cylinder numbers 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinder numbers 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinder(s).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code t05-324.

Last Modified: 08-Aug-2012


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: p0206 SPN: 656 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 6 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return to two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that are faulty.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled from the malfunctioning cylinder

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code t05-325.

Last Modified: 08-Aug-2012


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S006 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 2 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside the ECM. The injectors for cylinder numbers 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinder numbers 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault code will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinder(s).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and malfunctions.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code t05-331.

Last Modified: 08-Aug-2012


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S006 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 4 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside the ECM. The injectors for cylinder numbers 1 and 2 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinder numbers 3 and 4 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to two injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinder(s).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the faulty cylinders.

Conditions for Clearing the Fault Code

  • The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

This fault code and the malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code t05-332.

Last Modified: 08-Aug-2012


Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 334

Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 334 PID: P0110 SPN: 110 FMI: 2/2 LAMP: Amber SRT: | Engine Coolant Temperature - Data Erratic Intermittent or Incorrect. The engine coolant temperature reading is not changed with engine operating conditions. | Possible reduced engine performance.
ISL9.5 CM2150 SN - Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the engine control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emission control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

If coolant temperature is found to be higher than intake manifold temperature by a calibrated value, the fault code is logged. The diagnostic also checks to make sure that coolant temperature increases during the first 10 minutes of engine operation. If coolant temperature does not increase by a calibrated value, this fault code is logged.

Action Taken When the Fault Code is Active

  • The ECM will estimate engine coolant temperature.
  • Engine torque will be reduced after 50 hours of engine operation.
  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM illminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Two different failure modes of the engine coolant temperature sensor can trigger this fault code. The engine must be turned OFF for period of 8 hours before this diagnostic will run. When the keyswitch is turned ON after an 8 hour cold soak, engine coolant temperature is compared to intake manifold temperature. If coolant temperature is found to be higher than intake manifold temperature by a calibrated value, the fault code is logged. The diagnostic also checks to make sure that coolant temperature increases during the first 10 minutes of engine operation. If coolant temperature does not increase by a calibrated value, this fault code is logged.

Possible causes of this fault code include:

  • Stuck in-range engine coolant temperature sensor
  • A signal shorted to ground in the harness
  • A signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-334.

Last Modified: 01-Dec-2015


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Engine Control Module (ECM) Warning Internal Hardware Failure - Bad Intelligent Device or Component. ECM power supply errors have been detected. | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Engine Control Module

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the OEM power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If the unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code 343.

Last Modified: 05-Sep-2012


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 627 FMI: 12/12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The ECM measured injector boost voltage is low. | Possible smoke, low power, engine misfire, and/or engine will not start.
Injector Solenoid Driver Circuit

Circuit Description

Between each injection event, the electronic control module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors; this power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm, the primary engine speed sensor signal is present, and the battery charge is above a minimum threshold.

Conditions for Setting the Fault Codes

The ECM detects that the measured injector power supply voltage is lower than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the measured injector power supply voltage reaches the commanded injector power supply voltage and the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • The inactive fault code will be cleared from memory after the completion of 40 warm-up cycles.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

This fault code will become active when the engine is running, the primary engine speed sensor signal is present, the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

This fault code will become inactive whenever the keyswitch is turned on.

This fault code will become inactive whenever the engine is running and measured injector power supply voltage reaches the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351.

Last Modified: 08-Aug-2012


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Engine power derate.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 of the electronic control module (ECM) provides a 5 volt supply for multiple engine sensors.

Component Location

Sensor supply number 1 is located in the ECM engine harness connector and provides a 5 volt supply to various sensors. The supply voltage is spliced off in the engine harness to each sensor it supports.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 signal voltage is less than 4.75-VDC for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code t05-352.

Last Modified: 08-Aug-2012


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Engine power derate.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 of the electronic control module (ECM) provides a 5 volt supply for the barometric pressure sensor, fuel rail pressure sensor, intake manifold temperature/pressure combination sensor, and camshaft speed/position sensor.

Component Location

Sensor supply number 1 is located in the ECM engine harness connector and provides a 5 volt supply to various pressure sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 signal voltage is greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Low voltage on the 5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code t05-386.

Last Modified: 08-Aug-2012


Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Progressive power derate is increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Oil Rifle Pressure Circuit

Circuit Description

The engine oil pressure switch is used by the electronic control module (ECM) to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, the switch will open and cause Fault Code 415 to log.

The oil pressure switch is normally closed when the engine is not running and open when oil pressure is present.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is below minimum operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • A torque derate issued by the ECM limiting the power output of the engine.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE light and the torque derate will be removed when the oil pressure reading is detected to be within the normal operating range.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure switch
  • Engine harness shorted to ground.
Refer to Troubleshooting Fault Code 415.

Last Modified: 08-Aug-2012


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | Possible loss of power, or hard starting.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The electronic control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that water in the fuel filter is above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the flashing amber MAINTENANCE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the flashing amber MAINTENANCE light and the fault code will go inactive immediately after the water has been drained from the fuel filter.

Shop Talk

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water-In-Fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 418.

Last Modified: 05-Sep-2012


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P097 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The electronic control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor then pulls the 5 volt reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the water-in-fuel sensor signal voltage is above 4.95-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes for this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 428.

Last Modified: 05-Sep-2012


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P097 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The electronic control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor then pulls the 5 volt reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the water-in-fuel sensor signal voltage is below 0.05-VDC for 1second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
Refer to Troubleshooting Fault Code t05-429.

Last Modified: 05-Sep-2012


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect. The engine oil pressure sensor is reading an erratic value at key-on. | None on performance. No engine protection for oil pressure.
Engine Oil Rifle Pressure Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, the sensor will open and cause Fault Code 435 to log.

The oil pressure sensor is normally closed when the engine is not operating and open when oil pressure is present.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is turned ON and before engine speed is detected.

The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

This fault code is logged when an open circuit is detected for five consecutive key cycles when the ECM expected a closed circuit at key-on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include.

  • Damaged engine oil pressure sensor
  • Open circuit in the engine oil pressure sensor signal wire
  • Damaged ECM
  • Short circuit in the engine oil pressure sensor signal wire to a voltage source.
Refer to Troubleshooting Fault Code 435.

Last Modified: 08-Aug-2012


Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 436

Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 436 PID: 111 SPN: 105 FMI: 2 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect. The intake manifold temperature sensor is reading an erratic value at initial key ON or while the engine is running. | The ECM will estimate engine intake manifold temperature.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the electronic control module (ECM) for the engine protection system and engine emission control. The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage, or a low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of 8 hours before this part of the diagnostic will run. The second part runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine intake manifold temperature sensor reading is higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • The ECM will estimate engine intake manifold temperature.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for a period of 8 hours. After the 8 hour cold soak, turn the key to the ON position but do not start the engine.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • In-range malfunction of the engine intake manifold temperature sensor.
  • High resistance in the engine intake manifold temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code t05-436.

Last Modified: 08-Aug-2012


Battery 1 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Below Normal Operating Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine could stop running or be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-ampere fuse in the unswitched battery wires to protect the original equipment manufacturer (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for the battery location.

Not applicable.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is less than 6-VDC.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code and illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the fault code and amber CHECK ENGINE light, and the fault code will go inactive immediately after the battery voltage is above 6-VDC
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is logged when the ECM battery supply voltage drops below 6-VDC.

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code 441.

Last Modified: 08-Aug-2012


Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to all electrical components.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-ampere fuse in the unswitched battery wire to protect the original equipment manufacturers (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM troubleshooting and repair manual for battery location.

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is greater than +36-VDC.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code and illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the fault code and amber CHECK ENGINE light, and the fault code will go inactive immediately after the battery voltage drops below +36-VDC.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is logged when the ECM battery supply voltage exceeds +36-VDC. Causes of this fault code include:

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code 442.

Last Modified: 08-Aug-2012


Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: SPN: 157 FMI: 0 LAMP: Red SRT: | Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure in the fuel rail is higher than the normal operating fuel system pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load) or possible power derate.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) monitors engine-operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The high-pressure relief valve is located on the fuel rail. The fuel pump actuator is located on the engine-mounted fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the measured fuel rail pressure has been above the maximum pressure allowed by the fuel pressure relief valve.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails. Power derate can occur on some engines.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute. The fault code will go inactive once the fuel rail pressure returns to normal operatiing levels.
  • The ECM will turn off the amber CHECK ENGINE light immediately after diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Fault Code 449 is not used to indicate a fuel pressure relief valve opening. It is used to indicate a fuel pressure relief valve that fails to open or does not regulate pressure. Troubleshooting must be focused on inspecting the drain line path of the fuel pressure relief valve for restrictions/obstructions and checking or replacing the fuel pressure relief valve. A restriction in the fuel-drain-to-tank return line can prevent unneeded fuel from exiting the fuel system. Check the fuel drain line restriction from the fuel rail to the tank for damage.

Refer to Troubleshooting Fault Code 449.

Last Modified: 08-Aug-2012


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: SPN: 157 FMI: 3 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the rail fuel pressure sensor circuit. | Power and/or speed derate.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel rail. The fuel delivery pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor, using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel rail. The ECM will detect a low signal voltage at high rail pressures. The ECM will detect a high signal voltage during low rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the fuel rail pressure signal voltage is greater than a calibratible value for more than 1 second. This fault code will become active if there is an open circuit on any of the three pins 5 volt supply, signal, or return that connect the fuel rail pressure sensor or ECM to the wiring harness.

This fault will also be active if the signal wire is shorted to a source of voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque could possibly be reduced.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with an airless SCR aftertreatment system:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

  • Voltage 5-VDC or higher shorted to the signal wire
  • Open circuit on the signal wire
  • Open circuit on the 5-VDC supply wire
  • Open circuit on the return wire
  • Malfunctioning sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 451.

Last Modified: 08-Aug-2012


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: SPN: 157 FMI: 4 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the rail fuel pressure sensor circuit. | Power and/or speed derate.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel rail. The fuel delivery pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a low signal voltage at high rail pressures. The ECM will detect a high signal voltage during low rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the fuel rail pressure signal voltage is less than a calibratible value for more than 1 second. This can be caused by a short circuit to ground on the 5-VDC supply or signal wire.

This fault will also become active if a device that is powered by the common 5 volt power supply is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque can possibly be reduced.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.

For engines equipped with an airless SCR aftertreatment system:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after 3 consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

  • Engine harness; the supply or signal wire is shorted to ground
  • Other components; any component connected to the common power supply is shorted to ground
  • Malfunctioning sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 452.

Last Modified: 08-Aug-2012


Turbocharger 1 Wastegate Control - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 545

Turbocharger 1 Wastegate Control - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 545 PID: SPN: 1188 FMI: 7 LAMP: Amber SRT: | Turbocharger 1 Wastegate Control - Mechanical System Not Responding or Out of Adjustment. The intake manifold pressure has exceeded the maximum limit for the given engine rating. | Engine power derate.
Engine Control Module

Circuit Description

The intake manifold pressure sensor is used by the engine control module (ECM) to monitor the engine intake manifold pressure.

Component Location

Not Applicable.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code becomes active when the intake manifold pressure exceeds the maximum pressure limit for a given engine rating.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes:

  • Malfunctioning turbocharger wastegate
  • Wastegate tampering
  • Wrong turbocharger part
  • Possible tampering of the fuel system or turbocharger system.
Refer to Troubleshooting Fault Code 545.

Last Modified: 08-Aug-2012


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: 157 SPN: 157 FMI: 16 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The electronic control module (ECM) has detected that fuel pressure is higher than the commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load). Engine power is reduced.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (Open the fuel pump actuator) or decrease (Close the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed in the adapter on the back of the high-pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the fuel rail pressure reading has exceeded the recommended operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

If the fuel pump actuator exhibits excessive leakage, it is possible that the fuel rail pressure will reach the opening pressure of the fuel rail pressure relief valve and Fault Code 1911 could possibly become active.

The fuel rail pressure sensor can also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero on some engines. In such cases, it could be necessary to manually relieve the pressure from the high-pressure fuel rail.

Refer to Troubleshooting Fault Code 553.

Last Modified: 08-Aug-2012


Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 554

Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: PID: 554 SPN: 157 FMI: 2 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the fuel pressure signal is not changing. | The ECM will estimate the fuel pressure and power is reduced.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The fuel pressure sensor contains supply, signal, and return pins. The engine control module (ECM) provides 5 volt to the fuel pressure sensor. This 5 volts power supply is a shared supply. Other sensors on this circuit are the intake manifold temperature/pressure sensor, barometric air pressure sensor, and the backup engine position sensor.

Component Location

The fuel pressure sensor is located in the rail fuel on the air intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the fuel rail pressure reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails. Power derate could occur on some engines. A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code can become active any time the engine is loaded and the ECM detects the fuel pressure in the rail fuel is not changing. This fault code will become inactive when the ECM is powered down or if the ECM detects that the engine is loaded and the fuel pressure is changing normally. If there are many inactive counts of this fault code or if the fault is not repeatable, look for signs of tampering to the fuel pressure sensor circuit.

If the fault code occurs intermittently (can not be reproduced during a road test), then inspect each of the following for poor connections or damage:

  • Intake manifold temperature/pressure sensor
  • Backup engine position sensor
  • Fuel pressure sensor
  • Barometric air pressure sensor.
Refer to Troubleshooting Fault Code 554.

Last Modified: 08-Aug-2012


Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 18 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Possibly hard to start, low power, or engine smoke. Engine could possibly not start.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the fuel gear pump. The electronic control module (ECM) monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

Component Location

The fuel rail pressure sensor is mounted to the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM has detected the measured fuel rail pressure is below the commanded fuel rail pressure by a calibratable limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Before performing troubleshooting work, verify the vehicle's system voltage by monitoring battery voltage in INSITE™ electronic service tool data monitor or connecting a digital volt ohm meter to the batteries. This will help identify a potential system voltage issue. Refer to the OEM service manual for specified voltage range and troubleshooting procedures.

If the engine will not start and Fault Code 559 becomes active during cranking, but no speed sensor fault codes exist, monitor rail pressure with INSITE™ electronic service tool. The procedures referred to in this troubleshooting tree will also have checks for engine no-start conditions.

Before servicing any fuel system components, (such as fuel lines, fuel pump, injectors, etc.) which would expose the fuel system or internal engine component to potential contaminants prior to disassembly, clean the fittings, mounting hardware, and the area around the component to be removed. Dirt or contaminants can be introduced into the fuel system and engine if the surrounding areas are not cleaned, resulting in damage to the fuel system and engine. Refer to Procedure 000-009 in Section 0. This procedure is found in the ISC and ISL CM2150 Service Manual, Bulletin 4021569 and in the ISLe CM2150 Service Manual, Bulletin 4021630.

If rail pressure is low, check the following:

  • Fuel system prime (make sure there is fuel in the tanks and the system is primed)
  • Fuel lift pump pressure
  • Fuel gear pump pressure.

If gear pump pressure is OK, test for system leakage:

  • High-pressure pump leakage
  • Injector leakage
  • Fuel rail pressure relief valve.

If Fault Code 559 is inactive and there are no existing performance complaints, it is possible the vehicle was run out of fuel or the fault came active if the engine was not primed following fuel filter replacement. Clear the inactive fault code.

Fault Code 559 sets when the engine is operating and measured rail fuel pressure remains at least 100 bar [1450 psi] less than commanded pressure. Once detected, Fault Code 559 will remain active until the engine is turned off or until the measured rail fuel pressure matches the commanded rail fuel pressure. When a condition exists that causes Fault Code 559 to become active, it is typical for the fault code to become active when the engine is heavily loaded and become inactive when the engine is lightly loaded.

When Fault Code 559 occurs, the fuel system has lost its ability to maintain rail fuel pressure.

Causes of this fault include:

  • Fuel inlet restrictions
  • Fuel filter plugging
  • Fuel gear pump output low
  • Fuel gear pump pressure actuator sticking or leaking
  • High pressure pump capacity decay (high leakage to drain from the high-pressure pump)
  • Fuel rail pressure relief valve leaks to drain
  • Fuel rail pressure relief valve opens at too low a pressure
  • Injector fuel circuit leaks to drain
  • Pressure sensor reads more than 100 bar [1450 psi] lower than actual pressure
  • Air in the fuel.

A few bubbles exiting the line during the test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry can be isolated to one of the following; suction fuel lines, OEM fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).

The fuel rail pressure sensor can also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Once the engine is keyed OFF, there could be a significant amount of time waiting on the fuel to depressurize to 0. It is necessary to manually relieve the pressure from the high-pressure fuel rail by loosening the pump to rail line at the rail.

Intermittent ECM power supply connections can cause Fault Code 559. If the engine is operating with an active Fault Code 559 and Fault Codes 449, 1911, or 2311 are not present, check the ECM power supply for intermittent connections. Fault Code 1117 can also be active if this fault condition exists.

Inactive Fault Code/Exhausted Troubleshooting Tree:

Troubleshooting inactive Fault Code 559 can be very difficult. The fault code must be active for any of the outlined procedures in which the engine is operated during the test. For engines with high counts of inactive Fault Code 559, or if the troubleshooting tree has been exhausted, operate the engine on a chassis dynamometer or a diagnostic road test to duplicate the fault code. The most common causes of intermittent Fault Code 559 that are difficult to create are leaking high-pressure connectors that only leak when the engine and the fuel are hot, intermittent fuel supply restrictions, such as debris floating in the fuel tank, and a fuel pressure relief valve that opens prematurely. Check the High Pressure Connector (HPC) and connector torque, and tighten to specification if necessary. Operate the engine on a chassis dynamometer or conduct a diagnostic road test to duplicate the fault code. Use INSITE™ electronic service tool to log fuel system parameters during testing.

Refer to Troubleshooting Fault Code 559.

Last Modified: 08-Aug-2012


Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It could be wired back to the ECM on some vehicles, or wired to chassis or block ground on others. Refer to the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for exact location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is being energized or de-energized. In some cases the diagnostic could also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code 584.

Last Modified: 08-Aug-2012


Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S039 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at starter lockout circuit. | The engine will not have starter lockout protection.
Starter Lockout Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It could be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Refer to the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM troubleshooting and repair manual for exact location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is being energized or de-energized. In some cases the diagnostics could also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit PWM signal is detected to be greater than 0-VDC when the PWM signal is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The starter lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded on, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Refer to Troubleshooting Fault Code 585.

Last Modified: 08-Aug-2012


Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. High battery voltage detected by the battery voltage monitor feature. | Amber warning lamp illuminated until high battery voltage condition is corrected.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is higher than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use INSITE™ electronic service tool to view the Alternator Failure Warning feature settings. Disable the Alternator Failure Warning feature to disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

  • Overcharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code 596.

Last Modified: 08-Aug-2012


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low battery voltage detected by the battery voltage monitor feature. | Amber lamp will light until low battery voltage condition is corrected.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if Idle Speedup is enabled. Use INSITE™ electronic service tool to view the Alternator Failure Warning feature settings. Disable the Alternator Failure Warning feature to disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
  • High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.
Refer to Troubleshooting Fault Code 597.

Last Modified: 08-Aug-2012


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level. Very low battery voltage detected by the battery voltage monitor feature. | Red lamp illuminated until very low battery voltage condition is corrected.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with each OEM. Refer to the OEM service manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than 8-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle the decrement switch if Idle Speedup is enabled. Use INSITE™ electronic service tool to view the Alternator Failure Warning feature settings. Disable the Alternator Failure Warning feature to disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code 598.

Last Modified: 08-Aug-2012


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Maintenance SRT: | Engine Oil Change Interval - Condition Exists. Change engine oil and filter. | Maintenance reminder only.
Engine Control Module

Circuit Description

The engine control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

For a detailed component location view, refer to the appropriate service manual. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for the location of the oil fill port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Based on the programmable setting in the Maintenance Monitor feature, the ECM detects the engine oil and filter need to be changed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the maintenance condition is exceeded.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the Maintenance Monitor feature has been reset in INSITE™ electronic service tool.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enabled in INSITE™ electronic service tool. Make sure the oil and filter are changed before clearing the fault code.

Refer to Troubleshooting Fault Code 649.

Last Modified: 08-Aug-2012


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: 190 SPN: 190 FMI: 2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Loss of signal from crankshaft sensor. | Engine can run rough. Possibly poor starting capability. Engine runs using backup speed sensor. Engine power is reduced.
Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the crankshaft speed/position sensor for more than 1second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The camshaft speed sensor is used to provide engine speed and position information to the ECM.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid signal from the crankshaft speed/position sensor.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness
  • Damaged or failed engine speed sensor.
Refer to Troubleshooting Fault Code 689.

Last Modified: 08-Aug-2012


ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or an open circuit is detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 697.

Last Modified: 08-Aug-2012


ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or an open circuit is detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 698.

Last Modified: 08-Aug-2012


ECM Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 699

ECM Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 699 PID: SPN: 1136 FMI: 2 LAMP: Amber SRT: | ECM Temperature - Data Erratic, Intermittent, or Incorrect. An incorrect or inconsistent temperature reading has been detected internal to the electronic control module (ECM). | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is irrational.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If this fault code is active, the ECM must be replaced.

Refer to the Troubleshooting Fault Code 699.

Last Modified: 08-Aug-2012


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S064 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment. Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Engine will run derated. Hard start and rough idle is possible.
Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a +5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the lobes on the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used to determine the position of the engine by the ECM.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

Possible causes for this fault code include:

  • Engine speed sensor rings that are loose or not aligned correctly
  • Mechanical misalignment.
Refer to Troubleshooting Fault Code 731.

Last Modified: 08-Aug-2012


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: SPN: 723 FMI: 2 LAMP: Amber SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected a loss of signal from the camshaft position sensor. | Engine can run rough. Possibly poor starting capability. Engine runs using primary engine position sensor.
Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the camshaft speed/position sensor for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid signal from the crankshaft speed/position sensor.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness
  • Damaged or malfunctioning camshaft position sensor.
Refer to Troubleshooting Fault Code 778.

Last Modified: 08-Aug-2012


Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below 6.2 VDC momentarily, or the ECM was not allowed to power down correctly. | Possible no noticeable performance effects, or engine dying, or hard starting. Fault code information, trip information, and maintenance monitor data can be inaccurate.
Engine Control Module

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the original equipment manufacturer (OEM) power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that primary ECM power supply dropped below a calibratible value while the keyswitch was in the ON position or before the ECM had properly powered down. The fault code will be active when the keyswitch is turned on, following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM records the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

To validate the repair, start the engine, let it idle for 1 minute, and shut it down properly. The ECM must see adequate primary ECM battery voltage when the keyswitch is turned OFF before the fault code will go inactive.

For engines equipped with selective catalytic reduction (SCR) aftertreatment:

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

For all other engines:

  • The ECM will turn OFF the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For on-board diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active. Use of battery disconnect switches to turn OFF the engine or any device that disconnects battery voltage to the ECM within 100 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

Before troubleshooting Fault Code 1117, make sure battery post connections, engine block and chassis grounds are properly connected, tightened, and free of corrosion.

Refer to Troubleshooting Fault Code 1117.

Last Modified: 20-Apr-2017


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in power output of the engine. Limp home power only.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5-volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5-volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position 2 signal circuit shorted to battery or 5-VDC supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Damaged accelerator pedal position sensor.

The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1239.

Last Modified: 08-Aug-2012


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: None SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in the power output of the engine. Limp home power only.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and passes.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Damaged accelerator pedal position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1241.

Last Modified: 08-Aug-2012


Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P091 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect. Accelerator position sensor number 1 and number 2 are reading different values. | The engine will only idle.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the readings between accelerator position sensor 1 and accelerator position sensor 2 differ by more than 2 percent.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.

Possible causes of the fault include:

  • Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2
  • Accelerator pedal position sensor number 1 and accelerator pedal position sensor number 2 signal wires are shorted together.
Refer to Troubleshooting Fault Code 1242.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668

Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 PID: P203C SPN: 1761 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank. The aftertreatment diesel exhaust fluid tanks level sensor is a combination sensor with the aftertreatment diesel exhaust fluid temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel exhaust fluid tank level sensor signal voltage dropped below a calibratible value while the keyswitch was in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid tank level sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 1668, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor.
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code 1668.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669

Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 PID: P203D SPN: 1761 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage above normal or shorted to high source. High signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank. The aftertreatment diesel exhaust fluid tank level sensor is a combination sensor with the aftertreatment diesel exhaust fluid temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel exhaust fluid tank level sensor signal voltage is above a calibratible value while the keyswitch was in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

This fault code can not be cleared with INSITE™ electronic service tool.

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid tank level sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 1669, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1669.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1671

Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1671 PID: 203F SPN: 1761 FMI: 18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Moderately Severe Level. Low aftertreatment diesel exhaust fluid level has been detected in the aftertreatment diesel exhaust fluid tank. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The diesel exhaust fluid tank level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The diesel exhaust fluid tank level sensor is located in the diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Low aftertreatment diesel exhaust fluid level has been detected in the diesel exhaust fluid tank.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

Fault code 1671 is triggered when low diesel exhaust fluid level has been detected in the diesel exhaust fluid tank. Add diesel exhaust fluid to the tank. This fault code is only a warning for low diesel exhaust fluid tank solution level.

Refer to Troubleshooting Fault Code 1671.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Most Severe Level

FAULT CODE 1673

Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1673 PID: P203F SPN: 1761 FMI: 1 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid but Below Normal Operating Range - Most Severe Level. No aftertreatment diesel exhaust fluid has been detected in the aftertreatment diesel exhaust fluid tank. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled. Immediate engine power derate.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The diesel exhaust fluid level sensor is located in the diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • The aftertreatment diesel exhaust fluid level sensor has detected that the diesel exhaust fluid tank is empty.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) willl start to flash when the diagnostic runs and fails.
  • An engine torque derate will be activated immediately when the fault code becomes active.

Conditions for Clearing the Fault Code

This fault code can not be cleared with INSITE™ electronic service tool.

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Fault code 1673 is triggered when the diesel exhaust fluid level sensor has detected that the diesel exhaust fluid tank is empty. Diesel exhaust fluid may still be visible inside the tank when this fault code is active. Add diesel exhaust fluid to the tank.

Refer to Troubleshooting Fault Code 1673.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1677

Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1677 PID: P205C SPN: 3031 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank temperature sensor circuit. | Default temperature value used for aftertreatment diesel exhaust fluid tank temperature.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the aftertreatment diesel exhaust fluid inside the diesel exhaust fluid tank. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The aftertreatment diesel exhaust fluid temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • The ECM detects that the aftertreatment diesel exhaust fluid tank temperature sensor signal voltage dropped below a calibratible value while the keyswitch was in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 1677, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 1677.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 1678

Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1678 PID: P205D SPN: 3031 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid tank temperature sensor circuit. | Default temperature value used for aftertreatment diesel exhaust fluid tank temperature.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the aftertreatment diesel exhaust fluid inside the diesel exhaust fluid tank. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The aftertreatment diesel exhaust fluid temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • The ECM detects that the aftertreatment diesel exhaust fluid tank temperature sensor signal voltage is above a calibratible value when the keyswitch is in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The aftertreatment diesel exhaust fluid temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 1678.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1679

Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1679 PID: SPN: 3031 FMI: 2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid tank temperature sensor has indicated a tank temperature too high or too low for the ambient conditions. | Default temperature value used for catalyst solution temperature.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the aftertreatment diesel exhaust fluid inside the diesel exhaust fluid tank. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The aftertreatment diesel exhaust fluid temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs at initial key on and continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel exhaust fluid tank temperature does not match the ambient temperature sensor reading at initial key-on, or the tank temperature does not increase after an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • In-range failure of the diesel exhaust fluid tank temperature
  • Damaged wiring harness
  • Failed aftertreatment diesel exhaust fluid controller.
Refer to Troubleshooting Fault Code 1679.

Last Modified: 08-Aug-2012


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

FAULT CODE 1682

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1682 PID: SPN: 3362 FMI: 31 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists. The aftertreatment diesel exhaust fluid dosing unit is unable to prime. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

For an air assisted selective catalytic reduction (SCR) aftertreatment system, the aftertreatment diesel exhaust fluid (DEF) dosing unit requires air pressure from the original equipment manufacturer (OEM) air tanks or a stand-alone air pump. The DEF dosing unit precisely measures the amount of DEF to be injected into the aftertreatment system. The DEF dosing unit has three primary cycles. A priming cycle at initial engine start makes sure that DEF is available at the DEF dosing unit. During the dosing cycle, the DEF is being delivered to the aftertreatment nozzle. A purge cycle occurs when the engine is turned OFF. The purge cycle makes sure that all the DEF is removed from the DEF line and the aftertreatment nozzle.

Component Location

The aftertreatment DEF dosing unit is located on top of the DEF tank. The DEF tank location is OEM dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs during the aftertreatment DEF dosing unit priming phase after the engine is started and the aftertreatment system is ready to dose.

Conditions for Setting the Fault Codes

The aftertreatment DEF dosing unit has been unable to successfully prime itself after a calibrated amount of time and after multiple attempts.

Action Taken When the Fault Code is Active

  • The engine control module (ECM) illuminates the amber CHECK ENGINE lamp and the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • Engine torque will be derated to 60% after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, use INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Dosing Unit Override Test" under the "ECM Diagnostics Test" menu in INSITE™ electronic service tool. Refer to Procedure 011-063 in Section 11.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL immediately after the diagnostic runs and passes.
  • Inactive faults will be cleared from memory after 9600 hours of engine operations without reoccurence.

Shop Talk

The DEF dosing unit process consists of three phases that occur in the following sequence: Priming, dosing, and purging.

Priming:

  • The DEF dosing unit will attempt to prime when the engine has been operating for 5 minutes or when the average SCR temperature reaches 180°C [356°F].
  • The DEF dosing unit will attempt to prime every 140 seconds for 3 attempts.
  • The DEF dosing unit can take up to 10 minutes to complete the priming cycle before a fault code will become active
  • During priming, the dosing unit will pump DEF through the supply lines and into the DEF dosing unit.
  • If priming is not successful, the DEF dosing unit will be purged, disabled, and Fault Code 1682 will be activated.

Dosing:

  • Immediately after successful priming the system will enter dosing mode. At this point, the air solenoid will click once and a constant flow of air will flow through the aftertreatment nozzle, which helps transport the DEF and keep the aftertreatment nozzle clear.
  • The air flow will remain constant until the system reaches all dosing conditions before DEF is delivered to the aftertreatment system (catalyst temperature greater than 200°C [392°F], engine speed and load conditions met, etc.)

Purging:

  • After the engine is stopped and the keyswitch is turned OFF, the dosing unit enters the purging cycle, which clears any DEF left in the line and the aftertreatment nozzle after operation.
  • Purging consists of flowing compressed air through the aftertreatment nozzle, DEF dosing module, and all DEF lines for 30 seconds. If the full purge time is not completed, it is possible to leave DEF in the line, leading to a building up of hard urea crystals, resulting in a blocked DEF line or aftertreatment nozzle.
  • If the vehicle is equipped with a battery isolation switch, it should have a built-in delay device to prevent power down of the dosing unit until the purge sequence is complete.

Possible causes of this fault code include:

  • Low aftertreatment DEF level in the DEF tank
  • Blocked or restricted aftertreatment nozzle
  • Blocked, restricted, kinked, broken, disconnected or frozen DEF supply lines
  • Plugged or restricted in-tank DEF filter
  • Plugged or restricted DEF dosing unit filter
  • Missing DEF dosing unit damping element
  • Interchanged 12-VDC and 24-VDC DEF dosing unit
  • Open circuit in the wiring harness
  • Open circuit in the pump motor SIGNAL wire
  • Open circuit in the pump motor power wire.
Refer to Troubleshooting Fault Code t05-1682.

Last Modified: 03-Jun-2013


Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

FAULT CODE 1683

Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1683 PID: P202C SPN: 3363 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid tank heater relay sensor circuit. | High signal voltage detected at the aftertreatment diesel exhaust fluid tank heater relay sensor circuit.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The heating element is powered by the diesel exhaust fluid tank heater relay.

Component Location

The diesel exhaust fluid tank heater is located in the diesel exhaust fluid tank. The location of the diesel exhaust fluid tank heater relays will vary by OEM. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Circuit error between the ECM and the diesel exhaust fluid tank heater relay has been detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the MIL immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code can not detect any circuit failures on the heater side of the relay. Only circuit errors between the ECM and the relay can be detected by this fault code.

Possible causes of this fault code include:

  • Diesel exhaust fluid tank heater relay signal wire not connected to the relay
  • Diesel exhaust fluid tank heater relay return wire not connected to the relay
  • Malfunctioning diesel exhaust fluid tank heater relay
  • Open circuit in the diesel exhaust fluid tank heater relay signal wire
  • Open circuit in the diesel exhaust fluid tank heater relay return wire
  • Diesel exhaust fluid tank heater signal wire shorted to a voltage source.
Refer to Troubleshooting Fault Code 1683.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1684

Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1684 PID: P205B SPN: 3363 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank heater relay sensor circuit. | The aftertreatment diesel exhaust fluid tank heater will be disabled.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank, and will also thaw a frozen diesel exhaust fluid tank. The heating element is powered by the diesel exhaust fluid tank heater relay.

Component Location

The aftertreatment diesel exhaust fluid tank heater is located in the aftertreatment diesel exhaust fluid tank. The location of the aftertreatment diesel exhaust fluid tank heater relays will vary by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

A circuit error has been detected between the ECM and the diesel exhaust fluid tank heater relay.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code cannot detect any circuit failures on the heater side of the relay. Only circuit errors between the ECM and the relay can be detected by this fault code.

Possible causes of this fault code include:

  • A shorted aftertreatment diesel exhaust fluid tank heater relay
  • Aftertreatment diesel exhaust fluid tank heater signal wire shorted to ground.
Refer to Troubleshooting Fault Code 1684.

Last Modified: 08-Aug-2012


Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1694

Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1694 PID: P2201 SPN: 3226 FMI: 2 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect. An incorrect NOx sensor reading has been detected by the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor operation will be disabled. Engine torque will be reduced.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The Aftertreatment Outlet NOx Sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs only under certain engine operating conditions. Refer to the troubleshooting tree for details on running the diagnostic.

Conditions for Setting the Fault Codes

The ECM has detected that the NOx reading is higher or lower than is possible from the engine output.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails on two consecutive ignition cycles.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • The ECM has detected that the NOx reading is higher or lower than is possible from the engine output.
  • Exhaust system leaks.
  • An incorrectly installed aftertreatment outlet NOx sensor.
  • An aftertreatment outlet NOx sensor that has carbon buildup on the tip of the sensor.
  • Excessive oil consumption.
  • Possible engine misfire.
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code 1694.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1712

Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1712 PID: SPN: 3363 FMI: 18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid but Below Normal Operating Range - Moderately Severe Level. The aftertreatment diesel exhaust fluid tank heater is unable to thaw the frozen diesel exhaust fluid. | None on performance. Diesel exhaust fluid injection into the aftertreatment system may be disabled if the aftertreatment diesel exhaust fluid is frozen.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the vehicle OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater has been on long enough to thaw the diesel exhaust fluid, but the SCR dosing system is still not able to prime.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diesel exhaust fluid tank heater is able to successfully thaw the diesel exhaust fluid tank and the diagnostic runs and passes. If a thawing cycle can not be completed, make sure the diesel exhaust fluid tank heater control valve is operating correctly by using the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck closed
  • Blockage or restricitons in the coolant plumbing to the diesel exhaust fluid tank heater
  • Engine coolant level low
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • Malfunctioning aftertreatment diesel exhaust fluid controller is unable to command tank heating.
Refer to Troubleshooting Fault Code 1712.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1713

Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1713 PID: SPN: 3363 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid tank heater is continuously in the ON position. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve that controls the flow of engine coolant to a heating coil inside the diesel exhaust tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and then closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary, depending on the vehicle OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater is determined to be in the ON position when the ECM is commanding the heater to be in the OFF position. This is done by detecting when the DEF tank temperature is equal to or greater than the fault code threshold value of 77°C [170°F].

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Before troubleshooting this fault code, make sure the vehicle is not equipped with an auxiliary heating device for the diesel exhaust fluid tank. Such a device can result in overheating the diesel exhaust fluid in the tank.

This fault code may be inactive when the vehicle is brought in for service. Even if inactive, follow the troubleshooting tree completely.

  • Reason: If there is a problem with the diesel exhaust fluid (DEF) tank heater control valve, the valve is stuck open, there is coolant leaking past the valve seat, or the valve is incorrectly installed, it can take long periods of operation at high load before the diesel exhaust fluid (DEF) tank temperature gradually increases to the fault code threshold value of 77°C [170°F]. As soon as the DEF temperature drops below 75°C [167°F] due to a stopped engine, overnight parking, reduced coolant temperature, and so forth, the fault code will go inactive while the root cause of the issue is still present.

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck open
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve - stuck open or leakage past the valve seat.
  • Malfunctioning aftertreatment diesel exhaust fluid controller is continuously commanding tank heating.
Refer to Troubleshooting Fault Code 1713.

Last Modified: 08-Aug-2012


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: SPN: 97 FMI: 16 LAMP: Amber SRT: | Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level. The Water-In-Fuel Indicator indicates that the water level is above warning level. | None on performance.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The water-in-fuel sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires, a ground wire and a signal wire.

Component Location

The water-in-fuel sensor is integrated into the bottom of the fuel filter. The filter housing location will vary with each original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Water has been detected in the fuel filter housing above the warning limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Water in the fuel can do extensive damage to the fuel system due to the tight tolerances of fuel system components.

It must be drained immediately.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water-In-Fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1852.

Last Modified: 05-Sep-2012


Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1887

Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1887 PID: P2202 SPN: 3226 FMI: 4 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment outlet NOx sensor. | Engine may not start.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature at the aftertreatment intake NOx sensor is above 150°C [302°F] and the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error has been detected by in the aftertreatment outlet NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • The voltage supplied to the aftertreatment outlet NOx sensor is below + 18-VDC
  • The voltage supplied to the aftertreatment outlet NOx sensor is above + 32-VDC
  • The aftertreatment outlet NOx sensor has malfunctioned or is damaged
  • The aftertreatment outlet NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code t05-1887.

Last Modified: 08-Aug-2012


Injector Metering Rail 1 Pressure Circuit - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 1911

Injector Metering Rail 1 Pressure Circuit - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1911 PID: P157 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure in the rail fuel is higher than the commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load) or possible power interruption associated with dump valve reset.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed on the high-pressure fuel pump. The high-pressure relief valve is located on the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM has detected that the measured fuel rail pressure is above the commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

In normal engine operation, the ECM calibration varies the flow commanded to the fuel pump actuator to achieve the correct fuel rail pressure. System failures that cause loss of pressure control can cause the fuel rail pressure relief valve to open. The fuel rail pressure relief valve acts to protect the high-pressure components from over-pressurization. If the ECM detects that the fuel rail pressure relief valve is open without detection of a fuel pump actuator circuit error, Fault Code 1911 will become active. On certain applications, the ECM will attempt to reset automatically causing a momentary loss of power for less than 1 second.

Conditions that can cause Fault Code 1911:

  • Purging air through the fuel system can cause a pressure overshoot, therefore causing Fault Code 1911 to log. A few bubbles exiting the line during the air in fuel test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry should be isolated to one of the following: Suction fuel lines, OEM fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).
  • Sustained periods of very low pressure under load followed by pressure recovery overshoot. This can be caused by high restriction due to plugged filters (Fault Code 559).
  • A tampered fuel pressure sensor that reads low, a biased pressure sensor, or a poor electrical connection.
  • If an intermittent electrical circuit problem with the fuel pump actuator circuit exists, it is possible for Fault Code 1911 to become active, then inactive, during normal engine operation. ECM Fault Code 2311 is designed to detect electrical circuit issues with the actuator. Therefore, it is only necessary to inspect for bad connectors or harness issues for Fault Code 1911 if no other fault codes exist. A fuel pump actuator with excessive leakage will result in high rail fuel pressures at idle or light load.
  • Other conditions include ECM wiring harness issues such as poor grounds, battery voltage spikes, electrical noise, low alternator output, and large disturbances of battery voltage, as when jump-starting the vehicle.
  • The fuel rail pressure sensor should also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero on some engines. In such cases, it may be necessary to manually relieve the pressure from the high-pressure fuel rail.
Refer to Troubleshooting Fault Code 1911.

Last Modified: 08-Aug-2012


Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2182

Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2182 PID: P0478 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage or an open circuit detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinders 1, 2, and 3 can not be activated.
Engine Brake Solenoid Signal Circuit

Circuit Description

This circuit can be used to control either an exhaust brake or an engine brake depending on the application. The engine control module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 1 circuit pulse width modulated signal is detected to be greater than 0 volts when the pulse width modulated signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illumines the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes of this fault code include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Short to voltage source in the engine harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 2182.

Last Modified: 08-Aug-2012


Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2183

Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2183 PID: PO477 SPN: 1072 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinders 1, 2, and 3 can not be activated.
Engine Brake Solenoid Signal Circuit

Circuit Description

This circuit can be used to control either an exhaust brake or an engine brake depending on the application. The engine control module (ECM) controls engine brakes on cylinders 1, 2, and 3, by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the pulse width modulated device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 1 circuit pulse width modulated signal is not detected to be system voltage when the pulse width modulated signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes of this fault code include a short circuit to ground in the engine harness, connector, or engine brake solenoids.

Refer to Troubleshooting Fault Code 2183.

Last Modified: 08-Aug-2012


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at 5 volt sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 volt supply to the accelerator pedal position sensor. The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the ECM as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal assembly is located in the cab. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 4 signal voltage is more than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and malfunction indicator lamp (MIL) can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Refer to Troubleshooting Fault Code 2185.

Last Modified: 08-Aug-2012


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the 5 volt sensor supply circuit to the accelerator pedal position sensor. | Engine will only die.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 volt supply to the accelerator pedal position sensor. The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the ECM as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal is located in the cab. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 4 signal voltage is less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will only die.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and the MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 2186.

Last Modified: 08-Aug-2012


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: S126 SPN: 1075 FMI: 3 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source. High voltage or open detected at the fuel lift pump signal circuit. | Engine can be difficult to start.
Electric Fuel Lift Pump Circuit

Circuit Description

The fuel lift pump circuit is a discrete output in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The electric fuel lift pump is located behind the ECM cooling plate on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the lift pump timer has expired 1 minute after intial key ON.

Conditions for Setting the Fault Codes

The engine fuel lift pump signal circuit is detected to be greater than 0-VDC when the signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine fuel lift pump will be disabled.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault becomes active if the ECM detects an open circuit at key ON. Causes of this fault code include an open circuit in the electric fuel lift pump circuit.

If the fault code is intermittent, look for causes of an intermittent open circuit, such as loose pins and bad connections. This fault code can detect open circuit conditions only at key ON. The lift pump only runs at key ON and during cranking to aid in priming of the fuel pump gear pump.

The lift pump will run continuously if shorted to battery power. If the lift pump runs continuously, check for aftermarket modifications and wiring to the lift pump.

Refer to Troubleshooting Fault Code t05-2265.

Last Modified: 08-Aug-2012


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: S126 SPN: 1075 FMI: 4 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel lift pump circuit. | Engine can be difficult to start.
Electric Fuel Lift Pump Circuit

Circuit Description

The fuel lift pump circuit is a discrete output in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The electric fuel lift pump is located behind the ECM cooling plate on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs during the first minute after initial key ON, when the fuel lift pump is being commanded to run.

Conditions for Setting the Fault Codes

The engine fuel lift pump signal circuit is detected to be 0-VDC when the signal is turned on by the ECM and must be at system voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine fuel lift pump will be disabled.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the keyswitch in the ON position for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code becomes active whenever the ECM detects a short circuit to ground or high current in the electric fuel lift pump circuit. Causes for this fault code are a short circuit to ground or low resistance (lift pump partially shorted). During cold weather, gelled fuel can plug the lift pump and cause this fault code. Listen to the lift pump to be sure it is running during cold ambient temperatures (less than -29°C [-20°F]). This fault code can possibly also become active if the lift pump rotor stalls or seizes. When the fault condition is detected, the ECM driver to the lift pump is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test for the cause of the fault code. The ECM driver is enabled at key ON. If the cause if no longer present, the fault code will become inactive and can be cleared.

Refer to Troubleshooting Fault Code t05-2266.

Last Modified: 08-Aug-2012


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S018 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. The fuel pump actuator circuit resistance is too high or too low, or an intermittent connection has been detected. | The engine will run rough with low power.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse width modulated driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the high-pressure pump, based on engine operating conditions. The fuel pump actuator valve is a normally open valve. High circuit resistance can cause fuel pressure to be higher than commanded at light loads.

Component Location

The fuel pump actuator valve is located on the engine-mounted fuel pump housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault is set when the fuel pump actuator circuit has intermittent circuit problems, or the fuel pump actuator resistance it too high or low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

If this fault code occurs during a road test, verify that all connectors are clean and free of corrosion before replacing components.

This fault code can become active for any of the following reasons:

  • Fuel pump actuator high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins at the fuel pump actuator or ECM connectors
  • Fuel pump actuator with low internal resistance
  • Fuel pump actuator or engine harness that has shorted to ground
  • Intermittent circuit malfunctions that cause the fuel pressure to exceed the fuel rail pressure relief valve opening pressure.

If an intermittent electrical circuit problem of the fuel pump actuator circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty, causing the fuel rail pressure relief valve to open. Following the event that caused the fuel rail pressure relief valve to open, the ECM will attempt to reset the fuel rail pressure relief valve, provided the fuel pump actuator circuit is not still faulty.

Refer to Troubleshooting Fault Code t05-2311.

Last Modified: 08-Aug-2012


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2/2 LAMP: None SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Crankshaft engine speed sensor intermittent synchronization. | The engine can exhibit misfire as control switches from the primary to the backup speed sensor. Engine power is reduced while the engine operates on the backup speed sensor.
Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position based on the missing tooth on the speed indicator ring.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects an intermittent or degraded signal from the crankshaft speed/position sensor over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the degraded signal from the crankshaft speed/position sensor is no longer present and the diagnostic runs and passes.

Shop Talk

During engine operation, the ECM monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp if the signal from the primary speed sensor is not present or degraded for more than 3 continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than 3 seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. Engine power will be reduced while the injection events are based on the backup speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

A vehicle operator can notice an intermittent “misfire” if the injection events are interrupted while the ECM switches from control based on the primary and secondary speed sensors. Also, a vehicle operator can notice intermittent “low power” if a “glitch” in the primary speed sensor signal causes the engine to intermittently use the backup speed sensor for injection control.

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

This fault becomes inactive at each key-on or if the ECM does not detect a loss of the primary engine speed sensor signal for at least 20 minutes.

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.
  • Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the primary engine speed sensor circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2321.

Last Modified: 08-Aug-2012


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S064 SPN: 723 FMI: 2/2 LAMP: None SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. Camshaft engine speed sensor intermittent synchronization. | None on performance.
Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects an intermittent loss of the camshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the ECM detects a valid signal from the camshaft speed/position sensor.
  • This fault code can also be cleared with INSITE™ electronic service tool.

The ECM will set the fault code inactive after the ECM detects a valid signal from the camshaft speed/position sensor.

Shop Talk

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active and light the yellow lamp if the signal from the secondary speed sensor is not present or degraded for more than 3 continuous seconds. If over a period of time the ECM detects several incidents of a loss of the secondary speed sensor signal, but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator could possibly not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

This fault becomes inactive at each key ON or if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 20 minutes.

Problems that can cause this fault:

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems
  • Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the secondary engine speed sensor circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2322.

Last Modified: 08-Aug-2012


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2363

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S029 SPN: 1073 FMI: 4 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brake on cylinders 4, 5, and 6 can not be activated.
Engine Brake Solenoid Signal Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. A 2-pin Weather Pack™ connector is located near the number 3 injector pass-through connector at the back of the engine. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 2 circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the vehicle so that the engine brakes are activated. This will allow the diagnostics to run and pass.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes, or at the next key cycle.
  • This fault code can also be cleared with the INSITE electronic service tool.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an active or inactive fault code.

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness, connectors, or engine brake solenoids
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2363.

Last Modified: 08-Aug-2012


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2367

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S80 SPN: 1073 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brake on cylinders 4, 5, and 6 can not be activated.
Engine Brake Solenoid Signal Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. A 2-pin Weather Pack connector is located near the number 3 injector pass-through connector at the back of the engine. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is being energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 2 circuit PWM signal is detected to be system voltage when the PWM signal is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake solenoid 2 can not be energized.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the vehicle so that the engine brakes are ativated. This will allow the diagnostics to run and pass.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes, or at the next key cycle.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an active or inactive fault code.

Possible causes of this fault code include:

  • An open circuit in the engine harness, brake harness, or engine brake solenoids
  • A short to voltage source in the engine harness
  • A damaged ECM.
Refer to Troubleshooting Fault Code t05-2367.

Last Modified: 08-Aug-2012


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S033 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan could stay on continuously or not run at all.
Fan Clutch Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A pulse width modulated (PWM) signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. Use INSITE™ electronic service tool to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or goes to the engine block or chassis ground.

Component Location

The fan clutch solenoid location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan pulse width modulated (PWM) signal is less than 100 percent and will latch active when the fan pulse width modulated (PWM) signal is 100 percent.

Conditions for Setting the Fault Codes

The fan control circuit PWM signal is detected to be greater than 0-VDC when the pulse width modulated (PWM) signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

For ON/OFF and variable speed fan, the diagnostic will clear when the fan is turned off and the diagnostic runs and passes. For all other fan types, the diagnostic will clear when the fan pulse width modulated (PWM) signal is less than 100 percent.

Shop Talk

Possible causes of this fault include:

  • An open circuit in the engine harness or fan control solenoid
  • A short circuit to voltage source in the OEM harness
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2377.

Last Modified: 08-Aug-2012


Coolant Level - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: P2560 SPN: 111 FMI: 17 LAMP: Maintenance SRT: | Coolant Level - Data Valid but Below Normal Operating Range - Least Severe Level. Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is in operation.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limits.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light at initial key ON for 30 seconds when low engine coolant level has been detected.

Conditions for Clearing the Fault Code

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant. The ECM will stop flashing the amber CHECK ENGINE light at key ON when coolant has been added to the engine.

Shop Talk

Not Applicable

Refer to Troubleshooting Fault Code t05-2448.

Last Modified: 08-Aug-2012


Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2555

Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2555 PID: SPN: 729 FMI: 3 LAMP: Amber SRT: | Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the intake air heater signal circuit. | The intake air heaters can be ON or OFF all the time.
Intake Air Heater Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions.

The electronic control module (ECM) controls relays that switch power to the intake air heater. Air heaters on 12 volt systems will have two relays; 24 volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection to the intake manifold. The location of the intake air heater relays will vary by vehicle and engine configuration.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is activated. In some cases, the diagnostic can also run at certain fixed intervals.

Conditions for Setting the Fault Codes

The intake air heater circuit pulse width modulated (PWM) signal is detected to be greater than 0-VDC when the pulse width modulated (PWM) signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The intake air heater operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Intake air heater relay signal wire not connected to the relay
  • Intake air heater relay return wire not connected to the relay
  • Open circuit in the intake air heater relay signal wire
  • Open circuit in the intake air heater relay return wire
  • Intake air heater signal wire shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-2555.

Last Modified: 08-Aug-2012


Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2556

Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2556 PID: SPN: 729 FMI: 4 LAMP: Amber SRT: | Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the intake air heater signal circuit. | The intake air heaters can be ON or OFF all the time.
Intake Air Heater Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions.

The engine control module (ECM) controls relays that switch power to the intake air heater. Air heaters on 12 volt systems will have two relays and 24 volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection to the intake manifold. The location of the intake air heater relays will vary by vehicle and engine configuration.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is activated. In some cases, the diagnostic can also run at certain fixed intervals.

Conditions for Setting the Fault Codes

The intake air heater circuit pulse width modulated (PWM) signal is not detected to be system voltage when the pulse width modulated (PWM) signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The intake air heater circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • A shorted intake air heater relay
  • Intake air heater relay supply wire shorted to ground.
Refer to Troubleshooting Fault Code t05-2556.

Last Modified: 08-Aug-2012


Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

FAULT CODE 2771

Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2771 PID: SPN: 3226 FMI: 9 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Abnormal Update Rate. No communications or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor operation will be disabled.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine ECM via the J1939 data link. The aftertreatment outlet NOx sensor receives power and a ground directly from the battery. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment SCR catalyst. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM loses J1939 communications with the aftertreatment outlet NOx sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9600 hours of engine operation without a re-occurance.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment outlet NOx sensor is not receiving power from the battery supply circuit in the OEM harness. This could be caused by an open circuit in the power supply wire, blown NOx sensor fuse, or low voltage supplied by the battery.
  • Open return circuit on the Aftertreatment Outlet NOx Sensor battery return.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment outlet NOx sensor.
  • Intermittent communications between the aftertreatment outlet NOx sensor and the primary engine ECM on the J1939 data link.
  • A damaged engine ECM.
Refer to Troubleshooting Fault Code 2771.

Last Modified: 08-Aug-2012


Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2772

Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2772 PID: SPN: 3226 FMI: 15 LAMP: Amber SRT: | Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level. The engine NOx output is higher than recommended levels. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device that communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor receives power and a ground directly from the battery. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The aftertreatment outlet NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system, at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete. The NOx sensor gathers data over varying engine speeds and loads. When enough data has been gathered, the diagnostic will run, make a pass/fail decision, and begin to gather data again.

Conditions for Setting the Fault Codes

This fault code is triggered when the diagnostic detects that the NOx output is higher than a calibratible value for two consecutive ignition cycles.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL).

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool. It is necessary to drive or operate the vehicle on a chassis dynamometer in order to validate the repair and for the fault code to go inactive.
  • Connect INSITE™ electronic service tool, and start the "Aftertreatment High NOx Reset" test from the "ECM Diagnostic Tests" screen. Operate the vehicle per the instructions on the screen. If the completion status of the NOx reset test slows or stops advancing, vary the engine speed and load until the NOx reset test completes data collection and a decision is made. See below for additional tips to assist in operating the diagnostic.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9600 hours of engine operation without a re-occurrence.

Tips for conducting the diagnostic:

  • Aftertreatment selective catalytic reduction (SCR) catalyst intake and outlet temperatures should be above 240°C [464°F].
  • Load the engine by operating at approximately 1000 rpm while in high gear.
  • Apply the throttle at greater than 60 percent to allow the dosing percentage to be over 100 percent.
  • Vary the engine speed between 1000 and 1500 rpm.
  • Try to achieve a dosing value of just over 100 percent with as little throttle as possible.

Shop Talk

Possible causes of this fault code include:

  • Diesel exhaust fluid quality is not within specification
  • External leaks in the diesel exhaust fluid dosing unit and/or diesel exhaust fluid lines
  • Aftertreatment nozzle has malfunctioned
  • Aftertreatment diesel exhaust fluid dosing unit has malfunctioned or become damaged
  • Sulfur content of the diesel fuel is too high, fouling the SCR catalyst and resulting in high NOx output
  • Aftertreatment nozzle is partially or completely plugged.
Refer to Troubleshooting Fault Code 2772.

Last Modified: 08-Aug-2012


Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 2773

Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2773 PID: SPN: 3226 FMI: 0 LAMP: Amber SRT: | Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level. The engine NOx output is higher than recommended levels. | Aftertreatment outlet NOx sensor operation will be disabled. Engine will derate the next time the vehicle is at zero vehicle speed.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor receives power and a ground directly from the battery. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The aftertreatment outlet NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete. The NOx sensor gathers data over varying engine speeds and loads. When enough data has been gathered, the diagnostic will run, make a pass/fail decision, and begin to gather data again.

Conditions for Setting the Fault Codes

This fault code is triggered when the diagnostic detects that the NOx output is higher than a calibratible value for two consecutive ignition cycles.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and/or the malfunction indicator lamp (MIL).
  • An engine torque derate will be activated immediately when the fault code becomes active.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool. It is necessary to drive or operate the vehicle on a chassis dynamometer in order to validate the repair and for the fault code to go inactive.
  • Connect INSITE™ electronic service tool, and start the "Aftertreatment High NOx Reset" test from the "ECM Diagnostic Tests" screen. Operate the vehicle per the instructions on the screen. If the completion status of the NOx reset test slows or stops advancing, vary the engine speed and load until the NOx reset test completes data collection and a decision is made. See below for additional tips to assist in operating the diagnostic:
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory after 9600 hours of engine operation without a re-occrance.

Tips for running the diagnostic:

  • Load the engine by operating at approximately 1000 rpm while in high gear.
  • Apply the throttle at greater than 60 percent to allow the dosing percentage to be over 100 percent.
  • Vary the engine speed between 1000 and 1500 rpm.
  • Try to achieve a dosing value of just over 100 percent with as little throttle as possible.

Shop Talk

Possible causes of this fault code include:

  • Diesel exhaust fluid quality is not within specification
  • External leaks in the diesel exhaust fluid dosing unit and/or diesel exhaust fluid lines
  • Sulfur content of the diesel fuel is too high, fouling the SCR catalyst and resulting in high NOx content
  • Aftertreatment nozzle has malfunctioned
  • Aftertreatment diesel exhaust fluid dosing unit has malfunctioned or become damaged
  • Aftertreatment nozzle is partially or completely plugged
  • Aftertreatment SCR catalyst is damaged or missing.
Refer to Troubleshooting Fault Code 2773.

Last Modified: 08-Aug-2012


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. Engine coolant temperature is above the engine coolant temperature engine protection warning limit. | Power derate and possible engine shutdown if the engine protection shutdown feature is enabled.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and for engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it idle for 1 minute.

The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE and the torque derate will be removed immediately after the engine coolant temperature drops below a calibratible limit set in the ECM and the diagnostic runs and passes.

The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code t05-2963.

Last Modified: 08-Aug-2012


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

When the intake air is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

This fault code indicates that the intake manifold temperature has exceeded the maximum engine protection limit.

Component Location

The intake manifold 1 temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

The maximum torque output of the engine will return and the fault code will go inactive after the intake manifold temperature drops below a calibratible limit set in the ECM.

The ECM will turn off the amber CHECK ENGINE light and the fault code will go inactive immediately after the diagnostic runs and passes.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Plugged charge air cooler fins
  • Restricted airflow through the charge air cooler
  • An undersized charge air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-2964.

Last Modified: 08-Aug-2012


Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3142

Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3142 PID: SPN: 4360 FMI: 3 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the SCR intake temperature sensor circuit. | Default temperature value used for SCR intake temperature.
Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The SCR intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the turbocharger outlet and the intake of the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the SCR intake temperature sensor signal voltage is above a calibratible value when the keyswitch is in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • A default value for the aftertreatment SCR intake temperature is used.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The SCR intake temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 3142.

Last Modified: 08-Aug-2012


Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3143

Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3143 PID: SPN: 4360 FMI: 4 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the SCR intake temperature sensor circuit. | Default temperature value used for SCR intake temperature.
Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The SCR intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the exhaust aftertreatment system. It is located between the turbocharger outlet and the intake of the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the SCR intake temperature sensor signal voltage is below a calibratible value when the keyswitch is in the ON position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • A default value for the aftertreatment SCR intake temperature is used.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The SCR intake temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 3143.

Last Modified: 08-Aug-2012


Aftertreatment SCR Intake Temperature - Data Erratic, Intermiitent, or Incorrect

FAULT CODE 3144

Aftertreatment SCR Intake Temperature - Data Erratic, Intermiitent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3144 PID: SPN: 4360 FMI: 2 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature - Data Erratic, Intermiitent, or Incorrect.. The SCR intake temperature sensor is not changing with engine operating conditions. | Default temperature value used for SCR intake temperature.
Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The SCR intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the exhaust aftertreatment system. It is located between the turbocharger outlet and the intake of the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

  • This diagnostic runs when the exhaust gas temperature sensors are compared to other engine temperatures during engine operation. The engine coolant temperature must be above 60°C [140°F] before the diagnostic will run.

Conditions for Setting the Fault Codes

  • This fault code is logged if the value of the SCR catalyst intake temperature sensor does not match the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • A default value for the aftertreatment SCR intake temperature is used.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range SCR intake temperature sensor
  • High resistance in the SCR intake temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code 3144.

Last Modified: 08-Aug-2012


Aftertreatment SCR Intake Temperature Sensor Swapped - Out of Calibration

FAULT CODE 3163

Aftertreatment SCR Intake Temperature Sensor Swapped - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3163 PID: SPN: 4360 FMI: 13 LAMP: Amber SRT: | Aftertreatment SCR Intake Temperature Sensor Swapped - Out of Calibration. The SCR intake and outlet temperature sensor connections are swapped. | Diesel exhaust fluid injection into the SCR aftertreatment system is disabled.
Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The SCR temperature sensors are used to monitor the temperatures of the exhaust gas entering and exiting the SCR catalyst.

Component Location

The SCR intake and outlet exhaust temperature sensors are located in the aftertreatment system. The intake temperature sensor is located before the SCR catalyst and the outlet temperature sensor is located at the outlet of the SCR catalyst.

Conditions for Running the Diagnostics

The engine must be turned off for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The ECM determines that the temperature readings from the SCR intake and outlet temperature sensors are swapped.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the off position for a period of 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute to run the diagnostic.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • This fault code can also be cleared with INSITE ™electronic service tool.

Shop Talk

Both intake and outlet exhaust gas temperature sensors have the same part number, so it is possible to get the sensors connected incorrectly to the engine harness. The most likely cause of this fault code is that the SCR intake and outlet temperature sensor connectors are swapped at the engine harness. Disconnect the intake and outlet temperature sensors from the engine harness and swap the connectors. The catalyst temperature sensors must be reading ambient temperature and the engine must be off for a period of eight hours before this diagnostic will run.

Refer to Troubleshooting Fault Code 3163.

Last Modified: 05-Sep-2012


Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3164

Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3164 PID: SPN: 4360 FMI: 15 LAMP: None SRT: | Aftertreatment SCR Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. High selective catalytic reduction (SCR) intake temperature has been detected. | Possible engine derate.
Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The SCR intake temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the temperature at the SCR catalyst intake is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the MIL after three consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with INSITE™ electronic service tool.

Shop Talk

This fault code is triggered when the temperature at the SCR intake exceeds the maximum allowable temperature for a given engine rating.

Refer to Troubleshooting Fault Code t05-3164.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3242

Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3242 PID: SPN: 3363 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment. The aftertreatment diesel exhaust fluid temperature did not increase when the aftertreatment diesel exhaust fluid tank heater was commanded on. | None on performance. Diesel exhaust fluid injection into the aftertreatment system will be disabled if the aftertreatment diesel exhaust fluid is frozen.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the vehicle original equipment manufacturer (OEM). The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a short time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater is commanded on by the engine electronic control module (ECM), but no corresponding temperature increase in the aftertreatment diesel exhaust fluid tank temperature was recorded by the tank temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, the system must start a diesel exhaust fluid tank heating cycle and see an initial temperature rise in the diesel exhaust fluid tank.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a re-occurrence.

Shop Talk

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck closed
  • Blockage or restricitons in the coolant plumbing to the diesel exhaust fluid tank heater
  • Engine coolant level low
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • Malfunctioning aftertreatment diesel exhaust fluid controller is unable to command tank heating.
Refer to Troubleshooting Fault Code 3242.

Last Modified: 08-Aug-2012


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

FAULT CODE 3326

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3326 PID: SPN: 91 FMI: 9 LAMP: Red SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate. The enigne control module (ECM) expected information from a multiplexed accelerator pedal or lever sensor but did not receive it soon enough or did not receive it at all. | Engine will only idle.
Engine Control Module

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine ECM directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from OEM VECU's or transmission ECU's are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from the multiplexed accelerator pedal or lever sensor for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, bad OEM VECU or malfunctioning Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.
  • It is possible to use INSITE™ electronic service tool to monitor multiplexed components.
Refer to Troubleshooting Fault Code t05-3326.

Last Modified: 08-Aug-2012


Real Time Clock - Abnormal Rate of Change

FAULT CODE 3492

Real Time Clock - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3492 PID: SPN: 251 FMI: 10 LAMP: Amber SRT: | Real Time Clock - Abnormal Rate of Change. The real time clock indicates a stuck engine off timer. | None on performance.
Engine Control Module

Circuit Description

The real-time clock consists of a timing chip internal to the engine control module (ECM) which monitors engine off time, i.e. how long the engine has been shut down.

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs after initial key-on and takes approximately 15 minutes to complete.

Conditions for Setting the Fault Codes

The engine off timer is not counting correctly and does not match other timers in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will not be able to monitor engine off time accurately.

Conditions for Clearing the Fault Code

  • To validate the repair, key-off for 1 minute, then key-on for 15 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code and MIL can also be cleared with the INSITE™ electronic service tool.

Shop Talk

Monitoring the engine off time is necessary in order to make sure that all other engine sensors and actuators are performing correctly. If the ECM is recalibrated or replaced during the repair and the fault code is no longer present, the instructions in the "Conditions for Clearing" section must be followed in order for the diagnostic to run again and validate the repair.

Potential causes of this fault code include:

  • Failed real time clock chip internal to the ECM
  • Engine calibration issue
Refer to Troubleshooting Fault Code t05-3492.

Last Modified: 08-Aug-2012


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3559

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3559 PID: SPN: 3361 FMI: 4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid (DEF) dosing unit. | Diesel exhaust fluid dosing unit will be unable to prime or inject diesel exhaust fluid into the selective catalytic reduction (SCR) aftertreatment system.
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The DEF dosing unit performs many functions, one of which is to generate adequate DEF pressure in the lines using a pump to allow for dosing. The engine control module (ECM) or DEF controller provides a voltage supply and a ground to the DEF dosing unit. The controller also supplies a signal to the dosing unit to control the DEF output. This signal changes, based on the DEF pressure being commanded.

Component Location

The aftertreatment DEF dosing unit is located on top of the DEF tank. The DEF tank location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual for more information.

Conditions for Running the Diagnostics

This diagnostic runs when the DEF dosing valve is being commanded ON.

Conditions for Setting the Fault Codes

The ECM or DEF controller detects that the DEF dosing unit voltage is shorted to ground or below normal voltage rating for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • Engine torque will be derated to 60% after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, DEF dosing must be commanded so that the dosing valve is actuated. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool. Refer to Procedure 011-063 in Section 11.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostic (OBD) engines, the ECM will turn off the MIL after the diagnostic runs and passes.
  • Inactive faults will be cleared from memory after 9600 hours of engine operation without reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the DEF dosing unit pump motor
  • Short to ground in the wire harness
  • Malfunctioning ECM or DEF controller.
Refer to Troubleshooting Fault Code t05-3559.

Last Modified: 03-Jun-2013


Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 3565

Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3565 PID: SPN: 5394 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid dosing valve circuit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing valve is controlled by the engine control module (ECM). When the engine ECM commands DEF dosing, a pulse width modulated signal is sent to the dosing valve, which opens the dosing valve and allows DEF to be pumped into the mixing chamber and sprayed into the exhaust stream.

Component Location

The aftertreatment DEF dosing valve is internal to the aftertreatment DEF dosing unit and cannot be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the DEF dosing valve is being commanded ON.

Conditions for Setting the Fault Codes

The ECM detects that the DEF dosing valve voltage is higher than the threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • Engine torque will be derated to 60% after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, DEF dosing must be commanded so that the dosing valve is actuated. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool. Refer to Procedure 011-063 in Section 11
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes
  • For On-Board Diagnostic engines, the ECM will turn off the MIL after the diagnostic runs and passes
  • Inactive faults will be cleared from memory after 9600 hours of engine operations without reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Short to battery voltage or open circuit in the DEF dosing valve
  • Short to battery voltage or open circuit in the OEM harness
  • Malfunctioning DEF controller.
Refer to Troubleshooting Fault Code t05-3565.

Last Modified: 03-Jun-2013


Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3566

Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3566 PID: SPN: 5394 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid dosing valve circuit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) dosing valve is controlled by the engine control module (ECM). When the ECM commands DEF dosing, the DEF controller sends a pulse width modulated signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment DEF dosing valve is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the DEF dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The ECM detects that the DEF dosing valve voltage is lower than the threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled.
  • Engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, DEF dosing must be commanded so that the dosing valve is actuated. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool. Refer to Procedure 011-063 in Section 11.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics engines, the ECM will turn off the MIL after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.
  • Inactive fault codes will be cleared from memory after 9,600 hours of engine operations without occurrence.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the DEF dosing valve
  • Short to ground in the DEF controller harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-3566.

Last Modified: 03-Jun-2013


Aftertreatment Diesel Exhaust Fluid Dosing Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3568

Aftertreatment Diesel Exhaust Fluid Dosing Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3568 PID: SPN: 5394 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Valve - Mechanical System Not Responding or Out of Adjustment. The DEF dosing valve has been detected to be stuck closed. | DEF injection into the aftertreatment system is disabled.
Aftertreatment DEF Dosing Valve Circuit

Circuit Description

The aftertreatment DEF dosing valve is controlled by the engine control module (ECM). When the engine ECM commands DEF dosing, a pulse width modulated (PWM) signal is sent to the dosing dosing valve, which opens the dosing valve and allows DEF to be pumped into the mixing chamber and sprayed into the exhaust stream.

Component Location

The aftertreatment DEF dosing valve is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs momentarily, when the aftertreatment diesel exhaust fluid dosing valve is being commanded ON for the first time after a key cycle.

Conditions for Setting the Fault Codes

The ECM detects the DEF pressure to be higher than the DEF pressure target value or the maximum dosing unit pressure for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled upon activation of the fault code.
  • An engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, use INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Dosing Unit Override Test" under the "ECM Diagnostics Test" menu in INSITE™ electronic service tool. Refer to Procedure 011-063 in Section 11.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL immediately after the diagnostic runs and passes.
  • Inactive fault codes will be cleared from memory after 9600 hours of engine operations without another occurrence.

Shop Talk

Possible causes of this fault code include:

  • Dosing valve stuck closed
  • Dosing valve restricted
  • Malfunctioning DEF pressure sensor.

If this fault code is active, the dosing system may not be able to purge, which means there will be DEF left in the lines. Care must be taken when removing connections. Also, lines could freeze and the selective catalyst reduction (SCR) system could become damaged in cold weather if the system is not properly purged.

Refer to Troubleshooting Fault Code t05-3568.

Last Modified: 03-Jun-2013


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 3571

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3571 PID: SPN: 4334 FMI: 3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid (DEF) pressure sensor circuit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and a ground to the DEF pressure sensor. The DEF pressure sensor provides a signal to the engine control module (ECM) on the sensor signal circuit. This sensor signal voltage changes, based on the DEF pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low DEF pressures, and a high signal voltage at high DEF pressures.

Component Location

The aftertreatment DEF pressure sensor is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the DEF pressure sensor signal voltage is higher than the threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • For On-Board Diagnostics (OBD) engines, engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications
  • Inactive fault codes will be cleared from memory after 9600 hours of engine operations without another occurrence.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • SIGNAL wire shorted to sensor supply or battery voltage
  • Short to battery in the harness
  • Sensor RETURN wire open
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-3571.

Last Modified: 03-Jun-2013


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3572

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3572 PID: SPN: 4334 FMI: 4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid (DEF) pressure sensor circuit. | Diesel exhaust fluid injection into the aftertreatment system is disabled.
Aftertreatment DEF Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and a ground to the DEF pressure sensor. The DEF pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the DEF pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low DEF pressures, and a high signal voltage at high DEF pressures.

Component Location

The aftertreatment DEF pressure sensor is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the measured DEF pressure sensor signal voltage to be lower than the threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • For On-Board Diagnostics (OBD) engines, engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL after the diagnostic runs and passes.
  • The "Reset All Faults" command in the INSITE electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.
  • Inactive faults will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • SIGNAL wire shorted to ground
  • Short to ground in the wiring harness
  • Sensor SUPPLY wire open or short to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-3572.

Last Modified: 03-Jun-2013


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3574

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3574 PID: SPN: 4334 FMI: 18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low diesel exhaust fluid (DEF) pressure has been detected in the dosing unit. | Diesel exhaust fluid dosing unit will be unable to inject or insufficiently inject DEF into the selective catalyst reduction (SCR) aftertreatment system. Dosing unit may not be able to complete purge, leaving the system pressurized.
Diesel Exhaust Fluid Components

Circuit Description

The engine control module (ECM) provides a 5 volt supply and a ground to the DEF pressure sensor. The DEF pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the DEF pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low DEF pressures, and high signal voltage at a high DEF pressures.

Component Location

The aftertreatment DEF pressure sensor is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the DEF dosing unit is in operation.

Conditions for Setting the Fault Codes

The ECM detects that the dosing unit is unable to build or maintain adequate DEF pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • Engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, use INSITE™ electronic service tool to perform the "Diesel Exhaust Fluid Dosing Unit Override Test" under the "ECM Diagnostics Test" menu in INSITE™ electronic service tool. Refer to Procedure 011-063 in Section 11.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after the diagnostic runs and passes.
  • Inactive faults will be cleared from the memory after 9600 hours of engine operation without reoccurence.

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Possible causes of this fault code include:

  • Low DEF tank level
  • Blocked, restricted, frozen, or broken DEF dosing unit supply line
  • Blocked or restricted DEF tank filter
  • Blocked or restricted DEF dosing unit filter/screen
  • Blocked or restricted DEF dosing unit supply line fitting
  • Malfunctioning or slow DEF dosing unit pump motor
  • Short to battery in the DEF dosing unit pump motor
  • Purge valve stuck open
  • Internal leakage
  • Open circuit in the wiring harness
  • Open circuit in the pump motor SIGNAL wire
  • Open circuit in the pump motor power wire.
Refer to Troubleshooting Fault Code t05-3574.

Last Modified: 03-Jun-2013


Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3575

Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3575 PID: SPN: 4334 FMI: 16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level. High pressure has been detected in the diesel exhaust fluid (DEF) path in the dosing unit. | System will be unable to spray DEF into the aftertreatment system. System will be unable to purge. System will be overpressurized and may reduce the life of the pump motor.
Aftertreatment DEF Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and a ground to the DEF pressure sensor. The DEF pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the DEF pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low DEF pressures, and a high signal voltage at high DEF pressures.

Component Location

The aftertreatment DEF pressure sensor is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the DEF pressure to be higher than the DEF pressure target value or the maximum supply module pressure for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • Engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, use INSITE electronic service tool to perform the "Diesel Exhaust Fluid Dosing Unit Override Test" under the "ECM Diagnostics Test" menu in INSITE electronic service tool. Refer to Procedure 011-063 in Section 11
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after the diagnostic runs and passes.
  • Inactive faults will be cleared from memory after 9600 hours of engine operation without reoccurence.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Dosing valve stuck closed
  • Diesel exhaust fluid pump motor speed too fast.

If this fault is active, the dosing system may not be able to purge, which means there will be DEF left in the lines. Care must be taken when removing connections. Also, lines could freeze and the selective catalyst reduction (SCR) system could become damaged in cold weather if the system is not properly purged.

Refer to Troubleshooting Fault Code t05-3575.

Last Modified: 03-Jun-2013


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 3577

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3577 PID: SPN: 4376 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid (DEF) return valve. | The DEF dosing unit will be unable to purge DEF from the system when the engine is shut off.
Aftertreatment DEF Dosing Unit Circuit

Circuit Description

The aftertreatment DEF return valve is controlled by the ECM. The return valve position determines the flow path of the DEF. When the dosing system is in purge mode, the return valve will be energized to return the DEF in the lines to the tank.

Component Location

The aftertreatment DEF return valve is internal to the aftertreatment DEF dosing unit and cannot be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is shutting down and the selective catalyst reduction (SCR) system is purging.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the DEF return valve voltage is higher than the threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The DEF injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • Engine torque will be derated to 60% after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, the DEF dosing system must be commanded to purge. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool. Refer to Procedure 011-080 in Section 11.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after the diagnostic runs and passes.
  • Inactive faults will be cleared from memory after 9600 hours of engine operations without reoccurrence.

Shop Talk

Possible causes of this fault code are:

  • Short to power supply in the harness
  • Short to power supply in the DEF return valve
  • Open circuit in the DEF return valve.

If this fault is active, the dosing system may not be able to purge which means there will be DEF left in the lines. Care must be taken when removing connections. Also, the lines could freeze and the SCR system could become damaged in cold weather if the system is not properly purged.

Refer to Troubleshooting Fault Code t05-3577.

Last Modified: 03-Jun-2013


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3578

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3578 PID: SPN: 4376 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid (DEF) return valve. | The DEF dosing unit will be unable to purge DEF from the system when the engine is shut off.
Aftertreatment DEF Dosing Unit Circuit

Circuit Description

The aftertreatment DEF return valve is controlled by the engine control module (ECM). The return valve position determines the flow path of the DEF. When the dosing system is in purge mode, the return valve will be energized to return the DEF in the lines to the tank.

Component Location

The aftertreatment DEF return valve is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is shutting down and the selective catalytic reduction (SCR) system is purging.

Conditions for Setting the Fault Codes

The ECM detects that the DEF return valve voltage is lower than the threshold value for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled and purged upon activation of fault code.

Conditions for Clearing the Fault Code

  • To validate the repair, the DEF dosing must be commanded to purge. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool. Refer to Procedure 011-080 in Section 11.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE electronic service tool can be used to clear active and inactive faults, as well as extinguish the malfunction indicator lamp (MIL) for on-board diagnostics (OBD) applications.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the wire harness
  • Short to ground in the in the DEF return valve.

If this fault is active, the dosing system may not be able to purge, which means there will be DEF left in the lines. Care must be taken when removing connections. Also, lines could freeze and become damaged in cold weather if the system is not properly purged.

Refer to Troubleshooting Fault Code t05-3578.

Last Modified: 03-Jun-2013


Aftertreatment Outlet NOx Sensor Power Supply - Data Erratic, Intermittent or Incorrect

FAULT CODE 3681

Aftertreatment Outlet NOx Sensor Power Supply - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3681 PID: P411 SPN: 3228 FMI: 0/2 LAMP: Amber SRT: | Aftertreatment outlet NOx sensor power supply - Data erratic, intermittent, or incorrect. The aftertreatment outlet NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhasut gas temperature at the aftertreatment outlet NOx sensor is above 150°C [302°F].

Conditions for Setting the Fault Codes

The ECM has detected that the power supply to the outlet NOx sensor is above or below a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for 10 minutes to allow the NOx sensor to warm up.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without an occurrence again.

Shop Talk

Possible causes of this fault code include:

  • Short to battery or ground in the OEM harness
  • Internal malfunction of the outlet NOx sensor
Refer to Troubleshooting Fault Code t05-3681.

Last Modified: 08-Aug-2012


Engine Auxiliary Governor Switch - Abnormal Update Rate

FAULT CODE 3735

Engine Auxiliary Governor Switch - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3735 PID: SPN: 2884 FMI: 9 LAMP: None SRT: | Engine Auxiliary Governor Switch - Abnormal Update Rate. Communication between the engine control module (ECM) and another device on the SAE J1939 data link has been lost. | Engine speed will ramp down and remain at idle.
Engine Control Module

Circuit Description

Devices such as ABS controllers, autoshift transmissions, ASR systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) (VECUs) can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than one second. The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM will log the fault code immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status will change to INACTIVE in INSITE™ electronic service tool immediately after the diagnostic runs and passes.
  • The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Possible causes of this fault code include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits
  • The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages
  • The external OEM controlling device has malfunctioned or can no longer transmit on the data link.
Refer to Troubleshooting Fault Code t05-3735.

Last Modified: 08-Aug-2012


Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4157

Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4157 PID: SPN: 4376 FMI: 7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment. The purge valve has been detected to be stuck closed. | The diesel exhaust fluid (DEF) dosing unit will be unable to purge DEF from the system when the engine is shut OFF.
Aftertreatment DEF Return Valve

Circuit Description

The purge valve allows air supply from the air tank going into the DEF dosing unit to purge DEF from the dosing unit back to the DEF tank.

Component Location

The aftertreatment DEF return valve is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is shutting down and the selective catalytic reduction (SCR) system is purging.

Conditions for Setting the Fault Codes

  • The engine control module (ECM) detects during purge that the measured DEF pressure was unable to reduce by a set amount in a specific amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled and purged upon activation of the fault code.

Conditions for Clearing the Fault Code

  • To validate the repair, the DEF dosing must be commanded to purge. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool. Refer to Procedure 011-063 in Section 11.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Inactive faults will be cleared from memory after 9,600 hours of engine operations without reoccurrence.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the malfunction indicator lamp (MIL) for on-board diagnostics (OBD) applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning DEF return valve
  • Plugged or restricted DEF circuit.

If this fault is active, the dosing system may not be able to purge, which means there will be DEF left in the lines. Care must be taken when removing connections. Also, lines could freeze and the SCR system could become damaged in cold weather if the system is not properly purged.

Refer to Troubleshooting Fault Code t05-4157.

Last Modified: 03-Jun-2013


Aftertreatment Selective Catalytic Reduction Dosing Air Assist Absolute Pressure Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 4172

Aftertreatment Selective Catalytic Reduction Dosing Air Assist Absolute Pressure Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4172 PID: SPN: 4335 FMI: 3 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Dosing Air Assist Absolute Pressure Sensor - Voltage Above Normal or Shorted to Low Source. High signal voltage detected at the dosing air assist pressure sensor circuit. | Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
Aftertreatment Selective Catalytic Reduction (SCR) System Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and a ground to the air assist pressure sensor. The dosing air assist pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the dosing air assist pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low dosing air assist pressures, and a high signal voltage at high dosing air assist pressures.

Component Location

The dosing air assist pressure sensor is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the measured dosing air assist pressure sensor signal voltage to be higher than the threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • For On-Board Diagnostics (OBD) engines, engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL immediately after diagnostic runs and passes.
  • Inactive faults will be cleared from memory after 9600 hours of engine operation without reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • SIGNAL wire shorted to sensor supply or battery voltage
  • Short to battery in the harness
  • Open circuit in the harness
  • Malfunctioning dosing air assist pressure sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-4172.

Last Modified: 03-Jun-2013


Aftertreatment Selective Catalytic Reduction Dosing Air Assist Absolute Pressure Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4173

Aftertreatment Selective Catalytic Reduction Dosing Air Assist Absolute Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4173 PID: SPN: 4335 FMI: 4 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Dosing Air Assist Absolute Pressure Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the dosing air assist pressure sensor circuit. | Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
Aftertreatment Selective Catalytic Reduction (SCR) System Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and a ground to the air assist pressure sensor. The dosing air assist pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the dosing air assist pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low dosing air assist pressures, and a high signal voltage at high dosing air assist pressures.

Component Location

The dosing air assist pressure sensor is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the dosing air assist pressure sensor signal voltage to be lower than the threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • For On-Board Diagnostics (OBD) engines, engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL immediately after diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • SIGNAL wire shorted to ground
  • Short to ground in the wire harness
  • SUPPLY wire open or shorted to ground
  • Malfunctioning dosing air assist pressure sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-4173.

Last Modified: 03-Jun-2013


Aftertreatment Selective Catalytic Reduction 1 Dosing Reagent Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 4174

Aftertreatment Selective Catalytic Reduction 1 Dosing Reagent Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4174 PID: SPN: 4337 FMI: 3 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction 1 Dosing Reagent Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid (DEF) temperature sensor circuit. | DEF injection into the aftertreatment system is disabled.
Aftertreatment Selective Catalytic Reduction (SCR) System Circuit

Circuit Description

The aftertreatment DEF temperature sensor is a variable resistor sensor and is used to measure the temperature of the DEF in the dosing unit. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF temperature.

Component Location

The aftertreatment DEF temperature sensor is internal to the aftertreatment DEF dosing unit and cannot be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the aftertreatment DEF temperature sensor signal voltage to be higher than the threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled and purged upon activation of fault code.
  • For On-Board Diagnostics (OBD) engines, engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL immediately after diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • SIGNAL wire shorted to ground
  • Short to ground in the wire harness
  • Open circuit in the wire harness
  • Malfunctioning aftertreatment DEF temperature sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-4174.

Last Modified: 03-Jun-2013


Aftertreatment 1 SCR Dosing Reagent Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4175

Aftertreatment 1 SCR Dosing Reagent Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4175 PID: SPN: 4337 FMI: 4 LAMP: SRT: | Aftertreatment 1 Selective Catalytic Reduction (SCR) Dosing Reagent Temperature Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid (DEF) temperature sensor circuit. | DEF injection into the aftertreatment system is disabled.
Aftertreatment 1 SCR Dosing Reagent Temperature Sensor

Circuit Description

The aftertreatment DEF temperature sensor is a variable resistor sensor that is used to measure the temperature of the DEF in the dosing unit. The engine control module (ECM) supplies 5 volts to the aftertreatment DEF temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the aftertreatment DEF temperature.

Component Location

The aftertreatment DEF temperature sensor is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module detects that the DEF temperature sensor signal voltage is lower than the threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled and purged upon activation of fault code.
  • Engine torque will be derated to 60% after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning DEF temperature sensor
  • Short to ground in the harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-4175.

Last Modified: 03-Jun-2013


Aftertreatment 1 SCR Dosing Air Assist Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 4176

Aftertreatment 1 SCR Dosing Air Assist Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4176 PID: SPN: 4336 FMI: 3 LAMP: Amber SRT: | Aftertreatment 1 SCR Dosing Air Assist Valve - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the dosing air assist valve circuit. | The diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
Aftertreatment 1 Selective Catalytic Reduction (SCR) Dosing Air Assist Valve

Circuit Description

The dosing air assist valve regulates the air supply from the air tank going into the DEF dosing unit.

Component Location

The dosing air assist valve is mounted on the DEF dosing unit. It is connected to the air supply line from the air tank.

Conditions for Running the Diagnostics

This diagnostic runs when the air assist valve is commanded ON.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the dosing air assist valve circuit voltage is higher than the threshold value for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled and purged upon activation of fault code.
  • For On-Board Diagnostics (OBD) engines, engine torque will be derated to 60% after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications

Shop Talk

Possible causes of this fault code include:

  • Short to power supply in the harness
  • Malfunctioning ECM
  • Malfunctioning dosing air assist valve.
Refer to Troubleshooting Fault Code t05-4176.

Last Modified: 03-Jun-2013


Aftertreatment 1 SCR Dosing Air Assist Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4177

Aftertreatment 1 SCR Dosing Air Assist Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4177 PID: SPN: 4336 FMI: 4 LAMP: Amber SRT: | Aftertreatment 1 SCR Dosing Air Assist Valve - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the dosing air assist valve circuit. | Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
Aftertreatment 1 Selective Catalytic Reduction (SCR) Dosing Air Assist Valve

Circuit Description

The dosing air assist valve regulates the air supply from the air tank going into the DEF dosing unit.

Component Location

The dosing air assist valve is mounted on the DEF dosing unit. It is connected to the air supply line from the air tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • The engine control module (ECM) detects that the dosing air assist valve voltage is lower than the threshold value for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light and the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • For On-Board Diagnostics (OBD) engines, engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For OBD engines, the ECM will turn off the MIL immediately after diagnostic runs and passes.
  • Inactive faults will be cleared from memory after 9600 hours of engine operation without reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the harness
  • Open circuit in the harness
  • Malfunctioning ECM
  • Malfunctioning dosing air assist valve.
Refer to Troubleshooting Fault Code t05-4177.

Last Modified: 03-Jun-2013


Aftertreatment 1 SCR Dosing Air Assist Absolute Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4238

Aftertreatment 1 SCR Dosing Air Assist Absolute Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 4335 FMI: 18 LAMP: Red SRT: | Aftertreatment 1 SCR Dosing Air Assist Absolute Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low dosing air assist pressure has been detected in the dosing unit. | Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
Aftertreatment DEF Dosing Unit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and a ground to the air assist pressure sensor. The dosing air assist pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes based on the dosing air assist pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low dosing air assist pressures and at high signal voltage.

Component Location

The dosing air assist pressure sensor is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the aftertreatment DEF dosing unit is in operation.

Conditions for Setting the Fault Codes

The ECM detects that the dosing air assist pressure is lower than a target pressure value or the minimum air pressure threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • DEF injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • Engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, the DEF dosing must be commanded to prime. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool. Refer to Procedure 011-063 in Section 11.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL immediately after diagnostic runs and passes.
  • Inactive faults will be cleared from memory after 9600 hours of engine operation without reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Blocked or restricted air supply line
  • Damaged air supply line
  • Damaged DEF and air mixture transfer line
  • Dosing air assist valve stuck closed
  • Insufficient air pressure from the vehicle air supplier system
  • Malfunctioning air pressure regulator.
Refer to Troubleshooting Fault Code t05-4238.

Last Modified: 03-Jun-2013


Aftertreatment 1 SCR Dosing Air Assist Absolute Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4239

Aftertreatment 1 SCR Dosing Air Assist Absolute Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 4335 FMI: 12/12 LAMP: Red SRT: | Aftertreatment 1 SCR Dosing Air Assist Absolute Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. High air pressure has been detected in the dosing unit during dosing mode. | Diesel exhaust fluid (DEF) injection into the aftertreatment system is disabled.
Aftertreatment DEF Dosing Unit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and a ground to the air assist pressure sensor. The dosing air assist pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes based on the dosing air assist pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low dosing air assist pressures and a high signal voltage at high dosing assist pressures.

Component Location

The dosing air assist pressure sensor is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the aftertreatment DEF dosing unit is in operation.

Conditions for Setting the Fault Codes

The ECM detects the dosing air assist pressure to be higher than a target pressure value or the maximum mixture pressure threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • Engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, the DEF dosing must be commanded to prime. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool. Refer to Procedure 011-063 in Section 11.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL immediately after the diagnostic runs and passes.
  • Inactive fault codes will be cleared from memory after 9600 hours of engine operation without recurrence.

Shop Talk

Possible causes of this fault code include:

  • Blocked or restricted DEF and air mixture transfer line
  • Blocked or restricted mixing chamber
  • Malfunctioning air pressure regulator
  • Blocked nozzle.
Refer to Troubleshooting Fault Code t05-4239.

Last Modified: 03-Jun-2013


Aftertreatment 1 SCR Dosing Air Assist Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4271

Aftertreatment 1 SCR Dosing Air Assist Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Aftertreatment 1 SCR Dosing Air Assist Valve - Mechanical System Not Responding or Out of Adjustment. High air pressure has been detected in the diesel exhaust fluid (DEF) dosing unit during prime when dosing air assist valve is closed. | DEF injection into the aftertreatment system is disabled.
Aftertreatment DEF Dosing Unit

Circuit Description

The dosing air assist valve regulates the air supply from the air tank going into the DEF dosing unit.

Component Location

The dosing air assist valve is mounted on the DEF dosing unit. It is connected to the air supply line from the air tank.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment DEF is in standby state prior to the priming phase.

Conditions for Setting the Fault Codes

When the dosing air assist valve is closed during priming, the engine control module (ECM) detects that the measured air pressure is higher than the threshold for a set amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled and purged upon activation of the fault code.
  • Engine torque will be derated to 60 percent after 50 hours of engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, the DEF dosing must be commanded to prime. This can be done by performing the "Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test" found under "ECM Diagnostic Tests" in INSITE™ electronic service tool. Refer to Procedure 011-063 in Section 11.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL immediately after diagnostic runs and passes.
  • Inactive faults will be cleared from memory after 9600 hours of engine operation without recurrence.

Shop Talk

Possible causes of this fault code include:

  • Stuck open dosing air assist valve
  • Blocked nozzle or DEF injection line.
Refer to Troubleshooting Fault Code t05-4271.

Last Modified: 03-Jun-2013


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 111 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 115. | Active or inactive counts of Fault Code 115?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 115.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 115?
YES NO

Swap the engine position sensor connectors.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Feb-2014


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 VOLT SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 VOLT SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 131 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 active?
STEP 3. | Check the ECM and original equipment harness (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2185

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position sensor +5 VOLT SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal or lever.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and original equipment harness (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 132 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 or 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 is active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 or 2186 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position +5 volt SUPPLY pin to the accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal position +5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 is active?
YES NO

A damaged accelerator pedal has been detected. See equipment manufacturer service information for repair instructions.

Replace the accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES NO

The removal and installation of the connector corrected the fault.

.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 133 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 or 1696 active?
 | STEP 1B. Check for an active fault code. | Fault Code 133 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. |
 | STEP 2A. Inspect the remote remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 134 active and Fault Code 133 inactive?
 | STEP 2D. Check the fault codes and verify remote remote accelerator pedal or lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 or 1696 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1695 and/or 1696.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit supply voltage and return circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal position sensor +5 volt SUPPLY pin to the remote accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active and Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote remote accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal or lever has been detected. Contact the appropriate OEM dealership for repair instructions.

Replace the remote accelerator pedal or lever. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever RETURN pin and the OEM harness remote accelerator pedal RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 134 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 134 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 133 active and Fault Code 134 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal or lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal position +5 volt SUPPLY pin to the remote accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the remote accelerator pedal position +5 volt SUPPLY pin and the remote accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active and Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal has been detected.

Replace the remote accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SUPPLY pin and the OEM harness remote accelerator pedal or lever connector SUPPLY pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SIGNAL pin and the OEM harness remote accelerator pedal connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9.5 CM2150 SN | 4310608
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB3.9 CM2220 B107 | 4310792
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2150 B108 | 4326163
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2150 B109 | 4326168
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G106 | 4332695
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G107 | 4332690
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G108 | 4332901
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G109 | 4332906
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSNT14 CM876 N102 | 4325993
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2880 L112 | 4358493
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9.3 CM2880 L113 | 4383811
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSC8.3 CM2880 C102 | 4388785
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB3.9 CM2880 B138 | 5411050
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB5.9 CM2880 B139 | 4388870
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISD6.7 CM2880 D101 | 5411372
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.7 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9.5 CM2150 SN | 4310608
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB3.9 CM2220 B107 | 4310792
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2150 B108 | 4326163
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2150 B109 | 4326168
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G106 | 4332695
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G107 | 4332690
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G108 | 4332901
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G109 | 4332906
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2880 L112 | 4358493
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSNT14 CM876 N102 | 4325993
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB5.9 CM2880 B127 | 4383645
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9.3 CM2880 L113 | 4383811
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSC8.3 CM2880 C102 | 4388785
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB5.9 CM2880 B139 | 4388870
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB3.9 CM2880 B138 | 5411050
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISD6.7 CM2880 D101 | 5411372
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 VOLT SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 VOLT SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Use the following troubleshooting symptom tree, Lubricating Oil Pressure Low or Lubricating Oil Pressure High troubleshooting symptom tree in Section TS in the appropriate service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Aug-2014


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G108 | 4332901
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G109 | 4332906
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F104 | 4332741
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F108 | 4332746
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G108 | 4332901
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G109 | 4332906
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F104 | 4332741
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F108 | 4332746
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-043 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G108 | 4332901
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G109 | 4332906
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F104 | 4332741
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F108 | 4332746
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the engine harness intake manifold air temperature sensor connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

  • For the ISG11 CM2880 G106, ISG12 CM2880 G107, and QSNT14 CM876 N102 engines: Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manfiold air temperature reading. |
 | STEP 1A. Monitor intake manfiold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor intake manfiold air temperature reading.

Guided Step 1A - Monitor intake manfiold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS, in the appropriate service manual.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 195 - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB7 CM2880 B117 | 4358390
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG11 CM2880 G106 | 4332695
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG12 CM2880 G107 | 4332690
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG11 CM2880 G108 | 4332901
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG12 CM2880 G109 | 4332906
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F104 QSF2.8 CM2882 F108 | 4332741 4332746
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Reference Fault Code 1695.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB7 CM2880 B117 | 4358390
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG11 CM2880 G106 | 4332695
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG12 CM2880 G107 | 4332690
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG11 CM2880 G108 | 4332901
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG12 CM2880 G109 | 4332906
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F104 QSF2.8 CM2880 F108 | 4332741 4332746
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Reference Fault Code 1696.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISL9.5 CM2150 SN | 4310608
Cooling System | Refer to Procedure 008-018 | ISG11 CM2880 G106 | 4332695
Cooling System | Refer to Procedure 008-018 | ISG12 CM2880 G107 | 4332690
Cooling System | Refer to Procedure 008-018 | ISG11 CM2880 G108 | 4332901
Cooling System | Refer to Procedure 008-018 | ISG12 CM2880 G109 | 4332906
Cooling System | Refer to Procedure 008-018 | QSNT14 CM876 N102 | 4325993
Cooling System | Refer to Procedure 008-018 | QSB7 CM2880 B117 | 4358390
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F104 | 4332741
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F108 | 4332746
Cooling System | Refer to Procedure 008-018 | ISB/ISD6.7 CM2880 B126 | 4383693
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2880 F112 | 4383825
Cooling System | Refer to Procedure 008-018 | QSL9.3 CM2880 L113 | 4383811
Cooling System | Refer to Procedure 008-018 | QSC8.3 CM2880 C102 | 4388785
Cooling System | Refer to Procedure 008-018 | QSB5.9 CM2880 B139 | 4388870
Cooling System | Refer to Procedure 008-018 | QSB3.9 CM2880 B138 | 5411050
Cooling System | Refer to Procedure 008-018 | ISD6.7 CM2880 D101 | 5411372
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F129 | 5411325
Cooling System | Refer to Procedure 008-018 | ISF4.5 CM2220 F123 | 5411320
Cooling System | Refer to Procedure 008-018 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

Reference the Coolant Loss troubleshooting symptom tree in Section TS.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likley cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISL9.5 CM2150 SN | 4310608
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISB3.9 CM2220 B107 | 4310792
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSNT14 CM876 N102 | 4325993
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSB4.5 CM2150 B108 | 4326163
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSB6.7 CM2150 B109 | 4326168
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF3.8 CM2220 F116 | 4383664
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDCto 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit reaponse after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISL9.5 CM2150 SN | 4310608
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISB3.9 CM2220 B107 | 4310792
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSNT14 CM876 N102 | 4325993
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSB4.5 CM2150 B108 | 4326163
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSB6.7 CM2150 B109 | 4326168
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF3.8 CM2220 F116 | 4383664
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric air pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric air pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric air pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric air pressure +5 volt SUPPLY pin to the barometric air pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the barometric air pressure +5 volt SUPPLY pin and the barometric air pressure SIGNAL pin at the barometric air pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric air pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric air pressure +5 volt SUPPLY pin to the barometric air pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the barometric air pressure +5 volt SUPPLY pin and the barometric air pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR Cummins® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring downhill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct revolutions per minute (rpm) reading?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring downhill?
YES NO
No Repair

Check for engine damage.

  • Electronics are ok.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to the engine tachometer red area.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct revolutions per minute (rpm) reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 1D

Troubleshoot Fault Codes 689 and 778.

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not running above high idle speed.

–

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test or the vessel in a sea trail to determine if the overspeed condition is still present.

–

Fault Code 234 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 l113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 l113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9.5 CM2150 SN | 4310608
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB3.9 CM2220 B107 | 4310792
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2150 B108 | 4326163
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2150 B109 | 4326168
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB7 CM2880 B117 | 4358390
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G106 | 4332695
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G107 | 4332690
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G108 | 4332901
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G109 | 4332906
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2880 L112 | 4358493
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F104 | 4332741
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F108 | 4332746
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2880 F112 | 4383825
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 CM2880 B127 | 4383645
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2880 B126 | 4383693
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9.3 CM2880 l113 | 4383811
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F116 | 4383664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSC8.3 CM2880 C102 | 4388785
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB5.9 CM2880 B139 | 4388870
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.9 CM2880 B138 | 5411050
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISD6.7 CM2880 D101 | 5411372
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F129 | 5411325
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine control module (ECM).

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or original equipment manufacturer (OEM) harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 3 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 241 - Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle settings in INSITE™ electronic service tool. |
 | STEP 1A. Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match. | Settings in INSITE™ electronic service tool match the vehicle configuration?
STEP 2. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the OEM harness pins and the sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM harness connector pins at the engine control module (ECM). | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check for additional OEM devices. |
 | STEP 3A. Check the vehicle speed sensor circuit for additional devices. | Extra devices?
 | STEP 3B. Check for the gear slipping on the shaft. | Gear or tone wheel damaged or slips?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the vehicle settings in INSITE™ electronic service tool.

Guided Step 1A - Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool. Go to Features and Parameters and verify the following parameters match the vehicle configuration.

  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type

The settings in INSITE™ electronic service tool match the vehicle configuration?
YES NO
No Repair

Change the settings in the ECM with INSITE™ electronic service tool to match the vehicle configuration.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness pins and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Repair the damaged connector pins.
  • Repair or replace the engine harness with the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM harness connector pins at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter, check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the ECM connector and engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for additional OEM devices.

Guided Step 3A - Check the vehicle speed sensor circuit for additional devices.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle speed sensor circuit.

  • Inspect the vehicle speed sensor circuit for any additional or extra devices that can interfere with the speed signal.

Extra devices?
YES NO

Remove the device or see equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for the gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the vehicle speed sensor from the transmission.

Action

Check for the gear slipping.

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal. Make sure the gear or tone wheel is not damaged or slipping on the shaft.

Gear or tone wheel damaged or slips?
YES NO

See equipment manufacturer service information to repair or replace the gear or tone wheel.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Aug-2014


FAULT CODE 242 - Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the feature settings are correct. |
 | STEP 1A. Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled. | Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
 | STEP 1B. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match. | Setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
 | STEP 1C. Verify that the Anti-Tampering Sensitivity Level is set correctly for the application. | Sensitivity level set correctly?
STEP 2. | Look for signs or evidence of tampering. |
 | STEP 2A. Inspect the vehicle speed sensor. | Tampering evidence, incorrect installation, or external device present?
 | STEP 2B. Check for open circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check the vehicle speed reporting. |
 | STEP 3A. Use INSITE™ electronic service tool to monitor the vehicle speed signal. | INSITE™ electronic service tool readout and the vehicle speedometer match?
 | STEP 3B. Verify the vehicle speed. | Vehicle speed is accurate?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Verify that the feature settings are correct.

Guided Step 1A - Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled.

Action

Verify that the customer wants Vehicle Speed Sensor Anti-Tampering feature enabled.

Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Vehicle Speed Sensor Anti-Tampering feature.

Go to 1B

Go to 4A

Guided Step 1B - Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.

  • Verify that the Vehicle Speed Sensor Type parameter setting in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 1C

Go to 4A

Guided Step 1C - Verify that the Anti-Tampering Sensitivity Level is set correctly for the application.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify that the Vehicle Speed Signal Tampering Sensitivity Level is set correctly for the application.

  • Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.
  • Check the ECM setting for Vehicle Speed Signal Tampering Sensitivity Level.

Sensitivity Level is set correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to set the Vehicle Speed Signal Tampering Sensitivity Level to the correct value for the vehicle.

Go to 2A

Go to 4A

Guided Step 2 - Look for signs or evidence of tampering.

Guided Step 2A - Inspect the vehicle speed sensor.

Action

Inspect the vehicle speed sensor for the following:

  • Improper mounting of the vehicle speed sensor
  • Vehicle speed sensor improperly connected to the OEM harness
  • Other external device connected in place of the vehicle speed sensor
  • Any evidence that tampering with the vehicle speed sensor has taken place.

Tampering evidence, incorrect installation, or external device present?
YES NO

Remove the tampering device.

Install the sensor correctly or remove the external device.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the vehicle speed reporting.

Guided Step 3A - Use INSITE™ to monitor the vehicle speed signal.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the vehicle speed.

  • Verify that the vehicle speed is 0 when the vehicle is stationary and the engine is running.
  • Drive the vehicle or run on a chassis dynamometer. Compare the vehicle speed reading by INSITE™ electronic service tool to the speedometer on the dash.

INSITE™ electronic service tool readout and the vehicle speedometer match?
YES NO
No Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correctly in the ECM.

Go to 3B

Go to 4A

Guided Step 3B - Verify the vehicle speed.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Vehicle moving.

Action

Use INSITE™ electronic service tool to verify that the speed reported is accurate or reasonable for the present gear.

  • (For example: 64 km/h [40 mph] in top gear is probably inaccurate data.)

Vehicle speed is accurate?
YES NO
No Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correctly in the ECM.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Apr-2013


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Within the original equipment manufacturer (OEM) resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control solenoid. |
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage and supply line. | Greater than 5 VDC?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 245 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

See equipment manufacturer service information for resistance specification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic SUPPLY voltage and SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and SUPPLY wire.

  • Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin at the OEM harness actuator connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Dec-2016


FAULT CODE 249 - Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 249 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 256 active and Fault Code 249 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 249 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and the ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the ambient air temperature SIGNAL pin and the ambient air temperature RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active and Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES NO

A damaged ambient air temperature sensor has been detected.

Replace the ambient air temperature sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor RETURN pin and the OEM harness ambient air temperature sensor connector RETURN pin.

Use a wiring diagram for pin identificaton and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor SIGNAL pin and the OEM harness ambient air temperature sensor connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 256 - Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 256 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 249 active and Fault Code 256 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 256 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 256 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active and Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

Replace the ambient air temperature sensor.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 269 - Antitheft Password Valid Indicator - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 269 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for the immobilizer anti-theft device fault codes.

  • Using INSITE™ electronic service tool read the fault codes.

Fault Code 269 active?
YES NO

The immobilizer anti-theft device has not been deactivated. The engine will not start until proper authorization has been activated.

Refer to OEM troubleshooting for immobilizer anti-theft device operation.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 271 - Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2280 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2280 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2280 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2280 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9.5 CM2150 SN | 4310608
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB3.9 CM2220 B107 | 4310792
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2150 B108 | 4326163
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2150 B109 | 4326168
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB7 CM2880 B117 | 4358390
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG11 CM2880 G106 | 4332695
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG12 CM2880 G107 | 4332690
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG11 CM2880 G108 | 4332901
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG12 CM2880 G109 | 4332906
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2280 F104 | 4332741
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2280 F108 | 4332746
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2880 L112 | 4358493
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2880 F112 | 4383825
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9.3 CM2880 L113 | 4383811
Fuel Pump Actuator | Refer to Procedure 019-117 | ISD6.7 CM2880 D101 | 5411372
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F129 | 5411325
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 271 active?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Inspect the fuel pump actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 272 is active and Fault Code 271 is inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 271 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 272 active and Fault Code 271 inactive?
 | STEP 3C. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 271 is inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Inspect the fuel pump actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Inspect the pigtail wire harness as well as the engine harness for wire insulation damage that can cause a short circuit.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 is active and Fault Code 271 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active and Fault Code 271 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 271 is inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been be detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 272 - Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9.5 CM2150 SN | 4310608
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2150 B108 | 4326163
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2150 B109 | 4326168
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB7 CM2880 B117 | 4358390
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG11 CM2880 G106 | 4332695
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG12 CM2880 G107 | 4332690
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG11 CM2880 G108 | 4332901
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG12 CM2880 G109 | 4332906
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F104 | 4332741
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F108 | 4332746
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2880 L112 | 4358493
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2880 F112 | 4383825
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9.3 CM2880 L113 | 4383811
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD6.7 CM2880 B126 | 4383693
Fuel Pump Actuator | Refer to Procedure 019-117 | ISD6.7 CM2880 D101 | 5411372
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F129 | 5411325
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF4.5 CM2220 F123 | 5411320
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 272 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Inspect the fuel pump actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 271 active and Fault Code 272 inactive?
 | STEP 2C. Check the fault codes and verify fuel pump actuator condition. | Fault Code 272 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 271 active and Fault Code 272 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 272 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Inspect the engine harness and actuator connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the circuit response.

  • Place a jumper wire between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the fuel pump actuator connector of the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active and Fault Code 272 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify fuel pump actuator condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or original equipment manufacturer (OEM) harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the circuit response.

  • Place a jumper wire between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN at the ECM engine connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active and Fault Code 272 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the ECM connector of the engine harness and the fuel pump actuator SIGNAL pin at the fuel pump actuator connector of the engine harness.
  • Measure the resistance between the fuel pump actuator RETURN pin at the ECM connector of the engine harness and the fuel pump actuator RETURN pin at the fuel pump actuator connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-pin short circuit on one connector.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4363825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 0 ohms and 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 is active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine electronic control module (ECM) for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the multiplexing configuration.

Check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Note: Use the following for OEM specific multiplexing configuration information. Refer to Multiplexing Troubleshooting, Bulletin 4021378.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Apr-2013


FAULT CODE 287 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 287 is active?
STEP 2. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the accelerator parameters are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of 0?
 | STEP 3B. Determine if the accelerator parameters are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than 0?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 287 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

Note: Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the throttle is released, the Throttle Status/Idle Validation parameter must display “released” and Percent Throttle parameter must display a value of 0.

Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of 0?
YES NO
No Repair

There is an OEM issue with the accelerator or idle validation switch or OEM VECU.

  • Refer to the appropriate OEM for further instructions.
  • Refer to Procedure 019-085 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

When the throttle is depressed, the Throttle Status/Idle Validation parameter must display “depressed” and Percent Throttle parameter must display a value greater than 0.

Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than 0?

YES NO
No Repair

There is an OEM issue with the idle validation switch or the accelerator or with the OEM VECU.

  • Refer to the appropriate OEM for further instructions.
  • Refer to Procedure 019-085 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Oct-2013


FAULT CODE 288 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 288 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the remote accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of 0?
 | STEP 3B. Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than 0?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 288 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the Society of Automotive Engineers (SAE) J1939 data link to the engine ECM and compare to the engine ECM configuration

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the remote accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Status/Idle Validation

Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the remote throttle is released, the Remote Throttle Switch parameter must display ON and the Percent Throttle parameter must display a value of 0.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of 0?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, the remote throttle, or the OEM VECU.

Use the appropriate OEM service manual for further instructions.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Switch Status

Monitor parameters can possibly notappear in the electronic service tool exactly as shown above.

When the remote throttle is depressed, the Remote Throttle Switch parameter mustdisplay ON and the Percent Throttle parameter mustdisplay a value greater than 0.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than 0?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, or the remote throttle, or the OEM VECU.

Use the appropriate OEM service manual for further instructions.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 291 - Proprietary Data Link Error (OEM/Vehicle Data Link) - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 291 active?
STEP 2. | Check the immobilizer anti-theft device for proper configuration. |
 | STEP 2A. Determine if the immobilizer anti-theft device is configured correctly. | The immobilizer anti-theft device is configured correctly?
STEP 3. | Check the service data link harness |
 | STEP 3A. Inspect the immobilizer anti-theft device and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open or short circuit in the J1939 data link harness. | Resistance between 50 and 70 ohms?
STEP 4. | Check the OEM harness |
 | STEP 4A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the ECM J1939 data link harness. | Resistance between 50 and 70 ohms?
 | STEP 4C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 291 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the immobilizer anti-theft device for proper configuration.

Guided Step 2A - Determine if the immobilizer anti-theft device is configured correctly.

Conditions

  • Turn keyswitch ON.

Action

Check the immobilizer anti-theft device for the following:

  • Correct power supply and ground connections
  • Proper connections to the J1939 data link
  • Correct electronic configuration of the immobilizer anti-theft device.

The immobilizer anti-theft device is configured correctly?
YES NO
No Repair

Refer to the immobilizer anti-theft installation instructions provided by the OEM.

Go to 3A

Refer to OEM installation instructions.

Guided Step 3 - Check the service data link harness

Guided Step 3A - Inspect the immobilizer anti-theft device and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the immobilizer anti-theft device from the J1939 data link.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the immobilizer anti-theft device from the J1939 data link.

Action

Check for an open or short circuit:

  • Measure the resistance between the SAE J1939 Data Link (+) wire and the SAE J1939 Data Link (-) wire on the service data link connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness

Guided Step 4A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit:

  • Measure the resistance between the SAE J1939 Data Link (+) wire and the SAE J1939 (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit:

  • Measure the resistance and check for a short circuit between the SAE J1939 Data Link (+) wire and the SAE J1939 (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 Data Link (+) and the SAE J1939 Data Link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Refer to the No Communication Symptom Tree in the appropriate service manual.

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 295 - Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 221 and Fault Code 222. | Fault Code 221 or Fault Code 222 active?
 | STEP 1B. Check the fault code. | Fault Code 295 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes.. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 221 and Fault Code 222.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 or Fault Code 222 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 295 active?
YES NO

A malfunctioning barometric pressure sensor has been detected.

  • The barometric pressure sensor is internal to the ECM. Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Dec-2016


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 F129 | 5411325
Rocker Lever Cover | Refer to Procedure 003-011 | ISF4.5 CM2220 F123 | 5411320
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 F129 | 5411325
Injector | Refer to Procedure 006-026 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active or inactive with more than 1 count in the last 25 ECM hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the fuel injector circuit for short circuits. |
 | STEP 2A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the fuel injector circuit for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the fuel injector wiring harness for short circuits to ground. |
 | STEP 2B-2. Check the fuel injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the fuel injector circuit for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the fuel injector. |
 | STEP 3A. Isolate fuel injector 1. | Multiple (same bank) fuel injector fault codes active?
 | STEP 3A-1. Isolate fuel injector 2. |
 | STEP 3A-2. Isolate fuel injector 3. |
STEP 4. | Check the fuel injector and injector circuit. |
 | STEP 4A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel injector circuit at the engine wiring harness. | Greater than 10 ohms?
 | STEP 4C. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the fuel injector wiring harness. | Greater than 10 ohms?
 | STEP 4E. Check the fuel injector solenoid circuit. | Greater than 10 ohms?
STEP 5. | Inspect the fuel injector wiring harness. |
 | STEP 5A. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active or inactive with more than 1 count in the last 25 ECM hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel injector circuit for short circuits.

Guided Step 2A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2A-1

Guided Step 2A-1 - Check the fuel injector circuit for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the engine wiring harness ECM connector and engine block ground. This is not required for 4-cylinder engines.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel injector wiring harness from the engine wiring harness.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible.

Repair the fuel injector wiring harness and/or engine wiring harness. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 2B-1

Guided Step 2B-1 - Check the fuel injector wiring harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check fuel injector wiring harness for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground. This is not required for 4-cylinder engines.

Refer to the wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged connection has been detected in the engine wiring harness.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B-2

Guided Step 2B-2 - Check the fuel injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoids being tested.

Action

Check the fuel injector solenoid for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin on the fuel injector solenoid and engine block ground. This is not required for 4-cylinder engines.

Refer to the wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the damaged fuel injector wiring harness.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 2C - Check the fuel injector circuit for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Remove the valve cover.
  • Disconnect the fuel injector wiring harness from the injectors being tested.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 1 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and all other pins in the engine wiring harness ECM connector. Not required for 4-cylinder engines.
  • Measure the resistance between the cylinder fuel injector solenoid 3 RETURN pin and all other pins in the wiring harness ECM connector. Not required for 4-cylinder engines.

Refer to the wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the fuel injector circuit. Troubleshoot the engine wiring harness, fuel injector wiring harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 6A

Guided Step 3 - Isolate the fuel injector.

Guided Step 3A - Isolate the fuel injector 1.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO
No Repair

Replace fuel injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-1

Go to 6A

Guided Step 3A-1 - Isolate fuel injector 2.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 1.
  • Disconnect the fuel injector wiring harness from fuel injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

For 6 cylinder engines: No repair.

For 4 cylinder engines: Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. Go to Step 6A.

Replace fuel injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 6A

Guided Step 3A-2 - Isolate fuel injector 3.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 2.
  • Disconnect the fuel injector wiring harness from fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. Go to Step 6A.

Replace fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 4 - Check the fuel injector and injector circuit.

Guided Step 4A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine wiring harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the fuel injector circuit at the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and fuel injector solenoid 1 RETURN pin at the ECM engine wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness and/or engine wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check fuel injector wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass through connector.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and the injector solenoid 1 RETURN pin on the fuel injector wiring harness side of the fuel injector harness pass through connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO
No Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the damaged engine wiring harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check the fuel injector solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in Section 3.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid.

Action

Check the fuel injector solenoid circuit.

  • Verify the rocker levers are not contacting the fuel injector wiring harness.
  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and the fuel injector solenoid 1 RETURN pin on the fuel injector solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO

A malfunctioning fuel injector 1 has been detected. Replace fuel injector 1.

Refer to Procedure 006-026 in the Associated Procedures Table.

A malfunctioning fuel injector wiring harness has been detected.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

Go to 6A

Go to 6A

Guided Step 5 - Inspect the fuel injector wiring harness.

Guided Step 5A - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the fuel injector wiring harness injector solenoid connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Go to

Last Modified: 17-Jan-2017


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the engine harness for short circuits. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B-1. Check the injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the engine harness for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the ECM or injector malfunction. |
 | STEP 3A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 3A-1. Complete injector isolation. |
 | STEP 3A-2. Complete injector isolation. |
 | STEP 3A-3. Check for active fault codes. |
STEP 4. | Check the injector and injector circuit for an open circuit. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 2 ohms?
 | STEP 4B-1. Check the injector solenoid for an open circuit. |
 | STEP 4C. Check the injector solenoid for a short circuit. | Fault code follow the injector?
 | STEP 4D. Check for active fault codes. | Fault codes still active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness for short circuits.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A short circuit to ground has been detected in the injector circuit.

Troubleshoot the engine harness, injector harness, and pass-through connector for a short circuit to ground.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Assoicated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2C - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Remove the valve cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the cylinder 4 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 4 RETURN pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 5 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 5 RETURN pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 6 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 6 RETURN pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 5A

Guided Step 3 - Isolate the ECM or injector malfunction.

Guided Step 3A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes for 6-cyliner engines:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Bank Fault Codes for 4-cyliner engines:

  • Bank 1 - Front Bank: Fault Codes 322, 331.
  • Bank 2 - Rear Bank: Fault Codes 324, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A-1

Go to 5A

Guided Step 3A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 5A

Guided Step 3A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-3

Go to 5A

Guided Step 3A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the injector and injector circuit for an open circuit.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the injector circuit for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit..

  • Measure the resistance between the cylinder number 5 SIGNAL pin and cylinder number 5 RETURN pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4B-1

Guided Step 4B-1 - Check the injector solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 5 SIGNAL pin and the cylinder number 5 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

An open circuit has been detected in the injector circuit. Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Assoicated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4C - Check the injector solenoid for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes still active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 F129 | 5411325
Rocker Lever Cover | Refer to Procedure 003-011 | ISF4.5 CM2220 F123 | 5411320
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 F129 | 5411325
Injector | Refer to Procedure 006-026 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 active or inactive with more than 1 count in the last 25 ECM hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the fuel injector circuit for short circuits. |
 | STEP 2A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the fuel injector circuit for a short circuit to ground. |
 | STEP 2B. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the fuel injector wiring harness for short circuits to ground. |
 | STEP 2B-2. Check the fuel injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the fuel injector circuit for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the fuel injector. |
 | STEP 3A. Isolate the fuel injector. | Multiple (same bank) fuel injector fault codes active?
 | STEP 3A-1. Isolate the fuel injector. |
 | STEP 3A-2. Isolate the fuel injector. |
STEP 4. | Check the fuel injector and injector circuit. |
 | STEP 4A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel injector circuit at the engine wiring harness. | Greater than 10 ohms?
 | STEP 4C. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the fuel injector wiring harness. | Greater than10 ohms?
 | STEP 4E. Check the fuel injector solenoid circuit. | Greater than 10 ohms?
STEP 5. | Inspect the fuel injector wiring harness. |
 | STEP 5A. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active or inactive with more than 1 count in the last 25 ECM hours?
YES | NO
No Repair | No Repair

Go to 1B

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel injector circuit for short circuits.

Guided Step 2A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2A-1

Guided Step 2A-1 - Check the fuel injector circuit for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for a short circuit to ground.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel injector wiring harness from the engine wiring harness.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible.

Repair the fuel injector wiring harness and/or engine wiring harness. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 2B-1

Guided Step 2B-1 - Check the fuel injector wiring harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check the fuel injector harness for a short circuit to ground.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged connection has been detected in the engine wiring harness.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B-2

Guided Step 2B-2 - Check the fuel injector wiring harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoids being tested.

Action

Check the fuel injector for a short circuit to ground.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin on the fuel injector solenoid and engine block ground

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin on the fuel injector solenoid and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the damaged fuel injector wiring harness.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 2C - Check the fuel injector circuit for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Remove the valve cover.
  • Disconnect the fuel injector wiring harness from the fuel injectors being tested.

Action

Check for a short circuit from pin-to-pin.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 1 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 RETURN pin and all other pins in the engine wiring harness ECM connector.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 4 RETURN pin and all other pins in the engine wiring harness ECM connector

Refer to the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the fuel injector circuit. Troubleshoot the engine wiring harness, fuel injector wiring harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 6A

Guided Step 3 - Isolate the fuel injector.

Guided Step 3A - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • For 6-cylinder engines: Disconnect the fuel injector wiring harness from fuel injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • For 4-cylinder engines: Disconnect the fuel injector wiring harness from fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO
No Repair

For 6-cylinder engines: Replace fuel injector number 1.

For 4-cylinder engines: Replace fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-1

Go to 6A

Guided Step 3A-1 - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • For 6-cylinder engines: Connect the fuel injector wiring harness to fuel injector number 1, and disconnect the fuel injector wiring harness from fuel injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • For 4-cylinder engines: Connect the fuel injector wiring harness to fuel injector number 3, and disconnect the fuel injector wiring harness from fuel injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

For 6-cylinder engines: No Repair.

For 4-cylinder engines: Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. Go to Step 6A.

For 6-cylinder engine: Replace fuel injector number 2.

For 4-cylinder engines: Replace fuel injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 6A

Guided Step 3A-2 - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 2.
  • Disconnect the fuel injector wiring harness from fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 4 - Check the fuel injector and injector circuit.

Guided Step 4A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine wiring harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the fuel injector circuit at the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and fuel injector solenoid 3 RETURN pin at the ECM engine wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness and/or engine wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check for fuel injector wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and the injector solenoid 3 RETURN pin on the fuel injector wiring harness side of the fuel injector harness pass-through connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO
No Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the damaged engine wiring harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check the fuel injector solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid.

Action

Check the fuel injector solenoid circuit.

  • Verify the rocker levers are not contacting the fuel injector wiring harness.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and the fuel injector solenoid 3 RETURN pin on the fuel injector solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO

A malfunctioning fuel injector 3 has been detected. Replace fuel injector 3. Refer to Procedure 006-026 in the Associated Procedures Table.

A malfunctioning fuel injector wiring harness has been detected.

Repair or replace the damaged engine wiring harness, connectors, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

Go to 6A

Go to 6A

Guided Step 5 - Inspect the fuel injector wiring harness.

Guided Step 5A - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the fuel injector wiring harness injector solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Go to

Last Modified: 17-Jan-2017


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the engine harness for short circuits. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2B-1. Check the injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the engine harness for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the ECM or injector malfunction. |
 | STEP 3A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 3A-1. Complete injector isolation. |
 | STEP 3A-2. Complete injector isolation. |
 | STEP 3A-3. Check for active fault codes. |
STEP 4. | Check the injector and injector circuit for an open circuit. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 2 ohms?
 | STEP 4B-1. Check the injector solenoid for an open circuit. |
 | STEP 4C. Check the injector solenoid for a short circuit. | Fault code follow the injector?
 | STEP 4D. Check for active fault codes. | Fault codes still active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness for short circuits.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A short circuit to ground has been detected in the injector circuit.

Troubleshoot the engine harness, injector harness, and pass-through connector for a short circuit to ground.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Assoicated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2C - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Remove the valve cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the cylinder 4 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 4 RETURN pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 5 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 5 RETURN pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 6 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the cylinder 6 RETURN pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the injector circuit. Troubleshoot the engine harness, injector harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 5A

Guided Step 3 - Isolate the ECM or injector malfunction.

Guided Step 3A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes for 6-cyliner engines:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Bank Fault Codes for 4-cyliner engines:

  • Bank 1 - Front Bank: Fault Codes 322, 331.
  • Bank 2 - Rear Bank: Fault Codes 324, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A-1

Go to 5A

Guided Step 3A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 5A

Guided Step 3A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-3

Go to 5A

Guided Step 3A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the injector and injector circuit for an open circuit.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the injector circuit for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit..

  • Measure the resistance between the cylinder number 6 SIGNAL pin and cylinder number 6 RETURN pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4B-1

Guided Step 4B-1 - Check the injector solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 6 SIGNAL pin and the cylinder number 6 RETURN pin on the injector solenoid.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

An open circuit has been detected in the injector circuit. Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Assoicated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4C - Check the injector solenoid for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for a short circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes still active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 F129 | 5411325
Rocker Lever Cover | Refer to Procedure 003-011 | ISF4.5 CM2220 F123 | 5411320
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 F129 | 5411325
Injector | Refer to Procedure 006-026 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 active or inactive with more than 1 count in the last 25 ECM hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the fuel injector circuit for short circuits. |
 | STEP 2A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the fuel injector circuit for a short circuit to ground. |
 | STEP 2B. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the fuel injector wiring harness for short circuits to ground. |
 | STEP 2B-2. Check the fuel injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the fuel injector circuit for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the fuel injector. |
 | STEP 3A. Isolate fuel injector 1. | Multiple (same bank) fuel injector fault codes active?
 | STEP 3A-1. Isolate fuel injector 2. |
 | STEP 3A-2. Isolate fuel injector 3. |
STEP 4. | Check the fuel injector and injector circuit. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel injector circuit at the engine wiring harness. | Greater than 10 ohms?
 | STEP 4C. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the fuel injector wiring harness. | Greater than 10 ohms?
 | STEP 4E. Check the fuel injector solenoid circuit. | Greater than 10 ohms?
STEP 5. | Inspect the fuel injector wiring harness. |
 | STEP 5A. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active or inactive with more than 1 count in the last 25 ECM hours?
YES | NO
No Repair | No Repair

Go to 1B

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel injector circuit for short circuits.

Guided Step 2A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2A-1

Guided Step 2A-1 - Check the fuel injector circuit for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the engine wiring harness ECM connector and engine block ground. (Not required for 4-cylinder engines).

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel injector wiring harness from the engine wiring harness.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible.

Repair the fuel injector wiring harness and/or engine wiring harness. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 2B-1

Guided Step 2B-1 - Check the fuel injector wiring harness for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check the fuel injector wiring harness for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground. (Not required for 4-cylinder engines.

Refer to the wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged connection has been detected in the engine wiring harness.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B-2

Guided Step 2B-2 - Check the fuel injector solenoid for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoids being tested.

Action

Check the fuel injector solenoid for a short circuit to ground.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin on the fuel injector solenoid and engine block ground
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin on the fuel injector solenoid and engine block ground. (Not required for 4-cylinder engines.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the damaged fuel injector wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 2C - Check the fuel injector circuit for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Remove the valve cover.
  • Disconnect the fuel injector wiring harness from the fuel injectors being tested.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the fuel injector solenoid 1 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 1 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 2 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and all other pins in the engine wiring harness ECM connector. (Not required for 4-cylinder engines)
  • Measure the resistance between the cylinder fuel injector solenoid 3 RETURN pin and all other pins in the engine wiring harness ECM connector. (Not required for 4-cylinder engines)

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the fuel injector circuit. Troubleshoot the engine wiring harness, fuel injector wiring harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 6A

Guided Step 3 - Isolate the fuel injector.

Guided Step 3A - Isolate fuel injector 1.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from fuel injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO
No Repair

Replace fuel injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-1

Go to 6A

Guided Step 3A-1 - Isolate fuel injector 2.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete the fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 1.
  • Disconnect the fuel injector wiring harness from fuel injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

For 6-cylinder engines: No repair.

For 4-cylinder engines: Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. Go to Step 6A.

Replace fuel injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 6A

Guided Step 3A-2 - Isolate fuel injector 3.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 2.
  • Disconnect the fuel injector wiring harness from fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 4 - Check the fuel injector and injector circuit.

Guided Step 4A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine wiring harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the fuel injector circuit at the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and fuel injector solenoid 2 RETURN pin at the ECM engine wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness and/or engine wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check the fuel injector wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and the injector solenoid 2 RETURN pin on the fuel injector wiring harness side of the fuel injector harness pass-through connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO
No Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the damaged engine wiring harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check the fuel injector solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid.

Action

Check the fuel injector solenoid circuit.

  • Verify the rocker levers are not contacting the fuel injector wiring harness.
  • Measure the resistance between the fuel injector solenoid 2 SIGNAL pin and the fuel injector solenoid 2 RETURN pin on the fuel injector solenoid

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO

A malfunctioning fuel injector 2 has been detected. Replace fuel injector 2. Refer to Procedure 006-026 in the Associated Procedures Table.

A malfunctioning fuel injector wiring harness has been detected.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

Go to 6A

Go to 6A

Guided Step 5 - Inspect the fuel injector wiring harness.

Guided Step 5A - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the fuel injector wiring harness injector solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible.

Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Go to

Last Modified: 17-Jan-2017


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB3.9 CM2220 B107 | 4310792
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2150 B108 | 4326163
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2150 B109 | 4326168
Rocker Lever Cover | Refer to Procedure 003-011 | QSB7 CM2880 B117 | 4358390
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G106 | 4332695
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G107 | 4332690
Rocker Lever Cover | Refer to Procedure 003-011 | ISG11 CM2880 G108 | 4332901
Rocker Lever Cover | Refer to Procedure 003-011 | ISG12 CM2880 G109 | 4332906
Rocker Lever Cover | Refer to Procedure 003-011 | QSNT14 CM876 N102 | 4325993
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F104 | 4332741
Rocker Lever Cover | Refer to Procedure 003-011 | QSNF2.8 CM2880 F108 | 4332746
Rocker Lever Cover | Refer to Procedure 003-011 | ISL8.9 CM2880 L112 | 4358493
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2880 F112 | 4383825
Rocker Lever Cover | Refer to Procedure 003-011 | ISB/ISD6.7 CM2880 B126 | 4383693
Rocker Lever Cover | Refer to Procedure 003-011 | ISB5.9 CM2880 B127 | 4383645
Rocker Lever Cover | Refer to Procedure 003-011 | ISF3.8 CM2220 F116 | 4383664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9.3 CM2880 L113 | 4383811
Rocker Lever Cover | Refer to Procedure 003-011 | QSC8.3 CM2880 C102 | 4388785
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Rocker Lever Cover | Refer to Procedure 003-011 | ISD6.7 CM2880 D101 | 5411372
Rocker Lever Cover | Refer to Procedure 003-011 | ISF2.8 CM2220 F129 | 5411325
Rocker Lever Cover | Refer to Procedure 003-011 | ISF4.5 CM2220 F123 | 5411320
Injector | Refer to Procedure 006-026 | ISB3.9 CM2220 B107 | 4310792
Injector | Refer to Procedure 006-026 | QSB4.5 CM2150 B108 | 4326163
Injector | Refer to Procedure 006-026 | QSB6.7 CM2150 B109 | 4326168
Injector | Refer to Procedure 006-026 | QSB7 CM2880 B117 | 4358390
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G106 | 4332695
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G107 | 4332690
Injector | Refer to Procedure 006-026 | ISG11 CM2880 G108 | 4332901
Injector | Refer to Procedure 006-026 | ISG12 CM2880 G109 | 4332906
Injector | Refer to Procedure 006-026 | QSNT14 CM876 N102 | 4325993
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F104 | 4332741
Injector | Refer to Procedure 006-026 | QSNF2.8 CM2880 F108 | 4332746
Injector | Refer to Procedure 006-026 | ISL8.9 CM2880 L112 | 4358493
Injector | Refer to Procedure 006-026 | QSF3.8 CM2880 F112 | 4383825
Injector | Refer to Procedure 006-026 | ISB/ISD6.7 CM2880 B126 | 4383693
Injector | Refer to Procedure 006-026 | ISB5.9 CM2880 B127 | 4383645
Injector | Refer to Procedure 006-026 | ISF3.8 CM2220 F116 | 4383664
Injector | Refer to Procedure 006-026 | QSL9.3 CM2880 L113 | 4383811
Injector | Refer to Procedure 006-026 | QSC8.3 CM2880 C102 | 4388785
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISD6.7 CM2880 D101 | 5411372
Injector | Refer to Procedure 006-026 | ISF2.8 CM2220 F129 | 5411325
Injector | Refer to Procedure 006-026 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 active or inactive with more than 1 count in the last 25 ECM hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the fuel injector circuit for short circuits. |
 | STEP 2A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the fuel injector circuit for a short circuit to ground. |
 | STEP 2B. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the fuel injector wiring harness for short circuits to ground. |
 | STEP 2B-2. Check the fuel injector solenoid for a short circuit to ground. |
 | STEP 2C. Check the fuel injector circuit for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Isolate the fuel injector. |
 | STEP 3A. Isolate the fuel injector. | Multiple (same bank) fuel injector fault codes active?
 | STEP 3A-1. Isolate the fuel injector. |
 | STEP 3A-2. Isolate the fuel injector. |
STEP 4. | Check the injector and injector circuit. |
 | STEP 4A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel injector circuit at the engine wiring harness. | Greater than 10 ohms?
 | STEP 4C. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the fuel injector wiring harness. | Greater than 10 ohms?
 | STEP 4E. Check the fuel injector solenoid circuit. | Greater than 10 ohms?
STEP 5. | Inspect the fuel injector wiring harness. |
 | STEP 5A. Inspect the fuel injector wiring harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 active or inactive with more than 1 count in the last 25 ECM hours?
YES | NO
No Repair | No Repair

Go to 1B

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel injector circuit for short circuits.

Guided Step 2A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 2A-1

Guided Step 2A-1 - Check the fuel injector circuit for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check for a short circuit to ground.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 5 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 6 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the engine wiring harness ECM connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel injector wiring harness from the engine wiring harness.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connectors, or pins, if possible.

Repair the fuel injector wiring harness and/or engine wiring harness. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 2B-1

Guided Step 2B-1 - Check the fuel injector wiring harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check fuel injector wiring harness for a short circuit to ground:

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 5 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 6 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin at the fuel injector wiring harness pass-through connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged connection has been detected in the engine wiring harness.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B-2

Guided Step 2B-2 - Check the fuel injector solenoid for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoids being tested.

Action

Check the fuel injector solenoid for a short circuit to ground:

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 5 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 6 SIGNAL pin on the fuel injector solenoid and engine block ground.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin on the fuel injector solenoid and engine block ground.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin on the fuel injector solenoid and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the damaged fuel injector wiring harness.

Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 2C - Check the fuel injector circuit for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Remove the valve cover.
  • Disconnect the fuel injector wiring harness from the fuel injectors being tested.

Action

Check for a short circuit from pin-to-pin.

For 6-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 4 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 5 SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 5 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 6 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 6 RETURN pin and all other pins in the engine wiring harness ECM connector.

For 4-cylinder engines:

  • Measure the resistance between the fuel injector solenoid 3 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 3 RETURN pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and all other pins in the engine wiring harness ECM connector.
  • Measure the resistance between the fuel injector solenoid 4 RETURN pin and all other pins in the engine wiring harness ECM connector.

Refer to the wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the fuel injector circuit. Troubleshoot the engine wiring harness, fuel injector wiring harness, and injector pass-through connector for a pin-to-pin short circuit.

Repair or replace the damaged component.

Go to 3A

Go to 6A

Guided Step 3 - Isolate the fuel injector.

Guided Step 3A - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete the fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from fuel injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO
No Repair

Replace fuel injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-1

Go to 6A

Guided Step 3A-1 - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete the fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 4.
  • For 6-cylinder engines: Disconnect the fuel injector wiring harness from fuel injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • For 4-cylinder engines: Disconnect the fuel injector wiring harness from fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

For 6-cylinder engines: No repair.

For 4-cylinder engines: Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. Go to Step 6A.

For 6-cylinder engines: Replace injector number 5.

For 4-cylinder engines: Replace fuel injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A-2

Go to 6A

Guided Step 3A-2 - Isolate the fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete fuel injector isolation.

  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the fuel injector wiring harness to fuel injector number 5.
  • Disconnect the fuel injector wiring harness from fuel injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the fuel injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the rocker lever cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) fuel injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace fuel injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 4 - Check the injector and injector circuit.

Guided Step 4A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector.

Action

Inspect the enginewiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine wiring harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the fuel injector circuit at the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and fuel injector solenoid 4 RETURN pin at the ECM engine wiring harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness and/or engine wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check the fuel injector wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Check the fuel injector circuit.

  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and the injector solenoid 4 RETURN pin on the fuel injector wiring harness side of the fuel injector harness pass-through connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO
No Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the damaged engine wiring harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check the fuel injector solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid.

Action

Check the fuel injector solenoid circuit.

  • Verify the rocker levers are not contacting the fuel injector wiring harness.
  • Measure the resistance between the fuel injector solenoid 4 SIGNAL pin and the fuel injector solenoid 4 RETURN pin on the fuel injector solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO

A malfunctioning fuel injector 4 has been detected. Replace fuel injector 4. Refer to Procedure 006-026 in the Associated Procedures Table.

A malfunctioning fuel injector wiring harness has been detected.

Repair or replace the damaged fuel injector wiring harness, connectors, or pins, if possible. Refer to Procedure 019-361 in Section 19.

Go to 6A

Go to 6A

Guided Step 5 - Inspect the fuel injector wiring harness.

Guided Step 5A - Inspect the fuel injector wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector wiring harness pass-through connector.

Action

Inspect the engine wiring harness and fuel injector wiring harness pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the fuel injector wiring harness injector solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel injector wiring harness.

Repair or replace the damaged fuel injector wiring harness, connector, or pins, if possible. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Go to

Last Modified: 17-Jan-2017


FAULT CODE 334 - Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 144 and 145. | Fault Code 144 or 145 active?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active?
 | STEP 2C. Check the circuit response. | Fault Code 145 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 144 active?
 | STEP 3C. Check the circuit response. | Fault Code 145 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 144 and 145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 144 or 145 active?
YES | NO
No Repair | No Repair

Go to Fault Code 144 or 145 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor and connector pins.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine coolant temperature signal pin and the engine coolant temperature return pin at the engine coolant temperature connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine coolant temperature SIGNAL pin and engine coolant temperature RETURN pin at the ECM engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Dec-2016


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active or more than 3 inactive counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During Cranking: At least (+) 6.2-VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Calibrate the ECM. |
 | STEP 4A. Calibrate the ECM. | Fault Code 343 active after Calibrating the ECM?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active or more than 3 inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During Cranking: At least (+) 6.2-VDC?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the original equipment manufacturer (OEM) power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY(+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Dirty or damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Calibrate the ECM.

Guided Step 4A - Calibrate the ECM

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a short circuit to ground.

  • Use INSITE™ electronic service tool to calibrate the ECM with the latest engine calibration.

Fault Code 343 active after calibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2016


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2200 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | QSB2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSB2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2200 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 active or inactive?
 | STEP 1B. Operate the engine. | Will the engine start?
 | STEP 1C. Read the fault codes. | Fault Code 351 active?
STEP 2. | Check the ECM power supply. |
 | STEP 2A. Inspect the ECM power supply connectors and fuses. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate the engine and determine if fault code condition exists. | Fault Code 351 occurs during engine operation?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 active or inactive?
YES NO

Troubleshoot Fault Code 441 first.

 No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Operate the engine.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Operate the engine.

Will the engine start?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES NO

A marginal battery voltage condition is possible. Make sure the batteries are fully charged or replace, if needed.

It is likely that a marginal battery condition will result in Fault Code 351 becoming active at engine cranking.

 No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Inspect the ECM power supply connectors and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Inspect the ECM power supply and fuses for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the power connector of the ECM power supply harness and the battery positive (+) pins at the battery positive (+) connection.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the battery terminals.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit in the ECM ground circuit.

  • Measure the resistance between the battery negative (-) pins at the ECM power supply connector to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 occurs during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A marginal battery voltage condition is possible. Make sure the batteries are fully charged or replace, if needed.

It is likely that a marginal battery condition will result in Fault Code 351 becoming active at engine cranking.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Low engine oil pressure has been detected.

Refer to Lubricating Oil Pressure Low symptom tree in the appropriate service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Feb-2013


FAULT CODE 418 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 428 or 429 active?
 | STEP 1B. Check for Fault Code 418. | Active or inactive counts of Fault Code 418?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 or 429 active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Code 418.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 418.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 418?
YES NO

Drain the water from the fuel filter.

If Fault Code 418 remains active, a malfunction in the sensor and/or connector may have occurred. Repair or replace the sensor and/or connector, as necessary

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-May-2016


FAULT CODE 428 - Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2150 B108 | 4326163
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2150 B109 | 4326168
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB7 CM2880 B117 | 4358390
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB3.9 CM2220 B107 | 4310792
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSNT14 CM876 N102 | 4325993
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G106 | 4332695
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G107 | 4332690
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G108 | 4332901
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G109 | 4332906
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F104 | 4332741
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F108 | 4332746
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2880 L112 | 4358493
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2880 B126 | 4383693
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB5.9 CM2880 B127 | 4383645
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F116 | 4383664
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F129 | 5411325
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 428 active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the water-in-fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 3.87 Mega-ohms (MΩ)?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 428 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 429 active and Fault Code 428 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, and water-in-fuel connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the water-in-fuel sensor connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.87 Mega-ohms (MΩ)?
YES NO

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the ECM engine connector.

Refer to the circuit or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active and Fault Code 428 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor RETURN pin and the engine harness water-in-fuel sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor SIGNAL pin and the engine water-in-fuel sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 429 - Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2150 B108 | 4326163
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2150 B109 | 4326168
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB7 CM2880 B117 | 4358390
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB3.9 CM2220 B107 | 4310792
Water in Fuel Sensor | Refer to Procedure 019-127 | QSNT14 CM876 N102 | 4325993
Water in Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G106 | 4332695
Water in Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G107 | 4332690
Water in Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G108 | 4332901
Water in Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G109 | 4332906
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F104 | 4332741
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F108 | 4332746
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2880 L112 | 4358493
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2880 B126 | 4383693
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB5.9 CM2880 B127 | 4383645
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F116 | 4383664
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F129 | 5411325
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 429 active?
STEP 2. | Check the Water in Fuel sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 429 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, sensor, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 429 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Water in Fuel sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Water in Fuel sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Water in Fuel sensor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the Water in Fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES NO

A damaged sensor has been detected.

Replace the Water in Fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, sensor, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the Water in Fuel sensor.

Action

Inspect the engine harness, sensor, and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 for Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Water in Fuel sensor.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the Water in Fuel SIGNAL pin at the ECM connector of the engine harness and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 435 - Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL9.5 CM2150 SN | 4310608
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSNT14 CM876 N102 | 4325993
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL8.9 CM2880 L112 | 4358493

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 135 and Fault Code 141 | Fault Code 135 and Fault Code 141 active?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active?
 | STEP 2C. Check the circuit response. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 141 active?
 | STEP 3C. Check the circuit response. | Fault Code 135 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 135 and Fault Code 141.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 and Fault Code 141 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil pressure +5 VOLT SUPPLY pin and the engine oil pressure SIGNAL pin at the engine oil pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

An in-range failure of the oil pressure sensor has been detected.

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the engine oil pressure +5 VOLT SUPPLY pin and the engine oil pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Sep-2014


FAULT CODE 436 - Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 436 active?
 | STEP 1B. Check for Fault Codes 153 and 154. | Fault Code 153 or 154 active?
STEP 2. | Check the engine intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the engine intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active?
 | STEP 2C. Check the circuit response. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 153 active?
 | STEP 3C. Check the circuit response. | Fault Code 154 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Intake manifold temperature and ambient air temperature reading within 5.6°C or 10°F of each other?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 436 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for Fault Codes 153 and 154.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 or 154 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the engine intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the original equipment manufacturer (OEM) wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 will also be active when the intake manifold temperature sensor is disconnected.

Fault Code 153 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold temperature RETURN pin and the intake manifold temperature SIGNAL pin at the intake manifold temperature connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

An in-range malfunction of the intake manifold temperature sensor has been detected.

Replace the engine intake manifold temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold temperature RETURN pin and the intake manifold temperature SIGNAL pin at the ECM engine connector.

See the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger.

  • Compare INSITE™ electronic service tool reading for intake manifold temperature to ambient air temperature.

Intake manifold temperature and ambient air temperature reading within 5.6°C or 10°F of each other?
YES | NO
No Repair | No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been competed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 02-Dec-2016


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the OEM power harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-ampere fuse is installed correctly.

  • Inspect the 30-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 30-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse.

Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the SUPPLY wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the battery system. |
 | STEP 2A. Check the battery voltage. | Less than +20 VDC for 12 volt system and less than +32 VDC for 24 volt system?
 | STEP 2B. Check the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Check the battery voltage.

  • Measure the battery voltage from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.
  • Repeat above step for the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector.

Less than +20 VDC for 12 volt system

Less than +32 VDC for 24 volt system?
YES NO
No Repair

Install the battery system correctly. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Jun-2014


FAULT CODE 451 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9.5 CM2150 SN | 4310608
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB3.9 CM2220 B107 | 4310792
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG11 CM2880 G106 | 4332695
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG12 CM2880 G107 | 4332690
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG11 CM2880 G108 | 4332901
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG12 CM2880 G109 | 4332906
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2880 L112 | 4358493
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F116 | 4383664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F129 | 5411325
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 or 515 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the fuel rail pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel rail pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 or 515 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor and circuit.

Guided Step 2A - Inspect the fuel rail pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the fuel rail pressure RETURN pin and the fuel rail pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the fuel rail pressure 5 volt SUPPLY pin to the fuel rail pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel rail pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO

A damaged sensor has been detected.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9.5 CM2150 SN | 4310608
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG11 CM2880 G106 | 4332695
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG12 CM2880 G107 | 4332690
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG11 CM2880 G108 | 4332901
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG12 CM2880 G109 | 4332906
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2880 L112 | 4358493
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2880 F112 | 4383825
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9.3 CM2880 L113 | 4383811
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISD6.7 CM2880 D101 | 5411372
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F129 | 5411325
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 516 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 or 516 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 584 - Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 584 active?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Less than 10k ohms?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the starter lockout relay circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Replace the starter lockout relay. See the equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the connection malfunction.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the starter lockout relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 585 - Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
STEP 2. | Check starter lockout relay and circuit. |
 | STEP 2A. Inspect starter relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the starter lockout relay resistance. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin to ground short circuit in the starter lockout relay. |
 | STEP 2C. Check the starter lockout relay diagnostic supply voltage, SUPPLY wire, and return circuit. | Greater than 3.75-VDC?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 585 is inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check starter lockout relay and circuit.

Guided Step 2A - Inspect starter relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the starter lockout relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the relay resistance.

  • Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the starter lockout relay. See the equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin to ground short circuit in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the starter lockout relay. See the equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the starter lockout relay diagnostic supply voltage, SUPPLY wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the starter lockout relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 596 - Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Voltages at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
STEP 2. | Check the charging system. |
 | STEP 2A. Inspect the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltages at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within original equipment manufacturer (OEM) specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Jan-2014


FAULT CODE 597 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use these test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Battery voltage at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
STEP 2. | Check the alternator and power harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
 | STEP 2B. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit. | Greater than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Any damaged wires?
 | STEP 2E. Check for a short circuit in the power harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Battery voltage at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and power harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within original equipment manufacturer (OEM) specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins of the OEM power harness ECM connector and the positive (+) battery terminal.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the battery harness.

Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins and the ECM battery SUPPLY (-) pins of the ECM power harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit in the SUPPLY wire to the engine block.

Any damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins in the OEM power harness connector to all pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Jan-2014


FAULT CODE 598 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Voltages at least (+) 12-VDC during normal conditions and at least (+) 6.2-VDC during cranking?
STEP 2. | Check the alternator and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
 | STEP 2B. Inspect the battery power connector. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the power harness. | Greater than 100k ohms?
 | STEP 2E. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes.. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltages at least (+) 12-VDC during normal conditions and at least (+) 6.2-VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and original equipment manufacturer (OEM) harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (ampere).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

Refer to the OEM service manual manual.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness from the battery at the power connector.

Action

Inspect the battery power connector on both the battery side and the harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the battery power connector.

Refer to the OEM service manual for location and procedure.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM

Action

Check for an open circuit.

  • Measure the resistance of the ECM battery supply (+) circuit between the OEM power harness connector and the positive (+) terminal of the battery.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the ECM battery SUPPLY (+) pins and all other pins of the power harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit at the SUPPLY wire to the engine block ground.

Damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Jan-2014


FAULT CODE 649 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 649. | Fault Code 649 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 649.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 649.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 649 active?
YES NO

Change the engine lubricating oil and filter.

Use INSITE™ electronic service tool to reset the Maintenance Monitor.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jun-2014


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2150 B108 | 4326163
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2150 B109 | 4326168
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB7 CM2880 B117 | 4358390
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9.5 CM2150 SN | 4310608
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB3.9 CM2220 B107 | 4310792
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G106 | 4332695
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G107 | 4332690
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G108 | 4332901
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G109 | 4332906
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F104 | 4332741
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F108 | 4332746
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2880 L112 | 4358493
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2880 B126 | 4383693
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2880 F112 | 4383825
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 CM2880 B127 | 4383645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9.3 CM2880 L113 | 4383811
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F116 | 4383664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSC8.3 CM2880 C102 | 4388785
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.9 CM2880 B138 | 5411050
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB5.9 CM2880 B139 | 4388870
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISD6.7 CM2880 D101 | 5411372
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F129 | 5411325
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 to 5.25-VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

  • Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components. Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the air gap and target wheel.

  • Remove the crankshaft position sensor from the engine block and measure the air gap at several points in the crankshaft's revolution.

Refer to Procedure 019-365 in the Associated Procedures Table.

Is the air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25-VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 697 - Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 697 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 698 - Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 698 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 699 - ECM Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active?
YES NO

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 731 - Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Camshaft | Refer to Procedure 001-008 | ISL9.5 CM2150 SN | 4310608
Camshaft | Refer to Procedure 001-008 | ISB3.9 CM2220 B107 | 4310792
Camshaft | Refer to Procedure 001-008 | QSB4.5 CM2120 B108 | 4326163
Camshaft | Refer to Procedure 001-008 | QSB6.7 CM2150 B109 | 4326168
Camshaft | Refer to Procedure 001-008 | ISL8.9 CM2880 L112 | 4358493
Camshaft | Refer to Procedure 001-008 | ISB5.9 CM2880 B127 | 4383645
Camshaft | Refer to Procedure 001-008 | QSF3.8 CM2880 F112 | 4383825
Camshaft | Refer to Procedure 001-008 | ISB/ISD6.7 CM2880 B126 | 4383693
Camshaft | Refer to Procedure 001-008 | QSL9.3 CM2880 L113 | 4383811
Camshaft | Refer to Procedure 001-008 | QSC8.3 CM2880 C102 | 4388785
Camshaft | Refer to Procedure 001-008 | QSB3.9 CM2880 B138 | 5411050
Camshaft | Refer to Procedure 001-008 | QSB5.9 CM2880 B139 | 4388870
Camshaft | Refer to Procedure 001-008 | ISD6.7 CM2880 D101 | 5411372
Camshaft | Refer to Procedure 001-008 | ISF4.5 CM2220 F123 | 5411320
Crankshaft | Refer to Procedure 001-016 | ISL9.5 CM2150 SN | 4310608
Crankshaft | Refer to Procedure 001-016 | ISB3.9 CM2220 B107 | 4310792
Crankshaft | Refer to Procedure 001-016 | QSB4.5 CM2120 B108 | 4326163
Crankshaft | Refer to Procedure 001-016 | QSB6.7 CM2150 B109 | 4326168
Crankshaft | Refer to Procedure 001-016 | ISG11 CM2880 G106 | 4332695
Crankshaft | Refer to Procedure 001-016 | ISG12 CM2880 G107 | 4332690
Crankshaft | Refer to Procedure 001-016 | ISG11 CM2880 G108 | 4332901
Crankshaft | Refer to Procedure 001-016 | ISG12 CM2880 G109 | 4332906
Crankshaft | Refer to Procedure 001-016 | ISL8.9 CM2880 L112 | 4358493
Crankshaft | Refer to Procedure 001-016 | ISB5.9 CM2880 B127 | 4383645
Crankshaft | Refer to Procedure 001-016 | QSF3.8 CM2880 F112 | 4383825
Crankshaft | Refer to Procedure 001-016 | ISB/ISD6.7 CM2880 B126 | 4383693
Crankshaft | Refer to Procedure 001-016 | QSL9.3 CM2880 L113 | 4383811
Crankshaft | Refer to Procedure 001-016 | QSC8.3 CM2880 C102 | 4388785
Crankshaft | Refer to Procedure 001-016 | QSB3.9 CM2880 B138 | 5411050
Crankshaft | Refer to Procedure 001-016 | QSB5.9 CM2880 B139 | 4388870
Crankshaft | Refer to Procedure 001-016 | ISD6.7 CM2880 D101 | 5411372
Crankshaft | Refer to Procedure 001-016 | ISF4.5 CM2220 F123 | 5411320
Crankshaft | Refer to Procedure 001-016 | QSG12 CM2880 G112 | 4388731
Gear Cover, Front | Refer to Procedure 001-031 | ISL9.5 CM2150 SN | 4310608
Gear Cover, Front | Refer to Procedure 001-031 | ISB3.9 CM2220 B107 | 4310792
Gear Cover, Front | Refer to Procedure 001-031 | QSB4.5 CM2120 B108 | 4326163
Gear Cover, Front | Refer to Procedure 001-031 | QSB6.7 CM2150 B109 | 4326168
Gear Cover, Front | Refer to Procedure 001-031 | ISG11 CM2880 G106 | 4332695
Gear Cover, Front | Refer to Procedure 001-031 | ISG12 CM2880 G107 | 4332690
Gear Cover, Front | Refer to Procedure 001-031 | ISG11 CM2880 G108 | 4332901
Gear Cover, Front | Refer to Procedure 001-031 | ISG12 CM2880 G109 | 4332906
Gear Cover, Front | Refer to Procedure 001-031 | ISL8.9 CM2880 L112 | 4358493
Gear Cover, Front | Refer to Procedure 001-031 | ISB5.9 CM2880 B127 | 4383645
Gear Cover, Front | Refer to Procedure 001-031 | QSF3.8 CM2880 F112 | 4383825
Gear Cover, Front | Refer to Procedure 001-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Gear Cover, Front | Refer to Procedure 001-031 | QSL9.3 CM2880 L113 | 4383811
Gear Cover, Front | Refer to Procedure 001-031 | QSC8.3 CM2880 C102 | 4388785
Gear Cover, Front | Refer to Procedure 001-031 | QSB3.9 CM2880 B138 | 5411050
Gear Cover, Front | Refer to Procedure 001-031 | QSB5.9 CM2880 B139 | 4388870
Gear Cover, Front | Refer to Procedure 001-031 | ISD6.7 CM2880 D101 | 5411372
Gear Cover, Front | Refer to Procedure 001-031 | ISF4.5 CM2220 F123 | 5411320
Gear Cover, Front | Refer to Procedure 001-031 | QSG12 CM2880 G112 | 4388731
Overhead Camshaft Timing Speed Ring | Refer to Procedure 002-034 | ISG11 CM2880 G106 | 4332695
Overhead Camshaft Timing Speed Ring | Refer to Procedure 002-034 | ISG12 CM2880 G107 | 4332690
Overhead Camshaft Timing Speed Ring | Refer to Procedure 002-034 | ISG11 CM2880 G108 | 4332901
Overhead Camshaft Timing Speed Ring | Refer to Procedure 002-034 | ISG12 CM2880 G109 | 4332906
Overhead Camshaft Timing Speed Ring | Refer to Procedure 002-034 | QSG12 CM2880 G112 | 4388731
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9.5 CM2150 SN | 4310608
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB3.9 CM2220 B107 | 4310792
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2120 B108 | 4326163
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2150 B109 | 4326168
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G106 | 4332695
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G107 | 4332690
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G108 | 4332901
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G109 | 4332906
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2880 L112 | 4358493
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 CM2880 B127 | 4383645
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2880 F112 | 4383825
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD6.7 CM2880 B126 | 4383693
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9.3 CM2880 L113 | 4383811
Camshaft Position Sensor | Refer to Procedure 019-363 | QSC8.3 CM2880 C102 | 4388785
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.9 CM2880 B138 | 5411050
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB5.9 CM2880 B139 | 4388870
Camshaft Position Sensor | Refer to Procedure 019-363 | ISD6.7 CM2880 D101 | 5411372
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF4.5 CM2220 F123 | 5411320
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2880 G112 | 4388731
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9.5 CM2150 SN | 4310608
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB3.9 CM2220 B107 | 4310792
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2120 B108 | 4326163
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2150 B109 | 4326168
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G106 | 4332695
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G107 | 4332690
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G108 | 4332901
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G109 | 4332906
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2880 L112 | 4358493
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 CM2880 B127 | 4383645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2880 F112 | 4383825
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2880 B126 | 4383693
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9.3 CM2880 L113 | 4383811
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSC8.3 CM2880 C102 | 4388785
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.9 CM2880 B138 | 5411050
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB5.9 CM2880 B139 | 4388870
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISD6.7 CM2880 D101 | 5411372
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the tone wheels and speed/position sensors. |
 | STEP 1A. Inspect the engine speed and position sensors for damage. | Damage found?
 | STEP 1B. Inspect the tone wheels for any damage. | Damage found?
STEP 2. | Check for correct engine static timing. |
 | STEP 2A. Check static timing. | Camshaft and crankshaft gears properly installed?
 | STEP 2B. Inspect the gear train. | Damage found?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the tone wheels and speed/position sensors.

Guided Step 1A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine speed and position sensors for damage.

Damage found?
YES NO

Replace the speed or position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft tone wheels for damage.

Damage found?
YES NO

Replace the tone wheel.

Use the following procedure for crankshaft removal and installation. Refer to Procedure 001-016 in the Associated Procedures Table.

Use the following procedure for camshaft removal and installation on ISG11 and ISG12 engines. Refer to Procedure 002-034 in the Associated Procedures Table.

Use the following procedure for camshaft removal and installation on all other engines. Refer to Procedure 001-008 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check for correct engine static timing.

Guided Step 2A - Check static timing.

Conditions

  • Turn keyswitch OFF.
  • Remove the gear cover. Refer to Procedure 001-031 in the Associated Procedures Table.
  • Rotate the engine to top dead center (TDC) for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned.
  • Use the following procedure for ISG11 and ISG12 engines. Refer to Procedure 002-034 in the Associated Procedures Table.
  • Use the following procedure for all other engines. Refer to Procedure 001-008 in the Associated Procedures Table.

Action

Inspect the engine static timing.

Camshaft and crankshaft gears properly installed?
YES NO
No Repair

Install the camshaft and crankshaft gear correctly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the gear train.

Conditions

  • Turn keyswitch OFF.

Action

Remove the gear cover.

Refer to Procedure 001-031 in the Associated Procedures Table.

Inspect the gear train for damage that would lead to slippage.

Damage found?
YES NO

  • Repair the damaged components.
  • Use the appropriate service manual for repair procedure.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Oct-2017


FAULT CODE 778 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2120 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9.5 CM2150 SN | 4310608
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G106 | 4332695
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G107 | 4332690
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB3.9 CM2220 B107 | 4310792
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2120 B108 | 4326163
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2150 B109 | 4326168
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB7 CM2880 B117 | 4358390
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G108 | 4332901
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G109 | 4332906
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F104 | 4332741
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F108 | 4332746
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2880 L112 | 4358493
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2880 F112 | 4383825
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD6.7 CM2880 B126 | 4383693
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 CM2880 B127 | 4383645
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9.3 CM2880 L113 | 4383811
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 F116 | 4383664
Camshaft Position Sensor | Refer to Procedure 019-363 | QSC8.3 CM2880 C102 | 4388785
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.9 CM2880 B138 | 5411050
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB5.9 CM2880 B139 | 4388870
Camshaft Position Sensor | Refer to Procedure 019-363 | ISD6.7 CM2880 D101 | 5411372
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F129 | 5411325
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF4.5 CM2220 F123 | 5411320
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for fault code. | Fault Code 778 active or inactive?
STEP 2. | Check the camshaft position sensor and connector. |
 | STEP 2A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the camshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the camshaft position sensor circuit. |
 | STEP 3A. Check the camshaft position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open camshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Verify adequate camshaft position sensor air gap. |
 | STEP 3B-4. Check the fault code and verify the camshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify camshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active or inactive?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the camshaft position sensor and connector.

Guided Step 2A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the camshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Remove the camshaft position sensor from the gear housing. Refer to Procedure 019-363 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed then inspect the camshaft gear and related components. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the camshaft position sensor circuit.

Guided Step 3A - Check the camshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor 1 RETURN pin at the camshaft position sensor connector of the engine wiring harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the engine control module (ECM) and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open camshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the camshaft position sensor SIGNAL pin at the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the camshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Verify adequate camshaft position sensor air gap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the camshaft position sensor from the gear housing and measure the air gap at several points in the camshaft's revolution.

Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the camshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

A damaged camshaft position sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor RETURN pin at the ECM.

Reference the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify camshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 active?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check battery ground(s), engine block, and chassis ground. | Connections tight and corrosion-free?
 | STEP 3D. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3E. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3F. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 active?
YES NO
No Repair

If high inactive counts of Fault Code 1117 are found in the ECM, check the battery disconnect devices in the vehicle.

If the keyswitch and ECM power are disconnected at the same time, Fault Code 1117 will be logged.

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. See the equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system];

During cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See the equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness/OEM harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM power harness/OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness/OEM harness connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the OEM power harness/OEM harness connector and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM harness from the OEM power connector to the batteries.

  • Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 3C - Check battery ground(s), engine block, and chassis ground.

Conditions

  • Turn keyswitch OFF.

Action

Check battery ground(s), engine block, and chassis ground.

  • Check all battery ground(s), engine block, and chassis ground for properly grounded, tightened, and free of corrosion.

See equipment manufacturer service information and wiring diagram for grounds information.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness/OEM harness connector from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM power harness/OEM harness connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the OEM power harness/OEM harness connector and the negative battery connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the OEM power harness/OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO
No Repair

Correct the wiring so the wire is uninterrupted.

Go to 4A

Go to 3F

Guided Step 3F - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Apr-2017


FAULT CODE 1239 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
STEP 2. | Check the accelerator pedal position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1241 active and Fault Code 1239 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 1239 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1239 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1695.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active and Fault Code 1239 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location.

Replace the accelerator pedal or lever. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 1241 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSC3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSC5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1239 active and Fault Code 1241 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 1241 is active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1241 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal position sensor supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the accelerator pedal position 5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active and Fault Code 1241 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active?
YES NO

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal. See the equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 1242 - Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Codes 131, 132, 1239, or 1241 active?
STEP 2. | Check the accelerator pedal position sensor readings. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 132 and 1241 both active?
 | STEP 2C. Check the accelerator pedal position 1 sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the accelerator pedal position 2 sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2E. Check the fault codes. | Fault Code 1242 inactive?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 131, 132, 1239, or 1241 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor readings.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 132 and 1241 both active?
YES NO
No Repair

If Fault Code 132 did not go active, follow Fault Code 132 troubleshooting tree.

If Fault Code 1241 did not go active, follow Fault Code 1241 troubleshooting tree.

Go to 2C

Appropriate fault code troubleshooting tree

Guided Step 2C - Check the accelerator pedal position 1 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal position 1 sensor +5 volt SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 132 troubleshooting tree.

Go to 2D

Fault Code 132 troubleshooting tree

Guided Step 2D - Check the accelerator pedal position 2 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal position 2 sensor +5 volt SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 1241 troubleshooting tree.

Go to 2E

Fault Code 1241 troubleshooting tree

Guided Step 2E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1242 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 1 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal. Refer to Procedure 019-071 in Section 19.

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Jun-2014


FAULT CODE 1671 - Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1671 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1671 active?
YES NO

Low catalyst solution level has been detected.

Add catalyst solution to the catalyst solution tank.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Sep-2012


FAULT CODE 1673 - Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1673 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1673 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) level has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2015


FAULT CODE 1677 - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1677 inactive?
STEP 2. | Check the aftertreatment deisel exhaust fluid (DEF) tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active and Fault Code 1677 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1677 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active and Fault Code 1677 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1677 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active and Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

Replace the aftertreatment DEF tank temperature sensor.

Refer to original equipment manufacturer (OEM) service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 is active and Fault Code 1677 is inactive?
YES NO
No Repair

Replace the ECM. 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness. 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness. 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2016


FAULT CODE 1678 - Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1678 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1678 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1677 active and Fault Code 1678 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1678 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code.Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Measure the sensor resistance.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin and aftertreatment DEF tank temperature sensor RETURN pin at the aftertreatment DEF tank temperature sensor.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the aftertreatment DEF tank temperature sensor.

Refer to the original equipment manufacturer (OEM) service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank temperature sensor SIGNAL pin and the aftertreatment DEF tank temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use a wiring diagram for pin identification.

Fault Code 1677 active and Fault Code 1678 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment DEF tank temperature sensor RETURN pin and the engine harness aftertreatment DEF tank temperature sensor connector RETURN pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment DEF tank temperature sensor SIGNAL pin and the engine harness aftertreatment DEF tank temperature sensor connector SIGNAL pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF tank temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 1678 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2016


FAULT CODE 1694 - Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISG11 CM2880 G106 | 4332695
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISG12 CM2880 G107 | 4332690
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL8.9 CM2880 L112 | 4358493
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISD6.7 CM2880 D101 | 5411372
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISG11 CM2880 G106 | 4332695
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISG12 CM2880 G107 | 4332690
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL8.9 CM2880 L112 | 4358493
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF2.8 CM2220 F129 | 5411325

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes are present?
 | STEP 1B. Check the exhaust system. | Aftertreatment outlet NOx sensor installed correctly and the exhaust system free of leaks?
 | STEP 1C. Check the selective cataylic reduction (SCR) catalyst dosing control unit for proper operation. | SCR catalyst dosing control unit operates correctly during INSITE™ electronic service tool override tests?
 | STEP 1D. Check for active fault codes. | Fault Code 1694 is active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Troubleshoot any other active fault codes first.
  • All other active fault codes must be resolved before following this troubleshooting tree.

Active fault codes are present?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the exhaust system.

Conditions

  • Remove the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Action

Check the exhaust system for the following:

  • Exhaust system leaks between the turbocharger and the aftertreatment SCR catalyst system.
  • Inspect the aftertreatment outlet NOx sensor for proper installation. Refer to Procedure 019-451 in the Associated Procedures Table.
  • Check the aftertreatment outlet NOx sensor tip for carbon buildup. Refer to Procedure 019-451 in the Associated Procedures Table.
  • Verify that the aftertreatment outlet NOx sensor part number is correct for this particular engine model.

Aftertreatment outlet NOx sensor installed correctly and the exhaust system free of leaks?
YES NO
No Repair

Repair the exhaust system or NOx sensor installation.

Refer to Procedure 019-451 in the Associated Procedures Table.

Refer to the original equipment manufacturer (OEM) service manual for correct exhaust system installation.

Go to 1C

Go to 2A

Guided Step 1C - Check the SCR catalyst dosing control unit for proper operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the SCR catalyst dosing control unit.

  • Use INSITE™ electronic service tool to perform the Urea Doser Pump Override Test found under ECM Aftertreatment Diagnostics Tests.

Use the following procedure for instructions and pass/fail criteria for air-assisted SCR dosing systems. Refer to Procedure 011-058 in the Associated Procedures Table.

Use the following procedure for instructions and pass/fail criteria for airless SCR dosing systems. Refer to Procedure 011-058 in the Associated Procedures Table.

The catalyst solution injector must be removed and placed in a measuring container in order to run this test. Be sure that the nozzle is not plugged and DEF is spraying from all holes.

SCR catalyst dosing control unit operates correctly during INSITE™ electronic service tool override tests?
YES NO
No Repair

Replace the SCR catalyst dosing control unit.

Use the following procedure for air-assisted SCR dosing systems. Refer to Procedure 011-058 in the Associated Procedures Table.

Use the following procedure for airless SCR dosing systems. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 1D

Go to 2A

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1694 is active?
YES NO

An in-range malfunction has been detected by the aftertreatment outlet NOx sensor.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 2A

Guided Step 2A - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2016


FAULT CODE 1852 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1852?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1852.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 1852?
YES NO

Drain water from the fuel filter.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If Necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jun-2014


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Check for a short circuit to battery in the OEM harness. | Greater than 100k ohms?
 | STEP 2B. Check for a short circuit to keyswitch power in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Check for a short circuit to battery in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to battery.

  • Measure the resistance and check for a short circuit between the accelerator pedal position +5 VOLT SUPPLY pin and the ECM battery SUPPLY (+) pins in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to keyswitch power in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to keyswitch power.

  • Check for a short circuit between the accelerator pedal position +5 VOLT SUPPLY pin and the ECM keyswitch SIGNAL pin in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ and test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin-to-ground short circuit in the OEM harness. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the accelerator pedal/lever position sensor.

See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector or ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal +5 volt SUPPLY and all other pins in the OEM harness ECM connector.

Refer to the circuit art or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator +5 volt SUPPLY pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jun-2014


FAULT CODE 2321 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2120 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 QSF2.8 CM2880 F108 | 4332741 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB3.9 CM2220 B107 | 4310792
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G106 | 4332695
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G107 | 4332690
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9.5 CM2150 SN | 4310608
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2120 B108 | 4326163
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2150 B109 | 4326168
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB7 CM2880 B117 | 4358390
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G108 | 4332901
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G109 | 4332906
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 K104 | 4332741
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 K108 | 4332746
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2880 L112 | 4358493
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 CM2880 B127 | 4383645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2880 F112 | 4383825
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2880 B126 | 4383693
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9.3 CM2880 L113 | 4383811
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F116 | 4383664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSC8.3 CM2880 C102 | 4388785
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.9 CM2880 B138 | 5411050
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB5.9 CM2880 B139 | 4388870
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISD6.7 CM2880 D101 | 5411372
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F129 | 5411325
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 active or has a high number of inactive counts?
STEP 2. | Check the primary speed sensor circuit (crankshaft sensor). |
 | STEP 2A. Inspect the primary speed sensor connector pins (crankshaft sensor). | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness engine control module (ECM) connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Fault Code 2321 become active during engine operation?
 | STEP 3B. Inspect the air gap and target wheel. | Air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Fault Code 2321 status change from inactive to active while manipulating the engine harness?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or has a high number of inactive counts?

If Fault Code 689 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

YES | NO
No Repair | No Repair

Reference Fault Code 689 troubleshooting tree

Go to 2A

Guided Step 2 - Check the primary speed sensor circuit (crankshaft sensor).

Guided Step 2A - Inspect the primary speed sensor connector pins (crankshaft sensor).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the primary speed sensor.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Check for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the primary speed sensor (crankshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. With the engine operating, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Fault Code 2321 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Remove the primary engine speed sensor (crankshaft) from the engine block and measure the air gap at several points in the crankshaft's revolution.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.96 mm [0.038 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2321 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector towards the engine speed sensor connector.

Fault Code 2321 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 2322 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2120 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 K104 QSF2.8 CM2880 K108 | 4332741 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB3.9 CM2220 B107 | 4310792
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9.5 CM2150 SN | 4310608
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2120 B108 | 4326163
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2150 B109 | 4326168
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB7 CM2880 B117 | 4358390
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G106 | 4332695
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G107 | 4332690
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G108 | 4332901
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G109 | 4332906
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 K104 | 4332741
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 K108 | 4332746
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2880 L112 | 4358493
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 CM2880 B127 | 4383645
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2880 F112 | 4383825
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD6.7 CM2880 B126 | 4383693
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9.3 CM2880 L113 | 4383811
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 F116 | 4383664
Camshaft Position Sensor | Refer to Procedure 019-363 | QSC8.3 CM2880 C102 | 4388785
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.9 CM2880 B138 | 5411050
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB5.9 CM2880 B139 | 4388870
Camshaft Position Sensor | Refer to Procedure 019-363 | ISD6.7 CM2880 D101 | 5411372
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F129 | 5411325
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF4.5 CM2220 F123 | 5411320
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 778 active or has a high number of inactive counts?
STEP 2. | Check the secondary speed sensor circuit (camshaft sensor). |
 | STEP 2A. Inspect the secondary speed sensor (camshaft sensor) connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Fault Code 2322 become active during engine operation?
 | STEP 3B. Inspect the air gap and target wheel. | Air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Fault Code 2322 status change from inactive to active while manipulating the engine harness?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active or has a high number of inactive counts?

If Fault Code 778 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

YES | NO
No Repair | No Repair

Reference Fault Code 778 troubleshooting tree

Go to 2A

Guided Step 2 - Check the secondary speed sensor circuit (camshaft sensor).

Guided Step 2A - Inspect the secondary speed sensor (camshaft sensor) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the secondary speed sensor.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the secondary speed sensor (camshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

With the engine operating, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Fault Code 2322 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the secondary engine speed sensor (camshaft sensor) from the gear housing and measure the air gap at several points in the camshaft's revolution. Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2322 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backward from the ECM connector toward the engine speed sensor connector.

Fault Code 2322 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 K104 QSF2.8 CM2880 K108 | 4332741 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM) , all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control solenoid. | Less than 10k ohms?
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage, SUPPLY wire, and return circuit. | Greater than 5 VDC?
 | STEP 2D. Check for an open circuit in the fan control solenoid return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufcturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness.

Action

Inspect the OEM harness and fan solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check fan control solenoid resistance.

  • Measure the resistance between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open circuit in the fan control solenoid has been detected.

Replace the fan control solenoid.

See the equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage, SUPPLY wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the fan control solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fan control solenoid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fan control solenoid RETURN pin in the engine harness and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM fan control solenoid SIGNAL pin and the OEM harness fan control solenoid connector fan control solenoid SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control solenoid signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fan control solenoid SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Dec-2016


FAULT CODE 2448 - Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISL9.5 CM2150 SN | 4310608
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2120 B108 | 4326163
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2150 B109 | 4326168
Cooling System | Refer to Procedure 008-018 | QSB7 CM2880 B117 | 4358390
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F104 QSF2.8 CM2880 F108 | 4332741 4332744
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2880 F112 | 4383825
Cooling System | Refer to Procedure 008-018 | QSL9.3 CM2880 L113 | 4383811
Cooling System | Refer to Procedure 008-018 | QSC8.3 CM2880 C102 | 4388785
Cooling System | Refer to Procedure 008-018 | QSB3.9 CM2880 B138 | 5411050
Cooling System | Refer to Procedure 008-018 | QSB5.9 CM2880 B139 | 4388870
Cooling System | Refer to Procedure 008-018 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2448. | Active or inactive counts of Fault Code 2448?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2448.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2448?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 2448 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 2555 - Engine Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 K104 QSF2.8 CM2880 K108 | 4332741 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the intake air heater relay. | Less than 100 ohms?
 | STEP 2C. Check the intake air heater diagnostic voltage, SUPPLY wire, and return circuit. | Greater than 3.75 VDC?
 | STEP 2D. Check for an open circuit in the intake air heater relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the intake air heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check the intake air heater relay resistance.

  • Measure the resistance between the intake air heater SIGNAL pin and the intake air heater RETURN pin at the intake air heater relay.

For 12 volt systems, both relays must be checked.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

An open circuit has been detected in the intake air heater relay.

Replace the intake air heater relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the intake air heater diagnostic voltage, SUPPLY wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the intake air heater supply voltage and return circuit.

  • Measure the voltage between the intake air heater relay signal line and the intake air heater relay RETURN wire at the intake air heater relay connector of the OEM harness.

For 12 volt systems, both leads must be tested.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the intake air heater relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the intake air heater relay RETURN pin at the intake air heater relay connector to ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness, if possible. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector intake air heater relay SIGNAL pin and the OEM harness intake air heater relay connector SIGNAL pin.

For 12 volt systems, both leads must be tested.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open intake air heater relay signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake air heater relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 2556 - Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 K104 QSF2.8 CM2880 K108 | 4332741 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2220 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2556 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2555 active and Fault Code 2556 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2556 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2556 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 active and Fault Code 2556 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake air heater relay to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 active?
YES NO

A damaged intake air heater relay has been detected.

Replace the intake air heater relay. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and ground.

For 12 volt systems, both leads must be tested.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the intake air heater relay wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake air heater SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 2963 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2120 B108 | 4326163
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2150 B109 | 4326168
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 K104 QSF2.8 CM2880 K108 | 4332741 4332746
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2880 B126 | 4383693
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor the coolant temperature. |
 | STEP 1A. Monitor the coolant temperature. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor the coolant temperature.

Guided Step 1A - Monitor the coolant temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature.

  • Use INSITE™ electronic service tool to monitor the Coolant Temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 2964 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 K104 QSF2.8 CM2880 K108 | 4332741 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor the intake manifold temperature. |
 | STEP 1A. Monitor the intake manifold temperature. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor the intake manifold temperature.

Guided Step 1A - Monitor the intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature.

  • Use INSITE™ electronic service tool to monitor the intake manifold temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

Replace the intake manifold temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 3163 - Aftertreatment SCR Intake Temperature Sensor Swapped - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 3142, 3143, 3144, 3146, 3147, or 3148 active?
STEP 2. | Check the temperature sensor configuration. |
 | STEP 2A. Check the circuit response. | Fault Code 3142 active?
 | STEP 2B. Check the circuit response. | Fault Code 3146 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142, 3143, 3144, 3146, 3147, or 3148 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the temperature sensor configuration.

Guided Step 2A - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the SCR intake temperature sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO

The SCR intake temperature and SCR outlet temperature sensor connectors are swapped.

Swap the wiring harness connections to the SCR intake temperature and SCR outlet temperature sensor.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the SCR intake temperature sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3146 active?
YES NO

The SCR intake temperature and SCR outlet temperature sensor connections are swapped.

Swap the wiring harness connections to the SCR intake temperature sensor and SCR outlet temperature sensor.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 3326 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 QSF2.8 CM2880 F104 | 4332741 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3326 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3326 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for ECM communication.

  • Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3326 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connector to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3326 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Dec-2016


FAULT CODE 3492 - Real Time Clock - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Is Fault Code 111 active?
STEP 2. | Verify fault condition and check ECM calibration. |
 | STEP 2A. Check for an active fault code. | Fault Code 3492 still active?
 | STEP 2B. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 111 troubleshooting tree.

Go to 2A

Guided Step 2 - Verify fault condition and check ECM calibration.

Guided Step 2A - Run diagnostic and verify that the fault condition exists.

Conditions

  • Turn keyswitch OFF.

Action

Perform the following steps in order to allow the diagnostic to run and complete and verify that the fault condition still exists.

  • Leave keyswitch off for at least 1 minute.
  • Turn keyswitch back on for 15 minutes.
  • At the end of 15 minutes, use INSITE™ electronic service tool to read the fault codes.

Fault Code 3492 active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Replace the ECM Refer to Procedure Refer to 019-031 in the Associated Procedures Table.

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Sep-2012


FAULT CODE 3681 - Aftertreatment Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISG11 CM2880 G106 | 4332695
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISG12 CM2880 G107 | 4332690
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL8.9 CM2880 L112 | 4358493

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3681 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment outlet mono-nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1-VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for the correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor correct for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
 | STEP 2F. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply | Voltage within 1-VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3681 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment outlet mono-nitrogen oxides (NOx) sensor circuit.

Guided Step 2A - Inspect aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at key ON while cranking the engine, and with the engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment outlet NOx sensor.

Action

Verify aftertreatment outlet NOx sensor is the correct sensor for the engine configuration.

The aftertreatment outlet NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment outlet NOx sensor is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment SCR catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics.

Fault Code 3681 active?
YES NO

Use NOx sensor service tool, Part Number 2892467, to test the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 2F

Go to 4A

Guided Step 2F - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment SCR catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can run its internal diagnostics.

Fault Code 3681 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage within 1-VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. Refer to the OEM service manual.

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage supply circuit.

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jul-2014


FAULT CODE 3735 - Engine Auxiliary Governor Switch - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1939 communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communications with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with the ECM?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check SAE J1939 communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM. Use a data link adapter (J1939) ECM connector.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM service manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM service manual.

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communications with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Connect the ECM bench calibration harness to the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM.Use a data link adapter (J1939) ECM connector.

INSITE™ electronic service tool communicates with the ECM?
YES NO

NSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM service manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

Refer to OEM service manual.

Refer to the Communication Error - Electronic Service Tool or Control Device Symptom troubleshooting tree.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 125 - Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Charge-Air Cooler | Refer to Procedure 010-027 | ISL9.5 CM2150 SN | 4310608
Air Intake Restriction | Refer to Procedure 010-031 | ISL9.5 CM2150 SN | 4310608
Exhaust Restriction | Refer to Procedure 011-009 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | High active or inactive counts of Fault Code 122, 123, 221, 222, or 295?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge-air cooler and charge-air plumbing for leaks. | Air leaks present in the charge-air system?
 | STEP 2B. Check for a restricted charge-air cooler. | Charge-air cooler restriction within specifications?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Check the intake manifold pressure sensor. | INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
STEP 4. | Check for restriction. |
 | STEP 4A. Check the exhaust system restriction. | Exhaust restriction within specifications?
 | STEP 4B. Check the intake restriction. | Air intake restriction within specifications?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of Fault Code 122, 123, 221, 222, or 295?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2B

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge-air cooler and charge-air plumbing for leaks.

Conditions

  • Operate the engine.

Action

Check the charge-air cooler and charge-air plumbing for leaks.

  • Check the charge-air cooler connections for leaks between the turbocharger compressor outlet and the charge-air cooler.
  • Check the charge-air cooler connections between the charge-air cooler and the intake manifold.
  • Check the air compressor inlet plumbing connections between the charge-air cooler and air compressor head for leaks.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge-air cooler hoses for leaks or loose connections.
  • Inspect the charge-air cooler clamps to make sure they are tight.
  • Inspect the charge-air plumbing for cracks.

Air leaks present in the charge-air system?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a restricted charge-air cooler.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the pressure differential across the charge-air cooler.

  • Refer to Procedure 010-027 in the Associated Procedures Table.

Charge-air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler as necessary.

Go to 3A

Go to 5A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold temperature/pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for restriction.

Guided Step 4A - Check exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check exhaust system restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO
No Repair

Continue to investigate the cause of the high exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications?
YES NO

Continue to troubleshoot the cause of low boost pressure.

  • Reference the Engine Performance Troubleshooting Tree - ISL9.5 CM2150 SN in Section TT.

Repair or replace the restricted component.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jun-2013


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISL9.5 CM2150 SN | 4310608
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the fuel rail pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the intake manifold pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the camshaft position sensor. Refer to 019-363 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel rail pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and the fuel rail pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the intake manifold pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Secdtion 19.

Go to 2A

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Replace the ECM. Refer to 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 1 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 449 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | ISL9.5 CM2150 SN | 4310608
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISL9.5 CM2150 SN | 2883445
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISL9.5 CM2150 SN | 4310608
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 449 active?
STEP 2. | Check the high-pressure fuel rail drain line restriction. |
 | STEP 2A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
STEP 3. | Inspect the fuel pressure relief valve. |
 | STEP 3A. Inspect the fuel pressure relief valve for tampering or wrong part number. | Was the correct fuel pressure relief valve part number installed and no tampering found?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 449 inactive?
 | STEP 4B. Check for active fault codes. | Fault Codes 1117 or 2311 active or high inactive counts?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the high-pressure fuel rail drain line restriction.

Guided Step 2A - Check drain line restriction.

Conditions

  • Keyswitch ON.
  • Engine running.

Action

Inspect the drain line from the high pressure relief valve to the OEM connection point for damage (obstructions, kinks, or crimps).

Check for excessive fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Replace the drain line or repair the source of the high fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the fuel pressure relief valve.

Guided Step 3A - Inspect the fuel pressure relief valve for tampering or wrong part number.

Conditions

  • Engine is not running.

Action

Make sure the correct fuel pressure relief valve part number is installed.

  • Look for tampering of the fuel pressure relief valve.

Was the correct fuel pressure relief valve part number installed and no tampering found?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

If replacing the fuel pump actuator does not resolve the issue, take the following action:

  • Replace the fuel pump. Refer to Procedure 005-016 in the Associated Procedures Table.

Repair the tampering or replace the fuel pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault Code 449 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1117 or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 545 - Turbocharger 1 Wastegate Control - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with INSITE™ electronic service tool. | Intake manifold pressure is less than 203.2 mm Hg [8 in Hg]?
 | STEP 1B. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct within 127 mm Hg [5 in Hg]?
 | STEP 1C. Check the system for tampering. | Tampering detected?
 | STEP 1D. Check the turbocharger wastegate operation. | Turbocharger wastegate operating properly?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify sensor accuracy with INSITE™ electronic service tool.

  • Monitor intake manifold pressure with INSITE™ electronic service tool with the keyswitch ON and the engine not running.

Intake manifold pressure is less than 203.2 mm Hg [8 in Hg]?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 1B

Repair Complete.

Guided Step 1B - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical intake manifold pressure gauge to the engine
  • Use INSITE™ electronic service tool to read the fault codes
  • Start the engine and compare the intake manifold pressure reading on the service tool monitor screen to the reading on the mechanical intake manifold pressure gauge.

The engine may need to be loaded before the pressure readings can be compared.

Sensor reading is within 127 mm Hg [5 in Hg]?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 1C

Go to 2A

Guided Step 1C - Check the system for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger and fuel system for the following:

  • Turbocharger wastegate tampering
  • Variable geometry turbocharger tampering
  • Fuel system tampering
  • Fuel system add-on electronic devices.

Tampering detected?
YES NO

Remove the tampering device.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check the turbocharger wastegate operation.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate actuator for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Turbocharger wastegate operating properly?
YES NO
No Repair

Replace the turbocharger wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Jul-2012


FAULT CODE 553 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9.5 CM2150 SN | 4310608
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 449, or 2311 active or high inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify rail fuel pressure sensor accuracy. | Is the correct fuel rail pressure sensor installed for the engine CPL?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
STEP 4. | Check the fuel pump actuator. |
 | STEP 4A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel pump actuator resistance. | Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
 | STEP 4C. Monitor the fuel rail pressure at idle. | Does Measured Fuel Rail Pressure deviate from Commanded Fuel Rail Pressure by more than 100 bar [1450 psi] and surge at idle?
 | STEP 4D. Inspect the fuel pump actuator for damage. | Is the fuel pump actuator damaged?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 271, 272, 449, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Verify fuel rail pressure sensor part number.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Check the fuel rail pressure sensor and make sure it is correct for the engine CPL.

Is the correct fuel rail pressure sensor installed for the engine CPL?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the fuel pump actuator.

Guided Step 4A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in the Associated Procedures Table.

Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Run the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor Commanded Fuel Rail Pressure and Measured Fuel Rail Pressure.

Does Measured Fuel Rail Pressure deviate from Commanded Fuel Rail Pressure by more than 100 bar [1450 psi] and surge at idle?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4D

Guided Step 4D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in the Associated Procedures Table.

Is the fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 554 - Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 451 and 452. | Fault Code 451 or 452 active?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 451 active?
 | STEP 2C. Check the circuit response. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pin?
 | STEP 3B. Check the circuit response. | Fault Code 451 active?
 | STEP 3C. Check the circuit response. | Fault Code 452 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 451 and 452.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 or 452 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the rail fuel pressure SIGNAL pin and the rail fuel pressure RETURN pin at the rail fuel pressure connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active?
YES NO

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the rail fuel pressure SIGNAL pin and the rail fuel pressure RETURN pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 452 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 559 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | ISL9.5 CM2150 SN | 4310608
Fuel System Diagnostics | Refer to Procedure 005-236 | ISL9.5 CM2150 SN | 4310608
Engine Control Module (ECM) Cooling Plate, Fuel Cooled | Refer to Procedure 006-006 | ISL9.5 CM2150 SN | 4310608
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Fuel Connector (Head Mounted) | Refer to Procedure 006-052 | ISL9.5 CM2150 SN | 4310608
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISL9.5 CM2150 SN | 4310608
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 271, 272, 322, 323, 324, 325, 331, 332, 352, 449, 451, 452, 1117, 1911, 2311, or 2372 active or inactive counts?
 | STEP 1B. Check for Fault Code 559. | Active or inactive counts of Fault Code 559 present in the Engine Control Module (ECM)?
 | STEP 1C. Check for adequate fuel supply. | Equipment/vehicle has adequate fuel supply?
STEP 2. | High-Pressure Leak Down Test. |
 | STEP 2A. Check the rail pressure decay. | Fuel rail pressure drop by more than 300 bar [4351 psi] in 60 seconds?
STEP 3. | Check the low-pressure fuel system. |
 | STEP 3A. Perform the low-pressure system check. | Engine passes the low-pressure system check?
 | STEP 3B. Check the fuel pump actuator condition. | Engine surges at idle and measured rail fuel pressure varies from the commanded fuel rail pressure by more than 100 bar [1450 psi] at idle?
STEP 4. | Check the high-pressure fuel system. |
 | STEP 4A. Check the injector return flow. | Injector return flow within the specifications outlined in the appropriate procedure?
 | STEP 4A-1. Check the high-pressure connector torque. |
 | STEP 4A-2. Check for individual leaking injectors. |
 | STEP 4B. Measure the high-pressure fuel rail return flow. | Fuel return flow within specifications outlined in the appropriate procedure?
STEP 5. | Fuel pump head. |
 | STEP 5A. Check the high-pressure fuel pump return flow. | Fuel return flow within the specifications outlined in the appropriate procedure?
 | STEP 5B. High-pressure injection pump flow test. | Fuel pump flow meets the specifications outlined in the appropriate procedure?
STEP 6. | Symptom based troubleshooting. |
 | STEP 6A. Engine is difficult to start or will not start. | Engine difficult to start or does not start?
 | STEP 6A-1. Check the injector return flow. |
 | STEP 6A-2. Check the high-pressure connector torque. |
 | STEP 6A-3. Check for individual leaking injectors. |
 | STEP 6A-4. Measure the high-pressure fuel rail return flow. |
 | STEP 6A-5. Inspect the fuel tank for debris. |
 | STEP 6B. Engine starts and stalls. | Engine shuts down or stalls?
 | STEP 6C. Road test unit. | Fault Code 559 becomes active during the road test?
 | STEP 6D. Fault Code 559 comes active during motoring. | Fault Code 559 becomes active during engine motoring?
 | STEP 6D-1. Check for drain line restriction. |
 | STEP 6E. Inspect the fuel tank for debris. | Debris present in the fuel tank?
 | STEP 6F. Inspect the engine control module (ECM) cooling plate check valve. | engine control module (ECM) cooling plate check valve shows signs of debris, rust, wear, or stickiness?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the engine control module (ECM) contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Initial checks.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271, 272, 322, 323, 324, 325, 331, 332, 352, 449, 451, 452, 1117, 1911, 2311, or 2372 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for Fault Code 559.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active or inactive Fault Code 559.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 559 present in the engine control module (ECM)?
YES | NO
No Repair | No Repair

Go to 1C

Repair complete

Guided Step 1C - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle's fuel gauge.
  • Verify there is fuel in the tank above the suction line.
  • Check the equipment/vehicle fuel gauge.

Equipment/vehicle has adequate fuel supply?
YES | NO
No Repair | No Repair

Go to 2A

Go to 7A

Guided Step 2 - High-Pressure Leak Down Test.

Guided Step 2A - Check the rail pressure decay.

Conditions

  • Perform the High-Pressure System Leak Down Test.

This test can not be performed if the engine does not start. If the engine does not start, skip this step and proceed to Step 3A.

Action

Check the rail pressure decay.

Fuel rail pressure drop by more than 300 bar [4351 psi] in 60 seconds?
YES NO

Inspect the high-pressure fuel system.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the low-pressure fuel system.

Guided Step 3A - Perform the low-pressure system check.

Conditions

  • Turn keyswitch ON.
  • Operate engine or engine not operating.

If the engine will start, make certain that the engine is at operating temperature before performing the test.

Action

Perform the low-pressure system check.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Engine Operating:

  • Measure the inlet restriction.
  • Check for air in the fuel.
  • Measure the gear pump pressure.
  • Measure the pressure drop at the fuel filter.

If the engine is difficult to start, measure the lift pump fuel flow.

Engine Not Operating:

  • Make sure the fuel system is primed.
  • Measure the lift pump flow.
  • Measure the gear pump pressure at cranking.

Engine passes the low-pressure system check?
YES NO
No Repair

Repair/replace the malfunctioning low-pressure system component as necessary and run the low-pressure system check again to verify the issue has been corrected.

Engine Operating, repair order priority:

  • Inlet restriction
  • Air in fuel
  • Fuel filter
  • Gear pump.

Engine Not Operating, repair order priority:

  • System is primed
  • Lift pump
  • Gear pump.

Go to 3B

Go to 7A

Guided Step 3B - Check the fuel pump actuator condition.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Connect INSITE™ electronic service tool.
  • Place INSITE™ electronic service tool in Monitor Mode.

This test can not be performed if the engine does not start. If the engine does not start, skip this step and proceed to Step 5A.

Action

Use INSITE™ electronic service tool to monitor the fuel rail pressure for 60 seconds.

  • Observe the commanded and measured rail pressure.

Pressure instability at idle due to a worn fuel pump actuator may be more repeatable when the engine is cold.

Engine surges at idle and measured rail fuel pressure varies from the commanded fuel rail pressure by more than 100 bar [1450 psi] at idle?

YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 5A

Guided Step 4 - Check the high-pressure fuel system.

Guided Step 4A - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Make certain that the engine is at operating temperature before performing the test.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector return flow within the specifications outlined in the appropriate procedure?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4A-1

Guided Step 4A-1 - Check the high-pressure connector torque.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector high-pressure connector torque.

  • Refer to Procedure 006-052 in the Associated Procedures Table.

Injector pressure connector torque meets specification outlined in the appropriate procedure?
YES NO
No Repair

Tighten the injector high-pressure connector.

Check the injector return flow again. Go back to Step 4A.

  • Refer to Procedure 006-052 in the Associated Procedures Table.

If the injector return flow is now within specification, go to Step 7A.

If the injector return flow is still high, proceed to the next step below.

Go to 4A-2

Go to 4A-2

Guided Step 4A-2 - Check for individual leaking injectors.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Make certain the engine is at operating temperature before performing the test.

Action

Check for fuel leaks at individual injectors.

Cap off each injector, one at a time, with the injector leakage isolation tool. The service tool must be installed with the engine OFF. Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel injector return flow within specifications outlined in the appropriate procedure with an injector capped off?
YES NO

Replace the high-pressure connector and injector for the cylinder that is causing the high injector return flow. Refer to Procedure 005-236 in the Associated Procedures Table.

Cap off additional injectors to identify the source of high injector return flow. Replace the high-pressure connector and injector for the cylinder(s) causing the high injector return flow. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 4B - Measure the high-pressure fuel rail return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Make certain the engine is at operating temperature before performing the test.

Action

Check for excessive fuel return from the high-pressure fuel rail.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel return flow within specifications outlined in the appropriate procedure?
YES NO

Make sure all high-pressure fuel lines are tightened to the correct specification.

Run the high-pressure leak down test again. If it fails, identify the source of the leak in the high-pressure system. If no leaks are identified from the injectors or rail after the second test, continue to Step 5A.

Replace the fuel rail pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Determine the reason the fuel rail pressure relief valve is leaking.

Examples:

  • Operation with the electronic fuel control valve unplugged.
  • Operation with a plugged fuel filter or excessive inlet restriction.

Go to 2A

Go to 7A

Guided Step 5 - Fuel pump head.

Guided Step 5A - Check the high-pressure fuel pump return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test ACTIVE, if available.

This test can be performed if the engine will not start. If the engine will not start, perform this test while cranking the engine.

If the engine will start, make certain the engine is at operating temperature before performing the test.

Action

Check for excessive fuel return from the high-pressure fuel pump.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel return flow within the specifications outlined in the appropriate procedure?
YES NO
No Repair

Replace the high-pressure fuel pump head.

  • Refer to Procedure 005-227 in the Associated Procedures Table.

While the fuel pump head is removed, inspect the cam housing for internal damage.

Go to 5B

Go to 7A

Guided Step 5B - High-pressure injection pump flow test.

Conditions

  • Turn keyswitch ON.
  • Crank the engine.

Action

Disconnect the high-pressure fuel line to the fuel rail from the high-pressure injection pump.

Check the high-pressure injection pump fuel flow. Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel pump flow meets the specifications outlined in the appropriate procedure?
YES NO
No Repair

Remove the fuel pump head and inspect for damaged or stuck plungers. While the pump head is removed, inspect the cam housing for internal damage.

If the fuel pump head damage or stuck plungers are found, replace the fuel pump head.

  • Refer to Procedure 005-227 in the Associated Procedures Table.

If the fuel pump head plungers are broken and/or internal cam housing damage is found, replace the fuel pump assembly.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 6A

Go to 7A

Guided Step 6 - Symptom based troubleshooting.

Guided Step 6A - Engine is difficult to start or will not start.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Attempt to start the engine.

Engine difficult to start or does not start?

YES | NO
No Repair | No Repair

Go to 6A-1

Go to 6B

Guided Step 6A-1 - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

This test can be performed if the engine will not start. If the engine will not start, perform this test while cranking the engine.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector return flow within specifications outlined in the appropriate procedure?
YES | NO
No Repair | No Repair

Go to 6A-4

Go to 6A-2

Guided Step 6A-2 - Check the high-pressure connector torque.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector high-pressure connector torque.

  • Refer to Procedure 006-052 in the Associated Procedures Table.

Injector pressure connector torque meets the specifications outlined in Procedure 006-052?
YES NO
No Repair

Tighten the injector high-pressure connector. Refer to Procedure 006-052 in the Associated Procedures Table.

Check the injector return flow again.

If the injector return flow is within specification, proceed to Step 7A.

Go to 6A-3

Go to 6A-3

Guided Step 6A-3 - Check for individual leaking injectors.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test ACTIVE, if available.

This test can be performed if the engine will not start. If the engine will not start, perform this test while cranking the engine.

Action

Check for fuel leaks at individual injectors.

Cap off each injector, one at a time, with the injector leakage isolation tool. The service tool must be installed with the engine OFF.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel injector return flow within specifications outlined in the appropriate procedure?
YES NO

Replace the high-pressure connector and injector for the cylinder that is causing the high injector return flow. Refer to Procedure 006-026 in the Associated Procedures Table.

Cap off additional injectors to identify the source of high injector return flow. Replace the high-pressure connector and injector for the cylinder(s) causing the high injector return flow.

Replace the injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the fuel connector(s). Refer to Procedure 006-052 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 6A-4 - Measure the high-pressure fuel rail return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

This test can be performed if the engine will not start. If the engine will not start, perform this test while cranking the engine.

Action

Check for excessive fuel return from the high-pressure fuel rail.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel return flow within specifications outlined in the appropriate procedure?
YES NO
No Repair

Replace the rail fuel pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Determine the reason the fuel rail pressure relief valve has been tripping.

Examples:

  • Operation with the electronic fuel control valve unplugged
  • Operation with a plugged fuel filter or excessive inlet restriction.

Go to 6A-5

Go to 7A

Guided Step 6A-5 - Inspect the fuel tank for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel tank for sources of intermittent fuel inlet restrictions, such as:

  • Shop rags
  • Sand
  • Cardboard
  • Plastic bags
  • Other debris.

Debris present in the fuel tank?
YES NO

Remove the fuel tank and clean out all debris.

Inspect the low-pressure fuel lines and low-pressure filter for debris.

Troubleshooting tree has been exhausted.

Review the Shop Talk section and/or go to the Engine Performance Troubleshooting Tree in Section TT for further troubleshooting assistance in the appropriate service manual.

Go to 7A

Engine Performance Troubleshooting Tree

Guided Step 6B - Engine starts and stalls.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Start the engine.

  • Start the engine and allow it to operate at idle for 1 minute.

Engine shuts down or stalls?
YES NO

If the engine shuts down or stalls within 15 seconds of startup, prime the fuel system and attempt to start the engine again. If the engine continues to shut down or stall within 15 seconds of startup, go to the Engine Performance Troubleshooting Tree in Section TT for further repair direction in the appropriate service manual.

If the engine shuts down or stalls more than 30 seconds after startup, replace the engine control module (ECM) cooling plate check valve.

  • Refer to Procedure 006-024 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 6C

Guided Step 6C - Road test unit.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Road test the unit until the CHECK ENGINE light turns ON or for a maximum of 30 minutes.

Make sure the unit is driven under load for at least 10 consecutive seconds during the road test.

  • Hard accelerations
  • Drive unit up a hill
  • Pull a trailer or load (if possible)

Make sure the unit is driven under motoring for at least 10 consecutive seconds during the road test.

  • Get the unit up to highway speed, remove foot from throttle pedal, and allow the unit to coast for at least 10 seconds.
  • Drive the unit down a hill, remove foot from throttle pedal, and allow the unit to coast for at least 10 seconds.

Make a note of the engine operating conditions when the CHECK ENGINE light turns ON.

Fault Code 559 becomes active during the road test?
YES NO
No Repair

Troubleshooting tree has been exhausted.

Go to 6D

Go to 7A

Guided Step 6D - Fault Code 559 comes active during motoring.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for Fault Code 559.

Use observations from previous road test.

Fault Code 559 becomes active during engine motoring?
YES | NO
No Repair | No Repair

Go to 6D-1

Go to 6E

Guided Step 6D-1 - Check for drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine at rated speed and at operating temperature.

Action

Operate the engine at rated speed and no load.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Drain line restriction within specification?
YES NO

Replace the fuel pump actuator housing. Refer to Procedure 005-228 in the Associated Procedures Table.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Correct the root cause of the fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 6E - Inspect the fuel tank for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel tank for sources of intermittent fuel inlet restrictions such as:

  • Shop rags
  • Sand
  • Cardboard
  • Plastic bags
  • Other debris.

Debris present in the fuel tank?
YES NO

Remove the fuel tank and clean out all debris.

Inspect the low-pressure fuel lines, low-pressure filter, low-pressure filter head, and engine control module (ECM) cooling plate connections for debris.

No Repair

Go to 7A

Go to 6F

Guided Step 6F - Inspect the engine control module (ECM) cooling plate check valve.

Conditions

  • Turn keyswitch OFF.

Action

Remove the engine control module (ECM) cooling plate check valve and inspect for signs of debris, rust, and/or sticking.

  • Refer to Procedure 006-006 in the Associated Procedures Table.

engine control module (ECM) cooling plate check valve shows signs of debris, rust, wear, or stickiness?
YES NO

Replace the engine control module (ECM) cooling plate check valve. Refer to Procedure 006-006 in the Associated Procedures Table.

Replace the rail fuel pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 7A - Check if an engine control module (ECM) calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the engine control module (ECM) code and revision in the engine control module (ECM) to the calibration revisions listed in the engine control module (ECM) Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present engine control module (ECM) code and revision number in the engine control module (ECM). The engine control module (ECM) code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the engine control module (ECM) contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the engine control module (ECM). Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 1668 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1668 inactive?
STEP 2. | Check the catalyst tank level sensor and circuit. |
 | STEP 2A. Inspect the catalyst tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1669 active and Fault Code 1668 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1668 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the electronic control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the electronic control module response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-361 in Section 19.

Go to 2A

Guided Step 2 - Check the catalyst tank level sensor and circuit.

Guided Step 2A - Inspect the catalyst tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.

Action

Inspect the engine harness and catalyst tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the catalyst tank level 5 volt SUPPLY pin to the catalyst tank level RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the catalyst tank level 5 volt SUPPLY pin to the catalyst tank level SIGNAL pin at the catalyst tank level sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition

Conditions

  • Turn keyswitch OFF.
  • Connect the catalyst tank level sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active?
YES NO

A damaged sensor has been detected.

Replace the catalyst tank level sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the catalyst tank level 5 volt SUPPLY pin to the catalyst tank level RETURN pin at the engine control module engine connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the engine control module and electronic harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the electronic control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the catalyst tank level 5 volt SUPPLY pin to the catalyst tank level SIGNAL pin at the engine control module engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 1668 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or pin to pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Sep-2012


FAULT CODE 1669 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1669 inactive?
STEP 2. | Check the catalyst tank level sensor and circuit. |
 | STEP 2A. Inspect the catalyst tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1669 active and Fault Code 1668 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1669 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the electronic control module response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect electronic control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?

YES | NO
No Repair | No Repair

Refer to Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the catalyst tank level sensor and circuit.

Guided Step 2A - Inspect the catalyst tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.

Action

Inspect the engine harness and catalyst tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank level SIGNAL pin and the aftertreatment diesel exhaust fluid tank level RETURN pin at the aftertreatment diesel exhaust fluid tank level OEM harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES NO
No Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the catalyst tank level +5 volt SUPPLY pin to the catalyst tank level RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the catalyst tank level sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 1669 active?
YES NO

A damaged sensor has been detected.

Replace the catalyst tank level sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the electronic control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank level SIGNAL pin and the aftertreatment diesel exhaust fluid tank level RETURN pin at the ECM.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active and Fault Code 1669 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect electronic control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and electronic control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the electronic control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the catalyst tank level +5 volt SUPPLY pin and the catalyst tank level RETURN pin at the engine control module engine connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Sep-2012


FAULT CODE 1679 - Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1677 or 1678 active?
STEP 2. | Check the aftertreatment DEF tank temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active?
 | STEP 2C. Check the circuit response. | Fault Code 1677 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active?
 | STEP 3C. Check the circuit response. | Fault Code 1677 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1677 or 1678 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment DEF tank temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1678 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank temperature SIGNAL pin and the aftertreatment DEF tank temperature RETURN pin at the aftertreatment DEF tank temperature connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 is active?
YES NO

Replace the aftertreatment DEF tank temperature sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the aftertreatment DEF tank temperature SIGNAL pin and aftertreatment DEF tank temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Sep-2012


FAULT CODE 1682 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Tank | Refer to Procedure 011-081 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Tank Level and Temperature Sensor | Refer to Procedure 019-488 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1668, 1669, 1677, 1678, 1712, 3242, 3559, 3565, 3566, 3571, 3572, 3577, or 3578 active?
 | STEP 1B. Check for low diesel exhaust fluid (DEF) tank level. | DEF tank empty and/or Fault Codes 1671 or 1673 active?
STEP 2. | Check the aftertreatment DEF dosing unit. |
 | STEP 2A. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine Critical Parts List (CPL)?
 | STEP 2B. Check for correct aftertreatment DEF dosing unit. | Aftertreatment DEF dosing unit is the correct voltage for the application?
 | STEP 2C. Inspect the DEF supply lines. | DEF lines correctly attached to the DEF dosing unit and the DEF tank?
STEP 3. | Check the aftertreatment DEF dosing unit and circuit. |
 | STEP 3A. Inspect the aftertreatment DEF dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Inspect the engine control module (ECM) and harness connector pins. | Dirty or damaged pins?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check the aftertreatment DEF tank filter. |
 | STEP 4A. Inspect the DEF tank filter for blockage. | DEF tank filter blocked?
STEP 5. | Perform the Diesel Exhaust Fluid Doser Pump Override Test. |
 | STEP 5A. Perform the Diesel Exhaust Fluid Doser Pump Override Test with INSITE™ electronic service tool. | Dosing control unit meet the specifications outlined in Procedure 011-063?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668, 1669, 1677, 1678, 1712, 3242, 3559, 3565, 3566, 3571, 3572, 3577, or 3578 active?
YES | NO
No Repair | No Repair

Reference the appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty, and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Code 1671 or 1673.

Diesel exhaust fluid tank empty and/or Fault Code 1671 or 1673 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF dosing unit.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter setting.

  • Use INSITE™ electronic tool "Features and Parameters" feature to determine electrical system voltage.
  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical system voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 2B

Go to 5A

Guided Step 2B - Check for correct aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.

Action

Verify the aftertreatment DEF dosing unit is the correct voltage for the application.

  • Check the aftertreatment DEF dosing unit dataplate for voltage.

NOTE: The aftertreatment DEF dosing unit is available in 12 or 24 volt versions.

Aftertreatment DEF dosing unit is the correct voltage for the application?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit with the correct part number for the application.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Inspect the DEF supply lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the DEF supply line.

  • Check for leaks and improper or loose connections between the aftertreatment DEF dosing unit and the tank.

DEF lines correctly attached to the DEF dosing unit and the DEF tank?
YES NO
No Repair

Repair the DEF supply line and connections.

  • Refer to Procedure 011-058 in the Associated Procedures Table.
  • Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 3A - Inspect the DEF dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the original equipment manufacturer (OEM) harness.

Action

Inspect the harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit or OEM harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the ECM and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit pump motor SIGNAL pin at the OEM harness ECM connector and aftertreatment DEF dosing unit pump motor SIGNAL pin at the dosing unit wiring harness connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit pump motor SUPPLY pin at the OEM harness ECM connector and aftertreatment DEF dosing unit pump motor SUPPLY pin at the dosing unit wiring harness connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit pump motor SIGNAL pin at the OEM harness ECM connector and other pins at the OEM harness ECM connector.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the aftertreatment DEF tank filter.

Guided Step 4A - Inspect the DEF tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Remove the tank level/temperature sensor from the DEF tank.

Action

Inspect the aftertreatment DEF tank filter for signs of blockage or buildup.

  • Refer to Procedure 011-081 in the Associated Procedures Table.
  • Refer to Procedure 019-488 in the Associated Procedures Table.

DEF tank filter blocked?
YES NO

Clean or replace aftertreatment DEF tank filter.

Drain, clean, and refill the aftertreatment DEF.

  • Refer to Procedure 011-081 in the Associated Procedures Table.
  • Refer to Procedure 019-488 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Perform the Diesel Exhaust Fluid Doser Pump Override Test.

Guided Step 5A - Perform the Diesel Exhaust Fluid Doser Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start engine and operate at low idle.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications for the Diesel Exhaust Fluid Doser Pump Override Test. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

Dosing control unit meet the specifications outlined in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit filter and damper. (Note that this filter and damper can not be reused and must be changed upon removal.)

  • Refer to Procedure 011-060 in the Associated Procedures Table.

Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test again with the new filter and damper. If the measured volume of DEF is still not within specifications, replace the aftertreatment DEF dosing unit.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Jun-2013


FAULT CODE 1683 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1683 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid relay and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment diesel exhaust fluid relay. | Less than 100 ohms?
 | STEP 2C. Check the aftertreatment diesel exhaust fluid diagnostic voltage, supply line and return circuit. | Greater than 6-VDC?
 | STEP 2D. Check for an open circuit in the aftertreatment diesel exhaust fluid return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the aftertreatment diesel exhaust fluid relay diagnostic supply voltage. | Greater than 6 VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1683 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid relay and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid relays from the engine harness.

Action

Inspect the engine harness and aftertreatment diesel exhaust fluid relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the aftertreatment diesel exhaust fluid relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid relays from the engine harness.

Action

Check aftertreatment diesel exhaust fluid relay resistance.

  • Measure the resistance between the aftertreatment diesel exhaust fluid SIGNAL pin and the aftertreatment diesel exhaust fluid RETURN pin at the aftertreatment diesel exhaust fluid relay.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment diesel exhaust fluid relay.

Replace the aftertreatment diesel exhaust fluid relay.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment diesel exhaust fluid diagnostic voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid relay from the engine harness.
  • Turn keyswitch ON.

Action

Check the aftertreatment diesel exhaust fluid supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel exhaust fluid relay SIGNAL line and the aftertreatment diesel exhaust fluid relay RETURN line at the aftertreatment diesel exhaust fluid relay connector of the engine harness.

Greater than 6 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the aftertreatment diesel exhaust fluid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid relay from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid relay RETURN pin in the engine harness and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open pin to ground circuit on the RETURN line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the OPEN RETURN circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment diesel exhaust fluid relay diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the aftertreatment diesel exhaust fluid relay diagnostic supplly voltage.

  • Measure the voltage between the aftertreatment diesel exhaust fluid relay signal pin and ground at ECM connector

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Greater than 6-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst heater relay from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment diesel exhaust fluid relay SUPPLY pin and the engine harness aftertreatment diesel exhaust fluid relay connector aftertreatment diesel exhaust fluid relay SUPPLY pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open aftertreatment diesel exhaust fluid SUPPLY circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid relay from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid relay SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin to pin short circuit on the aftertreatment diesel exhaust fluid relay SUPPLY line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 1684 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1684 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heater relay and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid tank heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 1683 active and fault code 1684 inactive?
 | STEP 2C. Check the fault codes and verify relay condition. | Fault code 1684 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault code 1683 active and fault code 1684 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1684 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. DCheck if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heater relay and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid tank heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater relays from the engine harness.

Action

Inspect the engine harness and aftertreatment diesel exhaust fluid tank heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment diesel exhaust fluid tank heater relays from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1683 active and fault code 1684 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify relay condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment diesel exhaust fluid tank heater relay from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Using INSITE™, read the fault codes

Fault code 1684 active?
YES NO

A malfunctioning aftertreatment diesel exhaust fluid tank heater relay has been detected.

Replace the aftertreatment diesel exhaust fluid tank heater relay.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1683 active and fault code 1684 inactive?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3E

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst heater relay from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater relay SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater relay from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater relay SUPPLY pin in the engine harness ECM connector and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin to ground short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 1712 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level correct?
STEP 3. | Check the aftertreatment diesel exhaust fluid tank heater operation. |
 | STEP 3A. Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heater control valve operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for diesel exhaust fluid tank heater or diesel exhaust fluid tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heating system.

Guided Step 2A - Inspect the diesel exhaust fluid tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including OEM in-line shutoff valve, if equipped)
  • Loose connections
  • Leaking seals or gaskets.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

Refer to OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check engine coolant level.

  • Make sure that the coolant level is within normal operating levels.

Coolant level correct?
YES NO
No Repair

Add coolant to the engine as necessary.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid tank heater operation.

Guided Step 3A - Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Refer to OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the diesel exhaust fluid tank heater control valve.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 1713 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active or high inactive counts ?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level correct?
STEP 3. | Check the aftertreatment diesel exhaust fluid tank temperature sensor. |
 | STEP 3A. Check the aftertreatment diesel exhaust fluid tank temperature sensor. | INSITE™ electronic service tool reading within 10°C or 18°F of infared thermometer reading?
STEP 4. | Check the aftertreatment diesel exhaust fluid tank heater operation. |
 | STEP 4A. Verify that the aftertreatment diesel exhaust fluid tank heater control valve is installed correctly. | Diesel exhaust fluid tank heater control valve installed correctly?
 | STEP 4B. Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heater control valve operating correctly?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for diesel exhaust fluid tank heater or diesel exhaust fluid tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, or 3576 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heating system.

Guided Step 2A - Inspect the diesel exhaust fluid tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including OEM in-line shutoff valve, if equipped)
  • Loose connections
  • Leaking seals or gaskets.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

Refer to OEM service manual.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check engine coolant level.

  • Make sure that coolant level is within normal operating levels.

Coolant level correct?
YES NO
No Repair

Add coolant to engine as necessary.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Guided Step 3A - Check the aftertreatment diesel exhaust fluid tank temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Measure the temperature of the diesel exhaust fluid in the diesel exhaust fluid tank with an infrared thermometer.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer.

INSITE™ electronic service tool reading within 10°C or 18°F of infared thermometer reading?
YES NO
No Repair

Replace the diesel exhaust fluid tank temperature sensor.

  • Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the aftertreatment diesel exhaust fluid tank heater operation.

Guided Step 4A - Verify that the aftertreatment diesel exhaust fluid tank heater control valve is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the installation of the tank heater control valve.

  • Make sure that the tank heater control valve is installed correctly, and not reversed.

Refer to OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve installed correctly?
YES NO
No Repair

Remove the diesel exhaust fluid tank heater control valve, and install it in the correct position. Make sure the valve is not reversed according to the coolant flow direction (where applicable).

Refer to the OEM service manual.

Go to 4B

Go to 5A

Guided Step 4B - Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Make sure the tank heater control valve is installed correctly, and not reversed.

Refer to OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the diesel exhaust fluid tank heater control valve.

Refer to OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 1887 - Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1887 inactive?
 | STEP 1B. Check for inactive fault codes. | Fault Code 1887 inactive?
STEP 2. | Check the aftertreatment outlet NOx sensor circuit. |
 | STEP 2A. Inspect the aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Is the voltage between 18 and 32-VDC?
 | STEP 2C. Check the batteries and the power connector. | Connections tight and corrosion free?
 | STEP 2D. Verify that the OEM fuse is installed correctly. | Is the fuse installed correctly, or has it been replaced?
 | STEP 2E. Check for an open circuit in the battery power circuit. | At least 22-VDC?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887 inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Engine is running.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it run for at least 2 minutes.

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887 inactive?
YES NO
No Repair

The aftertreatment outlet NOx sensor internal heater has malfunctioned.

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor 24 volt SUPPLY circuit and the aftertreatment outlet NOx sensor RETURN circuit at the OEM harness connector.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Refer to Procedure 019-359 in Section 19.

Is the voltage between 18 and 32-VDC?
YES NO

An out-of-range fault has been detected by the aftertreatment outlet NOx sensor control module.

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion free?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Clean the terminals and tighten the loose connections.

Refer to the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2D - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch ON.

Action

Verify the fuse is installed correctly.

The aftertreatment outlet NOx sensor power supply wire contains a 20-ampere fuse. This fuse is located in the OEM harness.

  • Inspect the OEM fuse for correct installation, or for a blown fuse.
  • Inspect the fuse for corrosion or damaged pins.

Is the fuse installed correctly, or has it been replaced?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage from the aftertreatment outlet NOx sensor SUPPLY (+) pin of the OEM harness to engine block ground.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Refer to Procedure 019-359 in Section 19.

At least 22-VDC?
YES NO

An open circuit in the OEM battery return circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

An open circuit in the OEM battery supply circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Jul-2012


FAULT CODE 1911 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump Gear Pump | Refer to Procedure 005-025 | ISL9.5 CM2150 SN | 4310608
Fuel System Diagnostics | Refer to Procedure 005-236 | ISL9.5 CM2150 SN | 4310608
Air in Fuel | Refer to Procedure 006-003 | ISL9.5 CM2150 SN | 4310608
Fuel Drain Line Restriction | Refer to Procedure 006-012 | ISL9.5 CM2150 SN | 4310608
Fuel Filter (Spin On Type) | Refer to Procedure 006-015 | ISL9.5 CM2150 SN | 4310608
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISL9.5 CM2150 SN | 4310608
Injector | Refer to Procedure 006-026 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Fuel Rail Pressure Sensor | Refer to Procedure 019-115 | ISL9.5 CM2150 SN | 4310608
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 449, 451, 452, 553, 1117, 2311, 2372, or 3727 active or any inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify rail fuel pressure sensor accuracy. | Is the fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
STEP 3. | Perform preliminary fuel system checks. |
 | STEP 3A. Check for air in the fuel. | Was there air in the fuel?
 | STEP 3B. Check the fuel inlet restriction at the OEM connection and gear pump. | Is the fuel inlet restriction within the specifications outlined in Procedure 006-020?
 | STEP 3C. Measure the pressure drop at the pressure side fuel filter. | Is the fuel pressure drop within the specifications outlined in Procedure 005-236?
STEP 4. | Check for fuel return drain line restriction. |
 | STEP 4A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
STEP 5. | Check the fuel pump actuator. |
 | STEP 5A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the fuel pump actuator resistance. | Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
 | STEP 5C. Monitor the fuel rail pressure at idle. | Does Measured Fuel Rail Pressure deviate more than 100 bar [1450 psi] and surge at idle?
 | STEP 5D. Inspect the fuel pump actuator for damage. | Is the fuel pump actuator damaged?
STEP 6. | Check the ECM to ground strap. |
 | STEP 6A. Inspect the ECM to ground strap. | Is the ECM to ground strap missing or are the connections degraded?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the fuel pump actuator shorted low or high.

Fault Code 271, 272, 449, 451, 452, 553, 1117, 2311, 2372, or 3727 active or any inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run INSITE™ electronic service tool monitor.
  • Fuel pressure relieved from the high-pressure fuel rail.
  • Engine not operating.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.
  • When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Once the engine is keyed OFF, there could be a significant amount of time waiting on the rail to depressurize to zero. It is necessary to manually relieve the pressure from the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail. Refer to Procedure 006-026 in the Associated Procedures Table.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 7A

Guided Step 3 - Perform preliminary fuel system checks.

Guided Step 3A - Check for air in the fuel.

Conditions

  • Keyswitch ON.
  • Engine operating.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Was there air in the fuel?
YES NO

A few bubbles exiting the line during the test is expected.

A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed.

If fuel inlet restriction is not excessive. Refer to Procedure 006-020 in the Associated Procedures Table.

The source of air entry should be isolated to one of the following:

  • Suction fuel lines
  • OEM fuel lines
  • Suction-side fuel filter assemblies
  • Stand-pipe(s) in the fuel tank(s).

 No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check the fuel inlet restriction at the OEM connection and gear pump.

Conditions

  • Keyswitch ON.
  • Engine operating.

Action

Check the fuel inlet restriction.

  • Refer to Procedure 006-020 in the Associated Procedures Table.

Is the fuel inlet restriction within the specifications outlined in Procedure 006-020?
YES NO
No Repair

If inlet restriction is excessive, search for the root cause:

  • Suction side fuel filters plugged
  • Fuel heater valves are restricted
  • OEM fuel lines pinched or restricted
  • Fuel tank stand pipes restricted.

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic , paper, etc.) that could intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that could intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers, filters, or malfunctioning check valves.

If no issues are found, replace the suction side fuel filter and prime the fuel system. Refer to Procedure 006-020 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Measure the pressure drop at the pressure side fuel filter.

Conditions

  • Keyswitch ON.
  • Engine operating.

Action

Measure the pressure drop.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Is the fuel pressure drop within the specifications outlined in Procedure 005-236?
YES NO
No Repair

Make sure the pump pressure into the filter is within specification. Refer to Procedure 005-236 in the Associated Procedures Table.

If the pressure from the gear pump is within specifications, replace the fuel filter and prime the fuel system. Refer to Procedure 006-015 in the Associated Procedures Table.

If the pressure from the gear pump is not within specifications, replace the gear pump. Refer to Procedure 005-025 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check for fuel return drain line restriction.

Guided Step 4A - Check drain line restriction.

Conditions

  • Keyswitch ON.
  • Engine operating.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel pump actuator.

Guided Step 5A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in the Associated Procedures Table.

Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
YES NO
No Repair

Replace the fuel pump actuator. Follow the correct torque sequence in the following procedure.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 5C

Go to 7A

Guided Step 5C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Run the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor Commanded Fuel Rail Pressure and Measured Fuel Rail Pressure.

Does Measured Fuel Rail Pressure deviate more than 100 bar [1450 psi] and surge at idle?
YES NO

Replace the fuel pump actuator. Follow the correct torque sequence in the following procedure.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 5D

Guided Step 5D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in the Associated Procedures Table.

Is the fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator. Follow the correct torque sequence in the following procedure.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the ECM to ground strap.

Guided Step 6A - Inspect the ECM to ground strap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM to ground strap.

  • Check the ground connections from the cylinder block to battery (-) negative.
  • Check the ground from the ECM to the cylinder block. Refer to Procedure 019-008 in Section 19.

Is the ECM to ground strap missing or are the connections degraded?
YES NO

Repair missing or degraded ground connections. Refer to the OEM Service manual.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 2182 - Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures Table
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758; female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917; male Weather Pack™ test lead, Part Number 3823995; female Weather Pack™ test lead, Part Number 3823996.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2182 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the engine harness. | Greater thank 100k ohms?
STEP 3. | Check the engine brake solenoid and circuit. |
 | STEP 3A. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3B. Check for an open circuit in the ECM. | Engine brake number 1 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2182 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an intermittent or inactive fault code. Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 1 wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL wire at the engine brake solenoid and the engine brake solenoid number 1 SIGNAL wire at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 1 signal circuit has been detected in the engine harness. The open circuit is in one of the following harnesses:

  • The main engine harness between the ECM and the 2 pin connector at the back of the engine
  • The engine brake jumper harness between the engine harness 2 pin connector at the back of the engine and the rocker lever housing
  • The internal engine brake harness between the rocker lever housing and the engine brake solenoid.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3B

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 wire from the engine brake pass through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid terminal pin-to-ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2.
  • Enable engine brake control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Set delay time to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 1 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Aug-2014


FAULT CODE 2183 - Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures Table
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758; female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917; male Weather Pack™ test lead, Part Number 3823995; female Weather Pack™ test lead, Part Number 3823996.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2183 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect ECM and engine harness pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater thank 100k ohms?
STEP 3. | Check the engine brake solenoid. |
 | STEP 3A. Check the engine brake solenoid for a short-to-ground. | 5 ohms or greater?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 1 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2183 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an intermittent or inactive fault code. Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damaged
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 1 SUPPLY wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL wire at the engine brake solenoid and the engine brake solenoid number 1 SIGNAL wire at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin indentification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 1 SIGNAL circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 from the engine brake pass through connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine brake actuator SIGNAL wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the short-to-ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 from the engine brake pass through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for a short-to-ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocket lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the engine brake number 1 solenoid terminal pin-to-ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance of the engine brake number 1 solenoid SUPPLY terminal pin-to-ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2.
  • Enable engine brake control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Set delay to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 1 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Aug-2014


FAULT CODE 2265 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Lift Pump | Refer to Procedure 005-045 | ISL9.5 CM2150 SN | 4310608
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2265 active?
STEP 2. | Check the electric fuel control lift pump. |
 | STEP 2A. Inspect the engine harness and electric fuel control lift pump connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the lift pump. | Less than 10 ohms?
 | STEP 2C. Check the fuel control lift pump diagnostic supply voltage and return circuit. | Voltage is between 2.5 and 4.0-VDC?
 | STEP 2D. Check for an open circuit in the fuel lift pump return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM lift pump diagnostic supply voltage. | Voltage is between 2.5 and 4.0-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2265 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the electric fuel control lift pump.

Guided Step 2A - Inspect the engine harness and fuel control lift pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel control lift pump.

Action

Inspect the engine harness and fuel control lift pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedure Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the lift pump.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel control lift pump.

Action

Check for an open circuit in the electric fuel control lift pump.

  • Measure the resistance between the electric fuel lift pump relay SUPPLY and the fuel lift pump RETURN pin at the electric fuel supply pump connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the electric fuel lift pump. Refer to Procedure 005-045 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel control lift pump diagnostic supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel pump.
  • Turn keyswitch ON.
  • Wait a minimum of 2 minutes.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the fuel lift pump SUPPLY pin and the fuel lift pump RETURN pin at the lift pump connector of the engine harness.

The keyswitch must be turned ON for more than 2 minutes before the check can be performed.

Use the circuit diagram or the wiring diagram for connector pin identification.

Voltage is between 2.5 and 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the fuel lift pump return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness lift pump RETURN pin and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM lift pump diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Wait a minimum of 2 minutes.

Action

Check the supply voltage.

  • Measure the voltage between the fuel lift pump SUPPLY pin and the fuel lift pump RETURN pin at the engine harness ECM connector port.

The keyswitch must be turned ON for more than 2 minutes before the check can be performed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage is between 2.5 and 4.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the lift pump from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel lift pump SUPPLY pin at the fuel lift pump connector and the fuel lift pump SUPPLY pin at the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the lift pump from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine harness ECM connector and all other pins in the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Jul-2012


FAULT CODE 2266 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Lift Pump | Refer to Procedure 005-045 | ISL9.5 CM2150 SN | 4310608
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2266 active?
STEP 2. | Check the electric fuel lift pump. |
 | STEP 2A. Inspect the engine harness and electric fuel lift pump connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2265 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2266 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2265 active?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2266 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 in Section 19.

Guided Step 2 - Check the electric fuel lift pump.

Guided Step 2A - Inspect the engine harness and fuel lift pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.

Action

Inspect the engine harness and fuel control lift pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel lift pump to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 active?
YES NO

A damaged fuel lift pump has been detected.

Replace the fuel lift pump. Refer to Procedure 005-045 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel lift pump from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel lift pump from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Jul-2012


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the fuel pump actuator valve. |
 | STEP 2A. Inspect the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel pump actuator resistance. | Less than 5 ohms?
 | STEP 2C. Check the fuel pump actuator for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2311, 271, and/or 272 become active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify the fuel pump actuator is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel pump actuator.

Guided Step 2A - Inspect the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the actuator connector.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the engine block ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the engine harness resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the ECM connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check the engine harness and fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the ECM connector of the engine harness and engine block ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine operating at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel pump actuator.

If a short or open circuit is induced while the engine is operating, the fuel rail pressure relief valve will open.

Fault Codes 2311, 271, and/or 272 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedure Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 4B

Go to 4B

Guided Step 4B - Disable fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Jul-2012


FAULT CODE 2363 - Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures Table
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758; female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917; male Weather Pack™ test lead, Part Number 3823995; female Weather Pack™ test lead, Part Number 3823996.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2363 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect ECM and engine harness pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid. |
 | STEP 3A. Check the engine brake solenoid for a short-to-ground. | 5 ohms or greater?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 2 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2363 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an intermittent or inactive fault code. Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 2 SUPPLY wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SUPPLY wire at the engine brake solenoid and the engine brake solenoid number 2 SIGNAL wire at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 2 SIGNAL circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine brake actuator SIGNAL wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 2 SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for a short-to-ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocket lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the engine brake number 2 solenoid terminal pin-to-ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance of the engine brake number 2 solenoid SUPPLY terminal pin-to-ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 1.
  • Turn keyswitch ON.
  • Enable engine brake control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Set delay time to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 2 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Aug-2014


FAULT CODE 2367 - Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures Table
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758; female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917; male Weather Pack™ test lead, Part Number 3823995; female Weather Pack™ test lead, Part Number 3823996.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2367 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect ECM and engine harness pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid and circuit. |
 | STEP 3A. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3B. Check for an open circuit in the ECM. | Engine brake number 2 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2367 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an intermittent or inactive fault code. Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 2 wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL wire at the engine brake solenoid to the engine brake solenoid number 2 SIGNAL wire at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 2 SIGNAL circuit has been detected in the engine harness. The open circuit is in one of the following harnesses:

  • The main engine harness between the ECM and the 2 pin connector at the back of the engine.
  • The engine brake jumper harness between the engine harness 2 pin connector at the back of the engine and the rocker level housing.
  • The internal engine brake harness between the rocker lever housing and the engine brake solenoid.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3B

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 wire from the engine brake pass through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 2 SIGNAL wire has been detected in the engine.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid terminal pin-to-ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 1.
  • Turn keyswitch ON.
  • Enable engine brake control feature
  • Set engine brake minimum vehicle speed to 0.
  • Set delay time to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 2 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Aug-2014


FAULT CODE 2771 - Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes | Fault Code 2771 inactive?
STEP 2. | Check the aftertreatment outlet NOx sensor circuit. |
 | STEP 2A. Inspect the aftertreatment outlet NOx sensor and connector pins. | Damaged or dirty pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage is within 1-VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine CPL?
 | STEP 2D. Check for correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor is the correct sensor for the engine CPL?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3A-1. Verify that the OEM fuse is installed correctly |
 | STEP 3A-2. Check for an open circuit in the battery power circuit. |
 | STEP 3B. Inspect the ECM and OEM harness connector pins. | Damaged or dirty pins?
 | STEP 3B-1. Check for an open circuit in the J1939 data link harness. |
 | STEP 3B-2. Check for a short circuit in the J1939 data link harness. |
 | STEP 3B-3. Check for a short circuit to ground in the J1939 data link harness. |
 | STEP 3B-4. Check the J1939 terminating resistance. |
 | STEP 3B-5. Check the fault codes. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage SUPPLY circuit and the aftertreatment outlet NOx sensor RETURN circuit at the NOx sensor wiring harness connector.

Check the voltage at key-ON, while cranking the engine, and with the engine at idle.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for instructions on how to use a multimeter. Refer to Procedure 019-359 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2CCheckforcorrrectadjustableparametersettings -

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

To configure the electrical system voltage to match the engine CPL, use INSITE™ electronic service tool.

Go to 2D

Go to 4A

Guided Step 2DCheckforcorrectaftertreatmentoutletNOxsensor. -

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment outlet NOx sensor.

Action

Verify aftertreatment outlet NOx sensor is the correct sensor for the engine CPL.

The aftertreatment outlet NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment outlet NOx sensor is the correct sensor for the engine CPL?
YES NO
No Repair

Replace the aftertreatment outlet NOx sensor.

019-451 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Tighten the connections.

Tighten the loose connections, and clean the terminals.

Refer to the OEM service manual.

Go to 3A-1

Go to 4A

Guided Step 3A-1 - Verify that the OEM fuse in installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

The aftertreatment outlet NOx sensor power supply wire contains a 20 amperes fuse. This fuse is located in the OEM harness.

  • Inspect the OEM fuse for correct installation, or for a blown fuse.

Is the fuse installed correctly, or has it been replaced?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 4A

Go to 4A

Guided Step 3A-2 - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the aftertreatment outlet NOx sensor SUPPLY (+) pin of the OEM harness to engine block ground.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Voltage is within 1-VDC of battery voltage?
YES NO

An open circuit in the OEM battery return circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

An open circuit in the OEM battery supply circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the aftertreatment outlet NOx sensor OEM harness connector and the SAE J1939 data link (+) wire at the ECM OEM harness connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the aftertreatment outlet NOx sensor OEM harness connector and the SAE J1939 data link (−) wire at the ECM OEM harness connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link harness.

Repair or replace the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the ECM OEM harness connector and all other pins in the connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (−) pins.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An short circuit has been detected in the J1939 data link harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (−) wire at the ECM OEM harness connector and ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An short circuit to ground has been detected in the J1939 data link harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-4

Go to 4A

Guided Step - 3B-4 Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the aftertreatment outlet NOx sensor OEM harness connector.

50 to 70 ohms?
YES NO
No Repair

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness.

Refer to the OEM service manual.

Go to 3B-5

Go to 4A

Guided Step 3B-5 - Check the fault codes.

Conditions

  • Turn keyswitch OFF
  • Connect the OEM harness to the ECM connector
  • Connect the aftertreatment outlet NOx sensor to the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Jul-2012


FAULT CODE 2772 - Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Exhaust Restriction | Refer to Procedure 011-009 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect vehicle fault codes. |
 | STEP 1A. Check for active counts of Fault Code 1694. | Fault Code 1694 active?
 | STEP 1B. Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738. | Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?
STEP 2. | Check the aftertreatment catalyst system. |
 | STEP 2A. Inspect the aftertreatment catalyst system for external leaks. | External leaks detected in the system?
 | STEP 2B. Check the exhaust back pressure. | Exhaust back pressure exceeds the limits provided in Procedure 011-009?
 | STEP 2C. Inspect the aftertreatment nozzle. | Plugged or restricted aftertreatment nozzle detected?
STEP 3. | Verify the priming cycle of the diesel exhaust fluid (DEF) dosing unit. |
 | STEP 3A. Check the DEF dosing unit during priming. | Dosing unit only prime for 3 seconds? (Plus the 140 second prime delay, if applicable.)
 | STEP 3B. Check the air solenoid operation during priming. | Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Will attempt to prime up to 20 times.)
 | STEP 3C. Confirm the successful priming of the DEF dosing unit. | Air flow above 25 liters per minute?
STEP 4. | Check the DEF dosing unit air supply system. |
 | STEP 4A. Inspect the air supply lines to the DEF dosing unit. | Original equipment manufacturer (OEM) air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
 | STEP 4B. Clear the DEF dosing unit air side circuit. Carry out the flushing procedure. | Flushing procedure successful?
STEP 5. | Check the DEF lines and fittings for restriction and contamination. |
 | STEP 5A. Check the DEF dosing unit fittings and lines. | DEF fittings and lines pass the inspections?
 | STEP 5B. Check the DEF dosing lines for restrictions or leaks. | Restriction line test completed successfully?
 | STEP 5C. Inspect the DEF tank and the 35 micron tank filter. | DEF tank contaminated or the urea solution less than 32.5%?
STEP 6. | Perform the Diesel Exhaust Fluid Doser Pump Override Test. |
 | STEP 6A. Perform the Diesel Exhaust Fluid Dosing Pump Override Test with INSITE™ electronic service tool. | Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test three times)
 | STEP 6B. Inspect the DEF dosing unit inline screen filter connection. | Contamination present at the screen filter?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect vehicle fault codes.

Guided Step 1A - Check for active counts of Fault Code 1694.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The following items must be checked or verified before continuing:

  • Check for active Fault Code 1694.

Fault Code 1694 active?
YES NO

Troubleshoot FC1694 before returning to this troubleshooting tree.

No Repair

Fault Code 1694 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check for inactive counts of Fault Code 1682, 3548, 3569, 3575 or 3738 in the ECM.

  • Look specifically for one or more inactive counts of Fault Code 1682, 3548, 3569, 3575 or 3738 within 50 engine hours of this fault code being set.

Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?

YES NO

Troubleshooting Fault Code 1682, 3548, 3569, 3575, or 3738 before returning to this fault code troubleshooting tree.

 No Repair

Fault Code 1682, 3548, 3569, 3575 or 3738 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment catalyst system.

Guided Step 2A - Inspect the aftertreatment catalyst system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment catalyst system.

  • Inspect aftertreatment catalyst and all attached exhaust pipework for signs of exhaust gas leakage or damage.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Measure the exhaust restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust back pressure exceeds the limits provided in Procedure 011-009?
YES NO
No Repair

Repair source or replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Go to 7A

Go to 32C

Guided Step 2C - Inspect the aftertreatment nozzle.

Conditions

  • Make sure the nozzle has been warmed in the exhaust prior to removal. Refer to Procedure 011-040 in the Associated Procedure Table.
  • Turn keyswitch OFF.
  • Remove the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedure Table.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedure Table.
  • Soft crystal and ash like buildup in the spray holes can be dissolved with 40°C [104°F] warm water.
  • Be sure that the soft buildup in the spray holes clears when the dosing unit begins dosing.

Plugged or restricted aftertreatment nozzle detected?
YES NO

Clean or replace the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Verify the priming cycle of the diesel exhaust fluid (DEF) dosing unit.

Guided Step 3A - Check the DEF dosing unit during priming.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check the DEF dosing unit during priming

  • After key ON with the engine operating, listen for the DEF dosing pump to start.
  • Time the pump operation until the pump automatically switches off (The pump is attempting to prime).

While the engine is operating it may be difficult to hear the pump. If this is the case, listen for the air solenoid to click, indicating that the pump has completed 1 prime attempt.

Older calibrations did not incorporate the 140 second delay from key on to initial prime cycle. During the 140 second delay the dosing unit will remain on standby before receiving the command to prime. This was introduced to remove any crystallization built up on injection tip prior to priming cycle and to avoid any blocked injection lines.

A correct prime cycle is as follows:

1. Turn keyswitch ON

2. 140 second pump start delay

3. Pump starts and operates for 30 seconds. (The system is now priming. This step may be attempted up to 20 times).

4. The DEF injection line will now exhaust air. Priming is now complete.

Dosing unit only prime for 3 seconds? (Plus the 140 second prime delay. if applicable.)

YES NO

Complete line restriction testing procedure then prime again. Refer to Procedure 011-086 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3B

Guided Step 3B - Check the air solenoid operation during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Be sure that the DEF dosing unit has successfully primed and entered the dosing state.

  • The DEF dosing unit enters the dosing state only when a successful prime is has completed, and the air solenoid has clicked.
  • At this point, air will be flowing continuously down the aftertreatment nozzle line.
  • The DEF dosing unit could attempt to prime for up to 12 minutes, at which point, if a prime is successful, the pump will switch off.
  • Use INSITE™ electronic service tool Data/Monitor Logger for Aftertreatment DEF Dosing Unit State to confirm the doser status.

Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Will attempt to prime up to 20 times.)

YES NO
No Repair

The DEF dosing unit has not primed.

Go to 3C

Go to 5A

Guided Step 3C - Confirm the successful priming of the DEF dosing unit.

Conditions

  • Turn keyswitch OFF for a minimum of 1 minute.
  • Disconnect the DEF line from the aftertreatment nozzle.
  • Attach the air flow meter to the DEF dosing line. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Secure the DEF dosing line and the attached air flow meter.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (Each prime attempt will take 30 seconds. If not successful, the doser will attempt to prime up to 20 times.) air should continuously flow through the DEF Injection line, and the attached air flow meter.

  • Record the measured air flow from the DEF dosing line.

Air flow above 25 l/min?
YES NO

Clean or replace the aftertreatment nozzle.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the DEF dosing unit air supply system.

Guided Step 4A - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Operate the engine at low idle.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for water or excessive oil from the vehicle's compressed air system.
  • Make sure a clean supply of air, at least 517 kPa [75 psi], pressure is present at the DEF dosing unit.

Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

Original equipment manufacturer (OEM) air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO
No Repair

Correct the OEM air supply connection or supply. Refer to the OEM service manual.

Go to 4B

Go to 3A

Guided Step 4B - Clear the DEF dosing unit air side circuit. Carry out the flushing procedure.

Conditions

  • Drain or isolate the OEM air supply circuit.
  • Remove the OEM air supply hose.

Action

Carry out the DEF dosing unit flushing procedure.

  • Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

Flushing procedure successful?
YES NO
No Repair

Replace the DEF dosing unit.

Go to 5A

Go to 7A

Guided Step 5 - Check the DEF lines and fittings for restriction and contamination.

Guided Step 5A - Check the DEF dosing unit fittings and lines.

Conditions

  • Clean the front fact of the doser before removing any lines.
  • Disconnect the DEF line from the aftertreatment nozzle and secure appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Inspect the DEF dosing unit fittings and lines for the following:

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any line. This is to prevent any contamination due to service intervention.

  • Loose DEF inlet connectors or fitting.
  • Cracked DEF lines, resulting in leaks or drawing in air.
  • Be sure DEF is returning to the tank during the priming cycle.

DEF fittings and lines pass the inspections?
YES NO
No Repair

Repair or replace DEF lines and / or connectors. Refer to the OEM service manual.

Go to 5B

Go to 3B

Guided Step 5B - Check the DEF dosing lines for restrictions or leaks

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Complete the line restriction procedure.

  • Refer to Procedure 011-086 in the Associated Procedures Table.
  • Check the DEF lines for leaks or restrictions.

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

  • Remove and check the supply and return lines.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Restriction line test completed successfully?
YES NO
No Repair

Repair or replace the DEF lines and/or connectors.

Go to 5C

Go to 3B

Guided Step 5C - Inspect the DEF tank and the 35 micron tank filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (Each prime attempt will take 30 seconds. If not successful, the doser will attempt to prime up to 20 times.) air should continuously flow through the DEF Injection line, and the attached air flow meter.

  • Record the measured air flow from the DEF dosing line.

DEF tank contaminated or the urea solution less than 32.5%?

YES NO

Clean or replace the aftertreatment nozzle.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Perform the Diesel Exhaust Fluid Doser Pump Override Test.

Guided Step 6A - Perform the Diesel Exhaust Fluid Dosing Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

The aftertreatment nozzle must have been warmed in the exhaust before removing and placing it in a measuring container greater than 200 ml [6.8 oz] capacity to perform the Diesel Exhaust Fluid Doser Pump Override Test.

The troubleshooting tree must be followed completely before completing this test.

Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test three times.)

YES | NO
No Repair | No Repair

Go to 7A

Go to 6B

Guided Step 6B - Inspect the DEF dosing unit inline screen filter connection.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF supply line from the dosing unit and secure appropriately.

Action

Inspect the DEF dosing unit inline screen filter connection.

  • Remove the DEF dosing unit supply line.
  • Inspect the inlet screen filter. Refer to Procedure 011-060 in the Associated Procedures Table.

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Contamination present at the screen filter?
YES NO

Replace the screen filter.

 No Repair

Go to 6A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Sep-2015


Fault Code 2773 - Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Exhaust Restriction | Refer to Procedure 011-009 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Line Restriction Test | Refer to Procedure 011-086 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect vehicle fault codes. |
 | STEP 1A. Check for active counts of Fault Code 1694. | Fault Code 1694 active?
 | STEP 1B. Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738. | Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?
 | STEP 1C. Check the remaining active/inactive fault codes. | Active fault codes or performance complaints present? (With exception of Fault Ccode 2772.)
STEP 2. | Check the aftertreatment cataylst system. |
 | STEP 2A. Inspect the aftertreatment catalyst system for external leaks. | External leaks detected in the system?
 | STEP 2B. Check the exhaust back pressure. | Exhaust back pressure exceeds the limits provided in Procedure 011-009?
 | STEP 2C. Check the aftertreatment SCR catalyst. | SCR catalyst present, not damaged, and not found to be broken up?
 | STEP 2D. Inspect the aftertreatment nozzle. | Plugged or restricted aftertreatment nozzle detected?
STEP 3. | Verify the priming cycle of the diesel exhaust fluid (DEF) dosing unit. |
 | STEP 3A. Check the DEF dosing unit during priming. | Dosing unit only prime for 3 seconds? (Plus the 140 second prime delay if applicable.)
 | STEP 3B. Check the air solenoid operation during priming. | Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Will attempt to prime up to 20 times)
 | STEP 3C. Confirm the successful priming of the DEF dosing unit. | Air flow above 25 liters/min [6.6 gal/min]?
STEP 4. | Check the DEF dosing unit air supply system. |
 | STEP 4A. Inspect the air supply lines to the DEF dosing unit. | Original equipment manufacturer (OEM) air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
 | STEP 4B. Clear the DEF dosing unit air side circuit. Carry out the flushing procedure. | Flushing procedure successful?
STEP 5. | Check the DEF lines and fittings for restriction and contamination. |
 | STEP 5A. Check the DEF dosing unit fittings and lines. | DEF fittings and lines pass the inspections?
 | STEP 5B. Inspect the DEF dosing unit inline screen filter connection. | Contamination present at the screen filter?
 | STEP 5C. Inspect the DEF tank and the 35 micron tank filter. | DEF tank contaminated or the urea solution less than 32.5%?
STEP 6. | Perform the DEF Doser Pump Override Test. |
 | STEP 6A. Perform the DEF Dosing Pump Override Test with INSITE™ electronic service tool. | Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test three times.)
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect vehicle fault codes.

Guided Step 1A - Check for active counts of Fault Code 1694.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The following items must be checked or verified before continuing:

  • Check for active counts of Fault Code 1694.

Fault Code 1694 active?
YES NO

Troubleshoot Fault Code 1694 before returning to this troubleshooting tree.

No Repair

Fault Code 1694 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 in the ECM.

  • Look specifically for one or more inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 within 50 engine hours of this fault code being set.

Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?

YES NO

Troubleshoot Fault Code 1682, 3548, 3569, 3575, or 3738 before returning to this fault code troubleshooting tree.

 No Repair

Fault Code 1682, 3548, 3569, 3575, or 3738 troubleshooting tree.

Go to 1C

Guided Step 1C - Check the remaining active/inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Troubleshoot any other active fault codes first.
  • All other active fault codes except FC2772 must be resolved before following this troubleshooting tree.
  • Check for performance complaints
  • Troubleshoot any performance complaints related to smoke or misfire first.

Fault Code 2773 is caused by the same symptoms as Fault Code 2772, but at a more severe level, therefore if both fault codes are active Fault Code 2773 should always be addressed first.

Active fault codes or performance complaints present? (With exception of Fault Code 2772.)
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment catalyst system.

Guided Step 2A - Inspect the aftertreatment catalyst system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment catalyst system.

  • Inspect the aftertreatment catalyst and all attached exhaust pipework for signs of exhaust gas leakage or damage.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Measure the exhaust restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust back pressure exceeds the limits provided in Procedure 011-009?
YES NO

Repair source or replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2C

Guided Step 2C - Check the aftertreatment SCR catalyst.

Conditions

  • Turn keyswitch OFF.

Action

Make sure that the SCR catalyst is present in the exhaust stream.

Remove the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Inspect the aftertreatment SCR catalyst. If the aftertreatment SCR catalyst has broken up, then a significant mass of broken material will move around inside the assembly when the catalyst is tilted or moved.

SCR catalyst present, not damaged, and not found to be broken up?

YES NO
No Repair

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-036 in the Associated Procedures Table.

Go to 2D

Go to 7A

Guided Step 2D - Inspect the aftertreatment nozzle.

Conditions

  • Make sure the nozzle has been warmed in the exhaust prior to removal. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Turn keyswitch OFF.
  • Remove the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Soft crystal and ash like buildup in the spray holes can be dissolved with 40°C [104°F] warm water.
  • Be sure that the soft buildup in the spray holes clears when the dosing unit begins dosing.

Plugged or restricted aftertreatment nozzle detected?
YES NO

Clean or replace the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Verify the priming cycle of the diesel exhaust fluid (DEF) dosing unit.

Guided Step 3A - Verify the priming cycle of the DEF dosing unit.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle
  • Connect INSITE™ electronic service tool.

Action

The following items must be checked or verified before continuing:

  • After key ON with the engine operating, listen for the DEF dosing pump to start.
  • Time the pump operation until the pump automatically switches off (The pump is attempting to prime).

While the engine is operating it may be difficult to hear the pump. If this is the case, listen for the air solenoid to click, indicating that the pump has completed 1 prime attempt.

Older calibrations did not incorporate the 140 second delay from key ON to initial prime cycle. During the 140 second delay the dosing unit will remain on standby before receiving the command to prime. This was introduced to remove any crystallization built up on injection tip prior to priming cycle and to avoid any blocked injection lines.

A correct prime cycle is as follows:

1. Turn keyswitch ON

2. 140 second pump start delay

3. Pump starts and operates for 30 seconds. (The system is now priming. This step may be attempted up to 20 times.)

4. The DEF injection line will now exhaust air. Priming is now complete.

Dosing unit only prime for 3 seconds? (Plus the 140 second prime delay, if applicable.)

YES NO

Complete line restriction testing procedure then re-prime. Refer to Procedure 011-086 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3B

Guided Step 3B - Check the air solenoid operation during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Be sure that the DEF dosing unit has successfully primed and entered the dosing state.

  • The DEF dosing unit enters the dosing state only when a successful prime is has completed, and the air solenoid has clicked.
  • At this point, air will be flowing continuously down the aftertreatment nozzle line.
  • The DEF dosing unit could attempt to prime for up to 12 minutes, at which point, if a prime is successful, the pump will switch off.
  • Use INSITE™ electronic service tool Data/Monitor Logger for Aftertreatment Diesel Exhaust Fluid Dosing Unit State to confirm the doser status.

Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Will attempt to prime up to 20 times.)

YES NO
No Repair

The DEF dosing unit has not primed.

Go to 3C

Go to 5A

Guided Step 3C - Confirm the successful priming of the DEF dosing unit.

Conditions

  • Turn keyswitch OFF for a minimum of 1 minute.
  • Disconnect the DEF line from the aftertreatment nozzle.
  • Attach the air flow meter to the DEF dosing line. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Secure the DEF dosing line and the attached air flow meter
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (Each prime attempt will take 30 seconds. If not successful, the doser will attempt to prime up to 20 times.) air should continuously flow through the DEF Injection line, and the attached air flow meter.

  • Record the measured air flow from the DEF dosing line.

Air flow above 25 liters/min [6.6 gal/min]?
YES | NO
No Repair | No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the DEF dosing unit air supply system.

Guided Step 4A - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Operate the engine at low idle.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for water or excessive oil from the vehicle's compressed air system.
  • Make sure a clean supply of air, at least 517 kPa [75 psi], pressure is present at the DEF dosing unit.

Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

Original equipment manufacturer (OEM) air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO
No Repair

Correct the OEM air supply connection or supply. Refer to the OEM service manual.

Go to 4B

Go to 3A

Guided Step 4B - Clear the DEF dosing unit air side circuit. Carry out the flushing procedure.

Conditions

  • Drain or isolate the OEM air supply circuit.
  • Remove the OEM air supply hose.

Action

Carry out the DEF dosing unit flushing procedure.

  • Refer to Procedure 011-082 in the Associated Procedures Table.
  • Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

Flushing procedure successful?
YES NO
No Repair

Replace the DEF dosing unit.

Go to 5A

Go to 7A

Guided Step 5 - Check the DEF lines and fittings for restriction and contamination.

Guided Step 5A - Check the DEF dosing unit fittings and lines.

Conditions

  • Clean the front fact of the doser before removing any lines.
  • Disconnect the DEF line from the aftertreatment nozzle and secure appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Inspect the DEF dosing unit fittings and lines for the following:

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any line. This is to prevent any contamination due to service intervention.

  • Loose DEF inlet connectors or fitting
  • Cracked DEF lines, resulting in leaks or drawing in air
  • Be sure DEF is returning to the tank during the priming cycle.

DEF fittings and lines pass the inspections?
YES NO
No Repair

Repair or replace DEF lines and/or connectors.Refer to the OEM service manual.

Go to 5B

Go to 3B

Guided Step 5B - Inspect the DEF dosing unit inline screen filter connection.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF supply line from the dosing unit and secure appropriately.

Action

Inspect the DEF dosing unit inline screen filter connection.

  • Remove the DEF dosing unit supply line.
  • Inspect the inlet screen filter. Refer to Procedure 011-060 in the Associated Procedures Table.

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Contamination present at the screen filter?
YES NO

Replace the screen filter.

 No Repair

Go to 5C

Go to 5C

Guided Step 5C - Inspect the DEF tank and the 35 micron tank filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the DEF tank and filters for fuel, oil, coolant, dirt, and debris.

  • Inspect the contents of the tank.
  • Inspect the condition of the tank filter.
  • Check and record the urea concentration of the DEF using a sample from the tank. Refer to Procedure 018-026 in Section V.

DEF tank contaminated or the urea solution less than 32.5%?

YES NO

Locate/remove source, inform OEM. If required replace components and connectors. Drain/refill the DEF tank. Refer to OEM service manual.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Perform the Diesel Exhaust Fluid Doser Pump Override Test.

Guided Step 6A - Perform the Diesel Exhaust Fluid Dosing Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-058 in the Associated Procedures Table.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

The aftertreatment nozzle must have been warmed in the exhaust before removing and placing it in a measuring container greater than 200 ml [6.8 oz] capacity to perform the Diesel Exhaust Fluid Doser Pump Override Test.

The troubleshooting tree must be followed completely before completing this test.

Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test three times)

YES | NO
No Repair | No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Sep-2015


FAULT CODE 3142 - Aftertreatment SCR Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3142 inactive?
STEP 2. | Check the SCR inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3143 active and Fault Code 3142 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3142 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 3142 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the SCR inlet temperature sensor and circuit.

Guided Step 2A - Inspect the SCR inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and SCR inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the SCR inlet temperature sensor from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the SCR inlet temperature SIGNAL pin and the SCR inlet temperature RETURN pin at the sensor connector of the OEM harness.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 3143 active and Fault Code 3142 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the SCR inlet temperature sensor to the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO

A damaged SCR inlet temperature sensor has been detected.

Replace the SCR inlet temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector SCR inlet temperature sensor RETURN pin and the OEM harness SCR inlet temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector SCR inlet temperature sensor SIGNAL pin and the OEM harness SCR inlet temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-360 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the SCR inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response. This could take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

The troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Jul-2012


FAULT CODE 3143 - Aftertreatment SCR Inlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3143 inactive?
STEP 2. | Check the SCR inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3142 active and Fault Code 3143 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3143 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 3143 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the SCR inlet temperature sensor and circuit.

Guided Step 2A - Inspect the SCR inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and SCR catalyst inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active and Fault Code 3143 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the SCR inlet temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 active?
YES NO

Replace the SCR inlet temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the SCR inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SCR inlet temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the SCR inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 for Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3143 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Dec-2013


FAULT CODE 3144 - Aftertreatment SCR Inlet Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes 3142 or 3143. | Fault Code 3142 or 3143 active?
STEP 2. | Check the SCR inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the SCR inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3142 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3142 active?
STEP 4. | Verify the repair. |
 | STEP 4A. Verify the repair | SCR inlet temperature and SCR outlet temperature reading within 14°C or 25°F of each other?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes 3142 or 3143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 or 3143 active?
YES | NO
No Repair | No Repair

Fault Code 3142 or 3143 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the SCR inlet temperature sensor and circuit.

Guided Step 2A - Inspect the SCR inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the engine harness.

Action

Inspect the engine harness and SCR inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SCR inlet temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure engine coolant temperature is above 60°C [140°F].

Action

Check for the appropriate (ECM or circuit) response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO
No Repair

Replace the SCR inlet temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure engine coolant temperature is above 60°C [140°F].

Action

Check for the appropriate ECM or circuit response. This can take up to 300 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool Data Monitor/Logger.

  • Compare the INSITE™ electronic service tool reading for catalyst inlet temperature and catalyst outlet temperature.

SCR inlet temperature and SCR outlet temperature reading within 14°C or 25°F of each other?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Jul-2012


FAULT CODE 3164 - Aftertreatment SCR Inlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISL9.5 CM2150 SN | 4310608
Turbocharger | Refer to Procedure 010-033 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3142 or 3143 active?
STEP 2. | Check the air handling system for correct operation. |
 | STEP 2A. Check the charge air cooler, clamps, hoses, and piping. | Air leaks present or clamps loose?
 | STEP 2B. Inspect turbocharger compressor and turbine blades. | Damage found on turbocharger blades?
STEP 3. | Inspect the SCR inlet temperature sensor. |
 | STEP 3A. Inspect the SCR inlet temperature sensor. | Damage found on SCR inlet temperature sensor?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3142 or 3143 active?
YES | NO
No Repair | No Repair

Fault Code 3142 or 3143 troubleshooting tree

Go to 2A

Guided Step 2 - Check the air handling system for correct operation.

Guided Step 2A - Check the charge-air cooler, clamps, hoses, and piping.

Conditions

  • Turn keyswitch OFF.

Action

Check the charge-air cooler, hoses, and piping for leaks.

  • Check the clamps for adequate torque. Refer to Procedure 010-024 in the Associated Procedures Table.

Air leaks present or clamps loose?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect turbocharger compressor and turbine blades.

Conditions

  • Turn keyswitch OFF.
  • Remove the inlet and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Damage found on turbocharger blades?
YES NO

Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Inspect the SCR inlet temperature sensor.

Guided Step 3A - Inspect the SCR inlet temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the SCR inlet temperature sensor from the exhaust system.

Action

Inspect the SCR inlet temperature sensor.

  • Inspect the SCR inlet temperature sensor for damage or signs of excessively high temperature.

Damage found on SCR inlet temperature sensor?
YES NO

Replace the SCR inlet temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 3242 - Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part No. 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, 1684, 3237, 3258, 3261, 3422, 3425, 3426, 3429, or 3576 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level ok?
STEP 3. | Check the aftertreatment diesel exhaust fluid tank heater operation. |
 | STEP 3A. Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve. | Diesel exhaust fluid tank heater control valve operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for diesel exhaust fluid tank heater or diesel exhaust fluid tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684, 3237, 3258, 3261, 3422, 3425, 3426, 3429, or 3576 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid tank heating system

Guided Step 2A - Inspect the diesel exhaust fluid tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel exhaust fluid tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including the OEM in-line shutoff valve if equipped)
  • Loose connections
  • Leaking seals or gaskets.

Refer to the OEM service manual for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF

Action

Check engine coolant level.

  • Make sure that coolant level is within normal operating levels.

Coolant level ok?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment diesel exhaust fluid tank heater operation.

Guided Step 3A - Verify proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.

  • Make sure that the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Refer to the OEM service manual for details on the tank heater control valve.

Diesel exhaust fluid tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the diesel exhaust fluid tank heater control valve.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 3559 - Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-056 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3559 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and electrical connections. | Dirty or damaged pins?
STEP 3. | Check the engine control module (ECM) and harness. |
 | STEP 3A. Inspect the ECM and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3559 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3559 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the original equipment manufacturer (OEM) harness.

Action

Inspect the harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SIGNAL pin at the OEM harness ECM connector and block ground.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SUPPLY pin at the OEM harness ECM connector and block ground.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SUPPLY pin at the OEM harness ECM connector and other pins at the OEM harness ECM connector.
  • Measure the resistance between the aftertreatment DEF dosing unit SIGNAL pin at the OEM harness ECM connector and other pins at the OEM harness ECM connector.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3559 active?
YES NO

First replace the dosing unit.

  • Refer to Procedure 011-058 in the Associated Procedures Table.

Repeat Step 3E. If Fault Code 3559 is still active, a malfunctioning ECM has been detected.

  • Replace ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal in installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jul-2016


FAULT CODE 3565 - Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3565 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the aftertreatment DEF valve. | Resistance between 11 and 13 ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to battery in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3565 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check the aftertreatment DEF dosing valve resistance.

  • Use a multimeter to measure the resistance between the DEF dosing valve SUPPLY and RETURN pin at the aftertreatment DEF dosing unit connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 11 and 13 ohms?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness from the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SUPPLY pin at the aftertreatment DEF dosing unit harness connector and the aftertreatment DEF dosing valve SUPPLY pin at the OEM harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

4A

Guided Step 3C - Check for a short circuit to battery in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a short circuit to battery.

  • Measure the resistance between the aftertreatment DEF dosing valve SUPPLY pin at the aftertreatment DEF dosing unit harness connector and battery (+).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to battery (+) has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SUPPLY pin in the OEM harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunctioning ECM has been detected.

Replace the ECM

Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 03-Jun-2013


FAULT CODE 3566 - Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To avoid connector damage due to connector expansion, use test lead, Part Number 4919546, for the smaller pins and test lead, Part Number 4919348, for the larger pins.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3566 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the aftertreatment DEF dosing valve. | Resistance between 11 and 13 ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3566 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit or OEM harness connector.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check the aftertreatment DEF dosing unit resistance.

  • Measure the resistance between the aftertreatment DEF dosing valve SUPPLY pin and the aftertreatment DEF dosing valve RETURN pin at the aftertreatment DEF dosing unit connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 11 and 13 ohms?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness and ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the aftertreatment DEF dosing valve SUPPLY pin at the aftertreatment DEF dosing unit harness connector and block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SUPPLY pin at the OEM harness ECM connector and all other pins in the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunctioning ECM has been detected. Replace the ECM. Refer to Procedure 019-031 in Section 19.

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-May-2013


FAULT CODE 3568 - Aftertreatment Diesel Exhaust Fluid Dosing Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3571, 3572, 3565, or 3566 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3568 active?
STEP 2. | Perform the Diesel Exhaust Fluid Doser Pump Override Test. |
 | STEP 2A. Perform the Diesel Exhaust Fluid Doser Pump Override Test using INSITE™ electronic service tool. | Aftertreatment diesel exhaust fluid dosing unit operates according to the specifications in procedure 011-063?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571, 3572, 3565, or 3566 active?
YES | NO
No Repair | No Repair

Go the the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3568 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform the Diesel Exhaust Fluid Doser Pump Override Test.

Guided Step 2A - Perform the Diesel Exhaust Fluid Doser Pump Override Test using INSITE™ electronic service tool.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start engine and operate at low idle.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.
  • Check to make sure the diesel exhaust fluid is being injected through the aftertreatment nozzle during the dosing state.

Aftertreatment diesel exhaust fluid dosing unit operates according to the specifications in procedure 011-063?
YES NO
No Repair

A damaged aftertreatment diesel exhaust fluid dosing unit has been detected.

Replace the aftertreatment diesel exhaust fluid dosing unit. Refer to Procedure 011-063 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-May-2012


FAULT CODE 3571 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 3571 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3572 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3571 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3571 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Codes 3565, 3577, 4173, 4174, 4175, and 4237 may also become active.

Fault Code 3572 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DEF sensor SUPPLY pin and the aftertreatment DEF sensor RETURN pin at the OEM harness aftertreatment DEF dosing unit connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF dosing unit to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 active?
YES NO

A damaged aftertreatment DEF pressure sensor has been detected in the aftertreatment DEF dosing unit.

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF sensor RETURN pin at the OEM harness ECM connector and the aftertreatment DEF sensor RETURN pin at the OEM harness aftertreatment DEF dosing unit connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Last Modified: 16-Jan-2017


FAULT CODE 3572 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 3572 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 3571 active?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 3572 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 3572 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the aftertreatment DEF pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DEF sensor SUPPLY pin and the aftertreatment DEF sensor RETURN pin at the aftertreatment DEF dosing unit connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DEF sensor SUPPLY pin and the aftertreatment DEF sensor SIGNAL pin at the aftertreatment DEF dosing unit connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Other DEF dosing unit fault codes will be active.

Fault Code 3571 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF dosing unit to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 active?
YES NO

A damaged aftertreatment DEF pressure sensor has been detected inside the aftertreatment DEF dosing unit.

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF sensor SUPPLY pin at the OEM harness ECM connector and the aftertreatment DEF sensor SUPPLY pin at the OEM harness aftertreatment DEF dosing unit connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor SIGNAL pin at the OEM harness ECM connector and the aftertreatment DEF pressure sensor SIGNAL pin at the OEM harness aftertreatment DEF dosing unit connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Jun-2013


FAULT CODE 3574 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Overide Test | Refer to Procedure 011-063 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Tank | Refer to Procedure 011-081 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Tank Level and Temperature Sensor | Refer to Procedure 019-488 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1668, 1669, 1677, 1678, 1712, 3242, 3559, 3565, 3566, 3571, 3572, 3577, 3578, or sensor supply fault codes active?
 | STEP 1B. Check for low diesel exhaust fluid (DEF) tank level. | DEF tank empty and/or Fault Code 1671 or 1673 active?
STEP 2. | Check the aftertreatment DEF dosing unit. |
 | STEP 2A. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine control parts list (CPL)?
 | STEP 2B. Check for correct aftertreatment DEF dosing unit. | Aftertreatment DEF dosing unit the correct voltage for the application?
 | STEP 2C. Inspect the DEF supply lines. | DEF lines correctly attached to the DEF dosing unit and the DEF tank?
STEP 3. | Inspect the DEF dosing unit. |
 | STEP 3A. Inspect the aftertreatment DEF dosing unit and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Inspect the engine control module (ECM) and harness connector pins. | Dirty or damaged pins?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check the aftertreatment DEF tank filter. |
 | STEP 4A. Inspect the DEF tank filter for blockage. | Diesel exhaust fluid tank filter blocked?
STEP 5. | Perform the DEF doser pump override test. |
 | STEP 5A. Perform the Diesel Exhaust Fluid Doser Pump Override Test with INSITE™ electronic service tool. | Dosing unit meet the specifications outlined in procedure 011-063?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668, 1669, 1677, 1678, 1712, 3242, 3559, 3565, 3566, 3571, 3572, 3577, 3578, or sensor supply fault code active?
YES | NO
No Repair | No Repair

Reference the appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty, and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Code 1671 or 1673.

Diesel exhaust fluid tank empty and/or Fault Code 1671 or 1673 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF dosing unit.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter setting.

  • Use INSITE™ electronic tool "Features and Parameters" feature to determine electrical system voltage.
  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical system voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 2B

Go to 5A

Guided Step 2B - Check for correct aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.

Action

Verify the aftertreatment DEF dosing unit is the correct voltage for the application.

  • Check the aftertreatment DEF dosing unit dataplate for voltage.

The aftertreatment DEF dosing unit is available in 12 or 24 volt versions.

Aftertreatment DEF dosing unit is the correct voltage for the application?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit with the correct part number for the application.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Inspect the DEF supply lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF dosing unit and DEF supply line.

  • Check for leaks around the aftertreatment DEF dosing unit.
  • Check for leaks and improper or loose connections between the aftertreatment DEF dosing unit and the tank. Refer to Procedure 011-058 in the Associated Procedures Table.

DEF lines correctly attached to the DEF dosing unit and the DEF tank?
YES NO
No Repair

Repair the DEF supply line and connections.

  • Refer to Procedure 011-058 in the Associated Procedures Table.
  • Refer to the original equipment manufacturer (OEM) service manual.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the DEF dosing unit.

Guided Step 3A - Inspect the aftertreatment DEF dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the ECM and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit pump motor SIGNAL pin at the OEM harness ECM connector and aftertreatment DEF dosing unit pump motor SIGNAL pin at the dosing unit wiring harness connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SUPPLY pin at the OEM harness ECM connector and aftertreatment DEF dosing unit SUPPLY pin at the dosing unit wiring harness connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit pump motor SIGNAL pin at the OEM harness ECM connector and all other pins at the OEM harness ECM connector.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the aftertreatment DEF tank filter.

Guided Step 4A - Inspect the DEF tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Remove the tank level/temperature sensor from the DEF tank.

Action

Inspect the aftertreatment DEF tank filter for signs of blockage or buildup.

  • Refer to Procedure 011-081 in the Associated Procedures Table.
  • Refer to Procedure 019-488 in the Associated Procedures Table.

Diesel exhaust fluid tank filter blocked?
YES NO

Clean or replace the DEF tank filter.

Drain, clean, and refill the DEF tank.

Refer to Procedure 011-081 in the Associated Procedures Table.

Refer to Procedure 019-488 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Perform the Diesel Exhaust Fluid Doser Pump Override Test.

Guided Step 5A - Perform the Diesel Exhaust Fluid Doser Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start engine and operate at low idle.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table. for instructions and specifications.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

Does the dosing unit meet the specifications outlined in procedure 011-063?
YES NO
No Repair

Replace the Diesel Exhaust Fluid Doser Pump Override Test filter and damper. (Note that this filter and damper can not be reused and must be changed upon removal.)

Refer to Procedure 011-060 in the Associated Procedures Table.

Perform the Diesel Exhaust Fluid Doser Pump Override Test again with the new filter and damper. If the measured volume of DEF is still not within specifications, replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Sep-2015


FAULT CODE 3575 - Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3571, 3572, 3565, 3566, or 3568 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3575 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit. |
 | STEP 2A. Check the aftertreatment DEF dosing unit. | Aftertreatment DEF dosing unit running?
 | STEP 2B. Check for a short circuit in the original equipment manufacturer (OEM) harness. | Greater than 100k ohm?
 | STEP 2C. Check for a short circuit in the OEM harness. | Greater than 100k ohm?
STEP 3. | Perform the Diesel Exhaust Fluid Doser Pump Override Test. |
 | STEP 3A. Perform the Diesel Exhaust Fluid Doser Pump Override Test with INSITE™ electronic service tool. | Does the aftertreatment DEF dosing unit operate according to the specifications in procedure 011-063?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571, 3572, 3565, 3566, or 3568 active?
YES NO

Troubleshoot any active faults in this list before troubleshooting Fault Code 3575.

 No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3575 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 2A - Check the aftertreatment DEF dosing unit.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.

Action

Check for a stuck on aftertreatment DEF dosing unit.

  • Listen for a running aftertreatment DEF dosing unit.

Aftertreatment DEF dosing unit running?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit pump motor SIGNAL pin at the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohm?
YES NO
No Repair

A pin-to-pin short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to battery.

  • Measure the resistance between the aftertreatment DEF dosing unit pump motor SIGNAL pin at the OEM harness ECM connector and battery POSITIVE (+).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohm?

YES NO
No Repair

A short to battery has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Perform the Diesel Exhaust Fluid Doser Pump Override Test.

Guided Step 3A - Perform the Diesel Exhaust Fluid Doser Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start engine and operate at low idle.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Refer to Procedure 011-058 in the Associated Procedures Table.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.
  • Verify that the DEF dosing unit remains powered for at least 30 seconds after key OFF to complete the purge cycle.

Aftertreatment DEF dosing unit operate according to the specifications in procedure 011-063?
YES NO
No Repair

A damaged aftertreatment DEF dosing unit has been detected. Replace the DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-May-2013


FAULT CODE 3577 - Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™AMP™Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™AMP™Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3577 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the aftertreatment DEF return valve. | 4 to 6 ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to battery in the harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3577 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connector pins for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the aftertreatment DEF return valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check the aftertreatment DEF return valve resistance.

  • Measure the resistance between the aftertreatment diesel exhaust fluid return valve SUPPLY pin and the aftertreatment diesel exhaust fluid return valve RETURN pin at the aftertreatment DEF dosing unit connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

10 to 12 ohms?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin at the OEM harness aftertreatment DEF dosing unit connector and the aftertreatment DEF return valve SUPPLY pin at the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use the following procedure for general inspection techniques.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness.

Troubleshoot the OEM harness, engine harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to battery in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a short circuit to battery.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin at the OEM harness aftertreatment DEF dosing unit harness connector and battery POSITIVE (+).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to battery POSITIVE (+) has been detected in the harness.

Troubleshoot the OEM harness, engine harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the 8-pin OEM to engine crossover connector.

Action

Check for a short circuit.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin in the engine harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Disconnect the 8-pin OEM to engine crossover connector.

Action

Check for a short circuit.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin in the OEM harness aftertreatment DEF dosing unit connector and all other pins in the aftertreatment DEF dosing unit connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated procedures table.

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Jun-2013


FAULT CODE 3578 - Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3578 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the aftertreatment DEF return valve. | 10 to 12 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | Dirty or damaged pins?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3578 active?
YES | NO
No Repair | No Repair

2A

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the aftertreatment DEF return valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check the aftertreatment DEF return valve resistance.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin and the aftertreatment DEF return valve RETURN pin at the aftertreatment DEF dosing unit connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

10 to 12 ohms?

YES NO
No Repair

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin at the OEM harness aftertreatment DEF dosing unit connector and block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the harness.

Troubleshoot the OEM harness, engine harness, and all interconnects.

Repair or replace the malfunctioning component.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the 8-pin OEM to engine crossover connector.

Action

Check for a short circuit.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the 8-pin OEM to engine crossover connector.

Action

Check for a short circuit.

  • Measure the resistance between the aftertreatment DEF return valve SUPPLY pin in the OEM harness aftertreatment DEF dosing unit connector and all other pins in the aftertreatment DEF dosing unit wiring harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunctioning ECM has been detected.

Replace the ECM. Refer to procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Jun-2013


FAULT CODE 4157 - Aftertreatment Diesel Exhaust Fluid (DEF) Return Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing System Leak Test | Refer to Procedure 011-080 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active aftertreatment diesel exhaust fluid (DEF) system fault codes. | Fault Code 3577 or 3578 active?
 | STEP 1B. Check for an active fault code. | Fault Code 4157 active?
STEP 2. | Perform the DEF doser leak test. |
 | STEP 2A. Perform the DEF doser leak test with INSITE™ electronic service tool. | Fault Code 4571 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active aftertreatment DEF system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3577 or 3578 active?
YES NO

Troubleshoot any active faults in this list before troubleshooting Fault Code 4157.

 No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4157 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform the DEF doser leak test.

Guided Step 2A - Perform the DEF doser leak test with INSITE™ electronic service tool.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.
  • Make sure the vehicle air tanks are full.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Exhaust Fluid (DEF) Doser Leak Test, under ECM Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-080 in the Associated Procedures Table.
  • Turn keyswitch OFF for 1 minute to allow the system to purge.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes at the end of the test.

Fault Code 4571 active?
YES NO

A damaged aftertreatment DEF return valve has been detected inside the aftertreatment DEF dosing unit.

Replace the aftertreatment diesel exhaust dosing unit.

Refer to the Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Apr-2012


FAULT CODE 4172 - Aftertreatment Diesel Exhaust Fluid Dosing Air Assist Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
ECM Calibration Code | Refer to Procedure 019-032 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 4172 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing air assist pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing air assist pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4173 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 4172 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 4172 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4172 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid dosing air assist pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing air assist pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel exhaust fluid dosing unit connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Codes 3565, 3572, 3577, 4169, 4174, and 4237 may also come active.

Fault Code 4173 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel exhaust fluid dosing unit sensor SUPPLY pin and the aftertreatment diesel exhaust fluid dosing unit sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel exhaust fluid dosing unit to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4172 active?
YES NO

A damaged aftertreatment diesel exhaust fluid dosing air assist pressure sensor has been detected inside the aftertreatment diesel exhaust fluid dosing unit.

Replace the aftertreatment diesel exhaust dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit sensor RETURN pin at the OEM harness ECM connector and the aftertreatment diesel exhaust fluid unit sensor RETURN pin at the OEM harness aftertreatment diesel exhaust fluid dosing unit connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate exhaust fluid dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing air assist pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4172 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Jun-2013


FAULT CODE 4173 - Aftertreatment Selective Catalyst Reduction Dosing Air Assist Absolute Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 4173 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing air assist pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing air assist pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 4172 active?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 4173 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 4173 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4173 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing air assist pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing air assist pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF dosing uint connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DEF unit SUPPLY pin and the aftertreatment DEF unit RETURN pin at the aftertreatment DEF dosing unit connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DEF dosing unit SUPPLY pin and the aftertreatment DEF dosing air assist pressure sensor SIGNAL pin at the aftertreatment DEF dosing unit connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Other DEF dosing unit fault codes will be active.

Fault Code 4172 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF dosing unit to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4173 active?
YES NO

A damaged aftertreatment DEF dosing air assist pressure sensor has been detected inside the aftertreatment DEF dosing unit.

Replace the aftertreatment diesel exhaust dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit SUPPLY pin at the OEM harness ECM connector and the aftertreatment DEF dosing unit SUPPLY pin at the OEM harness aftertreatment DEF dosing unit connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing air assist pressure sensor SIGNAL pin at the OEM harness ECM connector and the aftertreatment DEF dosing air assist pressure sensor SIGNAL pin at the OEM harness aftertreatment DEF dosing unit connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate exhaust fluid dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing air assist pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DEF dosing air assist pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4173 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jun-2013


FAULT CODE 4174 - Aftertreatment Diesel Exhaust Fluid Dosing Temperature Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM) , all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4174 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4175 active and Fault Code 4174 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 4174 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 4175 active and Fault Code 4174 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the original equipment manufacturer (OEM) harness. | Greater than 100k ohms?
STEP 4. | Check the ECM and OEM harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 4C. Check for an inactive fault code. | Fault Code 4174 inactive?
 | STEP . |
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4174 active?
YES | NO
No Repair | No Repair

2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing temperature sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the engine harness.

Action

Inspect the engine harness and aftertreatment DEF dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit connector pins or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the aftertreatment DEF dosing temperature SIGNAL pin and the aftertreatment DEF dosing unit sensor RETURN pin at the dosing unit OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4175 active and Fault Code 4174 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF dosing unit to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4174 active?
YES NO

A malfunctioning aftertreatment DEF dosing temperature sensor has been detected.

Replace the aftertreatment diesel exhaust dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 5A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the aftertreatment DEF dosing temperature sensor SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4175 active and Fault Code 4174 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing temperature sensor SIGNAL pin at the OEM harness dosing unit connector and the aftertreatment DEF dosing temperature sensor SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected.

Troubleshoot the OEM harness, engine harness, and all interconnects.

Repair or replace the damaged component.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot the OEM harness, engine harness, and all interconnects.

Repair or replace the harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF dosing temperature sensor SIGNAL pin in the dosing unit wiring harness connector and all other pins in the dosing unit wiring harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot the OEM harness, engine harness, and all interconnects.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and OEM harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing unit sensor RETURN pin at the dosing unit OEM harness connector and the aftertreatment DEF dosing unit sensor RETURN pin at the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4174 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

Troubleshooting procedures need to be repeated from the beginning. A fault code should have been detected.

5A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Jun-2013


FAULT CODE 4175 - Aftertreatment Diesel Exhaust Fluid Dosing Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.8 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.8 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.8 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 4175 inactive?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4174 active and Fault Code 4175 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4175 is active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 4174 active and Fault Code 4175 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the original equipment manufacturer (OEM) harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 4175 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4175 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4174 active and Fault Code 4175 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF dosing unit to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4175 active?
YES NO

A damaged sensor has been detected in the aftertreatment DEF dosing unit. Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4174 active and Fault Code 4175 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF dosing temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF dosing temperature sensor SIGNAL pin in the OEM harness aftertreatment DEF dosing unit connector and all other pins in the OEM harness aftertreatment DEF dosing unit connector.

Refer to the circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot the OEM harness, engine harness, and all interconnects.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DEF dosing temperature temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected.

Troubleshoot the OEM harness, engine harness, and all interconnects.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4175 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jun-2013


FAULT CODE 4176 - Aftertreatment Selective Catalyst Reduction Air Assist Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4176 active?
STEP 2. | Check the aftertreatment selective catalyst reduction (SCR) dosing air assist valve and circuit. |
 | STEP 2A. Inspect the aftertreatment SCR dosing air assist valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the aftertreatment SCR dosing air assist valve. | Resistance between 6.5 to 12.5 ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4176 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the aftertreatment SCR dosing air assist valve and circuit.

Guided Step 2A - Inspect the aftertreatment SCR dosing air assist valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR dosing air assist valve from the OEM harness.

Action

Inspect the OEM harness and aftertreatment SCR dosing air assist valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the aftertreatment SCR dosing air assist valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR dosing air assist valve from the OEM harness.

Action

Check the aftertreatment SCR dosing air assist valve resistance.

  • Measure the resistance between the aftertreatment SCR dosing air assist valve SUPPLY pin and the aftertreatment SCR dosing air assist valve RETURN pin at the aftertreatment SCR dosing air assist valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 6.5 to 12.5 ohms?
YES NO
No Repair

Replace the aftertreatment SCR dosing air assist valve. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM OEM connector.

Action

Inspect the OEM harness and ECM OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM OEM connector.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve connector from the OEM harness.

Action

Check for a short circuit.

  • Measure the resistance between the aftertreatment SCR dosing air assist valve RETURN pin at the aftertreatment SCR dosing air assist valve harness connector and battery positive (+).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM OEM connector.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve connector from the OEM harness.

Action

Check for a short circuit.

  • Measure the resistance between the aftertreatment SCR dosing air assist valve RETURN pin in the OEM harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunctioning ECM has been detected. Replace the ECM. Refer to Procedure 019-031 the Associated Procedures Table.

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Jun-2013


FAULT CODE 4177 - Aftertreatment Selective Catalyst Reduction Air Assist Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM) , all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4177 inactive?
STEP 2. | Check the aftertreatment selective catalytic reduction (SCR) dosing air assist valve and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid (DEF) dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment SCR dosing air assist valve. | Resistance bewteen 6.5 to 12.5 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4177 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the aftertreatment SCR dosing air assist valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR dosing air assist valve from the OEM harness.

Action

Inspect the OEM harness and aftertreatment SCR dosing air assist valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the aftertreatment SCR dosing air assist valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR dosing air assist valve from the OEM harness.

Action

Check the aftertreatment SCR dosing air assist valve resistance.

  • Measure the resistance between the aftertreatment SCR dosing air assist valve SUPPLY pin and the aftertreatment SCR dosing air assist valve RETURN pin at the aftertreatment SCR dosing air assist valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 6.5 to 12.5 ohms?
YES NO
No Repair

Replace the aftertreatment SCR dosing air assist valve. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM OEM connector.

Action

Inspect the OEM harness and ECM OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing air assist valve from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment SCR dosing air assist valve SUPPLY pin at the aftertreatment SCR dosing air assist valve harness connector and battery positive (+).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing air assist valve from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the aftertreatment SCR dosing air assist valve SUPPLY pin at the aftertreatment SCR dosing air assist valve harness connector and block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing air assist valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment SCR dosing air assist valve SUPPLY pin at the OEM harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A short circuit to ground has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jun-2013


FAULT CODE 4238 - Aftertreatment 1 SCR Dosing Air Assist Absolute Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4172, 4173, 4176, 4177, 4271, or sensor supply fault code active?
 | STEP 1B. Check for aftertreatment selective catalytic reduction (SCR) dosing air assist valve fault codes. | Fault Code 4238 active?
STEP 2. | Check aftertreatment SCR dosing air assist valve and circuit. |
 | STEP 2A. Inspect the aftertreatment SCR dosing air assist valve and circuit. | Dirty or damaged pins
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
STEP 4. | Check the aftertreatment SCR dosing air assist valve and the air supply and transfer lines. |
 | STEP 4A. Inspect the air supply and transfer lines to the diesel exhaust fluid (DEF) dosing unit. | OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
 | STEP 4B. Check the DEF dosing unit aftertreatment SCR dosing air assist valve. | Aftertreatment SCR dosing air assist valve clicking at a regular interval?
 | STEP 4C. Check the DEF dosing unit. | Air flowing from the outlet of the DEF dosing unit greater than specification?
STEP 5. | Perform the DEF doser pump override test. |
 | STEP 5A. Perform the DEF doser pump override test with INSITE™ electronic service tool. | Diesel exhaust fluid dosing unit meet the specifications outlined in the procedure?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4172, 4173, 4176, 4177, 4271, or sensor supply fault code active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for aftertreatment SCR dosing air assist valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4238 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment SCR dosing air assist valve and circuit.

Guided Step 2A - Inspect the aftertreatment SCR dosing air assist valve and connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the aftertreatment SCR dosing air assist valve from the OEM harness.

Action

Inspect the OEM harness and aftertreatment SCR dosing air assist valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Go to 6A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment SCR dosing air assist valve from the OEM harness.

Action

Measure the resistance between the aftertreatment SCR dosing air assist valve RETURN pin at the harness connector and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the aftertreatment SCR dosing air assist valve and the air supply and transfer lines.

Guided Step 4A - Inspect the air supply and transfer lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Make sure the vehicle air tanks are full.

Action

Inspect the OEM air supply and DEF transfer line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line and DEF transfer line.
  • Make sure a clean air supply of at least 600kPa [87 psi] of pressure is present at the DEF dosing unit downstream of the air filter.
  • Make sure the air filter is not clogged or leaking.
  • Refer to the OEM service manual.

Is the OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO
No Repair

Repair the OEM air supply connection or transfer line. Refer to the OEM service manual.

Go to 4B

Go to 6A

Guided Step 4B - Check the DEF dosing unit aftertreatment SCR dosing air assist valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the vehicle air tanks are full.

Action

Check the aftertreatment SCR dosing air assist valve.

  • Use INSITE™ electronic service tool to select the “Diesel Exhaust Fluid Doser Pump aftertreatment SCR dosing air assist valve Click Test” under the ECM Diagnostic Tests menu.
  • Perform the aftertreatment SCR dosing air assist valve operability test by following the instruction on the screen.
  • Check for correct aftertreatment SCR dosing air assist valve operation.
  • While the test is running, the aftertreatment SCR dosing air assist valve should click at a regular interval.

Is the aftertreatment SCR dosing air assist valve clicking at a regular interval?
YES NO
No Repair

A malfunctioning aftertreatment SCR dosing air assist valve has been detected. Replace the aftertreatment SCR dosing air assist valve. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check the aftertreatment DEF dosing unit outlet air flow.

Conditions

  • Remove the DEF line from the aftertreatment nozzle and secure appropriately.
  • Connect the air flow meter, Part Number 5296515, from the doser pump cleaner kit, Part Number 5296510, to outlet of the DEF line.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the vehicle air tanks are full.

Action

Check the aftertreatment SCR dosing air assist valve.

  • Use INSITE™ electronic service tool to select the “Diesel Exhaust Fluid Doser Pump aftertreatment SCR dosing air assist valve Click Test” under the ECM Diagnostic Tests menu.
  • Perform the air flow test by following the instruction on the screen.
  • Check for correct aftertreatment SCR dosing air assist valve operation.
  • While the test is running, the aftertreatment SCR dosing air assist valve should click, and air flow must be felt at the outlet of the DEF dosing unit at a regular interval.
  • Specification Air flow greater than 24 liters [6.3 gal] per minute.

Air flowing from the outlet of the DEF dosing unit greater than specification?
YES NO
No Repair

A blocked air circuit inside the DEF dosing unit has been detected.

Flush the air circuit of the DEF dosing unit. Refer to Procedure 011-082 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Perform the DEF doser pump override test.

Guided Step 5A - Perform the DEF doser pump override test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

Does the DEF dosing unit meet the specifications outlined in the procedure?
YES NO
No Repair

Replace the DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Feb-2015


FAULT CODE 4239 - Aftertreatment 1 SCR Dosing Air Assist Absolute Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4172, 4173, 4176, 4177, or sensor supply fault code active?
 | STEP 1B. Check for air solenoid fault codes. | Fault Code 4239 active?
STEP 2. | Check air solenoid and diesel exhaust fluid (DEF) line. |
 | STEP 2A. Check the DEF dosing unit air solenoid. | Air solenoid clicking at a regular interval?
 | STEP 2B. Check the DEF dosing unit. | Is air flowing from the outlet of the DEF dosing unit greater than the specification?
 | STEP 2C. Inspect the diesel exhaust fluid lines. | Is air flowing from the outlet of the original equipment manufacturer (OEM) DEF linegreater than specification?
 | STEP 2D. Inspect the aftertreatment nozzle. | Air flowing at all four holes of the aftertreatment nozzle during the test?
STEP 3. | Perform the Diesel Exhaust Fluid Doser Pump Override Test. |
 | STEP 3A. Perform the DEF Doser Pump Override Test. | DEF dosing unit meet the specification outlined in the procedure?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4172, 4173, 4176, 4177, or sensor supply fault code active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air solenoid fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4239 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the air solenoid and diesel exhaust fluid line.

Guided Step 2A - Check the diesel exhaust fluid dosing unit air solenoid.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the vehicle air tanks are full.

Action

Check the air solenoid.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test under the ECM Diagnostic Tests menu.
  • Check for correct solenoid operation.
  • While the test is running, the air solenoid should click at a regular interval.

Is the air solenoid clicking at a regular interval?
YES NO
No Repair

A malfunctioning air solenoid has been detected. Replace the air solenoid. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check the DEF dosing unit.

Conditions

  • Disconnect DEF line from the outlet of the DEF dosing unit and secure appropriately.
  • Connect the air flow meter, Part Number 5296515, from the doser pump cleaner kit, Part Number 5296510, to the outlet of the DEF dosing unit.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the vehicle air tanks are full.

Action

Check the air solenoid.

  • Make sure a clean air supply of more than 600 kPa [87 psi] of pressure is present at the DEF dosing unit downstream of the air filter.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test under the ECM Diagnostic Tests menu.
  • Check for correct solenoid operation.
  • While the test is running, the air solenoid should click and air flow must be felt at the outlet of the DEF dosing unit at a regular interval.
  • Specification: Air flow greater than 24 liters [6.3 gal] per minute.

Is air flowing from the outlet of the DEF dosing unit greater than the specification?
YES NO
No Repair

A blocked air circuit inside the diesel exhaust fluid dosing unit has been detected.

Flush the air circuit of the DEF dosing unit. Refer to Procedure 011-082 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the diesel exhaust fluid lines.

Conditions

  • Connect the DEF line to the outlet of the DEF dosing unit.
  • Disconnect DEF line from the aftertreatment nozzle and secure appropriately.
  • Connect the air flow meter, Part Number 5296515, from the doser pump cleaner kit, Part Number 5296510, to the outlet of the DEF dosing unit.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the vehicle air tanks are full.

Action

Inspect the OEM DEF line attached to the DEF dosing unit.

  • Check for kinks and restriction in the DEF line.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test under the ECM Diagnostic Tests menu.
  • While the test is running, the air solenoid should click, and air flow must be felt at the outlet of the diesel exhaust fluid line at a regular interval.
  • Specification: Air flow greater than 24 liters [6.3 gal] per minute.

Is air flowing from the outlet of the OEM DEF linegreater than specification?
YES NO
No Repair

Repair or replace the OEM DEF transfer line and connections. Refer to the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2DInspecttheaftertreatmentnozzle. -

Conditions

  • Connect the DEF line to the aftertreatment nozzle.
  • Remove the aftertreatment nozzle from the exhaust system.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the vehicle air tanks are full.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test under the ECM Diagnostic Tests menu.
  • While the test is running, the air solenoid should click, and air flow must be felt at all four holes of the aftertreatment nozzle at a regular interval.

Is air flowing at all four holes of the aftertreatment nozzle during the test?
YES NO
No Repair

A plugged aftertreatment nozzle has been detected. Clean or replace the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Perform the DEF Doser Pump Override Test.

Guided Step 3A - Perform the DEF doser pump override test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle engine.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.
  • Check to make sure that the diesel exhaust fluid is being injected through the aftertreatment nozzle during the dosing state.

Does the DEF dosing unit meet the specification outlined in the procedure?
YES NO
No Repair

Replace the DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Jun-2013


FAULT CODE 4271 - Aftertreatment 1 SCR Dosing Air Assist Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Nozzle | Refer to Procedure 011-040 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing System Leak Test | Refer to Procedure 011-080 | ISL9.5 CM2150 SN | 4310608
Aftertreatment Diesel Exhaust Fluid Dosing Unit Air Side Flushing | Refer to Procedure 011-082 | ISL9.5 CM2150 SN | 4310608

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4172, 4173, 4176, 4177, 4238, or 4239 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4271 active?
STEP 2. | Check the air solenoid. |
 | STEP 2A. Check the diesel exhaust fluid (DEF) dosing unit air solenoid . | Air solenoid clicking at a regular interval?
 | STEP 2B. Check the DEF dosing unit. | Air flowing from the outlet of the DEF dosing unit greater than the specification?
 | STEP 2C. Inspect the DEF lines. | Air flowing from the outlet of the original equipment manufacturer (OEM) DEF line greater than the specification?
 | STEP 2D. Inspect the aftertreatment nozzle | Air flowing from all four holes of the aftertreatment nozzle during the test?
STEP 3. | Perform the DEF Doser Pump Override Test. |
 | STEP 3A. Perform the DEF Doser Pump Override Test with INSITE™ electronic service tool | DEF dosing unit meet the specifications outlined in the procedure?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4172, 4173, 4176, 4177, 4238, or 4239 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4271 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air solenoid.

Guided Step 2A - Check the DEF dosing unit air solenoid.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the vehicle air tanks are full.

Action

Check the air solenoid.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test under the ECM Diagnostic Tests menu.
  • Check for correct solenoid operation.
  • While the test is running, the air solenoid should click at a regular interval.

Air solenoid clicking at a regular interval?
YES NO
No Repair

A malfunctioning air solenoid has been detected in the dosing unit.

Replace the air solenoid. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check the DEF dosing unit.

Conditions

  • Disconnect the DEF line from the outlet of the DEF dosing unit and secure appropriately.
  • Connect the air flow meter, Part Number 5296515, from the Doser Pump Cleaner Kit, Part Number 5296510, to the outlet of the DEF dosing unit.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the vehicle air tanks are full.

Action

Check the air solenoid.

  • Make sure a clean air supply of more than 600 kPa [87 psi] of pressure is present at the DEF dosing unit downstream of the air filter.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test under the ECM Diagnostic Tests menu.
  • While the test is running, the air solenoid should click and air flow must be felt at the outlet of the DEF dosing unit at a regular interval.
  • Specification: Air flow greater than 24 liters [6.3 gal] per minute.

Air flowing from the outlet of the DEF dosing unit greater than the specification?
YES NO
No Repair

A blocked air circuit inside the DEF dosing unit has been detected.

Flush the air circuit of the DEF dosing unit. Refer to Procedure 011-082 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the DEF lines.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure appropriately.
  • Connect the air flow meter, Part Number 5296515, from the Doser Pump Cleaner Kit, Part Number 5296510, to the outlet of the DEF dosing unit.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the vehicle air tanks are full.

Action

Inspect the original equipment manufacturer (OEM) DEF line attached to the DEF dosing unit.

  • Make sure a clean air supply or more than 600 kPa [87 psi] of pressure is present at the DEF dosing unit downstream of the air filter.
  • Check for kinks and restriction in the DEF line.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test under the ECM Diagnostic Tests menu.
  • While the test is running, the air solenoid should click, and air flow must be felt at the outlet of the DEF line at a regular interval.
  • Specification: Air flow greater than 24 liters [6.3 gal] per minute.

Air flowing from the outlet of the OEM DEF line greater than the specification?
YES NO
No Repair

Repair or replace the OEM DEF transfer line and connections. Refer to the OEM service manual.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the aftertreatment nozzle.

Conditions

  • Connect the DEF line to the aftertreatment nozzle.
  • Remove the aftertreatment nozzle from the exhaust system.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the vehicle air tanks are full.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Air Solenoid Click Test under the ECM Diagnostic Tests menu.
  • While the test is running, the air solenoid should click, and air flow must be felt at all four holes of the aftertreatment nozzle at a regular interval.

Air flowing from all four holes of the aftertreatment nozzle during the test?
YES NO
No Repair

A plugged aftertreatment nozzle has been detected.

Clean or replace the aftertreatment nozzle. Refer to Procedure 011-040 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Perform the Diesel Exhaust Fluid Doser Pump Override Test.

Guided Step 3A - Perform the Diesel Exhaust Fluid Doser Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.Check to make sure theDEF is being injected through the aftertreatment nozzle during the dosing state.

  • DEF dosing unit meet the specifications outlined in the procedure?
YES NO
No Repair

Replace the DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Sep-2013


INDEX
179-fc111.htm

178-t05-111.htm

179-fc115.htm

178-t05-115.htm

179-fc122.htm

178-t05-122.htm

179-fc123.htm

178-t05-123.htm

179-fc125.htm

179-t05-125.htm

179-fc131.htm

178-t05-131.htm

179-fc132.htm

178-t05-132.htm

179-fc133.htm

178-t05-133.htm

179-fc134.htm

178-t05-134.htm

179-fc135.htm

178-t05-135.htm

179-fc141.htm

178-t05-141.htm

179-fc143.htm

178-t05-143.htm

179-fc144.htm

178-t05-144.htm

179-fc145.htm

178-t05-145.htm

179-fc151.htm

178-t05-151.htm

179-fc153.htm

178-t05-153.htm

179-fc154.htm

178-t05-154.htm

179-fc155.htm

178-t05-155.htm

179-fc195.htm

178-t05-195.htm

179-fc196.htm

178-t05-196.htm

179-fc197.htm

178-t05-197.htm

179-fc221.htm

178-t05-221.htm

179-fc222.htm

178-t05-222.htm

179-fc234.htm

178-t05-234.htm

179-fc238.htm

178-t05-238.htm

179-fc239.htm

178-t05-239.htm

179-fc241.htm

178-t05-241.htm

179-fc242.htm

178-t05-242.htm

179-fc245.htm

178-t05-245.htm

179-fc249.htm

178-t05-249.htm

179-fc256.htm

178-t05-256.htm

179-fc269.htm

178-t05-269.htm

179-fc271.htm

178-t05-271.htm

179-fc272.htm

178-t05-272.htm

179-fc285.htm

178-t05-285.htm

179-fc286.htm

178-t05-286.htm

179-fc287.htm

178-t05-287.htm

179-fc288.htm

178-t05-288.htm

179-fc291.htm

178-t05-291.htm

179-fc295.htm

178-t05-295.htm

179-fc322.htm

178-t05-322.htm

179-fc323.htm

178-t05-323.htm

179-fc324.htm

178-t05-324.htm

179-fc325.htm

178-t05-325.htm

179-fc331.htm

178-t05-331.htm

179-fc332.htm

178-t05-332.htm

179-fc334.htm

178-t05-334.htm

179-fc343.htm

178-t05-343.htm

179-fc351.htm

178-t05-351.htm

179-fc352.htm

179-t05-352.htm

179-fc386.htm

179-t05-386.htm

179-fc415.htm

178-t05-415.htm

179-fc418.htm

178-t05-418.htm

179-fc428.htm

178-t05-428.htm

179-fc429.htm

178-t05-429.htm

179-fc435.htm

178-t05-435.htm

179-fc436.htm

178-t05-436.htm

179-fc441.htm

178-t05-441.htm

179-fc442.htm

178-t05-442.htm

179-fc449.htm

179-t05-449.htm

179-fc451.htm

178-t05-451.htm

179-fc452.htm

178-t05-452.htm

179-fc545.htm

179-t05-545.htm

179-fc553.htm

179-t05-553.htm

179-fc554.htm

179-t05-554.htm

179-fc559.htm

179-t05-559.htm

179-fc584.htm

178-t05-584.htm

179-fc585.htm

178-t05-585.htm

179-fc596.htm

178-t05-596.htm

179-fc597.htm

178-t05-597.htm

179-fc598.htm

178-t05-598.htm

179-fc649.htm

178-t05-649.htm

179-fc689.htm

178-t05-689.htm

179-fc697.htm

178-t05-697.htm

179-fc698.htm

178-t05-698.htm

179-fc699.htm

178-t05-699.htm

179-fc731.htm

178-t05-731.htm

179-fc778.htm

178-t05-778.htm

179-fc1117.htm

178-t05-1117.htm

179-fc1239.htm

178-t05-1239.htm

179-fc1241.htm

178-t05-1241.htm

179-fc1242.htm

178-t05-1242.htm

179-fc1668.htm

179-t05-1668.htm

179-fc1669.htm

179-t05-1669.htm

179-fc1671.htm

178-t05-1671.htm

179-fc1673.htm

178-t05-1673.htm

179-fc1677.htm

178-t05-1677.htm

179-fc1678.htm

178-t05-1678.htm

179-fc1679.htm

179-t05-1679.htm

179-fc1682.htm

179-t05-1682.htm

179-fc1683.htm

179-t05-1683.htm

179-fc1684.htm

179-t05-1684.htm

179-fc1694.htm

178-t05-1694.htm

179-fc1712.htm

179-t05-1712.htm

179-fc1713.htm

179-t05-1713.htm

179-fc1852.htm

178-t05-1852.htm

179-fc1887.htm

179-t05-1887.htm

179-fc1911.htm

179-t05-1911.htm

179-fc2182.htm

179-t05-2182.htm

179-fc2183.htm

179-t05-2183.htm

179-fc2185.htm

178-t05-2185.htm

179-fc2186.htm

178-t05-2186.htm

179-fc2265.htm

179-t05-2265.htm

179-fc2266.htm

179-t05-2266.htm

179-fc2311.htm

179-t05-2311.htm

179-fc2321.htm

178-t05-2321.htm

179-fc2322.htm

178-t05-2322.htm

179-fc2363.htm

179-t05-2363.htm

179-fc2367.htm

179-t05-2367.htm

179-fc2377.htm

178-t05-2377.htm

179-fc2448.htm

178-t05-2448.htm

179-fc2555.htm

178-t05-2555.htm

179-fc2556.htm

178-t05-2556.htm

179-fc2771.htm

179-t05-2771.htm

179-fc2772.htm

179-t05-2772.htm

179-fc2773.htm

179-t05-2773.htm

179-fc2963.htm

178-t05-2963.htm

179-fc2964.htm

178-t05-2964.htm

179-fc3142.htm

179-t05-3142.htm

179-fc3143.htm

179-t05-3143.htm

179-fc3144.htm

179-t05-3144.htm

179-fc3163.htm

178-t05-3163.htm

179-fc3164.htm

179-t05-3164.htm

179-fc3242.htm

179-t05-3242.htm

179-fc3326.htm

178-t05-3326.htm

179-fc3492.htm

178-t05-3492.htm

179-fc3559.htm

179-t05-3559.htm

179-fc3565.htm

179-t05-3565.htm

179-fc3566.htm

179-t05-3566.htm

179-fc3568.htm

179-t05-3568.htm

179-fc3571.htm

179-t05-3571.htm

179-fc3572.htm

179-t05-3572.htm

179-fc3574.htm

179-t05-3574.htm

179-fc3575.htm

179-t05-3575.htm

179-fc3577.htm

179-t05-3577.htm

179-fc3578.htm

179-t05-3578.htm

179-fc3681.htm

178-t05-3681.htm

179-fc3735.htm

178-t05-3735.htm

179-fc4157.htm

179-t05-4157.htm

179-fc4172.htm

179-t05-4172.htm

179-fc4173.htm

179-t05-4173.htm

179-fc4174.htm

179-t05-4174.htm

179-fc4175.htm

179-t05-4175.htm

179-fc4176.htm

179-t05-4176.htm

179-fc4177.htm

179-t05-4177.htm

179-fc4238.htm

179-t05-4238.htm

179-fc4239.htm

179-t05-4239.htm

179-fc4271.htm

179-t05-4271.htm