INSITE Integrated Simulator - Multi Module, QSK38 CM2150 MCRS, QSK38 CM2150 MCRS Power Gen, QSK38, QSK50, and QSK60 CM2150 Simulator INSITE Integrated Simulator - Multi Module - P1, QSK50 CM2350 K118, QSK50 CM2358 K118, QSK50/60 CM2150 MCRS, QSK50/60 CM2150 MCRS Power Gen

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
ECM

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECMs are located on the left (fuel pump) side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 08-Aug-2016
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Fault Code Path Selection

FAULT CODE 1117
Fault Code Path Selection

Is the ECM source address 00? | Go to 122-fc1117sa00
Is the ECM source address 01? | Go to 122-fc1117sa01
Is the ECM source address 144? | Go to 122-fc1117sa144

Last Modified: 26-Feb-2010


Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117 (Source Address 00)

Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
QSK38 CM2150 Industrial - Power Supply Circuit
QSK38 CM2150 Marine - Power Supply Circuit
QSK38 CM2150 Power Generation - Power Supply Circuit
QSK38 CM2150 Power Generation (Military Application) - Power Supply Circuit
QSK50 CM2150 Industrial - Power Supply Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Power Supply Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Power Supply Circuit
QSK60 CM2150 Industrial - Power Supply Circuit
QSK60 CM2150 Power Generation - Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is a 10-ampere fuse in the battery 1 voltage wires to protect the harness from overheating. The ECM receives switched battery input through the ignition wire when the ignition is turned ON. The battery 1 voltage return is connected directly to the negative (-) battery post.

Component Location

The ECMs are connected to the batteries through the 4-pin connectors on the OEM harness. This direct link provides a constant power supply for the ECMs. The location of the batteries will vary with the OEM. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that is displayed when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 1117.
  • Inspect the intermittent keyswitch for fast keyswitch cycling.

NOTE: If a battery disconnect switch is turned OFF after the keyswitch is turned OFF, but before the ECM completely powers down (up to 30 seconds), this fault can register.

Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 1117.

Corrupted voltage (short interruptions or other spikes that can only be seen with an oscilloscope) on the ignition wire can cause this fault.

Refer to Troubleshooting Fault Code 1117 (Source Address 00).

Last Modified: 27-Sep-2010


Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117 (Source Address 01)

Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects, engine dying, or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
QSK38 CM2150 Industrial - Power Supply Circuit
QSK38 CM2150 Marine - Power Supply Circuit
QSK38 CM2150 Power Generation - Power Supply Circuit
QSK38 CM2150 Power Generation (Military Application) - Power Supply Circuit
QSK50 CM2150 Industrial - Power Supply Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Power Supply Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Power Supply Circuit
QSK60 CM2150 Industrial - Power Supply Circuit
QSK60 CM2150 Power Generation - Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is a 10-ampere fuse in the battery 1 voltage wires to protect the harness from overheating. The ECM receives switched battery input through the ignition wire when the ignition is turned ON. The battery 1 voltage return is connected directly to the negative (-) battery post.

Component Location

The ECMs are connected to the batteries through the 4-pin connectors on the OEM harness. This direct link provides a constant power supply for the ECMs. The location of the batteries will vary with the OEM. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that is displayed when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 1117.
  • Inspect the intermittent keyswitch for fast keyswitch cycling.

NOTE: If a battery disconnect switch is turned OFF after the keyswitch is turned OFF, but before the ECM completely powers down (up to 30 seconds), this fault can register.

Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 1117.

Corrupted voltage (short interruptions or other spikes that can only be seen with an oscilloscope) on the ignition wire can cause this fault.

Refer to Troubleshooting Fault Code 1117 (Source Address 01).

Last Modified: 10-Dec-2010


Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117 (Source Address 144)

Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition ON - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects, engine dying, or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
QSK38 CM2150 Industrial - Power Supply Circuit
QSK38 CM2150 Marine - Power Supply Circuit
QSK38 CM2150 Power Generation - Power Supply Circuit
QSK38 CM2150 Power Generation (Military Application) - Power Supply Circuit
QSK50 CM2150 Industrial - Power Supply Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Power Supply Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Power Supply Circuit
QSK60 CM2150 Industrial - Power Supply Circuit
QSK60 CM2150 Power Generation - Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is a 10-ampere fuse in the battery 1 voltage wires to protect the harness from overheating. The ECM receives switched battery input through the ignition wire when the ignition is turned ON. The battery 1 voltage return wires are connected directly to the negative (-) battery post.

Component Location

The ECMs are connected to the batteries through the 4-pin connectors on the OEM harness. This direct link provides a constant power supply for the ECMs. The location of the batteries will vary with the OEM. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 1117.
  • Inspect the intermittent keyswitch for fast keyswitch cycling.

NOTE: If a battery disconnect switch is turned OFF after the keyswitch is turned OFF, but before the ECM completely powers down (up to 30 seconds), this fault can register.

Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 1117.

Corrupted voltage (short interruptions or other spikes that can only be seen with an oscilloscope) on ignition wire can cause this fault.

Refer to Troubleshooting Fault Code 1117 (Source Address 144).

Last Modified: 10-Dec-2010


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: SPN: 612 FMI: 2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect | Fueling to the injectors is disabled and the engine can not be started.
QSK38 CM2150 Industrial - Engine Magnetic Speed/Position Sensor Circuit
QSK50 CM2150 Industrial - Engine Magnetic Speed/Position Sensor Circuit
QSK60 CM2150 Industrial - Engine Magnetic Speed/Position Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Magnetic Speed/Position Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Magnetic Speed/Position Sensor Circuit
QSK60 CM2150 Power Generation - Engine Magnetic Speed/Position Sensor Circuit
QSK38 CM2150 Marine - Engine Magnetic Speed/Position Sensor Circuit
QSK50 CM2150 Marine - Engine Magnetic Speed/Position Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The engine crankshaft speed/position sensor and the engine camshaft speed/position sensor are connected to the engine wiring harness.

Component Location

The engine crankshaft speed/position sensor reads a tone wheel mounted to the engine crankshaft. On the QSK50 the sensor is located on the top left side of the flywheel housing; on the QSK60 it is located on the top right side of the flywheel housing.

The engine camshaft speed/position sensor reads a tone wheel inside the front gear cover. The sensor is located on the left side of the engine on the back of the gear housing. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine speed sensor and camshaft position sensor use the same style sensor and the connector keys are the same. It is possible to connect the wiring harness to the incorrect sensors. If this occurs, the ECM will detect the problem and the engine will not start. Once the connector problem is corrected, the engine can be started and the fault code will become inactive.

Refer to Troubleshooting Fault Code 115.

Last Modified: 22-Sep-2010


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | None on performance for Power Generation applications.
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Applications) - Intake Manifold 1 Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The intake manifold 1 pressure sensor monitors intake manifold pressure and passes the information to the ECM through the engine harness. If the intake manifold 1 pressure sensor circuit voltage becomes too high, it will cause a derate condition on industrial applications.

Component Location

The intake manifold 1 pressure sensor is located in the left bank front air intake manifold. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 1 pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 122.

Last Modified: 16-Sep-2010


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the intake manifold 1 pressure circuit. | No engine protection for circuit sensor failure.
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Applications) - Intake Manifold 1 Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The intake manifold 1 pressure sensor monitors intake manifold pressure and passes the information to the ECM through the engine harness. If the intake manifold 1 pressure sensor circuit voltage becomes too low, it will cause a derate condition on Industrial applications.

Component Location

The intake manifold 1 pressure sensor is located in the left bank front air intake manifold. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 1 pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 123.

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 1256
Fault Code Path Selection

Is the ECM source address 00? | Go to 122-fc1256sa00
Is the ECM source address 01? | Go to 122-fc1256sa01
Is the ECM source address 144? | Go to 122-fc1256sa144

Last Modified: 26-Feb-2010


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1256 (Source Address 00)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1256 PID: SPN: 1563 FMI: 2 LAMP: Amber SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect | Possibly none on performance. The engine will not run.
QSK38 CM2150 Industrial - Control Module Identification Circuit
QSK38 CM2150 Power Generation - Control Module Identification Circuit
QSK38 CM2150 Power Generation (Military Application) - Control Module Identification Circuit
QSK38 CM2150 Marine Propulsion - Control Module Identification Circuit
QSK38 CM2150 Marine Auxiliary - Control Module Identification Circuit
QSK50 and QSK60 CM2150 Industrial - Control Module Identification Circuit
QSK50 CM2150 without Advanced Engine Monitoring/QSK50 CM2150 with Advanced Engine Monitoring and QSK60 CM2150 Power Generation - Control Module Identification Circuit
QSK50 and QSK60 CM2150 Marine Propulsion - Control Module Identification Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary/QSK60 CM2150 Drill Rig - Control Module Identification Circuit

Circuit Description

If the control module identification input for the electronic control module (ECM) does not match the internal ECM's memory (i.e. how it has been running before), Fault Code 1256 will go active.

Component Location

The ECM is located on the fuel system side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault can go active if a new ECM is connected in the wrong location or the wrong calibration is downloaded on the ECM.

Refer to Troubleshooting Fault Code 1256 (Source Address 00).

Last Modified: 16-Sep-2010


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1256 (Source Address 01)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1256 PID: SPN: 1563 FMI: 2 LAMP: Amber SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect | Possibly none on performance. The engine will not run.
QSK38 CM2150 Industrial/QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Control Module Identification Circuit
QSK38 CM2150 Marine - Control Module Identification Circuit
QSK50 and QSK60 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Control Module Identification Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 with Advanced Engine Monitoring and QSK60 CM2150 Power Generation - Control Module Identification Circuit

Circuit Description

If the control module identification input for the electronic control module (ECM) does not match the internal ECM's memory (i.e., how it has been running before), Fault Code 1256 will go active.

Component Location

The ECM is located on the fuel system side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault can go active if a new ECM is connected in the wrong location or the wrong calibration is downloaded on the ECM.

Refer to Troubleshooting Fault Code 1256 (Source Address 01).

Last Modified: 16-Sep-2010


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1256 (Source Address 144)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1256 PID: SPN: 1563 FMI: 2 LAMP: Amber SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect | Possibly none on performance. The engine will not run.
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring and QSK60 CM2150 Power Generation - Control Module Identification Circuit
QSK50 and QSK60 CM2150 Marine/QSK50 and QSK60 CM2150 Industrial/QSK60 CM2150 Drill Rig - Control Module Identification Circuit

Circuit Description

If the control module identification input for the electronic control module (ECM) does not match the internal ECM's memory (i.e., how it has been running before), Fault Code 1256 will go active.

Component Location

The ECM is located on the fuel system side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault can go active if a new ECM is connected in the wrong location or the wrong calibration is downloaded on the ECM.

Refer to Troubleshooting Fault Code 1256 (Source Address 144).

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 1257
Fault Code Path Selection

Is the ECM source address 00? | Go to 122-fc1257sa00
Is the ECM source address 01? | Go to 122-fc1257sa01
Is the ECM source address 144? | Go to 122-fc1257sa144

Last Modified: 26-Feb-2010


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1257 (Source Address 00)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1257 PID: SPN: 1563 FMI: 2 LAMP: Red SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect | Possibly none on performance. The engine will not run.
QSK38 CM2150 Industrial - Control Module Identification Circuit
QSK38 CM2150 Power Generation - Control Module Identification Circuit
QSK38 CM2150 Power Generation (Military Application) - Control Module Identification Circuit
QSK38 CM2150 Marine Propulsion - Control Module Identification Circuit
QSK38 CM2150 Marine Auxiliary - Control Module Identification Circuit
QSK50 and QSK60 CM2150 Industrial - Control Module Identification Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Control Module Identification Circuit
QSK50 and QSK60 CM2150 Marine Propulsion - Control Module Identification Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary/QSK60 CM2150 Drill Rig - Control Module Identification Circuit

Circuit Description

If the control module identification input for the ECM does not match the calibration, and the ECM has no image stored in its memory, Fault Code 1257 will go active.

Component Location

The ECM is located on the fuel system side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that is displayed when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault can go active if a new ECM is connected on the wrong location IN the wrong calibration is downloaded on the ECM.

Refer to Troubleshooting Fault Code 1257 (Source Address 00).

Last Modified: 16-Sep-2010


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1257 (Source Address 01)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1257 PID: SPN: 1563 FMI: 2 LAMP: Red SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect | Possibly none on performance. The engine will not run.
QSK38 CM2150 Industrial - Control Module Identification Circuit
QSK38 CM2150 Marine - Control Module Identification Circuit
QSK50 and QSK60 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Control Module Identification Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Control Module Identification Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Control Module Identification Circuit

Circuit Description

If the control module identification input for the ECM does not match the calibration, and the ECM has no image stored in its memory, Fault Code 1257 will go active.

Component Location

The ECM is located on the fuel system side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that is displayed when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault can go active if a new ECM is connected in the wrong location or the wrong calibration is downloaded on the ECM.

Refer to Troubleshooting Fault Code 1257 (Source Address 01).

Last Modified: 07-Oct-2010


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1257 (Source Address 144)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1257 PID: SPN: 1563 FMI: 2 LAMP: Red SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect | Possibly none on performance. The engine will not run.
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK50 CM2150 Power Generation - Control Module Identification Circuit
QSK50 and QSK60 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Control Module Identification Circuit

Circuit Description

If the control module identification input for the ECM does not match the calibration, and the ECM has no image stored in its memory, Fault Code 1257 will go active.

Component Location

The ECM is located on the fuel system side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that is displayed when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault can go active if a new ECM is connected on the wrong location or the wrong calibration is downloaded in the ECM.

Refer to Troubleshooting Fault Code 1257 (Source Address 144).

Last Modified: 17-Sep-2010


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: SPN: 100 FMI: 3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
QSK38 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK38 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK38 CM2150 Power Generation (Military Application) - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK38 CM2150 Marine - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Marine - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK60 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK60 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts it to a pressure value.

Component Location

The QSK50 engine oil rifle pressure 1 sensor is located on either side of the engine block, depending on the filter head option. The QSK60 engine oil rifle pressure 1 sensor is located on the rear right side of the engine block, behind the flywheel housing. The QSK38 marine engine oil rifle pressure 1 sensor is located on the left bank of the engine. On QSK38 industrial engines, the oil rifle pressure 1 sensor is located in the lubricating oil filter head, which can be located on the left or right bank of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine oil rifle pressure 1 sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 135.

Last Modified: 21-Sep-2010


Engine Oil Level Remote Reservoir - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1357

Engine Oil Level Remote Reservoir - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1357 PID: SPN: 1380 FMI: 18 LAMP: Amber SRT: | Engine Oil Level Remote Reservoir - Data Valid but Below Normal Operating Range - Moderately Severe Level. Engine oil level remote reservoir is below normal operating level. | No action taken by ECM. Possible damage to engine if left unresolved.
QSK38 CM2150 Industrial - Engine Oil Level Remote Reservoir Circuit
QSK38 CM2150 Power Generation - Engine Oil Level Remote Reservoir Circuit
QSK38 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Engine Oil Level Remote Reservoir Circuit
QSK38 CM2150 Marine with C Command™ Panel System - Engine Oil Level Remote Reservoir Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Engine Oil Level Remote Reservoir Circuit
QSK50 and QSK60 CM2150 Industrial - Engine Oil Level Remote Reservoir Circuit
QSK50 and QSK60 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System/QSK60 CM2150 Drill Rig - Engine Oil Level Remote Reservoir Circuit
QSK50 and QSK60 CM2150 with C Command™ Panel System - Engine Oil Level Remote Reservoir Circuit

Circuit Description

The engine oil level remote reservoir sensor monitors the oil level in the engine oil level remote reservoir and passes information to the ECM through the wiring harness.

Component Location

The location of the engine oil level remote reservoir is dependent on the OEM. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Refer to Troubleshooting Fault Code 1357.

Last Modified: 13-Dec-2010


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1358

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1358 PID: SPN: 91 FMI: 3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal or lever position sensor 1 circuit. | Calibration dependent power and speed derate.
QSK38 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Switch
QSK38 CM2150 Marine Propulsion - Accelerator Pedal or Lever Idle Validation Switch
QSK50 and QSK60 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Switch
QSK50 and QSK60 CM2150 Marine Propulsion - Accelerator Pedal or Lever Idle Validation Switch

Circuit Description

The accelerator pedal or lever position sensor is attached to the accelerator pedal. The accelerator pedal or lever position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal is depressed and released. The accelerator pedal or lever position circuit contains three wires: accelerator pedal or lever position 5 volt supply (sensor supply 4), accelerator pedal or lever position return (sensor return 4), and accelerator pedal or lever position signal.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal. Refer to the OEM service manual for a detailed component location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that is displayed when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal circuit shorted to battery, or accelerator pedal or lever position 5 volt supply (sensor supply 4)
  • Open accelerator pedal or lever position return (sensor return 4) circuit in the harness or connections
  • Accelerator pedal or lever position 5 volt supply (sensor supply 4) shorted to battery
  • Damaged accelerator pedal or lever position sensor.

The three wires in the accelerator position or lever sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1358.

Last Modified: 19-Apr-2010


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1359

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1359 PID: SPN: 91 FMI: 4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal or lever position signal circuit. | Calibration dependent power and speed derate.
QSK38 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Switch
QSK38 CM2150 Marine Propulsion - Accelerator Pedal or Lever Idle Validation Switch
QSK50 and QSK60 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Switch
QSK50 and QSK60 CM2150 Marine Propulsion - Accelerator Pedal or Lever Idle Validation Switch

Circuit Description

The accelerator pedal or lever position sensor is attached to the accelerator pedal. The accelerator pedal or lever position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal is depressed and released. The accelerator pedal or lever position sensor circuit contains three wires: accelerator pedal or lever position 5 volt supply (sensor supply 4), accelerator pedal or lever position return (sensor return 4), and accelerator pedal or lever position signal.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that is displayed when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal shorted to engine ground or accelerator pedal or lever position sensor return (sensor return 4) wires in the OEM harness or sensor.
  • Damaged accelerator pedal or lever position sensor.
  • Open circuit in the accelerator pedal or lever position signal wire or accelerator pedal or lever position supply (sensor supply 4) wire in the harness or connectors.

The three wires in the accelerator pedal or lever position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1359.

Last Modified: 19-Apr-2010


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1361

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1361 PID: SPN: 974 FMI: 4/4 LAMP: Amber SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the remote accelerator pedal or lever position sensor signal circuit. | Calibration-dependent power and speed derate.
QSK38 CM2150 Industrial - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command™ Panel System - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit
QSK50 and QSK60 CM2150 Industrial - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ Panel System - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit

Circuit Description

The remote accelerator pedal or lever position sensor provides the operator's accelerator command to the electronic control module (ECM) through the original equipment manufacturer (OEM) harness and engine harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote accelerator pedal or lever position sensor varies with each OEM. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If troubleshooting an intermittent remote accelerator pedal or lever position sensor problem, the remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while working the harness to locate the intermittent connection.

Possible causes of this fault code include:

  • Remote accelerator pedal or lever position signal wire has shorted to engine ground or remote accelerator pedal or lever position return (sensor return 1) wire in the OEM harness, engine harness, or sensor
  • A circuit is open in the remote accelerator pedal or lever position signal or remote accelerator pedal or lever position supply (sensor supply 1) in the harness or connectors
  • Damaged remote accelerator pedal or lever position sensor
  • The remote accelerator pedal or lever position enable switch must be turned on for the remote accelerator pedal or lever position sensor to operate.
Refer to Troubleshooting Fault Code 1361.

Last Modified: 19-Apr-2010


Engine Oil Filter Differential Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1362

Engine Oil Filter Differential Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1362 PID: SPN: 99 FMI: 16 LAMP: Amber SRT: | Engine Oil Filter Differential Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Calibration-dependent progressive power derate and engine shutdown with increasing time after alert.
QSK38 CM2150 Industrial - Engine Oil Filter Differential Pressure Circuit
QSK38 CM2150 Marine - Engine Oil Filter Differential Pressure Circuit
QSK50 CM2150 Industrial - Engine Oil Filter Differential Pressure Circuit
QSK50 CM2150 Power Generation with Advanced Engine Montoring - Engine Oil Filter Differential Pressure Circuit
QSK50 CM2150 Marine - Engine Oil Filter Differential Pressure Circuit
QSK60 CM2150 Industrial - Engine Oil Filter Differential Pressure Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Oil Filter Differential Pressure Circuit

Circuit Description

The engine oil filter differential pressure is monitored by the electronic control module (ECM) before and after filtration. The pre-oil filter pressure sensor monitors the oil pressure before the filters. The post-oil filter pressure sensor monitors the pressure after the oil filters on the QSK60. The engine oil rifle pressure 1 sensor monitors this pressure on the QSK38 and QSK50. The ECM monitors the voltage on the signal pin and converts it to a pressure value.

Component Location

The pre-oil pressure and post-oil pressure sensors are located on or near the lubricating oil filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 1362 will go active when the difference between the oil pressure at the inlet and outlet of the oil filter head reaches a preset warning value. Reasons for this fault code include:

  • Plugged oil filters
  • Damaged sensors or harness
  • Plugged oil filter head.
Refer to Troubleshooting Fault Code 1362.

Last Modified: 10-May-2018


Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1367

Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1367 PID: SPN: 1208 FMI: 3 LAMP: Maintenance SRT: | Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the pre-oil filter pressure sensor circuit. | None on performance. No engine protection for pre-oil filter pressure.
QSK38 CM2150 Industrial - Pre-Oil Filter Pressure Sensor Circuit
QSK38 CM2150 Marine - Pre-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Industrial - Pre-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Pre-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Marine - Pre-Oil Filter Pressure Sensor Circuit
QSK60 CM2150 Industrial - Pre-Oil Filter Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Pre-Oil Filter Pressure Sensor Circuit

Circuit Description

The pre-oil filter pressure sensor is used by the electronic control module (ECM) to monitor the lubricating pre-oil filter pressure before the oil filters. The ECM monitors the voltage on the pre-oil filter pressure signal pin and converts it to a pressure value.

Component Location

The pre-oil filter pressure sensor is located on the inboard side of the oil filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The pre-oil filter pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1367, check for multiple faults.

Possible causes of this fault code include:

  • Open RETURN circuit in the harness, connectors, or sensor
  • A SIGNAL circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1367.

Last Modified: 16-Sep-2010


Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1368

Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1368 PID: SPN: 1208 FMI: 4/4 LAMP: Maintenance SRT: | Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the pre-oil filter pressure circuit. | None on performance. No engine protection for pre-oil filter pressure.
QSK38 CM2150 Industrial - Pre-Oil Filter Pressure Sensor Circuit
QSK38 CM2150 Marine - Pre-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Industrial - Pre-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Pre-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Marine - Pre-Oil Filter Pressure Sensor Circuit
QSK60 CM2150 Industrial - Pre-Oil Filter Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Pre-Oil Filter Pressure Sensor Circuit

Circuit Description

The pre-oil filter pressure sensor is used by the electronic control module (ECM) to monitor the lubricating pre-oil filter pressure before the lubricating oil filters. The ECM monitors the voltage on the pre-oil filter pressure signal pin and converts it to a pressure value.

Component Location

The pre-oil filter pressure sensor is located on the inboard side of the oil filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The pre-oil filter pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1368, check for multiple faults.

Possible causes of this fault include:

  • A SIGNAL circuit open or shorted to ground in the engine harness or sensor
  • A SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1368.

Last Modified: 16-Sep-2010


Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1369

Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1369 PID: SPN: 441 FMI: 3 LAMP: Maintenance SRT: | Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the OEM auxiliary temperature sensor input 1 circuit. | None on performance.
QSK38 CM2150 Industrial - Auxiliary Temperature Sensor Input 1 Circuit
QSK38 CM2150 Power Generation (Military Application) - Auxiliary Temperature Sensor Input 1 Circuit
QSK50 and QSK60 CM2150 Industrial - Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring an auxiliary temperature sensor input 1 to the ECM. A specific calibration is then created to recognize this temperature sensor input.

Component Location

The OEM auxiliary temperature sensor input 1 will vary depending, on application. Refer to the OEM service manual for sensor location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open RETURN circuit in the harness, connectors, or sensor
  • Open SIGNAL circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 1369.

Last Modified: 16-Sep-2010


Start Enable Device 1 Circuit (Ether Injection) - Root Cause Not Known

FAULT CODE 1373

Start Enable Device 1 Circuit (Ether Injection) - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1373 PID: SPN: 626 FMI: 11 LAMP: Maintenance SRT: | Start Enable Device 1 Circuit (Ether Injection) - Root Cause Not Known. | Ether injection feature is disabled. Possible white smoke, engine hard to start in cold temperatures.
QSK38 CM2150 Industrial - Start Enable Device 1 Circuit (Ether Injection) Circuit
QSK38 CM2150 Power Generation (Military Application) - Start Enable Device 1 Circuit (Ether Injection) Circuit
QSK50 and QSK60 CM2150 Industrial - Start Enable Device 1 (Ether Injection) Circuit

Circuit Description

The start enable device 1 circuit (ether injection) is used by the ECM to control the ether injection system during cold starts. The start enable device 1 circuit (ether injection) controls the injection of ether into the air intake in order to allow a better start under cold engine conditions.

Component Location

The ether injection solenoid location is dependent on the OEM. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open or short circuit on the start enable device 1 circuit (ether injection) driver signal
  • Defective ether injection solenoid.
Refer to Troubleshooting Fault Code 1373.

Last Modified: 16-Sep-2010


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1376

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1376 PID: SPN: 723 FMI: 2 LAMP: Maintenance SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine camshaft speed/position signal. | Possible poor starting. Engine power derate.
QSK38 CM2150 Industrial - Engine Camshaft Speed/Position Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Camshaft Speed/Position Sensor Circuit
QSK38 CM2150 Marine - Engine Camshaft Speed/Position Sensor Circuit
QSK50 CM2150 Industrial - Engine Camshaft Speed/Position Sensor Circuit
QSK60 CM2150 Industrial - Engine Camshaft Speed/Position Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring and QSK60 CM2150 Power Generation - Engine Camshaft Speed/Position Sensor Circuit
QSK50 CM2150 Marine - Engine Camshaft Speed/Position Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine camshaft speed/position sensor provides engine position information to the ECM. The engine camshaft speed/position sensor is powered by 5 VDC. The engine camshaft speed/position sensor generates the signal by sensing the movement of target teeth machined into the camshaft gear.

Component Location

The engine camshaft speed/position sensor is located above the fuel pump, in back of the gear housing.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is recorded when the ECM does not receive or receives a degraded signal from the engine camshaft speed/position sensor

The fault code will go inactive when the normal backup camshaft speed/position sensor signal is detected.

Possible causes of this fault code include:

  • Open circuit on the SUPPLY, SIGNAL, or RETURN circuits in the camshaft speed/position sensor, engine harness, or ECM
  • Short circuits to ground or RETURN circuits in the sensor, engine harness, or ECM
  • Short circuits to a voltage source in the sensor, engine harness, or ECM
  • Damage to the engine camshaft speed/position sensor target teeth or camshaft gear.

INSITE™ electronic service tool monitor parameters associated with this fault code and sensor include:

  • Camshaft speed/position sensor state.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections, such as loose or worn pins in the engine harness connectors.

If this fault code occurs intermittently, Fault Code 2322 will also be active or have high counts.

Refer to Troubleshooting Fault Code 1376.

Last Modified: 16-Sep-2010


Post-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1377

Post-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1377 PID: SPN: 3549 FMI: 3 LAMP: Maintenance SRT: | Post-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the post-oil filter pressure sensor circuit. | None on performance. No engine protection for oil pressure.
QSK50 CM2150 Industrial - Post-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Post-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Post-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Marine - Post-Oil Filter Pressure Sensor Circuit
QSK60 CM2150 Industrial - Post-Oil Filter Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Post-Oil Filter Pressure Sensor Circuit

Circuit Description

The post-oil filter pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure after the oil filters. The ECM monitors the voltage on the post-oil filter pressure signal pin and converts it to a pressure value.

Component Location

The post-oil filter pressure sensor is located on the outboard side of the oil filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The post-oil filter pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1377, check for multiple faults.

Possible causes of this fault code include:

  • Open RETURN circuit in the harness, connectors, or sensor
  • SIGNAL circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1377.

Last Modified: 16-Sep-2010


Post-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1378

Post-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1378 PID: SPN: 3549 FMI: 4 LAMP: Maintenance SRT: | Post-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the post-oil filter pressure sensor circuit. | None on performance. No engine protection for post-oil filter pressure.
QSK50 CM2150 Industrial - Post-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Post-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Post-Oil Filter Pressure Sensor Circuit
QSK50 CM2150 Marine - Post-Oil Filter Pressure Sensor Circuit
QSK60 CM2150 Industrial - Post-Oil Filter Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Post-Oil Filter Pressure Sensor Circuit

Circuit Description

The post-oil filter pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure after the oil filters. The ECM monitors the voltage on the post-oil filter pressure signal pin and converts it to a pressure value.

Component Location

The post-oil filter pressure sensor is located on the outboard side of the oil filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The post-oil filter pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1378, check for multiple faults.

Possible causes of this fault include:

  • SIGNAL circuit open or shorted to ground in the engine harness or sensor
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1378.

Last Modified: 16-Sep-2010


Auxiliary Temperature Sensor Input 1 - Special Instructions

FAULT CODE 1381

Auxiliary Temperature Sensor Input 1 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1381 PID: SPN: 441 FMI: 14 LAMP: Maintenance SRT: | Auxiliary Temperature Sensor Input 1 - Special Instructions. OEM temperature out-of-range has been detected. Voltage signal at the OEM temperature SIGNAL pin indicates OEM temperature is beyond the OEM-specified threshold. | Calibration-dependent progressive power and speed derate and engine shutdown with increasing time after alert.
QSK38 CM2150 Industrial - Auxiliary Temperature Sensor Input 1 Circuit
QSK38 CM2150 Power Generation (Military Application) - Auxiliary Temperature Sensor Input 1 Circuit
QSK50 and QSK60 CM2150 Industrial - Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The OEM resistive signal is used by the ECM to monitor an OEM temperature. The OEM temperature is used by the ECM for the engine protection system.

Component Location

The location varies with the OEM. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

Refer to Troubleshooting Fault Code 1381.

Last Modified: 16-Sep-2010


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1383

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1383 PID: SPN: 102 FMI: 3 LAMP: Maintenance SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Possible engine power derate to no air setting for Industrial applications. For Marine applications, no derate occurs.
QSK38 CM2150 Industrial - Intake Manifold 1 Pressure Sensor Circuit
QSK38 CM2150 Marine - Intake Manifold 1 Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 1 Pressure Sensor Circuit
QSK50 CM2150 Industrial - Intake Manifold 1 Pressure Sensor Circuit
QSK50 CM2150 Marine - Intake Manifold 1 Pressure Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 1 Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The intake manifold 1 pressure sensor monitors intake manifold pressure and passes the information to the ECMs through the engine harness. The engine has only one intake maniofld 1 pressure sensor, and the intake manifold 1 pressure sensor circuit voltage becomes too high, it will cause a derate condition. If the engine has more than one intake manifold 1 pressure sensor, and only one sensor faults (generating a fault code) no negative effect will occur. The ECM will ignore the damaged sensor and use the other sensor for calculating fueling. If both sensors malfunction, a default intake manifold pressure value will be used and detates can occur.

For marine applications, no derate condition occurs. There is no engine protection for a intake manifold 1 pressure sensor or circuit fault.

Component Location

The intake manifold 1 pressure sensor is located in the left bank front air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 1 pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1383, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Supply wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1383.

Last Modified: 13-Apr-2010


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1384

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1384 PID: SPN: 102 FMI: 4 LAMP: Maintenance SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the intake manifold 1 pressure circuit. | Possible engine power derate to no air setting for Industrial applications. For Marine applications, no derate occurs.
QSK38 CM2150 Industrial - Intake Manifold 1 Pressure Sensor Circuit
QSK38 CM2150 Marine - Intake Manifold 1 Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 1 Pressure Sensor Circuit
QSK50 CM2150 Industrial - Intake Manifold 1 Pressure Sensor Circuit
QSK50 CM2150 Marine - Intake Manifold 1 Pressure Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 1 Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The intake manifold 1 pressure sensor monitors intake manifold pressure and passes information to the ECMs through the engine harness. If the engine has only one intake manifold 1 pressure sensor, and the intake manifold 1 pressure sensor circuit voltage becomes too high, it will cause a derate condition. If the engine has more than one intake manifold 1 pressure sensor and only one sensor faults (generating a fault code), no negative effect will occur. The ECM will ignore the damaged sensor and use the other sensor for calculating fueling. If both sensors malfunction, then a default intake manifold pressure value will be used and derate can occur.

For marine applications, no derate condition occurs. There is no engine protection for an intake manifold 1 pressure sensor or circuit fault.

Component Location

The intake manifold 1 pressure sensor is located in the left bank front air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 1 pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1384, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1384.

Last Modified: 13-Apr-2010


Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1385

Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1385 PID: SPN: 1128 FMI: 3 LAMP: Maintenance SRT: | Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High SIGNAL voltage detected at the intake manifold 2 pressure sensor circuit. | Engine power derate to no air setting.
QSK38 CM2150 Industrial - Intake Manifold 2 Pressure Sensor Circuit
QSK38 CM2150 Marine - Intake Manifold 2 Pressure Sensor Circuit
QSK50 CM2150 Industrial - Intake Manifold 2 Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 2 Pressure Sensor Circuits
QSK50 CM2150 Marine - Intake Manifold 2 Pressure Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 2 Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 2 Pressure Sensor Circuit

Circuit Description

The intake manifold 2 pressure sensor monitors intake manifold pressure and passes information to the ECMs through the engine harness. If the intake manifold 2 pressure sensor circuit voltage becomes too high, it will cause a derate condition.

If the engine has more than one intake manifold 2 pressure sensor and only one sensor faults (generating a fault code), no negative effect will occur. The ECM will ignore the damaged sensor and use the other sensor for calculating fueling. If both sensors malfunction, a default intake manifold pressure value will be used and derate can occur.

Component Location

The intake manifold 2 pressure sensor is located in the right bank rear air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 2 pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1385, check for multiple faults.

Possible causes of this fault code include:

  • Open RETURN circuit in the engine harness, connectors, or sensor
  • SUPPLY wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1385.

Last Modified: 16-Sep-2010


Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1386

Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1386 PID: SPN: 1128 FMI: 4 LAMP: Maintenance SRT: | Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the intake manifold 2 pressure sensor circuit. | Engine power derate to no air setting.
QSK38 CM2150 Industrial - Intake Manifold 2 Pressure Sensor Circuit
QSK38 CM2150 Marine - Intake Manifold 2 Pressure Sensor Circuit
QSK50 CM2150 Industrial - Intake Manifold 2 Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 2 Pressure Sensor Circuit
QSK50 CM2150 Marine - Intake Manifold 2 Pressure Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 2 Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 2 Pressure Sensor Circuit

Circuit Description

The intake manifold 2 pressure sensor monitors intake manifold pressure and passes information to the ECMs through the engine harness. If the engine has only one intake manifold 1 pressure sensor, and the intake manifold 2 pressure sensor circuit voltage becomes too low, it will cause a derate condition. If the engine has more than one intake manifold 1 pressure sensor and only one sensor faults (generating a fault code) no negative effect will occur. The ECM will ignore the damaged sensor and use the other sensor for calculating fueling. If both sensors malfunction, a default intake manifold pressure value will be used and derates can occur.

For Marine applications, no derate condition occurs. There is no engine protection for a circuit or intake manifold 2 pressure sensor fault.

Component Location

The intake manifold 2 pressure sensor is located in the right bank rear air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 2 pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1386, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1386.

Last Modified: 16-Sep-2010


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
QSK38 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK38 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK38 CM2150 Power Generation (Military Application) - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK38 CM2150 Marine - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Marine - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK60 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK60 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value.

Component Location

The QSK50 engine oil rifle pressure 1 sensor is located on either side of the engine block, depending on the oil filter head option. The QSK60 engine oil rifle pressure 1 sensor is located on the rear right side of the engine block, behind the flywheel housing. The QSK38 marine engine oil rifle pressure 1 sensor is located in the lubricating oil filter head, which is located on the left bank of the engine. On the QSK38 industrial engines, the oil rifle pressure 1 sensor is located in the lubricating oil filter head, which can be mounted on the left or right bank of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine oil rifle pressure 1 sensor shares supply and return wires in the engine harness with other sensors. Open and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code 141.

Last Modified: 21-Sep-2010


Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1411

Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1411 PID: SPN: 4182 FMI: 3 LAMP: Amber SRT: | Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source | The generator output frequency adjust potentiometer will go to the default value.
QSK38 CM2150 Power Generation - Generator Output Frequency Adjust Potentiometer Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Generator Output Frequency Adjust Potentiometer Circuit
QSK38 CM2150 Marine Auxillary with C Command Elite™ and C Command Elite Plus™ Panel System - Generator Output Frequency Adjust Potentiometer Circuit
QSK38 CM2150 Marine Auxillary with C Command™ Panel System - Generator Output Frequency Adjust Potentiometer Circuit
QSK50 and QSK60 CM2150 Marine Auxillary with C Command Elite™ and C Command Elite Plus™ Panel System/QSK60 CM2150 Drill Rig - Generator Output Frequency Adjust Potentiometer Circuit
QSK50 and QSK60 CM2150 Marine Auxillary with C Command™ Panel System - Generator Output Frequency Adjust Potentiometer Circuit

Circuit Description

The generator output frequency adjust potentiometer is used to regulate the generator frequency.

Component Location

The generator output frequency adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Shop Talk

There are multiple electronic control module (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If Fault Code 1411 goes active, the generator output frequency adjust potentiometer will not respond.

Possible causes of the fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage
  • 5-VDC reference circuit shorted to high source.
Refer to Troubleshooting Fault Code 1411.

Last Modified: 17-Sep-2010


Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1412

Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1412 PID: SPN: 4183 FMI: 3 LAMP: Amber SRT: | Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source | The droop adjust potentiometer will go to the default value.
QSK38 CM2150 Power Generation - Droop Adjust Potentiometer Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Droop Adjust Potentiometer Circuit
QSK38 CM2150 Marine Auxiliary with C Command Elite™ - Droop Adjust Potentiometer Circuit
QSK38 CM2150 Marine Auxiliary with C Command™ Panel System - Droop Adjust Potentiometer Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command Elite™/QSK60 CM2150 Drill Rig - Droop Adjust Potentiometer Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command™ Panel System - Droop Adjust Potentiometer Circuit

Circuit Description

The droop adjust potentiometer is used to regulate the engine droop.

Component Location

The droop adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Shop Talk

There are multiple electronic control module (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of the fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage
  • 5-VDC reference circuit shorted to high source.
Refer to Troubleshooting Fault Code 1412.

Last Modified: 20-Sep-2010


Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1418

Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1418 PID: SPN: 4184 FMI: 3 LAMP: Amber SRT: | Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source | The ECM gain adjust potentiometer will go to default value.
QSK38 CM2150 Power Generation - Gain Adjust Potentiometer Circuit
QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Gain Adjust Potentiometer Circuit

Circuit Description

The gain adjust potentiometer is used to regulate the governor gains.

Component Location

The gain adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Shop Talk

There are multiple electronic control module (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of the fault code include:

  • Open RETURN circuit in the engine harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage
  • 5-VDC reference circuit shorted to high source.
Refer to Troubleshooting Fault Code t05-1418

Last Modified: 16-Sep-2010


Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

FAULT CODE 1427

Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1427 PID: SPN: 4185 FMI: 31 LAMP: Amber SRT: | Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists | The overspeed shutdown lamp will not turn on.
QSK38 CM2150 Power Generation - Overspeed Shutdown Circuit
QSK38 CM2150 Marine Auxiliary - Overspeed Shutdown Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Overspeed Shutdown Circuit
QSK60 CM2150 Power Generation - Overspeed Shutdown Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary/QSK60 CM2150 Drill Rig - Overspeed Shutdown Circuit

Circuit Description

The overspeed shutdown lamp will indicate when the engine has reached overspeed. Fault Code 1992 will trigger the overspeed shutdown lamp.

Component Location

The overspeed shutdown lamp is located on the generator control panel. Refer to the OEM service manual for the overspeed shutdown lamp location.

Shop Talk

There are multiple electronic control modules for the engine models included in this manual. Each electronic control module (ECM) has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If the ECM detects an open lamp circuit, Fault Code 1427 will go active, even in the absence of Fault Code 1992. The ECM does not have to be trying to turn the lamp on to detect Fault Code 1427.

Possible causes of this fault code include:

  • Open SIGNAL circuit or shorted to voltage source
  • SIGNAL circuit shorted to ground in the harness
  • Open RETURN circuit in the OEM harness, connectors, or overspeed shutdown lamp.
Refer to Troubleshooting Fault Code t05-1427

Last Modified: 16-Sep-2010


Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

FAULT CODE 1428

Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1428 PID: SPN: 4186 FMI: 31 LAMP: Amber SRT: | Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists | The low oil pressure (LOP) shutdown lamp will not turn on.
QSK38 CM2150 Marine Auxiliary with C Command Elite™ Panel System - Low Oil Pressure (LOP) Shutdown Circuit
QSK38 CM2150 Power Generation - Low Oil Pressure (LOP) Shutdown Circuit
QSK38 CM2150 Marine Auxiliary with C Command™ Panel System - Low Oil Pressure (LOP) Shutdown Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Low Oil Pressure (LOP) Shutdown Circuit
QSK60 CM2150 Power Generation - Low Oil Pressure (LOP) Shutdown Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command™ Panel System - Low Oil Pressure (LOP) Shutdown Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command Elite™ Panel System/QSK60 CM2150 Drill Rig - Low Oil Pressure (LOP) Shutdown Circuit

Circuit Description

The low oil pressure (LOP) shutdown lamp will indicate when the engine has reached a low oil pressure most severe condition. Fault Code 415 will trigger the low oil pressure (LOP) shutdown lamp.

Component Location

The low oil pressure (LOP) shutdown lamp is located on the generator control panel. Refer to the OEM service manual for lamp location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If the ECM detects an open lamp circuit, Fault Code 1428 will go active, even in the absence of Fault Code 415. The ECM does not have to be trying to turn the lamp on to detect Fault Code 1428.

Possible causes of this fault code include:

  • Open signal circuit or shorted to voltage source
  • Signal circuit shorted to ground in the harness
  • Open return circuit in the OEM harness, connectors, or low oil pressure (LOP) shutdown lamp.
Refer to Troubleshooting Fault Code 1428.

Last Modified: 27-Sep-2010


High Engine Temperature (HET) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

FAULT CODE 1429

High Engine Temperature (HET) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1429 PID: SPN: 4187 FMI: 31 LAMP: Amber SRT: | High Engine Temperature (HET) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists | The HET shutdown lamp will not turn on.
QSK38 CM2150 Marine Auxiliary with C Command™ Panel System - High Engine Temperature (HET) Shutdown Circuit
QSK38 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - High Engine Temperature (HET) Shutdown Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - High Engine Temperature (HET) Shutdown Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command™ Panel System - High Engine Temperature (HET) Shutdown Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command Elite™, C Command Elite Plus™ Panel System/QSK60 CM2150 Drill Rig - High Engine Temperature (HET) Shutdown Circuit

Circuit Description

The high engine temperature (HET) shutdown lamp will indicate when the engine has reached a most severe level high coolant or intake manifold temperature. Fault Code 151 or 155 will trigger the HET shutdown lamp.

Component Location

The HET shutdown lamp is located on the generator control panel. Refer to the OEM service manual for lamp location.

Shop Talk

There are multiple electronic control module (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If Fault Code 151 or 155 becomes active and the HET shutdown lamp does not, or if the ECM detects an open lamp circuit, Fault Code 1429 will become active even in the absence of Fault Code 151 or Fault Code 152. The ECM does not have to be trying to turn the lamp on to detect Fault Code 1429.

Possible causes of this fault code include:

  • Open SIGNAL circuit or shorted to voltage source
  • A SIGNAL circuit shorted to ground in the harness
  • Open RETURN circuit in the OEM harness, connectors, or HET shutdown lamp.
Refer to Troubleshooting Fault Code 1429.

Last Modified: 17-Sep-2010


Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Calibration dependent, progressive power derate and engine shutdown with increasing time after alert.
QSK38 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK38 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK38 CM2150 Power Generation (Military Application) - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK38 CM2150 Marine Auxiliary - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK50 CM2150 Marine Auxiliary - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK60 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK60 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK60 CM2150 Marine Auxiliary/QSK60 CM2150 Drill Rig - Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value.

Component Location

The QSK50 engine oil rifle pressure 1 sensor is located on the oil filter head, which can be mounted on either side of the engine block, depending on the filter head option. The QSK60 engine oil rifle pressure 1 sensor is located on the rear right of the engine block, behind the flywheel housing. The QSK38 marine engine oil rifle pressure 1 sensor is located in the lubricating oil filter head, which is mounted on the left bank of the engine. On the QSK38 industrial engines, the lubricating oil rifle pressure 1 sensor is located in the lubricating oil filter head, which can be mounted on the left or right bank of the engine.

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine oil rifle pressure 1 sensor shares supply and return wires in the engine harness with other sensors. A partial fault with one of the other sensors in the circuit can cause false fault codes for other sensors in the circuit. If the oil rifle pressure 1 sensor is confirmed to be functioning correctly, and oil pressure is confirmed to be adequate using a mechanical gauge, inspect the other sensors in the shared circuit for correct function.

Refer to Troubleshooting Fault Code 143.

Last Modified: 10-Dec-2010


Pre-Low Oil Pressure Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists

FAULT CODE 1431

Pre-Low Oil Pressure Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1431 PID: SPN: 4188 FMI: 31 LAMP: Amber SRT: | Pre-Low Oil Pressure Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists | The pre-low oil pressure warning lamp will not turn on.
QSK38 CM2150 Marine Auxiliary with C Command™ Panel System - Pre-Low Oil Pressure Warning Circuit
QSK38 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Pre-Low Oil Pressure Warning Circuit
QSK38 CM2150 Power Generation - Pre-Low Oil Pressure Warning Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring and QSK60 CM2150 Power Generation - Pre-Low Oil Pressure Warning Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command™ Panel System - Pre-Low Oil Pressure Warning Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command Elite™ , C Command Elite Plus™ Panel System/QSK60 CM2150 Drill Rig - Pre-Low Oil Pressure Warning Circuit

Circuit Description

The pre-low oil pressure warning lamp will indicate when the engine has reached a moderately severe low oil pressure condition. Fault Code 143 will trigger the pre-low oil pressure warning lamp.

Component Location

The pre-low oil pressure warning lamp is located on the generator control panel. Refer to the OEM service manual for lamp location.

Shop Talk

There are multiple electronic control modules (ECMs) for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If Fault Code 143 goes active and the pre-low oil pressure warning lamp does not go on if the ECM detects an open lamp circuit, Fault Code 1431 will go active even in the absence of Fault Code 143. The ECM does not have to be trying to turn the lamp on to detect Fault Code 1431.

Possible causes of this fault code include:

  • Open SIGNAL circuit or shorted to voltage source
  • A SIGNAL circuit shorted to ground in the harness
  • Open RETURN circuit in the OEM harness, connectors, or pre-low oil pressure warning lamp.
Refer to Troubleshooting Fault Code 1431.

Last Modified: 17-Sep-2010


Pre-High Engine Temperature Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists

FAULT CODE 1432

Pre-High Engine Temperature Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1432 PID: SPN: 4223 FMI: 31 LAMP: Amber SRT: | Pre-High Engine Temperature Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists | The pre-high engine temperature warning lamp will not turn on.
QSK38 CM2150 Marine Auxiliary with C Command™ Panel System - Pre-High Engine Temperature Warning Circuit
QSK38 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Pre-High Engine Temperature Warning Circuit
QSK38 CM2150 Power Generation - Pre-High Engine Temperature Warning Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Pre-High Engine Temperature Warning Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command™ Panel System - Pre-High Engine Temperature Warning Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command Elite™, C Command Elite Plus™ Panel System/QSK60 CM2150 Drill Rig - Pre-High Engine Temperature Warning Circuit

Circuit Description

The pre-high engine temperature warning lamp will indicate when the engine has reached a moderately severe level high coolant or intake manifold temperature. Fault Code 146 or 488 will trigger the pre-high engine temperature warning lamp.

Component Location

The pre-high engine temperature warning lamp is located on the generator control panel. Refer to the OEM service manual for lamp location.

Shop Talk

There are multiple electronic control modules (ECMs) for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If Fault Code 146 or 488 goes active and the pre-high engine temperature warning lamp does not go on if the ECM detects an open lamp circuit, Fault Code 1432 will go active even in the absence of Fault Code 146 or Fault Code 488. The ECM does not have to be trying to turn the lamp on to detect Fault Code 1432.

Possible causes of this fault code include:

  • Open SIGNAL circuit or shorted to voltage source
  • SIGNAL circuit shorted to ground in the harness
  • Open RETURN circuit in the OEM harness, connectors, or pre-high engine temperature warning lamp.
Refer to Troubleshooting Fault Code 1432.

Last Modified: 17-Sep-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for engine coolant temperature.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Engine Coolant Temperature 1 Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Coolant Temperature 1 Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Engine Coolant Temperature 1 Sensor Circuit
QSK50 CM2150 Power Generation - Engine Coolant Temperature 1 Sensor Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Coolant Temperature 1 Sensor Circuit
QSK60 CM2150 Power Generation - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system, and for engine emissions control.

Component Location

The QSK50 and QSK60 engine coolant temperature 1 sensor is located in the thermostat housing. The QSK38 engine coolant temperature 1 sensor is located in the thermostat housing on Industrial and Power Generation applications, and in coolant sensor housings on Marine applicatiosn. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Before troubleshooting Fault Code 144, check for multiple faults.

The engine coolant temperature 1 sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code 144.

Last Modified: 16-Sep-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for engine coolant temperature.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Engine Coolant Temperature 1 Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Coolant Temperature 1 Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Engine Coolant Temperature 1 Sensor Circuit
QSK50 CM2150 Power Generation - Engine Coolant Temperature 1 Sensor Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Coolant Temperature 1 Sensor Circuit
QSK60 CM2150 Power Generation - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system, and for engine emissions control.

Component Location

The QSK50 and QSK60 engine coolant temperature 1 sensor is located in the thermostat housing. The QSK38 engine coolant temperature 1 sensor is located in the thermostat housing on Industrial and Power Generation applications, and in coolant housings on Marine applicatiosn. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine coolant temperature 1 sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code 145.

Last Modified: 10-Mar-2015


Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level. Engine coolant temperature 1 signal indicates engine coolant temperature is above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Engine Coolant Temperature 1 Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Coolant Temperature 1 Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Engine Coolant Temperature 1 Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Coolant Temperature 1 Sensor Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Coolant Temperature 1 Sensor Circuit
QSK60 CM2150 Power Generation - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system, and for engine emissions control.

Component Location

The QSK50 and QSK60 engine coolant temperature 1 sensor is located in the thermostat housing. The QSK38 engine coolant temperature 1 sensor is located in the thermostat housing on Industrial and Power Generation applications and in coolant sensor housings on Marine applications. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

See the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. See the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Service Manual, QSK45 and QSK60 Series Engines, Bulletin Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528.

Refer to Troubleshooting Fault Code 146.

Last Modified: 10-Dec-2010


Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Most Severe Level. Engine coolant temperature 1 signal indicates engine coolant temperature above engine protection critical limit. | Calibration dependent progressive power derate and engine shutdown with increasing time after alert.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Engine Coolant Temperature 1 Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Coolant Temperature 1 Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Engine Coolant Temperature 1 Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Coolant Temperature 1 Sensor Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Coolant Temperature 1 Sensor Circuit
QSK60 CM2150 Power Generation - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and for engine emissions control.

Component Location

The QSK50 and QSK60 engine coolant temperature 1 sensor is located on the thermostat housing. The QSK38 engine coolant temperature 1 sensor is located in the thermostat housing on Industrial, and Power Generation applications and in coolant sensor housings on Marine applications. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Service Manual, QSK45 and QSK60 Service Manual, Bulletin 4021530. Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Service Manual, QSK45 and QSK60 Service Manual,Bulletin 4021530 and K38, K50, and QSK50 Service Manual, Bulletin 4021528.

Refer to Troubleshooting Fault Code 151.

Last Modified: 10-Dec-2010


Accelerator Pedal or Lever Position Sensor 1 Circuit Frequency - Abnormal Frequency, Pulse Width, or Period

FAULT CODE 1514

Accelerator Pedal or Lever Position Sensor 1 Circuit Frequency - Abnormal Frequency, Pulse Width, or Period

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1514 PID: SPN: 091 FMI: 8 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit Frequency - Abnormal Frequency, Pulse Width, or Period. A frequency of more than 314 Hz or less than 109 Hz has been detected at the frequency accelerator signal pin of the engine harness. | Engine operates at idle.
QSK38 CM2150 Industrial - Accelerator Pedal or Lever Sensor Circuit
QSK50 and QSK60 CM2150 Industrial - Accelerator Pedal or Lever Sensor Circuit
QSK38 CM2150 Marine Propulsion - Accelerator Pedal or Lever Position Sensor Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator pedal or lever position sensor provides the driver's accelerator command to the electronic control module (ECM) through the OEM harness and the engine harness. The ECM uses this signal to determine the fueling command.

Component Location

Accelerator location varies with each OEM. Refer to the OEM service manual for component location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is usually caused when the ECM is receiving a frequency signal that is out of range. If the frequency is not between 109 to 314 Hz or 5 to 95 percent of the frequency throttle, the fault code will be logged.

The accelerator pedal or lever can be used either in conjunction with a voltage accelerator or by itself.

Refer to Troubleshooting Fault Code 1514.

Last Modified: 08-Jul-2010


At Least One Module Has A Most Severe Fault - Condition Exists

FAULT CODE 1517

At Least One Module Has A Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1517 PID: SPN: 1484 FMI: 11/31 LAMP: Red SRT: | At Least One Module Has A Most Severe Fault - Condition Exists | Dependent on particular faults from ECM 1 and/or ECM 2 that triggered Fault Code 1517.
Electronic Control Module (ECM)

Circuit Description

ECM 3 lights a red lamp when ECM 1 and/or ECM 2 have a Most Severe Fault on the QSK50 and QSK60 engines. ECM 2 lights a red lamp when ECM 1 has a Most Severe Fault on QSK38 engines.

Component Location

The ECMs are located on the left (fuel pump) side of the engine. ECM 1 is the front-mounted ECM, ECM 2 is in the middle, and ECM 3 is the rear-mounted ECM on the QSK50 and QSK60 engines. ECM 1 is the front-mounted ECM and ECM 2 is the rear-mounted ECM on the QSK38 engine. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

ECM 3 contains status information about ECM 1 and ECM 2 on QSK50 and QSK60 engines. When ECM 1 and/or ECM 2 have a Most Severe Fault Code, ECM 3 will recognize this and light a red lamp. When Fault Code 1517 is flashed out it means that ECM 1 and/or ECM 2 have at least one Most Severe Fault Code. If ECM 1 and/or ECM 2 have at least one Most Severe Fault Code, Fault Code 1517 will be flashed out, not the individual fault codes that are causing Fault Code 1517. Since Fault Code 1517 can represent more than one Most Severe Fault Code, INSITE™ electronic service tool can be connected in order to read the fault code(s) causing Fault Code 1517 and to troubleshoot accordingly.

ECM 2 contains status information about ECM 1 on the QSK38 engine . When ECM 1 has a Most Severe Fault Code, ECM 2 will recognize this and light a red lamp. When Fault Code 1517 is flashed, out it means that ECM 2 has at least one Most Servere Fault Code. If ECM 2 has at least one Most Severe Fault Code, Fault Code 1517 will be flashed out, not the individual fault codes that are causing Fault Code 1517. Since Fault Code 1517 can represent more than one Most Severe Fault Code, INSITE™ electronic service tool can be connected in order to read the fault code(s) causing Fault Code 1517 and to troubleshoot accordingly.

Possible causes of this fault code include:

  • ECM 1 and/or ECM 2 have at least one Most Severe Fault Code (Red).
Refer to Troubleshooting Fault Code 1517.

Last Modified: 08-Jul-2010


At Least One Module Has A Moderately Severe Fault - Condition Exists

FAULT CODE 1518

At Least One Module Has A Moderately Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1518 PID: SPN: 1484 FMI: 11/31 LAMP: Amber SRT: | At Least One Module Has A Moderately Severe Fault - Condition Exists | Dependent on particular faults from ECM 1 and/or ECM 2 that triggered Fault Code 1518.
Electronic Control Module (ECM)

Circuit Description

ECM 3 lights an amber lamp when ECM 1 and/or ECM 2 have a Moderately Severe Fault on QSK50 and QSK60 engines. ECM 2 lights an amber lamp when ECM 1 has a Moderately Severe Fault on QSK38 engines.

Component Location

The ECMs are located on the left (fuel pump) side of the engine. ECM 1 is the front-mounted ECM, ECM 2 is in the middle, and ECM 3 is the rear-mounted ECM on QSK50 and QSK60 engines. There are only two ECMs on QSK38 engines. ECM 1 is the front-mounted ECM and ECM 2 is the rear-mounted ECM. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

ECM 3 contains status information about ECM 1 and ECM 2 on QSK50 and QSK60 engines. When ECM 1 and ECM 2 have a Moderately Severe Fault Code, ECM 3 will recognize this and light an amber lamp. When Fault Code 1518 is flashed out, it means that ECM 1 and/or ECM 2 have at least one Moderately Severe Fault Code. Fault Code 1518 will be flashed out, not the individual fault codes that are causing Fault Code 1518. Since Fault Code 1518 can represent more than one Moderately Severe Fault Code, INSITE™ electronic service tool can be connected in order to read the fault code(s) causing Fault Code 1518 and to troubleshoot accordingly.

ECM 2 contains status information about ECM 1 on QSK38 engines. When ECM 1 has a Moderately Severe Fault Code, ECM 2 will recognize this and light an amber lamp. When t Fault Code 1518 is flashed out, it means that ECM 1 has at least one Moderately Severe Fault Code. Fault Code 1518 will be flashed out, not the individual fault codes that are causing Fault Code 1518. Since Fault Code 1518 can represent more than one Moderately Severe Fault Code, INSITE™ electronic service tool can be connected in order to read the fault code(s) causing Fault Code 1518 and to troubleshoot accordingly.

Possible causes of this fault code include:

  • ECM 1 and/or ECM 2 have at least one Moderately Severe Fault Code (Amber).
Refer to Troubleshooting Fault Code 1518.

Last Modified: 08-Jul-2010


At Least One Module Has a Least Severe Fault - Condition Exists

FAULT CODE 1519

At Least One Module Has a Least Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1519 PID: SPN: 1484 FMI: 11/31 LAMP: Maintenance SRT: | At Least One Module Has a Least Severe Fault - Condition Exists | Dependent on particular faults from ECM 1 and/or ECM 2 that triggered 1519.
Electronic Control Module (ECM)

Circuit Description

ECM 3 lights a maintenance lamp when ECM 1 and/or ECM 2 have a Least Severe Fault on QSK50 and QSK60 engines. ECM 2 lights a maintenance lamp when ECM 1 has a Least Severe Fault on QSK38 engines.

Component Location

The ECMs are located on the left (fuel pump) side of the engine. ECM 1 is the front most mounted ECM, ECM 2 source address 01 is in the middle, and ECM 3 source address 144 is the rear-mounted ECM on QSK50 and QSK60 engines. ECM 1 is the front-mounted ECM and ECM 2 is the rear-mounted ECM on QSK38 engines. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

ECM 3 contains status information about ECM 1 and ECM 2 on QSK50 and QSK60 engines. When ECM 1 and/or ECM 2 have a Least Severe Fault Code, ECM 3 will recognize this and light a maintenance lamp. When the Fault Code 1519 is flashed out, it means that ECM 1 and/or ECM 2 have at least one Least Severe Fault Code. If ECM 1 and/or ECM 2 have at least one Least Severe Fault Code, Fault Code 1519 will be flashed out, not the individual fault codes that are causing Fault Code 1519. Since Fault Code 1519 can represent more than one Least Severe Fault Code, INSITE™ electronic service tool can be connected in order to read the fault code(s) causing Fault Code 1519 and to troubleshoot accordingly.

On QSK38 engines, ECM 2 contains status information about ECM 1. When ECM 1 has a Least Severe Fault Code, ECM 2 will recognize this and light a maintenance lamp. When Fault Code 1519 is flashed out, it means that ECM 1 has an least one Least Severe Fault Code. If ECM 1 has at least one Least Severe Fault Code, 1519 will be flashed out, not the individual fault codes that are causing Fault Code 1519. Since Fault Code 1519 can represent more than one Least Severe Fault Code, INSITE™ electronic service tool can be connected in order to read the fault code(s) causing Fault Code 1519 and to troubleshoot accordingly.

Possible causes of the fault code include:

  • ECM 1 and/or ECM 2 have at least one Least Severe Fault Code (Maintenance).
Refer to Troubleshooting Fault Code 1519.

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 1521
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1521qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1521thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1521 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1521 PID: SPN: 1139 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 3. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 3
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor circuit Cylinder 3

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 3. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 3 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 3 signal circuit. The exhaust gas temperature sensor circuit cylinder 3 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 3 is located in the exhaust manifold at the cylinder head 3 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 3 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1521 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1521 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1521 PID: SPN: 1139 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 3. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2)
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2)
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 3 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 3 is located in the engine harness and extends between the cylinder 3 head and the ECM. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 3 measures the exhaust temperature ofcylinder 3. The ECM monitors the temperature and compares it to the threshold limit in thecalibration.

On QSK38 engines, ECM 2 contains status information about ECM 1. When ECM 1 has a Least Severe Fault Code, ECM 2 will recognize this and light a maintenance lamp. When the Fault Code 1519 is An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gastemperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gastemperature sensor return (sensor return 3 ) of the engine harness can generate multiple faultcodes for all of the sensors on the shared sensor return for that group of sensors. This will alsocause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to voltage source in the sensor
  • Damaged sensor
  • Damaged ECM.

The resistance of the engine exhaust gas temperature sensor circuit cylinder 3 varies with the temperature. If the engine exhaust gas temperature sensor circuit cylinder 3 is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1521 (Thermistor).

Last Modified: 10-Mar-2015


Fault Code Path Selection

FAULT CODE 1522
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1522qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1522thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1522 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1522 PID: SPN: 1141 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 5. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 5
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 5

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 5. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 5 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 5 signal circuit. The exhaust gas temperature sensor circuit cylinder 5 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 5 is located in the exhaust manifold at the cylinder head 5 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 5 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1522 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1522 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1522 PID: SPN: 1141 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 5. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3)
QSK50 and QSK60 CM2150 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3)
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 5 (A3) monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 5 (A3) is located in the engine harness and extends between the cylinder 5 (A3) head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 5 (A3) measures the exhaust gas temperature of cylinder 5 (A3). The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3 ) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A SIGNAL circuit shorted to battery voltage in the harness
  • A SIGNAL circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The resistance of the engine exhaust gas temperature circuit cylinder 5 (A3) varies with the temperature. If the engine exhaust gas temperature circuit cylinder 5 (A3) sensor is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1522 (Thermistor).

Last Modified: 10-Dec-2010


Fault Code Path Selection

FAULT CODE 1523
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1523qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1523thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1523 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1523 PID: SPN: 1143 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 7. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 7
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 7

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 7. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 7 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 7 signal circuit. The exhaust gas temperature sensor circuit cylinder 7 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 7 is located in the exhaust manifold at the cylinder head 7 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 7 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1523 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1523 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1523 (A4) PID: SPN: 1143 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 7. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4)
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4)
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 7 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 7 is located in the engine harness and extends between the cylinder 7 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 7 measures the exhaust gas temperature of cylinder 7. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit SIGNAL wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3 ) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A SIGNAL circuit shorted to battery voltage in the harness
  • A SIGNAL circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The resistance of the engine exhaust gas temperature sensor circuit cylinder 7 varies with the temperature. If the engine exhaust gas temperature sensor circuit cylinder 7 is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1523 (Thermistor).

Last Modified: 10-Dec-2010


Fault Code Path Selection

FAULT CODE 1524
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1524qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1524thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1524 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1524 PID: SPN: 1145 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 9. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 9
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 9

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 9. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 9 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 9 signal circuit. The exhaust gas temperature sensor circuit cylinder 9 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 9 is located in the exhaust manifold at the cylinder head 9 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 9 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1524 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1524 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1524 PID: SPN: 1145 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 9. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5)
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5)
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 9 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 9 is located in the engine harness and extends between the cylinder 9 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 9 measures the exhaust gas temperature of cylinder 9. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit SIGNAL wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A SIGNAL circuit shorted to battery voltage in the harness
  • A SIGNAL circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The resistance of the engine exhaust gas temperature sensor circuit cylinder 9 varies with the temperature. If the engine exhaust gas temperature sensor circuit cylinder 9 is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1524 (Thermistor).

Last Modified: 10-Dec-2010


Fault Code Path Selection

FAULT CODE 1525
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1525qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1525thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1525 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1525 PID: SPN: 1147 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 11. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 11
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 11

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 11. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 11 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 11 signal circuit. The exhaust gas temperature sensor circuit cylinder 11 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 11 is located in the exhaust manifold at the cylinder head 11 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 11 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1525 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1525 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1525 PID: SPN: 1147 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 11. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6)
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6)
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 11 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 11 is located in the engine harness and extends between the cylinder 11 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 11 measures the exhaust gas temperature of cylinder 11. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit SIGNAL wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A SIGNAL circuit shorted to battery voltage in the harness
  • A SIGNAL circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The resistance of the engine exhaust gas temperature sensor circuit cylinder 11 varies with the temperature. If the engine exhaust gas temperature sensor circuit cylinder 11 is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1525 (Thermistor).

Last Modified: 10-Dec-2010


Fault Code Path Selection

FAULT CODE 1526
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1526qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1526thermistor

Last Modified: 16-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1526 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1526 PID: SPN: 1147 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Above Normal or Shorted to High Source. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 13

Circuit Description

The exhaust gas temperature sensor circuit cylinder 13 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 13 located in the exhaust manifold at the cylinder head 13 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM as an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 11 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration. Possible causes of this fault include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted aftercooler
  • Boost air leaks
  • Overfueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 1526 (QSK38 and QSK50 Marine).

Last Modified: 10-Dec-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1526 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1526 PID: SPN: 1149 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 13. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7)
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7)
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 13 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 13 is located in the engine harness and extends between the cylinder 13 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 13 measures the exhaust gas temperature of cylinder 13. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit SIGNAL wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A SIGNAL circuit shorted to battery voltage in the harness
  • A SIGNAL circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The resistance of the engine exhaust gas temperature sensor circuit cylinder 13 varies with the temperature. If the engine exhaust gas temperature sensor circuit cylinder 13 is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1526 (Thermistor).

Last Modified: 10-Dec-2010


Fault Code Path Selection

FAULT CODE 1527
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc1527qsk50mar
Does the engine have thermistors? | Go to 122-fc1527thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1527 (QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1527 PID: SPN: 1151 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 15. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 15

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 15. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 15 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 15 signal circuit. The exhaust gas temperature sensor circuit cylinder 15 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 15 is located in the exhaust manifold at the cylinder head 15 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 15 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1527 (QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1527 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1527 PID: SPN: 1151 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 15. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8)
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8)
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 15 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 15 is located in the engine harness and extends between the cylinder 15 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 15 measures the exhaust gas temperature of cylinder 15. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit SIGNAL wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3 ) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A SIGNAL circuit shorted to battery voltage in the harness
  • A SIGNAL circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The resistance of the engineexhaust gas temperature sensor circuit cylinder 15 varies with the temperature. If the engine exhaust gas temperature sensor circuit cylinder 15 is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1527 (Thermistor).

Last Modified: 10-Dec-2010


Fault Code Path Selection

FAULT CODE 1529
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1529qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1529thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1529 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1529 PID: SPN: 1138 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 2. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 2

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 2. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 2 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 2 signal circuit. The exhaust gas temperature sensor circuit cylinder 2 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 2 is located in the exhaust manifold at the cylinder head 2 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 2 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1529 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1529 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1529 PID: SPN: 1138 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 2. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1)
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1)
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1)
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 2 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 2 is located in the engine harness and extends between the cylinder 2 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 2 measures the exhaust gas temperature of cylinder 2. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit SIGNAL wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3 ) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A SIGNAL circuit shorted to battery voltage in the harness
  • A SIGNAL circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The resistance of the engine exhaust gas temperature sensor circuit cylinder 2 varies with the temperature. If the engine exhaust gas temperature sensor circuit cylinder 2 is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1529 (Thermistor).

Last Modified: 10-Dec-2010


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold 1 temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold air temperature.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Intake Manifold 1 Temperature Sensor
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Intake Manifold 1 Temperature Sensor
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Intake Manifold 1 Temperature Sensor
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 1 Temperature Sensor
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 1 Temperature Sensor
QSK60 CM2150 Power Generation - Intake Manifold 1 Temperature Sensor

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the engine control module (ECM)s through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold 1 temperature sensor is located in the left bank front air intake manifold. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 1 temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
40 | 104 | 4.9k to 5.8k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code 153.

Last Modified: 21-Sep-2010


Fault Code Path Selection

FAULT CODE 1531
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1531qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1531thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1531 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1531 PID: SPN: 1142 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 6. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 6

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 6. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 6 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 6 signal circuit. The exhaust gas temperature sensor circuit cylinder 6 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 6 is located in the exhaust manifold at the cylinder head 6 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 6 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1531 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1531 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1531 PID: SPN: 1142 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 6. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 6

Circuit Description

The exhaust gas temperature sensor circuit cylinder 6 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 6 is located in the engine harness and extends between the cylinder 6 head and the ECM.

Shop Talk

There are multiple electronic control modules (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 6 measures the exhaust gas temperature of cylinder 6. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3 ) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to battery voltage in the harness
  • A signal circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1531 (Thermistor).

Last Modified: 15-Sep-2010


Fault Code Path Selection

FAULT CODE 1532
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1532qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1532thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1532 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1532 PID: SPN: 1144 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 8. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 8

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 8. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 8 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 8 signal circuit. The exhaust gas temperature sensor circuit cylinder 8 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 8 is located in the exhaust manifold at the cylinder head 8 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 8 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1532 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1532 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1532 PID: SPN: 1144 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 8. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 8

Circuit Description

The exhaust gas temperature sensor circuit cylinder 8 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 8 is located in the engine harness and extends between the cylinder 8 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 8 measures the exhaust gas temperature of cylinder 8. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3 ) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to battery voltage in the harness
  • A signal circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1532 (Thermistor).

Last Modified: 15-Sep-2010


Fault Code Path Selection

FAULT CODE 1533
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1533qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1533thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1533 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1533 PID: SPN: 1146 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 10. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 10

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 10. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 10 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 10 signal circuit. The exhaust gas temperature sensor circuit cylinder 10 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 10 is located in the exhaust manifold at the cylinder head 10 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 10 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1533 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1533 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1533 PID: SPN: 1146 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 10. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 10

Circuit Description

The exhaust gas temperature sensor circuit cylinder 10 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 10 is located in the engine harness and extends between the cylinder 10 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 10 measures the exhaust gas temperature of cylinder 10. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to battery voltage in the harness
  • A signal circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1533 (Thermistor).

Last Modified: 15-Sep-2010


Fault Code Path Selection

FAULT CODE 1534
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1534qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1534thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1534 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1534 PID: SPN: 1148 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 12. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 12

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 12. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 12 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 12 signal circuit. The exhaust gas temperature sensor circuit cylinder 12 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 12 is located in the exhaust manifold at the cylinder head 12 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 12 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1534 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1534 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1534 PID: SPN: 1146 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 12. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 12

Circuit Description

The exhaust gas temperature sensor circuit cylinder 12 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 12 is located in the engine harness and extends between the cylinder 12 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 12 measures the exhaust gas temperature of cylinder 12. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to battery voltage in the harness
  • A signal circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1534 (Thermistor).

Last Modified: 15-Sep-2010


Fault Code Path Selection

FAULT CODE 1535
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc1535qsk50mar
Does the engine have thermistors? | Go to 122-fc1535thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1535 (QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1535 PID: SPN: 1150 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 14. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 14

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 14. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 14 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 14 signal circuit. The exhaust gas temperature sensor circuit cylinder 14 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 14 is located in the exhaust manifold at the cylinder head 14 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 14 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1535 (QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1535 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1535 PID: SPN: 1150 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 14. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 14

Circuit Description

The exhaust gas temperature sensor circuit cylinder 14 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 14 is located in the engine harness and extends between the cylinder 14 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 14 measures the exhaust gas temperature of cylinder 14. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to battery voltage in the harness
  • A signal circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1535 (Thermistor).

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 1536
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc1536qsk50mar
Does the engine have thermistors? | Go to 122-fc1536thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1536 (QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1536 PID: SPN: 1152 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 16. | No engine protection for the exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 16

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 16. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 16 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 16 signal circuit. The exhaust gas temperature sensor circuit cylinder 16 monitors exhaust gas temperature and passes the information to the ECM through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 16 is located in the exhaust manifold at the cylinder head 16 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 16 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1536 (QSK50 Marine).

Last Modified: 16-Jul-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1536 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1536 PID: SPN: 1146 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 16. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 16

Circuit Description

The exhaust gas temperature sensor circuit cylinder 16 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 16 is located in the engine harness and extends between the cylinder 16 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 16 measures the exhaust gas temperature of cylinder 16. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to battery voltage in the harness
  • A signal circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1536 (Thermistor).

Last Modified: 16-Sep-2010


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold 1 temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold temperature.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Intake Manifold 1 Temperature Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Intake Manifold 1 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Intake Manifold 1 Temperature Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advance Engine Monitoring - Intake Manifold Temperature Sensor Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold Temperature Sensor Circuit
QSK60 CM2150 Power Generation - Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the electronic control modules (ECM)s through the engine harness.

Component Location

The intake manifold 1 temperature sensor is located in the left bank front air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 1 temperature sensor share return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
40 | 104 | 4.9k to 5.8k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code 154.

Last Modified: 16-Sep-2010


Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1542

Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1542 PID: P137 SPN: 1387 FMI: 3/3 LAMP: Amber SRT: | Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at theoriginal equipment manufacturer (OEM) pressure sensor circuit. | None on performance.
QSK60 CM2150 Industrial - Auxiliary Pressure Sensor Input 1 Circuit

Circuit Description

The OEM has the option of wiring an auxiliary pressure sensor input to the engine control module (ECM). Refer to the OEM service manual for information about the auxiliary pressure sensor.

Component Location

The OEM pressure sensor input will vary depending on application. Refer to the OEM service manual for sensor location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected the OEM pressure signal circuit was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1542.

Last Modified: 15-Nov-2017


Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1543

Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1543 PID: P443 SPN: 1388 FMI: 4 LAMP: Amber SRT: | Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the OEM pressure circuit. | None on performance.
QSK38 CM2150 Industrial - Auxiliary Pressure Sensor Input 1 Circuit
QSK38 CM2150 Marine - Auxiliary Pressure Sensor Input 1 Circuit
QSK50 and QSK60 CM2150 Industrial - Auxiliary Pressure Sensor Input 1 Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Auxiliary Pressure Sensor Input 1 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure sensor input to the Cummins® electronic control module (ECM). A specific calibration is then created to recognize this pressure sensor input.

For marine applications, when a pressure sensor is not being used, a resistive jumper is installed in the wiring harness extension to simulate the sensor.

Component Location

The OEM pressure sensor input will vary depending on application. Refer to the OEM service manual for sensor location.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the OEM harness or sensor
  • Supply line open or shorted to ground.

Possible causes of this fault code for marine applications without pressure sensor:

  • Resistive jumper is not installed in the wiring harness extension
  • Resistor malfunction.
Refer to Troubleshooting Fault Code 1543.

Last Modified: 21-Sep-2010


Auxiliary Pressure Sensor Input 1 - Special Instructions

FAULT CODE 1544

Auxiliary Pressure Sensor Input 1 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1544 PID: SPN: 1387 FMI: 14 LAMP: Maintenance SRT: | Auxiliary Pressure Sensor Input 1 - Special Instructions | Possible engine power derate or engine shutdown, depending on the OEM calibration.
QSK38 CM2150 Industrial - Auxiliary Pressure Sensor Input 1 Circuit
QSK38 CM2150 Marine - Auxiliary Pressure Sensor Input 1 Circuit
QSK50 and QSK60 CM2150 Industrial - Auxiliary Pressure Sensor Input 1 Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Auxiliary Pressure Sensor Input 1 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure sensor input to the electronic control module (ECM). A specific calibration is then created to recognize the auxiliary pressure sensor input 1. This fault code is activated when the pressure input from the OEM sensor exceeds the engine protection limit defined by the OEM. In marine applications, this sensor monitors gear oil pressure and the fault code is activated when the pressure falls below a threshold which is an INSITE™ electronic service tool adjustable parameter. Depending on the OEM requirements, an engine protection derate or even engine shutdown can be associated with the fault code.

Component Location

The OEM pressure sensor input will vary depending on application. Refer to the OEM troubleshooting and repair manual for sensor location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is activated when the pressure input from the OEM sensor exceeds the engine protection limit defined by the OEM. An engine power derate is possible depending on the OEM application.

In marine applications, the default setting is intentionally set higher than any possible gear oil pressure. This is so the fault code will become active immediately after recalibration where the adjustable parameters were not overlaid on the new calibration. This prevents the customer from the assumption that he is protected by this lamp when the parameters were not adjusted properly. When the gear oil pressure sensor is not installed, the factory installed resistor is designed to signal to the ECM that gear oil pressure conditions are satisfactory at all times.

Note: The fault code will only go inactive if the ECM sees a known condition for a period (about five seconds) and with the engine running above 1000 RPM.

Refer to Troubleshooting Fault Code 1544.

Last Modified: 17-Jan-2012


Fault Code Path Selection

FAULT CODE 1548
Fault Code Path Selection

Is the engine QSK38? | Go to 122-fc1548qsk38
Is the engine QSK50 or QSK60? | Go to 122-fc1548qsk50-60

Last Modified: 26-Feb-2010


Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1548 (QSK38)

Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1548 PID: SPN: 657 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 7 circuit, or no current detected at injector solenoid driver cylinder 7 or RETURN pin when the voltage supply at the harness is ON. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 7 Circuit
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 7 Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 7 Circuit
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 7 Circuit

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low side switches. The injectors for cylinders 7, 9, and 11 share a single high-side switch that connects the injector circuit to the source of high voltage in ECM 2. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector solenoid driver circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive when the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector solenoid driver circuits in the same bank, a short circuit exists.

Possible causes of a single injector solenoid driver fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector solenoid driver fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank, shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1548 (QSK38).

Last Modified: 23-Sep-2010


Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1548 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1548 PID: SPN: 657 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 7 circuit, or no current detected at injector solenoid driver cylinder 7 or RETURN pin when the voltage supply at the harness is ON. | Engine can misfire or possibly run rough.
QSK50 and QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 7 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 7 Circuit
QSK50 CM2150 Marine - Injector Solenoid Driver Cylinder 7 Circuit

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. ECM 1 has two high-side switches and four low-side switches. ECM 2 and ECM 3 have two high-side switches and six low side switches. The injectors for cylinders 6, 7, and 14 share a single high-side switch that connects the injector circuit to the source of high voltage in ECM 2. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector solenoid driver circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector solenoid driver circuits in the same bank, a short circuit exists.

Possible causes of a single injector solenoid driver fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally, but not to ground)
  • Malfunctiong ECM.

Possible causes of multiple injector solenoid driver fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es), either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank, shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1548 (QSK50 and QSK60).

Last Modified: 23-Sep-2010


Fault Code Path Selection

FAULT CODE 1549
Fault Code Path Selection

Is the engine QSK38? | Go to 122-fc1549qsk38
Is the engine QSK50 or QSK60? | Go to 122-fc1549qsk50-60

Last Modified: 26-Feb-2010


Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1549 (QSK38)

Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1549 PID: SPN: 658 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 8, or no current detected at injector solenoid driver cylinder 8 signal or injector solenoid driver cylinder 8 RETURN pins when the voltage supply at the harness is ON. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 8 Circuit
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 8 Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 8 Circuit
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 8 Circuit

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low side switches. The injectors for cylinders 8, 10, and 12 share a single high-side switch inside ECM 1. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker lever.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector solenoid driver fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single solenoid driver injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es), either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank, shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1549 (QSK38).

Last Modified: 23-Sep-2010


Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1549 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1549 PID: SPN: 658 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 8, or no current detected at injector solenoid driver cylinder 8 signal or injector solenoid driver cylinder 8 RETURN pins when the voltage supply at the harness is ON. | Engine can misfire or possibly run rough.
QSK50 CM2150 Industrial - Injector Solenoid Driver Cylinder 8 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Injector Solenoid Driver Cylinder 8 Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 8 Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 8 Circuit
QSK60 CM2150 Industrial - Injector Solenoid Driver Cylinder 8 Circuit

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside ECM 1. ECM 2 and ECM 3 have two high-side switches and six low side switches. The injectors for cylinders 8, 16, and 5 share a single high-side switch inside ECM 3. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine wiring harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector solenoid driver fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single solenoid driver injector fault:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector fault codes in the same bank of injectors:

  • Short circuit in the engine harness(es), either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank, shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1549 (QSK50 and QSK60).

Last Modified: 23-Sep-2010


Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level. Intake manifold 1 air temperature above engine protection critical limit. | Industrial: Calibration dependent progressive power derate and engine shutdown with increasing time after alert. Power Generation: Calibration dependent possible engine shutdown.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Intake Manifold 1 Temperature Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Intake Manifold 1 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Intake Manifold 1 Temperature Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 with Advanced Engine Monitoring - Intake Manifold 1 Temperature Sensor Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 1 Temperature Sensor Circuit
QSK60 CM2150 Power Generation - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensors monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The intake manifold 1 temperature sensor is located in the left bank front intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155.

Last Modified: 10-Dec-2010


Fault Code Path Selection

FAULT CODE 1551
Fault Code Path Selection

Is the engine QSK38? | Go to 122-fc1551qsk38
Is the engine QSK50 or QSK60? | Go to 122-fc1551qsk50-60

Last Modified: 26-Feb-2010


Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1551 (QSK38)

Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1551 PID: SPN: 660 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 10 circuit, or no current detected at injector solenoid driver cylinder 10 signal pin or injector solenoid driver cylinder 10 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 10
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 10
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 10
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 10

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low side switches. The injectors for cylinders 8, 10, and 12 share a single high-side switch inside the ECM. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM 1.

Component Location

The engine wiring harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector solenoid driver fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector solenoid driver fault:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector fault codes in the same bank of injectors:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1551 (QSK38).

Last Modified: 23-Sep-2010


Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1551 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1551 PID: SPN: 660 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 10 circuit, or no current detected at injector solenoid driver cylinder 10 SIGNAL pin or injector solenoid driver cylinder 10 RETURN pin when the voltage supply at the harness is ON. | Engine can misfire or possibly run rough.
QSK50 CM2150 Industrial - Injector Solenoid Driver Cylinder 10
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Injector Solenoid Driver Cylinder 10
QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 10
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 10
QSK60 CM2150 Industrial - Injector Solenoid Driver Cylinder 10

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside of ECM 1. ECM 2 and ECM 3 have two high-side switches and six low side switches. The injectors for cylinders 2, 10, and 11 share a single high-side switch inside ECM 3. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector solenoid driver fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector solenoid driver fault:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector fault codes in the same bank of injectors:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine wiring harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1551 (QSK50 and QSK60).

Last Modified: 23-Sep-2010


Fault Code Path Selection

FAULT CODE 1552
Fault Code Path Selection

Is the engine QSK38? | Go to 122-fc1552qsk38
Is the engine QSK50 or QSK60? | Go to 122-fc1552qsk50-60

Last Modified: 26-Feb-2010


Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1552 (QSK38)

Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1552 PID: SPN: 661 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 11 circuit, or no current detected at injector solenoid driver cylinder 11 signal pin or injector solenoid driver cylinder 11 return pin when the voltage supply at the harness is ON. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 11 Circuit
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 11 Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 11 Circuit
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 11 Circuit

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low side switches. The injectors for cylinders 7, 9, and 11 share a single high-side switch inside ECM 2. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector solenoid driver fault:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector fault codes in the same bank of injectors:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1552 (QSK38).

Last Modified: 23-Sep-2010


Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1552 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1552 PID: SPN: 661 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 11 circuit, or no current detected at injector solenoid driver cylinder 11 SIGNAL pin or injector solenoid driver cylinder 11 RETURN pin when the voltage supply at the harness is ON. | Engine can misfire or possibly run rough.
QSK50 CM2150 Industrial - Injector Solenoid Driver Cylinder 11 Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 11 Circuit
QSK50 CM2150 Marine - Injector Solenoid Driver Cylinder 11 Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 11 Circuit

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside ECM 1. ECM 2 and ECM 3 have two high-side switches and six low side switches. The injectors for cylinders 2, 10, and 11 share a single high-side switch inside ECM 3. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector solenoid driver fault:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector fault codes in the same bank of injectors:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1552 (QSK50 and QSK60).

Last Modified: 07-Oct-2010


Fault Code Path Selection

FAULT CODE 1553
Fault Code Path Selection

Is the engine QSK38? | Go to 122-fc1553qsk38
Is the engine QSK50 or QSK60? | Go to 122-fc1553qsk50-60

Last Modified: 26-Feb-2010


Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1553 (QSK38)

Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1553 PID: SPN: 662 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 12 circuit, or no current detected at injector solenoid driver cylinder 12 signal or injector solenoid driver return pin when the voltage supply at the harness is ON. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 12 Circuit
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 12 Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 12 Circuit
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 12 Circuit

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low side switches. The injectors for cylinders 8, 10, and 12 share a single high-side switch inside ECM 1. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector solenoid driver circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector solenoid driver fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector solenoid driver fault:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector solenoid driver fault codes in the same bank of injectors:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1553 (QSK38).

Last Modified: 23-Sep-2010


Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1553 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1553 PID: SPN: 662 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 12 circuit, or no current detected at injector solenoid driver cylinder 12 signal or injector solenoid driver return pin when the voltage supply at the harness is ON. | Engine can misfire or possibly run rough.
QSK50 CM2150 Industrial - Injector Solenoid Driver Cylinder 12 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 12 Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 12 Circuit
QSK60 CM2150 Industrial - Injector Solenoid Driver Cylinder 12 Circuit

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside ECM 1. ECM 2 and ECM 3 have two high-side switches and six low side switches. The injectors for cylinders 4, 9, and 12 share a single high-side switch inside ECM 2. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector solenoid driver circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector solenoid driver fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector solenoid driver fault:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector solenoid driver fault codes in the same bank of injectors:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1553 (QSK50 and QSK60).

Last Modified: 17-Sep-2010


Injector Solenoid Driver Cylinder 13 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1554

Injector Solenoid Driver Cylinder 13 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1554 PID: SPN: 663 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 13 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid cylinder 13 circuit, or no current detected at injector solenoid driver cylinder 13 signal or injector solenoid driver cylinder return pin when the voltage supply at the harness is ON. | Engine can misfire or possibly run rough.
QSK50 and QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 13 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 13 Circuit
QSK50 CM2150 Marine - Injector Solenoid Driver Cylinder 13 Circuit

Circuit Description

The injector solenoid driver controls fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside of ECM 1. ECM 2 and ECM 3 have tow high-side switches and six low-side switches. The injectors for cylinders 3 and 13 share a single high-side switch inside ECM 1. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector solenoid driver circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than one minute.
  • If a fault condition is intermittent, and especially if more than one injector solenoid driver fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector solenoid driver fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector solenoid driver fault:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector solenoid driver fault codes in the same bank of injectors:

  • Short circuit in the engine harness(es), either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank, shorts to ground
  • Damaged ECM.
Refer to Troubleshooting Fault Code 1554.

Last Modified: 17-Sep-2010


Injector Solenoid Driver Cylinder 14 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1555

Injector Solenoid Driver Cylinder 14 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1555 PID: SPN: 664 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 14 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 14 circuit, or no current detected at injector solenoid driver 14 signal or return pin when the voltage supply at the harness is ON. | Engine can misfire or possibly run rough.
QSK50 CM2150 Industrial - Injector Solenoid Driver Cylinder 14 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 12 Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 14 Circuit
QSK60 CM2150 Industrial - Injector Solenoid Driver Cylinder 14 Circuit

Circuit Description

The injector solenoid driver controls fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside of ECM 1. ECM 2 and ECM 3 have two high-side switches and six low side switches. The injectors for cylinders 6, 7, and 14 share a single high-side switch inside ECM 2. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than one minute.
  • If a fault condition is intermittent, and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector solenoid driver circuits in the same bank, a short circuit exists.

Possible causes of a single injector solenoid driver fault

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector solenoid driver fault codes in the same bank of injectors:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1555.

Last Modified: 17-Sep-2010


Injector Solenoid Driver Cylinder 15 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1556

Injector Solenoid Driver Cylinder 15 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1556 PID: SPN: 665 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 15 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 15 circuit or no current detected at injector solenoid driver cylinder 15 injector signal or return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK50 and QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 15 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 15 Circuit
QSK50 CM2150 Marine - Injector Solenoid Driver Cylinder 15 Circuit

Circuit Description

The injector solenoid driver controls fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside of ECM 1. ECM 2 and ECM 3 have two high-side switches and six low side switches. The injectors for cylinders 1 and 15 share a single high-side switch inside ECM 1. Each injector solenoid driver circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector solenoid driver circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than one minute.
  • If a fault condition is intermittent, and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector solenoid driver fault code is occurring and the faults occur for injector solenoid driver circuits in the same bank, a short circuit exists.

Causes of a single injector solenoid driver fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally, but not to ground)
  • Damaged ECM.

Causes of multiple injector solenoid driver fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfuctioning ECM.
Refer to Troubleshooting Fault Code 1556.

Last Modified: 10-Mar-2015


Injector Solenoid Driver Cylinder 16 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1557

Injector Solenoid Driver Cylinder 16 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1557 PID: SPN: 666 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 16 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 16 circuit or no current detected at the injector solenoid driver cylinder 16 signal or return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK50 CM2150 Industrial - Injector Solenoid Driver Cylinder 16 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Injector Solenoid Driver Cylinder 16
QSK50 CM2150 Power Generation with Advanced Engine Monitoring/ QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 16
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 16 Circuit
QSK60 CM2150 Industrial - Injector Solenoid Driver Cylinder 16 Circuit

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid driver by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside of ECM 1. ECM 2 and ECM 3 have two high-side switches and six low side switches. The injectors for cylinders 8, 16, and 5 share a single high-side switch inside ECM 3. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector solenoid driver. The injector solenoid driver connectors are located on the injector, above the rocker cover. Use the following procedure for or a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector solenoid driver circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection solenoid driver event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than one minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector solenoid driver circuits in the same bank, a short circuit exists.

Causes of a single injector solenoid driver fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector solenoid driver fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injector solenoid drivers in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1557.

Last Modified: 23-Sep-2010


Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 156

Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 156 PID: SPN: 1131 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold 2 temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold air temperature.
QSK38 CM2150 Industrial - Intake Manifold 2 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Intake Manifold 2 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 2 Temperature Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 2 Temperature Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The intake manifold 2 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold 2 temperature sensor is located in the right bank front air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 2 temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
40 | 104 | 4.9k to 5.8k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code 156.

Last Modified: 15-Sep-2010


Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 157

Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 157 PID: SPN: 1131 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold 2 temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold temperature.
QSK38 CM2150 Industrial - Intake Manifold 2 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Intake Manifold 2 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 2 Temperature Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 2 Temperature Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The intake manifold 2 temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The intake manifold 2 temperature sensor is located in the right bank front air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 2 temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness.
  • Signal circuit shorted to return or ground in the sensor.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
40 | 104 | 4.9k to 5.8k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code 157.

Last Modified: 13-Apr-2010


Intake Manifold 2 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 158

Intake Manifold 2 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 158 PID: SPN: 1131 FMI: 0 LAMP: Red SRT: | Intake Manifold 2 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level. Intake manifold 2 air temperature above engine protection critical limit. | Industrial: Calibration dependent progressive power derate and engine shutdown with increasing time after alert. Power Generation: Calibration dependent possible engine shutdown.
QSK38 CM2150 Industrial - Intake Manifold 2 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Intake Manifold 2 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 2 Temperature Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 2 Temperature Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The intake manifold 2 temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The intake manifold 2 temperature sensor is located in the right bank front air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 2 temperature sensor measures the temperature of the charge air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler.
  • Undersized after cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 158.

Last Modified: 10-Dec-2010


Intake Manifold 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 159

Intake Manifold 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 159 PID: SPN: 1132 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold 3 temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold air temperature.
QSK38 CM2150 Industrial - Intake Manifold 3 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 3 Temperature Sensor Circuit
QSK50 and QSK60 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 3 Temperature Sensor Circuit

Circuit Description

The intake manifold 3 temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold 3 temperature sensor is located in the left bank rear air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

The intake manifold 3 temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code 159.

Last Modified: 13-Apr-2010


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1595

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1595 PID: SPN: 974 FMI: 3/3 LAMP: Amber SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the remote accelerator pedal or lever position signal circuit. | Calibration dependent power and speed derate.
QSK38 CM2150 Industrial - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit
QSK50 and QSK60 CM2150 Industrial - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command™ Panel System - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ Panel System - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit

Circuit Description

The remote accelerator pedal or lever position sensor provides the operator's accelerator command to the electronic control module (ECM) through the OEM harness and engine harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote accelerator pedal or lever position sensor location varies with each OEM. Refer to the OEM service manual for component location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If troubleshooting an intermittent accelerator problem, the remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while working the harness to locate the intermittent connection.

Possible causes of this fault code include:

  • Remote accelerator pedal or lever position signal shorted to supply wire, battery, or 5-VDC
  • Open remote accelerator pedal or lever position return (sensor return 1) circuit into the OEM harness or connectors
  • Damaged remote accelerator pedal or lever position sensor
  • The remote accelerator enable signal switch must be turned on for the remote accelerator to operate.
Refer to Troubleshooting Fault Code 1595.

Last Modified: 13-Apr-2010


Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1596

Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1596 PID: SPN: 441 FMI: 4 LAMP: Maintenance SRT: | Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at auxiliary temperature input 1 circuit. | None on performance.
QSK38 CM2150 Industrial - Auxiliary Temperature Sensor Input 1 Circuit
QSK38 CM2150 Power Generation (Military Application) - Auxiliary Temperature Sensor Input 1 Circuit
QSK50 and QSK60 CM2150 Industrial - Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The OEM has the option of wiring a temperature sensor input to the electronic control module (ECM) 3. A specific calibration is then created to recognize this temperature sensor input.

Component Location

The OEM temperature sensor input will vary, depending on application. Refer to the OEM service manual for sensor location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • SIGNAL shorted to ground in the harness
  • SIGNAL shorted to RETURN or ground in the sensor.
Refer to Troubleshooting Fault Code 1596.

Last Modified: 10-Dec-2010


Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 1597

Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1597 PID: SPN: 629 FMI: 12/12 LAMP: Maintenance SRT: | Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the ECM related to memory hardware failures or internal ECM voltage supply circuits. | Engine will possibly not start.
Electronic Control Module (ECM)

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the fuel pump side of the engine. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 1597.

Last Modified: 11-May-2010


Intake Manifold 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 161

Intake Manifold 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 161 PID: SPN: 1132 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold 3 temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold temperature.
QSK38 CM2150 Industrial - Intake Manifold 3 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 3 Temperature Sensor Circuit
QSK50 and QSK60 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 3 Temperature Sensor Circuit

Circuit Description

The intake manifold 3 temperature sensor monitors intake manifold air temperature and passes information to the engine control modules (ECMs) through the engine harness.

Component Location

The intake manifold 3 temperature sensor is located in the left bank rear air intake manifold. Refer to Procedure 100-002 in Section E of the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528, for a detailed component location view.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 3 temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness.
  • Signal circuit shorted to return or ground in the sensor.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
40 | 104 | 4.9k to 5.8k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code 161.

Last Modified: 03-Sep-2015


Fault Code Path Selection

FAULT CODE 1618
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc1618qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1618thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1618 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1618 PID: 1618 SPN: 1137 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 1. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 1
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 1

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 1. The ECM also provides a ground on the sensor RETURN circuit. The exhaust gas temperature sensor circuit cylinder 1 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 1 signal circuit. The exhaust gas temperature sensor circuit cylinder 1 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 1 is located in the exhaust manifold at the cylinder head 1 exhaust manifold interface. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit, Cylinder 1, measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

NOTE: It is possible that the exhaust gas temperature sensor, 5 volt supply, can be open and a fault code will not be set. If this happens, the temperature of the exhaust gas temperature sensors connected to that exhaust gas temperature sensor supply will read a constant 474°C [885°F].

Possible causes of this fault include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1618 (QSK38 and QSK50 Marine).

Last Modified: 14-Apr-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1618 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1618 PID: SPN: 1137 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 1. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1)
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1)
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 1 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 1 is located in the engine harness and extends between the cylinder 1 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 1 measures the exhaust gas temperature of cylinder 1. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit SIGNAL wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600 C° [1112 F°] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600 C° [1112 F°] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A SIGNAL circuit shorted to battery voltage in the harness
  • A SIGNAL circuit shorted to voltage source in the sensor
  • Malfunctioning sensor
  • Malfunctioning ECM.

The resistance of the engine exhaust gas temperature sensor varies with the temperature. If the engine exhaust gas temperature sensor is operating properly, the observed reading will be comparable to the values in the following table.

Sensor Resistance Specifications
Temperature (C°) | Temperature [F°] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1618 (Thermistor).

Last Modified: 10-Dec-2010


Fault Code Path Selection

FAULT CODE 1619
Fault Code Path Selection

Is the engine QSK38 and QSK50 Marine? | Go to 122-fc1619qsk38-50mar
Does the engine have thermistors? | Go to 122-fc1619thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1619 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1619 PID: 1619 SPN: 1140 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 4. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 4

Circuit Description

The ECM provides a 5 volt supply to the exhaust gas temperature sensor circuit cylinder 4. The ECM also provides a ground on the sensor return circuit. The exhaust gas temperature sensor circuit cylinder 4 provides a signal to the ECM on the exhaust gas temperature sensor circuit cylinder 4 signal circuit. The exhaust gas temperature sensor circuit cylinder 4 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 4 is located in the exhaust manifold at the cylinder head 4 exhaust manifold interface. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit, Cylinder 4, measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

NOTE: It is possible that the exhaust gas temperature sensor, 5 volt supply, can be open and a fault code will not be set. If this happens, the temperature of the exhaust gas temperature sensors connected to that exhaust gas temperature sensor supply will read a constant 474°C [885°F].

Possible causes of this fault include:

  • An open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1619 (QSK38 and QSK50 Marine).

Last Modified: 15-Apr-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1619 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1619 PID: SPN: 1140 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 4. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 4

Circuit Description

The exhaust gas temperature sensor circuit cylinder 4 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 4 is located in the engine harness and extends between the cylinder 4 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 4 measures the exhaust temperature of cylinder 4. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600 C° [1112 F°] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600 C° [1112 F°] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to battery voltage in the harness
  • A signal circuit shorted to voltage source in the sensor
  • Damaged sensor
  • Malfunctioning ECM.

Temperature (C°) | Temperature [F°] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 1619 (Thermistor).

Last Modified: 15-Sep-2010


Intake Manifold 3 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 162

Intake Manifold 3 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 162 PID: SPN: 1132 FMI: 0 LAMP: Red SRT: | Intake Manifold 3 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level. Intake manifold 3 air temperature above engine protection critical limit. | Industrial: Calibration dependent progressive power derate and engine shutdown with increasing time after alert. Power Generation: Calibration dependent possible engine shutdown.
QSK38 CM2150 Industrial - Intake Manifold 3 Temperature Sensor
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 3 Temperature Sensor
QSK50 and QSK60 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 3 Temperature Sensor

Circuit Description

The intake manifold 3 temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The intake manifold 3 temperature sensor is located in the left bank rear air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

The intake manifold 3 temperature sensor measures the temperature of the charge air as it passes through the intake manifold.

Possible causes of this fault include:

  • Restricted air flow through the charge-air cooler
  • Undersized after-cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 162.

Last Modified: 10-Dec-2010


Fault Code Path Selection

FAULT CODE 1622
Fault Code Path Selection

Is the engine QSK38? | Go to 122-fc1622qsk38
Is the engine QSK50 or QSK60? | Go to 122-fc1622qsk50-60

Last Modified: 26-Feb-2010


Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1622 (QSK38)

Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1622 PID: SPN: 659 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 9 circuit or no current detected at injector solenoid driver cylinder 9 signal pin or injector solenoid driver cylinder 9 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 9 Circuit
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 9 Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 9 Circuit
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 9 Circuit

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low side switches. The injectors for cylinders 7, 9, and 11 share a single high-side switch inside ECM 2. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent, and especially if more than one injector solenoid driver fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector solenoid driver fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1622 (QSK38).

Last Modified: 10-Dec-2010


Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1622 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1622 PID: SPN: 659 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 9 circuit or no current detected at injector solenoid driver cylinder 9 SIGNAL pin or injector solenoid driver cylinder 9 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK50 and QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 9 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 9 Circuit
QSK50 CM2150 Marine - Injector Solenoid Driver Cylinder 9 Circuit

Circuit Description

The injector solenoid drivers control fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and four low-side switches inside ECM1. ECM2 and ECM3 have two high-side switches and six low side switches. The injectors for cylinders 4, 12, and 9 share a single high-side switch inside ECM2 . Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector solenoid driver is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector solenoid driver circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector solenoid driver circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector solenoid driver fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid driver.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector solenoid driver fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid driver (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1622 (QSK50 and QSK60).

Last Modified: 23-Sep-2010


Intake Manifold 4 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 163

Intake Manifold 4 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 163 PID: SPN: 1133 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 4 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold 4 temperature sensor circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold air temperature.
QSK38 CM2150 Industrial - Intake Manifold 4 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 4 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 and QSK60 CM2150 MarineQSK60 CM2150 Drill Rig - Intake Manifold 4 Temperature Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 4 Temperature Sensor Circuit

Circuit Description

The intake manifold 4 temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold 4 temperature sensor is located in the right bank rear air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 4 temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code 163.

Last Modified: 16-Sep-2010


Intake Manifold 4 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 164

Intake Manifold 4 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 164 PID: SPN: 1133 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 4 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold 4 temperature sensor circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold temperature.
QSK38 CM2150 Industrial - Intake Manifold 4 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 4 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 4 Temperature Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 4 Temperature Sensor Circuit

Circuit Description

The intake manifold 4 temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The intake manifold 4 temperature sensor is located in the right bank rear air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 4 temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.

The temperature sensor resistance should be int he range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
40 | 104 | 4.9k to 5.8k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code 164.

Last Modified: 16-Sep-2010


Intake Manifold 4 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 165

Intake Manifold 4 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 165 PID: SPN: 1133 FMI: 0 LAMP: Red SRT: | Intake Manifold 4 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level. Intake manifold 4 temperature sensor above engine protection critical limit. | Industrial: Calibration dependent progressive power derate and engine shutdown with increasing time after alert. Power Generation: Calibration dependent possible engine shutdown.
QSK38 CM2150 Industrial - Intake Manifold 4 Temperature Sensor
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 4 Temperature Sensor
QSK50 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 4 Temperature Sensor
QSK60 CM2150 Industrial - Intake Manifold 4 Temperature Sensor

Circuit Description

The intake manifold 4 temperature sensor monitors intake manifold air temperature and passes information to the electronic control modules (ECM)s through the engine harness.

Component Location

The intake manifold 4 temperature sensor is located in the right bank rear air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 4 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the aftercooler
  • Undersized aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 165.

Last Modified: 10-Dec-2010


Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1774

Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1774 PID: SPN: 3589 FMI: 3 LAMP: Amber SRT: | Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected in the Engine Oil Priming Pump Circuit. | None on performance.
QSK38 CM2150 Industrial - Engine Oil Priming Pump Control Circuit
QSK50 and QSK60 CM2150 Industrial - Engine Oil Priming Pump Control Circuit

Circuit Description

The ECM monitors the engine oil priming circuit. If the ECM sees the engine oil priming pump is activated and oil pressure does not build to a pre-set level, Fault Code 1774 will become active and the amber lamp will illuminate.

Component Location

The engine oil priming pump can be located on either side of the engine block.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine oil priming pump circuit monitors oil pressure and OEM pump switch input.

Possible causes of this fault code include:

  • Open RETURN circuit in the engine harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage
  • Engine oil priming pump not operating.
Refer to Troubleshooting Fault Code t05-1774.

Last Modified: 30-Nov-2010


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: SPN: 101 FMI: 3 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure sensor circuit. | None on performance.
QSK38 CM2150 Industrial - Crankcase Pressure Sensor Circuit
QSK38 CM2150 Marine - Crankcase Pressure Sensor Circuit
QSK38 CM2150 Power Generation - Crankcase Pressure Sensor Circuit
QSK38 CM2150 Power Generation (Military Application) - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Industrial - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Marine - Crankcase Pressure Sensor Circuit
QSK60 CM2150 Industrial - Crankcase Pressure Sensor Circuit
QSK60 CM2150 Power Generation - Crankcase Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor monitors crankcase pressure and passes information to the electronic control module (ECM) through the engine harness. If the crankcase pressure sensor circuit voltage becomes too high, Fault Code 1843 will become active and the amber lamp will illuminate.

Component Location

The QSK60 crankcase pressure sensor is located in the right bank front cylinder head deck. The QSK38 and QSK50 crankcase pressure sensors are located in a right bank hand hole cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The crankcase pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1843, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1843.

Last Modified: 17-Sep-2010


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source. | None on performance.
QSK38 CM2150 Industrial - Crankcase Pressure Sensor Circuit
QSK38 CM2150 Marine - Crankcase Pressure Sensor Circuit
QSK38 CM2150 Power Generation - Crankcase Pressure Sensor Circuit
QSK38 CM2150 Power Generation (Military Application) - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Industrial - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Marine - Crankcase Pressure Sensor Circuit
QSK60 CM2150 Industrial - Crankcase Pressure Sensor Circuit
QSK60 CM2150 Power Generation - Crankcase Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor monitors crankcase pressure and passes information to the electronic control module (ECM) through the engine harness. If the crankcase pressure sensor circuit voltage becomes too low, Fault Code 1844 will become active and the amber light will illuminate.

Component Location

The QSK60 crankcase pressure sensor is located in the right bank front cylinder head deck. The QSK38 and QSK50 crankcase pressure sensor is located in a right bank hand hole cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The crankcase pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1844, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1844.

Last Modified: 17-Sep-2010


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1845

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1845 PID: SPN: 97 FMI: 3 LAMP: Maintenance SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water in fuel indicator circuit. | None on performance. No water in fuel warning available.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine with C Command™ Panel System - Water in Fuel Indicator Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Water in Fuel Indicator Sensor Circuit
QSK38 CM2150 Marine with C Command Elite™ and C Comman Elite Plus™ Panel System - Water in Fuel Indicator Sensor Circuit
QSK50 CM2150 Industrial - Water in Fuel Indicator Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Water in Fuel Indicator Sensor Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Water in Fuel Indicator Sensor Circuit
QSK60 CM2150 Industrial - Water in Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator sensor is attached to the first stage fuel filter. The water in fuel indicator sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator sensor circuit contains two wires: a water in fuel indicator return (sensor return 1) ground wire and a water in fuel indicator signal wire.

Component Location

The water in fuel indicator sensor is integrated into the first stage fuel filter housing, which is mounted off-engine. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The water in fuel indicator sensor is integrated into the fuel filter. It is automatically replaced whenever the fuel filter is replaced.

Possible causes of this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1845.

Last Modified: 27-Sep-2010


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1846

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1846 PID: SPN: 97 FMI: 4 LAMP: Maintenance SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water in fuel indicator sensor circuit. | None on performance. No water in fuel warning available.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine with C Command™ Panel System - Water in Fuel Indicator Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Water in Fuel Indicator Sensor Circuit
QSK38 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Water in Fuel Indicator Sensor Circuit
QSK50 CM2150 Industrial - Water in Fuel Indicator Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Water in Fuel Indicator Sensor Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Water in Fuel Indicator Sensor Circuit
QSK60 CM2150 Industrial - Water in Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator sensor is attached to the first stage fuel filter. The water in fuel indicator sensor sends a signal to the ECM when a set volume of water has accumulated in the fuel filter. The water in fuel indicator sensor circuit contains two wires: a water in fuel indicator return (sensor return 1) ground wire and a water in fuel indicator signal wire.

Component Location

The water in fuel indicator sensor is integrated into the first stage fuel filter housing, which is mounted off-engine. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The water in fuel indicator sensor is integrated into the fuel filter. It is automatically replaced whenever the fuel filter is replaced.

Possible causes for this fault code include:

  • SIGNAL circuit shorted to ground in the harness, sensor, or connector.
Refer to Troubleshooting Fault Code t05-1846

Last Modified: 20-Sep-2010


Engine Coolant Temperature - Special Instructions

FAULT CODE 1847

Engine Coolant Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1847 PID: SPN: 110 FMI: 14 LAMP: Red SRT: | Engine Coolant Temperature - Special Instructions. Engine coolant temperature 1 signal indicates engine coolant temperature is above the engine protection warning limit. | Power Generation - Engine will be disconnected from the grid and idle only. The generator controllers will shut down the engine.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Engine Coolant Temperature 1 Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Coolant Temperature 1 Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Engine Coolant Temperature 1 Sensor Circuit
QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Coolant Temperature 1 Sensor Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Coolant Temperature 1 Sensor Circuit
QSK60 CM2150 Power Generation - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts it to a temperature value. The engine coolant temperature 1 value is used by the ECM for the engine protection system, and for engine emissions control.

Component Location

The engine coolant temperature 1 sensor is located in the thermostat housing.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528 or in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530.

Refer to Troubleshooting Fault Code t05-1847

Last Modified: 23-Sep-2010


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: SPN: 97 FMI: 16 LAMP: Amber SRT: | Water In Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting. Engine derate will occur on Marine engines if optional engine protection feature is enabled.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine with C Command™ Panel System - Water in Fuel Indicator Sensor Circuit
QSK38 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Water in Fuel Indicator Sensor Circuit
QSK50 CM2150 Industrial - Water in Fuel Indicator Sensor Circuit
QSK38 CM2150 Power Generation and QSK38 CM2150 Power Generation (Military Application) - Water in Fuel Indicator Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Water in Fuel Indicator Sensor Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Water in Fuel Indicator Sensor Circuit
QSK60 CM2150 Industrial - Water in Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator sensor is attached to the first stage fuel filter. The water in fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator sensor circuit contains two wires; a water in fuel indicator return (sensor return 1) ground wire and a water in fuel indicator signal wire.

Component Location

The water in fuel indicator sensor is integrated into the first stage fuel filter housing which is mounted off-engine. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • On Marine Propulsion engines, if the optional engine protection feature has been enabled, a torque derate will occur.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

Drain the Stage 1 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code t05-1852.

Last Modified: 24-Sep-2015


Fault Code Path Selection

FAULT CODE 187
Fault Code Path Selection

Is the sensor supply 2 circuit fault code generated from ECM 3 source address 00? | Go to 122-fc187sa00
Is the sensor supply 2 circuit fault code generated from ECM 2 source address 01? | Go to 122-fc187sa01

Last Modified: 25-Feb-2010


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187 (Source Address 00)

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 2 circuit. | Loss of some sensor functionality.
QSK38 CM2150 Industrial - Sensor Supply 2 Circuit
QSK38 CM2150 Power Generation - Sensor Supply 2 Circuit
QSK38 CM2150 Marine - Sensor Supply 2 Circuit
QSK50 CM2150 Industrial/QSK60 CM2150 Industrial - Sensor Supply 2 Circuit
QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Sensor Supply 2 Circuit
QSK50 CM2150 Marine - Sensor Supply 2 Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the electronic control module (ECM) provides 5 volts for the engine camshaft speed/position sensor, intake manifold 1 pressure sensor, fuel delivery pressure sensor, barometric pressure sensor, and injector metering rail 1 pressure sensor.

Component Location

The sensor supply 2 is located in the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of low voltage on the 5 volt supply line:

  • Short circuit to ground in a supply line
  • Short circuit between a supply line or return wire
  • Damaged sensor
  • Malfunctioning ECM power supply.
Refer to Troubleshooting Fault Code 187 (Source Address 00).

Last Modified: 17-Sep-2010


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187 (Source Address 01)

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 2 circuit. | Loss of some sensor functionality.
QSK38 CM2150 Marine - Sensor Supply 2 Circuit
QSK50 CM2150 Marine - Sensor Supply 2 Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 pin of the of the electronic control module (ECM) provides 5 volt supply for the pre-filter oil pressure sensor and intake manifold 2 pressure sensor.

On the QSK60 engines the sensor supply 2 pin also supplies voltage to the post-oil filter pressure sensor.

Component Location

The sensor supply 2 is located in the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Short circuit to ground in a supply wire
  • Short circuit between a supply line or a return wire
  • Damaged sensor
  • Damaged ECM supply.
Refer to Troubleshooting Fault Code 187 (Source Address 01).

Last Modified: 16-Jul-2010


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

FAULT CODE 1888

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1888 PID: SPN: 91 FMI: 19 LAMP: Maintenance SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error. The OEM electronic control unit detected a fault with its accelerator pedal or lever sensor. | Engine could possibly only idle or engine will not accelerate to full speed.
QSK38 CM2150 Industrial - SAE J1939 Datalink Circuit
QSK38 CM2150 Marine Propulsion - SAE J1939 Datalink Circuit
QSK50 and QSK60 CM2150 Industrial - SAE J1939 Datalink Circuit
QSK50 and QSK60 CM2150 Marine Propulsion - SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit or transmission electronic control unit in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM electronic control unit to the engine ECM over the SAE J1939 datalink.

Messages sent from OEM electronic control units or transmission electronic control units are received by the ECM and used for controlling the engine. The ECM and OEM electronic control units must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the left side of the engine. The SAE J1939 datalink wiring and OEM electronic control unit location varies by OEM. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault can occur when the OEM electronic control unit detects an error on the accelerator pedal or idle validation switch. The ECM has been set up properly (components enabled and OEM electronic control unit source addressed correctly) to receive multiplexed information for the accelerator pedal or lever idle validation switch states and accelerator pedal or lever position over the SAE J1939 datalink from an OEM electronic control unit, and the OEM electronic control unit is transmitting the message for that component.

The three types of errors that can occur for this fault are:

  • When the accelerator pedal or lever position is depressed and the OEM electronic control unit reads accelerator pedal or lever position as greater than 0 percent, but the accelerator pedal or lever idle validation switch indicates it is in the idle position. This fault status is transmitted to the ECM on the SAE J1939 datalink, which causes this fault to occur in the ECM.
  • When the accelerator pedal or lever position is released and the OEM electronic control unit reads accelerator pedal or lever position as 0 percent, but the accelerator pedal or lever idle validation switch indicates it is not in the idle position. This fault status is transmitted to the ECM on the SAE J1939 datalink, which causes this fault to occur in the ECM.
  • The OEM electronic control unit determines that the accelerator pedal or lever position signal wire is shorted high or shorted low.

NOTE: It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM electronic control unit or ECM, from other components, from the accelerator pedal or lever idle validation switch, or if the SAE J1939 datalink is damaged. OEM configurations must multiplex the accelerator pedal or lever idle validation switch inputs together to allow the use of the SAE J1939 multiplexed accelerator pedal or lever sensor system and limp home feature for these components. INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code 1888.

Last Modified: 13-Apr-2010


SAE J1939 Multiplexed Remote Accelerator Pedal or Lever Sensor System - Received Network Data In Error

FAULT CODE 1889

SAE J1939 Multiplexed Remote Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1889 PID: SPN: 974 FMI: 2/19 LAMP: Maintenance SRT: | SAE J1939 Multiplexed Remote Accelerator Pedal or Lever Sensor System - Received Network Data In Error. The OEM electronic control unit detected a fault with its remote accelerator pedal or lever sensor system. | Engine will not respond to the remote throttle. Engine could possibly only idle. The primary or cab accelerator could possibly be used.
QSK38 CM2150 Industrial - SAE J1939 Datalink Circuit
QSK38 CM2150 Marine Propulsion - SAE J1939 Datalink Circuit
QSK50 and QSK60 CM2150 Industrial - SAE J1939 Datalink Circuit
QSK50 and QSK60 CM2150 Marine Propulsion - SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit or transmission electronic control unit in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM electronic control unit to the ECM over the SAE J1939 datalink.

Messages sent from OEM electronic control units or transmissions electronic control units are received by the ECM and used for controlling the engine. The ECM and OEM electronic control units must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the left side of the engine. The SAE J1939 datalink wiring and vehicle electronic control unit location varies by OEM. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault can occur when the OEM electronic control unit detects an error on the remote accelerator pedal or lever or from the remote accelerator pedal or lever enable switch. The ECM has been set up properly (components enabled and OEM electronic control unit source addressed correctly) to receive multiplexed information for the accelerator pedal or lever idle validation switch states and remote accelerator pedal or lever position over the SAE J1939 datalink from an OEM electronic control unit, and the OEM electronic control unit is transmitting the message for that component.

Most OEM's will not have the circuitry to detect a remote accelerator pedal or lever switch error.

The two types of errors that can occur for this fault are:

  • The OEM electronic control unit determines that the remote accelerator pedal or lever SIGNAL wire is shorted high or shorted low. This fault status is transmitted to the ECM on the SAE J1939 datalink, which causes this fault to occur in the ECM.
  • When the remote accelerator pedal or lever enable switch has a shorted high or shorted low error detected by the OEM electronic control unit, this fault status is transmitted to the ECM on the SAE J1939 datalink, which causes this fault to occur in the ECM.

Note: It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM electronic control unit or ECM, for other components, or the accelerator and idle validation switch, or if the SAE J1939 datalink is damaged. OEM configurations must multiplex the accelerator pedal or lever and accelerator pedal or lever idle validation switch inputs together to allow the use of the SAE J1939 datalink multiplexing and limp home feature for these components. INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code 1889.

Last Modified: 13-Apr-2010


Engine Oil Change Interval - Condition Exists

FAULT CODE 1891

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1891 PID: SPN: 1378 FMI: 31 LAMP: Amber SRT: | Engine Oil Change Interval - Condition Exists. | Engine oil burn valve solenoid unable to inject oil.
QSK38 CM2150 Industrial/QSK38 CM2150 Power Generation/QSK38 CM2150 Marine - Engine Oil Burn Valve Solenoid Driver Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Oil Burn Valve Solenoid Driver Circuit
QSK60 CM2150 Industrial - Engine Oil Burn Valve Solenoid Driver Circuit

Circuit Description

The engine oil burn valve solenoid driver controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The engine oil burn valve solenoid is located on the rear left side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

When the solenoid tries to inject oil and can not it generates a miss count. When these counts reach a predefined level, Fault Code 1891 goes active. Check for the presence of engine oil burn valve solenoid driver circuit Fault Codes 223 and 224.

Check for counts of engine oil rifle pressure sensor circuit Fault Codes 135 and 141 and coolant temperature sensor circuit Fault Codes 144 and 145. When active, these fault codes will prevent oil injection.

If an oil make-up tank is used, check for Fault Code 1357. If an oil make-up tank is not used, it is recommended to change the engine oil at the next maintenance interval.

Refer to Troubleshooting Fault Code 1891.

Last Modified: 21-Sep-2010


Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 1911

Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1911 PID: SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level. Mechanical dump valve has tripped. | Engine performance derate.
QSK38 CM2150 Industrial - Injector Metering Rail 1 Pressure Circuit
QSK38 CM2150 Marine - Injector Metering Rail 1 Pressure Circuit
QSK38 CM2150 Power Generation - Injector Metering Rail 1 Pressure Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Metering Rail 1 Pressure Circuit
QSK50 CM2150 Industrial - Injector Metering Rail 1 Pressure Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Injector Metering Rail 1 Pressure Circuit
QSK50 CM2150 Marine - Injector Metering Rail 1 Pressure Circuit
QSK60 CM2150 Industrial - Injector Metering Rail 1 Pressure Circuit
QSK60 CM2150 Power Generation- Injector Metering Rail 1 Pressure Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Metering Rail 1 Pressure Circuit

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the gerotor pump. The ECM monitors the injector metering rail 1 pressure and engine operating conditions, and changes the flow command to maintain the proper injector metering rail 1 pressure. Changes to the flow command result in opening or closing of the fuel pump pressurizing assembly.

The high-pressure relief valve is set to trip at 1950 bar [28,282 psi]. After it trips, it then regulates at 900 to 1300 bar [13,053 to 18,854 psi].

Component Location

The high-pressure fuel pump is mounted to the gear housing on the left side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fuel drain flow and drain fuel temperature will increase due to the following possible causes:

  • Fuel pump pressurizing assembly o-ring leaking
  • High gerotor outlet pressure
  • High gerotor inlet pressure
  • Air in fuel.
Refer to Troubleshooting Fault Code 1911.

Last Modified: 13-Dec-2010


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
QSK38 CM2150 Industrial/QSK50 CM2150 Industrial - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Power Generation - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Power Generation (Military Application) - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command™ and Marine Auxiliary with C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ and Marine Auxilary with C Command Elite™ and Elite Plus™ Panel System - Coolant Level Sensor 1 Circuit
QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Coolant Level Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ and Marine Auxiliary with C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ and Marine Auxilary with C Command Elite™ and Elite Plus™ Panel System Panel/QSK60 CM2150 Drill Rig - Coolant Level Sensor 1 Circuit

Circuit Description

The coolant level sensor 1 monitors the engine coolant level within the cooling system and passes information to the electronic control module (ECM) through the original equipment manufacturer (OEM) harness and engine harness. In Power Generation applications, the information is passed only through the engine harness.

Component Location

The coolant level sensor 1 is typically located in the radiator top tank or surge tank. Refer to Procedure 100-001 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 195.

Last Modified: 10-Mar-2015


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
QSK38 CM2150 Industrial/QSK50 CM2150 Industrial - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Power Generation - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Power Generation (Military Application) - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command™ and Marine Auxiliary with C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ and Marine Auxilary with C Command Elite™ and C Command Elite Plus™ Panel System Panel - Coolant Level Sensor 1 Circuit
QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Coolant Level Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ and Marine Auxiliary with C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ and Marine Auxilary with C Command Elite™ and C Command Elite Plus™ Panel System Panel/QSK60 CM2150 Drill Rig - Coolant Level Sensor 1 Circuit

Circuit Description

The coolant level 1 sensor monitors the engine coolant level within the cooling system and passes information to the electronic control module (ECM) through the original equipment manufacturer (OEM) harness and engine harness. In Power Generation applications, the information is passed only through the engine harness.

Component Location

The coolant level sensor 1 is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Signal circuit shorted to ground or return in the harness, sensor, or connectors
  • Damaged sensor.
Refer to Troubleshooting Fault Code 196.

Last Modified: 01-Oct-2010


Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: SPN: 111 FMI: 18 LAMP: Amber SRT: | Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level. Low engine coolant level detected. | None on performance.
QSK38 CM2150 Industrial/QSK50 CM2150 Industrial - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Power Generation - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Power Generation (Military Application) - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command™ and Marine Auxiliary with C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ and Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Coolant Level Sensor 1 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Coolant Level Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ and Marine Auxiliary C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ and Marine Auxilary with C Command Elite™ and C Command Elite Plus™ Panel System/QSK60 CM2150 Drill Rig - Coolant Level Sensor 1 Circuit

Circuit Description

The engine coolant level sensor 1 monitors the engine coolant level within the coolant system and passes information to the electronic control module (ECM) through the original equipment manufacturer (OEM) harness and engine harness.

Component Location

The engine coolant level sensor 1 is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for location.

Shop Talk

This fault code normally goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

This fault can also go active as a result of an open signal wire or open supply wire in the circuit causing a false Fault Code 197 even though there is coolant in the system.

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open supply wire in the engine harness
  • Signal wire shorted to sensor supply or battery voltage
  • Low coolant level in the cooling system.
Refer to Troubleshooting Fault Code 197.

Last Modified: 10-Dec-2010


Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1978

Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1978 PID: SPN: 4222 FMI: 3 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source. | Engine will not synchronize with the grid, if connected.
QSK38 CM2150 Marine Auxiliary - Generator Speed/Load Governing Bias Circuit
QSK38 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Generator Speed/Load Governing Bias Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary/QSK60 CM2150 Drill Rig - Generator Speed/Load Governing Bias Circuit

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the generator set controller on the generator set. Refer to the OEM service manual for component location.

Shop Talk

There are multiple electronic control modules (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • OPEN return circuit in the harness, connectors, or sensor
  • SIGNAL circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1978.

Last Modified: 17-Sep-2010


Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1979

Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1979 PID: SPN: 4222 FMI: 4 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will not synchronize with the grid, if connected.
QSK38 CM2150 Power Generation - Generator Speed/Load Governing Bias Circuit
QSK38 CM2150 Marine Auxiliary - Generator Speed/Load Governing Bias Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Generator Speed/Load Governing Bias Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary/QSK60 CM2150 Drill Rig - Generator Speed/Load Governing Bias Circuit

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the genset controller on the Generator-Drive or Corporate Genset. Refer to the OEM service manual.

Shop Talk

There are multiple electronic control module (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • A SIGNAL circuit open or shorted to ground in the OEM harness or engine harness
  • A SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1979.

Last Modified: 17-Sep-2010


Intake Manifold 2 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1984

Intake Manifold 2 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1984 PID: SPN: 1131 FMI: 16 LAMP: Amber SRT: | Intake Manifold 2 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level. Intake manifold 2 temperature above engine protection warning limit. | For Industrial application: Calibration-dependent progressive power derate and engine shutdown with increasing time after alert.
QSK38 CM2150 Industrial - Intake Manifold 2 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Intake Manifold 2 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 2 Temperature Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 2 Temperature Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The intake manifold 2 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 2 temperature sensor is located in the front right air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 2 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the aftercooler
  • Coolant restriction on the aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 1984.

Last Modified: 13-Dec-2010


Intake Manifold 3 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1985

Intake Manifold 3 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1985 PID: SPN: 1132 FMI: 16 LAMP: Amber SRT: | Intake Manifold 3 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level. Intake manifold 3 temperature sensor above engine protection warning limit. | For Industrial application: Calibration dependent progressive power derate and engine shutdown with increasing time after alert.
QSK38 CM2150 Industrial - Intake Manifold 3 Temperature Sensor Circuit
QSK50 and QSK60 CM2150 Industrial and Marine/QSK60 CM2150 Drill Rig - Intake Manifold 3 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 3 Temperature Sensor Circuit

Circuit Description

The intake manifold 3 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 3 temperature sensor is located in the rear left air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 3 temperature sensor measures the temperature of the charge air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the aftercooler
  • Coolant restriction on the aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 1985.

Last Modified: 13-Dec-2010


Intake Manifold 4 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1986

Intake Manifold 4 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1986 PID: SPN: 1133 FMI: 16 LAMP: Amber SRT: | Intake Manifold 4 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level. Intake manifold 4 temperature sensor above engine protection warning limit. | For Industrial application: Calibration dependent progressive power derate and engine shutdown with increasing time after alert.
QSK38 CM2150 Industrial - Intake Manifold 4 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 4 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 4 Temperature Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 4 Temperature Sensor Circuit

Circuit Description

The intake manifold 4 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 4 temperature sensor is located in the rear right air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 4 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the aftercooler
  • Coolant restriction on the aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 1986.

Last Modified: 13-Dec-2010


Engine Crankshaft Speed/Position - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: SPN: 190 FMI: 0/16 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid but Above Normal Operating Range - Moderately Severe Level. Engine crankshaft speed/position signal indicates engine speed above generator set limit. | Engine will shut down.
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application)/QSK38 CM2150 Marine Auxiliary - Engine Crankshaft Speed/Position Sensor Circuit
QSK50 CM2150 Marine Auxiliary/QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Crankshaft Speed/Position Sensor Circuit
QSK60 CM2150 Power Generation - Engine Crankshaft Speed/Position Sensor Circuit
QSK60 CM2150 Marine Auxiliary/QSK60 CM2150 Drill Rig - Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine crankshaft speed/position sensor and the engine camshaft speed/position sensor provide engine speed and position information to the ECM through the engine harness.

Component Location

The QSK60 engine crankshaft speed/position sensor is located at the top right of the flywheel housing. The QSK50 and QSK60 engine camshaft speed/position sensor is located above the fuel pump, in the back of the gear housing. The QSK50 engine crankshaft speed/position sensor is located at the top left of the flywheel housing.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Gain adjust potentiometer not set correctly
  • Erroneous generator speed/load governing bias signal from the generator set
  • Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 1992.

Last Modified: 13-Dec-2010


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: SPN: 175 FMI: 3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine oil temperature sensor1 circuit. | No engine protection for engine oil temperature.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Engine Oil Temperature Sensor 1 Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Oil Temperature Sensor 1 Circuit
QSK50 CM2150 Power Generation - Engine Oil Temperature Sensor 1 Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Oil Temperature Sensor 1 Circuit
QSK50 and QSK60 CM2150 Industrial/QSK50 CM2150 Power Generation/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Oil Temperature Sensor 1 Circuit
QSK50 CM2150 Marine - Engine Oil Temperature Sensor 1 Circuit
QSK60 CM2150 Power Generation - Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor 1 is used by the electronic control module (ECM) to monitor the engine oil temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value. The engine oil temperature value is used by the ECM for the engine protection system, and engine emissions control.

Component Location

The engine oil temperature sensor 1 is located in the oil pan adaptor on the left bank.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Before troubleshooting Fault Code 212, check for multiple faults.

The engine oil temperature sensor 1 shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature (°F) | QSK50 Resistance (Ohms) | QSK60 Resistance (Ohms)
0 | 32 | 30.7k to 36.6k | 30.7k to 36.6k
25 | 77 | 9.3k to 10.7k | 9.3k to 10.7k
50 | 122 | 3.2k to 3.75k | 3.2k to 3.75k
80 | 176 | 1.1k to 1.3k | 1.1k to 1.3k
95 | 203 | 725 to 756 | 710 to 793
Refer to Troubleshooting Fault Code 212.

Last Modified: 13-Sep-2010


Fault Code Path Selection

FAULT CODE 2121
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2121qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2121thermistor

Last Modified: 16-Jun-2010


Exhaust Gas Temperature Cylinder 1 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2121 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 1 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2121 PID: SPN: 1137 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 1 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 1
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 1

Circuit Description

The exhaust gas temperature sensor circuit cylinder 1 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 1 is located in the exhaust manifold at the cylinder head 1 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 1 measures the exhaust temperature of it is respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted aftercooler
  • Boost air leaks
  • Overfueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2121 (QSK38 and QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 1 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2121 (Thermistor)

Exhaust Gas Temperature Cylinder 1 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2121 PID: SPN: 1337 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 1 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 1
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 1
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 1

Circuit Description

The exhaust gas temperature sensor circuit cylinder 1 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 1 is located in the engine harness and extends between the number 1 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 1 measures the exhaust gas temperature of cylinder 1. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2121 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2122
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2122qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2122thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 3 - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2122 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 3 - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2122 PID: SPN: 1139 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 3 - Data Valid But Above Normal Operational Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 3
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 3

Circuit Description

The exhaust gas temperature sensor circuit cylinder 3 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 3 is located in the exhaust manifold at the cylinder head 3 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 3 measures the exhaust temperature of it is respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted aftercooler
  • Boost air leaks
  • Overfueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2122 (QSK38 and QSK50 Marine).

Last Modified: 02-Apr-2010


Exhaust Gas Temperature Cylinder 3 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2122 (Thermistor)

Exhaust Gas Temperature Cylinder 3 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2122 PID: SPN: 1139 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 3 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 3
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 3
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 3

Circuit Description

The exhaust gas temperature sensor circuit cylinder 3 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 3 is located in the engine harness and extends between the cylinder 3 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 3 measures the exhaust gas temperature of cylinder 3. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault code include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2122 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2123
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2123qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2123thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 5 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2123 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 5 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2123 PID: SPN: 1141 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 5 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 5
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 5

Circuit Description

The exhaust gas temperature sensor circuit cylinder 5 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 5 is located in the exhaust manifold at the cylinder head 5 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 5 measures the exhaust temperature of it is respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted aftercooler
  • Boost air leaks
  • Overfueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2123 (QSK38 and QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 5 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2123 (Thermistor)

Exhaust Gas Temperature Cylinder 5 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2123 PID: SPN: 1141 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 5 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 5
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 5
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 5

Circuit Description

The exhaust gas temperature sensor circuit cylinder 5 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 5 is located in the engine harness and extends between the number 5 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 5 measures the exhaust gas temperature of cylinder 5. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault code include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2123 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2124
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2124qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2124thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 7 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2124 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 7 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2124 PID: SPN: 1143 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 7 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 7
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 7

Circuit Description

The exhaust gas temperature sensor circuit cylinder 7 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 7 is located in the exhaust manifold at the cylinder head 7 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 7 measures the exhaust temperature of it is respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted aftercooler
  • Boost air leaks
  • Overfueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2124 (QSK38 and QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 7 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2124 (Thermistor)

Exhaust Gas Temperature Cylinder 7 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2124 PID: SPN: 1143 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 7 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 7
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 7
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 7

Circuit Description

The exhaust gas temperature sensor circuit cylinder 7 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 7 is located in the engine harness and extends between the number 7 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 7 measures the exhaust gas temperature of cylinder 7. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault code include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2124 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2125
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2125qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2125thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 9 - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2125 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 9 - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2125 PID: SPN: 1145 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 9 - Data Valid but Above Normal Operational Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 9
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 9

Circuit Description

The exhaust gas temperature sensor circuit cylinder 9 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 9 is located in the exhaust manifold at the cylinder head 9 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 9 measures the exhaust temperature of it is respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted aftercooler
  • Boost air leaks
  • Overfueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2125 (QSK38 and QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 9 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2125 (Thermistor)

Exhaust Gas Temperature Cylinder 9 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2125 PID: SPN: 1337 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 9 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 9
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 9
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 9

Circuit Description

The exhaust gas temperature sensor circuit cylinder 9 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 9 is located in the engine harness and extends between the number 9 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 9 measures the exhaust gas temperature of cylinder 9. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault code include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2125 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2126
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2126qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2126thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 11 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2126 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 11 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2126 PID: SPN: 1147 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 11 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 11
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 11

Circuit Description

The exhaust gas temperature sensor circuit cylinder 11 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 11 located in the exhaust manifold at the cylinder head 11 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 11 measures the exhaust temperature of it is respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted after-cooler
  • Boost air leaks
  • Over-fueling
  • Turbocharger over-speed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2126 (QSK38 and QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 11 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2126 (Thermistor)

Exhaust Gas Temperature Cylinder 11 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2126 PID: SPN: 1147 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 11 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 11
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 11
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 11

Circuit Description

The exhaust gas temperature sensor circuit cylinder 11 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 11 is located in the engine harness and extends between the number 11 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 11 measures the exhaust gas temperature of cylinder 11. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault code include:

  • Restricted after-cooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • High intake air temperature
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2126 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2127
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc2127qsk50mar
Does the engine have thermistors? | Go to 122-fc2127thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 13 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2127 (QSK50 Marine)

Exhaust Gas Temperature Cylinder 13 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2127 PID: SPN: 1149 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 13 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 13

Circuit Description

The exhaust gas temperature sensor circuit cylinder 13 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 13 is located in the exhaust manifold at the cylinder head 13 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 13 measures the exhaust temperature of it is respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted after-cooler
  • Boost air leaks
  • Over-fueling
  • Turbocharger over-speed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2127 (QSK50 Marine).

Last Modified: 01-Apr-2010


Exhaust Gas Temperature Cylinder 13 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2127 (Thermistor)

Exhaust Gas Temperature Cylinder 13 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2127 PID: SPN: 1149 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 13 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 13
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 13
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 13

Circuit Description

The exhaust gas temperature sensor circuit cylinder 13 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 13 is located in the engine harness and extends between the number 13 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 13 measures the exhaust gas temperature of cylinder 13. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault code include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • High intake air temperature
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2127 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2128
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc2128qsk50mar
Does the engine have thermistors? | Go to 122-fc2128thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 15 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2128 (QSK50 Marine)

Exhaust Gas Temperature Cylinder 15 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2128 PID: SPN: 1151 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 15 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 15

Circuit Description

The exhaust gas temperature sensor circuit cylinder 15 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 15 is located in the exhaust manifold at the cylinder head 15 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 15 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted after-cooler
  • Boost air leaks
  • Over-fueling
  • Turbocharger over-speed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2128 (QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 15 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2128 (Thermistor)

Exhaust Gas Temperature Cylinder 15 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2128 PID: SPN: 1151 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 15 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 15
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 15
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 15

Circuit Description

The exhaust gas temperature sensor circuit cylinder 15 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 15 is located in the engine harness and extends between the number 15 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 15 measures the exhaust gas temperature of cylinder 15. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • High intake air temperature
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2128 (Thermistor).

Last Modified: 10-Dec-2010


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: SPN: 175 FMI: 4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine oil temperature sensor 1 circuit. | No engine protection for engine oil temperature.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Engine Oil Temperature Sensor 1 Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Oil Temperature Sensor 1 Circuit
QSK50 CM2150 Power Generation - Engine Oil Temperature Sensor 1 Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Oil Temperature Sensor 1 Circuit
QSK50 and QSK60 CM2150 Industrial/QSK50 CM2150 Power Generation/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Oil Temperature Sensor 1 Circuit
QSK50 CM2150 Marine - Engine Oil Temperature Sensor 1 Circuit
QSK60 CM2150 Power Generation - Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor 1 is used by the electronic control module (ECM) to monitor the engine oil temperature. The ECM monitors the voltage on the engine oil temperature 1 SIGNAL pin and converts it to a temperature value. The engine oil temperature value is used by the ECM for the engine protection system, and for engine emissions control.

Component Location

The engine oil temperature sensor 1 is located in the oil pan adapter on the left bank.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

The engine oil temperature sensor 1 shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 213, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature (°F) | QSK50 Resistance (Ohms) | QSK60 Resistance (Ohms)
0 | 32 | 30.7k to 36.6k | 30.7k to 36.6k
25 | 77 | 9.3k to 10.7k | 9.3k to 10.7k
50 | 122 | 3.2k to 3.75k | 3.2k to 3.75k
80 | 176 | 1.1k to 1.3k | 1.1k to 1.3k
95 | 203 | 725 to 756 | 710 to 793
Refer to Troubleshooting Fault Code 213.

Last Modified: 13-Sep-2010


Fault Code Path Selection

FAULT CODE 2131
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2131qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2131thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 2 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2131 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 2 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2131 PID: SPN: 1138 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 2 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 2

Circuit Description

The exhaust gas temperature sensor circuit cylinder 2 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 2 is located in the exhaust manifold at the cylinder head 2 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 2 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted after-cooler
  • Boost air leaks
  • Over-fueling
  • Turbocharger over-speed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2131 (QSK38 and QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 2 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2131 (Thermistor)

Exhaust Gas Temperature Cylinder 2 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2131 PID: SPN: 1138 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 2 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 2

Circuit Description

The exhaust gas temperature sensor circuit cylinder 2 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 2 is located in the engine harness and extends between the number 2 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 2 measures the exhaust gas temperature of cylinder 2. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • High intake air temperature
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2131 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2132
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2132qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2132thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 4 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2132 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 4 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2128 PID: SPN: 1140 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 4 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 4

Circuit Description

The exhaust gas temperature sensor circuit cylinder 4 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 4 is located in the exhaust manifold at the cylinder head 4 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 4 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted after-cooler
  • Boost air leaks
  • Over-fueling
  • Turbocharger over-speed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2132 (QSK38 and QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 4 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2132 (Thermistor)

Exhaust Gas Temperature Cylinder 4 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2132 PID: SPN: 1140 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 4 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 4

Circuit Description

The exhaust gas temperature sensor circuit cylinder 4 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 4 is located in the engine harness and extends between the number 4 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 4 measures the exhaust gas temperature of cylinder 4. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • High intake air temperature
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2132 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2133
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2133qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2133thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 6 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2133 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 6 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2133 PID: SPN: 1142 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 6 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 6

Circuit Description

The exhaust gas temperature sensor circuit cylinder 6 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 6 is located in the exhaust manifold at the cylinder head 6 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 6 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted after-cooler
  • Boost air leaks
  • Over-fueling
  • Turbocharger over-speed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2133 (QSK38 and QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 6 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2133 (Thermistor)

Exhaust Gas Temperature Cylinder 6 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2133 PID: SPN: 1142 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 6 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 6

Circuit Description

The exhaust gas temperature sensor circuit cylinder 6 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit - cylinder 6 is located in the engine harness and extends between the number 6 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 6 measures the exhaust gas temperature of cylinder 6. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • High intake air temperature
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2133 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2134
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2134qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2134thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 8 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2134 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 8 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2134 PID: SPN: 1144 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 8 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 8

Circuit Description

The exhaust gas temperature sensor circuit cylinder 8 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 8 is located in the exhaust manifold at the cylinder head 8 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 8 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted after-cooler
  • Boost air leaks
  • Over-fueling
  • Turbocharger over-speed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2134 (QSK38 and QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 8 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2134 (Thermistor)

Exhaust Gas Temperature Cylinder 8 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2134 PID: SPN: 1144 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 8 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 8

Circuit Description

The exhaust gas temperature sensor circuit cylinder 8 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit - cylinder 8 is located in the engine harness and extends between the number 8 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 8 measures the exhaust gas temperature of cylinder 8. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • High intake air temperature
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2134 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2135
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2135qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2135thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 10 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2135 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 10 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2135 PID: SPN: 1146 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 10 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 10

Circuit Description

The exhaust gas temperature sensor circuit cylinder 10 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 10 is located in the exhaust manifold at the cylinder head 10 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 10 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted after-cooler
  • Boost air leaks
  • Over-fueling
  • Turbocharger over-speed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2135 (QSK38 and QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 10 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2135 (Thermistor)

Exhaust Gas Temperature Cylinder 10 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2135 PID: SPN: 1146 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 10 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 10

Circuit Description

The exhaust gas temperature sensor circuit cylinder 10 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit - cylinder 10 is located in the engine harness and extends between the number 10 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 10 measures the exhaust gas temperature of cylinder 10. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • High intake air temperature
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2135 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2136
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc2136qsk38-50mar
Does the engine have thermistors? | Go to 122-fc2136thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 12 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2136 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Cylinder 12 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2136 PID: SPN: 1148 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 12 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 12

Circuit Description

The exhaust gas temperature sensor circuit cylinder 12 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 12 is located in the exhaust manifold at the cylinder head 12 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 12 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted after-cooler
  • Boost air leaks
  • Over-fueling
  • Turbocharger over-speed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2136 (QSK38 and QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 12 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2136 (Thermistor)

Exhaust Gas Temperature Cylinder 12 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2136 PID: SPN: 1148 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 12 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 12

Circuit Description

The exhaust gas temperature sensor circuit cylinder 12 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 12 is located in the engine harness and extends between the number 12 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 12 measures the exhaust gas temperature of cylinder 12. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2136 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2137
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc2137qsk50mar
Does the engine have thermistors? | Go to 122-fc2137thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 14 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2137 (QSK50 Marine)

Exhaust Gas Temperature Cylinder 14 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2137 PID: SPN: 1150 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 14 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 14

Circuit Description

The exhaust gas temperature sensor circuit cylinder 14 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 14 is located in the exhaust manifold at the cylinder head 14 (exhaust manifold interface).

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 14 measures the exhaust temperature of it's respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damaged
  • Restricted after-cooler
  • Boost air leaks
  • Over-fueling
  • Turbocharger over-speed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2137 (QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 14 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2137 (Thermistor)

Exhaust Gas Temperature Cylinder 14 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2137 PID: SPN: 1150 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 14 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 14

Circuit Description

The exhaust gas temperature sensor circuit cylinder 14 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit - cylinder 14 is located in the engine harness and extends between the number 14 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 14 measures the exhaust gas temperature of cylinder 14. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • High intake air temperature
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2137 (Thermistor).

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 2138
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc2138qsk50mar
Does the engine have thermistors? | Go to 122-fc2138thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Cylinder 16 - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2138 (QSK50 Marine)

Exhaust Gas Temperature Cylinder 16 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2138 PID: SPN: 1152 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 16 - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 16

Circuit Description

The exhaust gas temperature sensor circuit cylinder 16 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 16 is located in the exhaust manifold at the cylinder head 16 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 16 measures the exhaust temperature of it's respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted after-cooler
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2138 (QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 16 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2138 (Thermistor)

Exhaust Gas Temperature Cylinder 16 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2138 PID: SPN: 1152 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 16 - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 16

Circuit Description

The exhaust gas temperature sensor circuit cylinder 16 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit - cylinder 16 is located in the engine harness and extends between the number 16 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 16 measures the exhaust gas temperature of cylinder 16. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • High intake air temperature
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code t05-2138 (Thermistor)

Last Modified: 16-Sep-2010


Engine Oil Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: SPN: 175 FMI: 0 LAMP: Red SRT: | Engine Oil Temperature - Data Valid but Above Normal Operating Range - Most Severe Level. Engine oil temperature 1 sensor indicates the engine oil temperature is above the engine protection limit. | No engine protection for engine oil temperature.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Engine Oil Temperature 1 Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Oil Temperature 1 Sensor Circuit
QSK50 CM2150 Power Generation - Engine Oil Temperature 1 Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring- Engine Oil Temperature 1 Sensor Circuit
QSK50 and QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig- Engine Oil Temperature 1 Sensor Circuit
QSK50 CM2150 Marine - Engine Oil Temperature 1 Sensor Circuit
QSK60 CM2150 Power Generation - Engine Oil Temperature 1 Sensor Circuit

Circuit Description

The engine oil temperature 1 sensor is used by the electronic control module (ECM) to monitor the engine oil temperature. The ECM monitors the voltage on the engine oil temperature 1 SIGNAL pin and converts it to a temperature value. The engine oil temperature value is used by the ECM for the engine protection system, and for engine emissions control.

Component Location

The engine oil temperature sensor 1 is located in the oil pan adapter on the left bank.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code indicates that the engine oil temperature has exceeded the engine protection limits for high engine oil temperature. Refer to Engine Oil Temperature Above Normal troubleshooting symptom tree in the Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530, or the Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528.

Refer to Troubleshooting Fault Code 214.

Last Modified: 10-Dec-2010


Exhaust Gas Temperature Cylinder 16 - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 2144

Exhaust Gas Temperature Cylinder 16 - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2144 PID: SPN: 1152 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 16 - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 16

Circuit Description

The exhaust gas temperature sensor circuit cylinder 16 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 16 is located in the engine harness and extends between the number 1 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 16 measures the exhaust gas temperature of cylinder 16. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Fault Code 2144 indicates the exhaust gas temperature sensor in cylinder 16 has exceeded the engine protection warning limit.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2144.

Last Modified: 13-Dec-2010


Intake Manifold 2 Temperature - Abnormal Rate of Change

FAULT CODE 2157

Intake Manifold 2 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2157 PID: SPN: 1131 FMI: 10 LAMP: Red SRT: | Intake Manifold 2 Temperature - Abnormal Rate of Change | Calibration-dependent progressive power derate or engine shutdown. Power-Generation: Calibration-dependent possible engine shutdown.
QSK38 CM2150 Industrial - Intake Manifold 2 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Intake Manifold 2 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 2 Temperature Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 2 Temperature Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 2 Temperature Sensor Circuit

Circuit Description

The intake manifold 2 temperature sensor monitors intake manifold air temperature and passes information to the ECMs through the engine harness.

Component Location

The intake manifold 2 temperature sensor is located in the right bank front air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 2 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

This feature provides protection for the valves and turbocharger when a rapid increase in intake manifold temperature occurs along with a bank to bank exhaust gas temperature difference. Intake manifold 2 temperature sensor rapid rise monitors rapid rise in and change in intake manifold 2 temperature over a period of time, and then logs a fault and requests a derate or shutdown because of excessive temperature change. The bank to bank exhaust gas temperature difference acts as an enabler for the intake manifold 2 temperature sensor rapid rise feature.

Possible causes of this fault code include:

  • Restricted air flow through the air intake circuit
  • LTA cooling circuit temperature too high
  • Damaged valves
  • Undersized aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-2157

Last Modified: 16-Sep-2010


Intake Manifold 3 Temperature - Abnormal Rate of Change

FAULT CODE 2158

Intake Manifold 3 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2158 PID: SPN: 1132 FMI: 10 LAMP: Red SRT: | Intake Manifold 3 Temperature - Abnormal Rate of Change | Calibration dependent progressive power derate or engine shutdown.
QSK38 CM2150 Industrial - Intake Manifold 3 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 3 Temperature Sensor Circuit
QSK50 and QSK60 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 3 Temperature Sensor Circuit

Circuit Description

The intake manifold 3 temperature sensor monitors intake manifold air temperature and passes information to the electronic control modules (ECM)s through the engine harness.

Component Location

The intake manifold 3 temperature sensor is located in the left-bank rear air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 3 temperature sensor measures the temperature of the charge air as it passes through the intake manifold.

This feature provides protection for the valves and turbocharger when a rapid increase in intake manifold temperature occurs along with a bank to bank exhaust gas temperature difference. Intake manifold 3 temperature sensor monitors rapid rise and the change in intake manifold 3 temperature over a period of time, then logs a fault and requests a derate or shutdown because of excessive temperature change. The bank-to-bank exhaust gas temperature difference acts as an enable for the intake manifold 3 temperature sensor rapid rise feature.

Possible causes of this fault code include:

  • Restricted air flow through the air intake circuit.
  • LTA cooling circuit temperature to high.
  • Damaged valves.
  • Undersized after-cooler.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 2158.

Last Modified: 13-Apr-2010


Intake Manifold 4 Temperature - Abnormal Rate of Change

FAULT CODE 2159

Intake Manifold 4 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2159 PID: SPN: 1133 FMI: 10 LAMP: Red SRT: | Intake Manifold 4 Temperature - Abnormal Rate of Change | Calibration-dependent progressive power derate or engine shutdown.
QSK38 CM2150 Industrial - Intake Manifold 4 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 4 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 4 Temperature Sensor Circuit
QSK60 CM2150 Industrial - Intake Manifold 4 Temperature Sensor Circuit

Circuit Description

The intake manifold 4 temperature sensor monitors intake manifold air temperature and passes information to the electronic control modules (ECM)s through the engine harness.

Component Location

The intake manifold 4 temperature sensor is located in the right bank rear air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 4 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

This feature provides protection for the valves and turbocharger when a rapid increase in intake manifold temperature occurs along with a bank-to-bank exhaust gas temperature difference. Intake manifold 4 temperature sensor monitors rapid rise and change in intake manifold 4 temperature over a period of time, then logs a fault and requests a derate or shutdown because of excessive temperature change. The bank-to-bank exhaust gas temperature difference acts as an enabler for the intake manifold 4 temperature sensor rapid rise feature.

Possible causes of this fault code include:

  • Restricted air flow through the air intake circuit
  • LTA cooling circuit temperature to high
  • Malfunctioning valves
  • Undersized aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-2159

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 2185
Fault Code Path Selection

Is the engine an Industrial application? | Go to 122-fc2185ind
Is the engine a Power-Generation application? | Go to 122-fc2185pg

Last Modified: 26-Feb-2010


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185 (Industrial)

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor SUPPLY 4 circuit to the accelerator pedal or lever position sensor. | Loss of some accelerator pedal or lever position sensor functionality.
QSK38 CM2150 Industrial - Sensor Supply 4 Circuit
QSK50 CM2150 Industrial - Sensor Supply 4 Circuit
QSK60 CM2150 Industrial - Sensor Supply 4 Circuit

Circuit Description

The electronic control module (ECM) supplies the accelerator pedal or lever position sensor with 5-VDC.

Component Location

The accelerator pedal or lever position assembly is located in the cab.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is logged when the ECM senses more than 5.25-VDC on the sensor SUPPLY 4 for the accelerator pedal or lever position wire. This can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Refer to Troubleshooting Fault Code 2185 (Industrial).

Last Modified: 14-May-2010


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185 (Power Generation)

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply 4 circuit to the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer. | Loss of some sensor functionality.
QSK38 CM2150 Power Generation - Sensor Supply 4 Circuit
QSK38 CM2150 Power Generation (Military Application) - Sensor Supply 4 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Sensor Supply 4 Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Sensor Supply 4 Circuit
QSK60 CM2150 Power Generation - Sensor Supply 4 Circuit

Circuit Description

The electronic control module (ECM) supplies the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer with 5-VDC.

Component Location

Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service manual to determine which ECM and circuit is affected.

This fault code is logged when the ECM senses greater than 5.25-VDC on the sensor SUPPLY 4 wire for the generator output frequency adjust potentiometer, and droop adjust potentiometer. This can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Refer to Troubleshooting Fault Code 2185 (Power Generation).

Last Modified: 21-Sep-2010


Fault Code Path Selection

FAULT CODE 2186
Fault Code Path Selection

Is the engine an Industrial application? | Go to 122-fc2186ind
Is the engine a Power-Generation application? | Go to 122-fc2186pg

Last Modified: 26-Feb-2010


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186 (Industrial)

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 4 circuit. | Loss of some sensor functionality.
QSK38 CM2150 Industrial - Sensor Supply 4 Circuit
QSK50 CM2150 Industrial - Sensor Supply 4 Circuit
QSK60 CM2150 Industrial - Sensor Supply 4 Circuit

Circuit Description

The sensor supply number 4 circuit of the elctronic control module (ECM) provides 5 volts for the accelerator pedal or lever position sensor. If the sensor supply 4 circuit to the accelerator is damaged, the accelerator will not work properly.

Component Location

The sensor supply 4 is located in the ECM.

Refer to the original equipment manufacturer (OEM) service manual for a detailed component location view of the accelerator pedal or lever position sensor.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in a supply wire
  • A short circuit between a supply wire or a return wire
  • A damaged accelerator
  • A damaged ECM power supply.
Refer to Troubleshooting Fault Code 2186 (Industrial).

Last Modified: 28-Apr-2010


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186 (Power Generation)

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 4 circuit. | Loss of some sensor functionality.
QSK38 CM2150 Power Generation - Sensor Supply 4 Circuit
QSK38 CM2150 Power Generation (Military Application) - Sensor Suply 4 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Sensor Supply 4 Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Sensor Supply 4 Circuit
QSK60 CM2150 Power Generation - Sensor Supply 4 Circuit

Circuit Description

The sensor supply 4 circuit of the electronic control module (ECM) provides 5 volts for the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer. If the SUPPLY circuit to the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer is damaged, the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer will not work properly.

Component Location

The sensor supply 4 is located in the ECM 3.

Refer to the OEM service manual for a detailed component location view of the gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Short circuit to ground in a SUPPLY wire
  • Short circuit between a SUPPLY wire or a RETURN wire
  • Malfunctioning gain adjust potentiometer
  • Malfunctioning generator output frequency adjust potentiometer
  • Malfunctioning droop adjust potentiometer
  • Malfunctioning ECM power supply.
Refer to Troubleshooting Fault Code 2186 (Power Generation).

Last Modified: 21-Sep-2010


Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

FAULT CODE 2195

Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2195 PID: SPN: 703 FMI: 14 LAMP: Red SRT: | Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions. The air shutoff valve (ASOV) indicator switch or pin O of the 23 pin connector indicates engine protection feature. | Engine shuts down if engine protection shutdown feature is enabled.
QSK60 CM2150 Drill Rig - Air Shutoff Valve (ASOV) and E-stop Circuit

Circuit Description

The circuit shown in the above figure consists of four ASOV switches and the E-stop signal connected in parallel to each other.

Component Location

The E-Stop button is located on the door of the customer interface box (CIB) panel.

Shop Talk

Each intake manifold requires an air shutoff valve. The dual output air shutoff feature uses a single driver to actuate the air shutoff valves via an electric relay.

The air shutoff uses the OEM switch input for the emergency air shutoff stop. A switch closure from either the operator's E-stop or engine overspeed will cause the dual output B to activate, thereby triggering the air shutoff. Causes of this fault code are:

  • Operator pushes engine stop button.
  • Any of the four plunger switches close.
  • Overspeed shutdown event as commanded by ECM.
  • Short circuit in the wiring harness.
Refer to Troubleshooting Fault Code 2195.

Last Modified: 28-Apr-2010


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the barometric pressure sensor circuit. | Power derate can occur depending on application and calibration.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine/QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Barometric Pressure Sensor Circuit
QSK50 and QSK60 CM2150 Industrial/QSK50 CM2150 Marine/QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation/QSK60 CM2150 Drill Rig - Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor is used by the electronic control module (ECM) to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the left side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 221.

Last Modified: 16-Sep-2010


Fuel Pump Delivery Pressure - Data Valid but Below Operating Range - Moderately Severe Level

FAULT CODE 2215

Fuel Pump Delivery Pressure - Data Valid but Below Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2215 PID: SPN: 94 FMI: 18 LAMP: Amber SRT: | Fuel Pump Delivery Pressure - Data Valid but Below Operating Range - Moderately Severe Level. Fuel pump supply pressure low. | Low power.
QSK38 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring and QSK60 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the electronic control module (ECM) to monitor fuel supply pressure directly before the second stage filter. The ECM monitors the voltage on the fuel delivery pressure signal pin and converts it to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the second stage fuel filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Stage 1 fuel filter restriction high
  • Fuel inlet restriction high
  • Low fuel flow from gerotor
  • Stuck mechanical dump valve in gerotor housing
  • Stuck low-pressure regulator in high-pressure fuel pump
  • Air in fuel.
Refer to Troubleshooting Fault Code 2215.

Last Modified: 13-Dec-2010


Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2216

Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2216 PID: SPN: 94 FMI: 16 LAMP: Amber SRT: | Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. Fuel pump supply pressure very high. | Low power or engine smoke.
QSK38 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 Power Generation (Military Application) - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring and QSK60 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the engine control module (ECM) to monitor fuel delivery pressure directly before the Stage 2 filter. The ECM monitors the voltage on the fuel delivery pressure SIGNAL pin and converts it to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the Stage 2 fuel filter head.

Conditions for Running the Diagnostics

  • The engine speed must be above 500 RPM for 10 seconds, and fueling must be above 20 mg/stk for 5 seconds before a diagnostic decision begins to be made.
  • The fuel temperature must be greater than, or equal to -10 ⁰C

Conditions for Setting the Fault Codes

When the fuel supply pressure is greater than 1100 kPa (160 psi) for more than 3 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostics detects high fuel supply pressure.

Conditions for Clearing the Fault Code

FC2216 is a latching fault code. The diagnostic only clears errors if the fuel supply pressure is below 850 kPa. Once the fault code is invoked, the only way to clear it would be to perform the following steps:

  • Turn off engine and follow the troubleshooting steps for resolution.
  • Restart engine, and run the engine at rated for a few minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Stage 2 fuel filter restriction high
  • Pinched or damaged fuel supply line
  • Stuck gerotor pump fuel pressure regulator located in high-pressure pump.
Refer to Troubleshooting Fault Code t05-2216.

Last Modified: 30-May-2017


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the barometric pressure circuit. | Power derate can occur depending on application and calibration.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine/QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Barometric Pressure Sensor Circuit
QSK50 and QSK60 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine/QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation/QSK60 CM2150 Drill Rig - Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor is used by the electronic control module (ECM) to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the left side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 222.

Last Modified: 16-Sep-2010


Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 223

Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 223 PID: SPN: 1265 FMI: 4 LAMP: Amber SRT: | Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source. The engine oil burn valve solenoid driver circuit is shorted. Low voltage detected at the engine oil burn valve solenoid driver supply pin of the ECM engine harness connector or resistance of the solenoid is outside the range of 15 to 22 ohms (12-VDC) or 64.5 to 94.7 ohms (24-VDC). | The ECM turns OFF the engine oil burn valve solenoid driver supply voltage and the system is disabled.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine/QSK38 CM2150 Power Generation - Engine Oil Burn Valve Solenoid Driver Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 Power Generation/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Oil Burn Valve Solenoid Driver Circuit
QSK60 CM2150 Industrial - Engine Oil Burn Valve Solenoid Driver Circuit

Circuit Description

The engine oil burn valve solenoid driver controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The engine oil burn valve is usually located on the rear left bank of the engine.

Shop Talk

There are multiple electronic control modules (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Damaged engine oil burn valve solenoid driver
  • Short circuit to ground on the output device driver wire
  • Short circuit from pin-to-pin in the output device driver wire.
Refer to Troubleshooting Fault Code 223.

Last Modified: 16-Sep-2010


Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 224

Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 224 PID: SPN: 1265 FMI: 3 LAMP: Amber SRT: | Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source. High voltage has been detected at the engine oil burn valve solenoid driver pin in the engine harness ECM connector or resistance of the solenoid is outside the range of 15 to 22 ohms (12-VDC) or 64.5 to 94.7 ohms (24-VDC). | The ECM turns OFF the engine oil burn valve solenoid driver supply voltage and the system is disabled.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine/QSK38 CM2150 Power Generation - Engine Oil Burn Valve Solenoid Driver Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation/QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Oil Burn Valve Solenoid Driver Circuit
QSK60 CM2150 Industrial - Engine Oil Burn Valve Solenoid Driver Circuit

Circuit Description

The engine oil burn valve solenoid driver controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The engine oil burn valve is usually located on the rear left bank of the engine.

Shop Talk

Some Marine engines are equipped with Centinel™. If a Marine engine is not equipped with Centinel™, it will have a sensor plugged into the engine oil burn valve solenoid driver connector of the engine harness. If this resistor is damaged, it will cause this fault to go active. There are multiple electronic control modules (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Malfunctioning engine oil burn valve solenoid driver
  • Open circuit in the output device driver return wire
  • Pin-to-pin short in the output device driver wire
  • Damaged 230 ohm resistor (Marine applications without Centinel™ only)
Refer to Troubleshooting Fault Code 224.

Last Modified: 15-Sep-2010


Fuel Pump Delivery Pressure - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2261

Fuel Pump Delivery Pressure - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2261 PID: SPN: 94 FMI: 15 LAMP: Maintenance SRT: | Fuel Pump Delivery Pressure - Data Valid but Above Normal Operating Range - Least Severe Level. Fuel pump supply pressure high. | Low power or engine smoke.
QSK38 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 Power Generation (Military Application) - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring and QSK60 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the electronic control module (ECM) to monitor fuel delivery pressure directly before the second stage filter. The ECM monitors the voltage on the fuel delivery pressure signal pin and converts it to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the second stage fuel filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Stage 2 fuel filter restriction high
  • Pinched or damaged fuel supply line
  • Stuck rotor pump fuel pressure regulator located in high-pressure pump.
Refer to Troubleshooting Fault Code 2261.

Last Modified: 13-Dec-2010


Fuel Pump Delivery Pressure - Data Valid but Below Operating Range - Least Severe Level

FAULT CODE 2262

Fuel Pump Delivery Pressure - Data Valid but Below Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2262 PID: SPN: 94 FMI: 17 LAMP: Maintenance SRT: | Fuel Pump Delivery Pressure - Data Valid but Below Operating Range - Least Severe Level. Fuel pump supply pressure low. | Low power.
QSK38 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 Power Generation (Military Application) - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring and QSK60 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the electronic control module (ECM) to monitor fuel supply pressure directly before the second stage filter. The ECM monitors the voltage on the signal pin and converts it to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the second stage fuel filter head.

Shop Talk

There are multiple electronic control modules (ECMs) for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Stage 1 fuel filter restriction high
  • Fuel inlet restriction high
  • Low fuel flow from gerotor
  • Stuck mechanical dump valve in gerotor housing
  • Stuck low-pressure regulator in high-pressure fuel pump
  • Air in fuel.
Refer to Troubleshooting Fault Code 2262.

Last Modified: 13-Dec-2010


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: SPN: 1075 FMI: 3 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel SUPPLY Circuit - Voltage Above Normal or Shorted to High Source. High voltage or open detected at the electric lift pump for engine fuel supply SIGNAL circuit. | Engine can be difficult to start.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Electric Lift Pump for Engine Fuel SUPPLY Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Electric Lift Pump for Engine Fuel SUPPLY Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Electric Lift Pump for Engine Fuel SUPPLY Circuit
QSK50 CM2150 Industrial - Electric Lift Pump for Engine Fuel SUPPLY Circuit
QSK60 CM2150 Industrial - Electric Lift Pump for Engine Fuel SUPPLY Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Electric Lift Pump for Engine Fuel SUPPLY Circuit

Circuit Description

The circuit is a pulse width modulated driver in the electronic control module (ECM) that controls the electric lift pump for engine fuel supply. The electric lift pump for engine fuel supply is grounded in the ECM and runs at 100-percent duty cycle for approximately 30 seconds following key-ON.

Component Location

The electric lift pump for engine fuel supply is located on the first stage fuel filter head bracket. The bracket is mounted off-engine. Refer to the OEM troubleshooting and repair manual for mounting location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault becomes active if the ECM detects an open circuit at key-on.

If the fault code is intermittent, look for the cause of an intermittent open circuit, such as loose pins and/or bad connections. At key ON, the electric lift pump for engine fuel supply duty cycle ramps to 100-percent. This fault code can detect open circuit conditions only at key ON. The electric lift pump for engine fuel supply only runs at key ON and during cranking to aid in priming of the gear pump.

When this fault condition is detected, the ECM driver to the electric lift pump for engine fuel supply is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will retest for the cause of the fault code. The ECM driver is re-enabled at key ON, and if the cause is no longer present, the fault code will become inactive and can be cleared.

During cold weather, gelled fuel can plug the electric lift pump for engine fuel supply and cause this fault code.

Listen to the electric lift pump for engine fuel supply to make sure it is running during cold ambient temperatures (less than -29°C [-20°F]).

NOTE: This fault code will also become active if the electric lift pump for engine fuel supply motor stalls. Stall current for the electric lift pump for engine fuel supply motor is approximately 9 amperes. A good electric lift pump for engine fuel supply typically runs with less than 3 amperes. If the fault code is intermittent, observe the snapshot data electric lift pump for engine fuel supply measured current. If current was near 9 amperes when the fault condition occurred, conclude that the rotor has stalled and replace the electric lift pump for engine fuel supply.

Refer to Troubleshooting Fault Code 2265.

Last Modified: 27-Sep-2010


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: SPN: 1075 FMI: 4 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the electric lift pump for engine fuel supply circuit. | Engine can be difficult to start.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Electric Lift Pump for Engine Fuel Supply Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Electric Lift Pump for Engine Fuel Supply Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Electric Lift Pump for Engine Fuel Supply Circuit
QSK50 CM2150 Industrial - Electric Lift Pump for Engine Fuel Supply Circuit
QSK60 CM2150 Industrial - Electric Lift Pump for Engine Fuel Supply Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Electric Lift Pump for Engine Fuel Supply Circuit

Circuit Description

The circuit is a pulse width modulated driver in the electronic control module (ECM) that controls the electric lift pump for engine fuel supply. The electric lift pump for engine fuel supply is grounded in the ECM and runs at 100-percent duty cycle for approximately 30 seconds following key ON.

Component Location

The electric lift pump for engine fuel supply is located on the first stage fuel filter head bracket. The bracket is mounted off-engine. Refer to the original equipment manufactured (OEM) service manual for mounting location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code becomes active whenever the ECM detects a short circuit to ground or high current in the electric lift pump for engine fuel supply circuit.

When this fault condition is detected, the ECM driver to the electric lift pump for engine fuel supply is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF, then back ON before the ECM will retest for the cause of the fault code. The ECM driver is re-enabled at key ON, and if the cause is no longer present, the fault code will become inactive and can be cleared.

During cold weather, gelled fuel can plug the electric lift pump for engine fuel supply and cause this fault code.

Listen to the electric lift pump for engine fuel supply to make sure it is running during cold ambient temperatures (less than -29°C [-20°F]).

NOTE: This fault code will also become active if the electric lift pump for engine fuel supply motor stalls. Stall current for the electric lift pump for engine fuel supply motor is approximately 9 amperes. A good electric lift pump for engine fuel supply typically runs with less than 3 amperes. If the fault code is intermittent, observe the snapshot data electric lift pump for engine fuel supply measured current. If current was near 9 amperes when the fault condition occurred, conclude that the rotor has stalled and replace the electric lift pump for engine fuel supply.

Possible causes for this fault code include:

  • Short circuit to ground
  • Low resistance (electric lift pump for engine fuel supply partially shorted).
Refer to Troubleshooting Fault Code 2266.

Last Modified: 27-Sep-2010


Fault Code Path Selection

FAULT CODE 227
Fault Code Path Selection

Is the ECM source address 00? | Go to 122-fc227sa00
Is the ECM source address 01? | Go to 122-fc227sa01

Last Modified: 02-Mar-2010


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227 (Source Address 00)

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply 2 circuit. | Loss of some sensor functionality.
QSK38 CM2150 Industrial - Sensor Supply 2 Circuit
QSK38 CM2150 Power Generation - Sensor Supply 2 Circuit
QSK38 CM2150 Marine - Sensor Supply 2 Circuit
QSK50 and QSK60 CM2150 Industrial - Sensor Supply 2 Circuit
QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Sensor Supply 2 Circuit
QSK50 CM2150 Marine - Sensor Supply 2 Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the electronic control module (ECM) provides 5 volt supply for the engine camshaft speed/position sensor, intake manifold 1 pressure sensor, fuel delivery pressure sensor, barometric pressure sensor, and injector metering rail 1 pressure sensor.

Component Location

Sensor supply voltage 2 is located inside the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

High voltage on the sensor supply 2 wire can be caused by a signal shorted to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 227 (Source Address 00).

Last Modified: 16-Sep-2010


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227 (Source Address 01)

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply 2 circuit. | Loss of some sensor functionality.
QSK38 CM2150 Marine - Sensor Supply 2 Circuit
QSK50 CM2150 Marine - Sensor Supply 2 Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Sensor Supply 2 Circuit

Circuit Description

The QSK50 engine sensor supply circuit supplies 5 volts to the pre-oil filter pressure sensor and the intake manifold 2 pressure sensor. The QSK60 engine sensor supply circuit supplies 5 volts to the pre-oil filter pressure sensor, intake manifold 2 pressure sensor, and the post-oil filter pressure sensor.

The QSK38 engine sensor supply 2 circuit supplies 5 volts to the pre-oil filter pressure sensor (left bank option) and pre-oil filter pressure sensor (right bank option).

Component Location

Sensor supply 2 is located inside the electronic control module (ECM).

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

High voltage on the 5 volt supply wire can be caused by a signal shorted to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 227 (Source Address 01).

Last Modified: 16-Jul-2010


Coolant Pressure - Data Valid but Below Normal Operating Range - Most Severe Level

FAULT CODE 228

Coolant Pressure - Data Valid but Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 228 PID: SPN: 109 FMI: 1 LAMP: Red SRT: | Coolant Pressure - Data Valid but Below Normal Operating Range - Most Severe Level. Coolant pressure signal indicates coolant pressure is below the engine protection critical limit. | Calibration - dependent progressive power, speed derate, and engine shutdown with increasing time after alert.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Coolant Pressure Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application)
QSK50 CM2150 Industrial - Coolant Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Coolant Pressure Sensor Circuit
QSK50 CM2150 Power Generation/QSK60 CM2150 Power Generation
QSK50 CM2150 Marine - Coolant Pressure Sensor Circuit
QSK60 CM2150 Industrial - Coolant Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the electronic control module (ECM) to monitor the coolant pressure. If the coolant pressure drops below the engine protection limit, Fault Code 228 will log.

Component Location

The coolant pressure sensor is located on the water pump connection to the engine block.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Low coolant pressure.
Refer to Troubleshooting Fault Code 228.

Last Modified: 10-Dec-2010


Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 231

Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 231 PID: SPN: 109 FMI: 3 LAMP: Amber SRT: | Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the coolant pressure sensor circuit. | None on performance. No engine protection for coolant pressure.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Coolant Pressure Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Coolant Pressure Sensor Circuit
QSK50 CM2150 Industrial - Coolant Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Coolant Pressure Sensor Circuit
QSK50 CM2150 Power Generation/QSK60 CM2150 Power Generation - Coolant Pressure Sensor Circuit
QSK50 CM2150 Marine - Coolant Pressure Sensor Circuit
QSK60 CM2150 Industrial - Coolant Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the electronic control module (ECM) to monitor the coolant pressure. The ECM monitors the voltage on the coolant pressure SIGNAL pin and converts it to a pressure value.

Component Location

The coolant pressure sensor is located on the water pump connection to the engine block.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The coolant pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 231, check for multiple faults.

Possible causes of this fault code include:

  • Open RETURN circuit in the harness, connectors, or sensor
  • SIGNAL circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 231.

Last Modified: 16-Sep-2010


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. Fuel pump pressurizing assembly 1 circuit resistance too high or too low. | Possible low power.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Fuel Pump Pressurizing Assembly 1 Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Fuel Pump Pressurizing Assembly 1 Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Fuel Pump Pressurizing Assembly 1 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/ QSK60 CM2150 Power Generation - Fuel Pump Pressurizing Assembly 1 Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Fuel Pump Pressurizing Assembly 1 Circuit

Circuit Description

The circuit is a pulse-width-modulated (PWM) driver in the electronic control module (ECM) that controls the fuel pump pressurizing assembly 1. The fuel pump pressurizing assembly 1 is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the high-pressure pump based on engine operating conditions. The fuel pump pressurizing assembly 1 valve is a normally open valve. High circuit resistance can cause fuel pressure to be higher than commanded at light loads and Fault Code 1911 can be logged.

Component Location

The fuel pump pressurizing assembly 1 valve is located on the engine mounted fuel pump housing.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If this fault code occurs during a test, verify that all connectors are clean and free of corrosion before replacing components.

Possible causes for this fault code include:

  • Fuel pump pressurizing assembly 1 high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Fuel pump pressurizing assembly 1 with low internal resistance
  • Fuel pump pressurizing assembly 1 or engine harness has shorted to ground
  • Intermittent circuit problems that cause the fuel pressure to exceed the mechanical dump valve opening pressure.

If an intermittent electrical circuit problem of the fuel pump pressurizing assembly 1 circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is malfunctioning causing the mechanical dump valve to open. Following the event that caused the mechanical dump valve to open, the ECM will attempt to reset the mechanical dump valve, provided the mechanical dump valve circuit is not still damaged.

Following any event that opens the mechanical dump valve, the mechanical dump valve will regulate the fuel pressure at approximately 900 bar [13,053 psi]. If the ECM is still capable of controlling fuel pressure, the following will occur:

  • The measured fuel pressure will reduce to 600 bar [8702 psi] as the ECM prepares to seat the mechanical dump valve.
  • Once pressure is 600 bar [8702 psi] and engine speed is greater than 1200 rpm, the ECM will momentarily close the mechanical dump valve. This action will reduce the injector metering rail 1 pressure (to less than 20 bar [290 psi] for a fraction of a second) so that the mechanical dump valve will reset. At light engine loads, especially if the engine is accelerated while the driveline is not engaged, engine power interruption will be noticeable while the ECM attempts to reset the mechanical dump valve.
  • Once the ECM detects that the mechanical dump valve is reset, normal engine operation will resume and Fault Code 2311 will become inactive.
Refer to Troubleshooting Fault Code 2311.

Last Modified: 23-Sep-2010


Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 232

Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 232 PID: SPN: 109 FMI: 4/4 LAMP: Amber SRT: | Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the coolant pressure sensor circuit. | None on performance. No engine protection for coolant pressure.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Coolant Pressure Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Coolant Pressure Sensor Circuit
QSK50 CM2150 Industrial - Coolant Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Coolant Pressure Sensor Circuit
QSK50 CM2150 Power Generation/QSK60 CM2150 Power Generation - Coolant Pressure Sensor Circuit
QSK50 CM2150 Marine - Coolant Pressure Sensor Circuit
QSK60 CM2150 Industrial - Coolant Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the electronic control module (ECM) to monitor the coolant pressure. The ECM monitors the voltage on the coolant pressure SIGNAL pin and converts it to a pressure value.

Component Location

The coolant pressure sensor is located on the water pump connection to the engine block.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The coolant pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 232, check for multiple faults.

Possible causes of this fault include:

  • SIGNAL circuit open or shorted to ground in the engine harness or sensor
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code 232.

Last Modified: 16-Sep-2010


Engine Crankshaft Speed/Position - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: SPN: FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid but Above Normal Operating Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Fuel injection disabled until engine speed falls below the overspeed limit.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine/QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Crankshaft Speed/Position Sensor
QSK50 CM2150 Industrial - Crankshaft Speed/Position Circuit
QSK50 CM2150 Power Generation/QSK50 CM2150 Marine/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Crankshaft Speed/Position Sensor
QSK60 CM2150 Industrial - Crankshaft Speed/Position Circuit
QSK60 CM2150 Power Generation - Crankshaft Speed/Position Circuit
QSK60 CM2150 Marine - Crankshaft Speed/Position Circuit

Circuit Description

The engine crankshaft speed/position sensor and engine camshaft speed/position sensor provide engine speed and position information to the electronic control module (ECM) through the engine harness.

Component Location

The QSK60 engine crankshaft speed/position sensor is located in the cylinder block at the top right of the flywheel housing. The QSK38 and QSK50 engine crankshaft speed/position sensor is located in the cylinder block at the top left of the flywheel housing. The QSK38, QSK50 and QSK60 engine camshaft speed/position sensor is located in the cylinder block at the top left of the gear housing.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine crankshaft speed/position sensor and the engine camshaft speed/position sensor.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed/position sensor and the engine camshaft speed/position sensor for damage or tampering.

When Fault Code 234 is active, Fault Code 1992 is activated as well for moderate overspeed conditions.

Refer to Troubleshooting Fault Code 234.

Last Modified: 10-Dec-2010


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: SPN: 111 FMI: 1 LAMP: Red SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level. Low engine coolant level detected. | Calibration-dependent progressive derate and possible engine shutdown with increasing time after alert. Marine: No effect. No engine protection for sensor or circuit fault.
QSK38 and QSK50 CM2150 Industrial - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Power Generation - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Power Generation (Military Application) - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command™ and Marine Auxiliary with C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ and Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Coolant Level Sensor 1 Circuit
QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Coolant Level Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ and Marine Auxiliary with C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ and Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System/QSK60 CM2150 Drill Rig - Coolant Level Sensor 1 Circuit

Circuit Description

The coolant level sensor 1 monitors the engine coolant level within the coolant system and passes information to the ECM through the original equipment manufacturer (OEM) harness and the engine harness.

Component Location

The coolant level sensor 1 is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for a detailed component location view.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the coolant level sensor 1 level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-235.

Last Modified: 01-Apr-2011


External Speed Command Input (Multiple Unit Synchronization) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 237

External Speed Command Input (Multiple Unit Synchronization) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 237 PID: SPN: 644 FMI: 2 LAMP: Amber SRT: | External Speed Command Input (Multiple-Unit Synchronization) - Data Erratic, Intermittent, or Incorrect. The throttle signal pin duty cycle input of the engine harness is less than 3 percent or more than 97 percent. | The primary and secondary engines are shut down with increasing time after alert if hard-coupled. Only the secondary engine(s) are shut down with increasing time after alert, if soft-coupled.
QSK38 CM2150 Marine Propulsion with C Command™ Panel System - External Speed Command Input
QSK38 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - External Speed Command Input
QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - External Speed Command Input
QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ Panel System - External Speed Command Input

Circuit Description

The primary engine outputs a throttle duty cycle signal on the original equipment manufacturer (OEM) actuator pulse width modulated (PWM) output supply pin. This signal is received by the secondary engine(s) and is used as the throttle input. To complete this circuit, a 5 volt supply is provided by the OEM and connected to the intermediate speed control/validate switch pin of the secondary engine(s).

Component Location

The PWM output supply is located in the engine harness connector.

Shop Talk

The secondary engine(s) expect to see a duty cycle signal that varies between 3 and 97 percent. A signal less than 3 percent or greater than 97 percent will generate Fault Code 237 in the secondary engine(s).

Refer to Troubleshooting Fault Code 237.

Last Modified: 28-Apr-2010


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: SPN: 647 FMI: 3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
QSK38 CM2150 Industrial - Fan Control Circuit
QSK38 CM2150 Marine Propulsion with C Command™ - Fan Control Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ - Fan Control Circuit
QSK50 CM2150 Industrial - Fan Control Circuit
QSK60 CM2150 Industrial - Fan Control Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ - Fan Control Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ - Fan Control Circuit

Circuit Description

The electronic control module (ECM) provides a signal to the fan control to turn the engine fan ON and OFF. There are two types of fans supported by this signal, variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by OEM. Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to engine block or chassis ground.

Component Location

The fan control location varies by OEM. Refer to the OEM service manual to determine the location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The ECM monitors the voltage level on this circuit. When the ECM commands the fan signal low, it expects the voltage level to be approximately 0 volts. If it detects a high voltage, this fault is recorded.

If Fault Code 2377 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control for an open circuit or short circuit to ground.

Possible causes of this fault include:

  • Open circuit in the engine harness or fan control
  • Short circuit to voltage source in the OEM harness
  • Damaged ECM.
Refer to Troubleshooting Fault Code 2377.

Last Modified: 23-Apr-2010


Fault Code Path Selection

FAULT CODE 238
Fault Code Path Selection

Is the ECM source address 00? | Go to 122-fc238sa00
Is the ECM source address 01? | Go to 122-fc238sa01

Last Modified: 03-Mar-2010


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238 (Source Address 00)

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: SPN: 3511 FMI: 4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 3 circuit. | Loss of some sensor functionality. Possible hard starting and rough running.
QSK38 CM2150 Industrial/QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application)/QSK38 CM2150 Marine - Sensor Supply 3 Circuit
QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/ QSK50 CM2150 Marine - Sensor Supply 3 Circuit
QSK50 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Sensor Supply 3 Circuit
QSK60 CM2150 Industrial - Sensor Supply 3 Circuit
QSK60 CM2150 Power Generation - Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 pin of the electronic control module (ECM) provides 5-VDC for the engine crankshaft speed/position sensor.

Component Location

The sensor supply 3 is located in ECM 3.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Short circuit to ground in a SUPPLY wire
  • Short between a SUPPLY wire or RETURN wire
  • Damaged engine crankshaft speed/position sensor
  • Damaged ECM power supply.
Refer to Troubleshooting Fault Code 238 (Source Address 00).

Last Modified: 16-Sep-2010


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238 (Source Address 01)

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: SPN: 3511 FMI: 4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 3 circuit. | Loss of some sensor functionality.
QSK38 CM2150 Industrial - Sensor Supply 3 Circuit
QSK38 CM2150 Marine - Sensor Supply 3 Circuit
QSK50 CM2150 Marine - Sensor Supply 3 Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Sensor Supply 3 Circuit

Circuit Description

Sensor supply 3 voltage from the electronic control module (ECM) 2 provides a 5 volt supply to the exhaust gas temperature sensor converter located on the rear right side of the engine.

Component Location

The sensor supply number 3 is located in the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in the INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Short to ground in a supply wire
  • Short circuit between a supply wire and a return wire
  • Damaged exhaust gas temperature sensor converter
  • Damaged ECM power supply.
Refer to Troubleshooting Fault Code 238 (Source Address 01).

Last Modified: 16-Jul-2010


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can possibly stay on continuously or not run at all.
QSK38 CM2150 Industrial - Fan Control Circuit
QSK38 CM2150 Power Generation (Military Application) - Fan Control Circuit
QSK50 CM2150 Industrial - Fan Control Circuit
QSK60 CM2150 Industrial - Fan Control Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Fan Control Circuit

Circuit Description

The electronic control module (ECM) provides a signal to the fan control to turn the engine fan ON and OFF. There are two types of fans supported by this signal; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by OEM. Certain OEMs can use a solenoid return that is wired to the ECM, or they can use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the OEM service manual to determine the location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The fan control logic can be adjusted with INSITE™ electronic service tool. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the fan control SIGNAL circuit usually indicates a short circuit to ground in the harness or fan control.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Refer to Troubleshooting Fault Code 245.

Last Modified: 16-Sep-2010


Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2474

Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2474 PID: SPN: 103 FMI: 2 LAMP: Maintenance SRT: | Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect | No effect on performance. At high altitude the engine will go to default derate value.
QSK38 CM2150 Industrial - Turbocharger 1 Speed Sensor Circuit
QSK50 CM2150 Industrial - Turbocharger 1 Speed Sensor Circuit
QSK60 CM2150 Industrial - Turbocharger 1 Speed Sensor Circuit

Circuit Description

The turbocharger 1 speed sensor monitors the turbocharger speed and passes the information to the electronic control module (ECM). The ECM compares this input to a calculated value based on the intake manifold pressure, barometric pressure, and engine speed. This fault becomes active when the calculated value does not coincide with the turbocharger 1 speed signal.

Component Location

The turbocharger 1 speed sensor is located on the turbocharger on the QSK38 engine. The turbocharger 1 speed sensor is located on the left-bank high-pressure turbocharger on the QSK50 two-stage. On the QSK60 single-stage the turbocharger 1 speed sensor is located on the left rear turbocharger. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes for this fault code include:

  • Open or short circuit on the turbocharger 1 speed signal
  • Open turbocharger 1 speed return
  • Damaged turbocharger 1 speed sensor.
Refer to Troubleshooting Fault Code 2474.

Last Modified: 10-Mar-2015


Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2557

Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2557 PID: SPN: 697 FMI: 3 LAMP: Amber SRT: | Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the pulse width modulated (PWM) OEM device. | Can not control PWM actuated OEM device.
QSK38 CM2150 Industrial - PWM Driver 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command™ Panel System - PWM Driver 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - PWM Driver 1 Circuit
QSK50 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ Panel System - PWM Driver 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - PWM Driver 1 Circuit
QSK60 Industrial - Auxiliary PWM Driver 1 Circuit

Circuit Description

A pulse width modulated original equipment manufacturer (OEM) device uses this signal from the electronic control module (ECM)3 on the QSK50 and QSK60 engines, and the ECM2 on the QSK38 engine. The return circuit uses the accelerator pedal or lever idle validation switch return.

Component Location

Refer to the OEM service manual for the location of the pulse width modulated OEM device.

Shop Talk

This fault can be caused by the following:

  • A damaged pulse width modulated OEM device
  • An open circuit in the output device driver return line
  • A pin-to-pin short in the output device driver line.
Refer to Troubleshooting Fault Code 2557.

Last Modified: 11-May-2010


Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2558

Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2558 PID: SPN: 697 FMI: 4 LAMP: Amber SRT: | Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the pulse width modulated (PWM) OEM device. | Can not control PWM actuated OEM device.
QSK38 CM2150 Industrial - Auxiliary PWM Driver 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command™ Panel System - Auxiliary PWM Driver 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Auxiliary PWM Driver 1 Circuit
QSK50 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ Panel System - Auxiliary PWM Driver 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Auxiliary PWM Driver 1 Circuit
QSK60 CM2150 Industrial - Auxiliary PWM Driver 1 Circuit

Circuit Description

A pulse width modulated OEM device uses this signal from the electronic control module (ECM)3 on QSK50 and QSK60 engines, and the ECM2 on QSK38 engines. The return circuit uses the accelerator pedal or lever idle validation switch return.

Component Location

Refer to the OEM service manual for the location of the pulse width modulated OEM device.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault can be caused by the following:

  • A damaged pulse width modulated OEM device
  • A short circuit to ground on the output device driver line
  • A pin-to-pin short in the output device driver wire.
Refer to Troubleshooting Fault Code 2558.

Last Modified: 11-May-2010


Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2562

Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2562 SPN: 175 FMI: 0 LAMP: Red SRT: | Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Transmission ( or gearbox) oil temperature sensor indicates the transmission (or gearbox) oil temperature is above the protection limit. | No engine protection for transmission oil temperature.
Transmission (or Gearbox) Oil Temperature Sensor Circuit

Circuit Description

Transmission (or gearbox) oil temperature sensor is used by the engine control module (ECM) to monitor the transmission oil temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The Transmission (or gearbox) oil temperature sensor is located in the transmission.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code indicates that the transmission (or gearbox) temperature has exceeded the protection limits for high transmission (or gearbox) temperature.

Refer to Troubleshooting Fault Code 2562.

Last Modified: 12-Dec-2016


Engine Fuel Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 261

Engine Fuel Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: SPN: 174 FMI: 16 LAMP: Amber SRT: | Engine Fuel Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level. Engine fuel temperature 1 signal indicates engine fuel temperature is above engine protection warning limit. | Calibration-dependent progressive power and speed derate and engine shutdown with increasing time after alert.
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Fuel Temperature 1 Sensor Circuit
QSK38 CM2150 Marine Auxiliary - Engine Fuel Temperature 1 Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Fuel Temperature 1 Sensor Circuit
QSK60 CM2150 Power Generation - Engine Fuel Temperature 1 Sensor Circuit
QSK50 and QSK60 CM2150 Power Generation (Military Application)/QSK60 CM2150 Drill Rig - Engine Fuel Temperature 1 Sensor Circuit

Circuit Description

The engine fuel temperature 1 sensor is used by the ECM to monitor engine fuel supply temperature. The ECM monitors the voltage on the engine fuel temperature 1 signal pin and converts it to a temperature value. The engine fuel temperature 1 sensor value is used by the ECM for the engine protection system.

Component Location

The engine fuel temperature 1 sensor is located on the second-stage filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

All Temperature Sensors:

  • The resistance of the engine fuel temperature 1 sensor varies with the temperature. If the engine fuel temperature 1 sensor is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 261.

Last Modified: 16-Sep-2010


Auxiliary Equipment Sensor Input 1 Engine Protection Critical - Special Instructions

FAULT CODE 2619

Auxiliary Equipment Sensor Input 1 Engine Protection Critical - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2619 PID: SPN: 701 FMI: 31 LAMP: Amber SRT: | Auxiliary Equipment Sensor Input 1 Engine Protection Critical - Special Instructions. The air shutoff is activated from engine overspeed or operator’s E-stop. | Engine shuts down if engine protection shutdown feature is enabled.
Air Shutoff (OEM Switch/Dual Output) and E-stop Circuit

Circuit Description

The circuit uses the OEM E-stop signal or engine overspeed to activate the air shutoff.

Component Location

The E-Stop button is located on the door of the customer interface box (CIB) panel.

Shop Talk

This is for engines with one or more OEM supplied air shutoff valves.

The air shutoff uses the OEM switch input for the emergency air shutoff stop. A switch closure from either the operator's E-stop or engine overspeed will cause the air shutoff to activate. Causes of this fault code are:

  • Operator pushes engine stop button.
  • Overspeed shutdown event as commanded by the ECM.
Refer to Troubleshooting Fault Code t05-2619

Last Modified: 21-Sep-2010


Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: SPN: 174 FMI: 3 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. More than 4.95-VDC detected at the engine fuel temperature 1 signal pin of the engine harness connector. | ECM will set a default value for fuel temperature. No other action taken by ECM.
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Fuel Temperature Sensor 1 Circuit
QSK38 CM2150 Marine Auxiliary - Engine Fuel Temperature Sensor 1 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Fuel Temperature Sensor 1 Circuit
QSK60 CM2150 Power Generation - Engine Fuel Temperature Sensor 1 Circuit
QSK50 and QSK60 CM2150 Power Generation (Military Application)/QSK60 CM2150 Drill Rig - Engine Fuel Temperature Sensor 1 Circuit

Circuit Description

The engine fuel temperature sensor 1 is used by the ECM to monitor engine fuel temperature. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage on the engine fuel temperature 1 signal pin. The ECM expects the voltage to vary between 0.5-VDC to 4.95-VDC. If the voltage is above 4.95-VDC, the ECM will log Fault Code 263.

Voltage above 4.95-VDC on the engine fuel temperature 1 signal pin can be caused by an open in the engine fuel temperature 1 signal or engine fuel temperature 1 return (sensor return 1) wires or voltage shorts to the engine fuel temperature 1 signal or engine fuel temperature return (sensor return 1) wires, or a damaged open engine fuel temperature 1 sensor.

Component Location

The engine fuel temperature sensor 1 is located on the left side of the engine, on the fuel filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Before troubleshooting Fault Code 263, check for multiple faults.

The engine fuel temperature sensor 1 shares RETURN wires in the engine harness with other sensors. An open RETURN can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open RETURN circuit in the harness, connectors, or sensor
  • Open SIGNAL circuit or shorted to a voltage source.

The resistance of the engine fuel temperature 1 sensor varies with the temperature. If the engine fuel temperature 1 sensor is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 263.

Last Modified: 16-Sep-2010


Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: SPN: 174 FMI: 4 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine fuel temperature sensor 1 circuit. | ECM will set fuel temperature to a default value. No other action taken by ECM.
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Fuel Temperature Sensor 1 Circuit
QSK38 CM2150 Marine Auxiliary - Engine Fuel Temperature Sensor 1 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Fuel Temperature Sensor 1 Circuit
QSK60 CM2150 Power Generation - Engine Fuel Temperature Sensor 1 Circuit
QSK50 and QSK60 CM2150 Power Generation (Military Application)/QSK60 CM2150 Drill Rig - Engine Fuel Temperature Sensor 1 Circuit

Circuit Description

The fuel supply temperature sensor 1 is used by the ECM to monitor the temperature of the fuel. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage on the engine fuel temperature 1 signal pin. The ECM expects the voltage to vary between 0.5-VDC to 4.5-VDC. If the voltage is below 0.21-VDC, the ECM will log Fault Code 265.

Voltage below 0.21-VDC on the fuel temperature 1 signal pin can be caused by shorts to ground on the engine fuel temperature 1 signal or engine fuel temperature 1 return (sensor return 1) wires, or an internally grounded or damaged engine fuel temperature sensor 1.

Component Location

The engine fuel temperature sensor 1 is located on the left side of the engine on the fuel filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine fuel temperature sensor 1 shares RETURN wires in the engine harness with other sensors. A shorted RETURN can cause multiple fault codes to be active. Before troubleshooting Fault Code 265, check for multiple fault codes.

Possible causes of this fault code include:

  • SIGNAL shorted to ground in the harness
  • SIGNAL shorted to return or ground in the sensor.

The resistance of the engine fuel temperature 1 sensor varies with the temperature. If the engine fuel temperature 1 sensor is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 265.

Last Modified: 16-Sep-2010


Engine Exhaust Gas Temperature - Right Manifold Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2651

Engine Exhaust Gas Temperature - Right Manifold Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2651 PID: SPN: 2433 FMI: 3 LAMP: Maintenance SRT: | Engine Exhaust Gas Temperature - Right Manifold Sensor Circuit Marine Engines - Voltage Above Normal or Shorted to High source. High signal voltage detected at the exhaust gas temperature - right manifold sensor circuit. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Power Generation (Military Application) - Exhaust Gas Temperature Right Manifold Sensor Circuit
QSK38 CM2150 Marine - Exhaust Gas Temperature Right Manifold Sensor Circuit
QSK50 CM2150 Marine - Exhaust Gas Temperature Right Manifold Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Right Manifold Sensor Circuit

Circuit Description

The exhaust gas temperature right manifold sensor circuit monitors exhaust gas temperature and passes the information on to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature right manifold sensor is located in the exhaust stack. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. the exhaust gas temperature right manifold sensor measures the exhaust temperature in the right bank stack. The exhaust gas temperature right manifold sensor has a 6.2k ohm resistor between a 5 volt SUPPLY and the SIGNAL wire. Possible causes as this fault include:

  • Open SIGNAL circuit or shorted to voltage source
  • Open RETURN circuit in the harness, connectors, or sensor.
Refer to Troubleshooting Fault Code 2651.

Last Modified: 10-Mar-2015


Engine Exhaust Gas Temperature - Right Manifold Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2652

Engine Exhaust Gas Temperature - Right Manifold Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2652 PID: SPN: 2433 FMI: 4 LAMP: Maintenance SRT: | Engine Exhaust Gas Temperature Right Manifold Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature right manifold sensor. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Power Generation (Military Application) - Exhaust Gas Temperature Right Manifold Sensor Circuit
QSK38 CM2150 Marine - Exhaust Gas Temperature Right Manifold Sensor Circuit
QSK50 CM2150 Marine - Exhaust Gas Temperature Right Manifold Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Right Manifold Sensor Circuit

Circuit Description

The exhaust gas temperature right manifold sensor circuit monitors exhaust gas temperature and passes the information on to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature right manifold sensor is located in the exhaust stack. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature right manifold sensor measures the exhaust temperature in the right bank stack. The exhaust gas temperature right manifold sensor has a 6.2k ohm resistor between a 5 volt SUPPLY and the SIGNAL wire.

Possible causes of this fault include:

  • SIGNAL circuit shorted to ground in the harness
  • SIGNAL circuit shorted to RETURN or ground in the sensor.
Refer to Troubleshooting Fault Code 2652.

Last Modified: 10-Mar-2015


Engine Exhaust Gas Temperature - Right Manifold - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2653

Engine Exhaust Gas Temperature - Right Manifold - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2653 PID: SPN: 2433 FMI: 16 LAMP: Amber SRT: | Engine Exhaust Gas Temperature - Right Manifold - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage.
QSK38 CM2150 Marine - Engine Exhaust Gas Temperature Right Manifold Sensor
QSK50 CM2150 Marine - Engine Exhaust Gas Temperature Right Manifold Sensor
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Exhaust Gas Temperature Right Manifold Sensor

Circuit Description

The engine exhaust gas temperature right manifold sensor monitors exhaust gas temperature in the exhaust stack and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The engine exhaust gas temperature right manifold sensor is located in the exhaust stack.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine exhaust gas temperature right manifold sensor measures the engine exhaust gas temperature of the right stack. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted aftercooler
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2653.

Last Modified: 13-Dec-2010


Engine Exhaust Gas Temperature - Right Manifold - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 2654

Engine Exhaust Gas Temperature - Right Manifold - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2654 PID: SPN: 2433 FMI: 0 LAMP: Red SRT: | Engine Exhaust Gas Temperature - Right Manifold - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine smoke and engine damage.
QSK38 CM2150 Marine - Engine Exhaust Gas Temperture Right Manifold Sensor
QSK50 CM2150 Marine - Engine Exhaust Gas Temperture Right Manifold Sensor
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Exhaust Gas Temperture Right Manifold Sensor

Circuit Description

The engine exhaust gas temperature right manifold sensor monitors exhaust gas temperature in the exhaust stack and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The engine exhaust gas temperature right manifold sensor is located in the exhaust stack.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine exhaust gas temperature right manifold sensor measures the engine exhaust gas temperature of the right stack. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted aftercooler
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2654.

Last Modified: 13-Dec-2010


Engine Exhaust Gas Temperature - Left Manifold Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2655

Engine Exhaust Gas Temperature - Left Manifold Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2655 PID: SPN: 2434 FMI: 3 LAMP: Maintenance SRT: | Engine Exhaust Gas Temperature - Left Manifold Sensor Circuit Marine Engines - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature left manifold sensor circuit. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Power Generation (Military Application) - Exhaust Gas Temperature Left Manifold Sensor Circuit
QSK38 CM2150 Marine - Exhaust Gas Temperature Left Manifold Sensor Circuit
QSK50 CM2150 Marine Auxiliary with C Command™ - Exhaust Gas Temperature Left Manifold Sensor Circuit
QSK50 CM2150 Marine Propulsion/QSK50 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ - Exhaust Gas Temperature Left Manifold Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Left Manifold Sensor Circuit

Circuit Description

The exhaust gas temperature left manifold sensor circuit monitors exhaust gas temperature and passes the information on to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature left manifold sensor is located in the exhaust stack. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature left manifold sensor measures the exhaust gas temperature in the left bank stack. The exhaust gas temperature left manifold sensor has a 6.2k ohm resistor between a 5 volt supply and the signal wire. Possible causes as this fault include:

  • Open SIGNAL circuit or shorted to voltage source
  • Open RETURN circuit in the harness, connectors, or sensor.
Refer to Troubleshooting Fault Code t05-2655

Last Modified: 10-Mar-2015


Engine Exhaust Gas Temperature - Left Manifold Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2656

Engine Exhaust Gas Temperature - Left Manifold Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2656 PID: SPN: 2433 FMI: 4 LAMP: Maintenance SRT: | Engine Exhaust Gas Temperature - Left Manifold Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature left manifold sensor. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Power Generation (Military Application) - Exhaust Gas Temperature Left Manifold Sensor Circuit
QSK38 CM2150 Marine - Exhaust Gas Temperature Left Manifold Sensor Circuit
QSK50 CM2150 Marine Auxiliary with C Command™ - Exhaust Gas Temperature Left Manifold Sensor Circuit
QSK50 CM2150 Marine Propulsion/QSK50 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ - Exhaust Gas Temperature Left Manifold Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Left Manifold Sensor Circuit

Circuit Description

The exhaust gas temperature left manifold sensor circuit monitors exhaust gas temperature and passes the information on to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature left manifold sensor is located in the exhaust stack. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature left manifold sensor measures the exhaust gas temperature in the left bank stack. The exhaust gas temperature left manifold sensor has a 6.2k ohm resistor between a 5 volt supply and the signal wire.

Possible causes of this fault include:

  • SIGNAL circuit shorted to ground in the harness
  • SIGNAL circuit shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-2656

Last Modified: 10-Mar-2015


Engine Exhaust Gas Temperature - Left Manifold - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2657

Engine Exhaust Gas Temperature - Left Manifold - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2657 PID: SPN: 2434 FMI: 16 LAMP: Amber SRT: | Engine Exhaust Gas Temperature - Left Manifold - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible engine smoke and engine damage.
QSK38 CM2150 Marine - Engine Exhaust Gas Temperature Left Manifold Sensor Engines
QSK50 CM2150 Marine Auxiliary with C Command™ - Engine Exhaust Gas Temperature - Left Manifold Sensor Engines
QSK50 CM2150 Marine Propulsion/QSK50 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ - Engine Exhaust Gas Temperature - Left Manifold Sensor Engines
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Exhaust Gas Temperature - Left Manifold Sensor Engines

Circuit Description

The engine exhaust gas temperature left manifold sensor monitors exhaust gas temperature in the exhaust stack and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The engine exhaust gas temperature left manifold sensor is located in the exhaust stack.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine exhaust gas temperature left manifold sensor measures the exhaust gas stack temperature of the left manifold exhaust stack. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted aftercooler
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2657.

Last Modified: 13-Dec-2010


Engine Exhaust Gas Temperature - Left Manifold - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 2658

Engine Exhaust Gas Temperature - Left Manifold - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2658 PID: SPN: 2434 FMI: 0 LAMP: Red SRT: | Engine Exhaust Gas Temperature - Left Manifold - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine smoke and engine damage.
QSK38 CM2150 Marine - Engine Exhaust Gas Temperature Left Manifold Sensor
QSK50 CM2150 Marine Auxiliary with C Command™ - Engine Exhaust Gas Temperature Left Manifold Sensor
QSK50 CM2150 Marine Propulsion/QSK50 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ - Engine Exhaust Gas Temperature Left Manifold Sensor
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Exhaust Gas Temperature Left Manifold Sensor

Circuit Description

The engine exhaust gas temperature left manifold sensor monitors exhaust gas temperature in the exhaust stack and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The engine exhaust gas temperature left manifold sensor is located in the exhaust stack.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine exhaust gas temperature left manifold sensor 2 measures the exhaust gas stack temperature of the left manifold exhaust stack. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Restricted air flow through the exhaust manifold or exhaust system
  • Damaged valves, rings, or piston
  • High intake air temperature
  • Injector damage
  • Restricted aftercooler
  • Boost air leaks
  • Over fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 2658.

Last Modified: 13-Dec-2010


Engine Fuel Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 266

Engine Fuel Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 266 PID: SPN: 174 FMI: 0 LAMP: Red SRT: | Engine Fuel Temperature - Data Valid but Above Normal Operating Range - Most Severe Level. | Power derate and possible engine shutdown if engine protection shutdown feature is enabled.
QSK38 CM2150 Industrial - Engine Fuel Temperature Sensor 1 Circuit
QSK38 CM2150 Marine Propulsion - Engine Fuel Temperature Sensor 1 Circuit
QSK50 CM2150 Industrial - Engine Fuel Temperature Sensor 1 Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Fuel Temperature Sensor 1 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion - Engine Fuel Temperature Sensor 1 Circuit

Circuit Description

The engine fuel temperature sensor 1 is used by the ECM to monitor engine fuel supply temperature. The ECM monitors the voltage on the engine fuel temperature signal pin and converts this to a temperature value. The engine fuel temperature value is used by the ECM for the engine protection system.

Component Location

The engine fuel temperature sensor 1 is located on the fuel filter housing.

Shop Talk

All Temperature Sensors:

  • The resistance of the sensor varies with the temperature. If the sensor is operating properly, the observed reading will be comparable to the values in the following table.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 266.

Last Modified: 10-Dec-2010


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. | No effect on performance
Electronic Control Module (ECM)

Circuit Description

Not applicable for this fault code.

Component Location

The reset button or switch location depends on the OEM. Refer to the OEM troubleshooting and repair manual for component location.

Shop Talk

This fault code occurs as a result of other fault codes becoming active or inactive. Fault Code 2661 will remain active until reset by the operator. Fault Code 2661 is designed to latch onto other fault codes that have become active or have gone inactive. The light is an indicator that will remain lit to inform the operator that there has been a fault code generated. The fault has no effect on engine performance.

This fault code is generated by red/shutdown lamp faults. Other fault codes need to be corrected before acknowledging this fault code, otherwise this fault code will become active again after a calibrated period of time, if other fault codes are still active.

Refer to Troubleshooting Fault Code 2661.

Last Modified: 16-Jul-2010


At Least One Unacknowledged Moderately Severe Fault - Condition Exists

FAULT CODE 2662

At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2662 PID: SPN: 629 FMI: 31 LAMP: Amber SRT: | At Least One Unacknowledged Moderately Severe Fault - Condition Exists. | No effect on performance
Electronic Control Module (ECM)

Circuit Description

Not applicable for this fault code.

Component Location

The reset button or switch location depends on the OEM. Refer to the OEM troubleshooting and repair manual for component location.

Shop Talk

This fault code occurs as a result of other fault codes becoming active or inactive. Fault Code 2662 will remain active until reset by the operator. Fault Code 2662 is designed to latch onto other fault codes that have become active or have gone inactive. The light is an indicator that will remain lit to inform the operator that there has been a fault code generated. The fault has no effect on engine performance.

This fault code is generated by red/shutdown lamp faults. Other fault codes need to be corrected before acknowledging this fault code, otherwise this fault code will become active again after a calibrated period of time, if other fault codes are still active.

Refer to Troubleshooting Fault Code 2662.

Last Modified: 16-Jul-2010


Accelerator Pedal or Lever Idle Validation Switch Circuit - Out of Calibration

FAULT CODE 2697

Accelerator Pedal or Lever Idle Validation Switch Circuit - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2697 PID: SPN: 558 FMI: 13/13 LAMP: Maintenance SRT: | Accelerator Pedal or Lever Idle Validation Switch Circuit - Out of Calibration. Voltage at accelerator pedal or lever idle validation switch on and accelerator pedal or lever idle validation off circuit does not match accelerator pedal position. | Engine will only idle or can revert to other throttle input if available.
QSK38 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Circuit
QSK38 CM2150 Marine Propulsion - Accelerator Pedal or Lever Idle Validation Switch Circuit
QSK50 and QSK60 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Switch Circuit
QSK50 and QSK60 CM2150 Marine Propulsion/QSK60 CM2150 Drill Rig - Accelerator Pedal or Lever Idle Validation Switch Circuit

Circuit Description

The accelerator pedal or lever idle validation position sensor is attached to the accelerator pedal or lever. The accelerator pedal or lever idle validation position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal or lever is depressed and released. The accelerator pedal or lever position circuit contains three wires: accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4), accelerator pedal or lever position RETURN (sensor return 4), and accelerator pedal or lever position SIGNAL. The accelerator pedal or lever position return (sensor return 4) circuit has a shared return with other OEM switches.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal.

Shop Talk

There are multiple ECMs for the engine models included in the manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault is logged when both the accelerator pedal or lever idle validation switch signal and accelerator pedal or lever idle validation switch signal disagree with the accelerator pedal or position signal. Turning the keyswitch ON while partially depressing the accelerator pedal or lever can cause this fault code to go active.

This fault will stay active until the accelerator pedal is cycled through its full travel.

It is important to note, while troubleshooting this fault code INSITE™ electronic service tool will display the default throttle position, not the actual accelerator pedal or lever position when this fault code is logged. A digital multimeter must be used to read accelerator pedal or lever position and not INSITE™ electronic service tool.

Possible causes of this fault code are:

  • Accelerator pedal is not calibrated properly
  • Accelerator pedal position sensor damaged
  • Both idle validation switches disagree with the accelerator pedal position.
Refer to Troubleshooting Fault Code 2697.

Last Modified: 14-May-2010


Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: SPN: 1347 FMI: 4 LAMP: Amber SRT: | Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel pump pressurizing assembly 1 circuit. | Engine will run poorly at idle. Engine will have low power. Fuel pressure will be higher than commanded.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Fuel Pump Pressurizing Assembly 1 Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Fuel Pump Pressurizing Assembly 1 Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Fuel Pump Pressurizing Assembly 1 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/ QSK60 CM2150 Power Generation - Fuel Pump Pressurizing Assembly 1 Circuit
QSK60 CM2150 Drill Rig - Fuel Pump Pressurizing Assembly 1 Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the ECM that controls the fuel pump pressurizing assembly 1. The fuel pump pressurizing assembly 1 is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the high-pressure pump, based on engine operating conditions. The fuel pump pressurizing assembly 1 is a normally open valve. Pulse width modulation duty cycle to the fuel pump pressurizing assembly 1 depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump pressurizing assembly 1 is located on the engine-mounted fuel pump housing. The engine harness and the ECM are other components in the circuit that can cause this fault code.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

This fault becomes active when the ECM detects a short circuit in the fuel pump pressurizing assembly 1 circuit. Causes for this fault code are short circuit to ground or low resistance (fuel pump pressurizing assembly 1 coil is shorted internally) in the circuit for the fuel pump pressurizing assembly 1. When excessive current or a short circuit is detected, the ECM driver to the fuel pump pressurizing assembly 1 is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will retest for the cause of the fault code. The ECM driver is activated at key ON; and if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors. Since the CM2150 engines utilize a two-stage mechanical dump valve, damage to the fuel pump pressurizing assembly 1 will result in operation with the mechanical dump valve open. Extended operation with the mechanical dump valve open can damage the pressure relief valve.

Fault Code 2311 can have high counts if the fault condition is, or was, intermittent.

Refer to Troubleshooting Fault Code 271.

Last Modified: 21-Sep-2010


Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: SPN: 1347 FMI: 3 LAMP: Amber SRT: | Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the fuel pump pressurizing assembly 1. | Engine will not run or engine will run poorly.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Fuel Pump Pressurizing Assembly 1 Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Fuel Pump Pressurizing Assembly 1 Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Fuel Pump Pressurizing Assembly 1 Circuit
QSK50 CM2150 without Advanced Engine Monitoring/QSK50 CM2150 with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Fuel Pump Pressurizing Assembly 1 Circuit
QSK60 CM2150 Drill Rig - Fuel Pump Pressurizing Assembly 1 Circuit

Circuit Description

The fuel pump pressurizing assembly 1 circuit is an auxiliary pulse width modulated (PWM) driver 1 in the ECM that controls the fuel pump pressurizing assembly 1 . The fuel pump pressurizing assembly 1 is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the high-pressure pump based on engine operating conditions. The fuel pump pressurizing assembly 1 valve is a normally open valve. Auxiliary pulse width modulated driver 1 duty cycle to the fuel pump pressurizing assembly 1 depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump pressurizing assembly 1 is located on the engine-mounted fuel pump housing. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault becomes active when the ECM detects an open fuel pump pressurizing assembly 1 circuit. Causes for this fault code are short circuit to a positive voltage or an open circuit in the fuel pump pressurizing assembly 1 circuit. If there is a high harness resistance or an intermittent open circuit, Fault Code 2311 can have high inactive counts. If the fault code is intermittent, look for causes of an intermittent open circuit, such as loose pins and bad connections. If the fault code is intermittent, look closely for loose connectors, corroded pins, bent or broken pins, pushed back or expanded pins, moisture in or on the connector, missing or damaged connector seals, dirt or debris in or on the connector pin, connector shell broken, wire insulation damage, damaged connector locking tab at the ECM, fuel pump pressurizing assembly 1, and wiring harness.

Refer to Troubleshooting Fault Code 272.

Last Modified: 21-Sep-2010


SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

FAULT CODE 2727

SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2727 PID: SPN: 1231 FMI: 9 LAMP: Maintenance SRT: | SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate. | Engine will lose power or stop running.
QSK38 CM2150 Industrial/QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - SAE J1939 Data Link 2 Engine Network Circuit
QSK38 CM2150 Marine - SAE J1939 Data Link 2 Engine Network Circuit
QSK50 and QSK60 CM2150 Industrial - SAE J1939 Data Link 2 Engine Network Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - SAE J1939 Data Link 2 Engine Network Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - SAE J1939 Data Link 2 Engine Network Circuit

Circuit Description

The SAE J1939 data link 2 engine network allows communication between ECM1, ECM 2, and ECM 3 on the QSK50 and QSK60 engines. The SAE J1939 data link 2 engine network allows communication between ECM 1 and ECM 2 on QSK38 engines. There are critical and non-critical compatibility messages transmitted between the ECMs through the SAE J1939 data link 2 engine network.

Component Location

The ECMs are located on the fuel system side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open or short circuit on the SAE J1939 data link 2 harness engine network
  • Malfunctioning terminator resistors on the SAE J1939 data link 2 harness engine network.
Refer to Troubleshooting Fault Code 2727.

Last Modified: 10-Dec-2010


Start Enable Device 1 Canister Empty (Ether Injection) - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2734

Start Enable Device 1 Canister Empty (Ether Injection) - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2734 PID: SPN: 626 FMI: 17 LAMP: None SRT: | Start Enable Device 1 Canister Empty (Ether Injection) - Data Valid but Below Normal Operating Range - Moderately Severe Level. The ether bottle for the Start Enable Device 1 Canister (Ether Injection) is empty. | The Start Enable Device 1 Canister Empty (Ether Injection) is disabled.
QSK38 CM2150 Industrial - Start Enable Device 1 Canister Empty (Ether Injection) System
QSK50 and QSK60 CM2150 Industrial - Start Enable Device 1 Canister Empty (Ether Injection) System

Circuit Description

Not applicable for this fault code.

Component Location

The ether injection canister location depends on the OEM. Refer to the OEM service manual for component location.

Shop Talk

There are multiple electronic control module (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code occurs when the ether injection canister is empty.

Refer to Troubleshooting Fault Code 2734.

Last Modified: 13-Dec-2010


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: SPN: 639 FMI: 9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM did not receive a multiplexed message from an OEM vehicle electronic control unit within the time limit or did not receive it at all. | One or more multiplexed devices will not operate properly. One or more symptoms will occur.
QSK38 CM2150 Industrial - SAE J1939 Multiplexing Configuration
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - SAE J1939 Multiplexing Configuration
QSK38 CM2150 Marine - SAE J1939 Multiplexing Configuration
QSK50 and QSK60 CM2150 Industrial - SAE J1939 Multiplexing Configuration
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - SAE J1939 Multiplexing Configuration
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators and other components are connected to the ECM directly through individual wires. Multiplexing allows those same components to be hard-wired to an OEM vehicle electronic control unit or transmission electronic control unit in the cab. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM vehicle electronic control unit to the ECM over the SAE J1939 data link.

Messages sent from OEM vehicle electronic control units or transmission electronic control units are received by the ECM and used for controlling the engine. The ECM and OEM vehicle electronic control units must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECMs are located on the left bank of the engine. The SAE J1939 data link wiring and vehicle electronic control unit location varies by OEM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM vehicle electronic control unit source addressed correctly) to receive information from an OEM vehicle electronic control unit, but the OEM vehicle electronic control unit is not actually transmitting the message for that component. This can be caused when a multiplexed component is enabled in the ECM, but the OEM vehicle electronic control unit source address of the vehicle electronic control unit transmitting the component message is incorrect in the ECM, or the OEM vehicle electronic control unit is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning SAE J1939 data link connection between the OEM vehicle electronic control unit and ECM, a malfunctioning connection between the component and the OEM vehicle electronic control unit, malfunctioning OEM vehicle electronic control unit, or malfunctioning ECM. It will possibly be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code 285.

Last Modified: 17-Sep-2010


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: SPN: 639 FMI: 13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
QSK38 CM2150 Industrial - SAE J1939 Multiplexing Configuration Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - SAE J1939 Multiplexing Configuration Circuit
QSK38 CM2150 Marine - SAE J1939 Multiplexing Configuration Circuit
QSK50 and QSK60 CM2150 Industrial - SAE J1939 Multiplexing Configuration Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - SAE J1939 Multiplexing Configuration Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - SAE J1939 Multiplexing Configuration Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the ECM directly through individual wires. Multiplexing allows those same components to be hard-wired to an OEM vehicle electronic control unit or transmission electronic control unit in the cab. As such, component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM vehicle electronic control unit to the engine ECM over the SAE J1939 data link.

Messages sent from OEM vehicle electronic control units or transmission electronic control units are received by the engine ECM and used for controlling the engine. The ECM and OEM vehicle electronic control unit(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The engine ECMs are located on the left bank of the engine. The J1939 data link wiring and vehicle electronic control unit location varies by OEM.

Shop Talk

Fault Code 286 can only go active if the electronic control module receives J1939 multiplexed data, but the data is not in the expected range. If the module is receiving this data from the OEM equipment, the data link must be good.

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The J1939 data link wiring and OEM vehicle electronic control unit location varies by OEM. Refer to the OEM service manual.

This fault can occur when the ECM is set up properly (components enabled and OEM vehicle electronic control unit source addressed correctly) to receive information from an OEM vehicle electronic control unit, but the OEM vehicle electronic control unit is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code 286.

Last Modified: 17-Sep-2010


Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Least Severe Level. | Progressive power derate increasing in severity from time of alert.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine Propulsion - Engine Coolant Temperature 1 Sensor Circuit Engines
QSK50 CM2150 Industrial/QSK50 CM2150 Marine Propulsion - Engine Coolant Temperature 1 Sensor Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine Propulsion/QSK60 CM2150 Drill Rig - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the engine coolant temperature 1 signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature 1 sensor is located on the thermostat housing. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in:

  • K38, K50, and QSK50 Service Manual, Bulletin 4021528
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
Refer to Troubleshooting Fault Code 2963.

Last Modified: 10-Mar-2015


Engine Torque Limit Feature - Special Instructions

FAULT CODE 2998

Engine Torque Limit Feature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2998 PID: SPN: 1632 FMI: 14 LAMP: Amber SRT: | Engine Torque Limit Feature - Special Instructions. Engine overload. | Possible engine derate if enabled.
ECM CM2150

Circuit Description

N/A

Component Location

N/A

Shop Talk

This fault code is designed to keep the engine from overloading.

The fault code is triggered when the engine speed fails to attain the commanded speed.

Potential causes of this fault code are:

  • Low engine power
  • High idle adjustment is too high
  • Excessive hull fouling
  • Incorrect transmission or propeller.

Refer to the OEM service manual for causes associated with excessive hull fouling and incorrect transmission or propeller, as these are external to engine.

Refer to Troubleshooting Fault Code 2998.

Last Modified: 20-Sep-2010


Fault Code Path Selection

FAULT CODE 322
Fault Code Path Selection

Is the engine a QSK38? | Go to 122-fc322qsk38
Is the engine a QSK50 or QSK60? | Go to 122-fc322qsk50-60

Last Modified: 26-Feb-2010


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322 (QSK38)

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: SPN: 651 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 1 circuit or no current detected at the injector solenoid driver cylinder 1 signal pin or injector solenoid driver cylinder 1 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 1 Circuit
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 1 Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 1 Circuit
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low-side switches. The injectors for cylinders 1, 3, and 5 share a single high-side switch that connects the injector circuit to the source of the high voltage in ECM 2. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is operating. If an injector circuit fault is active and the malfunctionn is repaired, the fault will become inactive once the engine is started or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent, and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 322 (QSK38).

Last Modified: 22-Sep-2010


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: SPN: 651 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 1 circuit or no current detected at the injector solenoid driver cylinder 1 signal pin or injector solenoid driver cylinder 1 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK50 CM2150 Industrial/QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 1 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 1 Circuit
QSK50 CM2150 Marine - Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. ECM 1 has two high-side switches and four low-side switches. ECM 2 and ECM 3 have two high-side switches and six low-side switches. The injectors for cylinders 1 and 15 share a single high-side switch that connects the injector circuit to the source of the high voltage in ECM 1. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is operating. If an injector circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 322 (QSK50 and QSK60).

Last Modified: 17-Sep-2010


Fault Code Path Selection

FAULT CODE 323
Fault Code Path Selection

Is the engine a QSK38? | Go to 122-fc323qsk38
Is the engine a QSK50 or QSK60? | Go to 122-fc323qsk50-60

Last Modified: 15-Jan-2010


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323 (QSK38)

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: SPN: 655 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 5 circuit or no current detected at injector solenoid driver cylinder 5 signal pin or injector solenoid driver cylinder 5 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 5 Circuit
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 5 Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 5 Circuit
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low-side switches. The injectors for cylinders 1, 3, and 5 share a single high-side switch that connects the injector circuit to the source of the high voltage in ECM 2. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is operating. If an injector circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is started or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 323 (QSK38).

Last Modified: 27-Sep-2010


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: SPN: 655 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 5 circuit or no current detected at injector solenoid driver cylinder 5 signal pin or injector solenoid driver cylinder 5 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK50 and QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 5 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 5 Circuit
QSK50 CM2150 Marine - Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. ECM 1 has two high-side switches and four low-side switches. ECM 2 and ECM 3 have two high-side switches and six low-side switches. The injectors for cylinders 8, 16, and 5 share a single high-side switch with the same ECM. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker lever cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 323 (QSK50 and QSK60).

Last Modified: 27-Sep-2010


Fault Code Path Selection

FAULT CODE 324
Fault Code Path Selection

Is the engine a QSK38? | Go to 122-fc324qsk38
Is the engine a QSK50 or QSK60? | Go to 122-fc324qsk50-60

Last Modified: 15-Jan-2010


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324 (QSK38)

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: SPN: 653 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 3 circuit or no current detected at injector solenoid driver cylinder 3 signal pin or injector solenoid driver cylinder 3 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 3 Circuit
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 3 Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 3 Circuit
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low-side switches. The injectors for cylinders 1, 3, and 5 share a single high-side switch in ECM 2. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 324 (QSK38).

Last Modified: 07-Oct-2010


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: SPN: 653 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 3 circuit or no current detected at injector solenoid driver cylinder 3 signal pin or injector solenoid driver cylinder 3 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK50 and QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 3 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 3 Circuit
QSK50 CM2150 Marine - Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. ECM 1 has two high-side switches and four low-side switches. ECM 2 and ECM 3 have two high-side switches and six low-side switches. The injectors for cylinders 3 and 13 share a single high-side switch in ECM 1. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 324 (QSK50 and QSK60).

Last Modified: 17-Sep-2010


Fault Code Path Selection

FAULT CODE 325
Fault Code Path Selection

Is the engine a QSK38? | Go to 122-fc325qsk38
Is the engine a QSK50 or QSK60? | Go to 122-fc325qsk50-60

Last Modified: 26-Feb-2010


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325 (QSK38)

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: SPN: 656 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. High detected on injector solenoid resistance driver cylinder 6 circuit or no current detected at injector solenoid driver cylinder 6 signal pin or injector solenoid driver cylinder 6 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 6 Circuit
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 6 Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 6 Circuit
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low-side switches. The injectors for cylinders 2 , 4, and 6 share a single high-side switch that connects the injector circuit to the source of the high voltage in ECM 1. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Possible causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 325 (QSK38).

Last Modified: 16-Sep-2010


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: SPN: 656 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 6 circuit or no current detected at injector solenoid driver cylinder 6 signal pin or injector solenoid driver cylinder 6 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK50 CM2150 Industrial - Injector Solenoid Driver Cylinder 6 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 6 Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 6 Circuit
QSK60 CM2150 Industrial - Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. ECM 1 has two high-side switches and four low-side switches. ECM 2 and ECM 3 have two high-side switches and six low-side switches. The injectors for cylinders 6 , 7, and 14 share a single high-side switch that connects the injector circuit to the source of the high voltage in ECM 2. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid driver
  • High resistance in a single injector or injector solenoid driver
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 325 (QSK50 and QSK60).

Last Modified: 16-Sep-2010


Fuel Consumption Rate - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 327

Fuel Consumption Rate - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 327 PID: SPN: 183 FMI: 16 LAMP: Amber SRT: | Fuel Consumption Rate - Data Valid but Above Normal Operating Range - Moderately Severe Level. Adaptive Power Limiter Feature - Engine is producing power above rating. | Fueling is derated only to limit power to the appropriate rating.
Electronic Control Module (ECM)

Circuit Description

The electronic control module (ECM) uses the adaptive power limiter feature to detect when the engine is producing power greater than the appropriate engine rating.

Component Location

The ECM is located on the left bank side of the engine.

Shop Talk

This fault code is most often caused by overfueling. This can cause excessive exhaust temperatures, turbocharger speed, and boost pressures. The ECM will limit fueling to bring these readings back to normal range. Fault Code 3132 will log after excessive counts of Fault Code 327 have occurred.

Refer to Troubleshooting Fault Code 327.

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 331
Fault Code Path Selection

Is the engine a QSK38? | Go to 122-fc331qsk38
Is the engine a QSK50 or QSK60? | Go to 122-fc331qsk50-60

Last Modified: 26-Feb-2010


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331 (QSK38)

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: SPN: 652 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 2 circuit or no current detected at injector solenoid driver cylinder 2 signal pin or injector solenoid driver cylinder 2 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 2 Circuit
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 2 Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 2 Circuit
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low-side switches. The injectors for cylinders 2, 4, and 6 share a single high-side switch that connects the injector circuit to the source of high voltage inside ECM 1 and each injector has a dedicated low-side switch that completes circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 331 (QSK38).

Last Modified: 16-Sep-2010


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: SPN: 652 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 2 circuit or no current detected at injector solenoid driver cylinder 2 signal pin or injector solenoid driver cylinder 2 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK50 CM2150 Industrial - Injector Solenoid Driver Cylinder 2 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Injector Solenoid Driver Cylinder 2 Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 2 Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 2 Circuit
QSK60 CM2150 Industrial - Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. ECM 1 has two high-side switches and four low-side switches. ECM 2 and ECM 3 have two high-side switches and six low-side switches. The injectors for cylinders 2, 10, and 11 share a single high-side switch that connects the injector circuit to the source of high voltage inside ECM 3 and each injector has a dedicated low-side switch that completes circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 331 (QSK50 and QSK60).

Last Modified: 22-Sep-2010


Fault Code Path Selection

FAULT CODE 332
Fault Code Path Selection

Is the engine a QSK38? | Go to 122-fc332qsk38
Is the engine a QSK50 or QSK60? | Go to 122-fc332qsk50-60

Last Modified: 15-Jan-2010


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332 (QSK38)

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: SPN: 654 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 4 circuit or no current detected at injector solenoid driver cylinder 4 signal pin or injector solenoid driver cylinder 4 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 4 Circuit
QSK38 CM2150 Power Generation - Injector Solenoid Driver Cylinder 4 Circuit
QSK38 CM2150 Power Generation (Military Application) - Injector Solenoid Driver Cylinder 4 Circuit
QSK38 CM2150 Marine - Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. The QSK38 engine has two ECMs. Each ECM has two high-side switches and six low-side switches. The injectors for cylinders 4, 2, and 6 share a single high-side switch in ECM 1. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 332 (QSK38).

Last Modified: 16-Sep-2010


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332 (QSK50 and QSK60)

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: SPN: 654 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector solenoid driver cylinder 4 circuit or no current detected at injector solenoid driver cylinder 4 signal pin or injector solenoid driver cylinder 4 return pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK38 CM2150 Industrial - Injector Solenoid Driver Cylinder 4 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Solenoid Driver Cylinder 4 Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Solenoid Driver Cylinder 4 Circuit
QSK60 CM2150 Industrial - Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. ECM 1 has two high-side switches and four low-side switches. ECM 2 and ECM 3 have two high-side switches and six low-side switches. The injectors for cylinders 4, 12, and 9 share a single high-side switch in the same ECM. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside its ECM.

Component Location

The engine harness connects the ECMs to each injector. The injector solenoid driver connectors are located on the injector, above the rocker cover.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is malfunctioning.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the malfunction is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally, but not to ground)
  • Malfunctioning ECM.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 332 (QSK50 and QSK60).

Last Modified: 16-Sep-2010


Electronic Calibration Code Incompatibility - Out of Calibration

FAULT CODE 342

Electronic Calibration Code Incompatibility - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: 630 FMI: 13 LAMP: Red SRT: | Electronic Calibration Code Incompatibility - Out of Calibration. | Hard to start or no start.
Electronic Control Module (ECM)

Circuit Description

The ECMs communicate via the wiring harness.

Component Location

The ECMs are located on the left (fuel pump) side of the engine. ECM 1 is the front-most mounted ECM. ECM 2 is in the middle and ECM 3 is the ECM mounted in the rear.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

ECM1 contains status information about ECM2 and ECM3. ECM2 and ECM3 contain status information for ECM1, to allow recalibration recovery if ECM1 is lost. At key on, this status is set to ECM2 and ECM3 not accessible and then is updated when the data link messages from ECM2 and ECM3 are received. If there is a communication or performance calibration incompatibility between ECM1, ECM2, or ECM3, a fault occurs that requires a recalibration of the modules identified with the fault and source address. This is for incompatibilities in calibrations between ECM1 and ECM2 or ECM3, and not related to accessibility. ECM1, ECM2, and ECM3 can communicate, but something in ECM2 or ECM3 calibration does not match with ECM1.

Possible causes:

  • Wrong or corrupt calibration
  • Wrong or malfunctioning ECM
  • Private terminating resistor damaged or disconnected.
Refer to Troubleshooting Fault Code 342.

Last Modified: 17-Mar-2010


Transmission Output Shaft Speed - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 349

Transmission Output Shaft Speed - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 349 PID: SPN: 191 FMI: 4/16 LAMP: Amber SRT: | Transmission Output Shaft Speed - Data Valid but Above Normal Operating Range - Moderately Severe Level | Engine will run off of a default auxiliary speed.
Electronic Control Module (ECM)

Circuit Description

The external speed command input is a frequency signal from an auxiliary speed or pressure pickup. It is sent to the ECM and is used to control the engine speed. Auxiliary reference speed is based on the accelerator position.

Component Location

Refer to the OEM service manual for component location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The ECM uses the auxiliary speed governor input and the throttle input in a calculation, along with calibration (application dependent) tables, to determine the fueling needed to obtain the desired output auxiliary shaft speed.

Fault code 349 is triggered if the external speed command input signal exceeds the calibration dependent defined maximum limit.

Refer to Troubleshooting Fault Code 349.

Last Modified: 27-Jun-2010


Fault Code Path Selection

FAULT CODE 351
Fault Code Path Selection

Is the ECM source address 00? | Go to 122-fc351sa00
Is the ECM source address 01? | Go to 122-fc351sa01
Is the ECM source address 144? | Go to 122-fc351sa144

Last Modified: 26-Feb-2010


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351 (Source Address 00)

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: SPN: 627 FMI: 12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component The ECM measured injector boost voltage is low. | Possible smoke, low power, engine misfire, and/or engine will not start.
QSK38 CM2150 Industrial - Battery 1 Voltage Circuit
QSK38 CM2150 Marine - Battery 1 Voltage Circuit
QSK38 CM2150 Power Generation - Battery 1 Voltage Circuit
QSK38 CM2150 Power Generation (Military Application) - Battery 1 Voltage Circuit
QSK50 CM2150 Industrial - Battery 1 Voltage Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Battery 1 Voltage Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Battery 1 Voltage Circuit
QSK60 CM2150 Industrial - Battery 1 Voltage Circuit
QSK60 CM2150 Power Generation - Battery 1 Voltage Circuit

Circuit Description

Between each injection event, the electronic control module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors; this power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine crankshaft speed/position sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code will become active when the engine is running, the engine crankshaft speed/position sensor signal is present, the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than commanded injector power supply voltage.

This fault code will become inactive whenever the keyswitch is turned OFF and ON and will become inactive whenever the engine is operating and measured injector power supply voltage reaches commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351 (Source Address 00).

Last Modified: 27-Sep-2010


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351 (Source Address 01)

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: SPN: 627 FMI: 12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component The ECM measured injector boost voltage is low. | Possible smoke, low power, engine misfire, and/or engine will not start.
QSK38 CM2150 Industrial - Battery 1 Voltage Circuit
QSK38 CM2150 Marine - Battery 1 Voltage Circuit
QSK38 CM2150 Power Generation - Battery 1 Voltage Circuit
QSK38 CM2150 Power Generation (Military Application) - Battery 1 Voltage Circuit
QSK50 CM2150 Industrial - Battery 1 Voltage Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Battery 1 Voltage Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Battery 1 Voltage Circuit
QSK60 CM2150 Industrial - Battery 1 Voltage Circuit
QSK60 CM2150 Power Generation - Battery 1 Voltage Circuit

Circuit Description

Between each injection event, the electronic control module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors; this power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine crankshaft speed/position sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in the INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code will become active when the engine is operating, the engine crankshaft speed/position sensor signal is present, the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than commanded injector power supply voltage.

This fault code will become inactive whenever the keyswitch is turned OFF and ON and will become inactive whenever the engine is operating and measured injector power supply voltage reaches commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351 (Source Address 01).

Last Modified: 22-Sep-2010


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351 (Source Address 144)

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: SPN: 627 FMI: 12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component The ECM measured injector boost voltage is low. | Possible smoke, low power, engine misfire, and/or engine will not start.
QSK38 CM2150 Industrial - Battery 1 Voltage Circuit
QSK38 CM2150 Marine - Battery 1 Voltage Circuit
QSK38 CM2150 Power Generation - Battery 1 Voltage Circuit
QSK38 CM2150 Power Generation (Military Application) - Battery 1 Voltage Circuit
QSK50 CM2150 Industrial - Battery 1 Voltage Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Battery 1 Voltage Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Battery 1 Voltage Circuit
QSK60 CM2150 Industrial - Battery 1 Voltage Circuit
QSK60 CM2150 Power Generation - Battery 1 Voltage Circuit

Circuit Description

Between each injection event, the electronic control module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors; this power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine crankshaft speed/position sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in the INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code will become active when the engine is operating, the engine crankshaft speed/position sensor signal is present, the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than commanded injector power supply voltage.

This fault code will become inactive whenever the keyswitch is turned OFF and ON and will become inactive whenever the engine is operating and measured injector power supply voltage reaches commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351 (Source Address 144).

Last Modified: 27-Sep-2010


Fault Code Path Selection

FAULT CODE 352
Fault Code Path Selection

Is the engine an Industrial or Marine application? | Go to 122-fc352ind
Is the engine a Power Generation application? | Go to 122-fc352pg

Last Modified: 23-Apr-2010


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352 (Industrial and Marine)

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: SPN: 3509 FMI: 4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Loss of some sensor functionality.
QSK38 CM2150 Industrial - Sensor Supply 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK38 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite™ Panel System - Sensor Supply 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command™ Panel System - Sensor Supply 1 Circuit
QSK38 CM2150 Marine Auxiliary with C Command™ Panel System - Sensor Supply 1 Circuit
QSK50 and QSK60 CM2150 Industrial - Sensor Supply 1 Circuit
QSK50 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK60 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK50 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK60 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System/QSK60 CM2150 Drill Rig - Sensor Supply 1 Circuit
QSK50 CM2150 Marine Propulsion with C Command™ Panel System - Sensor Supply 1 Circuit
QSK60 CM2150 Marine Propulsion with C Command™ Panel System - Sensor Supply 1 Circuit
QSK50 CM2150 Marine Auxiliary with C Command™ Panel System - Sensor Supply 1 Circuit
QSK60 CM2150 Marine Auxiliary with C Command™ Panel System - Sensor Supply 1 Circuit

Circuit Description

Sensor supply 1 voltage from the electronic control module (ECM) provides 5-VDC supply for the engine oil rifle pressure sensor, crankcase pressure sensor, and engine coolant pressure sensor on the engine harness. This 5-VDC supply also powers the coolant level sensor 1, the remote accelerator pedal or lever position sensor, and the auxiliary pressure sensor.

Component Location

The sensor supply number 1 is located in the ECM. The supply voltage is spliced off in the engine and original equipment manufacturer (OEM) harness to each sensor it supports.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Low voltage on the 5 volt supply line can be caused by a short to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code 352 (Industrial and Marine).

Last Modified: 16-Jul-2010


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352 (Power Generation)

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: SPN: 3509 FMI: 4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Loss of some sensor functionality.
QSK38 CM2150 Power Generation - Sensor Supply 1 Circuit
QSK38 CM2150 Power Generation (Military Application) - Sensor Supply 1 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Sensor Supply 1 Circuit

Circuit Description

Sensor supply 1 voltage from the electronic control module (ECM) provides 5 volts for the engine oil rifle pressure sensor, crankcase pressure sensor, and engine coolant pressure sensor on the engine harness. This 5 volt supply also powers coolant level sensor 1 and generator speed/load governing bias.

Component Location

The sensor supply number 1 is located in the ECM. The supply voltage is spliced off in the engine harness and original equipment manufacturer(OEM) harness to each sensor it supports.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Low voltage on the 5 volts supply line can be caused by a short to ground in a supply line, a short circuit between a supply line and a return line, a damaged sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code 352 (Power Generation).

Last Modified: 22-Sep-2010


Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3694

Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3694 PID: SPN: 4184 FMI: 4 LAMP: Amber SRT: | Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source | The ECM gain adjust potentiometer will go to the default value.
QSK38 CM2150 Power Generation - Gain Adjust Potentiometer Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Gain Adjust Potentiometer Circuit

Circuit Description

The gain adjust potentiometer is used to regulate the governor gains.

Component Location

The gain adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Shop Talk

There are multiple electronic control module (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of the fault code include:

  • SIGNAL wire open or shorted to ground
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-3694.

Last Modified: 07-Oct-2010


Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3695

Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3695 PID: SPN: 4182 FMI: 4 LAMP: Amber SRT: | Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source | The generator output frequency adjust potentiometer will go to the default value.
QSK38 CM2150 Power Generation - Generator Output Frequency Adjust Potentiometer Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 Power Generation - Generator Output Frequency Adjust Potentiometer Circuit
QSK38 CM2150 Marine Auxillary with C Command Elite™ and Elite Plus™ Panel System - Generator Output Frequency Adjust Potentiometer Circuit
QSK38 CM2150 Marine Auxillary with C Command™ Panel System - Generator Output Frequency Adjust Potentiometer Circuit
QSK50 and QSK60 CM2150 Marine Auxillary with C Command Elite™ and Elite Plus™ Panel System/QSK60 CM2150 Drill Rig - Generator Output Frequency Adjust Potentiometer Circuit
QSK50 and QSK60 CM2150 Marine Auxillary with C Command™ Panel System - Generator Output Frequency Adjust Potentiometer Circuit

Circuit Description

The generator output frequency adjust potentiometer circuit provides an analog (0 to 5-VDC) input for commanding a speed offset the base-rated speed. An external generator set controller can supply an analog signal with a potentiometer to this input to modify the generator set operating speed for synchronization or droop operations. The commanded engine speed offset is linearly proportional to the input voltage and nominal voltage of 2.5-VDC commands a speed offset of 0 rpm.

Component Location

The generator output frequency adjust potentiometer is located on the generator control panel. Refer to the original equipment manufacturer (OEM) service manual.

Shop Talk

There are multiple electronic control module (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

If Fault Code 3695 goes active, the generator output frequency adjust potentiometer will not respond.

Possible causes of the fault code include:

  • Signal wire open or shorted to ground.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 3695.

Last Modified: 28-Sep-2010


Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3696

Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3696 PID: SPN: 4183 FMI: 4 LAMP: Amber SRT: | Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source | The droop adjust potentiometer will go to the default value.
QSK38 CM2150 Power Generation -Droop Adjust Potentiometer Circuit
QSK50 CM2150 without Advanced Engine Monitoring/QSK50 CM2150 with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Droop Adjust Potentiometer Circuit
QSK38 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Droop Adjust Potentiometer Circuit
QSK38 CM2150 Marine Auxiliary with C Command™ Panel System - Droop Adjust Potentiometer Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System/QSK60 CM2150 Drill Rig - Droop Adjust Potentiometer Circuit
QSK50 and QSK60 CM2150 Marine Auxiliary with C Command™ Panel System - Droop Adjust Potentiometer Circuit

Circuit Description

The droop adjust potentiometer is used to regulate the engine droop.

Component Location

The droop adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Shop Talk

There are multiple electronic control module (ECM)s for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of the fault code include:

  • SIGNAL wire open or shorted to ground
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code 3696.

Last Modified: 27-Sep-2010


Intake Manifold Pressure Bank Imbalance - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3722

Intake Manifold Pressure Bank Imbalance - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3722 PID: SPN: FMI: LAMP: Maintenance SRT: | Intake Manifold Pressure Bank Imbalance - Data Erratic, Intermittent, or Incorrect. | Engine shutdown or derate.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 1 Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 2 Pressure Sensor Circuits

Circuit Description

The intake manifold 1 and 2 pressure sensors monitor intake manifold air pressure and pass information to the engine control module (ECM) through the engine harness. The ECM calculates a differential pressure between the left and right bank based on this information.

Component Location

The intake manifold 1 pressure sensors are located in the left and right bank front air intake manifold.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the ECM keyswitch is in the ON position.

Conditions for Setting the Fault Codes

  • If the boost pressure differential between the left and right bank intake manifold pressure sensors exceeded a calibrated value for a calibrated amount of time, the fault will activate.

Action Taken When the Fault Code is Active

  • N/A

Conditions for Clearing the Fault Code

  • N/A

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Restricted air intake filters
  • An intake air system boost leak
  • A closed intake air shut off valve
  • An issue with one of the turbochargers
  • Multiple malfunctioning injectors on one bank.
Refer to Troubleshooting Fault Code t05-3722.

Last Modified: 25-Jun-2015


Exhaust Gas Temperature Bank Imbalance - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3732

Exhaust Gas Temperature Bank Imbalance - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3732 PID: SPN: 1318 FMI: 2 LAMP: Red SRT: | Exhaust Gas Temperature Bank Imbalance - Data Erratic, Intermittent, or Incorrect | Possible engine shutdown.
Electronic Control Module (ECM)

Circuit Description

Each exhaust gas temperature sensors monitor exhaust gas temperature and pass information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor is located in the exhaust manifold at the cylinder head to exhaust manifold interface. Refer to Procedure 100-002 in Section E.

Shop Talk

Fault Code 3732 is associated with low power and is triggered when there is a significant difference between the average exhaust gas temperature on the left bank and the right bank. There are several causes associated with this fault code, including, but not limited to:

  • Intake manifold leak
  • Valve lash
  • Clogged air cleaner
  • Turbocharger malfunction
  • Air Shutoff valve malfunction
  • Flow limiter tripped on one or more injectors

If no malfunction is found by following this troubleshooting tree, reference the Engine Performance Troubleshooting Tree Procedure (05-t02-1001).

Refer to Troubleshooting Fault Code 3732.

Last Modified: 10-Dec-2010


Fault Code Path Selection

FAULT CODE 386
Fault Code Path Selection

Is the engine an Industrial and Marine application? | Go to 122-fc386ind
Is the engine a Power Generation application? | Go to 122-fc386pg

Last Modified: 23-Apr-2010


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386 (Industrial and Marine)

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: SPN: 3509 FMI: 3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Loss of some sensor functionality.
QSK38 CM2150 Industrial - Sensor Supply 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK38 CM2150 Marine Auxiliary with C Command Elite™ and Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK38 CM2150 Marine Propulsion with C Command™ Panel System - Sensor Supply 1 Circuit
QSK38 CM2150 Marine Auxilary with C Command™ Panel System - Sensor Supply 1 Circuit
QSK50 and QSK60 CM2150 Industrial - Sensor Supply 1 Circuit
QSK50 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK60 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK50 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK60 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System/QSK60 CM2150 Drill Rig - Sensor Supply 1 Circuit
QSK50 CM2150 Marine Propulsion with C Command™ Panel System - Sensor Supply 1 Circuit
QSK60 CM2150 Marine Propulsion with C Command™ Panel System - Sensor Supply 1 Circuit
QSK50 CM2150 Marine Auxiliary with C Command™ Panel System - Sensor Supply 1 Circuit
QSK60 CM2150 Marine Auxiliary with C Command™ Panel System - Sensor Supply 1 Circuit

Circuit Description

Sensor supply 1 voltage from the ECM provides 5-VDC supply for the engine oil rifle pressure sensor, crankcase pressure sensor, and engine coolant pressure sensor on the engine harness. This 5-VDC supply also powers the coolant level sensor 1, the remote accelerator pedal or lever position sensor, and the auxiliary pressure sensor.

Component Location

The sensor supply 1 is located in the ECM. The supply voltage is spliced off in the engine and OEM harness to each sensor it supports.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

High voltage on the sensor wire can be caused by an individual sensor supply wire in the harness shorted to battery voltage or a damaged ECM power supply.

Refer to Troubleshooting Fault Code 386 (Industrial and Marine).

Last Modified: 16-Jul-2010


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386 (Power Generation)

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply 1 circuit. | Loss of some sensor functionality.
QSK38 CM2150 Power Generation - Sensor Supply 1 Circuit
QSK38 CM2150 Power Generation (Military Application) - Sensor Supply 1 Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Sensor Supply 1 Circuit

Circuit Description

Sensor supply 1 voltage from the electronic control module (ECM) provides 5 volt supply for the engine oil rifle pressure sensor, the crankcase pressure sensor, and the engine coolant pressure sensor on the engine harness. This 5 volt supply also powers the coolant level sensor and generator speed/load governing bias.

Component Location

The sensor supply 1 is located in the ECM. The supply voltage is spliced off in the engine and OEM harness to each sensor it supports.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

High voltage on the sensor line can be caused by an individual sensor SUPPLY wire in the harness shorted to battery voltage or a damaged ECM power supply.

Refer to Troubleshooting Fault Code 386 (Power Generation).

Last Modified: 07-Oct-2010


Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: SPN: 100 FMI: 1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Most Severe Level. Engine oil rifle pressure 1 signal indicates oil pressure is below the engine protection critical limit. | Calibration-dependent progressive power, speed derate, and engine shutdown with increasing time after alert.
QSK38 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor QSK50 Industrial Engines
QSK38 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor
QSK38 CM2150 Power Generation (Military Application) - Engine Oil Rifle Pressure 1 Sensor
QSK38 CM2150 Marine - Engine Oil Rifle Pressure 1 Sensor
QSK50 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor
QSK50 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Oil Rifle Pressure 1 Sensor
QSK50 CM2150 Marine - Engine Oil Rifle Pressure 1 Sensor
QSK60 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor
QSK60 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Oil Rifle Pressure 1 Sensor

Circuit Description

The engine oil rifle pressure 1 sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, Fault Code 415 will log.

Component Location

The engine oil rifle pressure 1 sensor for the QSK50 series engine is located on the oil filter head. The engine oil rifle pressure 1 sensor for the QSK60 series engine is located on the left side on the flywheel housing.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level.
Refer to Troubleshooting Fault Code 415.

Last Modified: 17-Sep-2010


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water In Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine with C Command™ Panel System - Water in Fuel Indicator Sensor Circuit
QSK38 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Water in Fuel Indicator Sensor Circuit
QSK50 CM2150 Industrial - Water in Fuel Indicator Sensor Circuit
QSK38 CM2150 Power Generation and QSK38 CM2150 Power Generation (Military Application) - Water in Fuel Indicator Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Water in Fuel Indicator Sensor Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Water in Fuel Indicator Sensor Circuit
QSK60 CM2150 Industrial - Water in Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator sensor is attached to the first stage fuel filter. The water in fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator sensor circuit contains two wires; a water in fuel indicator RETURN (sensor RETURN 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator sensor is integrated into the first stage fuel filter housing which is mounted off-engine. Refer to the equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

Drain the Stage 1 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active, and there is no water in the fuel filter, then a malfunctioning water in filter sensor or water in the sensor connector can cause the fault.

Refer to Troubleshooting Fault Code 418.

Last Modified: 17-Nov-2015


Intake Manifold Pressure Bank Imbalance - Data Erratic, Intermittent, or Incorrect

FAULT CODE 419

Intake Manifold Pressure Bank Imbalance - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 419 PID: SPN: FMI: LAMP: Amber SRT: | Intake Manifold Pressure Bank Imbalance - Data Erratic, Intermittent, or Incorrect. | Engine shutdown or derate.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 1 Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 2 Pressure Sensor Circuits

Circuit Description

The intake manifold 1 and 2 pressure sensors monitor intake manifold air pressure and pass information to the engine control module (ECM) through the engine harness. The ECM calculates a differential pressure between the left and right bank based on this information.

Component Location

The intake manifold pressure sensors are located in the air intake manifold toward the front of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position.

Conditions for Setting the Fault Codes

If the boost pressure differential between the left and right bank intake manifold pressure sensors exceeded a calibrated value for a calibrated amount of time, the fault will activate.

Action Taken When the Fault Code is Active

  • N/A

Conditions for Clearing the Fault Code

  • N/A

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of the fault code include:

  • Restricted air intake filters
  • High compressor intake temperatures
  • An issue with one of the turbochargers
  • A closed intake air shut off valve.
Refer to Troubleshooting Fault Code t05-419.

Last Modified: 25-Jun-2015


Engine Oil Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level. Engine oil temperature 1 signal indicates engine oil temperature is above engine protection warning limit. | Severity based torque derate.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Engine Oil Temperature Sensor 1 Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Oil Temperature Sensor 1 Circuit
QSK50 CM2150 Power Generation - Engine Oil Temperature Sensor 1 Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Oil Temperature Sensor 1 Circuit
QSK50 and QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Oil Temperature Sensor 1 Circuit
QSK50 CM2150 Marine - Engine Oil Temperature Sensor 1 Circuit
QSK60 CM2150 Power Generation - Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor 1 is used by the electronic control module (ECM) to monitor the engine oil temperature. The ECM monitors the voltage on the engine oil temperature 1 signal pin and converts it to a temperature value. The engine oil temperature value is used by the ECM for the engine protection system, and for engine emissions control.

Component Location

The engine oil temperature sensor 1 is located in the oil pan adapter on the left bank.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code indicates that engine oil temperature has exceeded the engine protection limits for high engine oil temperature. Refer to the Fuel Temperature Above Normal troubleshooting tree in the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to the Fuel Temperature Above Normal troubleshooting tree in the QSK45 and QSK60 Service Manual, Bulletin 4021530.

Refer to Troubleshooting Fault Code 421.

Last Modified: 13-Dec-2010


SAE J1939 Data Link - Can Not Transmit

FAULT CODE 426

SAE J1939 Data Link - Can Not Transmit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: SPN: 639 FMI: 2 LAMP: None SRT: | SAE J1939 Data Link - Can Not Transmit. Communication between the ECM and another device on the SAE J1939 data link has been lost. | None on performance. SAE J1939 data link devices possibly do not operate.
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - SAE J1939 Data Link Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - SAE J1939 Data Link Circuit

Circuit Description

Devices such as vehicle electronic control module (ECM), automatic slip reduction systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The ECM is located on the intake side of the engine. The SAE J1939 data link wiring and the SAE J1939 data link devices vary by OEM options.

Shop Talk

This fault code only exists in Power Generation applications using multiplexed inputs, and will only go active if the ECM stops receiving Speed Bias, Alternate Frequency, or Idle/Rated information from the generator drive controller over the data link.

Refer to Troubleshooting Fault Code 426.

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 431
Fault Code Path Selection

Is an Integrated Sensor Switch (ISS) throttle pedal used? | Go to 122-fc431iss
Is an Nonintegrated Sensor Switch (NISS) throttle pedal used? | Go to 122-fc431niss

Last Modified: 15-Jan-2010


Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 431 (Integrated Sensor Switch)

Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect. Voltage detected simultaneously on both accelerator pedal or lever idle validation switch ON signal and accelerator pedal or lever idle validation switch OFF signal wires. | Engine will only idle.
QSK38 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Switch
QSK50 and QSK60 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Switch
QSK38 CM2150 Marine Propulsion - Accelerator Pedal or Lever Idle Validation Switch
QSK50 and QSK60 CM2150 Marine Propulsion - Accelerator Pedal or Lever Idle Validation Switch

Circuit Description

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever idle validation switch is released (on-idle) or depressed (off-idle). The accelerator pedal or lever idle validation switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The accelerator pedal or lever idle validation switch return has a shared return with other original equipment manufactured (OEM) cab switches.

Component Location

The integrated sensor switch (ISS) is located on the accelerator pedal or lever idle validation assembly.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is usually caused by an open circuit on either the accelerator pedal or lever idle validation ON switch or accelerator pedal or lever idle validation OFF switch signal circuit, a loose connection, uncalibrated accelerator pedal assembly, or mis-wired accelerator pedal or lever idle validation switch.

The integrated sensor switch has a different internal resistance specification (125 ohms) than the non-integrated sensor switch.

When installing a new accelerator pedal or lever idle validation assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.

Refer to Troubleshooting Fault Code 431 (Integrated Sensor Switch).

Last Modified: 13-Apr-2010


Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 431 (Nonintegrated Sensor Switch)

Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect. Voltage detected simultaneously on both accelerator pedal or lever idle validation switch ON and accelerator pedal or lever idle validation switch OFF. | Engine will only idle.
QSK38 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Switch
QSK50 and QSK60 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Switch
QSK38 CM2150 Marine Propulsion - Accelerator Pedal or Lever Idle Validation Switch
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Accelerator Pedal or Lever Idle Validation Switch

Circuit Description

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever idle validation switch is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal or lever position.

Component Location

The non-integrated sensor switch is located on the accelerator pedal or lever assembly.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is usually caused by an open circuit on either the idle validation on-idle or off-idle signal circuits, a loose connection, uncalibrated accelerator pedal assembly, or mis-wired accelerator pedal or lever idle validation switch.

The non-integrated sensor switch has a different internal resistance specification (10 ohms) than the integrated sensor switch.

When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position, then fully depress and release the pedal or lever three times.

Refer to Troubleshooting Fault Code 431 (Nonintegrated Sensor Switch).

Last Modified: 16-Jul-2010


Fault Code Path Selection

FAULT CODE 441
Fault Code Path Selection

Is the ECM source address 00? | Go to 122-fc441sa00
Is the ECM source address 01? | Go to 122-fc441sa01
Is the ECM source address 144? | Go to 122-fc441sa144

Last Modified: 26-Feb-2010


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441 (Source Address 00)

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine can stop running or be difficult to start.
QSK38 CM2150 Industrial - Unswitched Battery Supply
QSK38 CM2150 Marine - Unswitched Battery Supply
QSK38 CM2150 Power Generation - Unswitched Battery Supply
QSK38 CM2150 Power Generation (Military Application) - Unswitched Battery Supply
QSK50 CM2150 Industrial - Unswitched Battery Supply
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Unswitched Battery Supply
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Unswitched Battery Supply
QSK60 CM2150 Industrial - Unswitched Battery Supply
QSK60 CM2150 Power Generation - Unswitched Battery Supply

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is one 10-ampere fuse in the battery 1 voltage wires to protect the harness and ECM. The ECM receives switched battery input through the ignition wire when the ignition is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECMs are located on the left (fuel pump) side of the engine. ECM 1 is the front-most mounted ECM. ECM 2 is in the middle and ECM 3 is the rear-most mounted ECM. The ECMs are connected to the batteries by the OEM harness and the engine harness. This direct link provides a constant power supply for the ECMs. The location of the batteries will vary with the OEM. Refer to the OEM service manual for battery location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is logged when the ECM battery supply voltage drops below the minimum system voltage level.

  • Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM battery 1 voltage supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code 441 (Source Address 00).

Last Modified: 27-Sep-2010


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441 (Source Address 01)

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine can stop running or be difficult to start.
QSK38 CM2150 Industrial - Unswitched Battery Supply
QSK38 CM2150 Marine - Unswitched Battery Supply
QSK38 CM2150 Power Generation - Unswitched Battery Supply
QSK38 CM2150 Power Generation (Military Application) - Unswitched Battery Supply
QSK50 CM2150 Industrial - Unswitched Battery Supply
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Unswitched Battery Supply
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Unswitched Battery Supply
QSK60 CM2150 Industrial - Unswitched Battery Supply
QSK60 CM2150 Power Generation - Unswitched Battery Supply

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is one 10-ampere fuse in the battery 1 voltage wires to protect the harness and the ECM. The ECM receives switched battery input through the ignition wire when the ignition is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECMs are located on the left (fuel pump) side of the engine. ECM 1 is the front-most mounted ECM. ECM 2 is in the middle and ECM 3 is the rear-most mounted ECM. The ECMs are connected to the batteries by the OEM harness and engine harness. This direct link provides a constant power supply for the ECMs. The location of the batteries will vary with the OEM. Refer to the OEM service manual for battery location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is logged when the ECM battery supply voltage drops below the minimum system voltage level.

  • Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM battery 1 voltage supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code 441 (Source Address 01).

Last Modified: 27-Sep-2010


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441 (Source Address 144)

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine can stop running or be difficult to start.
QSK38 CM2150 Industrial - Unswitched Battery Supply
QSK38 CM2150 Marine - Unswitched Battery Supply
QSK38 CM2150 Power Generation - Unswitched Battery Supply
QSK38 CM2150 Power Generation (Military Application) - Unswitched Battery Supply
QSK50 CM2150 Industrial - Unswitched Battery Supply
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Unswitched Battery Supply
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Unswitched Battery Supply
QSK60 CM2150 Industrial - Unswitched Battery Supply
QSK60 CM2150 Power Generation - Unswitched Battery Supply

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is one 10-ampere fuse in the battery 1 voltage wires to protect the harness and the ECM. The ECM receives switched battery input through the ignition wire when the ignition is turned ON. The battery RETURN wires are connected directly to the negative (-) battery post.

Component Location

The ECMs are located on the left (fuel pump) side of the engine. ECM 1 is the front-most mounted ECM. ECM 2 is in the middle and ECM 3 is the rear-most mounted ECM. The ECMs are connected to the battery by the OEM harness and the engine harness. This direct link provides a constant power supply for the ECMs. The location of the batteries will vary with the OEM. Refer to the OEM service manual for battery location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is logged when the ECM battery supply voltage drops below the minimum system voltage level.

  • Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM battery 1 voltage supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code 441 (Source Address 144).

Last Modified: 27-Sep-2010


Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Above Normal Operating Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to all electrical components.
QSK38 CM2150 Industrial - Battery 1 Voltage Circuit
QSK38 CM2150 Marine - Battery 1 Voltage Circuit
QSK38 CM2150 Power Generation - Battery 1 Voltage Circuit
QSK38 CM2150 Power Generation (Military Application) - Battery 1 Voltage Circuit
QSK50 CM2150 Industrial - Battery 1 Voltage Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Battery 1 Voltage Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Battery 1 Voltage Circuit
QSK60 CM2150 Industrial - Battery 1 Voltage Circuit
QSK60 CM2150 Power Generation - Battery 1 Voltage Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 10-ampere fuse in the unswitched battery wire to protect the original equipment manufactured (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery 1 RETURN wires are connected directly to the negative (-) battery post.

Component Location

The QSK50 and the QSK60 engines each have 3 ECMs. ECMs are located on the left (fuel pump) side of the engine. ECM 1 is the front-most mounted ECM. The QSK38 engines have only 2 ECMs. The ECMs on the QSK38 engines are located on the left (fuel pump) side of the engine. ECM 1 is the front-most mounted ECM. ECM 2 is the rear-most mounted ECM. ECM 2 is in the middle and ECM 3 is the rear-most mounted ECM. The ECMs are connected to the batteries by the engine and OEM harnesses. This direct link provides a constant power supply for the ECM. The location of the batteries will vary with the OEM. Refer to the OEM service manual for battery location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is logged when the ECM battery 1 voltage exceeds 36-VDC.

Possible causes of this fault code include:

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code 442.

Last Modified: 27-Sep-2010


Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: SPN: 157 FMI: 0 LAMP: Red SRT: | Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level. ECM detects that injector metering rail 1 pressure has exceeded high-pressure relief valve. | Fuel injection noise.
QSK38 CM2150 Industrial - Injector Metering Rail 1 Circuit
QSK38 CM2150 Marine - Injector Metering Rail 1 Circuit
QSK38 CM2150 Power Generation (Military Application)/QSK38 CM2150 Power Generation - Injector Metering Rail 1 Circuit
QSK50 CM2150 Industrial - Injector Metering Rail 1 Circuit
QSK50 CM2150 Marine - Injector Metering Rail 1 Pressure Circuit
QSK60 CM2150 Industrial - Injector Metering Rail 1 Pressure Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Metering Rail 1 Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Metering Rail 1 Pressure Circuit

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the gerotor pump. The electronic control module (ECM) monitors the injector metering rail 1 pressure and the engine operating conditions, and changes the flow command to maintain the proper injector metering rail 1 pressure. Changes to the flow command result in opening or closing of the fuel pump pressurizing assembly 1.

The high-pressure relief valve is set to trip at 1950 bar [28,282 psi]. After it trips, it then regulates at 900 to 1300 bar [13,053 to 18,854 psi].

NOTE: The mechanical dump valve has not popped.

Component Location

The high-pressure fuel pump is mounted to the gear housing on the left side of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

NOTE: Replace the high-pressure mechanical dump valve even if the fault clears.

Refer to Troubleshooting Fault Code 449.

Last Modified: 13-Dec-2010


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: SPN: 157 FMI: 3 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High SIGNAL voltage detected at injector metering rail 1 pressure circuit. | Power and/or speed derate.
QSK38 CM2150 Industrial - Injector Metering Rail 1 Circuit
QSK38 CM2150 Marine - Injector Metering Rail 1 Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Injector Metering Rail 1 Circuit
QSK50 CM2150 Industrial - Injector Metering Rail 1 Circuit
QSK50 CM2150 Marine - Injector Metering Rail 1 Pressure Circuit
QSK60 CM2150 Industrial - Injector Metering Rail 1 Pressure Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Metering Rail 1 Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Metering Rail 1 Pressure Circuit

Circuit Description

The injector metering rail 1 pressure sensor is used by the electronic control module (ECM) to monitor the fuel pressure in the fuel pump accumulator. The sensor receives a 5 volt SUPPLY from the ECM and is grounded by a injector metering rail 1 pressure RETURN (sensor RETURN 2) pin. A third pin is the injector metering rail 1 pressure SIGNAL pin. The injector metering rail 1 pressure 5 volt SUPPLY (sensor SUPPLY 2) pin and injector metering rail 1 pressure RETURN (sensor RETURN 2) pin are shared with other devices on the engine.

Component Location

The injector metering rail 1 pressure sensor is installed in the fuel pump accumulator.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code will become active if there is an open circuit on any of the 3 pins (5-VDC SUPPLY, SIGNAL, or RETURN) that connect the injector metering rail 1 pressure sensor or ECM to the engine wiring harness. This fault will also be active if the injector metering rail 1 pressure SIGNAL wire is shorted to a source of voltage. This fault code will become inactive any time the keyswitch is ON and the SIGNAL returns to a valid in-range voltage.

Possible causes for this fault code include:

  • Voltage (5-VDC or higher shorted to the SIGNAL wire)
  • Open circuit on the SIGNAL wire
  • Open circuit on the 5-VDC SUPPLY wire
  • Open circuit on the RETURN wire
  • Damaged sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 451.

Last Modified: 17-Sep-2010


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: SPN: 157 FMI: 4 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low SIGNAL voltage detected at the injector metering rail 1 pressure sensor circuit. | Power and/or speed derate.
QSK38 CM2150 Industrial - Injector Metering Rail 1 Circuit
QSK38 CM2150 Marine - Injector Metering Rail 1 Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Injector Metering Rail 1 Pressure Circuit
QSK50 CM2150 Industrial - Injector Metering Rail 1 Circuit
QSK50 CM2150 Marine - Injector Metering Rail 1 Pressure Circuit
QSK60 CM2150 Industrial - Injector Metering Rail 1 Pressure Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Metering Rail 1 Pressure Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Metering Rail 1 Pressure Circuit

Circuit Description

The injector metering rail 1 pressure sensor is used by the electronic control module (ECM) to monitor the fuel pressure in the fuel pump accumulator. The sensor receives a 5 volt SUPPLY from the ECM and is grounded by a injector metering rail 1 pressure RETURN (sensor RETURN 2) pin. A third pin is the injector metering rail 1 pressure SIGNAL pin. The injector metering rail 1 pressure 5 volt SUPPLY (sensor SUPPLY 2) pin and injector metering rail 1 pressure RETURN (sensor RETURN 2) pin are shared with other devices on the engine.

Component Location

The injector metering rail 1 pressure sensor is installed in the fuel pump accumulator.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code will become active any time the keyswitch is ON and the SIGNAL pin of the ECM is too low. This can be caused by a short circuit to ground on the injector metering rail 1 pressure 5 volt SUPPLY (sensor SUPPLY 2) or injector metering rail 1 SIGNAL wire. This fault will also become active if a device that is powered by the common -VDC power SUPPLY is shorted to ground. This fault code will become inactive any time the keyswitch is ON and the SIGNAL returns to a valid in-range voltag.

Possible causes for this fault code include:

  • Engine harness SUPPLY or SIGNAL wire is shorted to ground
  • Component connected to the common power SUPPLY is shorted to ground
  • Damaged sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 452.

Last Modified: 17-Sep-2010


Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4615

Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4615 PID: SPN: 94 FMI: 0/0 LAMP: Amber SRT: | Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. Fuel pump supply pressure very high. | Possible engine speed derate. Low power or engine smoke.
QSK38 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 Power Generation (Military Application) - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring and QSK60 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the engine control module (ECM) to monitor fuel delivery pressure directly before the Stage 2 filter. The ECM monitors the voltage on the fuel delivery pressure SIGNAL pin and converts it to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the Stage 2 fuel filter head.

Conditions for Running the Diagnostics

  • The engine speed must be above 500 RPM for 10 seconds, and fueling must be above 20 mg/stk for 5 seconds before a diagnostic decision begins to be made.
  • The fuel temperature must be greater than, or equal to -10 ⁰C

Conditions for Setting the Fault Codes

When the fuel supply pressure is greater than 1200 kPa (174 psi) for more than 3 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostics detects high fuel supply pressure.
  • This fault code also activates an engine speed derate (1500 RPM) that attempts to bring down the fuel supply pressure at or below 1000 kPa. The speed derate is progressive and it is possible that the engine speed may pause above 1500 RPM if the derate is successful at bringing fuel supply pressure below 1000 kPa.

Conditions for Clearing the Fault Code

FC4615 is a latching fault code. The diagnostic only clears errors if the fuel supply pressure is below 850 kPa. Once the fault code is invoked, the only way to clear it would be to perform the following steps:

  • Turn off engine and follow the troubleshooting steps for resolution.
  • Restart engine, and run the engine at rated for a few minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Stage 2 fuel filter restriction high
  • Pinched or damaged fuel supply line
  • Stuck gerotor pump fuel pressure regulator located in high-pressure pump.
Refer to Troubleshooting Fault Code 4615.

Last Modified: 25-Apr-2017


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4642

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4642 PID: SPN: 97 FMI: 0 LAMP: Red SRT: | Water in Fuel Indicator - Data Valid But Above Normal Operating Rage - Most Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting. Engine derate will occur on marine engines if optional engine protection feature is enabled.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine with C Command™ Panel System - Water in Fuel Indicator Sensor Circuit
QSK38 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Water in Fuel Indicator Sensor Circuit
QSK50 CM2150 Industrial - Water in Fuel Indicator Sensor Circuit
QSK38 CM2150 Power Generation and QSK38 CM2150 Power Generation (Military Application) - Water in Fuel Indicator Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Water in Fuel Indicator Sensor Circuit
QSK50 and QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Water in Fuel Indicator Sensor Circuit
QSK60 CM2150 Industrial - Water in Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator sensor is attached to the first stage fuel filter. The water in fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator sensor circuit contains two wires; a water in fuel indicator return (sensor return 1) ground wire and a water in fuel indicator signal wire.

Component Location

The water in fuel indicator sensor is integrated into the first stage fuel filter housing which is mounted off-engine. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • On Marine Propulsion engines, if the optional engine protection feature has been enabled, a speed derate will occur.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

Drain the Stage 1 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active and there is no water in the fuel filter then a malfunctioning water in fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code t05-4642.

Last Modified: 25-Sep-2015


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4688

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4688 PID: SPN: 97 FMI: 3 LAMP: Maintenance SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water in fuel indicator circuit. | None on performance. No water in fuel warning available.
Water in Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator sensor is fitted by the original engine manufacturer (OEM). The water in fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator sensor circuit contains two wires: a water in fuel indicator RETURN (sensor return 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator sensor is mounted by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. . When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-4688.

Last Modified: 02-Jan-2017


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4689

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4689 PID: SPN: 97 FMI: 4 LAMP: Maintenance SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water in fuel indicator sensor circuit. | None on performance. No water in fuel warning available.
Water in Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator sensor is installed by the original equipment manufacturer (OEM). The water in fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator sensor circuit contains two wires: a water in fuel indicator RETURN (sensor return 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator sensor is mounted by the OEM. See equipment manufacturer service information.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM or circuit is affected.

Possible causes for this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
Refer to Troubleshooting Fault Code t05-4689.

Last Modified: 12-Dec-2016


Exhaust Gas Temperature Bank Imbalance - Data Erratic, Intermittent, or Incorrect

FAULT CODE 479

Exhaust Gas Temperature Bank Imbalance - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 479 PID: SPN: 1318 FMI: 2 LAMP: Amber SRT: | Exhaust Gas Temperature Bank Imbalance - Data Erratic, Intermittent, or Incorrect. Exhaust gas temperature bank-to-bank imbalance. | Possible engine shutdown.
Electronic Control Module (ECM)

Circuit Description

The exhaust gas temperature sensor monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor is located in the exhaust manifold at the cylinder head to exhaust manifold interface.

Shop Talk

Fault Code 479 is associated with low power and is triggered when there is a significant difference between the average EGT on the left bank versus the right bank.

Possible causes of this fault code include:

  • Intake manifold leak
  • Valve lash
  • Clogged air cleaner
  • Turbocharger damage
  • Air shutoff valve damage
  • Flow limiter tripped on one or more injectors.

If no damage is found by following this troubleshooting tree, see the Engine Performance Troubleshooting Tree in Section TT.

Refer to Troubleshooting Fault Code 479.

Last Modified: 13-Apr-2010


Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: SPN: 105 FMI: 16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level. Intake manifold 1 temperature above engine protection limit. | For Industrial applications: Calibration dependent progressive power derate and engine shutdown with increasing time after alert. For Power Generation applications: Calibration dependent. Possible engine shutdown. For Marine applications: Calibration dependent. Possible engine shutdown.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Intake Manifold 1 Temperature Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Intake Manifold 1 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Intake Manifold 1 Temperature Sensor Circuit
QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 1 Temperature Sensor Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 1 Temperature Sensor Circuit
QSK60 CM2150 Power Generation - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The intake manifold 1 temperature sensor is located in the left bank front air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold. Possible causes of this fault code include:

  • Restricted air flow through the aftercooler
  • Coolant restriction on the aftercooler
  • High turbocharger compressor outlet temperature
  • Restricted sea water flow through the heat exchanger on Marine applications.
Refer to Troubleshooting Fault Code 488.

Last Modified: 13-Dec-2010


Transmission Output Shaft Speed - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 489

Transmission Output Shaft Speed - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 489 PID: SPN: 191 FMI: 18 LAMP: Amber SRT: | Transmission Output Shaft Speed - Data Valid but Below Normal Operating Range - Moderately Severe Level. External speed command input signal indicates the frequency is below a calibration dependent threshold. | ECM changes engine speed to a calibration - dependent set point.
QSK38 CM2150 Industrial - External Speed Command Input Circuit
QSK38 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - External Speed Command Input Circuit
QSK38 CM2150 Marine Propulsion with C Command™ Panel System - External Speed Command Input Circuit
QSK50 and QSK60 CM2150 Industrial - External Speed Command Input Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - External Speed Command Input Circuit
QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ Panel System - External Speed Command Input Circuit

Circuit Description

The external speed command input is a frequency signal from an auxiliary speed or pressure pickup. It is sent to the electronic control module (ECM) and is used to control the engine speed. Auxiliary reference speed is based on the accelerator position.

Component Location

The transmission output shaft or pressure pickup device location is dependent on the original equipment manufacturer (OEM) application. Refer to the OEM service manual for a detailed component location view.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The transmission output shaft governor controls engine speed based on a measured auxiliary speed or pressure.

Refer to Troubleshooting Fault Code 489.

Last Modified: 13-Dec-2010


Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 497

Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 497 PID: SPN: 1377 FMI: 2 LAMP: Amber SRT: | Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect | Multiple unit synchronization switch feature is disabled.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine Propulsion with C Command™ Panel System - Multiple Unit Synchronization Switch
QSK38 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Multiple Unit Synchronization Switch
QSK50 and QSK60 CM2150 Marine Propulsion with C Command™ Panel System - Multiple Unit Synchronization Switch
QSK50 and QSK60 CM2150 Industrial/QSK50 and QSK60 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Multiple Unit Synchronization Switch

Circuit Description

The multiple unit synchronization switch uses a complimentary switch to provide two opposite signals into the electronic control module (ECM).

Component Location

Refer to the OEM service manual for specific location.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault occurs when both switches have the same state, i.e. both are open or closed. Check that the switches are set at different states before troubleshooting this fault.

Refer to Troubleshooting Fault Code 497.

Last Modified: 30-Mar-2010


Fuel Pump Oil Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5119

Fuel Pump Oil Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5119 PID: SID(S) SPN: 520754 FMI: 3/3 LAMP: Amber SRT: SRT: | High signal voltage detected at fuel pump oil pressure sensor circuit. | None on performance.
Engine Fuel Pump Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-volt supply to the engine fuel pump oil pressure sensor on the sensor

supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel pump oil pressure sensor

provides a signal to the ECM on the engine fuel pump oil pressure sensor signal circuit. This sensor signal voltage

changes based on the pressure in the oil flow path. The ECM will detect a low signal voltage at operating conditions

when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or

operating conditions when the oil pressure is high.

Component Location

The engine fuel pump oil pressure sensor is located in the engine fuel pump oil filter head mounted to the top of the

fuel pump adapter drive. Certain engines may have the filter head mounted remotely.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pump oil pressure signal voltage is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

• A default value for the fuel pump oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • A signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-5119.

Last Modified: 16-Apr-2020


Fuel Pump Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5121

Fuel Pump Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5121 PID: SID(S) SPN: 520754 FMI: 4/4 LAMP: LAMP: Amber SRT: | Low signal voltage or open circuit detected at the fuel pump oil pressure circuit. | None on performance.
Engine Fuel Pump Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-volt supply to the engine fuel pump oil pressure sensor on the sensor

supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel pump oil pressure sensor

provides a signal to the ECM on the engine fuel pump oil pressure sensor signal circuit. This sensor signal voltage

changes based on the pressure in the oil flow path. The ECM will detect a low signal voltage at operating conditions

when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or

operating conditions when the oil pressure is high.

Component Location

The engine fuel pump oil pressure sensor is located in the engine fuel pump oil filter head mounted to the top of the

fuel pump adapter drive. Certain engines may have the filter head mounted remotely.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel pump oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-5121.

Last Modified: 16-Apr-2020


Transmission Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 521

Transmission Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 521 PID: SPN: 175 FMI: 3 LAMP: Amber SRT: | Transmission (Gear) Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at transmission (gear) oil temperature sensor circuit. | No engine protection for transmission oil temperature.
Transmission (Gear) Oil Temperature Sensor Circuit

Circuit Description

The transmission (gear) oil temperature sensor is used by the engine control module (ECM) to monitor the transmission oil temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The transmission (gear) oil temperature sensor is located in the transmission.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Before troubleshooting Fault Code 521, check for multiple faults.

The transmission (gear) oil temperature sensor share RETURN wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes for this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 521.

Last Modified: 07-Dec-2016


Transmission Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 522

Transmission Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 522 PID: SPN: 175 FMI: 4 LAMP: Amber SRT: | Transmission Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at transmission (gear) oil temperature circuit. | No engine protection for transmission oil temperature.
Transmission (Gear) Oil Temperature Sensor Circuit

Circuit Description

Transmission (gear) oil temperature sensor is used by the engine control module (ECM) to monitor the transmission oil temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The transmission (gear) oil temperature sensor is located in the transmission.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The transmission (gear) oil temperature sensor shares RETURN wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 522, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 522.

Last Modified: 02-Jan-2017


Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 527

Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 527 PID: SPN: 702 FMI: 3 LAMP: Amber SRT: | Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source. The auxiliary input/output 2 signal pin of the engine harness indicates an open or short circuit. | No action taken by ECM.
QSK38 CM2150 Industrial - Auxiliary Input/Output 2 Circuit
QSK38 CM2150 Marine Proplusion - Auxiliary Input/Output 2 Circuit
QSK50 and QSK60 CM2150 Industrial - Auxiliary Input/Output 2 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion - Auxiliary Input/Output 2 Circuit

Circuit Description

The ECM provides a signal to the orginal equipment manufacturer (OEM) output control circuit to turn the OEM supplied accessory on and off. The OEM output control circuit varies by OEM. Certain OEMs can use a circuit return that is wired to the ECM or goes to the engine block or chassis ground.

Component Location

The output control circuit driver is an OEM device and the location of the circuit driver is dependent upon the OEM. Refer to the OEM service manual.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The ECM monitors the voltage level on this circuit. When the ECM commands the OEM output signal low, it expects the voltage level to be approximately 0- VDC. If it detects a high voltage, this fault is recorded. If Fault Code 527 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the OEM output device for an open circuit or short to ground. Possible causes of this fault include:

  • Open circuit in the engine harness
  • Damaged ECM.
Refer to Troubleshooting Fault Code 527.

Last Modified: 19-Jul-2010


Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 529

Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 529 PID: SPN: 703 FMI: 3 LAMP: Amber SRT: | Auxiliary Input/Output 3 Circuit Voltage Above Normal or Shorted to High Source. The auxiliary input/output 3 SIGNAL pin of the engine harness indicates an open or short circuit. | No action taken by ECM.
QSK38 CM2150 Industrial - Auxiliary Input/Output 3 Circuit
QSK38 CM2150 Marine Propulsion - Auxiliary Input/Output 3 Circuit
QSK50 and QSK60 CM2150 Industrial - Auxiliary Input/Output 3 Circuit
QSK50 and QSK60 CM2150 Marine Propulsion - Auxiliary Input/Output 3 Circuit

Circuit Description

The electronic control module (ECM) provides a signal to the OEM output control circuit to turn the OEM-supplied accessory on and off. The OEM output control circuit varies by OEM. Certain OEMs can use a circuit return that is wired to the ECM or goes to the engine block or chassis ground.

Component Location

The output control circuit driver is an OEM device and the location of the circuit is dependent upon the OEM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The ECM monitors the voltage level on this circuit. When the ECM commands the OEM output signal low, it expects the voltage level to be approximately 0-VDC. If it detects a high voltage, this fault is recorded. If Fault Code 529 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the OEM output device for an open circuit or short to ground. Possible causes of this fault include:

  • Open circuit in the engine harness
  • Short circuit to voltage source in the OEM harness
  • Damaged ECM.
Refer to Troubleshooting Fault Code 529.

Last Modified: 14-Apr-2010


Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5366

Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5366 PID: SPN: 6301 FMI: 16 LAMP: Amber SRT: | Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting. Engine derate will occur on Marine engines if optional engine protection feature is enabled.
Water In Fuel 2 Indicator Sensor Circuit

Circuit Description

The water in fuel indicator 2 sensor is attached to the Stage 0 (original equipment manufacturer (OEM)) fuel filter for Marine applications. The water in fuel indicator 2 sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator 2 sensor circuit contains two wires; a water in fuel indicator RETURN (sensor RETURN 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator 2 sensor is installed as an option into the Stage 0 (OEM) fuel filter housing which is mounted off-engine. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Water in the fuel can do extensive damage to the fuel system due to the tight tolerances of the fuel system components.

Drain the Stage 0 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active and there is no water in the fuel filter, then a malfunctioning water in fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code 5366.

Last Modified: 02-Jan-2017


Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 5367

Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4642 PID: SPN: 6301 FMI: 0 LAMP: Red SRT: | Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Most Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting. Engine derate will occur on Marine engines if optional engine protection feature is enabled.
Water In Fuel 2 Indicator Sensor Circuit

Circuit Description

The water in fuel indicator 2 sensor is attached to the Stage 0 (original equipment manufacturer (OEM)) fuel filter for Marine applications. The water in fuel indicator 2 sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator 2 sensor circuit contains two wires; a water in fuel indicator RETURN (sensor RETURN 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator 2 sensor is installed as an option into the Stage 0 (OEM) fuel filter housing which is mounted off-engine. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Water in the fuel can do extensive damage to the fuel system due to the tight tolerances of the fuel system components.

Drain the Stage 0 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active and there is no water in the fuel filter, then a malfunctioning water in fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code 5367.

Last Modified: 02-Jan-2017


Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 546

Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: SPN: 94 FMI: 3 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No action taken by the ECM.
QSK38 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor monitors the inlet fuel pressure and passes information to the ECM through the engine harness.

Component Location

The fuel delivery pressure sensor is located above the second stage fuel filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The fuel delivery pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 546, check for multiple fault codes.

Possible causes of this fault include:

  • Open RETURN circuit in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 546.

Last Modified: 17-Sep-2010


Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 547

Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: SPN: 94 FMI: 4 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit Voltage Below Normal or Shorted to Low Source. | No action taken by the ECM.
QSK38 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor monitors the inlet fuel pressure and passes information to the ECM through the engine harness.

Component Location

The fuel delivery pressure sensor is located above the second stage fuel filter head.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The fuel delivery pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 547, check for multiple fault codes.

Possible causes of this fault include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 547.

Last Modified: 17-Sep-2010


Crankcase Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: SPN: 101 FMI: 0 LAMP: Red SRT: | Crankcase Pressure - Data Valid but Above Normal Operating Range - Most Severe Level | Ramps to full derate in 20 seconds.
QSK38 CM2150 Industrial - Crankcase Pressure Sensor Circuit
QSK38 CM2150 Marine - Crankcase Pressure Sensor Circuit
QSK38 CM2150 Power Generation - Crankcase Pressure Sensor Circuit
QSK38 CM2150 Power Generation (Military Application) - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Industrial - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Crankcase Pressure Sensor Circuit
QSK50 CM2150 Marine - Crankcase Pressure Sensor Circuit
QSK60 CM2150 Industrial - Crankcase Pressure Sensor Circuit
QSK60 CM2150 Power Generation - Crankcase Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used by the ECM to monitor the engine crankcase pressure. The ECM monitors the voltage on the crankcase pressure signal pin and converts it to a pressure value. The crankcase pressure value is used by the ECM for the engine protection system.

Component Location

The QSK38 crankcase pressure sensor is located in the left bank under the number 3 cylinder. The QSK60 crankcase pressure sensor is located in the right bank front head deck. The QSK50 crankcase pressure sensor is located in a right bank hand hole cover, under the number 6 cylinder.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The crankcase pressure sensor is used in the engine protection section of the calibration. When the ECM detects that the crankcase pressure is above the engine protection limit in the calibration for at least 5 seconds, it will log Fault Code 556 and light a red lamp, indicating that the engine can be shut down.

Possible causes of this fault code include:

  • Damaged piston rings
  • Oil level too high
  • Damaged turbocharger seals
  • Damaged power cylinder
  • Damaged air compressor piston rings.

Confirm that the crankcase breathers and breather tubes are not obstructed.

Refer to Troubleshooting Fault Code 556.

Last Modified: 13-Dec-2010


Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: SPN: 157 FMI: 1/18 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid - but Below Normal Operating Range - Moderately Severe Level. The ECM has detected that the fuel pressure is lower than commanded. | Low Power, possible shutdown, or no start.
QSK38 CM2150 Industrial - Injector Metering Rail 1 Pressure Circuit
QSK38 CM2150 Marine - Injector Metering Rail 1 Pressure Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Injector Metering Rail 1 Pressure Circuit
QSK50 CM2150 Industrial - Injector Metering Rail 1 Pressure Circuit
QSK50 CM2150 Marine - Injector Metering Rail 1 Pressure Circuit
QSK60 CM2150 Industrial - Injector Metering Rail 1 Pressure Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring/QSK60 CM2150 Power Generation - Injector Metering Rail 1 Pressure Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Injector Metering Rail 1 Pressure Circuit

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the gerotor pump. The ECM monitors the injector metering rail 1 pressure and engine operating conditions, and changes the flow command to maintain the proper injector metering rail 1 pressure. Changes to the flow command result in opening or closing of the fuel pump pressurizing assembly 1.

Component Location

The high-pressure fuel pump is mounted to the front gear housing on the left bank of the engine.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Fuel inlet restriction
  • Fuel filter plugging
  • Gerotor pump output low
  • Gerotor pump pressure regulator sticking or leaking
  • High-pressure pump capacity decay
  • Mechanical dump valve leaks to drain
  • Mechanical dump valve opens at low pressure
  • High-pressure injector supply line inner wall leak
  • Malfunctioning fuel pump pressurizing assembly.
Refer to Troubleshooting Fault Code 559.

Last Modified: 17-Sep-2010


Fault Code Path Selection

FAULT CODE 5633
Fault Code Path Selection

Is engine used for propulsion application? | Go to 122-fc5633prop
Is engine used for auxiliary application? | Go to 122-fc5633aux

Last Modified: 07-Nov-2016


Marine Low Load Protection - Condition Exists

FAULT CODE 5633 (Auxiliary)

Marine Low Load Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5633 PID: SPN: 520891 FMI: 31 LAMP: Maintenance SRT: | Marine Low Load Protection - Condition Exists. Low load condition has been detected by the engine control module (ECM). | None on performance.

Circuit Description

Marine Low Load Protection monitors the engine operating in a low load condition of less than 15 percent of rated torque. This feature is needed to limit engine exposure in such working conditions by alerting the operator.

Component Location

Not Applicable

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque falls below the low load threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the low load region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in a normal operating region during a sea trial.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the white MAINTENANCE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • This is an information-only fault code that becomes active if the engine torque falls below the low load threshold for a calibratable time.
  • High counts of inactive Fault Code 5633 can indicate the engine is often operated beyond the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.
  • No repairs are necessary.
Refer to Troubleshooting Fault Code 5633.

Last Modified: 02-Nov-2016


Marine Low Load Protection - Condition Exists

FAULT CODE 5633 (Propulsion)

Marine Low Load Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5633 PID: SPN: 520891 FMI: 31 LAMP: Maintenance SRT: | Marine Low Load Protection - Condition Exists. Low load condition has been detected by the engine control module (ECM). | None on performance.

Circuit Description

Marine Low Load Protection monitors the engine operating in a low load condition of less than 15 percent of rated torque. This feature is needed to limit engine exposure in such working conditions by alerting the operator.

Component Location

Not Applicable

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque falls below the low load threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the low load region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in the normal operating region during a sea trial.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the white MAINTENANCE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • This is an information-only fault code that becomes active if the engine torque falls below the low load threshold for a calibratable time.
  • High counts of inactive Fault Code 5633 can indicate the engine is often operated below the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.
  • No repairs are necessary.
Refer to Troubleshooting Fault Code 5633.

Last Modified: 03-Nov-2016


Fault Code Path Selection

FAULT CODE 5634
Fault Code Path Selection

Is engine used for propulsion application? | Go to 122-fc5634prop
Is engine used for auxiliary application? | Go to 122-fc5634aux

Last Modified: 06-Oct-2015


Marine Overload Protection - Condition Exists

FAULT CODE 5634

Marine Overload Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5634 PID: SPN: 520892 FMI: 31 LAMP: Amber SRT: | Marine Overload Protection - Condition Exists. Overload condition has been detected by the engine control module (ECM). | None on performance.
Typical Overload Region for Auxiliary Application

Circuit Description

X - Engine Speed

Y - Torque

1 - Fuel Limited Torque Curve

2 - Overload Region

3 - 100 Percent Torque

4 - 110 Percent Torque.

The shaded region in the graph above corresponds to the calibratable overload region. Marine Overload Protection monitors the engine operating in an overload condition. This feature is needed to limit engine exposure in such working conditions by alerting the operator and, in some cases, by limiting fueling to the engine.

Component Location

N/A

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque exceeds the overload threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the overload region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in the normal operating region for more than a calibratable time.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This is an information-only fault code that becomes active if the engine torque exceeds the overload threshold for a calibratable time.

High counts of inactive Fault Code 5634 can indicate the engine is often operated beyond the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.

No repairs are necessary.

Reference the Marine Application Bulletin – 0.19.00 – Electronic Engine Controls for more information on this diagnostic.

Refer to Troubleshooting Fault Code 5634.

Last Modified: 30-Sep-2015


Marine Overload Protection - Condition Exists

FAULT CODE 5634

Marine Overload Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5634 PID: SPN: 520892 FMI: 31 LAMP: Amber SRT: | Marine Overload Protection - Condition Exists. Overload condition has been detected by the engine control module (ECM). | None on performance.
Typical Overload Region for Propulsion Application

Circuit Description

X - Engine Speed

Y - Torque

1 - Fuel Limited Torque Curve

2 - Propeller Curve

3 - Overload Region.

The shaded region in the graph above corresponds to the calibratable overload region. Marine Overload Protection monitors the engine operating in an overload condition. This feature is needed to limit engine exposure in such working conditions by alerting the operator.

Component Location

N/A

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque exceeds the overload threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the overload region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in the normal operating region for more than a calibratable time.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • This is an information-only fault code that becomes active if the engine torque exceeds the overload threshold for a calibratable time.
  • High counts of inactive Fault Code 5634 can indicate the engine is often operated beyond the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.
  • No repairs are necessary.
  • Reference the Marine Application Bulletin – 0.19.00 – Electronic Engine Controls for more information on this diagnostic.
Refer to Troubleshooting Fault Code 5634.

Last Modified: 05-Oct-2015


Fault Code Path Selection

FAULT CODE 5635
Fault Code Path Selection

Is engine used for propulsion application? | Go to 122-fc5635prop
Is engine used for auxiliary application? | Go to 122-fc5635aux

Last Modified: 06-Oct-2015


Marine Overload Protection - Special Instructions

FAULT CODE 5635

Marine Overload Protection - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5635 PID: SPN: 520892 FMI: 14 LAMP: Amber SRT: | Marine Overload Protection - Special Instructions. Overload condition has been detected by the engine control module (ECM). | Reduction in engine torque.
Typical Overload Region for Auxiliary Application

Circuit Description

X - Engine Speed

Y - Torque

1 - Fuel Limited Torque Curve

2 - Overload Region

3 - 100 Percent Torque

4 - 110 Percent Torque.

The shaded region in the graph above corresponds to the calibratable overload region. Marine Overload Protection monitors the engine operating in an overload condition. This feature is needed to limit engine exposure in such working conditions by alerting the operator and, in some cases, by limiting fueling to the engine.

Component Location

N/A

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque exceeds the overload threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the overload region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in the normal operating region for more than a calibratable time.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This is an information-only fault code that becomes active if the engine torque exceeds the overload threshold for a calibratable time.

High counts of inactive Fault Code 5635 can indicate the engine is often operated beyond the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.

No repairs are necessary.

Reference the Marine Application Bulletin – 0.19.00 – Electronic Engine Controls for more information on this diagnostic.

Refer to Troubleshooting Fault Code 5635.

Last Modified: 30-Sep-2015


Marine Overload Protection - Special Instructions

FAULT CODE 5635

Marine Overload Protection - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5635 PID: SPN: 520892 FMI: 14 LAMP: Amber SRT: | Marine Overload Protection - Special Instructions. Overload condition has been detected by the engine control module (ECM). | None on performance.
Typical Overload Region for Propulsion Application

Circuit Description

X - Engine Speed

Y - Torque

1 - Fuel Limited Torque Curve

2 - Propeller Curve

3 - Overload Region.

The shaded region in the graph above corresponds to the calibratable overload region. Marine Overload Protection monitors the engine operating in an overload condition. This feature is needed to limit engine exposure in such working conditions by alerting the operator.

Component Location

N/A

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque exceeds the overload threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the overload region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in the normal operating region for more than a calibratable time.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • This is an information-only fault code that becomes active if the engine torque exceeds the overload threshold for a calibratable time.
  • High counts of inactive Fault Code 5635 can indicate the engine is often operated beyond the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.
  • No repairs are necessary.
  • Reference the Marine Application, Bulletin – 0.19.00 – Electronic Engine Controls, for more information on this diagnostic.
Refer to Troubleshooting Fault Code 5635.

Last Modified: 09-Sep-2015


Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5932

Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5932 PID: SPN: 6301 FMI: 15 LAMP: Maintenance SRT: | Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Rage - Least Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
Water in Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator 2 sensor is attached to the Stage 0 original equipment manufacturer (OEM) fuel filter for Marine applications. The water in fuel indicator 2 sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator 2 sensor circuit contains two wires; a water in fuel indicator return (sensor RETURN 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator 2 sensor is installed as an option into the Stage 0 (OEM) fuel filter housing which is mounted off-engine. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected water in fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

Drain the Stage 0 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active and there is no water in the fuel filter, a malfunctioning water in fuel sensor or water in the sensor connector could be causing the fault

Refer to Troubleshooting Fault Code 5932.

Last Modified: 12-Dec-2016


Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5946

Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5946 PID: SPN: 175 FMI: 0 LAMP: Red SRT: | Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The transmission (or gearbox) oil temperature sensor indicates the transmission (or gearbox) oil temperature is above the protection limit. | No engine protection for engine oil temperature.
Engine Oil Temperature 1 Sensor Circuit

Circuit Description

The transmission (or gearbox) oil temperature sensor is used by the engine control module (ECM) to monitor the transmission oil temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The transmission (or gearbox) oil temperature sensor is located in the transmission.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code indicates that the transmission (or gearbox) temperature has exceeded the protection limits for high transmission (or gearbox) temperature.

Refer to Troubleshooting Fault Code 5946.

Last Modified: 03-Jan-2017


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 595

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 0/16 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level. High turbocharger speed has been detected by the engine control module (ECM). | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The ECM interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detected the turbocharger speed was greater than 150,000 rpm for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will estimate turbocharger speed.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and use the accelerator pedal to accelerate the engine speed to high idle (100 percent). Hold the engine speed at high idle for at least 20 seconds.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
  • Damaged ECM.

If the fault occurs intermittently, look for causes of intermittent open or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code t05-595.

Last Modified: 09-Oct-2017


Auxiliary Commanded Dual Output Shutdown - Special Instructions

FAULT CODE 599

Auxiliary Commanded Dual Output Shutdown - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 599 PID: SPN: 640 FMI: 14 LAMP: Red SRT: | Auxiliary Commanded Dual Output Shutdown - Special Instructions. The engine protection limit has exceeded for the calibrated limits. | Engine will shut down.
QSK38 CM2150 Industrial - Auxiliary Commanded Dual Output Shutdown
QSK38 CM2150 Marine Propulsion - Auxiliary Commanded Dual Output Shutdown
QSK50 and QSK60 CM2150 Industrial - Auxiliary Commanded Dual Output Shutdown
QSK50 and QSK60 CM2150 Marine Propulsion/QSK60 CM2150 Drill Rig - Auxiliary Commanded Dual Output Shutdown

Circuit Description

The ECM receives monitored inputs from various sensors on the engine and from OEM inputs. If the parameters exceed a calibrated limit, Fault Code 599 goes active and the engine shuts down.

Component Location

The calibrations are loaded inside the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is activated when one of the OEM defined inputs has exceeded a calibrated limit. The triggers for shutdown are OEM dependent. The parameters that can be used for the dual output feature are the following:

  • Engine speed
  • Fuel command
  • Boost pressure
  • Auxiliary speed input
  • Oil pressure
  • Coolant temperature
  • Fuel temperature
  • Command throttle
  • OEM temperature
  • OEM pressure
  • OEM supplied switch
  • ISC 2 status
  • Intake manifold temperature
  • Battery voltage
  • Engine torque.
Refer to Troubleshooting Fault Code 599.

Last Modified: 13-Apr-2010


Engine Shut Down Hot - Condition Exists

FAULT CODE 611

Engine Shut Down Hot - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 611 PID: SPN: 1383 FMI: 31 LAMP: None SRT: | Engine Shut Down Hot - Condition Exists. The engine was shut down with the keyswitch before proper engine cool down, resulting in a load factor above the maximum shut down threshold. | No action taken by ECM. Possible loss of performance. Possible damage to the engine can occur. Fault code will be logged.
Electronic Control Module (ECM)

Circuit Description

Not applicable for this fault code.

Component Location

The ECM(s) are located on the fuel pump side of the engine. The QSK38 has two ECMs. The QSK50 and QSK60 each have three ECMs.

Refer to Troubleshooting Fault Code 611.

Last Modified: 27-Jun-2010


Fault Code Path Selection

FAULT CODE 621
Fault Code Path Selection

Is the engine a QSK38 or QSK50 Marine? | Go to 122-fc621qsk38-50mar
Does the engine have thermistors? | Go to 122-fc621thermistor

Last Modified: 23-Sep-2010


Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 621 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 621 PID: SPN: 1323 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 1
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 1

Circuit Description

The exhaust gas temperature sensor circuit cylinder 1 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 1 is located in the engine harness and extends between the number 1 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 1 measures the exhaust temperature of cylinder 1. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted after-cooler.
  • Cylinder damage, valves, rings, or piston.
  • Damaged injector.
  • Connector pin damage, broken wire in sensor harness or wiring insulation damage triggering high number of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 621 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2014


Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operational Range - Least Severe Level

FAULT CODE 621 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 621 PID: SPN: 1323 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 1
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 1
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 1

Circuit Description

The exhaust gas temperature sensor circuit cylinder 1 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 1 is located in the engine harness and extends between the number 1 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 1 measures the exhaust temperature of cylinder 1. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder, valve, ring, or piston damage.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness or wiring insulation damage triggering high number of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 621 (Thermistor).

Last Modified: 27-Jun-2014


Fault Code Path Selection

FAULT CODE 622
Fault Code Path Selection

Is the engine a QSK38 or QSK50 Marine? | Go to 122-fc622qsk38-50mar
Does the engine have thermistors? | Go to 122-fc622thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 622 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 622 PID: SPN: 1325 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 3
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 3

Circuit Description

The exhaust gas temperature sensor circuit cylinder 3 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 3 is located in the engine harness and extends between the number 3 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 3 measures the exhaust temperature of cylinder 3. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder damage, valves, rings, or piston.
  • Damaged injector.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage, triggering a high number of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 622 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2014


Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 622 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 622 PID: SPN: 1323 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 3
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 3
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 3

Circuit Description

The exhaust gas temperature sensor circuit cylinder 3 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 3 is located in the engine harness and extends between the number 3 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 3 measures the exhaust gas temperature of cylinder 3. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder, valve, ring, or piston damage.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage, triggering a high number of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 622 (Thermistor).

Last Modified: 27-Jun-2014


Fault Code Path Selection

FAULT CODE 623
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc623qsk38-50mar
Does the engine have thermistors? | Go to 122-fc623thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 623 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 625 PID: SPN: 1323 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 5
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 5

Circuit Description

The exhaust gas temperature sensor circuit cylinder 5 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 5 is located in the engine harness and extends between the number 5 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 5 measures the exhaust temperature of cylinder 5. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder damage, valves, rings, or piston.
  • Damaged injector.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage, triggering a high number of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 623 (qsk38-50mar).

Last Modified: 27-Jun-2014


Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 623 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 623 PID: SPN: 1323 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 5
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 5
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 5

Circuit Description

The exhaust gas temperature sensor circuit cylinder 5 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 5 is located in the engine harness and extends between the number 5 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 5 measures the exhaust gas temperature of cylinder 5. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder, valve, ring, or piston damage.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage, triggering a high number of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 623 (thermistor).

Last Modified: 27-Jun-2014


Fault Code Path Selection

FAULT CODE 624
Fault Code Path Selection

Is the engine a QSK38 or QSK50 Marine? | Go to 122-fc624qsk38-50mar
Does the engine have thermistors? | Go to 122-fc624thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 624 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 624 PID: SPN: 1323 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 7
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 7

Circuit Description

The exhaust gas temperature sensor circuit cylinder 7 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 7 is located in the engine harness and extends between the number 7 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 7 measures the exhaust temperature of cylinder 7. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault code include:

  • Restricted aftercooler.
  • Damaged cylinder, valves, rings, or piston.
  • Damaged injector.
  • Connector pin damage, broken wire in sensor harness or wiring insulation damage, triggering a high number of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 624 (qsk38-50mar).

Last Modified: 27-Jun-2014


Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 624 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 624 PID: SPN: 1329 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid but Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 7
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 7
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 7

Circuit Description

The exhaust gas temperature sensor circuit cylinder 7 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 7 is located in the engine harness and extends between the number 7 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 7 measures the exhaust temperature of cylinder 7. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder, valve, ring, or piston damage.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage, triggering a high number of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 624 (thermistor).

Last Modified: 27-Jun-2014


Fault Code Path Selection

FAULT CODE 625
Fault Code Path Selection

Is the engine a QSK38 or QSK50 Marine? | Go to 122-fc625qsk38-50mar
Does the engine have thermistors? | Go to 122-fc625thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 625 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 625 PID: SPN: 1331 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 9
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 9

Circuit Description

The exhaust gas temperature sensor circuit cylinder 9 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 9 is located in the exhaust manifold at the cylinder head 9 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 9 measures the exhaust temperature of cylinder 9. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Damaged cylinder, valves, rings, or piston.
  • Damaged injector.
  • Connector pin damage, broken wire in sensor harness or wiring insulation damage triggering a high number of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 625 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2014


Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 625 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 625 PID: SPN: 1331 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 9
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 9
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 9

Circuit Description

The exhaust gas temperature sensor circuit cylinder 9 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 9 is located in the engine harness and extends between the number 9 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 9 measures the exhaust gas temperature of cylinder 9. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high number of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 625 (Thermistor).

Last Modified: 05-Oct-2015


Fault Code Path Selection

FAULT CODE 626
Fault Code Path Selection

Is the engine a QSK38 or QSK50 Marine? | Go to 122-fc626qsk38-50mar
Does the engine have thermistors? | Go to 122-fc626thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 626 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 626 PID: SPN: 1333 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possibe low power. No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 11
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 11

Circuit Description

The exhaust gas temperature sensor circuit cylinder 11 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 11 is located in the exhaust manifold at the cylinder head 11 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 11 measures the exhaust temperature of cylinder 11. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

See the Engine Performance Troubleshooting Tree in Section TT to troubleshoot this condition.

Possible causes of this fault include:

  • Restricted after-cooler
  • Damaged cylinder, valves, rings, and piston
  • Damaged injector.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high number of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 626 (QSK38 and QSK50 Marine).

Last Modified: 05-Oct-2015


Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 626 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 626 PID: SPN: 1329 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 11
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 11
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 11

Circuit Description

The exhaust gas temperature sensor circuit cylinder 11 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 11 is located in the engine harness and extends between the number 11 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 11 measures the exhaust gas temperature of cylinder 11. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness. or wiring insulation damage triggering high number of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 626 (Thermistor).

Last Modified: 05-Oct-2015


Fault Code Path Selection

FAULT CODE 627
Fault Code Path Selection

Is the engine a QSK50 Marine? | Go to 122-fc627qsk50mar
Does the engine have thermistors? | Go to 122-fc627thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 627 (QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 627 PID: SPN: 1335 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid but Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 13

Circuit Description

The exhaust gas temperature sensor circuit cylinder 13 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 13 is located in the exhaust manifold at the cylinder head 13 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 13 measures the exhaust temperature of cylinder 13. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

See the Engine Performance Troubleshooting Tree in Section TT to troubleshoot this condition.

Possible causes of this fault code include:

  • Restricted after-cooler
  • Damaged cylinder, valves, rings, or piston
  • Damaged injector.
Refer to Troubleshooting Fault Code 627 (QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 627 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 627 PID: SPN: 1331 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 13
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 13
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 13

Circuit Description

The exhaust gas temperature sensor circuit cylinder 13 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 13 is located in the engine harness and extends between the number 13 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 13 measures the exhaust gas temperature of cylinder 13. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high number of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 627 (Thermistor).

Last Modified: 05-Oct-2015


Fault Code Path Selection

FAULT CODE 628
Fault Code Path Selection

Is the engine a QSK50 Marine? | Go to 122-fc628qsk50mar
Does the engine have thermistors? | Go to 122-fc628thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 628 (QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 628 PID: SPN: 1337 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid but Below Normal Operating Range - Least Severe Level. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 15

Circuit Description

The exhaust gas temperature sensor circuit cylinder 15 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 15 for this fault code is located in the exhaust manifold at the cylinder head 15 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 15 measures the exhaust temperature of cylinder 15. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

See the Engine Performance Troubleshooting Tree in Section TT to troubleshoot this condition.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder damage, valves, rings, or piston
  • Injector damage.
Refer to Troubleshooting Fault Code 628 (QSK50 Marine).

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 628 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 628 PID: SPN: 1337 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 15
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 15
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 15

Circuit Description

The exhaust gas temperature sensor circuit cylinder 15 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 15 is located in the engine harness and extends between the number 15 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 15 measures the exhaust gas temperature of cylinder 15. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness or wiring insulation damage triggering high number of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 628 (Thermistor).

Last Modified: 05-Oct-2015


Fault Code Path Selection

FAULT CODE 631
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc631qsk38-50mar
Does the engine have thermistors? | Go to 122-fc631thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 631 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 631 PID: SPN: 1324 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 2

Circuit Description

The exhaust gas temperature sensor circuit cylinder 2 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 2 is located in the exhaust manifold at the cylinder head 2 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 2 measures the exhaust temperature of cylinder 2. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

See the Engine Performance Troubleshooting Tree in Section TT to troubleshoot this condition.

Possible causes of this fault code include:

  • Restricted after-cooler
  • Damaged cylinder, valves, rings, or piston
  • Damaged injector.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high number of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 631 (QSK38 and QSK50 Marine).

Last Modified: 05-Oct-2015


Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 631 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 631 PID: SPN: 1331 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig with C Command Elite™ and Command Elite Plus™ Panel System - Exhaust Gas Temperature Sensor Circuit Cylinder 2

Circuit Description

The exhaust gas temperature sensor circuit cylinder 2 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 2 is located in the engine wiring harness and extends between the number 2 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 2 measures the exhaust gas temperature of cylinder 2. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault code include:

  • Restricted after-cooler
  • Damaged cylinder, valve, ring, or piston
  • Damaged injector
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high number of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 631 (Thermistor).

Last Modified: 05-Oct-2015


Fault Code Path Selection

FAULT CODE 632
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc632qsk38-50mar
Does the engine have thermistors? | Go to 122-fc632thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 632 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 632 PID: SPN: 1326 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 4

Circuit Description

The exhaust gas temperature sensor circuit cylinder 4 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 4 is located in the exhaust manifold at the cylinder head 4 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 4 measures the exhaust temperature of cylinder 4. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

See the Engine Performance Troubleshooting Tree in Section TT to troubleshoot this condition.

Possible causes of this fault code include:

  • Restricted after-cooler
  • Damaged cylinder, valves, rings, or piston
  • Damaged injector
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high number of intermittent fault codes
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 632 (QSK38 and QSK50 Marine).

Last Modified: 05-Oct-2015


Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 632 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 632 PID: SPN: 1326 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 4

Circuit Description

The exhaust gas temperature sensor circuit cylinder 4 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 4 is located in the engine harness and extends between the number 4 cylinder head and the ECM.

Shop Talk

There are multiple electronic control modules (ECMs) for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 4 measures the exhaust gas temperature of cylinder 4. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high number of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 632 (Thermistor).

Last Modified: 05-Oct-2015


Fault Code Path Selection

FAULT CODE 633
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc633qsk38-50mar
Does the engine have thermistors? | Go to 122-fc633thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 633 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 633 PID: SPN: 1328 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 6

Circuit Description

The exhaust gas temperature sensor circuit cylinder 6 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 6 is located in the exhaust manifold at the cylinder head 6 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 6 measures the exhaust temperature of cylinder 15. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

See the Engine Performance Troubleshooting Tree in Section TT to troubleshoot this condition.

Possible causes of this fault code include:

  • Restricted after-cooler
  • Damaged cylinder, valves, rings, or piston
  • Damaged injector.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high number of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 633 (QSK38 and QSK50 Marine).

Last Modified: 05-Oct-2015


Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 633 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 633 PID: SPN: 1328 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid but Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperture.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 6

Circuit Description

The exhaust gas temperature sensor circuit cylinder 6 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 6 is located in the engine harness and extends between the number 6 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 6 measures the exhaust gas temperature of cylinder 6. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder, valve, ring, or piston damage.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation samage triggering high counts of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 633 (Thermistor).

Last Modified: 27-Jun-2014


Fault Code Path Selection

FAULT CODE 634
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc634qsk38-50mar
Does the engine have thermistors? | Go to 122-fc634thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 634 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 634 PID: SPN: 1330 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid but Below Normal Operating Range - Least Severe Level. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 8

Circuit Description

The exhaust gas temperature sensor circuit cylinder 8 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 8 for this fault code is located in the exhaust manifold at the cylinder head 8 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 8 measures the exhaust temperature of cylinder 8. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

See the Engine Performance troubleshooting tree in Section TT to troubleshoot this condition.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder damage, valves, rings, or piston.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high counts of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 634 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2014


Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 634 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 634 PID: SPN: 1330 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid but Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 8

Circuit Description

The exhaust gas temperature sensor circuit cylinder 8 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit - cylinder 8 is located in the engine harness and extends between the cylinder 8 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 8 measures the exhaust gas temperature of cylinder 8. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder, valve, ring, or piston damage.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high counts of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 634 (Thermistor).

Last Modified: 27-Jun-2014


Fault Code Path Selection

FAULT CODE 635
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc635qsk38-50mar
Does the engine have thermistors? | Go to 122-fc635thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 635 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 635 PID: SPN: 1332 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid but Below Normal Operating Range - Least Severe Level. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 10

Circuit Description

The exhaust gas temperature sensor circuit cylinder 10 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 10 is located in the exhaust manifold at the cylinder head 10 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 10 measures the exhaust temperature of it's respective cylinder. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Note: It is possible that the exhaust gas temperature sensor 5 volt supply can be open and a fault will not be set. If this happens, the temperature of the exhaust gas temperature sensor will read a constant 474°C [885°F]. See the Engine Performance troubleshooting tree in Section TT to troubleshoot this condition.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder damage, valves, rings, or piston.
  • Injector damage.Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high counts of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 635 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2014


Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 635 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 635 PID: SPN: 1332 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid but Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperture.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 10

Circuit Description

The exhaust gas temperature sensor circuit cylinder 10 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 10 is located in the engine harness and extends between the number 10 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 10 measures the exhaust gas temperature of cylinder 10. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder, valve, ring, or piston damage.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high counts of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 635 (Thermistor).

Last Modified: 27-Jun-2014


Fault Code Path Selection

FAULT CODE 636
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc636qsk38-50mar
Does the engine have thermistors? | Go to 122-fc636thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 636 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 636 PID: SPN: 1334 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid but Below Normal Operating Range - Least Severe Level. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 12

Circuit Description

The exhaust gas temperature sensor circuit cylinder 12 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 12 is located in the exhaust manifold at the cylinder head 12 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 12 measures the exhaust temperature of it's respective cylinder. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

See the Engine Performance troubleshooting tree in Section TT to troubleshoot this condition.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder damage, valves, rings, or piston.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high counts of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 636 (QSK38 and QSK50 Marine).

Last Modified: 16-Jun-2014


Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 636 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 636 PID: SPN: 1334 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 12

Circuit Description

The exhaust gas temperature sensor circuit cylinder 12 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 12 is located in the engine harness and extends between the number 12 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 12 measures the exhaust gas temperature of cylinder 12. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler.
  • Cylinder, valve, ring, or piston damage.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high counts of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 636 (Thermistor).

Last Modified: 27-Jun-2014


Fault Code Path Selection

FAULT CODE 637
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc637qsk50mar
Does the engine have thermistors? | Go to 122-fc637thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 637 (QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 637 PID: SPN: 1336 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 14

Circuit Description

The exhaust gas temperature sensor circuit cylinder 14 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 14 is located in the exhaust manifold at the cylinder head 14 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 14 measures the exhaust temperature of it's respective cylinder. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

See the Engine Performance troubleshooting tree in Section TT to troubleshoot this condition.

Possible causes of this fault code include:

  • Restricted after-cooler.
  • Cylinder damage, valves, rings, or piston.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high counts of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 637 (QSK50 Marine).

Last Modified: 17-Jun-2014


Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 637 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 637 PID: SPN: 1336 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 14

Circuit Description

The exhaust gas temperature sensor circuit cylinder 14 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 14 is located in the engine harness and extends between the number 14 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 14 measures the exhaust gas temperature of cylinder 14. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault code include:

  • Restricted aftercooler.
  • Cylinder, valve, ring, or piston damage.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high counts of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 637 (Thermistor).

Last Modified: 27-Jun-2014


Fault Code Path Selection

FAULT CODE 638
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc638qsk50mar
Does the engine have thermistors? | Go to 122-fc638thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 638 (QSK50 Marine)

Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 638 PID: SPN: 1338 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid but Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 16

Circuit Description

The exhaust gas temperature sensor circuit cylinder 16 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 16 is located in the exhaust manifold at the cylinder head 16 to exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 16 measures the exhaust temperature of it's respective cylinder. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

NOTE: It is possible that the exhaust gas temperature sensor 5 volt supply can be open and a fault will not be set. If this happens, the temperature of the exhaust gas temperature sensor will read a constant 474°C or 885°F. See the Engine Performance troubleshooting tree in Section TT to troubleshoot this condition.

Possible causes of this fault code include:

  • Restricted after-cooler.
  • Cylinder damage, valves, rings, or piston.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high counts of intermittent fault codes.
  • Sensor circuit shorted to ground.
Refer to Troubleshooting Fault Code 638 (QSK50 Marine).

Last Modified: 27-Jun-2014


Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 638 (Thermistor)

Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 638 PID: SPN: 1338 FMI: 0/17 LAMP: Maintenance SRT: | Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid but Below Normal Operating Range - Least Severe Level. | Possible low power. No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 16

Circuit Description

The exhaust gas temperature sensor circuit cylinder 16 monitors exhaust gas temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 16 is located in the engine harness and extends between the number 16 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 16 measures the exhaust gas temperature of cylinder 16. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault code include:

  • Restricted aftercooler.
  • Cylinder, valve, ring, or piston damage.
  • Injector damage.
  • Connector pin damage, broken wire in sensor harness, or wiring insulation damage triggering high counts of intermittent fault codes.
  • Sensor circuit shorted to the ground.
Refer to Troubleshooting Fault Code 638 (Thermistor).

Last Modified: 27-Jun-2014


Exhaust Gas Temperature Cylinder 1 - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 641

Exhaust Gas Temperature Cylinder 1 - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 641 PID: SPN: 1137 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 1 - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 1

Circuit Description

The exhaust gas temperature sensor circuit cylinder 1 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 1 is located in the engine harness and extends between the number 1 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 641 indicates the exhaust gas temperature sensor in cylinder 1 has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 1 measures the exhaust gas temperature of cylinder 1. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 641.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 3 - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 642

Exhaust Gas Temperature Cylinder 3 - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 642 PID: SPN: 1139 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 3 - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 3

Circuit Description

The exhaust gas temperature sensor circuit cylinder 3 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 3 is located in the engine harness and extends between the number 3 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 642 indicates the exhaust gas temperature sensor in cylinder 3 has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 3 measures the exhaust gas temperature of cylinder 3. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 642.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 5 - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 643

Exhaust Gas Temperature Cylinder 5 - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 643 PID: SPN: 1141 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 5 - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 5

Circuit Description

The exhaust gas temperature sensor circuit cylinder 5 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 5 is located in the engine harness and extends between the number 5 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 643 indicates the exhaust gas temperature sensor in cylinder 5 has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 5 measures the exhaust gas temperature of cylinder 5. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 643.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 644

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 644 PID: SPN: 1143 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid but Above Normal Operating Range - Most Severe Level | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 7 (A4) monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 7 (A4) is located in the engine harness and extends between the number 7 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 644 indicates the exhaust gas temperature sensor in cylinder 7 has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 7 (A4) measures the exhaust gas temperature of cylinder 7. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 644.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 645

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 645 PID: SPN: 1145 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid but Above Normal Operating Range - Most Severe Level | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 9 (A5) monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 9 (A5) is located in the engine harness and extends between the number 9 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 645 indicates the exhaust has temperature sensor in cylinder 9 (A5) has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 9 (A5) measures the exhaust gas temperature of cylinder 9. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 645.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 646

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 646 PID: SPN: 1147 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid but Above Normal Operating Range - Most Severe Level | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 11 (A6) monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 11 (A6) is located in the engine harness and extends between the number 11 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 646 indicates the exhaust gas temperature sensor in cylinder 11 has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 11 (A6) measures the exhaust gas temperature of cylinder 11. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 646.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 13 - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 647

Exhaust Gas Temperature Cylinder 13 - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 647 PID: SPN: 1149 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 13 - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 13

Circuit Description

The exhaust gas temperature sensor circuit cylinder 13 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 13 is located in the engine harness and extends between the number 13 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 647 indicates the exhaust gas temperature sensor in cylinder 13 has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 13 measures the exhaust gas temperature of cylinder 13. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 647.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 648

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 648 PID: SPN: 1151 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 15 (A8) monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 15 (A8) is located in the engine harness and extends between the number 1 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 648 indicates the exhaust gas temperature sensor in cylinder 15 (A8)has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 15 (A8) measures the exhaust gas temperature of cylinder 15 (A8). The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 648.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 652

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 652 PID: SPN: 1138 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 2 (B1) exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 2 (B1) is located in the engine harness and extends between the number 2 (B1) cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 652 indicates the exhaust gas temperature sensor in cylinder 2 (B1) has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 2 (B1) measures the exhaust gas temperature of cylinder 2 (B1). The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 652.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 4 - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 653

Exhaust Gas Temperature Cylinder 4 - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 653 PID: SPN: 1140 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 4 - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 4

Circuit Description

The exhaust gas temperature sensor circuit cylinder 4 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 4 is located in the engine harness and extends between the number 4 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault code 653 indicates the exhaust gas temperature sensor in cylinder 4 has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 4 measures the exhaust gas temperature of cylinder 4. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 653.

Last Modified: 02-Mar-2011


Exhaust Gas Temperature Cylinder 6 - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 654

Exhaust Gas Temperature Cylinder 6 - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 654 PID: SPN: 1142 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 6 - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 6

Circuit Description

The exhaust gas temperature sensor circuit cylinder 6 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 6 is located in the engine harness and extends between the number 6 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault code 654 indicates the exhaust gas temperature sensor in cylinder 6 has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 6 measures the exhaust gas temperature of cylinder 6. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 654.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 655

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 655 PID: SPN: 1144 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4)

Circuit Description

The exhaust gas temperature sensor circuit cylinder 8 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 8 is located in the engine harness and extends between the number 8 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 655 indicates the exhaust gas temperature sensor in cylinder 8 has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 8 measures the exhaust temperature of cylinder 8. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 655.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 10 - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 656

Exhaust Gas Temperature Cylinder 10 - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 656 PID: SPN: 1146 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 10 - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 10

Circuit Description

The exhaust gas temperature sensor circuit cylinder 10 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 10 is located in the engine harness and extends between the number 10 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 656 indicates the exhaust gas temperature sensor in cylinder 10 has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 10 measures the exhaust gas temperature of cylinder 10. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 656.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 12 - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 657

Exhaust Gas Temperature Cylinder 12 - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 657 PID: SPN: 1148 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 12 - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 12

Circuit Description

The exhaust gas temperature sensor circuit cylinder 12 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 12 is located in the engine harness and extends between the number 12 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Fault Code 657 indicates the exhaust gas temperature sensor in cylinder 12 has exceeded the engine protection warning limit.

The exhaust gas temperature sensor circuit cylinder 12 measures the exhaust gas temperature of cylinder 12. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Malfunctioning turbocharger seals.
Refer to Troubleshooting Fault Code 657.

Last Modified: 13-Dec-2010


Exhaust Gas Temperature Cylinder 14 - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 658

Exhaust Gas Temperature Cylinder 14 - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 658 PID: SPN: 1150 FMI: 0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 14 - Data Valid but Above Normal Operating Range - Most Severe Level. | Possible engine shutdown if feature is enabled. Possible engine smoke and engine damage.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 14

Circuit Description

The exhaust gas temperature sensor circuit cylinder 14 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 14 is located in the engine harness and extends between the number 14 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 14 measures the exhaust gas temperature of cylinder 14. The ECM monitors the temperature and compares it to the exhaust gas temperatures of other cylinders.

Fault Code 658 indicates the exhaust gas temperature sensor in cylinder number 14 has exceeded the engine protection warning limit.

Possible causes of this fault include:

  • Restricted aftercooler
  • Cylinder, valve, ring, or piston damage
  • Injector damage
  • High intake air temperature
  • Boost air leaks
  • Over-fueling
  • Turbocharger overspeed
  • Damaged turbocharger seals.
Refer to Troubleshooting Fault Code 658.

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 671
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc671qsk38-50mar
Does the engine have thermistors? | Go to 122-fc671thermistor

Last Modified: 26-Feb-2010


Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 6719

Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6719 PID: SPN: 94 FMI: 0/0 LAMP: Red SRT: | Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. Fuel pump supply pressure very high. | Possible engine speed derate. Low power or engine smoke.
QSK38 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 Power Generation (Military Application) - Fuel Delivery Pressure Sensor Circuit
QSK38 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advanced Engine Monitoring and QSK60 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK50 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the engine control module (ECM) to monitor fuel delivery pressure directly before the Stage 2 filter. The ECM monitors the voltage on the fuel delivery pressure SIGNAL pin and converts it to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the Stage 2 fuel filter head.

Conditions for Running the Diagnostics

  • The engine speed must be above 500 RPM for 10 seconds, and fueling must be above 20 mg/stk for 5 seconds before a diagnostic decision begins to be made.
  • The fuel temperature must be greater than, or equal to -10 ⁰C.

Conditions for Setting the Fault Codes

  • When the fuel supply pressure is greater than 1200 kPa (174 psi) for more than 3 seconds, FC4615 is initially set.
  • FC4615 also activates an engine speed derate that attempts to bring down the fuel supply pressure at or below 1000 kPa.
  • If after 30 minutes, the speed derate is unable to bring down the fuel supply pressure to 1000 kPa, then FC 6719 (Red) is activated.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red CHECK ENGINE lamp immediately when the diagnostics detects high fuel supply pressure.

Conditions for Clearing the Fault Code

  • FC 6719 (Red Lamp) is cleared at every key-cycle. However, it is strongly recommended to stop engine operation and follow the troubleshooting steps for resolution immediately.
  • Once the engine has been restarted, the fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Stage 2 fuel filter restriction high
  • Pinched or damaged fuel supply line
  • Stuck gerotor pump fuel pressure regulator located in high-pressure pump.
Refer to Troubleshooting Fault Code t05-6719.

Last Modified: 30-May-2017


Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 671 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 671 PID: SPN: 1137 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 1. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 1
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 1

Circuit Description

The exhaust gas temperature sensor circuit cylinder 1 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 1 is located in the exhaust manifold at the cylinder head 1 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 1 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

NOTE: It is possible that the exhaust gas temperature sensor 5 volt supply can be open and a fault code will not be set. If this happens, the temperature of the exhaust gas temperature sensors connected to that exhaust gas temperature sensor supply will read a constant 474°C [885°F].

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Open in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 671 (QSK38 and QSK50 Marine).

Last Modified: 16-Jul-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 671 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 671 PID: SPN: 1137 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 1. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 1
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 1
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 1

Circuit Description

The exhaust gas temperature sensor circuit cylinder 1 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 1 is located in the engine harness and extends between the number 1 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 1 measures the exhaust gas temperature of cylinder 1. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3 ) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Sensor Temperature vs. Resistance
Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 671 (Thermistor).

Last Modified: 13-Sep-2010


Fault Code Path Selection

FAULT CODE 672
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc672qsk38-50mar
Does the engine have thermistors? | Go to 122-fc672thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 672 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 672 PID: SPN: 1139 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 3. | No engine protection for the exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 3
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 3

Circuit Description

The exhaust gas temperature sensor circuit cylinder 3 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 3 is located in the exhaust manifold at the cylinder head 3 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting this fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 3 measures the exhaust temperature of the respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Open circuit in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 672 (QSK38 and QSK50 Marine).

Last Modified: 16-Jul-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 672 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 672 PID: SPN: 1139 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 3. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 3
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 3
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 3

Circuit Description

The exhaust gas temperature sensor circuit cylinder 3 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 3 is located in the engine harness and extends between the number 3 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 3 measures the exhaust gas temperature of cylinder 3. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3 ) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 672 (Thermistor).

Last Modified: 13-Sep-2010


Fault Code Path Selection

FAULT CODE 673
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc673qsk38-50mar
Does the engine have thermistors? | Go to 122-fc673thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 673 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 673 PID: SPN: 1141 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 5. | No engine protection for the exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 5
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 5

Circuit Description

The exhaust gas temperature sensor circuit cylinder 5 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 5 is located in the exhaust manifold at the cylinder head 5 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 5 measures the exhaust temperature of the respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Open circuit in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 673 (QSK38 and QSK50 Marine).

Last Modified: 16-Jul-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 673 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 673 PID: SPN: 1141 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 5. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 5
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 5
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 5

Circuit Description

The exhaust gas temperature sensor circuit cylinder 5 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 5 is located in the engine harness and extends between the number 5 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 5 measures the exhaust gas temperature of cylinder 5. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 673 (Thermistor).

Last Modified: 13-Sep-2010


Fault Code Path Selection

FAULT CODE 674
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc674qsk38-50mar
Does the engine have thermistors? | Go to 122-fc674thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 674 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 674 PID: SPN: 1143 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 7. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 7
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 7

Circuit Description

The exhaust gas temperature sensor circuit cylinder 7 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 7 is located in the exhaust manifold at the cylinder head 7 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 7 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Open circuit in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 674 (QSK38 and QSK50 Marine).

Last Modified: 16-Jul-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 674 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 674 PID: SPN: 1143 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 7. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 7
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 7
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 7

Circuit Description

The exhaust gas temperature sensor circuit cylinder 7 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 7 is located in the engine harness and extends between the cylinder 7 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 7 measures the exhaust gas temperature of cylinder 7. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3 ) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to battery voltage in the harness
  • A signal circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 674 (Thermistor).

Last Modified: 13-Sep-2010


Fault Code Path Selection

FAULT CODE 675
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc675qsk38-50mar
Does the engine have thermistors? | Go to 122-fc675thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 675 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 675 PID: SPN: 1145 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 9. | No engine protection for the exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 9
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 9

Circuit Description

The exhaust gas temperature sensor circuit cylinder 9 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine wiring harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 9 is located in the exhaust manifold at the cylinder head 9 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 9 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Open circuit in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 675 (QSK38 and QSK50 Marine).

Last Modified: 16-Jul-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 675 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 675 PID: SPN: 1145 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 9. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 9
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 9
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 9

Circuit Description

The exhaust gas temperature sensor circuit cylinder 9 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 9 is located in the engine harness and extends between the number 9 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 9 measures the exhaust gas temperature of cylinder 9. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 675 (Thermistor).

Last Modified: 13-Sep-2010


Fault Code Path Selection

FAULT CODE 676
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc676qsk38-50mar
Does the engine have thermistors? | Go to 122-fc676thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 676 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 676 PID: SPN: 1147 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at exhaust gas temperature sensor circuit cylinder 11. | No engine protection for the exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 11
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 11

Circuit Description

The exhaust gas temperature sensor circuit cylinder 11 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 11 is located in the exhaust manifold at the cylinder head 11 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 11 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Open circuit in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 676 (QSK38 and QSK50 Marine).

Last Modified: 16-Jul-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 676 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 676 PID: SPN: 1143 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 11. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 11
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 11
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 11

Circuit Description

The exhaust gas temperature sensor circuit cylinder 11 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 11 is located in the engine harness and extends between the cylinder 11 head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 11 measures the exhaust gas temperature of cylinder 11. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to battery voltage in the harness
  • A signal circuit shorted to voltage source in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 676 (Thermistor).

Last Modified: 13-Sep-2010


Fault Code Path Selection

FAULT CODE 677
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc677qsk50mar
Does the engine have thermistors? | Go to 122-fc677thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 677 (QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 677 PID: SPN: 1149 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at exhaust gas temperature sensor circuit cylinder 13. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 13

Circuit Description

The exhaust gas temperature sensor circuit cylinder 13 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 13 is located in the exhaust manifold at the cylinder head 13 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 13 measures the exhaust temperature of it's respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Open in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 677 (QSK50 Marine).

Last Modified: 16-Jul-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 677 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 677 PID: SPN: 1149 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 13. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 13
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 13
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 13

Circuit Description

The exhaust gas temperature sensor circuit cylinder 13 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 13 is located in the engine harness and extends between the number 13 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 13 measures the exhaust temperature of cylinder 13. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault include:

  • A SIGNAL circuit shorted to ground in the harness
  • A SIGNAL circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 677 (Thermistor).

Last Modified: 13-Sep-2010


Fault Code Path Selection

FAULT CODE 678
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc678qsk50mar
Does the engine have thermistors? | Go to 122-fc678thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 678 (QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 678 PID: SPN: 1151 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at exhaust gas temperature sensor circuit cylinder 15. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 15

Circuit Description

The exhaust gas temperature sensor circuit cylinder 15 monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 15 is located in the exhaust manifold at the cylinder head 15 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 15 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Open in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 678 (QSK50 Marine).

Last Modified: 16-Jul-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 678 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 678 PID: SPN: 1151 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 15. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 15
QSK50 and QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 15
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 15

Circuit Description

The exhaust gas temperature sensor circuit cylinder 15 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 15 is located in the engine harness and extends between the number 15 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 15 measures the exhaust gas temperature of cylinder 15. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 4) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 678 (Thermistor).

Last Modified: 16-Sep-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Loss of signal from engine crankshaft speed/position sensor. | Engine can run rough. Possibly poor starting capability. Engine runs using backup speed sensor. Engine power is reduced.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine/QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Crankshaft Speed/Position Sensor Circuit
QSK50 CM2150 Industrial - Engine Crankshaft Speed/Position Sensor Circuit
QSK50 CM2150 Power Generation without Advanced Engine Monitoring/QSK50 CM2150 Power Generation with Advance Engine Monitoring/QSK50 CM2150 Marine - Engine Crankshaft Speed/Position Sensor Circuit
QSK60 CM2150 Industrial - Engine Crankshaft Speed/Position Sensor Circuit
QSK60 CM2150 Power Generation - Engine Crankshaft Speed/Position Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine crankshaft speed/position sensor provides engine speed information to the ECM. The engine crankshaft speed/position sensor is powered by the engine crankshaft speed/position 5 volt supply (sensor supply 3). The engine crankshaft speed/position sensor generates the engine crankshaft speed/position signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

The engine crankshaft speed/position sensor is located on the flywheel housing. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code is recorded when the ECM does not receive a signal from the engine crankshaft speed/position sensor, or the signal it receives is degraded.

Possible causes of this fault code include:

  • Open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM
  • Short circuits to ground or return circuits in the sensor, engine harness, or ECM
  • Short circuits to a voltage source in the sensor, engine harness, or ECM
  • Damage to the sensor target teeth or tone wheel.

INSITE™ electronic service tool monitor parameters associated with this fault code and sensor include:

  • Engine speed sensor state.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code t05-689

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 721
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc721qsk38-50mar
Does the enigne have thermistors? | Go to 122-fc721thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 721 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 721 PID: SPN: 1138 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at exhaust gas temperature sensor circuit cylinder 2. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 2

Circuit Description

The exhaust gas temperature sensor circuit cylinder 2 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 2 is located in the exhaust manifold at the cylinder head 2 exhaust manifold interface. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 2 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • An open in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 721 (QSK38 and QSK50 Marine).

Last Modified: 13-Apr-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 721 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 721 PID: SPN: 1138 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 2. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 2
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 2

Circuit Description

The exhaust gas temperature sensor circuit cylinder 2 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 2 is located in the engine harness and extends between the number 2 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 2 measures the exhaust gas temperature of cylinder 2. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 721 (Thermistor).

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 722
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc722qsk38-50mar
Does the engine have thermistors? | Go to 122-fc722thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 722 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 722 PID: SPN: 1140 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at exhaust gas temperature sensor circuit cylinder 4. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 4

Circuit Description

The exhaust gas temperature sensor circuit cylinder 4 monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 4 is located in the exhaust manifold at the cylinder head 4 exhaust manifold interface. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 4 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • An open in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 722 (QSK38 and QSK50 Marine).

Last Modified: 13-Apr-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 722 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 722 PID: SPN: 1140 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 4. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 4
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 4

Circuit Description

The exhaust gas temperature sensor circuit cylinder 4 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 4 is located in the engine harness and extends between the number 4 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 4 measures the exhaust gas temperature of cylinder 4. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 722 (Thermistor).

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 723
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc723qsk38-50mar
Does the engine have thermistors? | Go to 122-fc723thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 723 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 723 PID: SPN: 1142 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 6. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 6

Circuit Description

The exhaust gas temperature sensor circuit cylinder 6 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust temperature sensor circuit cylinder 6 is located in the exhaust manifold at the cylinder head 6 exhaust manifold interface. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 6 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • An open in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 723 (QSK38 and QSK50 Marine).

Last Modified: 13-Apr-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 723 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 723 PID: SPN: 1142 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 6. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 6
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 6

Circuit Description

The exhaust gas temperature sensor circuit cylinder 6 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 6 is located in the engine harness and extends between the number 6 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The exhaust gas temperature sensor circuit cylinder 6 measures the exhaust gas temperature of cylinder 6. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C [1112°F] with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C [1112°F] with INSITE™ electronic service tool.

Possible causes of this fault include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 723 (Thermistor).

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 724
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc724qsk38-50mar
Does the engine have thermistors? | Go to 122-fc724thermistor

Last Modified: 06-Jul-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 724 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 724 PID: SPN: 1144 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 8. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 8

Circuit Description

The exhaust gas temperature sensor circuit cylinder 8 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust temperature sensor circuit cylinder 8 is located in the exhaust manifold at the cylinder head 8 exhaust manifold interface. Refer to Procedure 100-002 in Section E. .

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 8 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • An open in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 724 (QSK38 and QSK50 Marine).

Last Modified: 14-Apr-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 724 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 724 PID: SPN: 1144 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 8. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 8
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 8

Circuit Description

The exhaust gas temperature sensor circuit cylinder 8 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 8 is located in the engine harness and extends between the number 8 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 8 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

The exhaust gas temperature sensor circuit cylinder 8 measures the exhaust temperature of cylinder 8. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C or 1112°F with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C or 1112°F with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The temperature sensor rsistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 724 (Thermistor).

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 725
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc725qsk38-50mar
Does the engine have thermistors? | Go to 122-fc725thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 725 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 725 PID: SPN: 1146 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 10. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 10

Circuit Description

The exhaust gas temperature sensor circuit cylinder 10 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust temperature sensor circuit cylinder 10 is located in the exhaust manifold at the cylinder head 10 exhaust manifold interface. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 10 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • An open in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 725 (QSK38 and QSK50 Marine).

Last Modified: 01-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 725 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 725 PID: SPN: 1146 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 10. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 10
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 10

Circuit Description

The exhaust gas temperature sensor circuit cylinder 10 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 10 is located in the engine harness and extends between the number 10 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 10 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

The exhaust gas temperature sensor circuit cylinder 10 measures the exhaust temperature of cylinder 10. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C or 1112°F with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C or 1112°F with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioned ECM.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 725 (Thermistor).

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 726
Fault Code Path Selection

Is the engine QSK38 or QSK50 Marine? | Go to 122-fc726qsk38-50mar
Does the engine have thermistors? | Go to 122-fc726thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 726 (QSK38 and QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 726 PID: SPN: 1148 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 12. | No engine protection for exhaust gas temperature.
QSK38 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 12

Circuit Description

The exhaust gas temperature sensor circuit cylinder 12 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust temperature sensor circuit cylinder 12 is located in the exhaust manifold at the cylinder head 12 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 12 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • An open in the sensor return
  • Damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 726 (QSK38 and QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 726 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 726 PID: SPN: 1148 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 12. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 12
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 12

Circuit Description

The exhaust gas temperature sensor circuit cylinder 12 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 12 is located in the engine harness and extends between the number 12 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 12 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

The exhaust gas temperature sensor circuit cylinder 8 measures the exhaust temperature of cylinder 12. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C or 1112°F with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C or 1112°F with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 726 (Thermistor).

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 727
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc727qsk50mar
Does the engine have thermistors? | Go to 122-fc727thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 727 (QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 727 PID: SPN: 1150 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 14. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 14

Circuit Description

The exhaust gas temperature sensor circuit cylinder 14 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust temperature sensor circuit cylinder 14 is located in the exhaust manifold at the cylinder head 14 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 14 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • An open in the sensor return
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 727 (QSK50 Marine).

Last Modified: 28-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 727 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 727 PID: SPN: 1150 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 14. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 14
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 14

Circuit Description

The exhaust gas temperature sensor circuit cylinder 14 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 14 is located in the engine harness and extends between the number 14 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 14 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

The exhaust gas temperature sensor circuit cylinder 14 measures the exhaust temperature of cylinder 14. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C or 1112°F with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C or 1112°F with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 727 (Thermistor).

Last Modified: 16-Sep-2010


Fault Code Path Selection

FAULT CODE 728
Fault Code Path Selection

Is the engine QSK50 Marine? | Go to 122-fc728qsk50mar
Does the engine have thermistors? | Go to 122-fc728thermistor

Last Modified: 26-Feb-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 728 (QSK50 Marine)

Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 728 PID: SPN: 1152 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 16. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Marine - Exhaust Gas Temperature Sensor Circuit Cylinder 16

Circuit Description

The exhaust gas temperature sensor circuit cylinder 16 monitors exhaust gas temperature and passes the information to the ECM through the engine harness.

Component Location

The exhaust temperature sensor circuit cylinder 16 is located in the exhaust manifold at the cylinder head 16 exhaust manifold interface.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 16 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Possible causes of this fault include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • An open in the sensor return
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 728 (QSK50 Marine).

Last Modified: 27-Jun-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 728 (Thermistor)

Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 728 PID: SPN: 1152 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 16. | No engine protection for exhaust gas temperature.
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK50 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK60 CM2150 Industrial - Exhaust Gas Temperature Sensor Circuit Cylinder 16
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Exhaust Gas Temperature Sensor Circuit Cylinder 16

Circuit Description

The exhaust gas temperature sensor circuit cylinder 16 monitors exhaust gas temperature and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor circuit cylinder 16 is located in the engine harness and extends between the number 16 cylinder head and the ECM.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected. The exhaust gas temperature sensor circuit cylinder 16 measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

The exhaust gas temperature sensor circuit cylinder 16 measures the exhaust temperature of cylinder 16. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

An open in the exhaust gas temperature circuit signal wire between the ECM and the exhaust gas temperature sensor will cause the exhaust gas temperature sensor connected to the ECM to read 600°C or 1112°F with INSITE™ electronic service tool. An open in the shared exhaust gas temperature sensor return (sensor return 3) of the engine harness can generate multiple fault codes for all of the sensors on the shared sensor return for that group of sensors. This will also cause all four exhaust gas temperature sensors on the shared return to read 600°C or 1112°F with INSITE™ electronic service tool.

Possible causes of this fault code include:

  • A signal circuit shorted to ground in the harness
  • A signal circuit shorted to return or ground in the sensor
  • Malfunctioning exhaust gas temperature sensor
  • Malfunctioning ECM.

The temperature sensor resistance should be in the range indicated at the following temperatures.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
100 | 212 | 290k to 480k
300 | 572 | 5.3k to 6.6k
500 | 932 | 680 to 770
700 | 1292 | 200 to 220
900 | 1652 | 84 to 95
Refer to Troubleshooting Fault Code 728 (Thermistor).

Last Modified: 16-Sep-2010


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment. Mechanical misalignment between the engine crankshaft speed/position and engine camshaft speed/position sensors. | Engine will run derated. Excessive smoke, hard start, and rough idle possible.
QSK38 CM2150 Industrial - Engine Crankshaft Speed/Position Sensor and Engine Camshaft Speed/Position Sensor Circuit
QSK50 CM2150 Industrial - Engine Crankshaft Speed/Position Sensor and Engine Camshaft Speed/Position Sensor Circuit
QSK60 CM2150 Industrial - Engine Crankshaft Speed/Position Sensor and Engine Camshaft Speed/Position Sensor Circuit
QSK38 CM2150 Power Generation/QSK38 CM2150 Power Generation (Military Application) - Engine Crankshaft Speed/Position Sensor and Engine Camshaft Speed/Position Sensor Circuit
QSK50 CM2150 Power Generation/QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Engine Crankshaft Speed/Position Sensor and Engine Camshaft Speed/Position Sensor Circuit
QSK60 CM2150 Power Generation - Engine Crankshaft Speed/Position Sensor and Engine Camshaft Speed/Position Sensor Circuit
QSK38 CM2150 Marine - Engine Crankshaft Speed/Position Sensor and Engine Camshaft Speed/Position Sensor Circuit
QSK50 CM2150 Marine - Engine Crankshaft Speed/Position Sensor and Engine Camshaft Speed/Position Sensor Circuit
QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Engine Crankshaft Speed/Position Sensor and Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine crankshaft speed/position sensor and engine camshaft speed/position sensor provide an engine speed and position signal to the ECM through the engine harness.

Component Location

The QSK38 and QSK50 engine crankshaft speed/position sensor is located at the top left area of the flywheel housing. The QSK60 engine crankshaft speed/position sensor is located at the top right area of the flywheel housing. The engine camshaft speed/position sensor is located above the fuel pump, in the back of the gear housing.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault will become active any time the ECM receives a signal from both the primary engine crankshaft speed/position sensor and the engine camshaft speed/position sensor, and the ECM determines that the camshaft and crankshaft signals are not in the correct phase. If this fault code is active immediately following a repair that includes camshaft removal, it is likely that the camshaft gear was installed incorrectly and is not timed correctly.

Refer to Troubleshooting Fault Code 731.

Last Modified: 16-Sep-2010


Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 7313

Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7313 PID: SID(S) SPN: 520754 FMI: 1/1 LAMP: Red SRT: | Engine fuel pump oil pressure signal indicates oil pressure is below the engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Engine Fuel Pump Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-volt supply to the engine fuel pump oil pressure sensor on the sensor

supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel pump oil pressure sensor

provides a signal to the ECM on the engine fuel pump oil pressure sensor signal circuit. This sensor signal voltage

changes based on the pressure in the oil flow path. The ECM will detect a low signal voltage at operating conditions

when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or

operating conditions when the oil pressure is high.

Component Location

The engine fuel pump oil pressure sensor is located in the engine fuel pump oil filter head mounted to the top of the

fuel pump adapter drive. Certain engines may have the filter head mounted remotely.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure sensor
  • Plugged or restricted lubricating oil filter.
  • Plugged or restricted lubricating oil flow path.
Refer to Troubleshooting Fault Code t05-7313.

Last Modified: 16-Apr-2020


Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 7314

Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7314 PID: SID(S) SPN: 520754 FMI: 1/18 LAMP: Amber SRT: | Engine fuel pump oil pressure signal indicates oil pressure is below the engine protection warning limit. | None on performance.
Engine Fuel Pump Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-volt supply to the engine fuel pump oil pressure sensor on the sensor

supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel pump oil pressure sensor

provides a signal to the ECM on the engine fuel pump oil pressure sensor signal circuit. This sensor signal voltage

changes based on the pressure in the oil flow path. The ECM will detect a low signal voltage at operating conditions

when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or

operating conditions when the oil pressure is high.

Component Location

The engine fuel pump oil pressure sensor is located in the engine fuel pump oil filter head mounted to the top of the

fuel pump adapter drive. Certain engines may have the filter head mounted remotely.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pump oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure sensor
  • Plugged or restricted lubricating oil filter.
  • Plugged or restricted lubricating oil flow path.
Refer to Troubleshooting Fault Code t05-7314.

Last Modified: 16-Apr-2020


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 783

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 783 PID: SPN: 105 FMI: 10 LAMP: Red SRT: | Intake Manifold 1 Temperature - Abnormal Rate of Change | Calibration-dependent progressive power derate or engine shutdown. Power Generation: Calibration-dependent possible engine shutdown.
QSK38 CM2150 Industrial/QSK38 CM2150 Marine - Intake Manifold 1 Temperature Sensor Circuit
QSK50 CM2150 Industrial/QSK50 CM2150 Marine - Intake Manifold 1 Temperature Sensor Circuit
QSK50 CM2150 Power Generation with Advanced Engine Monitoring - Intake Manifold 1 Temperature Sensor Circuit
QSK60 CM2150 Industrial/QSK60 CM2150 Marine/QSK60 CM2150 Drill Rig - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 1 temperature sensor is located in the left bank front air intake manifold.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This feature provides protection for the valves and turbocharger when a rapid increase in intake manifold temperature occurs along with a bank to bank exhaust gas temperature difference. Intake manifold temperature rapid rise monitors the change in the intake manifold 1 temperature sensor over a period of time and then logs a fault and requests a derate or shut down due to excessive temperature change. The bank to bank exhaust gas temperature difference acts as an enabler for the intake manifold temperature rapid rise feature.

Possible causes of this fault include:

  • Restricted air flow through the charge-air cooler
  • LTA cooling circuit temperature too high
  • Malfunctioning valves
  • Undersized aftercooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 783.

Last Modified: 16-Sep-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 1852 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1852?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1852.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1852?
YES NO

Repair

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion. Clean or replace the connector or sensor, as necessary.

No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Nov-2018


Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2562 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2562 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2562 active?
YES NO

Repair

Refer to Engine Oil Temperature Above Normal troubleshooting symptom tree in Section TS, in the appropriate service manual.

 No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2562 is inactive.

Fault Code 2562 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Dec-2016


FAULT CODE 4642 - Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 4642?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 4642.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 4642?
YES NO

Repair

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion.

Clean or replace the connector or sensor, as necessary.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Jun-2019


FAULT CODE 5366 - Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 5366?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 5366.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 5366?
YES NO

Repair

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion.

Clean or replace the connector or sensor, as necessary.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jan-2017


FAULT CODE 5367 - Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 5367?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 5367.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 5367?
YES NO

Repair

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion.

Clean or replace the connector or sensor, as necessary.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jan-2017


FAULT CODE 5633 - Marine Low Load Protection - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5633 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 5633.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 5633 active?
YES NO

Repair

This is an information-only fault code that will only become active if the engine torque exceeds the overload threshold for a calibratable time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Follow the technical escalation process.

Last Modified: 02-Nov-2016


FAULT CODE 5634 - Marine Overload Protection - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5634 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 5634.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 5634 active?
YES NO

Repair

This is an information-only fault code that will only become active if the engine torque exceeds the overload threshold for a calibratable time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Sep-2015


FAULT CODE 5635 - Marine Overload Protection - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5635 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 5635.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 5635 active?

This is an information-only fault code that will only become active if the engine torque exceeds the overload threshold for a calibratable time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Sep-2015


FAULT CODE 5932 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 4642?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 4642.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 4642?
YES NO

Repair

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion.

Clean or replace the connector or sensor, as necessary.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jan-2017


FAULT CODE 5946 - Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5946 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 5946 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5946 active?
YES NO

Repair

Verify transmission (or gearbox) oil level is correct. See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 214 is inactive.

Fault Code 5946 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Jan-2017


FAULT CODE 111 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2150 MCRS | 4022102

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Check ECM calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 111 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than 3 counts?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2016


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Determine if Fault Code 115 becomes active during cranking. | Fault Code 115 becomes active during cranking?
 | STEP 1B. Inspect the engine harness. | Harness connectors connected to correct sensors?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Determine if Fault Code 115 becomes active during cranking.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Attempt to start the engine by engaging the starter for at least 10 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 becomes active during cranking?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine harness connectors for correct connections.

  • Make sure the engine crankshaft speed/position sensor and engine camshaft speed/position sensor are connected to the engine wiring harness correctly.

Harness connectors connected to correct sensors?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 115 is inactive.

Fault Code 115 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troublshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-Mar-2012


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 1 pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged intake manifold 1 pressure sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

Repair

A damaged intake manifold 1 pressure sensor has been detected.

  • Replace the intake manifold 1 pressure sensor. Refer to Procedure 019-061 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit reaponse after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the intake manifold 1 pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

Repair

The removal and installation of the connector corrected the fault.

Repair

An open in the intake manifold 1 pressure RETURN (sensor return 2) circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-Mar-2012


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 1 pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of engine harness or the damaged intake manifold 1 pressure sensor.

Check harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold 1 pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

Repair

A damaged intake manifold 1 pressure sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-061 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the ECM 60-pin engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit reaponse after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A open or shorted intake manifold 1 pressure SUPPLY (sensor supply 2) circuit has been detected in the engine harness.

Repair or replace the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the intake manifold 1 pressure SIGNAL wire of the engine harness.

Troubleshoot each section of harness to determine which contains the open or pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-Mar-2012


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the engine oil rifle pressure 1 sensor and circuit. |
 | STEP 2A. Inspect the engine oil rifle pressure 1 sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Reference Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil rifle pressure 1 sensor and circuit.

Guided Step 2A - Inspect the engine oil rifle pressure 1 sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness and engine oil rifle pressure 1 sensor connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins.
  • Wire insulation damage
  • Missing or damaged connector seals
  • Connector or shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine oil rifle pressure 1 sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or engine oil rifle pressure 1 sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-066 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine oil rifle pressure 1, 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil rifle pressure 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

Repair

A damaged engine oil rifle pressure 1 sensor has been detected.

  • Replace the engine oil rifle pressure 1 sensor. Refer to Procedure 019-066 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins.
  • Wire insulation damage
  • Missing or damaged connector seals
  • Connector or shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropraite circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the engine oil rifle pressure 1 SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine oil rifle pressure 1, 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the ECM 60-pin engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN circuit has been detected in the engine oil rifle pressure 1 (sensor return 1) circuit of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 135 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 16-Mar-2012


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement. Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the engine oil rifle pressure 1 sensor and circuit. |
 | STEP 2A. Inspect the engine oil rifle pressure 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil rifle pressure 1 sensor and circuit.

Guided Step 2A - Inspect the engine oil rifle pressure 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness and engine oil rifle pressure 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine oil rifle pressure 1 sensor harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine oil rifle pressure 1 sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-066 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from the engine oil rifle pressure 1, 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine oil rifle pressure 1, 5 volt SUPPLY (sensor supply 1) pin and the engine oil rifle pressure 1 SIGNAL pin at the engine oil rifle pressure 1 sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil rifle pressure 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

Repair

A damaged engine oil rifle pressure 1 sensor has been detected.

  • Replace the engine oil rifle pressure 1 sensor. Refer to Procedure 019-066 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine oil rifle pressure 1, 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the ECM 60-pin engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or short in the engine oil rifle pressure 5 volt SUPPLY (sensor supply 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short or open circuit.

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine oil rifle pressure 1, 5 volt SUPPLY (sensor supply 1) pin and the engine oil rifle pressure 1 SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the engine oil rifle pressure 1 SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or pin-to-pin short.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 141 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 19-Mar-2012


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 19-Mar-2012


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature 1 sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature 1 sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness and engine coolant temperature 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine oil rifle pressure 1 sensor harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine oil rifle pressure 1 sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-066 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin and engine coolant temperature 1 RETURN (sensor return 1) pin at the engine coolant temperature 1 sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

  • Replace the engine coolant temperature 1 sensor. Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine coolant temperature 1 SIGNAL pin and engine coolant temperature 1 RETURN (sensor return 1) pin at the ECM 60-pin engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine coolant temperature 1 RETURN (sensor return 1) pin of the engine harness ECM 60-pin connector and the engine coolant temperature 1 RETURN (sensor return 1) connector pin of the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open engine coolant temperature 1 RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin of the engine harness ECM 60-pin connector and the engine coolant temperature 1 SIGNAL pin of the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open engine coolant temperature 1 SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin of the engine harness ECM 60-pin connector and all other pins in the engine harness ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine coolant temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature 1 sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature 1 sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness and engine coolant temperature 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine coolant temperature 1 sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged engine coolant temperature 1 sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-019 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 is active?
YES NO

Repair

A damaged engine coolant temperature 1 sensor has been detected.

  • Replace the engine coolant temperature 1 sensor. Refer to Procedure 019-019 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin of the engine harness ECM 60-pin connector and all other pins in the engine harness ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine coolant temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin in the engine harness ECM 60-pin connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the engine coolant temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 146. | Active or inactive counts of Fault Code 146?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 146.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 146.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 146?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 19-Mar-2012


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 151. | Active or inactive counts of Fault Code 151?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 151.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 151?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 19-Mar-2012


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit -Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold 1 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 1 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 1 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 1 temperature sensor or harness connector.

Check all harnesses connected in series. Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold 1 temperature sensor SIGNAL pin and intake manifold 1 temperature sensor RETURN (sensor return 1) pin at the intake manifold temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

Replace the intake manifold 1 temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 1 temperature SIGNAL pin and the intake manifold 1 temperature RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 1 temperature RETURN (sensor return 1) pin and the engine harness intake manifold 1 temperature RETURN (sensor return 1) connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open in the intake manifold 1 temperature RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 1 temperature sensor SIGNAL pin and the engine harness connector intake manifold 1 temperature sensor SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open in the intake manifold 1 temperature SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 1 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake manifold 1 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold 1 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 1 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 1 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 1 temperature sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or the damaged intake manifold 1 temperature sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is active?
YES NO

Repair

A damaged intake manifold 1 temperature sensor has been detected.

  • Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-059 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 1 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake manifold 1 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold 1 temperature SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector and pin location.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the intake manifold 1 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode will have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 1 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Intake manifold 1 temperature sensor reading is correct?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 155 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 1 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Connect INSITE™ electronic service tool.
  • Compare the intake manifold 1 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe. If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Repair

A faulty intake manifold 1 temperature sensor has been detected.

  • Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-059 in Section 19.

Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 155 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 156 - Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 156 inactive?
STEP 2. | Check the intake manifold 2 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 156 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 157 active and Fault Code 156 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 156 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 156 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 2 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 2 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 2 temperature sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged intake manifold 2 temperature sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold 2 temperature SIGNAL pin and intake manifold 2 temperature RETURN (sensor return 1) pin at the intake manifold 2 temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

  • Replace the sensor. Refer to Procedure 019-059 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 2 temperature SIGNAL pin and the intake manifold 2 temperature RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 157 active and Fault Code 156 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 2 temperature RETURN (sensor return 1) pin and the engine harness connector intake manifold 2 temperature RETURN (sensor return 1) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open intake manifold 2 temperature RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 2 temperature SIGNAL pin and the engine harness connector intake manifold 2 temperature SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open in the intake manifold 2 temperature SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 2 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode will have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 156 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 157 - Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 157 inactive?
STEP 2. | Check the intake manifold 2 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 156 active and Fault Code 157 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 157 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 156 active and Fault Code 157 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 157 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 157 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 2 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 2 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or the damaged sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 active and Fault Code 157 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 is active?
YES NO

Repair

A damaged intake manifold 2 temperature sensor has been detected.

  • Replace the intake manifold 2 temperature sensor. Refer to Procedure 019-059 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 active and Fault Code 157 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 2 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold 2 temperature SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector and pin location.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode will have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 157 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 158 - Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 2 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe. | Intake manifold 2 temperature sensor reading is correct?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 158 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 2 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 2 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 2 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe. If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 2 temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Repair

A faulty intake manifold 2 temperature sensor has been detected.

  • Replace the intake manifold 2 temperature sensor. Refer to Procedure 019-059 in Section 19.

Intake Manifold Air Temperature Above Specification troubleshooting symptom tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 158 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 159 - Intake Manifold 3 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 159 inactive?
STEP 2. | Check the intake manifold 3 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 3 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 159 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 161 active and Fault Code 159 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 159 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 159 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 159 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 3 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 3 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 3 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 3 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 3 temperature sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged intake manifold 3 temperature sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 3 temperature sensor connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold 3 temperature SIGNAL pin and intake manifold 3 temperature RETURN (sensor return 1) pin at the intake manifold 3 temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

  • Replace the intake manifold 3 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 3 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 159 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 3 temperature SIGNAL pin and the intake manifold 3 temperature RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 161 active and Fault Code 159 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 3 temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 3 temperature RETURN (sensor return 1) pin and the engine harness connector intake manifold 3 temperature RETURN (sensor return 1) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open in the intake manifold 3 temperature RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 3 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 3 temperature SIGNAL pin and the engine harness connector intake manifold 3 temperature SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open in the intake manifold 3 temperature SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 3 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 3 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake manifold 3 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 159 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode will have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 161 - Intake Manifold 3 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 161 inactive?
STEP 2. | Check the intake manifold 3 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 3 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 159 active and Fault Code 161 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 161 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 159 active and Fault Code 161 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 161 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 161 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 161 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 3 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 3 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 3 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 3 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 3 temperature sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or the damaged intake manifold 3 temperature sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 3 temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 159 active and Fault Code 161 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 3 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 161 is active?
YES NO

Repair

A damaged intake manifold 3 temperature sensor has been detected.

  • Replace the intake manifold 3 temperature sensor. Refer to Procedure 019-059 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 159 active and Fault Code 161 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 3 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 3 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake manifold 3 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 3 temperature sensor connector from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold 3 temperature SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector and pin location.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the intake manifold 3 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 161 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode will have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 162 - Intake Manifold 3 Temperature - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 3 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 3 temperature sensor accuracy with a thermocouple or similar temperature probe. | Intake manifold 3 temperature sensor reading is correct?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 162 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 3 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 3 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 3 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 3 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 3 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe. If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 3 temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Repair

A faulty intake manifold 3 temperature sensor has been detected.

  • Replace the intake manifold 3 temperature sensor. Refer to Procedure 019-059 in Section 19.

Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 162 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 163 - Intake Manifold 4 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 163 inactive?
STEP 2. | Check the intake manifold 4 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 4 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 163 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 164 active and Fault Code 163 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 163 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 163 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 163 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 4 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 4 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 4 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 4 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 4 temperature sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged intake manifold 4 temperature sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19
  • Replace the sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 4 temperature sensor connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold 4 temperature SIGNAL pin and intake manifold 4 temperature RETURN (sensor return 1) pin at the intake manifold 4 temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

  • Replace the intake manifold 4 temperature sensor. Refer to Procedure Procedure 019-059 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 4 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 163 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 4 temperature SIGNAL pin and the intake manifold 4 temperature RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 164 active and Fault Code 163 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 4 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 4 temperature RETURN (sensor return 1) pin and the engine harness connector intake manifold 4 temperature RETURN (sensor return 1) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open in the intake manifold 4 temperature RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of engine harness. Refer to Procedure 019-043 in Section 19

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 4 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 4 temperature SIGNAL pin and the engine harness connector intake manifold 4 temperature connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open in the intake manifold 4 temperature SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of engine harness. Refer to Procedure 019-043 in Section 19

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 4 temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 4 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake manifold 4 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of engine harness. Refer to Procedure 019-043 in Section 19

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 163 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode will have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Mar-2012


FAULT CODE 164 - Intake Manifold 4 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 164 inactive?
STEP 2. | Check the intake manifold 4 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 4 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 163 active and Fault Code 164 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 164 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 163 active and Fault Code 164 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 164 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 164 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 164 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 4 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 4 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 4 temperature connector sensor from the engine harness connector.

Action

Inspect the engine harness and intake manifold 4 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 4 temperature sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or the damaged intake manifold 4 temperature sensor.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 4 temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 163 active and Fault Code 164 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 4 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 164 is active?
YES NO

Repair

A damaged intake manifold 4 temperature sensor has been detected.

  • Replace the intake manifold 4 temperature sensor. Refer to Procedure 019-059 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 163 active and Fault Code 164 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 4 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 4 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake manifold 4 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 4 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold 4 temperature SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector and pin location.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the intake manifold 4 temperature SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 164 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode will have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Mar-2012


FAULT CODE 165 - Intake Manifold 4 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 4 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 4 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading agree with the intake manifold 4 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 165 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 4 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 4 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 4 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 4 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 4 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe. If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 4 temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Repair

A damaged intake manifold 4 temperature sensor has been detected.

  • Replace the intake manifold 4 temperature sensor. Refer to Procedure 019-059 in Section 19.

Intake Manifold Air Temperature Above Specification troubleshooting symptom tree

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Mar-2012


FAULT CODE 187 (Source Address 00) Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3822812 - female Deutsch™ test lead, Part Number 3822758- male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917- female Deutsch™/AMP™/ Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 2 and return. |
 | STEP 2A. Inspect the engine camshaft speed/position sensor and circuit connected to the sensor supply 2 and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 187 active?
 | STEP 2C. Inspect the intake manifold 1 pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2D. Check the circuit response. | Fault Code 187 active?
 | STEP 2E. Inspect the injector metering rail 1 pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2F. Check the circuit response. | Fault Code 187 active?
 | STEP 2G. Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2H. Check the circuit response. | Fault Code 187 active?
 | STEP 2I. Inspect the fuel delivery pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2J. Check the circuit response. | Fault Code 187 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 187 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 2 and return.

Guided Step 2A - Inspect the engine camshaft speed/position sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor from the engine harness connector.

Action

Inspect the engine harness and engine camshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection had been detected in the camshaft speed/position sensor connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged camshaft speed/position sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-363 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the engine camshaft speed/position sensor.

  • Refer to Procedure 019-363 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the intake manifold 1 pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 1 pressure sensor connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged intake manifold 1 pressure sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 minutes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the intake manifold 1 pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the injector metering rail 1 pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector metering rail 1 pressure sensor connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged injector metering rail 1 pressure sensor.

Refer to the wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-115 in Section 19.
No Repair

Go to 4A

Go to 2F

Guided Step 2F - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the injector metering rail 1 pressure sensor.

  • Replace the sensor. Refer to Procedure 019-115 in Section 19.

Go to 2G

Go to 4A

Guided Step 2G - Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the barometric pressure sensor connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged barometric pressure sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-004 in Section 19.
No Repair

Go to 4A

Go to 2H

Guided Step 2H - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the barometric pressure sensor.

  • Refer to Procedure 019-115 in Section 19.

Go to 2I

Go to 4A

Guided Step 2I - Inspect the fuel delivery pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the fuel delivery pressure sensor connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged fuel delivery pressure sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-398 in Section 19.
No Repair

Go to 4A

Go to 2J

Guided Step 2J - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the fuel delivery pressure sensor.

  • Refer to Procedure 019-398 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit art or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

There is a short circuit to ground or short circuit from pin-to-pin in the engine harness.

Troubleshoot each section of the engine harness connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Mar-2012


FAULT CODE 187 (Source Address 01) - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3164597 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensor circuit connected to the sensor supply 2 and return. |
 | STEP 2A. Inspect the pre-filter oil pressure sensor and circuit connected to the sensor supply 2 and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 187 active?
 | STEP 2C. Inspect the intake manifold 2 pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2D. Check the circuit response. | Fault Code 187 active?
 | STEP 2E. Check for a post-oil filter pressure sensor. | Is the engine a QSK60?
 | STEP Inspectthepost-oilfilterpressuresensorandcircuitconnectedtosensorsupply2andreturn.. | Dirty or damaged pins?
 | STEP 2G. Check the circuit response. | Fault Code 187 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 187 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensor circuits connected to the sensor supply 2 and return.

Guided Step 2A - Inspect the pre-oil filter pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and pre-oil filter pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection had been detected in the pre-filter oil pressure sensor connector or engine harness connector.

Clean the connector or the damaged pre-filter oil pressure sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the sensor. Refer to Procedure 019-126 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-filter oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE ™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

  • Replace the pre-filter oil pressure sensor. Refer to Procedure 019-126 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the intake manifold 2 pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine from the engine harness connector.

Action

Inspect the engine harness and intake manifold 2 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 2 pressure sensor connector or engine harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness or the damaged intake manifold 2 pressure sensor.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

  • Replace the intake manifold 2 pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a post-oil filter pressure sensor.

Action

Check if the engine has a post-oil filter pressure sensor.

Is the engine a QSK60?
YES | NO
No Repair | No Repair

Go to 2F

Go to 3A

Guided Step 2F - Inspect the post-oil filter pressure sensor and circuit connected to the sensor supply 2 and return, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-oil filter pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and post-oil filter pressure sensor connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the post-oil filter sensor connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged post-oil filter pressure sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-447 in Section 19.
No Repair

Go to 4A

Go to 2G

Guided Step 2G - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-oil filter pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropirate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

  • Replace the post-oil filter pressure sensor. Refer to Procedure 019-447 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit art or wiring diagram for all engine harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

There is a short circuit to ground or short circuit from pin-to-pin in the engine harness.

Troubleshoot each section of the engine harness connected in series to determine which contains the short circuit to ground or short circuit from pin-to-pin.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness or damage sensor.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Mar-2012


FAULT CODE 195 - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824811 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the engine coolant level sensor and harness connector. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 800k ohms?
STEP 3. | Check the engine harness and OEM harness. |
 | STEP 3A. Inspect the engine harness and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM or engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and harness connector.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector or engine harness connector from the coolant level sensor connector.

Action

Inspect the OEM harness or engine harness connector and coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, pins, or replace the coolant level sensor.

  • Repair the OEM wiring harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-017 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor connector from the OEM harness connector or engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the coolant level 1 SIGNAL pin and the coolant level 1 RETURN pin at the coolant level sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 800k ohms?
YES NO

Repair

Replace the coolant level sensor.

Refer to Procedure 019-017 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness and OEM harness.

Guided Step 3A - Inspect the engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the OEM harness connector from the engine harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness, or the ECM.

Check all harnesses connected in series.

  • Repair the OEM wiring harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the coolant level sensor connector from the OEM harness connector or engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant level 1 RETURN pin and the harness connector coolant level 1 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the OEM harness or engine harness.

Troubleshoot each section of the engine and OEM harnesses to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness or OEM harness.

  • Repair the OEM wiring harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the coolant level sensor connector from the OEM harness connector or engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the coolant level 1 SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness or engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness or OEM harness.

  • Repair the OEM wiring harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Mar-2012


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the coolant level sensor 1 and harness connector. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the OEM harness, engine harness, and ECM. |
 | STEP 3A. Inspect the OEM harness, engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the coolant level sensor 1 and harness connector.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor connector from the OEM harness connector or engine harness connector.

Action

Inspect the OEM harness or engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, or replace the coolant level sensor, if possible.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-017 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor connector from the OEM harness connector or engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant level sensor connector to the OEM harness connector or engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

Repair

A damaged engine coolant level sensor has been detected.

  • Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness, engine harness, and ECM.

Guided Step 3A - Inspect the OEM harness, engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the harness connector from the sensor connector.
  • Disconnect the OEM harness connector from the engine harness connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the OEM harness, the engine harness, or the ECM.

Clean the connector and pins.

Replace the damaged section of the OEM harness, the engine harness, or the ECM.

Check all harnesses connected in series.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the coolant level sensor connector from the OEM harness connector or engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance and check for a short circuit between the coolant level 1 SIGNAL pin at the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit between pins has been detected in the OEM harness or engine harness.

Troubleshoot each of the harness sections to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness or OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the coolant level sensor connector from the OEM harness connector or engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance and check for a short circuit between the engine coolant level 1 SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the OEM harness or engine harness.

Troubleshoot each of the harness sections to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness or OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 196 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Mar-2012


FAULT CODE 197 - Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
 | STEP 1B. Check the coolant level | Fault Code active or inactive?
STEP 2. | Check the engine harness and ECM. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the coolant level sensor 1 and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 197 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete

Guided Step 1B - Check the coolant level.

Conditions

  • Make sure the engine coolant temperature is below 50°C [122°F].

Action

Check for fault codes.

Make sure the engine coolant temperature is below 50°C [122°F] before removing the radiator cap.

Fault Code active or inactive?
YES NO
No Repair

Repair

Fill the radiator top tank or surge tank with coolant.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness and ECM.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the ECM.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the coolant level sensor 1 and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor 1 from the engine harness.

Action

Inspect the coolant level sensor 1 and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the coolant level sensor or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the coolant level sensor.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram from all harness interconnections.

  • Replace the sensor. Refer to Procedure 019-017 in Section 19.
No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level 1 sensor connector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the coolant level 1, 5 volt supply (sensor supply 1) SUPPLY pin of the engine harness connector and the coolant level 1, 5 volt supply (sensor supply 1) SUPPLY pin of the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SUPPLY wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the coolant level 1 SIGNAL pin and the battery 1 voltage (ECM 1) pin of the ECM 4-pin OEM power harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Return to the troubleshooting steps. A fault mode should have been detected.

Repair

A pin-to-pin short circuit has been detected in the coolant level 1 SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 197 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Mar-2012


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the engine oil temperature sensor 1 and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 212 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 213 active and Fault Code 212 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 212 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor 1 and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Inspect the engine harness and engine oil temperature sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins.
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector or shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine oil temperature sensor 1 or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged engine oil temperature sensor 1. Refer to Procedure 019-067 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the engine oil temperature 1 SIGNAL pin and engine oil temperature 1 RETURN (sensor return 1) pin at the engine oil temperature sensor 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

  • Replace the damaged engine oil temperature sensor 1. Refer to Procedure 019-067 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil temperature sensor 1 connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins.
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector or shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Replace the damaged section of harness.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil temperature 1 SIGNAL pin and engine oil temperature 1 RETURN (sensor return 1) pin at the ECM 60-pin engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active and Fault Code 212 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil temperature 1 RETURN (sensor return 1) pin of the engine harness connector and the oil temperature 1 RETURN (sensor return 1) pin of the engine harness ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open engine oil temperature RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine oil temperature 1 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil temperature 1 SIGNAL pin of the engine harness ECM 60-pin connector and the engine oil temperature 1 SIGNAL pin of the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open engine oil temperature 1 SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature 1 SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the engine harness ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine oil temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 212 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Mar-2012


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor 1 and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 213 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor 1 and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Inspect the engine harness and engine oil temperature sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine oil temperature 1 sensor or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged engine oil temperature 1 sensor. Refer to Procedure 019-067 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor 1 connector to the engine harness connector
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 is active?
YES NO

Repair

A damaged engine oil temperature sensor 1 has been detected.

  • Replace the damaged engine oil temperature 1 sensor. Refer to Procedure 019-067 in Section 19.

Repair

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine oil temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine oil temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine oil temperature 1 SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the engine oil temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode will have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 213 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 214 active?
STEP 2. | Clear the Fault Codes. |
 | STEP 2A. Disable the fault code. | Fault Code 214 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active?
YES NO

Repair

Refer to Engine Oil Temperature Above Normal troubleshooting symptom tree in the appropriate service manual.

 No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 214 is inactive.

Fault Code 214 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227, on the same source address as Fault Code 221, active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227, on same source address as Fault Code 221, active?
YES | NO
No Repair | No Repair

Refer to Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the barometric pressure sensor or the engine harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged barometric pressure sensor. Refer to Procedure 019-004 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the barometric pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

Repair

A damaged barometric sensor has been detected.

  • Replace the damaged barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the barometric pressure SIGNAL wire of the engine harness.

Check each section of harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the ECM 60-pin engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

An open barometric pressure RETURN (sensor return 2) circuit has been detected in the engine harness.

Check each section of harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 221 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187, on same source address as Fault Code 222, active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187, on same source address as Fault Code 222, active?
YES | NO
No Repair | No Repair

Refer to Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the barometric pressure sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged barometric pressure sensor. Refer to Procedure 019-004 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the barometric pressure 5 volt SUPPLY (sensor supply 2) pin and the barometric pressure SIGNAL pin at the barometric pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

Repair

A damaged barometric pressure sensor has been detected.

  • Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted barometric pressure 5 volt SUPPLY (sensor supply 2) circuit has been detected in the engine harness.

Check each section of engine harness to determine which contains the open or short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the barometric pressure 5 volt SUPPLY (sensor supply 2) pin and the barometric pressure SIGNAL pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

An open RETURN or a pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Check each section of the engine harness to determine which contains the open or pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 222 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 223 - Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823995 - male Weather Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil burn valve solenoid driver. |
 | STEP 1A. Verify the engine oil burn valve solenoid driver is connected to the engine harness. | Engine oil burn valve solenoid driver connected to engine harness?
 | STEP 1B. Inspect the engine oil burn valve solenoid driver and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the engine oil burn valve solenoid driver for a short circuit to engine block ground. | 15 to 22 ohms (12-VDC) or 64.5 to 94.7 ohms (24-VDC)?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 223 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil burn valve solenoid driver.

Guided Step 1A - Verify the engine oil burn valve solenoid driver is connected to the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the engine oil burn valve solenoid driver is connected to the engine harness.

Engine oil burn valve solenoid driver connected to engine harness?
YES NO
No Repair

Repair

Connect the engine oil burn valve solenoid driver to the engine harness.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the engine oil burn valve solenoid driver and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.

Action

Inspect the engine oil burn valve solenoid driver and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine oil burn valve solenoid driver connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of the harness or damaged engine oil burn valve solenoid driver.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the connector. Refer to Procedure 019-173 in Section 19.
No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the engine oil burn valve solenoid driver for a short circuit to engine block ground.

Conditions

  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.

Action

Check for a short circuit to ground in the engine oil burn valve solenoid driver.

  • Measure the resistance from the engine oil burn valve solenoid driver SIGNAL pin of the engine oil burn valve solenoid driver connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

  • 15 to 22 ohms (12-VDC)?
  • 64.5 to 94.7 ohms (24-VDC)?
YES NO
No Repair

Repair

  • Replace the engine oil burn valve solenoid driver. Refer to Procedure 019-173 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or ECM.

Clean the connector and pins.

Replace the damaged section of the harness or damaged engine oil burn valve solenoid driver.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine oil burn valve solenoid driver SIGNAL pin of the engine harness ECM connector to engine block ground.
  • Measure the resistance from the engine oil burn valve solenoid driver RETURN pin of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine oil burn valve solenoid driver SIGNAL pin of the engine harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 30 seconds.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 223 is inactive.

Fault Code 223 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 224 - Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823995 - male Weather Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check if engine is equipped with an oil burn valve solenoid or a resistor jumper at the engine oil burn valve solenoid driver connector. | Does engine have an engine oil burn valve solenoid?
 | STEP 1B. Check for an engine oil burn valve solenoid (marine engine only). | Does engine have an engine oil burn valve solenoid?
 | STEP 1C. Check for an active fault code. | Fault Code 224 active?
STEP 2. | Check the engine oil burn valve solenoid driver. |
 | STEP 2A. Inspect the engine harness and engine oil burn valve solenoid driver. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine oil burn valve solenoid driver. | 15 to 22 ohms (12-VDC) or 64.5 to 94.7 ohms (24-VDC)?
 | STEP 2C. Check the engine oil burn valve solenoid driver supply voltage and return circuit. | Greater than 6.0-VDC?
 | STEP 2D. Check for an open circuit in the engine oil burn valve solenoid driver return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM engine oil burn valve solenoid driver diagnostic supply voltage. | Greater than 6.0-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 224 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 224 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check if the engine is equipped with an oil burn valve solenoid or a resistor jumper at the engine oil burn valve solenoid driver connector.

Conditions

Action

Check for an engine oil burn valve solenoid (marine only).

Does engine have an engine oil burn valve solenoid?
YES | NO
No Repair | No Repair

Go to 1C

Go to 1B

Guided Step 1B - Check the engine harness resistor jumper (marine only).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid resistor jumper from the engine harness.

Action

Measure the resistance across the engine oil burn valve resistor jumper.

230 ohms?
YES NO
No Repair

Repair

A damaged resistor has been detected.

Replace the resistor.

Go to 2A

Go to 3A

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 224 is active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil burn valve solenoid driver.

Guided Step 2A - Inspect the engine harness and engine oil burn valve solenoid driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Inspect the engine harness and engine oil burn valve solenoid driver connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or engine oil burn valve solenoid driver.

Clean the connector and pins.

Replace the damaged section of the harness or damaged engine oil burn valve solenoid driver.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the connector. Refer to Procedure 019-173 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine oil burn valve solenoid driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Check for an open circuit in the engine oil burn valve solenoid driver.

  • Measure the resistance from the engine oil burn valve solenoid driver SIGNAL pin to the engine oil burn valve solenoid driver RETURN pin at the engine oil burn valve solenoid driver.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

  • 15 to 22 ohms (12-VDC)?
  • 64.5 to 94.7 ohms (24-VDC)?
YES NO
No Repair

Repair

  • Replace the engine oil burn valve solenoid driver. Refer to Procedure 019-173 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the engine oil burn valve solenoid driver supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine oil burn valve solenoid driver SIGNAL pin and the engine oil burn valve solenoid driver RETURN pin at the engine oil burn valve solenoid driver connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 6.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the engine oil burn valve solenoid driver return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.

Action

Check for an open circuit.

  • Measure the resistance from the engine oil burn valve solenoid driver engine harness connector RETURN pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness or ECM connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM engine oil burn valve solenoid driver diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the engine oil burn valve solenoid driver SIGNAL pin and the engine oil burn valve solenoid driver RETURN pin at the ECM connector port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 6.0-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil burn valve solenoid driver harness connector SIGNAL pin and the engine oil burn valve solenoid driver engine harness connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the ECM connector.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil burn valve solenoid driver SIGNAL pin in the engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine oil burn valve solenoid driver SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 224 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 30 seconds.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 224 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 227 (Source Address 00) - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ECM response. | Fault Code 227 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector .

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector .
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 227 (Source Address 01) - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ECM response. | Fault Code 227 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the ECM connector or the engine harness.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 2B

Guided Step 2B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector .
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 228 - Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault code 228. | Active or inactive counts of Fault Code 228?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 228.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 228?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Go to 1B

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 231 - Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 231 inactive?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 232 active and Fault code 231 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 231 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 231 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 231 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness 60-pin connector.

Action

Check for an inactive fault code

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the coolant pressure sensor or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace damaged coolant pressure sensor. Refer to Procedure 019-016 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active and Fault Code 231 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the coolant pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active?
YES NO

Repair

A damaged coolant pressure sensor has been detected.

  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropraite circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active and Fault Code 231 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the coolant pressure SIGNAL line of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open coolant pressure RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 231 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 232 - Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for inactive fault code. | Fault Code 232 inactive?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 231 active and Fault Code 232 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 232 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 232 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and coolant pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the coolant pressure sensor harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged coolant pressure sensor. Refer to Procedure 019-016 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the coolant pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the coolant pressure 5 volt SUPPLY (sensor supply 1) pin and the coolant pressure SIGNAL pin at the coolant pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active and Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

Repair

A damaged coolant pressure sensor has been detected.

  • Replace the damaged coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the ECM 60-pin engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted coolant pressure SUPPLY (sensor supply 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short or open circuit.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant pressure 5 volt SUPPLY (sensor supply 1) pin and the coolant pressure SIGNAL pin at the ECM 60-pin engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active and Fault Code 232 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the coolant pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or pin to pin short.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 232 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Locationif all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 30-Mar-2012


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed exceeds 125 percent of rated speed, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Engine motoring downhill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1E. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1F. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Engine motoring downhill?
YES NO
No Repair

Repair

Check for engine damage.

  • Electronics are OK.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a uncommanded acceleration where the engine rapidly accelerated to or past 115 percent of rated rpm, followed by moderate deceleration to 115 percent of rated rpm.

Alternate fuel source?
YES NO

Repair

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine crankshaft speed/position sensor reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Repair

Inspect the engine crankshaft speed/position sensor and the engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1D

Fault Codes 689 and 1376

Guided Step 1D - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the engine harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the damaged engine crankshaft speed/position sensor.
 No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 234 when the engine is operating below rated rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1F

Go to 2A

Guided Step 1F - Test the vehicle.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Test the vehicle in a road test to check if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 235. | Active or inactive counts of Fault Code 235?
 | STEP 1B. Check the coolant level. | Coolant level normal?
STEP 2. | Check the engine harness and ECM. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the coolant level sensor 1 and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 235 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 235.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 235?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 1B - Check the coolant level.

Conditions

  • Engine coolant temperature below 50°C [122°F].

Action

Check the coolant level in the radiator top tank or surge tank.

Make sure the engine coolant temperature is below 50°C [122°F] before removing the radiator cap.

Coolant level normal?
YES NO
No Repair

Repair

Fill the radiator top tank or surge tank with coolant.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness and ECM.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the ECM.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the coolant level sensor 1 engine harness and the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant level sensor 1 connector.

Action

Inspect the engine harness and the coolant level sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness or the coolant level sensor 1 connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the the coolant level sensor 1.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant level sensor 1. Refer to Procedure 019-017 in Section 19.
No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level 1 sensor connector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the coolant level 1-5 volt supply (sensor supply1) SUPPLY pin of the coolant level sensor 1 engine harness connector and the coolant level 1-5 volt supply (sensor supply 1) SUPPLY pin of the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to the circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SUPPLY wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the coolant level 1 SIGNAL pin and the battery 1 voltage (ECM1) pin of the ECM 4-pin OEM power harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Return to the troubleshooting steps. A fault should have been detected.

Repair

A pin-to-pin short circuit has been detected in the coolant level 1 SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 235 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Jul-2012


FAULT CODE 237 - External Speed Command Input (Multiple Unit Synchronization) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Determine which engine is shutting down. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 426 and 497 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the output driver supply voltage. | 11.75 to 12.25-VDC?
 | STEP 2C. Check the 5 volt supply. | 4.75 to 5.25-VDC?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault Code 237 inactive?

Guided Step 1 - Determine which engine is shutting down.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 426 and 497 active or inactive with more than one count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate troubleshooting steps

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector from the ECM connector on the secondary engine.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the connector. Refer to Procedure 019-204
  • Repair the engine harness. Refer to Procedure 019-043
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the output driver supply voltage.

Conditions

  • Disconnect the engine harness connector from the ECM on the secondary engine.
  • Turn keyswitch ON.

Action

Check the output driver supply voltage.

  • Measure the voltage from the external speed command input SIGNAL pin of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

11.75 to 12.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the 5 volt supply.

Conditions

  • Disconnect the engine harness ECM connector from the ECM connector on the secondary engine.
  • Turn keyswitch OFF.

Action

Check the 5 volt supply.

  • Measure the voltage from the external speed input RETURN pin of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector from the ECM connector on the secondary engine.
  • Disconnect the engine harness ECM connector from the OEM harness connector on the secondary engine.

Action

Check for an open circuit.

  • Measure the resistance from the external speed command input SIGNAL pin of the engine harness ECM connector to the external speed command input SIGNAL pin of the OEM connector.
  • Measure the resistance from the frequency input RETURN (VSS)/auxiliary governor pin of the engine harness connector to the external speed command input RETURN pin of the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the connector. Refer to Procedure 019-199 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector from the ECM connector on the secondary engine.
  • Disconnect the engine harness ECM connector from the OEM harness connector on the secondary engine.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the external speed command input SIGNAL pin of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from the external speed command input RETURN pin of the engine harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 inSection 19.
  • Repair the connector. Refer to Procedure 019-199 in Section 19.

Go to 2F

Go to 5A

Guided Step 2F - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector from the ECM connector on the secondary engine.
  • Disconnect the engine harness ECM connector from the OEM harness connector on the secondary engine.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the external speed command input SIGNAL pin of the engine harness ECM connector to engine block ground.
  • Measure the resistance from the external speed command input RETURN pin of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the connector. Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness connector on the secondary engine.
  • Disconnect the engine harness connector from the OEM harness connector on the primary engine.

Action

Inspect the OEM harness connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the connector. Refer to Procedure 019-207 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23 pin OEM connector from the engine harness on the primary engine.
  • Disconnect the 31 pin OEM connector from the engine harness on the secondary engine.

Action

Check for an open circuit.

  • Measure the resistance from the auxiliary PWM driver SIGNAL pin on the 23 pin OEM connector of the primary engine to the external speed command input SIGNAL pin on the 31 pin OEM connector of the secondary engine.
  • Measure the resistance from the OEM-provided 5 volt SUPPLY to the external speed command input RETURN pin on the 31-pin OEM connector of the secondary engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23 pin OEM connector from the engine harness on the primary engine.
  • Disconnect the 31 pin OEM connector from the engine harness on the secondary engine.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the auxiliary PWM driver SIGNAL pin on the 23 pin OEM connector of the primary engine to all other pins in the connector.
  • Measure the resistance from the OEM-provided 5 volt SUPPLY to all other pins in the 23 pin OEM connector of the primary engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23 pin OEM connector from the engine harness on the primary engine.
  • Disconnect the 31 pin OEM connector from the engine harness on the secondary engine.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the OEM actuator pulse width modulation output pin on the 23 pin OEM connector of the primary engine to engine block ground.
  • Measure the resistance from the OEM-provided 5 volt SUPPLY to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness connector on the primary engine.
  • Disconnect the engine harness ECM connector from the ECM connector on the primary engine.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the connector. Refer to Procedure 019-204 in Section 19.
No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23 pin OEM connector from the engine harness on the primary engine.
  • Disconnect the engine harness ECM connector from the ECM on the primary engine.

Action

Check for an open circuit.

  • Measure the resistance from the auxiliary pulse width moduled (PWM) driver 1 SIGNAL pin on the 23 pin OEM connector to the auxiliary PWM driver 1 SIGNAL pin on the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the connector. Refer to Procedure 019-199 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23 pin OEM connector from the engine harness connector on the primary engine.
  • Disconnect the engine harness ECM connector from the ECM connector on the primary engine.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the auxiliary PWM driver 1 SIGNAL pin on the engine harness ECM connector all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the connector. Refer to Procedure 019-199 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23 pin OEM connector from the engine harness connector on the primary engine.
  • Disconnect the engine harness ECM connector from the ECM connector on the primary engine.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the auxiliary PWM driver 1 SIGNAL pin on the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the connector. Refer to Procedure 019-199 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 237 is inactive.

Fault Code 237 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 08-Sep-2017


FAULT CODE 238 (Source Address 00) - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | QSK50 CM2150 MCRS | 4022102
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2150 MCRS | 4022102

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the sensors and circuits connected to the sensor supply 3 and return. |
 | STEP 2A. Inspect the engine crankshaft speed/position sensor and circuit connected to the sensor supply 3 and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine wiring harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine control module (ECM) response. | Fault Code 238 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check for an active fault code.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair Complete

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 3 and return.

Guided Step 2A - Inspect the engine crankshaft speed/position sensor connector and circuit connected to the sensor supply 3 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine wiring harness connector.

Action

Inspect the engine wiring harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection had been detected in the engine crankshaft speed/position sensor or wiring harness connector.

Clean the connector and pins.

  • Repair or replace the damaged section of the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the damaged engine crankshaft speed/position sensor. Refer to Procedure 019-042 in the Associated Procedure Table.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine wiring harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Repair

  • Replace the damaged engine crankshaft speed/position sensor. Refer to Procedure 019-042 in the Associated Procedure Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM 60-pin connector.

Action

Inspect the engine wiring harness and ECM connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine wiring harness.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all wiring harness interconnections.

  • Repair or replace only the components and/or damaged section the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM 60-pins connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine wiring harness and ECM connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 238 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot each section of the wiring harnesses connected in series to determine which contains the short circuit to ground or pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all wiring harness interconnections.

  • Repair or replace the damaged section of the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 27-Jun-2018


FAULT CODE 238 (Source Address 01) - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | QSK50 CM2150 MCRS | 4022102
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2150 MCRS | 4022102

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the sensors and circuits connected to the sensor supply 3 and return. |
 | STEP 2A. Inspect the exhaust gas temperature sensor converter and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. |
STEP 3. | Check the engine control module (ECM). |
 | STEP 3A. Inspect the ECM and engine wiring harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 238 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 3 and return.

Guided Step 2A - Inspect the engine crankshaft speed/position sensor connector and circuit connected to the sensor supply 3 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine wiring harness connector.

Action

Inspect the engine wiring harness and converter connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Repair and replace the damaged section of wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged converter. Refer to Procedure 019-450 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine wiring harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Repair

Replace the damaged engine crankshaft speed/position sensor.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM 60-pin connector.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine wiring harness.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all wiring harness interconnections.

  • Repair or replace only the components and/or damaged section of the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot each section of the wiring harnesses connected in series to determine which contains the short circuit to ground or pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all wiring harness interconnections.

  • Repair or replace only the damaged section of the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine wiring harness and ECM connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 238 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot each section of the wiring harnesses connected in series to determine which contains the short circuit to ground or pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all wiring harness interconnections.

  • Repair or replace only the damaged section of the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 27-Jun-2018


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the fan control and circuit. |
 | STEP 2A. Inspect the fan control and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control. | Within the original equipment manufacturer (OEM) resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control. |
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 245 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 245 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control and circuit.

Guided Step 2A - Inspect the fan control and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the OEM harness connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the fan control or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or fan control.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the fan control circuit. Refer to Procedure 019-045 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the OEM or engine harness connector.

Action

Check for low internal resistance of the fan control.

  • Use a multimeter to measure the resistance between the fan control SIGNAL and fan control RETURN (sensor return 1) pin of the fan control connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to the OEM service manual for resistance specifications.

Use the following procedure for connector pin identification. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Repair

Replace the fan control.

  • Repair the fan control circuit. Refer to Procedure 019-045 in Section 19.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the OEM or engine harness connector.

Action

Short circuit on one connector pin-to-ground check:

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground:

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the fan control.

  • Repair the fan control circuit. Refer to Procedure 019-045 in Section 19.

Go to 2C

Go to 4A

Guided Step 3 - Check the ECM, engine harness, and OEM harness.

Guided Step 3A - Inspect all OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness and OEM harness connections.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the fan control or harness connector.

Replace the damaged section of the harness or fan control.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the fan control circuit. Refer to Procedure 019-045 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the fan control connector from the OEM or engine harness connector.

Action

Short circuit on one connector pin-to-ground check:

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-ground short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector
  • Disconnect the fan control connector from the OEM or engine harness connector.

Action

Short circuit on one connector pin-to-pin check:

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Disconnect the fan control solenoid from the OEM or engine harness.
  • Turn the keyswitch OFF.
  • Connect the fan control solenoid to the OEM or engine harness.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault Code 245 inactive?
YES NO
No Repair

Repair

Reference the Master Repair Manual, Marine C Command™ Basic Panel Manual Systems, Bulletin 4021587, or the Master Repair Manual, Marine C Command Elite™ and C Command Elite Plus™ Panel System, Bulletin 4021617.

Go to 4B

Appropriate Troubleshooting Steps

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Sep-2017


FAULT CODE 261 - Engine Fuel Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - Metri-Pack 2-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine fuel temperature 1 sensor accuracy. |
 | STEP 1A. Verify the engine fuel temperature 1 sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 261 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine fuel temperature 1 sensor accuracy.

Guided Step 1A - Verify the engine fuel temperature 1 sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the engine fuel temperature 1 sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the bottom-side of the control valve body, nearest the engine fuel temperature 1 sensor.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Compare the engine fuel temperature 1 reading on INSITE™ service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer Yes to this step.

Sensor reading is correct?
YES NO

Repair

For K38, K50, and QSK50 engines, use the following symptom tree in Service Manual, K38, K50 and QSK50, Bulletin 4021528. Reference the Fuel Temperature Above Normal troubleshooting symptom tree.

For QSK45 and QSK60 engines, use the following symptom tree in Service Manual, K38, K50 and QSK50, Bulletin 4021530. Reference the Fuel Temperature Above Normal troubleshooting symptom tree.

Repair

Replace the engine fuel supply temperature 1 sensor.

Refer to Procedure 019-119 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Jul-2012


FAULT CODE 263 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 263 inactive?
STEP 2. | Check the engine fuel temperature sensor 1 and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 600 ohms to 36k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 263 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 265 active and Fault Code 263 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 263 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 263 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine fuel temperature sensor 1 and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 connector from the engine harness connector.

Action

Inspect the engine harness and engine fuel temperature sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine fuel temperature sensor 1 or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine fuel temperature sensor 1.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-119 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the engine fuel temperature sensor 1 SIGNAL pin and engine fuel temperature sensor 1 RETURN (sensor return 1) pin at the engine fuel temperature sensor 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the engine fuel temperature sensor 1.

  • Refer to Procedure 019-119 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor 1 connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine fuel temperature 1 SIGNAL pin and engine fuel temperature 1 RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active and Fault Code 263 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine fuel temperature sensor 1 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature 1 RETURN (sensor return 1) pin and the engine harness connector engine fuel temperature 1 RETURN (sensor return 1) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open engine fuel temperature 1 RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine fuel temperature sensor 1 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature 1 SIGNAL pin and the engine harness connector engine fuel temperature 1 SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open engine fuel temperature 1 SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine fuel temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel temperature 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine fuel temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 263 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Jul-2012


FAULT CODE 265 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 265 inactive?
STEP 2. | Check the engine fuel temperature sensor 1 and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 265 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 3C. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 265 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 265 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine fuel temperature sensor 1 and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 connector from the engine harness connector.

Action

Inspect the engine harness and engine fuel temperature sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine fuel temperature sensor 1 or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine fuel temperature sensor 1.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-119 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor 1 connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 is active?
YES NO

Repair

A damaged engine fuel temperature sensor 1 has been detected.

Replace the engine fuel temperature sensor 1.

  • Refer to Procedure 019-119 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine fuel temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel temperature 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine fuel temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine fuel temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine fuel temperature 1 SIGNAL pin in the engineharness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A pin-to-ground short circuit on the engine fuel temperature 1 SIGNAL wire has been detected inthe engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Repair

Troubleshooting procedures need to be repeated from the beginning. A malfunctioning mode should have been detected.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be checked again from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 265 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Jul-2012


FAULT CODE 266 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - Metri-Pack™ 2-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine fuel temperature sensor 1 accuracy. |
 | STEP 1A. Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe. | Readings are correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 266 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine fuel temperature sensor 1 accuracy.

Guided Step 1A - Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Compare the engine fuel temperature sensor 1 reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer Yes to this step.

NOTE: Readings will possibly need to be checked while engine is operating at normal temperature conditions (82°C [180°F]).

Readings are correct?
YES NO

Repair

Make sure the fuel tanks are adequately filled.

Repair

Replace the fuel supply temperature sensor.

Refer to Procedure 019-119 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Jul-2012


FAULT CODE 271 - Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 271 inactive?
STEP 2. | Check the fuel pump pressurizing assembly 1 and circuit. |
 | STEP 2A. Inspect the fuel pump pressurizing assembly 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 271 inactive and Fault Code 272 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 271 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 3C. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 265 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 265 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump pressurizing assembly 1 and circuit.

Guided Step 2A - Inspect the fuel pump pressurizing assembly 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Inspect the engine harness and fuel pump pressurizing assembly 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the engine harness or fuel pump pressurizing assembly 1.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-117 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active and Fault Code 271 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump pressurizing assembly 1 connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES NO

Repair

A damaged fuel pump pressurizing assembly 1 has been detected.

Replace the fuel pump pressurizing assembly 1.

  • Refer to Procedure 019-117 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active and Fault Code 271 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the fuel pump pressurizing assembly 1 from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine fuel temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of engine harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A pin-to-ground short circuit on the engine fuel temperature 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be checked again from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 271 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Apr-2012


FAULT CODE 272 - Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - male Bosch™ test lead and Part Number 3164111 - female Bosch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 272 active?
STEP 2. | Check the fuel pump pressurizing assembly 1 and circuit. |
 | STEP 2A. Inspect the fuel pump pressurizing assembly 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel pump pressurizing assembly 1. | Less than 5 ohms?
 | STEP 2C. Check for an open circuit in the fuel pump pressurizing assembly 1 return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 272 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 272 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump pressurizing assembly 1 and circuit.

Guided Step 2A - Inspect the fuel pump pressurizing assembly 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Inspect the engine harness and fuel pump pressurizing assembly 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or the fuel pump pressurizing assembly 1.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-117 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel pump pressurizing assembly 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Control valve continuity - pin-to-pin continuity check:

  • Measure the resistance and check for an open circuit between the fuel pump pressurizing assembly 1 SIGNAL pin and the fuel pump pressurizing assembly 1 RETURN pin.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Replace the fuel pump pressurizing assembly 1.

  • Refer to Procedure 019-117 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the fuel pump pressurizing assembly 1 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness fuel pump pressurizing assembly 1 RETURN pin and ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open pin-to-ground circuit has been detected in the engine harness.

Troubleshoot each section of the harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin at the ECM 60-pin connector of the engine harness and the fuel pump pressurizing assembly 1 SIGNAL pin at the fuel pump pressurizing assembly 1 connector of the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 inactive?
YES NO

Repair

None. The removal and and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Apr-2012


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 is active?
STEP 3. | Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the SAE J1939 data link harness. |
 | STEP 4A. Inspect the SAE J1939 data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the SAE J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM SAE J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM SAE J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 285 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic servcie tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

Repair

An incorrect setup has been detected in the ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the SAE J1939 data link harness.

Guided Step 4A - Inspect the SAE J1939 data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link adapter connector from the 9-pin service data link connector.

Action

Inspect the SAE J1939 data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection technique. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair or replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link adapter connector from the 9-pin service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the service data link connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the SAE J1939 data link connector or harness connection to the SAE J1939 data link backbone.

Troubleshoot harnesses connected in series to determine which contains the open or short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-165 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the ECM SAE J1939 datalink harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection to the ECM has been detected in the SAE J1939 data link connector or harness.

Clean the connector and pins.

Repair or replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the appropriate ECM connection to the SAE J1939 data link harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the ECM connection to all other pins in the OEM connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link SUPPLY and the SAE J1939 data link RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check for appropriate circuit response.

Fault Code 285 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A communication issue between the ECM and the SAE J1939 data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Refer to the appropriate ECM No Communication (tt-ECM) symptom tree

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Jul-2012


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 286 active?
STEP 3. | Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the SAE J1939 data link harness. |
 | STEP 4A. Inspect the SAE J1939 data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the SAE J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM SAE J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM SAE J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 286 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 286 inactive?
 | STEP 6B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

Repair

An incorrect setup has been detected in the ECM.

Enable the proper components for multiplexing on the applicable OEM application and ensure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the SAE J1939 data link harness.

Guided Step 4A - Inspect the SAE J1939 data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link adapter connector from the 9-pin SAE J1939 data link connector.

Action

Inspect the SAE J1939 datalink connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the SAE J1939 data link cable or connector.

Clean the connector and pins.

Repair or replace the damaged section of the SAE J1939 data link harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-165 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link adapter connector from the 9-pin SAE J1939 data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the SAE J1939 data link connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the SAE J1939 data link connector or harness connection to the SAE J1939 data link backbone.

Troubleshoot all harnesses connected in series to determine which contains the open or short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-165 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the ECM SAE J1939 data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection to the ECM has been detected in the SAE J1939 data link connector or harness.

Clean the connector and pins.

Repair or replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-165 in Section 19.
No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the appropriate ECM engine connection to the SAE J1939 data link harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-165 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the SAE J1939 data link adapter connector from the 9-pin SAE J1939 data link connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the ECM connection to all other pins in the connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link SUPPLY and the SAE J1939 data link RETURN pins.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-165 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A communication issue between the ECM and the data link, a damaged ECM, or a calibration issue is causing the fault code.

Go to 6A

Reference the appropriate ECM No Communication symptom tree in Section TT.

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 286 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 322 (QSK38) - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead and Part Number 3824812 - female Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322, 323, or 324 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 1 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 322 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

temp

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 323, or 324 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Read the fault codes.

  • Use INSITE electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 1 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Read the fault codes.

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60-pin connector.

Action

Read the fault codes.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Refer to the circuit diagram or wiring diagram for all harness interconnections.

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Engine harness connector disconnected from the ECM 60-pin connector.

Action

Read the fault codes.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and the injector solenoid driver cylinder 1 RETURN pin at the engine harness ECM 60 pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.
  • Engine harness connector disconnected from the injector solenoid driver cylinder 1 connector.

Action

Read the fault codes.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 to replace the damaged section of the engine harness.

For QSK45 and QSK60 engines, use the following procedure for replacing the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, QSK38 and QSK50 engines, use the following procedure for replacing the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Engine harness connector disconnected from the ECM 60 pin connector
  • Engine harness connector disconnected from the injector solenoid driver cylinder 1 connector.

Action

Read the fault codes.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and the injector solenoid driver cylinder 1 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness or damaged injector.

For QSK45 and QSK60 engines, see the following procedure for replacing the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, QSK38 and QSK50 engines, see the following procedure for replacing the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Repair

Replace the injector.

For QSK45 and QSK60 engines, use the following procedure for replacing the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, QSK38 and QSK50 engines, use the following procedure for replacing the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 is the only active fault code?

YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF
  • Engine harness connectors disconnected from the injector solenoid driver cylinders 1, 3, and 5 connectors.

Action

Read the fault codes.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure for replacing the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, QSK38 and QSK50 engines, use the following procedure for replacing the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn keyswitch OFF
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 1, 3, and 5 connectors.

Action

Read the fault codes.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

For QSK45 and QSK60 engines, use the following procedure for replacing the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, QSK38 and QSK50 engines, use the following procedure for replacing the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 1, 3, and 5 connectors
  • Engine harness connectors disconnected from the ECM 60 pin connector.

Action

Read the fault codes.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure for replacing the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, QSK38 and QSK50 engines, use the following procedure for replacing the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connectors disconnected from the ECM 60 pin connector.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 1, 3, and 5 connectors.

Action

Read the fault codes.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the engine harness ECM 60-pin connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 3 SIGNAL and the injector solenoid driver cylinder 5 SIGNAL pins at the engine harness ECM 60 pin connector to engine block ground.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 3 RETURN and the injector solenoid driver cylinder 5 RETURN pins at the engine harness ECM 60-pin connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connectors disconnected from the ECM 60 pin connector.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 1, 3, and 5 connectors.

Action

Read the fault codes.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 3 SIGNAL and at the injector solenoid driver cylinder 5 SIGNAL pins at the engine harness ECM 60 pin connector to all other pins in the connector.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 3 RETURN and the injector solenoid driver cylinder 5 RETURN pins at the engine harness ECM 60 pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 322 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead and, Part Number 3824812 - female Deutsch™ test lead and, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 or 1556 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 1 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 322 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 or 1556 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 1 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection technique. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Refer to the circuit diagram or wiring diagram for all harness interconnections.

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 1 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and the injector solenoid driver cylinder 1 RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the ECM 60 pin connector.
  • Disconnect engine harness connector from the injector solenoid driver cylinder 1 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection technique. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50 and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the ECM 60 pin connector.
  • Disconnect engine harness connector from the injector solenoid driver cylinder 1 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and the injector solenoid driver cylinder 1 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50 and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and read the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 is the only active fault code?

YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from the injector solenoid driver cylinders 1 and 15 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection technique. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50 and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from the injector solenoid driver cylinder 1 and 15 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 15 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50 and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Repair

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50 and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from the injector solenoid driver cylinder 1 and 15 connectors.
  • Disconnect engine harness connectors from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection technique. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50 and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50 and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect engine harness connectors from the injector solenoid driver cylinder 1 and 15 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the engine harness ECM connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 15 SIGNAL pin at the engine harness ECM connector to engine block ground.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the engine harness ECM connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 15 RETURN pin at the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from the ECM 60 pin connector.
  • Disconnect engine harness connectors from the injector solenoid driver cylinder 1 and 15 connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the engine harness ECM connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 15 SIGNAL pin at the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the engine harness ECM connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 15 RETURN pin at the engine harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 323 (QSK38) - Injector Solenoid Driver cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead and, Part Number 3824812 - female Deutsch™ test lead and, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323, 323, or 324 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 5 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 323 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connected INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 323, or 324 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 5 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Connect engine harness to the ECM
  • Connect engine harness to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and the injector solenoid driver cylinder 5 RETURN pin at the engine harness ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the ECM 60 pin connector.
  • Dosconnect engine harness connector from the injector solenoid driver cylinder 5 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the ECM 60 pin connector.
  • Disconnect engine harness connectors from the injector solenoid driver cylinder 5 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and the injector solenoid driver cylinder 5 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 is the only active fault code?

YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from the injector solenoid driver cylinder 1, 3, and 5 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers cylinder for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from injector solenoid driver cylinder 1, 3, and 5 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from the injector solenoid driver cylinder 1, 3, and 5 connectors.
  • Disconnect engine harness connectors from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from the ECM 60 pin connector.
  • Disconnect engine harness connectors from injector solenoid driver cylinder 1, 3, and 5 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the engine harness ECM 60-pin connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 3 SIGNAL and injector solenoid driver cylinder 5 SIGNAL pins at the engine harness ECM 60 pin connector to engine block ground.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 3 RETURN and injector solenoid driver cylinder 5 RETURN pins at the engine harness ECM 60 pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from the ECM 60 pin connector.
  • disconnect engine harness connectors from the injector solenoid driver cylinder 1, 3, and 5 connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the engine harness ECM 60-pin connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 3 SIGNAL and injector solenoid driver cylinder 5 SIGNAL pins at the engine harness ECM 60 pin connector to all other pins in the connector.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 3 RETURN and injector solenoid driver cylinder 5 RETURN pins at the engine harness ECM 60 pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 323 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Go to 4B

Escalate or call for assistance.

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 323 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323, 1532, or 1536 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 5 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 323 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323, 1532, or 1536 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code, Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 5 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and the injector solenoid driver cylinder 5 RETURN pin at the engine harness ECM 60 pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 5 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50 Series Engines Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 5 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and the injector solenoid driver cylinder 5 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50 Series Engines Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 5, 8, and 16 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50 Series Engines Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers cylinder for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connectors from injector solenoid driver cylinder 5, 8, and 16 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 8 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 16 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and engine block ground.

Use a wiring diagram for connector pin identifcation and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50 Series Engines Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 5, 8, and 16 connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection technique. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50 Series Engines Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM 60 pin connector.
  • Disconnect the engine harness connectors from injector solenoid driver cylinder 5, 8, and 16 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 8 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 16 SIGNAL and injector solenoid driver cylinder 5 SIGNAL pins at the engine harness ECM 60 pin connector to engine block ground.
  • Measure the resistance from the injector solenoid driver cylinder 8 RETURN pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 16 RETURN and injector solenoid driver cylinder 5 RETURN pins at the engine harness ECM 60 pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM 60 pin connector.
  • Disconnect the engine harness connectors injector solenoid driver cylinder 5, 8, and 16 connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 8 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 16 SIGNAL and injector solenoid driver cylinder 5 SIGNAL pins at the engine harness ECM 60 pin connector to all other pins in the connector.
  • Measure the resistance from the injector solenoid driver cylinder 8 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 16 RETURN and injector solenoid driver cylinder 5 RETURN pins at the engine harness ECM 60 pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 324 (QSK38) - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322, 323, or 324 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 not active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 3 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 324 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 323, or 324 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • INSITE™ electronic service tool connected.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 3 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Connect engine harness to the ECM
  • Connect engine harness to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Refer to the circuit diagram or wiring diagram for all harness interconnections.

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 3 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and the injector solenoid driver cylinder 3 RETURN pin at the engine harness ECM connector.

Use a wiring diagram for connector pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector from the ECM 60 pin connector
  • Disconnect engine harness connector from the injector solenoid driver cylinder 3 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, see the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSKK38 engines, see the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector from the ECM 60 pin connector
  • Disconnect engine harness connector from the injector solenoid driver cylinder 3 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and the injector solenoid driver cylinder 3 RETURN pin at the injector connector.

Use a wiring diagram for connector pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector(s).

For QSK45 and QSK60 engines, see the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSKK38 engines, see the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 is the only active fault code?

YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from the injector solenoid driver cylinder 1, 3 and 5 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, see the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSKK38 engines, see the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from injector solenoid driver cylinder 1, 3, and 5 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and engine block ground.

Use a wiring diagram for connector pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

For QSK45 and QSK60 engines, see the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSKK38 engines, see the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connectors from the injector solenoid driver cylinder 1, 3, and 5 connectors
  • Disconnect engine harness connectors from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, see the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSKK38 engines, see the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from the ECM 60 pin connector.
  • Disconnect engine harness connectors from the injector solenoid driver cylinder 1, 3, and 5 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 3 SIGNAL and the injector solenoid driver cylinder 5 SIGNAL pins at the engine harness ECM 60 pin connector.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 3 RETURN and the injector solenoid driver cylinder 5 RETURN pins at the engine harness ECM 60 pin connector.

Use a wiring diagram for connector pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connectors from the ECM 60 pin connector.
  • Disconnect engine harness connectors from the injector solenoid driver cylinder 1, 3, and 5 connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 3 SIGNAL and the injector solenoid driver cylinder 5 SIGNAL pins at the engine harness ECM 60 pin connector.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 3 RETURN and the injector solenoid driver cylinder 5 RETURN pins at the engine harness ECM 60 pin connector.

Use a wiring diagram for connector pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 324 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 or 1554 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 3 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 324 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324, or 1554 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code, Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 3 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Connect engine harness to te ECM
  • Connect engine harness to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 3 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and the injector solenoid driver cylinder 3 RETURN pin at the engine harness ECM 60 pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 3 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 3 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and the injector solenoid driver cylinder 3 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector(s).

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 3 and 13 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connectors from injector solenoid driver cylinder 3 and 13 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 13 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 3 and 13 connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the injector(s).

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

For K38, K50, and QSK38 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 3 and 13 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 3 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 13 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground.
  • Measure the resistance from the injector solenoid driver cylinder 3 RETURN pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 13 RETURN pin at the engine harness ECM 60 pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 3 and 13 connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 3 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 13 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector.
  • Measure the resistance from the injector solenoid driver cylinder 3 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 13 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 325 (QSK38) - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead and Part Number 3824812 - female Deutsch™ test lead and Part Number 3822758 - male Deutsch™ /AMP™ /Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™ /AMP™ /Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325, 331, or 332 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 6 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 325 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325, 331, or 332 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 6 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and the injector solenoid driver cylinder 6 RETURN pin at the engine harness ECM 60 pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.
  • Engine harness connector disconnected from the injector solenoid driver cylinder 6 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the injector(s).

  • For K38, K50, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6 in Section 6.
  • For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.
  • Engine harness connector disconnected from the injector solenoid driver cylinder 6 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and the injector solenoid driver cylinder 6 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector.

  • For K38, K50, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6 in Section 6.
  • For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 is the only active fault code?

YES | NO
No Repair | No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 2, 4, and 6 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the injector(s).

  • For K38, K50, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6 in Section 6.
  • For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 2, 4, and 6 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

  • For K38, K50, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6 in Section 6.
  • For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Injector solenoid driver cylinder 2, 4, and 6 connectors disconnected from the engine harness connectors.
  • Engine harness connectors disconnected from the ECM 60 pin connectors.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the injector(s).

  • For K38, K50, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50 and QSK50, Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6 in Section 6.
  • For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.
  • Injector solenoid driver cylinder 2, 4, and 6 connectors disconnected from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 6 SIGNAL pin at the engine harness ECM 60-noid driver cylinder 2 SIGNAL pin and injector solenoid driver cylinder 4 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground.
  • Measure the resistance from the injector solenoid driver cylinder 6 RETURN pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 2 RETURN pin and injector solenoid driver cylinder 4 RETURN pin at the engine harness ECM 60 pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.
  • Injector solenoid driver cylinder 2, 4, and 6 connectors disconnected from the engine harness connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 6 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL and injector solenoid driver cylinder 4 SIGNAL pins at the engine harness ECM 60 pin connector to all other pins in the connector.
  • Measure the resistance from the injector solenoid driver cylinder 6 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 4 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 325 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Go to 4B

Escalate or call for assistance.

Guided Step 4B - Clear the inactive fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 325 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325, 1548 or 1555 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 6 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 325 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325, 1548, or 1555 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code, Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INISTE electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 6 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and the injector solenoid driver cylinder 6 RETURN pin at the engine harness ECM 60 pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 6 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 6 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and the injector solenoid driver cylinder 6 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector.

Use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 6, 7, and 14 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 6, 7, and 14 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 7 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 14 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

Use the following procedure to replace the injector in Service Manual, QSK45 and QSK60 Series Engines Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 6, 7, and 14 connectors from the engine harness connectors.
  • Disconnect the engine harness connectors from the ECM 60 pin connectors.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 6, 7, and 14 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 6 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 7 SIGNAL pin and injector solenoid driver cylinder 14 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground.
  • Measure the resistance from the injector solenoid driver cylinder 6 RETURN pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 7 RETURN pin and injector solenoid driver cylinder 14 RETURN pin at the engine harness ECM 60 pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 6, 7, and 14 connectors from the engine harness connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the injector solenoid driver cylinder 6 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 7 SIGNAL and injector solenoid driver cylinder 14 SIGNAL pins at the engine harness ECM 60 pin connector to all other pins in the connector.
  • Measure the resistance from the injector solenoid driver cylinder 6 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 7 RETURN and injector solenoid driver cylinder 14 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 327 - Fuel Consumption Rate - Data Valid but Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes other than Fault Code 327 found?
STEP 2. | Check the injectors. |
 | STEP 2A. Perform a single cylinder cutout test. | Can any miss or excessive smoke be attributed to a single cylinder?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 327 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes other than Fault Code 327 found?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the injectors.

Guided Step 2A - Perform a single cylinder cutout test.

Conditions

  • Turn keyswitch ON.
  • Engine operating at low idle.
  • Connect INSITE™ electronic service tool.

Action

Perform the single cylinder cutout test.

  • Operate the engine at load.
  • Use INSITE™ electronic service tool to perform the single cylinder cutout test to disable individual injectors.
  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Can any miss or excessive smoke be attributed to a single cylinder?
YES NO

Repair

Inspect for power cylinder damage or camshaft lobe wear.

If no damage is found, replace the fuel injector in the cylinder that was identified by the single cylinder cutout test.

  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Repair

Replace all injectors.

  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 6A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Calibrate all ECMs. Refer to Procedure 019-032 in Section 19.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 327 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Jul-2012


FAULT CODE 331 (QSK38) - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™ /AMP™ /Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™ /AMP™ /Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325, 331, or 332 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 2 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 331 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325, 331, or 332 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 2 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 2 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and the injector solenoid driver cylinder 2 RETURN pin at the engine harness ECM 60 pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.
  • Engine harness connector disconnected from the injector solenoid driver cylinder 2 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the injector.

  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.
  • Engine harness connector disconnected from the injector solenoid driver cylinder 2 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and the injector solenoid driver cylinder 2 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness or injector.

Refer to Procedure 019-043 in Section 19.

Replace the injector.

  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Repair

Replace the injector.

  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

4A

Go to 2E

Guided Step 2E - Read the fault codes.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 is the only active fault code?

YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 2, 4, and 6 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness ot injector pins, whichever has the damaged pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the injector.

  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 2, 10, and 11 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 2, 4, and 6 connectors.
  • Engine harness connector disconnected from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the injector.

  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to replace the injector in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 2, 10, and 11 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 2 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 4 SIGNAL pin and injector solenoid driver cylinder 6 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground.
  • Measure the resistance from the injector solenoid driver cylinder 2 RETURN pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 4 RETURN pin and injector solenoid driver cylinder 6 RETURN pin at the engine harness ECM 60 pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60 pin connector
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 2, 4, and 6 connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 2 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 4 SIGNAL pin and injector solenoid driver cylinder 6 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector.
  • Measure the resistance from the injector solenoid driver cylinder 2 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 4 RETURN pin and injector solenoid driver cylinder 6 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 331 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Escalate or call for assistance.

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 331 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine conttrol module (ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

)To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331, 1551, or 1552 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 2 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 331 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331, 1551, or 1552 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 2 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 2 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and the injector solenoid driver cylinder 2 RETURN pin at the engine harness ECM 60 pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 2 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 2 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and the injector solenoid driver cylinder 2 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 2E

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 2, 10, and 11 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 2, 10, and 11 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 10 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 11 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 2, 10, and 11 connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 2, 10, and 11 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 2 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 10 SIGNAL pin and injector solenoid driver cylinder 11 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground.
  • Measure the resistance from the injector solenoid driver cylinder 2 RETURN pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 10 RETURN pin and injector solenoid driver cylinder 11 RETURN pin at the engine harness ECM 60 pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 2, 10, and 11 connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 2 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 10 SIGNAL pin and injector solenoid driver cylinder 11 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector.
  • Measure the resistance from the injector solenoid driver cylinder 2 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 10 RETURN pin and injector solenoid driver cylinder 11 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-May-2019


FAULT CODE 332 (QSK38) - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332, 325, or 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 4 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 332 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332, 325, or 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 4 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 4 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and the injector solenoid driver cylinder 4 RETURN pin at the engine harness ECM 60 pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.
  • Engine harness connector disconnected from the injector solenoid driver cylinder 4 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire or insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the injector.

  • For K38, K50, QSK38, and and QSK50 engines, use the following procedure to replace the injector(s) in Service Manual, K38, K50, QSK38, and and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.
  • Engine harness connector disconnected from the injector solenoid driver cylinder 4 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and the injector solenoid driver cylinder 4 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Replace the injector.

  • For K38, K50, QSK38, and and QSK50 engines, use the following procedure to replace the injector(s) in Service Manual, K38, K50, QSK38, and and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Repair

Replace the injector.

  • For K38, K50, QSK38, and and QSK50 engines, use the following procedure to replace the injector(s) in Service Manual, K38, K50, QSK38, and and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 is the only active fault code?

YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 4, 2, and 6 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire or insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 to replace the damaged section of the engine harness.

Replace the injector.

  • For K38, K50, QSK38, and and QSK50 engines, use the following procedure to replace the injector(s) in Service Manual, K38, K50, QSK38, and and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 4, 2, and 6 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector.

  • For K38, K50, QSK38, and and QSK50 engines, use the following procedure to replace the injector(s) in Service Manual, K38, K50, QSK38, and and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 4, 2, and 6 connectors.
  • Engine harness connectors disconnected from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire or insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Replace the injector.

  • For K38, K50, QSK38, and and QSK50 engines, use the following procedure to replace the injector(s) in Service Manual, K38, K50, QSK38, and and QSK50, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 4, 2, and 6 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL pin and injector solenoid driver cylinder 6 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 6 RETURN pin at the engine harness ECM 60 pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector disconnected from the ECM 60 pin connector.
  • Engine harness connectors disconnected from the injector solenoid driver cylinder 4, 2, and 6 connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL and injector solenoid driver cylinder 6 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 6 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 323 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Go to 4B

Escalate or call for assistance.

Guided Step 4B - Clear the inactive fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 332 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement, Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332, 1553, or 1622 active?
 | STEP 1B. Use INSITE electronic service tool to read the fault codes. | Fault Code 332 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 4 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 332 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332, 1553, or 1622 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the procedure for inactive or intermittent fault code. Refer to Procedure 019-362

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 4 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Connect engine harness to the ECM
  • Connect engine harness to the injector.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 4 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and the injector solenoid driver cylinder 4 RETURN pin at the engine harness ECM 60 pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 4 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 4 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and the injector solenoid driver cylinder 4 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 4, 12, and 9 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 4, 12, and 9 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 12 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 9 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 4, 12, and 9 connectors.
  • Disconnect the engine harness connectors from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

For QSK45 and QSK60 engines, use the following procedure to replace the injector in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 4, 12, and 9 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 12 SIGNAL pin and injector solenoid driver cylinder 9 SIGNAL pin at the engine harness ECM 60 pin connector to engine block ground.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the engine harness ECM 60 pin connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 12 RETURN and injector solenoid driver cylinder 9 RETURN pin at the engine harness ECM 60 pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 4, 12, and 9 connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 12 SIGNAL and injector solenoid driver cylinder 9 SIGNAL pin at the engine harness ECM 60 pin connector to all other pins in the connector.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 12 RETURN and injector solenoid driver cylinder 9 RETURN pin at the engine harness ECM 60 pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 342 - Electronic Calibration Code Incompatibilty - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM) and engine harness. |
 | STEP 1A. Inspect all ECM and engine harness connector pins. | Dirty or damaged pins?
STEP 2. | Inspect terminating resistor and circuit. |
 | STEP 2A. Inspect the terminating resistor. | 120 ohms?
 | STEP 2B. Inspect data link circuit | 60 ohms?
STEP 3. | Calibrate the ECMs. |
 | STEP 3A. Calibrate ECMs. | ECMs accepted calibration?
 | STEP 3B. ROM boot ECMs. | ROM boot procedure successful?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 342 inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM and engine harness.

Guided Step 1A - Inspect all ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • All engine harness connectors disconnected from the ECM connectors.

Action

Inspect the engine harness and all ECM engine connector pins for the following:

Inspect the engine harness and all ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in an engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Refer to the circuit diagram or wiring diagram for connector identification.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Inspect the terminating resistor and circuit.

Guided Step 2A - Inspect the terminating resistor.

Conditions

  • Terminating resistors disconnected.

Action

Measure the resistance across SAE J1939 data link SUPPLY pin and SAE J1939 data link RETURN pin on both terminating resistors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

120 ohms?
YES NO
No Repair

Repair

Replace terminating resistor.

Go to 2B

Go to 4A

Guided Step 2B - Inspect data link circuit.

Conditions

  • All the engine harness ECM 60-pin connectors disconnected.
  • Connect terminating resistor.

Action

Measure the resistance across SAE J1939 data link RETURN pin and SAE J1939 data link SUPPLY pin on the 60-pin connectors for all ECMs.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

60 ohms?
YES NO
No Repair

Repair

A damaged connection has been detected in an engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Calibrate the ECMs

Guided Step 3A - Calibrate the ECM.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Calibrate the ECMs.

  • Refer to Procedure 019-032 in Section 19.

ECMs accepted calibration?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - ROM boot the ECMs.

Conditions

  • Turn keyswitch OFF.

Action

ROM boot the ECMs.

  • Refer to Procedure 019-427 in Section 19.

ROM boot procedure successful?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 325 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Jul-2012


FAULT CODE 349 - Transmission Output Shaft Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM) for fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 349 present?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 349 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM for fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Use INSITE™ electronic service tool to view the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 349 present?
YES | NO
No Repair | No Repair

Refer to the OEM service manual.

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 349 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 2B - Clear the inactive fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Jul-2012


FAULT CODE 351 (Source Address 00) - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 active during engine operation?
STEP 2. | Check the ECM power supply. |
 | STEP 2A. Inspect the ECM power supply connector and fuse. | Damage observed?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate the engine and determine if fault code condition exists. | Fault Code 351 reoccurs during engine operation, while injector Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 do not occur?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 351 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 active during engine operation?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Inspect the ECM power supply connector and fuse.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness ECM3 power 4-pin connector from the ECM connector
  • Disconnect the ECM3 fuse from the engine harness.

Action

Inspect the ECM power supply and fuse for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection technique. Refer to Procedure 019-361 in Section 19.

Damage observed?
YES NO

Repair

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-087 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness ECM3 power 4-pin connector from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the battery 1 voltage (ECM3) SUPPLY pin at the 4-pin power connector of the engine harness and the battery positive (+) pins at the battery positive (+) connection.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair

Replace the damaged section of the engine harness, fuse, or fuse holder, or clean the battery terminal connections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-087 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness ECM3 power 4-pin connector from the ECM connector
  • Disconnect the OEM harness from the battery terminals.

Action

Check for an open circuit in the ECM power supply circuit.

  • Measure the resistance between the battery 1 voltage RETURN (ECM3) pin at the 4-pin ECM power SUPPLY connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the damaged section of the engine harness, fuse, or fuse holder, or clean the battery terminal connections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-087 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: INSITE™ electronic service tool can also be used to monitor ECM power supply and injector power supply voltages.

Fault Code 351 reoccurs during engine operation, while injector Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 do not occur?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A marginal battery voltage condition is possible. Make sure the batteries are fully charged.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 351 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Apr-2012


FAULT CODE 351 (Source Address 01) - Injector Power Supply - Bad intelligent Device or Component

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 active during engine operation?
STEP 2. | Check the engine control module (ECM) power supply. |
 | STEP 2A. Inspect the ECM power supply connector and fuse. | Damage observed?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate the engine and determine if fault code condition exists. | Fault Code 351 reoccurs during engine operation, while injector Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 do not occur?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 351 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 active during engine operation?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Inspect the ECM power supply connector and fuse.

Conditions

  • Turn keyswitch OFF
  • Engine harness ECM 2 power 4-pin connector disconnected from the ECM connector
  • The ECM 2 fuse disconnected from the engine harness.

Action

Inspect the ECM power supply and fuse for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damage observed?
YES NO

Repair

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Engine harness ECM2 power 4-pin connector disconnected from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the battery 1 voltage (ECM2) supply pin at the 4-pin power connector of the engine harness and the battery positive (+) pins at the battery positive (+) connection.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Engine harness ECM2 power 4-pin connector disconnected from the ECM connector.
  • The OEM harness disconnected from the battery terminals.

Action

Check for an open circuit in the ECM power supply circuit.

  • Measure the resistance between the battery 1 voltage RETURN (ECM2) pin at the 4-pin ECM power supply connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • All components connected.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: INSITE™ electronic service tool can also be used to monitor ECM power supply and injector power supply voltages.

Fault Code 351 reoccurs during engine operation, while injector Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 do not occur?

YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A marginal battery voltage condition is possible. Make sure the batteries are fully charged.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Jul-2012


FAULT CODE 351 (Source Address 144) - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 active during engine operation?
STEP 2. | Check the ECM power supply. |
 | STEP 2A. Inspect the ECM power supply connector and fuse. | Damage observed?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate the engine and determine if fault code condition exists. | Fault Code 351 reoccurs during engine operation, while injector Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 do not occur?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 351 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 active during engine operation?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Inspect the ECM power supply connector and fuse.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness ECM1 power 4-pin connector from the ECM connector
  • Disconnect the ECM1 fuse from the engine harness.

Action

Inspect the ECM power supply and fuse for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damage observed?
YES NO

Repair

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-087 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness ECM1 power 4-pin connector from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the battery 1 voltage (ECM1) SUPPLY pin at the 4-pin power connector of the engine harness and the battery positive (+) pins at the battery positive (+) connection.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair

Replace the damaged section of the engine harness, fuse, or fuse holder, or clean the battery terminal connections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-087 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness ECM1 power 4-pin connector from the ECM connector
  • Disconnect the OEM harness from the battery terminals.

Action

Check for an open circuit in the ECM power supply circuit.

  • Measure the resistance between the battery 1 voltage RETURN (ECM1) pin at the 4-pin ECM power supply connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the damaged section of the engine harness, fuse, or fuse holder, or clean the battery terminal connections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-087 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: INSITE™ electronic service tool can also be used to monitor ECM power supply and injector power supply voltages.

Fault Code 351 reoccurs during engine operation, while injector Fault Codes 322, 323, 324, 325, 331, 332, 1548, 1549, 1551, 1552, 1553, 1554, 1555, 1556, 1557, or 1622 do not occur?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A marginal battery voltage condition is possible. Make sure the batteries are fully charged.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 351 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Apr-2012


FAULT CODE 352 (Industrial and Marine) - Sensor Supply 1 Circuit Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to sensor supply 1 and return. |
 | STEP 2A. Inspect the engine oil rifle pressure sensor and circuit connected to the sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the crankcase pressure sensor and circuit connected to the sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine coolant pressure sensor and circuit connected to the sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the auxiliary pressure sensor and circuit connected to the sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the remote accelerator pedal or lever position sensor and circuit connected to sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
 | STEP 2F. Inspect the coolant level sensor 1 and circuit connected to sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2F-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harnesses. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
 | STEP 3C. Inspect the vehicle for optional devices. | OEM devices installed?
 | STEP 3D. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the OEM harness or engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3F. Check the OEM harness or engine harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3G. Check for a short circuit in the OEM harness ECM battery negative (-) circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 1 and return.

Guided Step 2A - Inspect the engine oil rifle pressure sensor and circuit connected to the sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged sensor. Refer to Procedure 019-066 in Section 19.
No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the engine oil rifle pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the crankcase pressure sensor and circuit connected to the sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged sensor. Refer to Procedure 019-445 in Section 19.

Referenece the circuit diagram or wiring diagram for all harness interconnections.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the engine coolant pressure sensor and circuit connected to the sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged sensor. Refer to Procedure 019-016 in Section 19.

Reference the circuit diagram or wiring diagram for all harness interconnections.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the auxiliary pressure sensor and circuit connected to the sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector.
  • Disconnect the engine harness connector from the 31-pin OEM connector.

Action

Inspect the OEM, engine harness, and load share equipment connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Replace the damaged section of harness or damaged sensor.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to the OEM service manual

Reference the circuit diagram or wiring diagram for all harness interconnections.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the auxiliary pressure sensor.

Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the remote accelerator pedal or lever position sensor and circuit connected to sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Disconnect the engine harness connector from the OEM 23-pin connector.

Action

Inspect the OEM harness, engine harness, and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Replace the damaged section of harness or damaged sensor.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to the OEM service manual for the remote accelerator pedal or lever position sensor repair instructions.

Reference the circuit diagram or wiring diagram for all harness interconnections.

 No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the remote accelerator pedal or lever position sensor.

Refer to the OEM service manual.

Go to 2F

Go to 4A

Guided Step 2F - Inspect the coolant level sensor 1 and circuit connected to sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Replace the damaged section of harness. Refer to Procedure 019-071 in Section 19.
  • Replace the damaged sensor. Refer to Procedure 019-017 in Section 19.

Reference the circuit diagram or wiring diagram for all engine harness or interconnections.

 No Repair

Go to 4A

Go to 2F-1

Guided Step 2F-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the coolant level sensor 1. Refer to Procedure 019-017 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harnesses.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connectors.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Replace the damaged section of harness or damaged sensor.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Reference the circuit diagram or wiring diagram for all harness interconnections.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

There is a short circuit in the engine harness pulling the sensor supply voltage down.

  • Troubleshoot each section of harness to determine which contains the short circuit.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the vehicle for optional devices.

Conditions

  • Turn keyswitch OFF.

Action

OEM devices, the remote accelerator pedal or level position sensor, and the auxiliary pressure sensor share a 5 volt SUPPLY with sensors on the engine harness.

  • Check the vehicle for a remote accelerator pedal or lever position sensor, or an auxiliary pressure sensor.

OEM devices installed?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Inspect all OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the OEM and engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged sensor.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to the OEM service manual.

Reference the circuit diagram or wiring diagram for all harness interconnections.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the OEM harness or engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector.

Action

Check the harnesses connected in series for a short to ground.

  • Measure the resistance between the coolant level 1 5 volt SUPPLY (sensor supply 1) pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

There is a short to ground in the OEM harness or engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the short circuit.
  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged sensor.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to the OEM service manual.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Go to 3F

Go to 4A

Guided Step 3F - Check the OEM harness or engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector.

Action

Check the harnesses connected in series for a pin-to-pin short circuit.

  • Measure the resistance between the coolant level 1 5 volt SUPPLY (sensor supply 1) pin at the engine harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of harness.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Go to 3G

Go to 4A

Guided Step 3G - Check for a short circuit in the OEM harness ECM battery negative (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness battery supply 4-pin connector from the ECM connector.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector.

Action

Check for a short circuit.

  • Measure the resistance between the coolant level 1 5-VDC SUPPLY (sensor supply 1) pin at the engine harness ECM connector and the battery 1 voltage (ECM3) pins in the ECM power connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

  • Replace the damaged section of harness.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the damaged sensor.
  • Refer to Procedure 019-071 in Section 19.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 352 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 352 (Power Generation) - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to sensor supply 1 and return. |
 | STEP 2A. Inspect the engine oil rifle pressure sensor and circuit connected to sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the crankcase pressure sensor and circuit connected to sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine coolant pressure sensor and circuit connected to sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the generator speed/load governing bias circuit connected to sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the coolant level sensor 1 and circuit connected to sensor supply 1 and return. | Dirty or damaged pins.
 | STEP 2E-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harnesses. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
 | STEP 3C. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3D. Check the OEM harness or engine harness for a short-to-ground. | Greater than 100k ohms?
 | STEP 3E. Check the OEM harness or engine harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3F. Check for a short circuit in the OEM harness ECM battery negative (-) circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 1 and return.

Guided Step 2A - Inspect the engine oil rifle pressure sensor and circuit connected to sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil rifle pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-066 in Section 19.
No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the engine oil rifle pressure sensor.

Refer to Procedure 019-066 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the crankcase pressure sensor and circuit connected to sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-445 in Section 19.
No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnected the crankcase pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool connected.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the engine coolant pressure sensor and circuit connected to sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine coolant pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-016 in Section 19.
No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor.

  • Refer to Procedure 019-016 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the generator speed/load governing bias circuit connected to sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the generator speed/load governing bias connector from the OEM harness connector
  • Disconnect the engine harness connector from the 31-pin OEM connector.

Action

Inspect the OEM, engine harness, and load share equipment connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Refer to the OEM service manual for generator speed/load governing bias repair instructions.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator speed/load governing bias connector from the OEM harness connector.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the generator speed/load governing bias.

Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the coolant level sensor 1 and circuit connected to sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor 1 connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all engine harness or interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-017 in Section 19.
No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor 1 connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the coolant level sensor 1.

  • Refer to Procedure 019-017 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harnesses.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connectors.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool connected.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

There is a short circuit in the engine harness pulling the sensor supply voltage down.

Troubleshoot each section of harness to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Inspect all OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness connections.

Action

Inspect the OEM and engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the OEM harness or engine harness for a short-to-ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector
  • Disconnect the coolant level sensor connector from the engine harness connector
  • Disconnect the generator speed/load governing bias connector from the OEM harness connector.

Action

Check the harnesses connected in series for a short-to-ground.

  • Measure the resistance between the generator speed/load governing bias 5-VDC SUPPLY (sensor supply 1) pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

There is a short to ground in the OEM harness or engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness or damaged sensor.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the OEM harness or engine harness for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the coolant level sensor connector from the engine harness connector.
  • Disconnect the generator speed/load governing bias connector from the OEM harness connector.

Action

Check the harnesses connected in series for a short circuit from pin-to-pin.

  • Measure the resistance between the generator speed/load governing bias 5-VDC SUPPLY (sensor supply 1) pin at the engine harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit in the OEM harness ECM battery negative (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness battery supply 4-pin connector from the ECM connector.
  • Disconnect the coolant level sensor connector from the engine harness connector.
  • Disconnect the generator speed/load governing bias connector from the OEM harness connector.

Action

Check for a short circuit.

  • Measure the resistance between the generator speed/load governing bias 5-VDC SUPPLY (sensor supply 1) pin at the engine harness ECM connector and the battery 1 voltage RETURN (ECM3) pin in the ECM power connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 352 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Jul-2012


FAULT CODE 386 (Industrial and Marine) - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the ECM and engine harnesses. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check the OEM 5-VDC supply. |
 | STEP 3A. Inspect all OEM, ECM, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the OEM harness or engine harness for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the OEM harness ECM battery positive (+) circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 386 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify no fault codes are active for any sensor sharing sensor supply 1 circuit.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harnesses.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from both ECM connectors.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO
No Repair

Repair

There is a short circuit in the engine harness causing the sensor 5-VDC supply line to have too high a voltage.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the wiring harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM 5-VDC supply.

Guided Step 3A - Inspect all OEM, ECM, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the OEM, ECM, and engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the OEM harness or engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector (if equipped).
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector (if equipped).

Action

Check the OEM or engine harness for a pin-to-pin short circuit.

  • Measure the resistance between the coolant level 1 5-VDC SUPPLY (sensor supply 1) pin at the engine harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the OEM harness ECM battery positive (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness battery supply 4-pin connector from the ECM 4-pin connector.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector.

Action

Check for a short circuit to ECM battery positive (+) in the OEM harness or engine harness.

  • Measure the resistance between the coolant level 1 5-VDC SUPPLY (sensor supply 1) pin at the engine harness ECM connector and the battery 1 voltage (ECM3) at the ECM 4-pin power connection on the engine harness battery supply.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Jul-2012


FAULT CODE 386 (Power Generation) - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the ECM and engine harnesses. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check the 5-VDC supply. |
 | STEP 3A. Inspect all OEM, ECM, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the OEM harness or engine harness for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the engine harness ECM battery positive (+) circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify no fault codes are active for any sensor sharing sensor supply 1 circuit.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harnesses.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM 60-pin connectors.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged connector, or replace the ECM.

Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO
No Repair

Repair

There is a short circuit in the engine harness causing the sensor 5-VDC supply wire to have too high a voltage.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the wiring harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the 5-VDC supply.

Guided Step 3A - Inspect all OEM, ECM, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the OEM, ECM, and engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the OEM harness or engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the coolant level sensor connector from the engine harness connector.
  • Disconnect the generator speed/load governing bias connector from the OEM harness connector.

Action

Check the OEM or engine harness for a pin-to-pin short circuit .

  • Measure the resistance between the generator speed/load governing bias 5-VDC SUPPLY (sensor supply 1) pin at the engine harness ECM connectorand all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness ECM battery positive (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness battery supply connector from the ECM 4-pin connector.
  • Disconnect the coolant level sensor connector from the engine harness connector.
  • Disconnect the generator speed/load governing bias connector from the OEM harness connector.

Action

Check for a short circuit to ECM battery positive (+) in the OEM harness or engine harness.

  • Measure the resistance between the generator speed/load governing bias 5-VDC SUPPLY (sensor supply 1) pin at the engine harness ECM connector and the battery 1 voltage (ECM3) pin at the ECM 4-pin power connection on the engine harness battery supply.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jul-2012


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault code 415. | Active or inactive counts of Fault Code 415?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 415.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Repair

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS in K38, K50, QSK38, and QSK50, Service Manual, Bulletin 4021528. See the Lubricating Oil Pressure Low troubleshooting tree in QSK45 and QSK60, Service Manual, Bulletin 4021530.

No Repair

Appropriate troubleshooting symptom tree

Repair complete.

Last Modified: 19-Jul-2012


FAULT CODE 418 - Water In Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for Fault Code 418. | Active or inactive counts of Fault Code 418?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 418?
YES NO

Repair

Drain the water from the fuel filter.

 No Repair

Go to 2A

Repair Complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all the steps have been completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 17-Nov-2015


FAULT CODE 419 - Intake Manifold Pressure Bank Imbalance - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check air shutoff valve. |
 | STEP 1A. Check air shutoff valve position. | Air shutoff valve actuated/closed?
STEP 2. | Inspect the turbocharged impeller. |
 | STEP 2A. Inspect turbocharged impeller for damage. | Damaged impeller blades?
STEP 3. | Validate the boost pressure sensor. |
 | STEP 3A. Validate boost pressure sensor readings. | INSITE™ electronic service tool reading is within 102 mm-Hg [4 in-Hg] of the mechanical gauge?
STEP 4. | Check the injectors |
 | STEP 4A. Check for malfunctioning injectors. | Low exhaust gas temperature readings on multiple cylinders on same bank?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check air shut off valve.

Guided Step 1A - Check air shutoff valve position.

Conditions

  • Turn keyswitch OFF.
  • Turn run/stop/auto switch to STOP position.

Action

Inspect the air shut off valve position.

  • Is there a closed air shut off valve?

Air shut off valve actuated/closed?
YES NO

Repair

Open air shutoff valve.

  • See equipment manufacturer service information.
 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Inspect the turbocharged impeller.

Guided Step 2A - Inspect turbocharged impeller for damage.

Conditions

  • Turn keyswitch OFF/isolated.
  • Remove intake tubing from both turbochargers.

Action

Inspect turbocharged impeller.

  • Inspect turbocharger impeller blades for signs of damage.

Damaged impeller blades?
YES NO

Repair

Replace the turbocharger. Use the following procedure in the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Validate boost pressure sensor readings.

Guided Step 3A - Validate boost pressure sensor readings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a mechanical pressure gauge to the intake manifold.
  • Operate the engine.

Action

Verify the boost pressure sensor readings..

  • Use INSITE™ electronic service tool to monitor the intake manifold 1 and 2 pressure sensors.
  • Compare INSITE™ electronic service tool intake manifold pressure readings with the mechanical gauge pressure.
  • Operate the engine under load.

INSITE™ electronic service tool reading is within 102 mm-Hg [4 in-Hg] of the mechanical gauge pressure?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check for injectors.

Guided Step 4A - Check for malfunctioning injectors.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn run/stop/auto switch to RUN position.
  • Turn keyswitch ON.

Action

Check for malfunctioning injectors.

  • Use INSITE™ electronic service tool to monitor all exhaust gas temperature sensor readings.
  • Look for multiple low exhaust gas temperature readings on the same bank.

Multiple low exhaust gas temperature readings on same bank?
YES NO

Repair

Confirm the injectors are functioning correctly.

No Repair

Go to the appropriate fault code troubleshooting procedure within Section TT.

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 25-Jun-2015


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 421. | Active or inactive counts of Fault Code 421?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 421.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 421.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 421?
YES NO

Repair

Reference the Fuel Temperature Above Normal troubleshooting symptom tree in Section TS in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Reference the Fuel Temperature Above Normal troubleshooting symptom tree in Section TS in Service Manual, QSK45 and QSK60, Bulletin 4021530.

No Repair

Appropriate troubleshooting symptom tree

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jul-2012


FAULT CODE 426 - SAE J1939 Datalink - Can Not Transmit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement: Part Number 3163151 - ECM Bench Top Calibration Harness and Part Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SAE J1939 data link communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does the INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | Does INSITE™ electronic service tool communicate with the ECM?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the SAE J1939 data link communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Connect INLINE™ 5 data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to communicate with the ECM.

  • Use an INLINE™ 5 (J1939) ECM connection to start INSITE™ electronic service tool and connect to the ECM .

Does INSITE™ electronic service tool communicate with the ECM?

YES NO

Repair

The ECM SAE J1939 data link circuit is functioning properly.

 No Repair

Refer to the OEM service manual for information on troubleshooting and vehicle SAE J1939 data link network

Go to 1B

Guided Step 1B - Inspect the OEM engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector .

Action

Inspect the OEM harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connectors and pins.

Replace the damaged section of the engine harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Connect ECM bench calibration harness to the ECM connector.
  • Connect INLINE™ 5 data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM with an INLINE™ 5 (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

Repair

The INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

No Repair

Refer to the OEM troubleshooting and repair manual for information on troubleshooting the vehicle SAE J1939 data link network.

Reference the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jul-2012


FAULT CODE 431 (Integrated Sensor Switch) - Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death. Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch and securely chock the wheels.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the integrated sensor switch. |
 | STEP 1A. Verify the integrated sensor switch is connected to the OEM harness. | Integrated sensor switch connected to the OEM harness?
 | STEP 1B. Inspect the integrated sensor switch connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the integrated sensor switch for an open circuit. | Less than 125 ohms?
 | STEP 1D. Check the integrated sensor switch for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 2. | Check the OEM harness and engine harness. |
 | STEP 2A. Check the OEM harness and engine harness for an open circuit. | Greater than 4.0-VDC?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness and engine harness for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness and engine harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness and the engine harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the engine ECM battery (+) circuit. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the integrated sensor switch.

Guided Step 1A - Verify the integrated sensor switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the integrated sensor switch is connected to the harness.

  • Verify the integrated sensor switch is connected to the OEM harness.

Integrated sensor switch connected to the OEM harness?
YES NO
No Repair

Repair

Connect the integrated sensor switch to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the integrated sensor switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Inspect the OEM harness and integrated sensor switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the integrated sensor switch or OEM harness connector.

Clean the connector and pins.

Repair or replace the damaged section of the harness or the damaged integrated sensor switch.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the switch. Refer to Procedure 019-086 in Section 19.
  • Repair the harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the integrated sensor switch for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the accelerator pedal or lever idle validation switch ON SIGNAL pin and accelerator pedal or lever validation switch RETURN pin of the integrated sensor switch connector with the pedal released.
  • Measure the resistance between the accelerator pedal or lever idle validation switch OFF SIGNAL pin and accelerator pedal or lever validation switch RETURN pin of the integrated sensor switch connector with the pedal depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 125 ohms?
YES NO
No Repair

Repair

Replace the integrated sensor switch.

Refer to the OEM service manual.

Go to 1D

Go to 3A

Guided Step 1D - Check the integrated sensor switch for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator pedal or lever idle validation switch ON SIGNAL pin and accelerator pedal or lever idle validation switch OFF SIGNAL pin of the integrated sensor switch connector with the pedal released and depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the integrated sensor switch.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness and engine harness.

Guided Step 2A - Check the OEM harness and engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the accelerator pedal or lever idle validation switch ON SIGNAL pin in the integrated sensor switch connector of the OEM harness to the accelerator pedal or lever idle validation switch RETURN pin in the integrated sensor switch connector of the OEM harness.
  • Measure the voltage from the accelerator pedal or lever idle validation switch OFF SIGNAL pin in the integrated sensor switch connector of the OEM harness to the accelerator pedal or lever idle switch RETURN pin in the integrated sensor switch connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all interconnections.

  • Repair the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness and engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the accelerator pedal or lever idle validation switch ON SIGNAL wire in all harnesses connected in series between the ECM connector and the integrated sensor switch connector.
  • Measure the resistance of the accelerator pedal or lever idle validation switch OFF SIGNAL wire in all harnesses connected in series between the ECM connector and the integrated sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of the harness.

  • Repair the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness and engine harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance of the accelerator pedal or lever idle validation switch RETURN wire in the harnesses connected in series between the ECM connector and the integrated sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot each harness connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of the harness.

  • Repair the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness and the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open switch return circuit.

Measure the resistance and check for a short circuit between the following ECM harness connector pins and all other pins in the connector:

  • Accelerator pedal or lever idle validation switch ON SIGNAL pin
  • Accelerator pedal or lever Idle validation switch OFF SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of the harness.

  • Repair the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the engine ECM battery (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the integrated sensor switch from the OEM harness.
  • Disconnect the power connector from the ECM.

Action

Check for a pin-to-pin short circuit on two connectors.

  • Measure the resistance between the accelerator pedal or lever idle validation switch ON SIGNAL pin in the ECM connector and the battery 1 voltage (ECM 3) pin in the ECM 3 Source address (00) power 4-pin connector.
  • Measure the resistance between the accelerator pedal or lever idle validation switch OFF SIGNAL pin in the ECM connector and the battery 1 voltage (ECM 3) pin in the ECM 3 Source address (00) power 4-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot each section of harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of the harness.

  • Repair the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair complete.

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jul-2012


FAULT CODE 431 (Nonintegrated Switch Sensor) - Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death. Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch, and securely chock the wheels.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the nonintegrated sensor switch. |
 | STEP 1A. Verify the nonintegrated sensor switch is connected to the OEM harness. | Nonintegrated sensor switch connected to the OEM harness?
 | STEP 1B. Inspect the nonintegrated sensor switch and connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the nonintegrated sensor switch for an open circuit. | Less than 10 ohms?
 | STEP 1D. Check the nonintegrated sensor switch for a pin-to-pin short circuit. | More than 100k ohms?
STEP 2. | Check the OEM and engine harness. |
 | STEP 2A. Check the OEM and engine harness for an open circuit. | Greater than 4.0-VDC?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness and engine harness for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness and engine harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness and engine harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the engine harness ECM battery (+) circuit. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update is available for this fault code, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the nonintegrated sensor switch.

Guided Step 1A - Verify the nonintegrated sensor switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the nonintegrated sensor switch is connected to the OEM harness.

Check the nonintegrated sensor switch.

Nonintegrated sensor switch connected to the OEM harness?
YES NO
No Repair

Repair

Connect the nonintegrated sensor switch to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the nonintegrated sensor switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the nonintegrated sensor switch from the OEM harness.

Action

Inspect the OEM harness and nonintegrated switch sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the nonintegrated sensor switch or OEM harness connector.

Clean the connector and pins.

Repair or replace the damaged section of the harness or the damaged nonintegrated switch sensor.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the sensor. Refer to Procedure 019-085 in Section 19.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the nonintegrated sensor switch for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the nonintegrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the accelerator pedal or lever idle validation switch ON SIGNAL pin and accelerator pedal or lever idle validation switch RETURN pin of the nonintegrated sensor switch connector with the pedal or lever released.
  • Measure the resistance between the accelerator pedal or lever idle validation switch OFF SIGNAL pin and accelerator pedal or lever idle validation switch RETURN pin of the nonintegrated sensor switch connector with the pedal or lever depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following proceudre for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the nonintegrated sensor switch.

Refer to the OEM service manual.

Go to 1D

Repair Complete.

Guided Step 1D - Check the nonintegrated sensor switch for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the nonintegrated sensor switch from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator pedal or lever idle validation switch ON SIGNAL pin and accelerator pedal or lever idle validation switch off SIGNAL pin of the nonintegrated sensor switch connector with the pedal or lever released and depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the nonintegrated sensor switch.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM and engine harness.

Guided Step 2A - Check the OEM and engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the nonintegrated sensor switch from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the accelerator pedal or lever idle validation switch ON SIGNAL pin in the nonintegrated sensor switch connector of the OEM harness to the accelerator pedal or lever idle validation switch RETURN pin in the nonintegrated sensor switch connector of the OEM harness.
  • Measure the voltage from the accelerator pedal or lever idle validation switch OFF SIGNAL pin in the nonintegrated sensor switch connector of the OEM harness to the accelerator pedal or lever idle validation switch RETURN pin in the nonintegrated sensor switch connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection technique. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness and engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the nonintegrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the accelerator pedal or lever idle validation switch ON SIGNAL wire in all harnesses connected in series between the ECM connector and the nonintegrated sensor switch connector.
  • Measure the resistance of the accelerator pedal or lever idle validation switch OFF SIGNAL wire in all harnesses connected in series between the ECM connector and the nonintegrated sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness and engine harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the nonintegrated sensor switch from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance of the OEM harness accelerator pedal or lever idle validation switch RETURN wire in the OEM harness between the ECM connector and the nonintegrated sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the nonintegrated sensor switch from the OEM harness.

Action

Short circuit on one connector pin-to-pin check:

Measure the resistance and check for a short circuit between the following ECM connector pins and all other pins in the connector:

  • Accelerator pedal or lever idle validation switch ON SIGNAL pin
  • Accelerator pedal or lever idle validation switch OFF SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot each section harness connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the engine harness ECM battery (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the nonintegrated sensor switch from the OEM harness.
  • Disconnect the power connector from the ECM.

Action

Short circuit on two connectors pin-to-pin check:

  • Measure the resistance between the accelerator pedal or lever idle validation switch ON SIGNAL pin in the ECM connector and the battery 1 voltage (ECM 3) pin in the ECM 3 Source address (00) power 4-pin connector.
  • Measure the resistance between the accelerator pedal or lever idle validation switch OFF SIGNAL pin in the ECM connector and the battery 1 voltage (ECM 3) pin in the ECM 3 Source address (00) power 4-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace the damaged section of the OEM harness.

Refer to Procedure 019-071 in Section 19.

Repair complete.

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have completed and checked again.

Repair Complete.

Go to 1A

Last Modified: 19-Jul-2012


FAULT CODE 441 (Source Address 00) - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the 4-pin power connector and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update is available for this fault code, does the ECM contain that revision?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.

Normal conditions:

  • At least 12-VDC (+12 volt systems)
  • At least 24-VDC (+24 volt systems).

Cranking conditions:

  • At least 6.2-VDC (+12 volt systems)
  • At least 12-VDC (+24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 10-ampere fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 10-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the 4-pin power connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal connector to all ECM battery 1 voltage (ECM 3) SUPPLY (+) pins, one at a time, in the 4-pin power ECM connector.
  • Measure the resistance from the negative (-) battery terminal connector to all ECM battery 1 voltage (ECM 3) RETURN pins, one at a time, in the 4-pin power ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery 1 voltage (ECM 3) pin in the power harness ECM connector to the ECM battery 1 voltage (ECM 3) RETURN pins.

Refer to the circuit diagram or wiring diagram for connector identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery 1 voltage (ECM 3) SUPPLY pin in the 4-pin power harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the battery.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the ECM battery 1 voltage (ECM 3) SUPPLY (+) pins in the 4-pin power harness ECM connector to all pins in the harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jul-2012


FAULT CODE 441 (Source Address 01) - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the 4-pin power connector and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update is available for this fault code, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least 12-VDC (12 volt systems)
  • At least 24-VDC (24 volt systems).

Cranking conditions:

  • At least 6.2-VDC (12 volt systems)
  • At least 12-VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 10-ampere fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 10-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the 4-pin power connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal connector to all ECM battery 1 voltage (ECM 2) SUPPLY (+) pins, one at a time, in the 4-pin power ECM connector.
  • Measure the resistance from the negative (-) battery terminal connector to all ECM battery 1 voltage (ECM 2) RETURN pins, one at a time, in the 4-pin power ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery 1 voltage (ECM 2) pin in the power harness ECM connector to the ECM battery 1 voltage (ECM 2) RETURN pins.

Refer to the circuit diagram or wiring diagram for connector identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery 1 voltage (ECM 2) SUPPLY pin in the 4-pin power harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ECM battery 1 voltage (ECM 2) SUPPLY (+) pins in the 4-pin power harness ECM connector to all pins in the harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the defective section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jul-2012


FAULT CODE 441 (Source Address 144) - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the 4-pin power connector and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If an calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least 12-VDC (+12 volt systems)
  • At least 24-VDC (+24 volt systems).

Cranking conditions:

  • At least 6.2-VDC (+12 volt systems)
  • At least 12-VDC (+24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 10-ampere fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 10-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the 4-pin power connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal connector to all ECM battery 1 voltage (ECM 1) SUPPLY (+) pins, one at a time, in the 4-pin power ECM connector.
  • Measure the resistance from the negative (-) battery terminal connector to all ECM battery 1 voltage (ECM 1) RETURN pins, one at a time, in the 4-pin power ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery 1 voltage (ECM 1) pin in the power harness ECM connector to the ECM battery 1 voltage (ECM 1) RETURN pins.

Refer to the circuit diagram or wiring diagram for connector identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery 1 voltage (ECM 1) SUPPLY pin in the 4-pin power harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector identification.

Use the following for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 4-pin power connector from the ECM connector.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the battery.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the ECM battery 1 voltage (ECM 1) SUPPLY (+) pins in the 4-pin power harness ECM connector to all pins in the harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jul-2012


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the equipment battery system. |
 | STEP 2A. Check the battery voltage. | Less than 20-VDC for 12 volt system or 32-VDC for 24 volt system?
 | STEP 2B. Check the alternator. | Alternator charging within OEM specifications?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the equipment battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect all aftermarket devices connectors from the battery 1 voltage circuit connectors
  • Disconnect the 4-pin ECM power harness connector from the ECM connector.

Action

Check the battery voltage.

  • Measure the battery 1 voltage from one of the ECM battery 1 voltage pins in the 4-pin power harness ECM connector to engine block ground.
  • Repeat above step for the second ECM battery 1 voltage pin in the 4-pin power harness ECM connector.

Less than 20-VDC for 12 volt system or 32-VDC for 24 volt system?
YES NO
No Repair

Repair

Install the battery system correctly. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

NOTE: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • All components connected
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jul-2012


FAULT CODE 449 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Some contingency fuel, such as a jet fuel and kerosene, are much more flamable than normal diesel fuel. Use extreme care to keep cigarettes, flames, pilot lights, sparks, arcing equipment and switches, and other sources of ignition away and out of areas sharing ventilation.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 2311, 2261, 451, or 452 active or inactive?
STEP 2. | Clear the operation of the low-pressure fuel system. |
 | STEP 2A. Check for air in fuel. | Air present in the fuel flow line?
 | STEP 2B. Check the first stage fuel filter inlet pressure. | Fuel pressure greater than 0.35 bar [5 psi]?
STEP 3. | Check the operation of the fuel pump pressurizing assembly 1. |
 | STEP 3A. Inspect the fuel pump pressurizing assembly 1 o-ring. | O-ring cut or shaved?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271, 272, 2311, 2261, 451, or 452 active or inactive?
YES | NO
No Repair | No Repair

See the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Clear the operation of the low-pressure fuel system.

WARNING

Some contingency fuel, such as a jet fuel and kerosene, are much more flamable than normal diesel fuel. Use extreme care to keep cigarettes, flames, pilot lights, sparks, arcing equipment and switches, and other sources of ignition away and out of areas sharing ventilation.
Guided Step 2A - Check for air in fuel.

Conditions

  • Remove air bleed line from air bleed valve on the fuel drain manifold block.
  • Route the air bleed line into a suitable container to collect fuel.
  • Turn keyswitch ON.

Action

Inspect the fuel flow for air.

Use the following procedure in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-003 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-003 in Section 6.

Air present in the fuel flow line?
YES NO

Repair

Repair or replace the damaged line or loose connection.

Use the following procedure in the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-024 in Section 6.

Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the first stage fuel filter inlet pressure.

Conditions

  • Turn keyswitch OFF.
  • Install pressure gauge into fuel filter head port at inlet.

Action

Measure inlet pressure.

  • Measure the inlet pressure to the first stage fuel filter.

If the engine will not start, perform this test while cranking the engine.

Fuel pressure greater than 0.35 bar [5 psi]?
YES NO

Repair

Refer to the equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the operation of the fuel pump pressurizing assembly 1.

Guided Step 3A - Inspect the fuel pump pressurizing assembly 1 o-ring.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump pressurizing assembly 1.

  • Remove the fuel pump pressurizing assembly 1.
  • Inspect the fuel pump actuator o-ring.
  • If the o-ring is cut or shaved; fuel can be bypassing the fuel pump pressurizing assembly 1 and entering the high-pressure pump.

Use the following procedure in the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 005-016 in Section 5.

Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.

O-ring cut or shaved?
YES NO

Repair

Replace the damaged o-ring.

Use the following procedure in the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 005-016 in Section 5.

Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in Section 5.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Apr-2015


FAULT CODE 451 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active in the same source address as Fault Code 451?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the injector metering rail 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the injector metering rail 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update is available for this fault code, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active in the same source address as Fault Code 451?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the injector metering rail 1 pressure sensor and circuit.

Guided Step 2A - Inspect the injector metering rail 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and injector metering rail 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector metering rail 1 pressure sensor or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged sensor.

Check all harnesses connected in series.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the sensor. Refer to Procedure 019-115 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the injector metering rail 1 pressure RETURN (sensor return 2) pin and the injector metering rail 1 pressure SIGNAL pin at the injector metering rail 1 pressure sensor connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the injector metering rail 1 pressure RETURN (sensor return 2) pin at the injector metering rail 1 pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Disconnect the injector metering rail 1 pressure sensor connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the injector metering rail 1 pressure sensor.

Refer to Procedure 019-115 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the injector metering rail 1 pressure SIGNAL pin and the injector metering rail 1 pressure RETURN (sensor return 2) pin at the ECM engine harness connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the injector metering rail 1 pressure SIGNAL wire of the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the injector metering rail 1 pressure RETURN (sensor return 2) pin at the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open injector metering rail 1 pressure RETURN (sensor return 2) circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Apr-2012


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active in the same source address as Fault Code 452?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 inactive?
STEP 2. | Check the injector metering rail 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the injector metering rail 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active in the same source address as Fault Code 452?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 187.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the injector metering rail 1 pressure sensor and circuit.

Guided Step 2A - Inspect the injector metering rail 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch ON
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and injector metering rail 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector metering rail 1 pressure sensor or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged injector metering rail 1 pressure sensor.

Check all harnesses connected in series.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the injector metering rail 1 pressure RETURN (sensor return 2) pin at the injector metering rail 1 pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.2-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Disconnect the injector metering rail 1 pressure sensor connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

Repair

A damaged injector metering rail 1 pressure sensor has been detected.

Replace the injector metering rail 1 pressure sensor. Refer to Procedure 019-115 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the injector metering rail 1 pressure RETURN (sensor return 2) pin at the ECM engine harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • All components connected
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • All components connected
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open injector metering rail 1 RETURN (sensor return 2) circuit or a pin-to-pin short circuit has been detected on the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Apr-2012


FAULT CODE 479 - Exhaust Gas Temperature Bank Imbalance - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the left and right air shutoff valves. |
 | STEP 1A. Use INSITE™ electronic service tool to determine the temperature difference between the left and right banks. | EGT Bank Differential Temperature parameter in INSITE™ electronic service tool shows (+ve) value?
 | STEP 1B. Check the position of the right bank air shutoff valves. | Right bank air shutoff valves in open position?
 | STEP 1C. Check the position of the left bank air shutoff valves. | Left bank air shutoff valves in open position?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the left and right air shutoff valves.

Guided Step 1A - Use INSITE™ electronic service tool to determine the temperature difference between the left and right banks.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Review the value of EGT Bank Differential Temperature from fault log 479.

  • Determine if the EGT Bank Differential Temperature parameter shows a +ve or -ve value.

Does the EGT Bank Differential Temperature parameter in INSITE™ electronic service tool shows a +ve value?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1C

Guided Step 1B - Check the position of the right bank air shutoff valves.

Conditions

  • Turn keyswitch ON.
  • Connect all components, except the hump hose.

Action

Check the position of the right bank air shutoff valves.

Right bank air shutoff valves in the open position?
YES NO

Repair

Reference the Engine Performance Troubleshooting Tree in Section TT to troubleshoot low power symptoms. Disregard the exhaust gas temperature imbalance fault code procedure.

Repair

Reference the Remove and Install steps in the following procedure from the QSK45 and QSK60 CM2150 Service Manual, Bulletin 4021530. Refer to Procedure 010-143 in Section 10.

Repair complete.

Go to 2A

Guided Step 1C - Check the position of the left bank air shutoff valves.

Conditions

  • Turn keyswitch ON.
  • Connect all components, except the hump hose.

Action

Check the position of the left bank air shutoff valves.

Left bank air shutoff valves in open position?
YES NO

Repair

See the Engine Performance Troubleshooting Tree in Section TT to troubleshoot the low power symptoms. Disregard the exhaust gas temperature imbalance fault code procedure.

No Repair

Repair complete.

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 479 is inactive.

Fault Code 479 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 19-Jul-2012


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 1 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 488 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 1 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor.

NOTE: The probe must extend into the air flow and must not touch the intake manifold, except at the probe threads.

  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Compare the intake manifold 1 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
YES NO

Repair

Reference the Intake Manifold Air Temperature Above Specification symptom tree.

Repair

A damaged intake manifold 1 temperature sensor has been detected.

  • Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronics service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 488 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronics service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronics service tool to clear the inactive fault codes.

All faults codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Jul-2012


FAULT CODE 489 - Transmission Output Shaft Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the new ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, and Part Number 3823255 - female Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and engine harness connectors. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 10 ohms?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and engine harness connectors.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the 31-pin OEM connector.

Action

Inspect the OEM harness and connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the harness connection.

  • Clean the connectors and pins.
  • Repair or replace the damaged section of harness.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 1B

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the 31-pin OEM connector
  • Disconnect the OEM harness connector from the external speed command input sending unit connector.

Action

Check for an open circuit.

  • Measure the resistance from the external speed command input SIGNAL pin of the OEM harness 31-pin connector to the external speed command input pin of the OEM harness frequency signal sending unit side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot each section of the harness to determine which contains the open circuit.

  • Refer to the OEM service manual for repair information.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the 31-pin OEM connector
  • Disconnect the OEM harness connector from the external speed command input sending unit connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the external speed command input SIGNAL pin of the OEM harness 31-pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot each section of the harness to determine which contains the short circuit to ground.

  • Refer to the OEM service manual for repair information.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the 31-pin OEM connector
  • Disconnect the OEM harness connector from the external speed command input sending unit connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the external speed command input SIGNAL pin of the OEM harness 31-pin connector to all other pins in the connector except for the external speed command input RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot each section of the harness to determine which contains the pin-to-pin short circuit.

  • Refer to the OEM service manual for repair information.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness connections.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the harness connection.

  • Clean the connectors and pins.
  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness interconnections.

Action

Check for an open circuit.

  • Measure the resistance from the external speed command input SIGNAL pin of the ECM connector to the external speed command input RETURN pin of the engine harness, OEM harness side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot each section of the harness to determine which contains the open circuit.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness interconnections.

Action

Measure the resistance from the external speed command input SIGNAL pin of the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot each section of the harness to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness interconnections.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the external speed command input SIGNAL pin of the engine harness to all other pins in the connector except for the external speed command input RETURN pin.

Check to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot each section of the harness to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 1A

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jul-2012


FAULT CODE 497 - Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the switches. |
 | STEP 1A. Check the resistance from the multiple unit synchronization switch 1 pin to ground. | Less than 10 ohms?
 | STEP 1B. Check the resistance from the multiple unit synchronization switch 2 pin to ground. | Greater than 100k ohms?
 | STEP 1C. Check the resistance from the multiple unit synchronization switch 1 pin to ground. | Greater than 100k ohms?
 | STEP 1D. Check the resistance from the multiple unit synchronization switch 2 pin to ground. | Less than 10 ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect OEM harness and engine harness 50-pin connector for damaged pins. | Dirty or damaged pins?
 | STEP 2B. Check the OEM harness for a short to ground. | Greater than 100k ohms?
 | STEP 2C. Check the OEM harness for a short from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector for damaged pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check the engine harness for a short from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness to OEM harness connectors and ECM connectors for damaged pins. | Dirty or damaged pins?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 497 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the switch.

Guided Step 1A - Check the resistance from the multiple unit synchronization switch 1 signal pin to ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiple unit synchronization switch 1 ON.
  • Disconnect the OEM harness connector from the engine harness 23-pin connector.

Action

Check the resistance.

  • Measure the resistance from the multiple unit synchronization switch 1 SIGNAL pin of the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the multiple unit synchronization switch 1.

Refer to the OEM service manual.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance from the multiple unit synchronization switch 2 signal pin to ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiple unit synchronization switch 2 ON.
  • Disconnect the OEM harness connector from the engine harness 23-pin connector.

Action

Check the resistance.

  • Measure the resistance from the multiple unit synchronization switch 2 SIGNAL pin of the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the multiple unit synchronization switch 2.

Refer to the OEM service manual.

Go to 1C

Go to 5A

Guided Step 1C - Check the resistance from the multiple unit synchronization switch 1 signal pin to ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiple unit synchronization switch 1 OFF.
  • Disconnect the OEM harness connector from the engine harness 23- pin connector.

Action

Check the resistance.

  • Measure the resistance from the multiple unit synchronization switch 1 SIGNAL pin of the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the multiple unit synchronization switch 1.

Refer to the OEM service manual.

Go to 1D

Go to 5A

Guided Step 1D - Check the resistance from the multiple unit synchronization switch 2 signal pin to ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiple unit synchronization switch 2 OFF.
  • Disconnect the OEM harness connector from the engine 23-pin connector.

Action

Check the resistance.

  • Measure the resistance from the multiple unit synchronization switch 2 SIGNAL pin of the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the multiple unit synchronization switch 2.

Refer to the OEM service manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and engine harness connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 23-pin connector.

Action

Inspect the OEM harness and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Sectioin 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the OEM harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the multiple unit synchronization switch 1 and 2 connector from the OEM harness connector.
  • Disconnect the OEM harness connector from the engine harness 23-pin connector.

Action

Check the OEM harness for a short to ground.

  • Measure the resistance from the multiple unit synchronization switch 1 SIGNAL pin of the OEM harness connector to engine block ground.
  • Measure the resistance from the multiple unit synchronization switch 2 SIGNAL pin of the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check the OEM harness for a short from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the multiple unit synchronization switch 1 and 2 connector from the OEM harness connector.
  • Disconnect the OEM harness connector from the engine harness 23-pin connector.

Action

Check the OEM harness for a short from pin-to-pin.

  • Measure the resistance from the multiple unit synchronization switch 1 SIGNAL pin of the OEM harness to all other pins in the connector.
  • Measure the resistance from the multiple unit synchronization switch 2 SIGNAL pin of the OEM harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the OEM service manual.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness and ECM connector for damaged pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Sectioin 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector pins.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness connector.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the engine harness for an open circuit.

  • Measure the resistance from the multiple unit synchronization switch 1 SIGNAL pin of the engine harness to the multiple unit synchronization switch 2 SIGNAL pin of the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness connector.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the engine harness for a short to ground.

  • Measure the resistance from the multiple unit synchronization switch 1 SIGNAL pin of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the engine harness for a short from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the OEM harness connector.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the engine harness for a short from pin-to-pin.

  • Measure the resistance from the multiple unit synchronization switch 1 SIGNAL pin of the engine harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness to OEM harness connectors and ECM connectors for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness connector.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness to OEM harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Sectioin 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Verify that Fault Code 497 is inactive.

Fault code 497 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Refer to the appropriate troubleshooting steps.

Last Modified: 19-Jul-2012


Fault Code 521 - Transmission Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, and Part Number 3823256 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 521 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the transmission (gear) oil temperature sensor and circuit. |
 | STEP 2A. Inspect the transmission (gear) oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 521 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 522 active and Fault Code 521 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 521 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 521 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 521 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the transmission (gear) oil temperature sensor and circuit.

Guided Step 2A - Inspect the transmission (gear) oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness.

Action

Check the transmission (gear) oil temperature sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector or shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the transmission (gear) oil temperature sensor or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged transmission (gear) oil temperature sensor. See equipment manufacturer service information.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness.

Action

Check sensor resistance.

  • Measure the resistance between the transmission (gear) oil temperature sensor SIGNAL pin and transmission (gear) oil temperature sensor RETURN (sensor return 1) pin at the transmission (gear) oil temperature sensor.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

Replace the damaged transmission (gear) oil temperature sensor. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the transmission (gear) oil temperature sensor connector to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 521 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector or shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the transmission (gear) oil temperature sensor SIGNAL pin and transmission (gear) oil temperature sensor RETURN (sensor return 1) pin at the ECM 60 pin engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 522 active and Fault Code 521 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the transmission (gear) oil temperature sensor RETURN (sensor return 1) pin of the engine harness connector and the transmission (gear) oil temperature sensor RETURN (sensor return 1) pin of the engine harness ECM 60 pin connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open transmission (gear) oil temperature sensor return (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the transmission (gear) oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the transmission (gear) oil temperature sensor SIGNAL pin of the engine harness ECM 60 pin connector and the transmission (gear) oil temperature sensor SIGNAL pin of the engine harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open transmission (gear) oil temperature sensor signal circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the transmission (gear) oil temperature sensor SIGNAL pin in the engine harness ECM 60 pin connector and all other pins in the engine harness ECM 60 pin connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the transmission (gear) oil temperature sensor SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 521 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connection INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 521 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connection INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate fault code troubleshooting steps.

Last Modified: 02-Dec-2016


FAULT CODE 522 - Transmission Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 522 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the transmission (gear) oil temperature sensor and circuit. |
 | STEP 2A. Inspect the transmission (gear) oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 521 active and Fault Code 522 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 522 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 521 active and Fault Code 522 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 522 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 522 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service too.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 522 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil temperature sensor 1 and circuit.

Guided Step 2A - Inspect the transmission (gear) oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.

Action

Inspect the transmission (gear) oil temperature sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the transmission (gear) oil temperature sensor or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged transmission (gear) oil temperature sensor. See equipment manufacturer service information.
 No Repair

  • 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 521 active and Fault Code 522 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 522 active?
YES NO

Repair

A damaged transmission (gear) oil temperature sensor has been detected.

  • Replace the damaged transmission (gear) oil temperature sensor. See equipment manufacturer service information.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the ECM and engine harness connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 521 active and Fault Code 522 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the transmission (gear) oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the transmission (gear) oil temperature sensor SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the harness to determine which contains the short to open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.

Action

Check for a short circuit.

  • Measure the resistance between the transmission (gear) oil temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the transmission (gear) oil temperature sensor SIGNAL wire has been detected in the engine harness

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harness connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool\ to read the fault codes.

Fault Code 522 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode will have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to clear the inactive fault codes.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 02-Jan-2017


FAULT CODE 527 - Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the supply voltage at the ECM. | Greater than 24-VDC when set at 100 percent?
 | STEP 1C. Check for a short in the solenoid auxiliary input/output 2 SIGNAL wire to ground. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault codes. | Fault Code 527 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connection.

Clean the connector pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch ON.
  • Confirm auxiliary input/output 2 signal is turned ON.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM harness at the 23-pin connector.
  • Connect the female end of jumper wire to the auxiliary input/output 2 SIGNAL pin in the ECM connector.
  • Attach the clip end of the jumper wire to the ECM housing for completion of the ground circuit.

Action

Check the supply voltage at the ECM.

  • Measure the voltage from auxiliary input/output 2 SIGNAL pin on the ECM side of the OEM harness connector to engine block ground.

Note: The pulse width modulator must read either 24-VDC when set at 100 percent or 0-VDC when not at 100 percent.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

More than 24-VDC when set at 100 percent?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 1C - Check for a short in the solenoid auxiliary input/output 2 signal wire to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from both ECM connectors.
  • Disconnect the engine harness connector from the OEM harness at the 23-pin connector.

Action

Check for a short in the solenoid auxiliary input/output 2 SIGNAL wire to ground.

  • Measure the resistance from auxiliary input/output 2 SIGNAL pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from both ECM connectors.
  • Disconnect the engine harness connector from the OEM harness at the 23-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from auxiliary input/output 2 SIGNAL pin of the engine harness connector to all other wires in the connector.

Refer to the circuit diagram or wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness connections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 527 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear all of the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Jul-2012


FAULT CODE 529 - Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the supply voltage at the ECM. | Greater than 24-VDC when set at 100 percent?
 | STEP 1C. Check for a short in the solenoid auxiliary input/output 3 signal wire to ground. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault codes. | Fault Code 529 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connection.

Clean the connector pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch ON.
  • Confirm auxiliary input/output 3 signal is turned ON.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 23-pin connector.
  • Connect the female end of jumper wire to the auxiliary input/output 3 SIGNAL pin in the ECM connector.
  • Attach the clip end of the jumper wire to the ECM housing for completion of the ground circuit.

Action

Check the supply voltage at the ECM.

  • Measure the voltage from auxiliary input/output 3 SIGNAL pin on the ECM side of the OEM harness connector to engine block ground.

NOTE: The pulse width modulation must read either 24-VDC when set at 100 percent or 0-VDC when not at 100 percent.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 24-VDC when set at 100 percent?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short in the solenoid auxiliary input/output 3 signal wire to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 23-pin connector.

Action

Check for a short in the solenoid auxiliary input/output 3 signal wire to ground.

  • Measure the resistance from the auxiliary input/output 3 SIGNAL pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the damaged section of engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM 60-pin connectors.
  • Disconnect the engine harness connector from the OEM harness 23-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from auxiliary input/output 3 SIGNAL pin of the engine harness connector to all other wires in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the damaged section of engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 529 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear all of the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Refer to the appropriate troubleshooting steps

Last Modified: 19-Jul-2012


FAULT CODE 546 - Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault code. | Fault Code 227 active in same source address as Fault Code 546?
 | STEP 1B. Check for inactive fault code. | Fault Code 546 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 547 active and Fault code 546 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault code 546 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 546 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active in same source address as Fault Code 546?
YES | NO
No Repair | No Repair

Refer to fault code 227.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the fuel delivery pressure sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged fuel delivery pressure sensor. Refer to Procedure 019-398 in Sectioin 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 547 active and Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin to the fuel delivery pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 active?
YES NO

Repair

A damaged fuel delivery pressure sensor has been detected.

  • Replace the fuel delivery pressure sensor. Refer to Procedure 019-398 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness or damaged ECM.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 active ?
YES NO

Repair

A pin-to-pin short circuit has been detected on the fuel delivery pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

For general inspection techniques, refer to Component Connector and Pin Inspection, Procedure Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector pins.

Replace the damaged section of the harness or damaged ECM.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin to the fuel delivery pressure RETURN (sensor return 2) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open fuel delivery pressure RETURN (sensor return 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 546 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Refer to the appropriate troubleshooting steps

Last Modified: 20-Jul-2012


FAULT CODE 547 - Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault code. | Fault Code 187 active in same source address as Fault Code 547?
 | STEP 1B. Check for an inactive fault code. | Fault Code 547 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault code 546 active and fault code 547 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault code 547 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 547 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active in same source address as Fault Code 547?
YES | NO
No Repair | No Repair

Refer to fault code 187.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the fuel delivery pressure sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of harness. Refer to Procedure 019-043
  • Replace the damaged sensor. Refer to Procedure 019-398
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin to the fuel delivery pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin and the fuel delivery pressure SIGNAL pin at the fuel delivery pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Check for the circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 active and fault code 547 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 547 active?
YES NO

Repair

A damaged fuel delivery pressure sensor has been detected.

  • Replace the damaged sensor. Refer to Procedure 019-398

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 60-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Replace the damaged section of harness of damaged fuel delivery pressure sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connecto
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin to the fuel delivery pressure RETURN (sensor return 2) pin at the 60-pin connector port of the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds..

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 547 active ?
YES NO

Repair

An open or shorted fuel delivery pressure 5 volt SUPPLY (sensor supply 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 60-pin connector .

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector pins.

Replace the damaged section of the harness or ECM.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 60-pin connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin and the fuel delivery pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 active and fault code 547 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 547 inactive?
YES NO

Repair

An open fuel delivery pressure RETURN (sensor return 2) circuit or pin-to-pin short circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit or pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 547 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2012


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check sensor accuracy. |
 | STEP 1A. Verify the crankcase pressure sensor. | Crankcase pressure sensor agree with the mechanical gauge?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 556 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the crankcase pressure sensor.

Conditions

  • Connect a water manometer gauge to the engine.
  • Connect INSITE™ electronic service tool and service harness to the SAE J1939 data link connector on the engine harness.
  • Start the engine.

Action

Verify the crankcase pressure sensor accuracy with a gauge.

NOTE: Operate the engine at rated rpm and full load (wide open throttle) until a steady reading is obtained.

Crankcase pressure sensor agree with the mechanical gauge?
YES NO

Repair

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use the INSITE electronic service tool to verify fault code 556 is inactive.

Fault Code 556 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service too to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 20-Jul-2012


FAULT CODE 559 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK45 and QSK60 | 4021530
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSK45 and QSK60 | 4021530
Fuel Supply Lines | Refer to Procedure 006-024 | QSK45 and QSK60 | 4021530
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSK45 and QSK60 | 4021530
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK45 and QSK60 | 4021530
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK45 and QSK60 | 4021530

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 451, 452, 2215, 2261, or 2262 active or many inactive counts of Fault Code 451, 452, 2215, 2261, or 2262?
STEP 2. | Clear the operation of the high pressure fuel system. |
 | STEP 2A. Check for external leak. | External fuel leaks?
 | STEP 2B. Check for air in fuel. | Air present in the fuel flow line?
 | STEP 2C. Check the Stage 1 fuel filter restriction. | Fuel filter restriction less than specifications?
 | STEP 2D. Check the Stage 2 fuel filter restriction. | Fuel filter restriction less than specifications?
 | STEP 2E. Check the operation of the mechanical dump valve. | Mechanical dump valve leaking?
 | STEP 2E. Check the operation of the fuel pump pressurizing assembly. | Fault Code 559 become active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 559 inactive?
 | STEP 3A. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451, 452, 2215, 2261, or 2262 active or many inactive counts of Fault Code 451, 452, 2261, or 2262?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Clear the operation of the high pressure fuel system.

Guided Step 2A - Check for external leak.

Conditions

  • Operate engine.

Action

Check for external fuel leaks.

  • Start the engine and let it idle.
  • Inspect for external fuel leaks.

External fuel leaks?
YES NO

Repair

Repair all fuel leaks.

Reference the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air in fuel.

Conditions

  • Remove air bleed line from air bleed valve on the fuel drain manifold block.
  • Route the air bleed line into a suitable container to collect fuel.
  • Turn keyswitch ON.

Action

Inspect the fuel flow for air.

Use the following procedure in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-003 in Section 6

Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-003 in Section 6.

Air present in the fuel flow line?
YES NO

Repair

Repair or replace the damaged line or loose connection. Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the fuel restriction.

  • Operate the engine at idle and measure the restriction across the first stage fuel filters.
  • Refer to Procedure 006-020 in Section 6.

Fuel filter restriction less than specifications?
YES NO
No Repair

Repair

The restriction across the first stage filter is above specification. Replace the first stage fuel filter. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the fuel restriction.

  • Operate the engine at high idle and measure the restriction across the second stage fuel filters.
  • Refer to Procedure 006-020 in Section 6.

Fuel filter restriction less than specifications?
YES NO
No Repair

Repair

The restriction across the second stage filter is above specification. Replace the second stage fuel filter. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the operation of the mechanical dump valve.

Conditions

  • Disconnect the mechanical dump valve drain hose from the fuel drain manifold.
  • Place the relief drain hose into a clean container.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Start the engine.

  • Use INSITE™ electronic service tool High Pressure Common Rail Pressure Test to raise the injector metering rail 1 pressure.
  • Measure the fuel leakage from the mechanical dump valve.
  • Install and M18 plug into the fuel drain manifold.

If the engine will not start, reference the Engine Performance Troubleshooting Tree in Section TT.

Mechanical dump valve leaking?
YES NO

Repair

Replace the mechanical dump valve and fuel pump pressurizing assembly. Refer to Procedure 006-061 in the Associated Procedures Table. Refer to Procedure 005-016 in the Associated Procedures Table.

Repair

Replace the fuel pump pressurizing assembly. Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 2F

Go to 2F

Guided Step 2F - Check the operation of the fuel pump pressurizing assembly.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool High Pressure Common Rail Pressure Test to raise the injector metering rail 1 pressure.

Fault Code 559 become active?
YES NO

Repair

Replace the high pressure fuel pump assembly. Refer to Procedure 005-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the inactive fault codes.

Fault Code 559 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Apr-2015


FAULT CODE 595 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 122, 123, 221, or 222 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check for an intermittent fault condition. |
 | STEP 2A. Turn engine keyswitch ON and confirm that the turbocharger speed fault becomes active. | Fault Code 595 becomes active during engine keyswitch ON?
 | STEP 2B. Operate the engine and confirm the turbocharger speed fault comes active. | Fault Code 595 becomes active during engine operation?
STEP 3. | Check for a damaged turbocharger speed sensor. |
 | STEP 3A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 4C. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 5. | Check the turbocharger speed sensor. |
 | STEP 5A. Connect all components and determine if the fault code reoccurs. | Fault Code 595 come active during engine operation?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122, 123, 221, or 222 active or inactive with more than one count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check for an intermittent fault condition.

Guided Step 2A - Turn engine keyswitch ON and confirm that the turbocharger speed fault becomes active.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 595 becomes active during engine keyswitch ON?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Repair complete.

Go to 2B

Guided Step 2B - Operate the engine and confirm the turbocharger speed fault comes active.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent). Hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle.
  • Use INSITE™ electronic service tool to read the fault codes.

This step is valid even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Fault Code 595 becomes active during engine operation?
YES NO
No Repair

Repair

An intermittent fault code condition exists.

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check for a damaged turbocharger speed sensor.

Guided Step 3A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the turbocharger speed sensor connector, engine harness connector, and turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Refer to Procedure 019-390 in Section 19.
No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch ON.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor.

  • Refer to Procedure 019-390 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for a short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except turbocharger speed SIGNAL (-) pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Inspect the engine harness for a short between two pins.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the turbocharger speed sensor.

Guided Step 5A - Connect all components and determine if the fault code reoccurs.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Start the engine.

Action

Operate the engine at idle.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent). Hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle speed.
  • Use INSITE™ electronic service tool to read the fault codes.

This step applies even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Fault Code 595 becomes active during engine operation?
YES NO

Repair

  • The turbocharger speed sensor is damaged.
  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Repair

The faulty condition was repaired when the components were reconnected.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 03-Oct-2017


FAULT CODE 599 - Auxiliary Commanded Dual Output Shutdown - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault code 599. | Active or inactive counts of fault code 599?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault code 599.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an fault codes.

  • Use INSITE electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 599?
YES NO

Repair

  • The engine protection limit has been exceeded for the OEM supplied auxiliary device. Refer to the OEM service manual.
 No Repair

OEM service manual

Repair complete

Last Modified: 20-Jul-2012


FAULT CODE 611 - Engine Shut Down Hot - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | No action required. |
 | STEP 1A. No action required. | Engine shut down before proper cool down?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 611 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - No action required.

Guided Step 1A - No action required.

Conditions

None.

Action

Engine Hot Shutdown - Condition Exists.

The engine was shut down with the keyswitch before proper engine cooldown, resulting in a load factor above the maximum shut down threshold.

Engine shut down before proper cool down?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 611 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2012


FAULT CODE 621 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 1 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading with INSITE™ electronic service tool?
STEP 2. | Check engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 1 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 1 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 1 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 1.

Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 1 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 1 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 1 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 1 connector, if repair is not possible.

Check all harnesses connected in series.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 1 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 1 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 1 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2014


FAULT CODE 621 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 1 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading with INSITE™ electronic service tool?
STEP 2. | Check engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 1 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 1 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 1 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 1.

Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 1 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 1 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 1 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 1 connector, if repair is not possible.

Check all harnesses connected in series.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 1 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 1 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 1 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2014


FAULT CODE 622 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 3 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 3 reading with INSITE™ electronic service tool?
STEP 2. | Check engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 3 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 3 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 3 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 3 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 3.

Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 3 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 3 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 3 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 3 connector, if repair is not possible.

Check all harnesses connected in series.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 3 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 3 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 3 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2014


FAULT CODE 622 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 3 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 3 reading with INSITE™ electronic service tool?
STEP 2. | Check engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 3 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 3 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 3 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 3 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 3.

Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 3 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 3 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 3 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 3 connector, if repair is not possible.

Check all harnesses connected in series.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 3 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 3 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 3 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2014


FAULT CODE 623 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 5 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 5 reading with INSITE™ electronic service tool?
STEP 2. | Check engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 5 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 5 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 5 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 5 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 5.

Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 5 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 5 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 5 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 5 connector if repair is not possible.

Check all harnesses connected in series.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 5 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 5 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 5 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2014


FAULT CODE 623 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 5 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 5 reading with INSITE™ electronic service tool?
STEP 2. | Check engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 5 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 5 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 5 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 5 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 5.

Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 5 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 5 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 5 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 5 connector if repair is not possible.

Check all harnesses connected in series.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 5 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 5 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 5 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2014


FAULT CODE 624 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 7 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 7 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 7 reading with INSITE™ electronic service tool?
STEP 2. | Check engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit 7 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit 7 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 7 accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 7 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 7 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 7 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 7.

Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 7 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 7 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 7 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 7 connector if repair is not possible.

Check all harnesses connected in series.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 7 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 7 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 7 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2014


FAULT CODE 624 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 7 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 7 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 7 reading with INSITE™ electronic service tool?
STEP 2. | Check engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit 7 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit 7 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 7 accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 7 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 7 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 7 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 7.

Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • KTurn kDisconnect the exhaust gas temperature sensor cylinder 7 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 7 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 7 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 7 connector if repair is not possible.

Check all harnesses connected in series.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 7 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 7 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 7 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2014


FAULT CODE 625 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 9 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 9 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 9 reading with INSITE™ electronic service tool?
STEP 2. | Check engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit 9 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit 9 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 9 accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 9 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 9 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 9 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 9.

Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 9 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 9 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 9 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 9 connector if repair is not possible.

Check all harnesses connected in series.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 9 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 9 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 9 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2014


FAULT CODE 625 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 9 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 9 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 9 reading with INSITE™ electronic service tool?
STEP 2. | Check engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit 9 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit 9 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 9 accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 9 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 9 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 9 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 9.

Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 9 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 9 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 9 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 9 connector if repair is not possible.

Check all harnesses connected in series.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 9 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 9 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 9 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2014


FAULT CODE 626 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 11 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 11 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 11 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 626 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 11 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 11 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 11 accuracy with an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 11 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 11 reading with INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 11 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check ECM and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 11 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 11 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 11 connector, if repair is not possible.

Check all harnesses connected in series.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 11 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 11 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor converter.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 626 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Oct-2015


FAULT CODE 626 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 11 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 11 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 11 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 626 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 11 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 11 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 11 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 11 reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 11 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 11 has been detected.

  • Replace the exhaust gas temperature sensor circuit cylinder 11. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check ECM and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 11 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 11 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 11 connector, if repair is not possible.

Check all harnesses connected in series.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 11 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 11 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor converter.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 626 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Oct-2015


FAULT CODE 627 (QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 13 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 13 reading with INSITE™ electronic service tool?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy, use an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 13 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 13 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 13 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 13. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A -

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2012


FAULT CODE 627 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 13 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 13 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 627 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 13 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 13 reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 13 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 13 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 13.

  • Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check ECM and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 13 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 13 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 13 connector, if repair is not possible.

Check all harnesses connected in series.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 13 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 13 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor converter.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 627 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Oct-2015


FAULT CODE 628 (QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 15 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 15 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 628 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 15 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy, use an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 15 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 15 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 15 has been detected.

  • Replace the exhaust gas temperature sensor circuit cylinder 15. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 628 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Jul-2012


FAULT CODE 628 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 15 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 15 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 628 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 15 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 15 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 15 reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 15 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 15 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 15.

  • Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check ECM and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 15 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 15 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 15 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 15 connector, if repair is not possible.

Check all harnesses connected in series.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 15 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 15 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 15 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor converter.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 628 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Oct-2015


FAULT CODE 631 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 2 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 2 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 2 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy, use an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer, measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature exhaust gas temperature sensor circuit cylinder 2 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 2 reading in the INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A faulty exhaust gas temperature sensor circuit cylinder 2 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 2. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check ECM and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 2 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 2 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 2 connector, if repair is not possible.

Check all harnesses connected in series.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 2 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 2 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor converter.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 2B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Oct-2015


FAULT CODE 631 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 2 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 2 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update is available for this fault code, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 2 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 2 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 2 reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 2 reading with INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 2 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 2. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check ECM and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 2 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 2 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 2 connector, if repair is not possible.

Check all harnesses connected in series.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 2 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 2 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor converter.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A -

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Oct-2015


FAULT CODE 632 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 4 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 4 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 4 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 4 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 4 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 4 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 4 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 4 reading with INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A faulty exhaust gas temperature sensor circuit cylinder 4 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 4. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check ECM and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 4 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 4 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 4 connector, if repair is not possible.

Check all harnesses connected in series.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 4 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 4 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor converter.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Oct-2015


FAULT CODE 632 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 4 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 4 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 4 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 632 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 4 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 4 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperaturesensor circuit cylinder 4 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 4 reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 4 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 4 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 4.

  • Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check ECM and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 4 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 4 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 4 connector, if repair is not possible.

Check all harnesses connected in series.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 4 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 4 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor converter.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 632 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Oct-2015


FAULT CODE 633 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 6 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 6 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 6 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 6 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 6 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 6 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 6 reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 6 reading with INSITE™ electronic service tool?

YES NO

Repair

Troubleshoot possible cylinder or injector damage.

Repair

A faulty exhaust gas temperature sensor circuit cylinder 6 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 6. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check ECM and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 6 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 6 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 6 connector, if repair is not possible.

Check all harnesses connected in series.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 6 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 6 harness or connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor converter.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Oct-2015


FAULT CODE 633 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 6 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 6 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 6 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harenss connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 633 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 6 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 6 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 6 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 6 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 6 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 6 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 6.

  • Refer to Procedure 019-013 in Section 19.

Engine Performance troubleshooting tree in Section TT

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 6 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 6 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 6 connector, if repair is not possible.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 6 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 6 harness or connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19 or Refer to Procedure 019-450 in Section 19.

No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 633 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2014


FAULT CODE 634 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 8 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 8 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 8 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 634 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 8 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 8 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylidner 8 accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 8 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 8 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A faulty exhaust gas temperature sensor circuit cylinder 8 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 8.

Refer to Procedure 019-013 in Section 19.

Engine Performance troubleshooting tree in Section TT

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 8 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 8 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 8 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 8 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 8 harness or connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 8 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19 or Refer to Procedure 019-450 in Section 19.

No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 634 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2014


FAULT CODE 634 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 8 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 8 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 8 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 634 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 8 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 8 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 8 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 8 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 8 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 8 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 8.

  • Refer to Procedure 019-013 in Section 19.

Engine Performance troubleshooting tree in Section TT

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 8 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 1 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 8 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 8 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 1 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 634 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 635 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 10 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 10 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 635 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 10 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy, use infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 10 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 10 reading in the INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 10 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 10.

Refer to Procedure 019-013 in Section 19.

Engine Performance troubleshooting tree in Section TT

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 10 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 10 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 10 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 10 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 10 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19 or Refer to Procedure 019-450 in Section 19.

No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 635 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2014


FAULT CODE 635 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 10 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 10 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 635 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 10 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 10 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 10 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 10 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 10 has been detected.

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 10 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 10 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 10 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 10 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 10 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature convertor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19 or Refer to Procedure 019-450 in Section 19.

No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 635 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2014


FAULT CODE 636 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 12 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 12 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 636 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 12 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy, use infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 12 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 12 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A faulty exhaust gas temperature sensor circuit cylinder 12 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 12.

Refer to Procedure 019-013 in Section 19.

Engine Performance troubleshooting tree in Section TT

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 12 connector from the engine harness connector

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 12 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 12 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 12 connector from the engine harness connector

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 12 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section harness or the damaged exhaust gas temperature sensor convertor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19 or Refer to Procedure 019-450 in Section 19.

No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 636 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2014


FAULT CODE 636 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 12 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 12 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 636 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 12 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 12 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 12 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 12 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A faulty exhaust gas temperature sensor circuit cylinder 12 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 12.

  • Refer to Procedure 019-013 in Section 19.

Engine Performance troubleshooting tree in Section TT

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 12 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 12 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 12 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 12 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 12 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19 or Refer to Procedure 019-450 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 636 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2014


FAULT CODE 637 (QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 14 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 14 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 637 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 14 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy, use an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 14 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 14 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A faulty exhaust gas temperature sensor circuit cylinder 14 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 14.

Refer to Procedure 019-013 in Section 19.

Engine Performance troubleshooting tree in Section TT

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 14 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 14 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 14 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 14 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 14 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19 orRefer to Procedure 019-450 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 637 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2014


FAULT CODE 637 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 14 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 14 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and wiring harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 23. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 637 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 14 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 14 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 14 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 14 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 14 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 14.

  • Refer to Procedure 019-013 in Section 19.

Engine Performance troubleshooting tree in Section TT

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 14 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 14 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 14 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 14 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 14 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19 or Refer to Procedure 019-450 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 637 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2014


FAULT CODE 638 (QSK50 Marine) - Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 16 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy. | Temperature measurement from the infrared thermometer within 15 percent for the exhaust gas temperature sensor circuit cylinder 1 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 638 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 16 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy with an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 16 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent for the exhaust gas temperature sensor circuit cylinder 1 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 16 has been detected.

  • Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance troubleshooting tree in Section TT

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 16 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 16 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 16 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2A

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 16 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 16 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19 or Refer to Procedure 019-450 in Section 19.

No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 638 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 23B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2014


FAULT CODE 638 (Thermistor) - Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 16 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 16 reading with INSITE™ electronic service tool?
STEP 2. | Check the engine control module (ECM) and engine harness connector pins. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor wiring harness and connector pins. | Damaged sensor wiring harness or connector pins?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 638 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 16 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 16 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 16 reading on the INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 16 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 16 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 16.

  • Refer to Procedure 019-013 in Section 19.

Engine Performance troubleshooting tree in Section TT

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and wiring harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 16 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 16 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 16 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 16 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged sensor wiring harness or connector pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 16 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged exhaust gas temperature sensor convertor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19 or Refer to Procedure 019-450 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 638 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2014


FAULT CODE 641 - Exhaust Gas Temperature Cylinder 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 1 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 641 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 1 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 1 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 1 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 1 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 641 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 642 - Exhaust Gas Temperature Cylinder 3 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 3 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 3 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 642 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 3 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 3 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 3 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 3 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 3 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree.

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 642 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 643 - Exhaust Gas Temperature Cylinder 5 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 5 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 5 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 643 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 5 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 5 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 5 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 5 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 5 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 643 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 644 - Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 7 (A4) accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 7 (A4) accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 7 (A4) reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 644 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 7 (A4) accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 7 (A4) accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 7 (A4) accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 7 (A4) reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 7 (A4) reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 7 (A4) has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 644 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 645 - Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 9 (A5) accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 9 (A5) accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 9 (A5) reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 645 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 9 (A5) accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 9 (A5) accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 9 (A5) accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 9 (A5) reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 9 (A5) reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 9 (A5) has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 645 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 646 - Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 11 (A6) accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 11 (A6) accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 11 (A6) reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 646 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 11 (A6) accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 11 (A6) accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 11 (A6) accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 11 (A6) reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 11 (A6) reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 11 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 646 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 647 - Exhaust Gas Temperature Cylinder 13 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 13 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 13 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 647 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 13 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 13 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 13 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 13 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree.

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 647 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 648 - Exhaust Gas Temperature Cylinder 15 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 15 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 15 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 648 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 15 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 15 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 15 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 15 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 15 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 648 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 652 - Exhaust Gas Temperature Cylinder 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 2 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 2 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 652 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 2 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 2 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 2 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 2 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 2 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Dissable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 652 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 653 - Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 4 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 4 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 4 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 653 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 4 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 4 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 4 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 4 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 4 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 4 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 653 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 654 - Exhaust Gas Temperature Cylinder 6 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 6 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 6 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 6 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 654 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 6 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 6 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 6 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 6 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 6 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 6 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 654 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 655 - Exhaust Gas Temperature Cylinder 8 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 8 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 8 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 8 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 655 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 8 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 8 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 8 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 8 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 8 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 8 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 655 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 656 - Exhaust Gas Temperature Cylinder 10 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 10 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 10 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 656 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 10 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 10 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 10 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 10 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 10 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Dissable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 656 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 657 - Exhaust Gas Temperature Cylinder 12 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 12 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 12 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 657 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 12 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 12 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 12 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 12 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 12 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 657 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 658 (Thermistor) - Exhaust Gas Temperature Cylinder 14 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 14 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 14 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 658 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 14 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 14 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 14 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 14 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 14 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 658 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2012


FAULT CODE 671 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 671 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 1 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 1 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 671 active?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas temperature circuit cylinder 1. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the exhaust gas temperature circuit cylinder 1. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the exhaust gas temperature circuit cylinder 1. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 1 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 1 connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged exhaust gas temperature sensor circuit cylinder 1. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 active?
YES NO
No Repair

Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 1 SIGNAL pin and all other pins of the exhaust gas temperature sensor circuit cylinder 1 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 1.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 1. Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 1 RETURN (sensor return 3) pin of the exhaust gas temperature sensor circuit cylinder 1 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 1 RETURN (sensor return 3) wire.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature circuit cylinder 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 1 SIGNAL pin and the exhaust gas temperature sensor circuit cylinder 1 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature circuit cylinder 1 SIGNAL wire.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 1 SIGNAL pin and the exhaust gas temperature sensor circuit cylinder 1 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 1 SIGNAL wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 1 RETURN (sensor return 3) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 1 RETURN (sensor return 3) pin in the exhaust gas temperature sensor circuit cylinder 1 engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the exhaust gas temperature sensor circuit cylinder 1 RETURN (sensor return 3) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Jul-2012


FAULT CODE 671 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

Caution: To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 671 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 1 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1618 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 671 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 671 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 671 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 1 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 1 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 1.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 1 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 1 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 1 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 671 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 672 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 672 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 3 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 3 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 672 active?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 3. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 3. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 3. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 3 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 3 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 3 connector or engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 3.
  • Check all harnesses connected in series.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 active?
YES NO
No Repair

Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 3.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 3 SIGNAL pin and all other pins of the exhaust gas temperature sensor circuit cylinder 3 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 3.

  • Replace the exhaust gas temperature sensor circuit cylinder 3. Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 3.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 3 RETURN (sensor return 3) pin and the exhaust gas temperature sensor circuit cylinder 3 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 3 RETURN (sensor return 3) wire.

  • Replace the damage exhaust gas temperature sensor circuit cylinder 3. Refer to Procedure 019-013 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 3.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 3 SIGNAL pin and the exhaust gas temperature sensor circuit cylinder 3 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 3 SIGNAL wire.

  • Replace the exhaust gas temperature sensor circuit cylinder 3. Refer to Procedure 019-013 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness.
  • Check all harnesses connected in series.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature circuit cylinder 3 SIGNAL pin and the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 3 SIGNAL wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 3 RETURN (sensor return 3) pin in the engine harness ECM 60-pin connector and the exhaust gas temperature sensor circuit cylinder 3 RETURN (sensor return 3) pin in the exhaust gas temperature sensor circuit cylinder 1 engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the exhaust gas temperature sensor circuit cylinder 3 RETURN (sensor return 3) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jul-2012


FAULT CODE 672 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 672 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 3 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 3 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1521 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 672 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 672 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 672 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 3 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 3 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 3 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 3.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector and place a jumper between the SIGNAL pin and the RETURN pin at the exhaust gas temperature sensor connection.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 3 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 3 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 672 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 673 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 673 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 5 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 5 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 673 active?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 5. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 5. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 5. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 5 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 5 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 5 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 5 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 5 connector or engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 5.
  • Check all harnesses connected in series.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the sensor. Refer to Procedure 019-013 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 active?
YES NO
No Repair

Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 5.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 5 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 5 SIGNAL pin and all other pins of the exhaust gas temperature sensor circuit cylinder 5 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 5.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 5. Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 5.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 5 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 5 RETURN (sensor return 3) pin and the exhaust gas temperature sensor circuit cylinder 5 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 5 RETURN (sensor return 3) wire.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 5.
  • Refer to Procedure 019-013 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 5.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 5 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 5 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 5 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 5 SIGNAL wire.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 5.
  • Refer to Procedure 019-013 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness.
  • Check all harnesses connected in series.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 5 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 5 SIGNAL pin and the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 5 SIGNAL wire in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 5 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 5 RETURN (sensor return 3) pin in the engine harness ECM 60-pin connector and the exhaust gas temperature sensor circuit cylinder 5 RETURN (sensor return 3) pin in the exhaust gas temperature sensor circuit cylinder 5 engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the exhaust gas temperature sensor circuit cylinder 5 RETURN (sensor return 3) wire in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jul-2012


FAULT CODE 673 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 673 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 5 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 5 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1618 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 673 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 673 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 673 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 3 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 3 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 3 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 3.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector and place a jumper between the SIGNAL pin and the RETURN pin at the exhaust gas temperature sensor connection.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 5 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 5 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 5 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 5 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 3 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 673 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 674 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 674 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 7 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 7 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 674 active?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 7. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 7. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 7. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update is available for this fault code, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 7 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 7 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 7 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 7 connector or engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 7.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Repair the engine harness. Refer to Procedure 019-013 in Section 19.
  • Replace the exhaust gas temperature sensor. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 active?
YES NO
No Repair

Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 7.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 7 SIGNAL pin and all other pins of the exhaust gas temperature circuit cylinder 7 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 7.

  • Replace the exhaust gas temperature sensor circuit cylinder 7. Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 7.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance of the exhaust gas temperature sensor circuit cylinder 7 RETURN (sensor return 3) pin of the exhaust gas temperature circuit cylinder 7 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 7 RETURN (sensor return 3) wire.

  • Replace the damage exhaust gas temperature sensor circuit cylinder 7. Refer to Procedure 019-013 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 1.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 7 SIGNAL pin of the exhaust gas temperature circuit cylinder 7 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 7 SIGNAL wire.

  • Replace the damage exhaust gas temperature sensor circuit cylinder 7. Refer to Procedure 019-013 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance of the exhaust gas temperature sensor circuit cylinder 7 SIGNAL pin in the engine harness connector ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 7 SIGNAL wire in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 7 RETURN (sensor return 3) pin in the engine harness ECM 60-pin connector and the exhaust gas temperature sensor circuit cylinder 7 RETURN (sensor return 3) pin in the exhaust gas temperature sensor circuit cylinder 7 engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the exhaust gas temperature sensor circuit cylinder 7 RETURN (sensor return 3) wire in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code..

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jul-2012


FAULT CODE 674 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 674 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 7 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 7 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1523 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 674 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Less than 10 ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 674 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 674 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 7 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 7 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 7 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 7 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 7.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 connector from the engine harness connector and place a jumper between the SIGNAL pin and the RETURN pin at the exhaust gas temperature sensor connection.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 7 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-450 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 7 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 7 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 673 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 675 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 675 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 9 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 9 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 675 active?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 9. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 9. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 9. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 9 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 9 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 9 connector or engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 9.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the exhaust gas temperature sensor. .Refer to Procedure 019-450 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 active?
YES NO
No Repair

Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 9.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 9 SIGNAL pin and all other pins of the exhaust gas temperature sensor circuit cylinder 9 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 9.

  • Replace the damage exhaust gas temperature sensor circuit cylinder 9. Refer to Procedure 019-450 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 9.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance of the exhaust gas temperature sensor circuit cylinder 9 RETURN (sensor return 4) pin of the exhaust gas temperature sensor circuit cylinder 9 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 9 RETURN (sensor return 4) wire.

  • Replace the damage exhaust gas temperature sensor circuit cylinder 9. Refer to Procedure 019-450 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 9.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance of the exhaust gas temperature sensor circuit cylinder 9 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 9 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 9 SIGNAL wire.

  • Replace the exhaust gas temperature sensor circuit cylinder 9. Refer to Procedure 019-450 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the harness.
  • Repair the engine harness.Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance of the exhaust gas temperature sensor circuit cylinder 9 SIGNAL pin in the engine harness connector ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 9 SIGNAL wire in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 9 RETURN (sensor return 4) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 9 RETURN (sensor return 4) pin in the exhaust gas temperature sensor circuit cylinder 9 engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the exhaust gas temperature sensor circuit cylinder 9 RETURN (sensor return 4) wire in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault code could possibly have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jul-2012


FAULT CODE 675 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822958 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822919 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 675 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 9 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 9 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1524 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 675 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Less than 10 ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 675 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 675 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 9 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 9 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 9 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 9.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 connector from the engine harness connector and place a jumper between the SIGNAL pin and the RETURN pin at the exhaust gas temperature sensor connection.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-450 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 9 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 9 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 675 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 676 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 676 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 11 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 11 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 676 active?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 11. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 11. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 11. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 11 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 11 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 11 or harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the harness or the damaged exhaust gas temperature sensor circuit cylinder 11.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the exhaust gas temperature sensor. Refer to Procedure 019-450 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 11.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 11 connector to the engine harness connector

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 11 SIGNAL pin and all other pins of the exhaust gas temperature sensor circuit cylinder 11 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 11.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 11. Refer to Procedure 019-450 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 11.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 11 RETURN (sensor return 4) pin of the exhaust gas temperature sensor circuit cylinder 11 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 11.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 11. Refer to Procedure 019-450 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 11.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 11 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 11 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 11.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 11. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 11 SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 11 SIGNAL wire in the engine harness.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 11. Refer to Procedure 019-450 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 11 RETURN (sensor supply 4) pin in the engine harness ECM 60-pin connector and the exhaust gas temperature circuit cylinder 11 RETURN (sensor return 4) pin in the exhaust gas temperature sensor circuit cylinder 11 connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature sensor circuit cylinder 11 RETURN (sensor return 4) wire in the engine harness.

  • Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jul-2012


FAULT CODE 676 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822958 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822911 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 676 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 11 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 11 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1525 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 676 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 676 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 676 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 11 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 11 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 11 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 11.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-450 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 connector from the engine harness connector and place a jumper between the SIGNAL pin and the RETURN pin at the exhaust gas temperature sensor connection.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 11 connector from the engine harness connector.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-450 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 11 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 11 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 676 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 677 (QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 677 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 13 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 13 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 677 active?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 13. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 13. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 13. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 677 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 13 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 13 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 13 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 13 or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged exhaust gas temperature sensor circuit cylinder 13. Refer to Procedure 019-450 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature circuit cylinder 13.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 13 connector to the engine harness connector

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 13 SIGNAL pin and all other pins of the exhaust gas temperature sensor circuit cylinder 13 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 13.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 13. Refer to Procedure 019-450 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 13.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 13 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 13 RETURN (sensor return 4) pin of the exhaust gas temperature sensor circuit cylinder 13 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 13.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 13. Refer to Procedure 019-450 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 13.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 13 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 13 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 13 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 13.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 13 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 13 SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 13 SIGNAL wire in the engine harness.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 13 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 13 RETURN (sensor supply 4) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 13 RETURN (sensor return 4) pin in the exhaust gas temperature circuit cylinder 13 connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature sensor circuit cylinder 13 RETURN (sensor return 4) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 677 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 677 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824813 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822958 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822991 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 677 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 13 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 13 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1526 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 677 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 677 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 677 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 13 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 13 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 13 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 13 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 13.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 13 connector from the engine harness connector and place a jumper between the SIGNAL pin and the RETURN pin at the exhaust gas temperature sensor connection.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 2C

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 13 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 13 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 13 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 13 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 677 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 678 (QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 678 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 15 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 15 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 678 active?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 15. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 15. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 15. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 678 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 inactive?
YES | NO
No Repair | No Repair

Go to
Go to

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 15 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 15 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 15 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

USe the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 15 or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged exhaust gas temperature sensor circuit cylinder 15. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 15.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 15 connector to the engine harness connector

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 15 SIGNAL pin and all other pins of the exhaust gas temperature sensor circuit cylinder 15 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 15.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 15. Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 15.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 15 RETURN (sensor return 4) pin of the exhaust gas temperature sensor circuit cylinder 15 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 15 RETURN (sensor return 4) wire.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 15.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 15 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 15 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 15 SIGNAL wire.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 15 SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 15 SIGNAL wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 15 RETURN (sensor supply 4) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 15 RETURN (sensor return 4) pin in the exhaust gas temperature circuit cylinder 15 engine harness connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature sensor circuit cylinder 15 RETURN (sensor return 4) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 678 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 678 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824815 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822958 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822991 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 678 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 15 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 15 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1527 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 678 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 678 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 678 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 15 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 15 sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 15 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 15 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 15.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 connector from the engine harness connector and place a jumper between the SIGNAL pin and the RETURN pin at the exhaust gas temperature sensor connection.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 2C

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 15 SIGNAL pin in the ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 15 SIGNAL pin in the ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 678 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine crankshaft speed/position sensor and circuit. |
 | STEP 2A. Inspect the engine crankshaft speed/position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Engine crankshaft speed/position sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the engine crankshaft speed/position sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate engine crankshaft speed/position sensor air gap. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor engine crankshaft speed/position sensor state equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Fault Code 238

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • While engine idles, monitor the fault code status.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 689 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine crankshaft speed/position sensor and circuit.

Guided Step 2A - Inspect the engine crankshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine harness connector.

Action

Inspect the engine harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Measure the voltage at the engine crankshaft speed/position sensor connector.

  • Measure the voltage between the engine crankshaft speed/position 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed/position RETURN (sensor return 3) pin at the engine crankshaft speed/position sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool Monitor Mode to read the engine crankshaft speed/position sensor state.

Engine crankshaft speed/position sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the engine crankshaft speed/position 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed/position SIGNAL pin at the sensor connector of the engine harness.
  • Use INSITE™ electronic service tool Monitor Mode to read the engine crankshaft speed/position sensor state.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Engine crankshaft speed/position sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the engine crankshaft speed/position sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine crankshaft speed/position sensor from the engine.

Action

Inspect the engine crankshaft speed/position sensor for the following:

  • Damaged engine crankshaft speed/position sensor tip
  • Physical signs of the engine crankshaft speed/position sensor touching the speed teeth.

Damaged engine crankshaft speed/position sensor tip?
YES NO

Repair

  • Replace the engine crankshaft speed/position sensor.
 No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine crankshaft speed/position sensor from the engine.
  • Make sure the engine crankshaft speed/position sensor is connected to the harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response.

  • Use the side of the socket to directly touch the end of the sensor. Hold the socket against the sensor for a few seconds. Move the socket several inches away from the end of the sensor for a few seconds.
  • Use INSITE™ electronic service tool monitor mode to read the engine crankshaft speed/position sensor state.

Engine crankshaft speed/position sensor state transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Repair

  • Replace the engine crankshaft speed/position sensor.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate engine crankshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch ON.
  • Install the engine crankshaft speed/position sensor to the engine.
  • Connect INSITE™ electronic service tool
  • Momentarily engage the starter, but do not start the engine. Repeat this as many times as necessary.

Action

Monitor the crankshaft engine speed/positon sensor state for the following:

  • Change of state from high to low or low to high, or the state shows triggered.

Engine crankshaft speed/position sensor transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Repair

  • Inspect the crankshaft speed/position sensor for damage.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool Monitor Mode to read the engine crankshaft speed/position sensor state.

Monitor engine crankshaft speed/position sensor state equals low?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine crankshaft speed/position 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed/position SIGNAL pin at the ECM port.

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool Monitor Mode to read the engine crankshaft speed/position sensor state.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Monitor engine crankshaft speed/position sensor state equals high?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage between the engine crankshaft speed/position 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed/position RETURN (sensor return 3) pin at the ECM engine harness port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 689 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 721 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 721 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 2 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 721 active?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 2. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 2. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 2. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 721 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 2 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 2 or harness connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged exhaust gas temperature sensor circuit cylinder 2. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 2.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 2 connector to the engine harness connector

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 2 SIGNAL pin and all other pins of the exhaust gas temperature sensor circuit cylinder 2 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 2.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 2. Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature circuit cylinder 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 2 RETURN (sensor return 3) pin of the exhaust gas temperature sensor circuit cylinder 2 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 2 RETURN (sensor return 3) wire.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 2. Refer to Procedure 019-013 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 2 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 2 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 2 SIGNAL wire.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 2. Refer to Procedure 019-013 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 2 SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 2 SIGNAL wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 2. Refer to Procedure 019-013 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 2 RETURN (sensor supply 3) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 2 RETURN (sensor return 3) pin in the exhaust gas temperature sensor circuit cylinder 2 engine harness connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature sensor circuit cylinder 2 RETURN (sensor return 4) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 721 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 721 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 721 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 2 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1529 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 721 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Less than 10 ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 721 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 721 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 2 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 2 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 2.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 2 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 2 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 2 SIGNAL pin in the ECM 60-pin connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 721 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 722 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 722 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 4 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 4 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 722 active?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 4. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 4. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 4. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 722 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 4 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 4 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 4 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harnesses or

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged exhaust gas temperature sensor circuit cylinder 4. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 4.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 4 connector to the engine harness connector

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 4 SIGNAL pin and all other pins of the exhaust gas temperature sensor circuit cylinder 4 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature circuit cylinder 4.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 4. Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 4.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 4 RETURN (sensor return 3) pin of the exhaust gas temperature sensor circuit cylinder 4 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 4 RETURN (sensor return 3) wire.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 4. Refer to Procedure 019-013 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 4.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 4 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 4 connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 4.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 4. Refer to Procedure 019-013 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 4 SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 4 SIGNAL wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 4 RETURN (sensor supply 3) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 4 RETURN (sensor return 3) pin in the exhaust gas temperature sensor circuit cylinder 4 engine harness connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature sensor circuit cylinder 4 RETURN (sensor return 4) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 722 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 722 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 722 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 4 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 4 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1619 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 722 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 678 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 722 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 4 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 4 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 4 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 4.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 connector from the engineharness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 4 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 4 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 4 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 4 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 4 SIGNAL pin in the ECM 60-pin connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 722 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 723 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 723 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 6 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 6 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 723 active?
 | STEP 2C. Check for a pin-to-pin short circuit in exhaust gas temperature sensor circuit cylinder 6. | Greater than 100k ohms?
 | STEP 2D. Check for short circuit to ground in the exhaust gas temperature sensor circuit cylinder 6. | Greater than 100k ohms?
 | STEP 2E. Check for short circuit to ground in exhaust gas temperature sensor circuit cylinder 6. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for open circuit in engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 723 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 6 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 6 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 6 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harnesses or

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged exhaust gas temperature sensor circuit cylinder 6. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 6.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 6 SIGNAL pin and the exhaust gas temperature sensor circuit cylinder 6 RETURN (sensor return 3) pin of the exhaust gas temperature sensor circuit cylinder 6 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 6.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 6. Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 6.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 6 RETURN (sensor return 3) pin of the exhaust gas temperature sensor circuit cylinder 6 connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 6 RETURN (sensor return 3) wire.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 6.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 6 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 6 connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 6 SIGNAL wire.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 6. Refer to Procedure 019-013 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 6 SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 6 SIGNAL wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 6 RETURN (sensor return 3) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 6 RETURN (sensor return 3) pin in the exhaust gas temperature sensor circuit cylinder 6 engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature sensor circuit cylinder 6 RETURN (sensor return 3) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 723 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 723 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 723 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 6 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 6 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1531 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 723 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 723 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 723 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 6 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 6 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 6 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 6.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 6 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 6 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 6 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 6 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 6 SIGNAL pin in the ECM 60-pin connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 723 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 724 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 724 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 8 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 8 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 724 active?
 | STEP 2C. Check for a pin-to-pin short circuit in exhaust gas temperature sensor circuit cylinder 8. | Greater than 100k ohms?
 | STEP 2D. Check for short circuit to ground in the exhaust gas temperature sensor circuit cylinder 8. | Greater than 100k ohms?
 | STEP 2E. Check for short circuit to ground in exhaust gas temperature sensor circuit cylinder 8. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for open circuit in engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 724 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 8 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 8 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 8 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harnesses or damaged exhaust gas temperature sensor circuit cylinder 8.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged exhaust gas temperature sensor circuit cylinder 8. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 8.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature circuit cylinder 8 SIGNAL pin and all other pins of the exhaust gas temperature circuit cylinder 8 engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 8.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 8. Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 8.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 8 RETURN (sensor return 3) pin of the exhaust gas temperature sensor circuit cylinder 8 connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 8 RETURN (sensor return 3) wire.

Replace the damaged section of the engine harness.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 8. Refer to Procedure 019-013 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 8.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 8 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 8 connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 8 SIGNAL wire.

  • Replace the damaged exhaust gas temperature sensor circuit cylinder 8. Refer to Procedure 019-013 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the e engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 connector in the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 8 SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 8 SIGNAL wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 8 RETURN (sensor return 3) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 8 RETURN (sensor return 3) pin in the exhaust gas temperature sensor circuit cylinder 8 engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature sensor circuit cylinder 8 RETURN (sensor return 3) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 724 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaing fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Jul-2012


FAULT CODE 724 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 724 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 8 sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit cylinder 8 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 724 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Less than 10 ohms?
 | STEP 3D. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 8 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 8 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 8 connector or engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 8.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active?
YES NO
No Repair

Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 8 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 8 SIGNAL pin in the ECM 60-pin connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check the appropriate circuit response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 inactive?
YES NO

Repair

NOTE: The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jul-2012


FAULT CODE 725 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 725 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 10 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 10 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 725 active?
 | STEP 2C. Check for a pin-to-pin short circuit in exhaust gas temperature sensor circuit cylinder 10. | Greater than 100k ohms?
 | STEP 2D. Check for short circuit to ground in the exhaust gas temperature sensor circuit cylinder 10. | Greater than 100k ohms?
 | STEP 2E. Check for short circuit to ground in exhaust gas temperature sensor circuit cylinder 10. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for open circuit in engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 725 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 10 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 10 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 10 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 10.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 10.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 10 SIGNAL pin and the exhaust gas temperature sensor circuit cylinder 10 RETURN (sensor return 1) pin of the exhaust gas temperature sensor circuit cylinder 10 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 10.

Replace the damaged exhaust gas temperature sensor circuit cylinder 10.

  • Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 10.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 10 RETURN (sensor return 1) pin of the exhaust gas temperature sensor circuit cylinder 10 connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 10 RETURN (sensor return 1) wire.

Replace the damaged exhaust gas temperature sensor circuit cylinder 10.

  • Refer to Procedure 019-013 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 10.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 10 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 10 connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 10 SIGNAL wire.

Replace the damaged exhaust gas temperature sensor circuit cylinder 10.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 10 SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 10 SIGNAL wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 10 RETURN (sensor return 1) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 10 RETURN (sensor return 1) pin in the exhaust gas temperature sensor circuit cylinder 10 engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature sensor circuit cylinder 10 RETURN (sensor return 1) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 725 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 725 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 725 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 10 sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit cylinder 10 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1533 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 725 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 725 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 10 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 10 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 10 connector or engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 10.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active?
YES NO

Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 10 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 10 SIGNAL pin in the ECM 60-pin connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check the appropriate circuit response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 inactive?
YES NO

Repair

NOTE: The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jul-2012


FAULT CODE 726 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fault codes. | Fault Code 726 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 12 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 12 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 726 active?
 | STEP 2C. Check for a pin-to-pin short circuit in exhaust gas temperature sensor circuit cylinder 12. | Greater than 100k ohms?
 | STEP 2D. Check for short circuit to ground in the exhaust gas temperature sensor circuit cylinder 12. | Greater than 100k ohms?
 | STEP 2E. Check for short circuit to ground in exhaust gas temperature sensor circuit cylinder 12. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for open circuit in engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 726 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 12 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 12 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 12 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harnesses or damaged exhaust gas temperature sensor circuit cylinder 12.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 12.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 12 SIGNAL pin and the exhaust gas temperature sensor circuit cylinder 12 RETURN (sensor return 1) pin of the exhaust gas temperature sensor circuit cylinder 12 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 12.

Replace the damaged exhaust gas temperature sensor circuit cylinder 12.

Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 12.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 12 RETURN (sensor return 1) pin of the exhaust gas temperature sensor circuit cylinder 12 connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 12 RETURN (sensor return 1) wire.

Replace the damaged exhaust gas temperature sensor.

Refer to Procedure 019-013 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 12.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 12 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 12 connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 12 SIGNAL wire.

Replace the damaged exhaust gas temperature sensor circuit cylinder 12.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the e engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 12 SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 12 SIGNAL wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 12 RETURN (sensor return 1) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 12 RETURN (sensor return 1) pin in the exhaust gas temperature sensor circuit cylinder 12 engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature sensor circuit cylinder 12 RETURN (sensor return 1) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 726 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 726 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 726 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 12 sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit cylinder 12 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1534 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 726 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Less than 10 ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 726 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 12 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 12 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 12 connector or engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harnesses or damaged exhaust gas temperature sensor circuit cylinder 12.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 12 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 active?
YES NO

Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature. Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 12 SIGNAL pin in the ECM 60-pin connector and all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 12 SIGNAL pin in the ECM 60-pin connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 inactive?
YES NO

Repair

The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jul-2012


FAULT CODE 727 (QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fualt codes. | Fault Code 727 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 14 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 14 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 727 active?
 | STEP 2C. Check for a pin-to-pin short circuit in exhaust gas temperature sensor circuit cylinder 14. | Greater than 100k ohms?
 | STEP 2D. Check for short circuit to ground in the exhaust gas temperature sensor circuit cylinder 14. | Greater than 100k ohms?
 | STEP 2E. Check for short circuit to ground in exhaust gas temperature sensor circuit cylinder 14. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for open circuit in engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 727 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 14 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 14 connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 14 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harnesses or damaged exhaust gas temperature sensor circuit cylinder 14.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 14.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 14 SIGNAL pin and the exhaust gas temperature sensor circuit cylinder 14 RETURN (sensor return 3) pin of the exhaust gas temperature sensor circuit cylinder 14 connector.

Use a wiring diagram for connector pin identification and the following proceure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor circuit cylinder 14.

Replace the damaged exhaust gas temperature sensor circuit cylinder 14.

Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 14.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 14 RETURN (sensor return 1) pin of the exhaust gas temperature sensor circuit cylinder 14 connector to engine block ground.

Use a wiring diagram for connector pin identification and the following proceure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 14 RETURN (sensor return 1) wire.

Replace the damaged exhaust gas temperature sensor circuit cylinder 14.

Refer to Procedure 019-013 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 14.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 14 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 14 connector to engine block ground.

Use a wiring diagram for connector pin identification and the following proceure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 14 SIGNAL wire.

Replace the damaged exhaust gas temperature sensor circuit cylinder 14.

Refer to Procedure 019-013 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the e engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 connector in the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 14 SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following proceure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 14 SIGNAL wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 14 RETURN (sensor return 1) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 14 RETURN (sensor return 1) pin in the exhaust gas temperature sensor circuit cylinder 14 engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following proceure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature sensor circuit cylinder 14 RETURN (sensor return 1) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 727 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 727 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 727 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 14 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 14 sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1535 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 727 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Less than 10 ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 727 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 14 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 14 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 14 connector or engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 14.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 14 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 active?
YES NO

Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 14 SIGNAL pin in the ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 14 SIGNAL pin in the ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine and idle with engine speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate circuit response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 inactive?
YES NO

Repair

NOTE: The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jul-2012


FAULT CODE 728 (QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for intermittent fualt codes. | Fault Code 728 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 16 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 16 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 728 active?
 | STEP 2C. Check for a pin-to-pin short circuit in exhaust gas temperature sensor circuit cylinder 16. | Greater than 100k ohms?
 | STEP 2D. Check for short circuit to ground in the exhaust gas temperature sensor circuit cylinder 16. | Greater than 100k ohms?
 | STEP 2E. Check for short circuit to ground in exhaust gas temperature sensor circuit cylinder 16. | Greater than 100k ohms?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for open circuit in engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for active fault codes. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 728 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for intermittent fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 16 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 16 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 connector from the engine harness connector.

Action

Inpect the engine harness connector and exhaust gas temperature sensor circuit 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 16 connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harnesses or damaged exhaust gas temperature sensor circuit cylinder 16.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas temperature sensor circuit cylinder 16.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 16 SIGNAL pin and the exhaust gas temperature sensor circuit cylinder 16 RETURN (sensor return 3) pin of the exhaust gas temperature sensor circuit cylinder 16 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the exhaust gas temperature sensor.

Replace the damaged exhaust gas temperature sensor circuit cylinder 16.

Refer to Procedure 019-013 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 16.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 16 RETURN (sensor return 1) pin of the exhaust gas temperature sensor circuit cylinder 16 connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 16 RETURN (sensor return 1) wire.

Replace the damaged exhaust gas temperature circuit cylinder 16.

Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the exhaust gas temperature sensor circuit cylinder 16.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 connector from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 16 SIGNAL pin of the exhaust gas temperature sensor circuit cylinder 16 connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 16 SIGNAL wire.

Replace the damaged exhaust gas temperature sensor circuit cylinder 16.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the e engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 connector in the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 16 SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the exhaust gas temperature sensor circuit cylinder 16 SIGNAL wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 16 RETURN (sensor return 1) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature sensor circuit cylinder 16 RETURN (sensor return 1) pin in the exhaust gas temperature sensor circuit cylinder 16 engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature sensor circuit cylinder 16 RETURN (sensor return 1) wire in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Return to the troubleshooting steps. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 728 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 728 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 728 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 16 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 16 sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1535 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 728 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 728 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 16 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 16 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 16 connector or engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 16.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 16 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 active?
YES NO

Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 16 SIGNAL pin in the ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 16 SIGNAL pin in the ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine and idle with engine speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate circuit response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 inactive?
YES NO

Repair

NOTE: The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jul-2012


FAULT CODE 731 - Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the tone wheels and engine crankshaft speed/position and engine camshaft speed/position sensors. |
 | STEP 1A. Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage. | Any damage?
 | STEP 1B. Inspect the tone wheels for any damage. | Any damage?
STEP 2. | Check for correct engine static timing. |
 | STEP 2A. Check static timing. | Are the camshaft and crankshaft gears properly installed?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | Are all grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 731 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Inspect the tone wheels and engine crankshaft speed/position and engine camshaft speed/position sensors.

Guided Step 1A - Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for damage.

Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage.

Any damage?
YES NO

Repair

Replace the engine crankshaft speed/position or engine camshaft speed/position sensors.

  • Refer to Procedure 019-363 in Section 19.
No Repair

Go to 4A

Go to 1B

Guided Step 1B - Inspect the tone wheels for any defects.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for defects.

Inspect the camshaft gear and the crankshaft tone wheel for defects.

Any defects?
YES NO

Repair

Replace the camshaft gear or inspect the engine speed/position sensor.

  • Refer to Procedure 019-363 in Section 19.
  • For QSK45 and QSK60 engines, use the following procedure to replace the camshaft gear in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 001-012 in Section 1.
  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to replace the camshaft gear in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Refer to Procedure 001-012 in Section 1.
No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check for correct engine static timing.

Guided Step 2A - Check static timing.

Conditions

  • Remove the gear cover

Action

Check the timing.

Rotate the engine to top dead center for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned.

  • For QSK45 and QSK60 engines, use the following procedure to replace the camshaft gear in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 001-019 in Section 1.
  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to replace the camshaft gear in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Refer to Procedure 001-019 in Section 1.
  • Inspect the engine static timing.

Are the camshaft and crankshaft gears properly installed?
YES NO
No Repair

Repair

Install the camshaft and crankshaft gears correctly.

  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to install the camshaft gear in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Refer to Procedure 001-008 in Section 1
  • For K38, K50, QSK38, and QSK50 engines, use the following procedure to install the crankshaft gear in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Refer to Procedure 001-019 in Section 1.
  • For QSK45 and QSK60 engines, use the following procedure to install the camshaft gear in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 001-008 in Section 1.
  • For QSK45 and QSK60 engines, use the following procedure to install the crankshaft gear in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 001-019 in Section 1.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

Are all grounds present, properly grounded, free of corrosion, and tight?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 731 is inactive.

Fault Code 731 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 783 - Intake Manifold 1 Temperature - Abnormal Rate of Change

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 1 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 783 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 1 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 1 temperature sensor reading on the INSITE™ service tool monitor screen to the reading from the temperature probe.

NOTE: If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Repair

A damaged intake manifold 1 temperature sensor has been detected.

Replace the intake manifold 1 temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Reference the Intake Manifold Air Temperature is High (Rapid Rise) troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 783 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1117 (Source Address 00) - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gasses. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824811 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery 1 voltage. | Battery 1 voltage acceptable in normal and cranking conditions?
 | STEP 1C. Check the resistance of the OEM power harness and engine harness. | Less than 10 ohms?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness and engine harness. |
 | STEP 3A. Inspect the 4-pin power connector and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuits. | Voltage between 10.0 and 15.0-VDC?
 | STEP 3C. Check battery supply for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the add-on or accessory wiring at the positive (+) battery terminal. | Damaged wires?
 | STEP 3E. Check the ignition (keyswitch) input-to-ECM wire. | Ignition (keyswitch) input wire uninterrupted?
 | STEP 3F. Check the ignition (keyswitch) input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

  • Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery 1 voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery 1 voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.

Normal conditions:

  • At least 12-VDC (+12 volt systems).
  • At least 24-VDC (+24 volt systems).

During Cranking:

  • At least 6.2-VDC (+12 volt systems).
  • At least 12-VDC (+24 volt systems).

Battery 1 voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Repair

Charge or replace the battery.

  • Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the resistance of the OEM power harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power connector from the ECM connector.
  • Disconnect the positive terminal connector from the battery connector.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the battery 1 voltage (ECM 3) pin in the ECM connector and the positive (+) battery connector.
  • Measure the resistance between the battery 1 voltage (ECM 3) RETURN pin in the ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 10-ampere fuse to see if it has blown.

Fuse blown?
YES NO

Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the 4-pin power connector and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power connector from the ECM connector.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power harness connector from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage between the battery 1 voltage (ECM 3) pin in the 4-pin power connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 10.0 and 15.0-VDC (12 volt system) or 21 and 27-VDC (24 volt system)?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check battery supply for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power harness connector from the ECM connector.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from battery 1 voltage (ECM 3) pin in the 4-pin power connector to all other pins in the connector.
  • Measure the resistance from battery 1 voltage RETURN (ECM 3) pin in the 4-pin power connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the add-on or accessory wiring at the positive (+) battery terminal.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) battery terminal.

  • Starting at the positive (+) battery terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the ignition input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the ignition (keyswitch) input-to-ECM wire.

Inspect the ignition wire from the ignition input post in the ignition assembly to the ECM to make sure there are no interruptions in the wire, orno solenoids or relays.

Ignition wire uninterrupted?
YES NO
No Repair

Repair

Correct the wiring so the wire is uninterrupted.

Go to 4A

Go to 3F

Guided Step 3F - Check the ignition input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the ignition input circuit.

  • Measure the resistance from the ignition post in the ignition assembly to ignition input SUPPLY pin of the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jul-2012


FAULT CODE 1117 (Source Address 01) - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gasses. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824811 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery 1 voltage. | Battery 1 voltage acceptable in normal and cranking conditions?
 | STEP 1C. Check the resistance of the OEM power harness and engine harness. | Less than 10 ohms?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness and engine harness. |
 | STEP 3A. Inspect the 4-pin power connector and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuits. | 10.0 to 15.0-VDC?
 | STEP 3C. Check battery supply for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check the add-on or accessory wiring at the positive (+) battery terminal. | Damaged wires?
 | STEP 3E. Check the ignition input-to-ECM wire. | Ignition input wire uninterrupted?
 | STEP 3F. Check the ignition input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

  • Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery 1 voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery 1 voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.

Normal conditions:

  • At least 12-VDC (+12 volt systems).
  • At least 24-VDC (+24 volt systems).

During Cranking:

  • At least 6.2-VDC (+12 volt systems).
  • At least 12-VDC (+24 volt systems).

Battery 1 voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Repair

Charge or replace the battery.

  • Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the resistance of the OEM power harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power connector from the ECM connector.
  • Disconnect the positive terminal connector from the battery connector.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the battery 1 voltage (ECM 2) pin in the ECM connector and the positive (+) battery connector.
  • Measure the resistance between the battery 1 voltage RETURN (ECM 2) pin in the ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 10-ampere fuse to see if it has blown.

Fuse blown?
YES NO

Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the 4-pin power connector and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power connector from the ECM connector.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power harness connector from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage between the battery 1 voltage (ECM 2) pin in the 4-pin power connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 10.0 and 15.0-VDC (12 volt system) or 21 and 27-VDC (24 volt system)?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check battery supply for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power harness connector from the ECM connector.
  • Disconnect the battery leads.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from battery 1 voltage (ECM 2) pin in the 4-pin power connector to all other pins in the connector.
  • Measure the resistance from battery 1 voltage RETURN (ECM 2) pin in the 4-pin power connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the add-on or accessory wiring at the positive (+) battery terminal.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) battery terminal.

  • Starting at the positive (+) battery terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the ignition input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the ignition (keyswitch) input-to-ECM wire.

Inspect the ignition wire from the ignition input post in the ignition assembly to the ECM to make sure there are no interruptions in the wire,or no solenoids or relays.

Ignition wire uninterrupted?
YES NO
No Repair

Repair

Correct the wiring so the wire is uninterrupted.

Go to 4A

Go to 3F

Guided Step 3F - Check the ignition input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the ignition input circuit.

  • Measure the resistance from the ignition post in the ignition assembly to ignition input SUPPLY pin of the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jul-2012


FAULT CODE 1117 (Source Address 144) - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gasses. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824811 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery 1 voltage. | Battery 1 voltage acceptable in normal and cranking conditions?
 | STEP 1C. Check the resistance of the OEM power harness and engine harness. | Less than 10 ohms?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness and engine harness. |
 | STEP 3A. Inspect the 4-pin power connector and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuits. | Voltage between 10.0 and 15.0-VDC?
 | STEP 3C. Check battery supply for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check the add-on or accessory wiring at the positive (+) battery terminal. | Damaged wires?
 | STEP 3E. Check the ignition input-to-ECM wire. | Ignition input wire uninterrupted?
 | STEP 3F. Check the ignition input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain the revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

  • Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery 1 voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery 1 voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.

Normal conditions:

  • At least 12-VDC (+12 volt systems).
  • At least 24-VDC (+24 volt systems).

During Cranking:

  • At least 6.2-VDC (+12 volt systems).
  • At least 12 VDC (+24 volt systems).

Battery 1 voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Repair

Charge or replace the battery.

  • Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the resistance of the OEM power harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power connector from the ECM connector.
  • Disconnect the positive terminal connector from the battery connector.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the battery 1 voltage (ECM 1) pin in the ECM connector and the positive (+) battery connector.
  • Measure the resistance between the battery 1 voltage RETURN (ECM 1) pin in the ECM connector and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 10-ampere fuse to see if it has blown.

Fuse blown?
YES NO

Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the 4-pin power connector and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power connector from the ECM connector.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power harness connector from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage between the battery 1 voltage (ECM 1) pin in the 4-pin power connector and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 10.0 and 15.0-VDC (12 volt system) or 21 and 27-VDC (24 volt system)?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check battery supply for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power harness connector from the ECM connector.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from battery 1 voltage (ECM 1) pin in the 4-pin power connector to all other pins in the connector.
  • Measure the resistance from battery 1 voltage RETURN (ECM 1) pin in the 4-pin power connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the add-on or accessory wiring at the positive (+) battery terminal.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) battery terminal.

  • Starting at the positive (+) battery terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the ignition input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the ignition (keyswitch) input-to-ECM wire.

Inspect the ignition wire from the ignition input post in the ignition assembly to the ECM to make sure there are no interruptions in the wire, or no solenoids or relays.

Ignition wire uninterrupted?
YES NO
No Repair

Repair

Correct the wiring so the wire is uninterrupted.

Go to 4A

Go to 3F

Guided Step 3F - Check the ignition input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the ignition input circuit.

  • Measure the resistance from the ignition post in the ignition assembly to ignition input SUPPLY pin of the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jul-2012


FAULT CODE 1256 (Source Address 00) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1256 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address?
YES NO
No Repair

Repair

The ECM has the wrong calibration.

Download the correct calibration on the ECM.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the control module identification pins on the engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 2 and 3 pins and the control module identification RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the engine harness.

Replace the damaged section of the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 2 and 3 and RETURN pins and all other pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the engine harness.

Replace the damaged section of the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1256 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1256 (Source Address 01) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1256 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address?
YES NO
No Repair

Repair

The ECM has the wrong calibration.

Download the correct calibration on the ECM.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the control module identification pins on the engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine oil rifle pressure 1 sensor harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine oil rifle pressure 1 sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-066 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 1 and 3 pins and the control module identification RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 1 and 3 and RETURN pins and all other pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the engine harness.

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1256 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1256 (Source Address 144) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1256 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address?
YES NO
No Repair

Repair

The ECM has the wrong calibration.

Download the correct calibration on the ECM.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the control module identification pins on the engine harness-to-ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine oil rifle pressure 1 sensor harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine oil rifle pressure 1 sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-066 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 1 and 2 pins and the control module identification RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the engine harness.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 1 and 2 and RETURN pins and all other pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the engine harness.

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1256 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1257 (Source Address 00) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1257 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1257 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1257 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed in the ECM.

Does the calibration correspond with the ECM source address?
YES NO
No Repair

Repair

The ECM has the wrong calibration.

Download the correct calibration in the ECM.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the control module identification pins on the engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 2 and 3 pins and the control module identification RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open control module identification circuit has been detected in the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 2 and 3 and return pins and all other pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A pin-to-pin short circuit control module identification has been detected in the engine harness.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1257 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1257 (Source Address 01) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1257 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1257 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1257 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed in the ECM.

Does the calibration correspond with the ECM source address?
YES NO
No Repair

Repair

The ECM has the wrong calibration.

Download the correct calibration in the ECM.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the control module identification pins on the engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or ECM connector.

Clean the connector and pins.

Replace the damaged section of harness or the damaged engine oil rifle pressure 1 sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 1 and 3 pins and the control module identification RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedur for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open control module identification circuit has been detected in the engine harness.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 1 and 3 and RETURN pins and all other pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A pin-to-pin short circuit on the control module identification circuit has been detected in the engine harness.

Replace the damaged section of the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1257 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1257 (Source Address 144) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1257 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1257 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1257 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed in the ECM.

Does the calibration correspond with the ECM source address?
YES NO
No Repair

Repair

The ECM has the wrong calibration.

Download the correct calibration in the ECM.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the control module identification pins on the engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the engine harness connector or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the engine harness ECM connector control module identification input 1 and 2 pins and the control module identification RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open control module identification circuit has been detected in the engine harness.

Replace the damaged section of the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine harness ECM connector control module identification input 1 and 2 and RETURN pins and all other pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following proceudre for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A pin-to-pin short circuit on the control module identification has been detected in the engine harness.

Replace the damaged section of the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1257 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1357 - Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check all fault codes. |
 | STEP 1A. Check for fault code 1357. | Active or inactive counts of Fault Code 1357?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1357 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check all the fault codes.

Guided Step 1A - Check for fault code 1357.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1357?
YES NO

Repair

Fill engine oil level remote reservoir to appropriate level.

 No Repair

Appropriate troubleshooting symptom tree

Repair Complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1357 is inactive.

Fault Code 1357 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1358 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for accelerator pedal or lever position sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1358 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1359 active and Fault Code 1358 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1358 is active?
STEP 3. | Check the engine harness and OEM harness. |
 | STEP 3A. Inspect engine harness and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the OEM harness. |
 | STEP 3A-2. Check for a pin-to-pin short circuit in the OEM harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 1358 inactive?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4A-1. Check for an open circuit in the engine harness. |
 | STEP 4A-2. Check for a pin-to-pin short circuit in the engine harness. |
 | STEP 4B. Check for an inactive fault code. | Fault Code 1358 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1358 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for accelerator pedal or lever position sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for accelerator pedal or lever position sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Fault Code 2185

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Inspect the accelerator pedal or lever position sensor and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the accelerator pedal or lever position sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Use the following procedure for the OEM wiring harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the accelerator pedal or lever position sensor. Refer to Procedure 019-085 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the accelerator pedal or lever position sensor.

  • Measure the voltage from the accelerator pedal or lever position sensor 5 volt SUPPLY (sensor supply 4) pin to the accelerator pedal or lever position RETURN (sensor return 4) pin at the accelerator pedal or lever position sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 active and Fault Code 1358 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever position sensor connector to the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 is active?
YES NO

Repair

A damaged accelerator pedal has been detected. Contact the appropriate OEM or dealership for repair instructions.

  • Replace the accelerator pedal. Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness and OEM harness.

Guided Step 3A - Inspect the engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin connector.

Action

Inspect the OEM harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged OEM harness or replace damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Use the following procedure for the OEM wiring harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness connector to engine harness connector accelerator pedal or lever position RETURN (sensor return 4) pin and the OEM harness accelerator pedal or lever position RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open accelerator pedal or lever position RETURN (sensor return 4) circuit has been detected in the OEM harness.

Refer to the OEM service manual for repair instructions.

  • Refer to Procedure 019-071 in Section 19.

Go to 3A-2

Go to 5A

Guided Step 3A-2 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness 31-pin connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin in the OEM harness connector to engine harness connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the OEM harness.

Refer to the OEM service manual for repair instructions.

  • Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A-1

Guided Step 4A-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the OEM harness connector from the engine harness 31-pin connector.

Action

Check for an open circuit

  • Measure the resistance between the engine harness ECM connector accelerator pedal or lever position RETURN (sensor return 4) pin and the engine harness accelerator pedal or lever position RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open accelerator pedal or lever position RETURN (sensor return 4) circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the OEM harness connector from the engine harness 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected on the accelerator pedal or lever position SIGNAL wire of the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1358 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1359 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1359 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1358 active and Fault Code 1359 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1359 active?
STEP 3. | Check the engine harness and OEM harness. |
 | STEP 3A. Inspect the engine harness and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the OEM harness |
 | STEP 3A-2. Check for an open circuit in the OEM harness. |
 | STEP 3A-3. Check for a pin-to-pin short circuit in the OEM harness. |
 | STEP 3A-4. Check for a pin-to-ground short circuit in the OEM harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 1359 inactive?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4A-1. Check for an open circuit in the engine harness. |
 | STEP 4A-2. Check for an open circuit in the engine harness. |
 | STEP 4A-3. Check for a pin-to-pin short circuit in the engine harness. |
 | STEP 4A-4. Check for a pin-to-ground short circuit in the OEM engine harness. |
 | STEP 4B. Check for an inactive fault code. | Fault Code 1359 inactive?
STEP 5. | Clear the fault codes |
 | STEP 5A. Disable the fault code. | Fault Code 1359 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for accelerator pedal or lever position sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Fault Code 2186

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Inspect the OEM harness and accelerator pedal or lever position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the accelerator pedal or lever position sensor or harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Use the following procedure for the OEM wiring harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the accelerator pedal or lever. Refer to Procedure 019-085 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the accelerator pedal or lever position sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin to the accelerator pedal or lever position RETURN (sensor return 4) pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin and the accelerator pedal or lever position sensor SIGNAL pin at the accelerator pedal or lever position sensor connector of the OEM harness.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1358 active and Fault Code 1359 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever position sensor connector to the OEM harness connector.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 active?
YES NO

Repair

A damaged accelerator pedal has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal.

Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness and OEM harness.

Guided Step 3A - Inspect the engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin connector.

Action

Inspect the OEM harness and engine harness connector pins for fhe following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged OEM harness or replace the damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the accelerator pedal or lever. Refer to Procedure 019-085 in Section 19.
No Repair

Go to 5A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness to engine harness connector accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin and the OEM harness accelerator pedal or lever position SUPPLY (sensor supply 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedeure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open accelerator pedal or lever position SUPPLY (sensor supply 4) circuit has been detected in the OEM harness.

Refer to the OEM service manual for repair instructions.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-2

Go to 5A

Guided Step 3A-2 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness to engine harness connector accelerator pedal or lever position SIGNAL pin and the OEM harness accelerator pedal or lever position SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedeure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open accelerator pedal or lever position SIGNAL circuit has been detected in the OEM harness.

Refer to the OEM service manual for repair instructions.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-3

Go to 5A

Guided Step 3A-3 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin in the OEM harness to engine harness connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedeure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the accelerator pedal or lever position SIGNAL wire has been detected in the OEM harness.

Refer to the OEM service manual for repair instructions.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-4

Go to 5A

Guided Step 3A-4 - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the OEM harness to engine harness connector accelerator pedal or lever position SIGNAL pin to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedeure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the accelerator pedal or lever position SIGNAL wire has been detected in the OEM harness.

Refer to the OEM service manual for repair instructions.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A-1

Guided Step 4A-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the 31-pin OEM connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector accelerator pedal or lever position SUPPLY (sensor supply 4) pin and the engine harness accelerator pedal or lever position SUPPLY (sensor supply 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedeure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open accelerator pedal or lever position SUPPLY (sensor supply 4) circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the 31-pin connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector accelerator pedal or lever position SIGNAL pin and the engine harness accelerator pedal or lever position SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedeure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open accelerator pedal or lever position SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the 31-pin OEM connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedeure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected on the accelerator pedal or lever position SIGNAL wire of the engine harness.

Troubleshoot each section of engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A-4

Go to 5A

Guided Step 4A-4 - Check for a pin-to-ground short circuit in the OEM engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the 31-pin OEM connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedeure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the accelerator pedal or lever position SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the harness to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1359 is inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1361- Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1361 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1595 active and Fault Code 1361 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM harness and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness or engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1361 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for remote accelerator pedal or lever position sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1361 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Inspect the OEM and remote accelerator pedal or lever position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged remote accelerator pedal or lever position sensor.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin on the OEM harness sensor connector to the remote accelerator pedal or lever position RETURN (sensor return 1) pin on the OEM harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin and the remote accelerator pedal or lever position SIGNAL pin at the remote accelerator pedal or lever position sensor OEM harness connector.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1595 active and Fault Code 1361 inactive?
YES NO

Repair

Replace the remote accelerator pedal or lever position sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM harness and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for an open circuit in the OEM harness or engine harness.

  • Measure the resistance from the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin in the ECM engine harness connector to the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin in the remote accelerator pedal or lever position sensor connector.
  • Measure the resistance from the remote accelerator pedal or lever position SIGNAL pin in the ECM engine harness connector to the remote accelerator pedal or lever position SIGNAL pin in the remote accelerator pedal or lever position sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short circuit in the OEM harness or engine harness.

  • Measure the resistance and check for a short circuit from the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin in the ECM engine harness connector to all other pins in the connector.
  • Measure the resistance from the remote accelerator pedal or lever position SIGNAL pin in the ECM engine harness connector to all the other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Replace the engine harness.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector .
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Disconnect the tachograph (if equipped).

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit from the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin in the ECM engine harness connector to engine block ground.
  • Measure the resistance and check for a short circuit from the remote accelerator pedal or lever position SIGNAL pin in the ECM engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for the OEM harness. Refer to Procedure Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1361 is inactive.

Fault Code 1361 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1362 - Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active or inactive fault codes. |
 | STEP 1A. Check for Fault Code 1362. | Active or inactive counts of Fault Code 1362?
 | STEP 1B. Check for multiple fault codes. | Active or inactive counts of Fault Codes 143, 415, 556, 1367, 1368, 1377, and 1378?
STEP 2. | Check the lubricating oil filters. |
 | STEP 2A. Replace the lubricating oil filters. | Oil filters contaminated?
 | STEP 2B. Check for Fault Code 1362. | Active or inactive counts of Fault Code 1362?
STEP 3. | Check the lubricating oil pressure sensors. |
 | STEP 3A. Check the pre- and post- filter lubricating oil pressure sensors. | Pressure sensor found to be faulty?
 | STEP 3B. Check for Fault Code 1362. | Active or inactive counts of Fault Code 1362?
STEP 4. | Check the fault codes. |
 | STEP 4A. Disable the fault code. | Fault code inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for active or inactive fault codes.

Guided Step 1A - Check for Fault Code 1362.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1362?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete.

Guided Step 1B - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

Active or inactive counts of Fault Codes 143, 415, 556, 1367, 1368, 1377, and 1378?
YES NO

Repair

Troubleshoot all above fault codes. See relevant fault code tree.

Use INSITE™ electronic service tool to clear the inactive fault codes.

 No Repair

Go to 1A

Go to 2A

Guided Step 2 - Check the lubricating oil filters.

Guided Step 2A - Replace the lubricating oil filters.

Conditions

  • Not applicable.

Action

Remove and replace lubricating oil filters.

  • Use the procedure in the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 007-013 in Section 7.

Cut open the lubricating oil filters and identify any debris or oil contamination. Check the lubricating oil condition as per Cummins® Engine Oil and Oil Analysis Recommendations, Bulletin 3810340.

Oil filters contaminated?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check for Fault Code 1362.

Conditions

  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1362?
YES | NO
No Repair | No Repair

Go to 3A

Repair complete.

Guided Step 3 - Check the lubricating oil pressure sensors.

Guided Step 3A - Check the pre- and post- filter lubricating oil pressure sensors.

Conditions

  • Not applicable.

Action

Check operation and range of pre- and post- filter lubricating oil pressure sensors.

  • Refer to Procedure 019-126 in Section 19.
  • Refer to Procedure 019-447 in Section 19.

Pressure sensor found faulty?
YES NO

Repair

Replace pressure sensor.

 No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for Fault Code 1362.

Conditions

  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1362?
YES | NO
No Repair | No Repair

Go to 4A

Repair complete.

Guided Step 4 - Check the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 10-Mar-2015


FAULT CODE 1367 - Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1367 inactive?
STEP 2. | Check the pre-oil filter pressure sensor and circuit. |
 | STEP 2A. Inspect the pre-oil filter pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1368 active and Fault code 1367 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1367 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM Response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1367 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for pre-oil filter pressure sensor supply fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1367 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the pre-oil filter pressure sensor and circuit.

Guided Step 2A - Inspect the pre-oil filter pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and pre-oil filter pressure sensor connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector or shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the pre-oil filter pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged pre-oil filter pressure sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-126 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active and Fault Code 1367 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin to the pre-oil filter pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the pre-oil filter pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active?
YES NO

Repair

A damaged pre-oil filter pressure sensor has been detected.

Replace the pre-oil filter pressure sensor.

  • Refer to Procedure 019-126 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropraite circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active and Fault Code 1367 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the pre-oil filter pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin to the pre-oil filter pressure RETURN (sensor return 2) pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open pre-oil filter pressure RETURN (sensor supply 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1367 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1368 - Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for inactive fault code. | Fault Code 1368 inactive?
STEP 2. | Check the pre-oil filter pressure sensor and circuit. |
 | STEP 2A. Inspect the pre-oil filter pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1367 active and Fault Code 1368 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1368 active?
STEP 3. | Check the ECM and engine harness |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1368 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the pre-oil filter pressure sensor and circuit.

Guided Step 2A - Inspect the pre-oil filter pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and pre-oil filter pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the pre-oil filter pressure sensor harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged pre-oil filter pressure sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-126 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin to the pre-oil filter pressure RETURN (sensor return 2) pin at the pre-oil filter pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the pre-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin and the pre-oil filter pressure SIGNAL pin at the pre-oil filter pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active and Fault Code 1368 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the pre-oil filter pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active?
YES NO

Repair

A damaged pre-oil filter pressure sensor has been detected.

Replace the pre-oil filter pressure sensor.

  • Refer to Procedure 019-126 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pn connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin to the pre-oil filter pressure RETURN (sensor return 2) pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted pre-oil filter pressure SUPPLY (sensor supply 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short or open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the pre-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin and the pre-oil filter pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active and Fault Code 1368 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the pre-oil filter pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or pin to pin short.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1368 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 25-Jul-2012


FAULT CODE 1369 - Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1369 inactive?
STEP 2. | Check the OEM auxiliary temperature sensor input 1 and circuit. |
 | STEP 2A. Inspect the OEM auxiliary temperature sensor input 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Does sensor resistance meet the manufacturer's specifications?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness or engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness or engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1369 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1369 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1369 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM auxiliary temperature sensor input 1 and circuit.

Guided Step 2A - Inspect the OEM auxiliary temperature sensor input 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM auxiliary temperature sensor input 1 and connector pins.

Action

Inspect the OEM harness and OEM auxiliary temperature sensor input 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins.
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the auxiliary temperature sensor input 1 or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM auxiliary temperature sensor input 1 connector from the OEM harness connector.

Action

Check the auxiliary temperature sensor input 1 resistance.

  • Measure the resistance between the auxiliary temperature sensor SIGNAL pin and auxiliary sensor input 1 RETURN (sensor return 1) pin at the OEM auxiliary temperature sensor input 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Does sensor resistance meet the manufacturer's specifications?

Refer to the OEM service manual.
YES NO
No Repair

Repair

Replace the OEM auxiliary temperature sensor.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector pins if possible.
  • Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the OEM auxiliary temperature sensor input 1 connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector OEM auxiliary sensor input 1 RETURN (sensor return 1) pin and OEM harness connector OEM auxiliary temperature input 1 RETURN (sensor return 1) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open auxiliary sensor input 1 RETURN (sensor return 1) circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit. Repair or replace the harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the OEM auxiliary temperature sensor input 1 connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector OEM auxiliary temperature sensor input 1 SIGNAL pin and the OEM harness connector auxiliary temperature sensor input 1 SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open auxiliary temperature sensor input 1 SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the OEM auxiliary temperature sensor input 1 connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM auxiliary temperature sensor input 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the auxiliary temperature sensor input 1 SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted circuit.

Repair or replace the harnesses.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1369 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool, to verify that the fault code is inactive.

Fault Code 1369 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 26-Jul-2012


FAULT CODE 1373 - Start Enable Device 1 Circuit (Ether Injection) - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1373 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit to the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Less than 10 ohms?
STEP 3. | Check the supply voltage at the ECM |
 | STEP 3A. Check the supply voltage at the ECM. | Greater than 22-VDC?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1373 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 1373 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness

Guided Step 2A - Inspect the engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 60-pin connector.
  • Disconnect the engine harness from the 23-pin OEM connector.

Action

Inspect the OEM harness and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or OEM harness connector or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness or the ECM.

Check all harnesses connected in series.

Refer to Procedure 019-071 in Section 19.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit to the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 60-pin connector.
  • Disconnect the engine harness from the 23-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM 60-pin connector start enable device 1 circuit (ether injection) driver SIGNAL pin and the OEM harness connector ether injection start enable device 1 circuit (ether injection) driver SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open start enable device 1 circuit (ether injection) driver SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 60-pin connector.
  • Disconnect the engine harness from the 23-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the start enable device 1 circuit (ether injection) driver SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the start enable device 1 circuit (ether injection) driver SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 60-pin connector.
  • Disconnect the engine harness from the 23-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the start enable device 1 circuit (ether injection) driver SIGNAL pin in the engine harness ECM 60-pin connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground on the start enable device 1 circuit (ether injection) driver SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains a short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the supply voltage at the ECM

Guided Step 3A - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch ON.
  • Ether injection system enabled.
  • Coolant temperature below the ECM calibrated threshold.
  • Disconnect the engine harness from the ECM 60-pin connector.

Action

Check the supply voltage at the ECM.

  • Measure the supply voltage from the start enable device 1 circuit (ether injection) driver SIGNAL pin in the ECM engine connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 22-VDC?
YES NO

Repair

A damaged ether injection solenoid or damaged OEM harness has been detected.

Refer to the OEM service manual.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1373 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


FAULT CODE 1376 - Engine Camshaft Speed/Position Sensor - Data erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1376 active?
STEP 2. | Check the engine camshaft speed/position sensor and circuit. |
 | STEP 2A. Inspect the engine camshaft speed/position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Engine camshaft speed/ position sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the engine camshaft speed/position sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate engine camshaft speed/position sensor air gap. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor Engine Speed Backup Sensor State equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 4. | Check camshaft gear. |
 | STEP 4A. Inspect the camshaft gear. | Camshaft gear targets missing, damaged, and/or out of position?
 | STEP 4B. Inspect the sensor air gap. | Is the air gap within specification?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1376 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 or 227 active?
YES | NO
No Repair | No Repair

Fault Code 187 or 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 1376 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine camshaft speed/position sensor and circuit.

Guided Step 2A - Inspect the engine camshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.

Action

Inspect the engine harness and engine camshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged engine camshaft speed/position sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-363 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Measure the voltage at the engine camshaft speed/position sensor connector.

  • Measure the voltage between the engine camshaft speed/position 5 volt SUPPLY (sensor supply 2) pin and the engine camshaft speed/position RETURN (sensor return 2) pin at the engine camshaft speed/position sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool Monitor Mode to read the camshaft position sensor state.

Engine camshaft speed/position sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the engine camshaft speed/position 5 volt SUPPLY (sensor supply 2) pin and the engine camshaft speed/position SIGNAL pin at the engine camshaft speed/position sensor connector of the engine harness.
  • Use INSITE™ electronic service tool Monitor Mode to read the camshaft position sensor state.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Engine camshaft speed/position sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the engine camshaft speed/position sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine camshaft speed/position sensor from the engine.
  • Refer to Procedure 019-363 in Section 19.

Action

Inspect the engine camshaft speed/position sensor.

  • Damaged sensor tip
  • Physical signs of the camshaft speed/position sensor touching the speed teeth.

Damaged sensor tip?
YES NO

Repair

Replace the engine camshaft speed/position sensor.

  • Refer to Procedure 019-363 in Section 19.
No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine camshaft speed/position sensor from the engine.
  • Refer to Procedure 019-363 in Section 19.
  • Make sure the engine camshaft speed/position sensor is connected to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine camshaft speed/position sensor.

  • Use the ratchet drive side of the socket tool that was used to remove the engine camshaft speed/position sensor from the engine, placing it flush on the engine camshaft speed/position sensor so that the edge of the socket is on the edge of the engine camshaft speed/position sensor. Slowly slide the socket in a perpendicular direction to the line marked on the engine camshaft speed/position sensor or in a perpendicular direction to the mounting bracket of the engine camshaft speed/position sensor.
  • Check for the appropriate ECM response.
  • Use INSITE™ electronic service tool Monitor Mode to read the Engine Speed Backup Sensor State.

Engine Speed Backup Sensor State transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Repair

Replace the engine camshaft speed/position sensor.

Refer to Procedure 019-363 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate engine camshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Install the engine camshaft speed/position sensor to the engine and connect it to the harness.
  • Refer to Procedure 019-363 in Section 19.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Momentarily engage the starter, but do not start the engine. Repeat this as many times as necessary.

Action

Monitor the camshaft position sensor state of the engine camshaft speed/position sensor for the following:

  • Change of state from high to low or low to high, or the state shows triggered.

Engine Speed Backup Sensor State transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Repair

Inspect the camshaft gear teeth for damage or spinning.

For QSK45 and QSK60 engines, use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 001-012 in Section 1.

For K38, K50, QSK38, and QSK50 engines, use the following procedure in Service Manual, K38, K50, QSK38, and QSK50, Bulletin 4021528. Refer to Procedure 001-012 in Section 1.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool Monitor Mode to read the engine camshaft speed/position sensor state.

Monitor Engine Speed Backup Sensor State equals low?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the engine camshaft speed/position 5 volt SUPPLY (sensor supply 2) pin and the engine camshaft speed/position SIGNAL pin at the ECM port.
  • Read the engine camshaft speed/position sensor state using the INSITE™ electronic service tool monitor mode.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Monitor Engine Speed Backup Sensor State equals high?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the damaged section.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the ECM sensor supply voltage and return circuit.

  • Measure the voltage between the engine camshaft speed/position 5 volt SUPPLY (sensor supply 2) pin and the engine camshaft speed/position RETURN (sensor return 2) pin at the ECM engine harness port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO

Repair

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check the camshaft gear.

Guided Step 4A - Inspect the camshaft gear.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.

Action

Check the camshaft gear targets.

QSK38 and QSK50 Engines:

  • Check that the camshaft gear position indicator pin is not missing or damaged.
  • Measure the flushness of the pin to the gear surface. Use the Measure section in the following procedure in the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 001-012 in Section 1.
  • NOTE: This is a critical step for the QSK38 and QSK50 engine. The position of the pin in the camshaft gear is important to proper sensor operation.

QSK60 Engines:

  • Check the targets on the camshaft gear.

Camshaft gear targets missing, damaged, and/or out of position?
YES NO
No Repair

Repair

Replace the camshaft gear. Use the following procedure in the Service Manual QSK45 and QSK60 Engines, Bulletin 4021530.

  • Refer to Procedure 001-012 in Section 1.

Use the following procedure in the Service Manual K38, K50 and QSK50 Series Engines, Bulletin 4021528.

  • Refer to Procedure 001-012 in Section 1.

Go to 4B

Go to 5A

Guided Step 4B - Inspect the sensor air gap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap and target wheel.

  • Remove the engine camshaft speed/position sensor from the gear housing and measure the air gap at several points in the crankshaft's revolution.
  • Use the Measure section of the Camshaft Position Sensor procedure. Refer to Procedure 019-363 in Section 19.

Is the air gap within specifications?

Refer to Procedure 019-363 in Section 19.

YES NO
No Repair

Repair

Replace or shim the engine camshaft speed/position sensor if the air gap is out of specification.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1376 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to 1A

Last Modified: 26-Jul-2012


FAULT CODE 1377 - Post-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1377 inactive?
STEP 2. | Check the post-oil filter pressure sensor and circuit |
 | STEP 2A. Inspect the post-oil filter pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1378 active and Fault Code 1377 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.52-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1377 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1377 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1377 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the post-oil filter pressure sensor and circuit.

Guided Step 2A - Inspect the post-oil filter pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-oil filter pressure sensor connector from the engine harness connector.

Action

Check for an inactive fault code

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the post-oil filter pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-447 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-oil filter pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1378 active and Fault Code 1377 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-oil filter pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the post-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin to the post-oil filter pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the post-oil filter pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1377 active?
YES NO

Repair

A damaged post-oil filter pressure sensor has been detected.

Replace the post-oil filter pressure sensor.

Refer to Procedure 019-447 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1378 active and Fault Code 1377 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1377 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the post-oil filter pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the post-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin to the post-oil filter pressure RETURN (sensor return 2) pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1377 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open post-oil pressure RETURN (sensor return 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1377 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


FAULT CODE 1378 - Post-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1378 inactive?
STEP 2. | Check the post-oil filter pressure sensor and circuit |
 | STEP 2A. Inspect the post-oil filter pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1377 active and Fault Code 1378 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1378 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1378 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Reference Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1378 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the post-oil filter pressure sensor and circuit.

Guided Step 2A - Inspect the post-oil filter pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-oil filter pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and post-oil filter pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the post-oil filter pressure sensor harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged post-oil filter pressure sensor.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-447 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-oil filter pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from the post-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin to the post-oil filter pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-oil filter pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the post-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin and the post-oil filter pressure SIGNAL pin at the post-oil filter pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1377 active and Fault Code 1378 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the post-oil filter pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1378 active?
YES NO

Repair

A damaged post-oil filter pressure sensor has been detected.

Replace the post-oil filter pressure sensor.

Refer to Procedure 019-447 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the post-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin to the post-oil filter pressure RETURN (sensor return 2) pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1378 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted post-oil filter pressure supply (sensor supply 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short or open circuit.

Replace the damaged section of engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the post-oil filter pressure 5 volt SUPPLY (sensor supply 2) pin and the post-oil filter pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1377 active and Fault Code 1378 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1378 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the post-oil filter pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or pin-to-pin short.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1378 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 26-Jul-2012


FAULT CODE 1381 - Auxiliary Temperature Sensor Input 1 - Special Instructions

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 1369 and 1596 are inactive?
STEP 2. | Check the OEM temperature sensor. |
 | STEP 2A. Check the OEM temperature sensor, use INSITE™ electronic service tool. | Sensor reading (INSITE™ electronic service tool reading) equals actual temperature?
 | STEP 2B. Check the OEM temperature thresholds, use INSITE™ electronic service tool. | Sensor readings are not greater or less than the OEM temperature thresholds?
 | STEP 2C. Inspect the OEM temperature sensor and the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check the resistance of the OEM temperature sensor. | Sensor resistance within OEM specifications?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1381 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 1369 and 1596 are inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM temperature sensor.

Guided Step 2A - Use INSITE™ electronic service tool to check the OEM temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the OEM temperature.

  • Use a thermocouple or similar temperature probe to verify the actual temperature.
  • Refer to the OEM service manual.
  • Use INSITE™ electronic service tool to check the temperature.

Sensor reading (INSITE™ electronic service tool reading) equals actual temperature?
YES NO
No Repair

Repair

Replace the OEM temperature sensor.

Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Use INSITE™ electronic service tool to check the OEM temperature thresholds.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the OEM temperature thresholds.

  • Refer to the OEM service manual.
  • Use INSITE™ electronic service tool to check the temperature thresholds.

Sensor readings are not greater or less than the OEM temperature thresholds?

YES NO
No Repair

Repair

Replace the OEM temperature sensor.

Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the OEM temperature sensor and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM temperature sensor connector.

Action

Check the OEM temperature sensor and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the OEM harness or sensor connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-071 in Section 19.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the resistance of the OEM temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM temperature sensor connector.

Action

Check the resistance of the OEM temperature sensor.

Refer to the OEM service manual.

Sensor resistance within OEM specifications?
YES NO
No Repair

Repair

Replace the OEM temperature sensor.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1381 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Refer to the appropriate troubleshooting steps.

Last Modified: 26-Jul-2012


FAULT CODE 1383 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1383 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1384 active and Fault Code 1383 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1383 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1383 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 1 pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged intake manifold 1 pressure sensor.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Refer to Procedure 019-043 in Section19.

Refer to Procedure 019-061 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1384 active and Fault Code 1383 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the intake manifold 1 pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1383 active?
YES NO

Repair

A damaged intake manifold pressure 1 sensor has been detected.

Replace the intake manifold 1 pressure sensor.

Refer to Procedure 019-061 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1384 active and Fault Code 1383 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the intake manifold 1 pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open intake manifold 1 pressure RETURN (sensor return 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring harness for all engine harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1383 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 26-Jul-2012


FAULT CODE 1384 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1384 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1383 active and Fault Code 1384 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness control pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1384 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 inactive?
YES | NO
No Repair | No Repair

Use the following procedue for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 1 pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged intake manifold 1 pressure sensor.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-061 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the intake manifold 1 pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-361 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold 1 pressure SIGNAL pin at the intake manifold 1 pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 active and Fault Code 1384 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 active?
YES NO

Repair

A damaged intake manifold 1 pressure sensor has been detected.

Replace the intake manifold 1 pressure sensor.

Refer to Procedure 019-061 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A open or shorted intake manifold 1 pressure SUPPLY (sensor supply 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold 1 pressure SIGNAL pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1383 active and Fault Code 1384 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1384 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the intake manifold 1 pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or pin-to-pin short.

Refer to the circuit diagram or wiring harness for all engine harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1384 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Refer to the appropriate troubleshooting steps.

Last Modified: 26-Jul-2012


FAULT CODE 1385 - Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1385 inactive?
STEP 2. | Check the intake manifold 2 pressure sensor and circuit |
 | STEP 2A. Inspect the intake manifold 2 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1386 active and Fault Code 1385 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault code 1385 active?
STEP 3. | Check the ECM and engine harness |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply and voltage return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1385 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 2 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 2 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 2 pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged intake manifold 2 pressure sensor.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Refer to Procedure 019-043 in Section19.

Refer to Procedure 019-061 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1386 active and Fault Code 1385 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 2 pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 active?
YES NO

Repair

A damaged intake manifold 2 pressure sensor has been detected.

Replace the intake manifold 2 pressure sensor.

Refer to Procedure 019-061 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 active and Fault Code 1385 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the intake manifold 2 pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the failed section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 2 pressure RETURN (sensor return 2) pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open intake manifold 2 pressure RETURN (sensor return 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring harness for all engine harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1385 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 26-Jul-2012


FAULT CODE 1386 - Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1386 inactive?
STEP 2. | Check the intake manifold 2 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1385 active and Fault Code 1386 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1386 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness control pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1386 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Reference Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 2 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and intake manifold 2 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold 2 pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged intake manifold 2 pressure sensor.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-061 in Section19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 2 pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold 2 pressure SIGNAL pin at the intake manifold 2 pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 active and Fault Code 1386 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 active?
YES NO

Repair

A damaged intake manifold 2 pressure sensor has been detected.

Replace the intake manifold 2 pressure sensor.

Refer to Procedure 019-061 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 2 pressure RETURN (sensor return 2) pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit reaponse after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1386 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A open or shorted SUPPLY circuit has been detected in the engine harness.

Troubleshoot all harness connected in series to determine which contains the open or short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 2 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold 2 pressure SIGNAL pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1385 active and Fault Code 1386 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the fault codes.

Fault Code 1386 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the intake manifold 2 pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or pin-to-pin short.

Refer to the circuit diagram or wiring harness for all engine harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1386 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Refer to the appropriate troubleshooting steps.

Last Modified: 26-Jul-2012


FAULT CODE 1411 - Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1411 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault codes. | Fault Code 1411 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1411 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the OEM harness from the engine harness.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, OEM harness, or the ECM.

Check all harnesses connected in series.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open optional gain adjust potentiometer RETURN (sensor return 4) circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness from the 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A damaged generator drive harness or potentiometer has occurred. Refer to the OEM service manual.

Repair

A pin-to-pin short circuit on the optional gain adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1411 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 26-Jul-2012


FAULT CODE 1412 - Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1412 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault codes. | Fault Code 1412 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the OEM harness from the engine harness.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the followingh Procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness, or the ECM.

Check all harnesses connected in series.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open optional gain adjust potentiometer RETURN (sensor return 4) circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness from the 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the optional gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A damaged generator drive harness or potentiometer is detected. Refer to the OEM service manual for repair instructions.

Repair

A pin-to-pin short circuit on the droop adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1412 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 26-Jul-2012


FAULT CODE 1418 - Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1418 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault codes. | Fault Code 1418 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1418 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the OEM harness from the engine harness.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or OEM harness connector or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness or the ECM.

Check all harnesses connected in series.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open optional gain adjust potentiometer RETURN (sensor return 4) circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Secion 19.

Greater than 100k ohms?
YES NO

Repair

A damaged generator drive harness or potentiometer is detected. Refer to the OEM service manual for repair instructions.

Repair

A pin-to-pin short circuit on the gain adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1418 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 26-Jul-2012


FAULT CODE 1427 - Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1427 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1427 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1427 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the OEM harness connector from the engine harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector, OEM harness connector or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, OEM harness, or the ECM.

Check all harnesses connected in series.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector overspeed shutdown SIGNAL pin and the OEM harness connector overspeed shutdown SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open overspeed shutdown SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the overspeed shutdown SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

No repair

Repair

A pin-to-pin short circuit on the overspeed shutdown SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin to short ground

  • Measure the resistance and check for a short circuit between the overspeed shutdown SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A damaged generator drive harness or lamp has been detected. Refer to the OEM service manual.

Repair

A short circuit to ground has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1427 inactive?
YES NO

Repair

No repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


FAULT CODE 1428 - Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1428 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1428 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1428 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector, OEM harness connecto,r or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness, or the ECM.

Check all harnesses connected in series.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector low oil pressure (LOP) shutdown SIGNAL pin and the OEM harness connector low oil pressure (LOP) shutdown SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open low oil pressure (LOP) shutdown SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the low oil pressure (LOP) shutdown SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

No repair

Repair

A pin-to-pin short circuit on the low oil pressure (LOP) shutdown SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for a pin to short ground

  • Measure the resistance and check for a short circuit between the low oil pressure (LOP) shutdown SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19..

Greater than 100k ohms?
YES NO

Repair

A damaged generator drive harness or lamp has been detected. Refer to the OEM service manual.

Repair

A short circuit to ground has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1428 inactive?
YES NO

Repair

No repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


FAULT CODE 1429 - High Engine Temperature (HET) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1429 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1429 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1429 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness, or the ECM.

Check all harnesses connected in series.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector high engine temperature shutdown SIGNAL pin and the OEM harness connector high engine temperature (HET) shutdown SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin indentification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open high engine temperature shutdown SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the HET shutdown SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin indentification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

No repair

Repair

A pin-to-pin short circuit on the HET shutdown SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance and check for a short circuit between the HET shutdown SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A damaged generator drive harness or lamp has been detected. Refer to OEM service manual.

Repair

A pin-to-ground short has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1429 inactive?
YES NO

Repair

No repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


FAULT CODE 1431 - Pre-Low Oil Pressure Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1431 inactive?
STEP 2. | Check the engine harness and OEM harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1431 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness or the ECM.

Check all harnesses connected in series.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector pre-low oil pressure warning SIGNAL pin and the OEM harness connector pre-low oil pressure warning SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open pre-low oil pressure warning SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the pre-low oil pressure warning SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

No repair

Repair

A pin-to-pin short circuit on the pre-low pressure warning SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance and check for a short circuit between the pre-low oil pressure warning SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A damaged generator drive harness or lamp has been detected. Refer to the OEM service manual.

Repair

A pin-to-ground short has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1431 inactive?
YES NO

Repair

No repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


FAULT CODE 1432 - Pre-High Engine Temperature Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1432 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1432 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1432 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness or the ECM.

Check all harnesses connected in series.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector pre-high engine temperature warning SIGNAL pin and the OEM harness connector pre-high engine temperature warning SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open pre-high engine temperature warning SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the pre-high engine temperature warning SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the pre-high engine temperature warning SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance and check for a short circuit between the pre-high engine temperature warning SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A damaged generator drive harness or lamp has been detected. Refer to the OEM service manual.

Repair

A pin-to-ground short circuit has been detected in the engine harness.

Troubleshoot each section of the harness to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1432 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


FAULT CODE 1514 - Accelerator Pedal or Lever Position Sensor 1 Circuit Frequency - Abnormal Frequency, Pulse Width, or Period

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 10 ohms?
 | STEP 1C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check the OEM devices for frequency signal supply. | Correct frequency signal?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 1514 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1514 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the OEM harness or engine harness connector.

Clean the connector and pins.

Replace the damaged sections or harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from the accelerator pedal or lever position SIGNAL pin on the OEM harness 31-pin connector to the accelerator pedal or lever position SIGNAL pin on the accelerator pedal or lever position sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.
  • Connect the accelerator pedal or lever position sensor to the OEM harness connector.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the accelerator pedal or lever position SIGNAL pin on the 31-pin connector OEM harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.
  • Connect the accelerator pedal or lever position sensor to the OEM harness connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the accelerator pedal or lever position SIGNAL pin on the OEM harness 31-pin connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the engine harness or ECM connector.

Clean the connector and pins.

Replace the damaged sections of harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the accelerator pedal or lever position SIGNAL pin on the engine harness ECM connector to the accelerator pedal or lever position SIGNAL pin on the 31-pin connector of the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness 31-pin connector.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the accelerator pedal or lever position SIGNAL pin on the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of harness.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness 31-pin connector.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the accelerator pedal or lever position SIGNAL pin on the engine harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check the OEM devices for frequency signal supply.

Conditions

  • Turn keyswitch ON.

Action

Check the frequency signal of the OEM device(s).

  • Refer to the OEM service manual.

Correct frequency signal?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the OEM device.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1514 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1514 is inactive.

Fault code 1514 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 10-Mar-2015


FAULT CODE 1517 - At Least One Module Has A Most Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for fault codes |
 | STEP 1A. Check the ECM for fault codes. | Fault Code 1517 and other fault codes active?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code. | Fault Code 1517 inactive?
 | STEP 2B. Clear the fault code. | All fault codes cleared?

Guided Step 1 - Check the ECM for fault codes

Guided Step 1A - Check the ECM for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1517 and other fault codes active?
YES NO

Repair

Go to corresponding fault code troubleshooting steps

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1517 inactive?
YES NO

Repair

No repair.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


FAULT CODE 1518 - At Least One Module Has A Moderately Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for fault codes |
 | STEP 1A. Check the ECM for fault codes. | Fault Code 1518 and other fault codes active?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code. | Fault Code 1518 inactive?
 | STEP 2B. Clear the fault code. | All fault codes cleared?

Guided Step 1 - Check the ECM for fault codes.

Guided Step 1A - Check the ECM for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1518 and other fault codes active?
YES NO

Repair

Go to corresponding appropriate fault code troubleshooting steps

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1518 inactive?
YES NO

Repair

No repair.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


FAULT CODE 1519 - At Least One Module Has a Least Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for fault codes |
 | STEP 1A. Check ECM for fault codes. | Fault Code 1519 and other fault codes active?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code. | Fault Code 1519 inactive?
 | STEP 2B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM for fault codes

Guided Step 1A - Check ECM for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1519 and other fault codes active?
YES NO

Repair

Reference the corresponding appropriate fault code troubleshooting steps

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1519 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if alls steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


FAULT CODE 1521 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ tesl lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1521 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 3 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 3 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 672 active and Fault Code 1521 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Code 1521 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1521 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 3 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 3 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 3 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged exhaust gas temperature sensor circuit cylinder 3.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 active and Fault Code 1521 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 3 from the engine harness.
  • Turn keyswitch ON

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 3, 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 3 RETURN (sensor return 3) pin at the exhaust gas temperature sensor circuit cylinder 3 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 3 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 3.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 and Fault Code 1521 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B-1

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 3, 5 volt SUPPLY (sensor supply 3) pin to exhaust gas temperature circuit cylinder 3 RETURN (sensor return 3) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1521 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


Fault Code 1521 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead Part Number 3824812 - female Deutsch™ test leak Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1521 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 3 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 3 and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 672 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1521 active?
STEP 3. | Inspect the ECM and check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open RETURN circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open SIGNAL circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1521 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1521 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 3 and circuit.

Guided Step 2A - Check the exhaust gas temperature sensor cylinder 3 circuit and connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 3 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 3 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 3 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 3 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 3 connector from the engine harness.
  • Place a jumper wire between the exhaust gas temperature sensor 3 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading the fault codes, switch OFF the engine.
  • Remove the jumper wire between the exhaust gas temperature sensor 3 SIGNAL and RETURN pin at the sensor connector of the engine harness.

Fault Code 672 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Keyswitch OFF.
  • Connect the exhaust gas temperature sensor 3 to the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness, if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open RETURN circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 3 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 3 RETURN pin in the engine harness ECM 60 pin connector and the exhaust gas temperature sensor cylinder 3 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open SIGNAL circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 3 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 3 SIGNAL pin in the ECM 60 pin connector and the exhaust gas temperature sensor cylinder 3 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 3 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness ECM 60 pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Check if an ECM calibration update is available.

Go to 4A

Go to 3F

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1521 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-May-2014


FAULT CODE 1522 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ tesl lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1522 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 5 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 5 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 673 active and Fault Code 1522 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Codes 1522 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1522 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 5 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 5 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 5 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 5 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 5 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged exhaust gas temperature sensor circuit cylinder 5.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 5 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 673 active and Fault Code 1522 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 5 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 5, 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 5 RETURN (sensor return 3) pin at the exhaust gas temperature sensor circuit cylinder 5 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 5 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 5.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 and Fault Code 1522 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B-1

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 5, 5 volt SUPPLY (sensor supply 3) pin to exhaust gas temperature circuit cylinder 5 RETURN (sensor return 3) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Jul-2012


Fautl Code 1522 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead Part Number 3824812 - female Deutsch™ test leak Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1522 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 5 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 5 and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 673 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1522 active?
STEP 3. | Inspect the ECM and check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open RETURN circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open SIGNAL circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1522 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1522 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 5 and circuit.

Guided Step 2A - Check the exhaust gas temperature sensor cylinder 5 circuit and connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 5 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 5 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 5 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 5 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 5 connector from the engine harness.
  • Place a jumper wire between the exhaust gas temperature sensor 5 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading the fault codes, switch OFF the engine.
  • Remove the jumper wire between the exhaust gas temperature sensor 5 SIGNAL and RETURN pin at the sensor connector of the engine harness.

Fault Code 673 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Keyswitch OFF.
  • Connect the exhaust gas temperature sensor 5 to the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness, if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open RETURN circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 5 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 5 RETURN pin in the engine harness ECM 60 pin connector and the exhaust gas temperature sensor cylinder 5 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open SIGNAL circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 5 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 5 SIGNAL pin in the ECM 60 pin connector and the exhaust gas temperature sensor cylinder 5 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 5 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 5 SIGNAL pin in the engine harness ECM 60 pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Check if an ECM calibration update is available.

Go to 4A

Go to 3F

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-May-2014


FAULT CODE 1523 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1523 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 7 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 5 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 673 active and Fault Code 1523 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 ti 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Codes 1523 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1523 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 7 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 7 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 7 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 7 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged exhaust gas temperature sensor circuit cylinder 7.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 active and Fault Code 1523 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 7 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 7 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 7 RETURN (sensor return 3) pin at the exhaust gas temperature sensor circuit cylinder 7 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 7 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 7.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 and Fault Code 1523 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 7, 5 volt SUPPLY (sensor supply 3) pin to exhaust gas temperature circuit cylinder 7 RETURN (sensor return 3) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1523 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Jul-2012


Fautl Code 1523 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead Part Number 3824812 - female Deutsch™ test leak Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1523 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 7 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 7 and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 674 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1523 active?
STEP 3. | Inspect the ECM and check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open RETURN circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open SIGNAL circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1523 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1523 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 7 and circuit.

Guided Step 2A - Check the exhaust gas temperature sensor cylinder 7 circuit and connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 7 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 7 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 7 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 7 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 7 connector from the engine harness.
  • Place a jumper wire between the exhaust gas temperature sensor 7 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading the fault codes, switch OFF the engine.
  • Remove the jumper wire between the exhaust gas temperature sensor 7 SIGNAL and RETURN pin at the sensor connector of the engine harness.

Fault Code 674 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Keyswitch OFF.
  • Connect the exhaust gas temperature sensor 7 to the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness, if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open RETURN circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 7 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 5 RETURN pin in the engine harness ECM 60 pin connector and the exhaust gas temperature sensor cylinder 7 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open SIGNAL circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 7 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 7 SIGNAL pin in the ECM 60 pin connector and the exhaust gas temperature sensor cylinder 7 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 7 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 7 SIGNAL pin in the engine harness ECM 60 pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Check if an ECM calibration update is available.

Go to 4A

Go to 3F

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1523 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-May-2014


FAULT CODE 1524 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead and Part Number 3824812 - female Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1524 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 9 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 9 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 675 active and Fault Code 1524 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Codes 1524 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1524 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 9 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 9 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 9 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged exhaust gas temperature sensor circuit cylinder 9.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 active and Fault Code 1524 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 9 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 9 5 volt SUPPLY (sensor supply 4) pin to the exhaust gas temperature circuit cylinder 9 RETURN (sensor return 4) pin at the exhaust gas temperature sensor circuit cylinder 9 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 9 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 9.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 and Fault Code 1524 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B-1

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 9, 5 volt SUPPLY (sensor supply 4) pin to exhaust gas temperature circuit cylinder 9 RETURN (sensor return 4) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1524 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Jul-2012


Fault Code 1524 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead Part Number 3824812 - female Deutsch™ test leak Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1524 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 9 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 9 and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 675 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1524 active?
STEP 3. | Inspect the ECM and check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open RETURN circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open SIGNAL circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1524 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1524 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 9 and circuit.

Guided Step 2A - Check the exhaust gas temperature sensor cylinder 9 circuit and connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 9 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 9 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 9 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 9 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 9 connector from the engine harness.
  • Place a jumper wire between the exhaust gas temperature sensor 9 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading the fault codes, switch OFF the engine.
  • Remove the jumper wire between the exhaust gas temperature sensor 9 SIGNAL and RETURN pin at the sensor connector of the engine harness.

Fault Code 675 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Keyswitch OFF.
  • Connect the exhaust gas temperature sensor 9 to the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness, if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open RETURN circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 9 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 9 RETURN pin in the engine harness ECM 60 pin connector and the exhaust gas temperature sensor cylinder 9 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open SIGNAL circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 9 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 9 SIGNAL pin in the ECM 60 pin connector and the exhaust gas temperature sensor cylinder 9 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 9 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 9 SIGNAL pin in the engine harness ECM 60 pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Check if an ECM calibration update is available.

Go to 4A

Go to 3F

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1524 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-May-2014


FAULT CODE 1525 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1525 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 11 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 11 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 676 active and Fault Code 1525 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Codes 1525 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1525 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 11 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 11 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 11 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged exhaust gas temperature sensor circuit cylinder 11.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 active and Fault Code 1525 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 11 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 11, 5 volt SUPPLY (sensor supply 4) pin to the exhaust gas temperature circuit cylinder 11 RETURN (sensor return 4) pin at the exhaust gas temperature sensor circuit cylinder 11 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 11 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 11.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 and Fault Code 1525 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B-1

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 11, 5 volt SUPPLY (sensor supply 4) pin to exhaust gas temperature circuit cylinder 11 RETURN (sensor return 4) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1525 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Aug-2012


Fault Code 1525 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead Part Number 3824812 - female Deutsch™ test leak Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1525 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 11 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 11 and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 676 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1525 active?
STEP 3. | Inspect the ECM and check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open RETURN circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open SIGNAL circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1525 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1525 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 11 and circuit.

Guided Step 2A - Check the exhaust gas temperature sensor cylinder 11 circuit and connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 11 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 11 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 11 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 11 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 11 connector from the engine harness.
  • Place a jumper wire between the exhaust gas temperature sensor 11 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading the fault codes, switch OFF the engine.
  • Remove the jumper wire between the exhaust gas temperature sensor 11 SIGNAL and RETURN pin at the sensor connector of the engine harness.

Fault Code 676 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Keyswitch OFF.
  • Connect the exhaust gas temperature sensor 11 to the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness, if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open RETURN circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 11 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 11 RETURN pin in the engine harness ECM 60 pin connector and the exhaust gas temperature sensor cylinder 11 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open SIGNAL circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 11 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 11 SIGNAL pin in the ECM 60 pin connector and the exhaust gas temperature sensor cylinder 11 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 11 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 11 SIGNAL pin in the engine harness ECM 60 pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Check if an ECM calibration update is available.

Go to 4A

Go to 3F

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1525 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-May-2014


FAULT CODE 1526 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 13 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy. | Is the temperature measurement from the infrared thermometer with 15 percent of the exhaust gas temperature circuit cylinder 13 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2126 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy, with an infrared thermometer.

  • Start engine
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 13 reading on the service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the gas temperature sensor circuit cylinder 13 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 13 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 13.

Refer to Procedure 019-013 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2126 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 27-Jul-2012


Fault Code 1526 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead Part Number 3824812 - female Deutsch™ test leak Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1526 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 13 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 13 and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 677 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1526 active?
STEP 3. | Inspect the ECM and check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open RETURN circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open SIGNAL circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1526 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1526 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 13 and circuit.

Guided Step 2A - Check the exhaust gas temperature sensor cylinder 13 circuit and connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 13 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 13 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 13 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 13 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 13 connector from the engine harness.
  • Place a jumper wire between the exhaust gas temperature sensor 13 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading the fault codes, switch OFF the engine.
  • Remove the jumper wire between the exhaust gas temperature sensor 13 SIGNAL and RETURN pin at the sensor connector of the engine harness.

Fault Code 677 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Keyswitch OFF.
  • Connect the exhaust gas temperature sensor 13 to the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness, if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open RETURN circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 13 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 13 RETURN pin in the engine harness ECM 60 pin connector and the exhaust gas temperature sensor cylinder 13 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open SIGNAL circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 13 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 13 SIGNAL pin in the ECM 60 pin connector and the exhaust gas temperature sensor cylinder 13 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 13 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 SIGNAL pin in the engine harness ECM 60 pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Check if an ECM calibration update is available.

Go to 4A

Go to 3F

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1526 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-May-2014


FAULT CODE 1527 (QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1527 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 15 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 15 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 678 active and Fault Code 1527 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Code 1527 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1527 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 15 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 15 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 15 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 15 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 15.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 active and Fault Code 1527 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 15 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 15 5 volt SUPPLY (sensor supply 4) pin to the exhaust gas temperature circuit cylinder 15 RETURN (sensor return 4) pin at the exhaust gas temperature sensor circuit cylinder 15 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 15 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 15.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19..

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 active and Fault Code 1527 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 15 5 volt SUPPLY (sensor supply 4) pin to the exhaust gas temperature circuit cylinder 15 RETURN (sensor return 4) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1527 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Jul-2012


Fault Code 1527 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead Part Number 3824812 - female Deutsch™ test leak Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1527 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 15 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 15 and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 678 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1527 active?
STEP 3. | Inspect the ECM and check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open RETURN circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open SIGNAL circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1527 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1527 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 15 and circuit.

Guided Step 2A - Check the exhaust gas temperature sensor cylinder 15 circuit and connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 15 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 15 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 15 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 15 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 15 connector from the engine harness.
  • Place a jumper wire between the exhaust gas temperature sensor 15 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading the fault codes, switch OFF the engine.
  • Remove the jumper wire between the exhaust gas temperature sensor 15 SIGNAL and RETURN pin at the sensor connector of the engine harness.

Fault Code 678 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Keyswitch OFF.
  • Connect the exhaust gas temperature sensor 15 to the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness, if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open RETURN circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 15 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 15 RETURN pin in the engine harness ECM 60 pin connector and the exhaust gas temperature sensor cylinder 15 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open SIGNAL circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 15 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 15 SIGNAL pin in the ECM 60 pin connector and the exhaust gas temperature sensor cylinder 15 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 15 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 15 SIGNAL pin in the engine harness ECM 60 pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Check if an ECM calibration update is available.

Go to 4A

Go to 3F

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1527 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-May-2014


FAULT CODE 1529 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1529 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 2 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 2 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 721 active and Fault Code 1529 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Code 1529 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1529 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 2 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 2 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 2.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 active and Fault Code 1529 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 2 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 2 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 2 RETURN (sensor return 3) pin at the exhaust gas temperature sensor circuit cylinder 2 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general mulitmeter usage techniques. Refer to Procedure 019-361 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 2 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 active?

YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 2.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 active and Fault Code 1529 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 2 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 2 RETURN (sensor return 3) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general mulitmeter usage techniques. Refer to Procedure 019-361 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1529 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Jul-2012


Fault Code 1529 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead Part Number 3824812 - female Deutsch™ test leak Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1529 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 2 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 2 and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 721 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1529 active?
STEP 3. | Inspect the ECM and check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open RETURN circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open SIGNAL circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1529 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1529 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 2 and circuit.

Guided Step 2A - Check the exhaust gas temperature sensor cylinder 2 circuit and connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 2 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 2 connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 2 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 2 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 2 connector from the engine harness.
  • Place a jumper wire between the exhaust gas temperature sensor 2 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading the fault codes, switch OFF the engine.
  • Remove the jumper wire between the exhaust gas temperature sensor 15 SIGNAL and RETURN pin at the sensor connector of the engine harness.

Fault Code 721 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Keyswitch OFF.
  • Connect the exhaust gas temperature sensor 2 to the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness, if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open RETURN circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 2 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 2 RETURN pin in the engine harness ECM 60 pin connector and the exhaust gas temperature sensor cylinder 2 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open SIGNAL circuit in the engine wiring harness.

Conditions

  • Keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 2 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 2 SIGNAL pin in the ECM 60 pin connector and the exhaust gas temperature sensor cylinder 2 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 2 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 2 SIGNAL pin in the engine harness ECM 60 pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Check if an ECM calibration update is available.

Go to 4A

Go to 3F

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1529 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-May-2014


FAULT CODE 1531 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1531 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 6 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 6 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 723 active and Fault Code 1531 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Code 1531 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1531 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 6 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 6 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 6 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 6.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 active and Fault Code 1531 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 6 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 6 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 6 RETURN (sensor return 3) pin at the exhaust gas temperature sensor circuit cylinder 6 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-361 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 6 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 active?

YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 6.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 active and Fault Code 1531 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 6 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 6 RETURN (sensor return 3) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-361 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1531 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Jul-2012


FAULT CODE 1531 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1531 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 6 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 6 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 723 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1531 active?
STEP 3. | Inspect the ECM and check engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1531 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1531 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 6 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor cylinder 6 circuit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 6 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 6 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor cylinder 6, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 6 connector from the engine harness.
  • Place a jumper between the exhaust gas temperature sensor 6 SIGNAL pin and the RETURN pin at the sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading fault codes switch the engine off.
  • Remove a jumper wire between the exhaust gas temperature sensor 6 SIGNAL pin and RETURN pin at the sensor connector of the engine harness.

Fault Code 723 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 6 to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 active?
YES NO

Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and check engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the harness, if repair is not possible.

Check all harnesses connected in series.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 6 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 6 RETURN pin in the engine harness ECM 60-pin connector and the exhaust gas temperature sensor cylinder 6 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 6 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 6 SIGNAL pin in the ECM 60-pin connector and the exhaust gas temperature sensor cylinder 6 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 6 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 6 SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • A pin-to-pin short circuit on the signal wire has been detected in the engine harness.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Check if an ECM calibration update is available.

Go to 3D

Go to 4A

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1531 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 20-May-2014


FAULT CODE 1532 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1532 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 8 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 8 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 724 active and Fault Code 1532 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Code 1532 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1532 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 8 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 8 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 8 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 8.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active and Fault Code 1532 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 8 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 8 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 8 RETURN (sensor return 3) pin at the exhaust gas temperature sensor circuit cylinder 8 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 8 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 active?

YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 8.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active and Fault Code 1532 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 8 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 8 RETURN (sensor return 3) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1532 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Jul-2012


FAULT CODE 1532 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1532 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 8 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 8 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 724 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1532 active?
STEP 3. | Inspect the ECM and check engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1532 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1532 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 8 and circuit.

Guided Step 2A - Check the exhaust gas temperature sensor cylinder 8 circuit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 8 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 8 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, is possible.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor cylinder 8 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 8 connector from the engine harness.
  • Place a jumper wire between the exhaust gas temperature sensor 8 SIGNAL pin and RETURN pin at the sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Remove a jumper wire between the exhaust gas temperature sensor 8 SIGNAL pin and RETURN pin at the sensor connector of the engine harness.

Fault Code 724 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 8 connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 active?
YES NO

Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and check engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, is possible.

Replace the damaged section of the harness, if repair is not possible.

Check all harnesses connected in series.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

  • Replace the ECM if ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 8 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 8 RETURN pin in the engine harness ECM 60-pin connector and the exhaust gas temperature sensor cylinder 8 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 8 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 8 SIGNAL pin in the ECM 60-pin connector and the exhaust gas temperature sensor cylinder 8 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 8 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 8 SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Check if an ECM calibration update is available.

Go to 4A

Go to 4A

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1532 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-May-2014


FAULT CODE 1533 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1533 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 10 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 10 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 725 active and Fault Code 1533 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Code 1533 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1533 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 10 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 10 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 10 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 10.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active and Fault Code 1533 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 10 5 volt SUPPLY (sensor supply 1) pin to the exhaust gas temperature circuit cylinder 10 RETURN (sensor return 1) pin at the exhaust gas temperature sensor circuit cylinder 10 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 10 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 10.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active and Fault Code 1533 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 10 5 volt SUPPLY (sensor supply 1) pin to the exhaust gas temperature circuit cylinder 10 RETURN (sensor return 1) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1533 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 29-Jul-2012


FAULT CODE 1533 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1533 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 10 sensor and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 10 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 725 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1533 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open RETURN circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open SIGNAL circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1533 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1533 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 10 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 10 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor circuit cylinder 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 10 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 10.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 connector from the engineharness and place a jumper between the SIGNAL pin and the RETURN pin at the exhaust gas temperature sensor connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and the exhaust gas temperature sensor RETURN pin at the sensor connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 10 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.

Action

Check for the appropriate response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 10 RETURN pin in the ECM 60-pin connector and the exhaust gas temperature sensor circuit cylinder 10 RETURN pin at the exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 10 temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 10 SIGNAL pin in the ECM 60-pin connector and the exhaust gas temperature sensor circuit cylinder 10 SIGNAL pin at the exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1533 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 29-Jul-2012


FAULT CODE 1534 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1534 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 12 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 12 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 726 active and Fault Code 1534 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Code 1534 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1534 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 12 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 12 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 12 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 12.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 active and Fault Code 1534 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 12 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 12 5 volt SUPPLY (sensor supply 1) pin to the exhaust gas temperature circuit cylinder 12 RETURN (sensor return 1) pin at the exhaust gas temperature sensor circuit cylinder 12 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 12 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 active?

YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 12.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 active and Fault Code 1534 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 12 5 volt SUPPLY (sensor supply 1) pin to the exhaust gas temperature circuit cylinder 12 RETURN (sensor return 1) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1534 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 29-Jul-2012


FAULT CODE 1534 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1534 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 12 and circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor cylinder 12 circuit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 726 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1534 active?
STEP 3. | Inspect the ECM and check engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1534 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1534 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 12 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor cylinder 12 circuit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 12 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 12 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 12 connector, if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 12 connector from the engine harness.
  • Place a jumper between the exhaust gas temperature sensor 12 SIGNAL pin and RETURN pin at the sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading the fault codes, turn the engine OFF.
  • Remove a jumper wire between the exhaust gas temperature sensor 12 SIGNAL and RETURN pins at the sensor connector of the engine harness.

Fault Code 726 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 12 to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and check engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness, if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open RETURN circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 12 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor circuit cylinder 12 RETURN pin in the engine harness ECM 60-pin connector and the exhaust gas temperature sensor cylinder 12 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 12 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 12 SIGNAL pin in the ECM 60-pin connector and the exhaust gas temperature sensor cylinder 12 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 12 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 12 SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the signal wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Check if an ECM calibration update is available.

Go to 3F

Go to 4A

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1534 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 21-May-2014


FAULT CODE 1535 (QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1535 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 14 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 14 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 727 active and Fault Code 1535 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Codes 1535 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1535 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 14 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 14 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 14 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 14.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 active and Fault Code 1535 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 14 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 14 5 volt SUPPLY (sensor supply 1) pin to the exhaust gas temperature circuit cylinder 14 RETURN (sensor return 1) pin at the exhaust gas temperature sensor circuit cylinder 14 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 14 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active?

YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 14.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 active and Fault Code 1535 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 14 5 volt SUPPLY (sensor supply 1) pin to the exhaust gas temperature circuit cylinder 14 RETURN (sensor return 1) pin at the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1535 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 29-Jul-2012


FAULT CODE 1535 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1535 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 14 and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor cylinder 14 circuit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 727 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1535 active?
STEP 3. | Inspect the ECM and check engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1535 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1535 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 14 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor cylinder 14 circuit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 14 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 14 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 14 connector, is repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 14 connector from the engine harness.
  • Place a jumper between the exhaust gas temperature sensor 14 SIGNAL pin and RETURN pin at the sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading the fault codes, turn the engine OFF.
  • Remove a jumper wire between the exhaust gas temperature sensor 14 SIGNAL and RETURN pins at the sensor connector of the engine harness.

Fault Code 727 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 14 to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and check engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness, if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the exhaust gas temperature sensor cylinder 14 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 14 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor cylinder 14 RETURN pin the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the exhaust gas temperature sensor cylinder 14 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 14 SIGNAL pin in the ECM connector and the exhaust gas temperature sensor cylinder 14 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 14 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 14 SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the signal wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Check if an ECM calibration update is available.

Go to 3D

Go to 4A

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1535 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 21-May-2014


FAULT CODE 1536 (QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1536 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 16 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 16 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 728 active and Fault Code 1536 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Codes 1536 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 1536 inactive?
 | STEP 4B. Disable the fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 16 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit cylinder 16 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 16 or engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor circuit cylinder 16.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 active and Fault Code 1536 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 16 5 volt SUPPLY (sensor supply 1) pin to the exhaust gas temperature circuit cylinder 16 RETURN (sensor return 1) pin at the exhaust gas temperature sensor circuit cylinder 16 connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 16 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1536 active?
YES NO

Repair

A damaged sensor has been detected.

  • Replace the exhaust gas temperature sensor circuit cylinder 16. Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Check all harnesses connected in series.
  • Replace the damaged section of harness.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 active and Fault Code 1536 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of harness.
  • Check all harnesses connected in series.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 16 5 volt SUPPLY (sensor supply 1) pin to the exhaust gas temperature circuit cylinder 16 RETURN (sensor return 1) pin at the ECM 60-pin connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1536 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to 1A

Last Modified: 29-Jul-2012


FAULT CODE 1536 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1536 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 16 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 16 and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 728 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1536 active?
STEP 3. | Inspect the ECM and check engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1536 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1536 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 16 and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor cylinder 16 circuit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 16 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 16 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 16 connector if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 16 connector from the engine harness.
  • Place a jumper between the exhaust gas temperature sensor 16 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading fault codes, switch off the engine.
  • Remove a jumper wire between the exhaust gas temperature 16 SIGNAL and RETURN pin at the sensor connector of the engine harness.

Fault Code 728 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 16 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 active?
YES NO

Repair

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and check engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 16 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 16 RETURN pin in the engine harness ECM 60-pin connector and the exhaust gas temperature sensor cylinder 16 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 16 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 16 SIGNAL pin in the ECM 60-pin connector and the exhaust gas temperature sensor cylinder 16 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 16 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 16 SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the signal wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Check if an ECM calibration update is available.

Go to 3F

Go to 4A

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1536 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Jul-2014


FAULT CODE 1542 - Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Fault Code 386 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the original equipment manufacturer (OEM) pressure sensor and circuit. |
 | STEP 2A. Inspect the OEM pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 1543 active and Fault Code 1542 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1542 is active?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 297 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code 1542 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Reference Fault Code 386.

Go to 2A

Guided Step 2 - Check the OEM pressure sensor and circuit.

Guided Step 2A - Inspect the OEM pressure sensor and connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1543 active and Fault Code 1542 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the OEM Pressure +5 volt SUPPLY pin and the OEM pressure RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1542 is active?
YES NO

Repair

A damaged sensor has been detected.

  • Replace the OEM pressure sensor.
  • Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure RETURN pin and the OEM harness OEM pressure sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the open return circuit.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SUPPLY pin in the OEM harness ECM connector and all other pins in the ECM OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted supply circuit.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SUPPLY pin in the OEM harness ECM connector and all other pins in the ECM OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1542 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 1542 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or Call for assistance

Last Modified: 13-Nov-2017


FAULT CODE 1543 - Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
STEP 2. | Check the OEM pressure sensor and circuit. |
 | STEP 2A. For Marine applications, check if a a resistive jumper is installed when a pressure sensor is not being used. | Resistive jumper installed in wiring harness extension when OEM pressure sensor is not being used?
 | STEP 2B. For Marine applications, check the resistive jumper. | Resistance within specifications across all pins?
 | STEP 2C. Inspect the OEM pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2D. Check the sensor supply voltage and return circuit. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2E. Check the circuit response. | Fault Code 297 active and Fault Code 298 inactive?
 | STEP 2F. Check the fault codes and verify sensor condition. | Fault Code 298 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 298 inactive?
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 1543 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service to tool read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference Fault Code 352.

Go to 2A

Guided Step 2 - Check the OEM pressure sensor and circuit.

Guided Step 2A - For Marine applications, check if a resistive jumper is installed when a pressure sensor is not being used.

Conditions

  • Turn keyswitch OFF.

Action

Check if an OEM pressure sensor is installed.

  • If an OEM pressure sensor is not installed, check to make sure a resistive jumper is installed in the wiring harness extension.

Resistive jumper installed in wiring harness extension when OEM pressure sensor is not being used?

YES NO
No Repair

Repair

Install the resistive jumper in the wiring harness extension.

Go to 2B

Go to 4A

Guided Step 2B - For Marine applications, check the resistive jumper.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring extension harness.

Action

Check the resistance across the pins.

  • Pin 1 to Pin 2: 1.2k Ohms
  • Pin 2 to Pin 3: 1.5k Ohms
  • Pin 1 to Pin 3: 270 Ohms

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance within specifications across all pins?
YES NO
No Repair

Repair

Replace the resistive jumper.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the OEM pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the OEM pressure +5 volt SUPPLY pin and the OEM pressure RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the OEM pressure SUPPLY pin and the OEM pressure SIGNAL pin at the OEM pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 297 active and Fault Code 298 inactive?
YES | NO
No Repair | No Repair

Go to 2F

Go to 3A

Guided Step 2F - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 is active?
YES NO

Repair

A damaged sensor has been detected.

  • Replace the OEM pressure sensor. Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure RETURN pin and the OEM harness OEM pressure sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the open return circuit.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure SIGNAL pin and the OEM harness OEM pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms
YES NO
No Repair

Repair

An open signal circuit has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the open signal circuit.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the signal wire has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1543 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 29-Jul-2012


FAULT CODE 1544 - Auxiliary Pressure Sensor Input 1 - Special Instructions

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C or 122°F before removing the pressure cap. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for Fault Code 1544. | Active or inactive counts of Fault Code 1544?
STEP 2. | Check gear oil pressure alarm/derate setting. |
 | STEP 2A. Check gear oil pressure alarm/derate setting. | Parameter set to OEM specifications?
 | STEP 2B. Check the fault codes and verify sensor condition. | Fault Code 1544 active?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for Fault Code 1544.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1544?
YES NO

Repair

The engine protection limit has been exceeded for the OEM-supplied pressure input. Refer to the OEM service manual.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the gear oil pressure alarm/derate setting.

Guided Step 2A - Check the gear oil pressure alarm/derate setting.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the gear oil pressure alarm/derate setting.

  • Use INSITE™ electronic service tool to read the parameter "OEM Auxiliary Pressure Threshold".

Parameter set to OEM specifications?
YES NO

Repair

The engine protection limit has been exceeded for the OEM-supplied pressure input. Refer to the OEM service manual for repair instructions.

Repair

Adjust the parameter to the correct OEM setting. Use INSITE™ electronic service tool to check the parameter setting.

Refer to the OEM service manual.

Go to 2B

Guided Step 2B - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Operate engine above 1000 RPM.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 3o seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: The fault code will only go inactive if the ECM sees a known good condition for a period of time (above five seconds) and with the engine running above 1000 RPM.

Fault Code 1544 active?
YES NO

Repair

The engine protection limit has been exceeded for the OEM-supplied pressure input. Refer to the OEM service manual for repair instructions.

No Repair

Refer to the OEM service manual.

Repair complete.

Last Modified: 29-Jul-2012


FAULT CODE 1548 (QSK38) - Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1548, 1552, or 1622 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1548 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector solenoid driver cylinder 7 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 1548 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 1548 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548, 1552, or 1622 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector solenoid driver cylinder 7 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly connected:

  • Engine harness connected to ECM.
  • Engine harness connected to the injector solenoid driver cylinder 7.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Replace the damaged section of the harness.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 7 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 7 SIGNAL pin and the injector solenoid driver cylinder 7 RETURN pin at the ECM 60 pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 7 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 7 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector.

  • Use the following procedure from K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 7 connector.

Action

Check for continuity in the injector solenoid driver cylinder 7.

  • Measure the resistance between the injector solenoid driver cylinder 7 SIGNAL pin and the injector solenoid driver cylinder 7 RETURN pin at the injector solenoid driver cylinder 7 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector.

  • Use the following procedure from K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 7, 9, and 11 connectors from the engine harness connectors.

Action

Inspect the engine harness and injector solenoid driver cylinder 7, 9, and 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

  • Clean the connector and pins.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector.

  • Use the following procedure from K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 7, 9, and 11 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 7 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 9 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 11 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

Use the following procedure from K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure from QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 7, 9, and 11 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins, or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s)

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector.

Use the following procedure from K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure from QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 7, 9, and 11 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 7 SIGNAL pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 9 SIGNAL and injector solenoid driver cylinder 11 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 7 RETURN pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 9 RETURN and injector solenoid driver cylinder 11 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 7, 9, and 11 connectors from the engine harness connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 7 SIGNAL pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 9 SIGNAL and injector solenoid driver cylinder 11 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 7 RETURN pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 9 RETURN and injector solenoid driver cylinder 11 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1548 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Go to 4B

Escalate or call for assistance.

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes inactive?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Jun-2019


FAULT CODE 1548 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1548, 325, or 1555 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Only Fault Code 1548 is active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector solenoid driver cylinder 7 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Only Fault Code 1548 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to clear the fault codes.

Fault Code 1548, 325, or 1555 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1548 active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector solenoid driver cylinder 7 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 7.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 7 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 7 SIGNAL pin and the injector solenoid driver cylinder 7 RETURN pin at the ECM 60 pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 7 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 7 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 7 connector.

Action

Check for continuity in the injector solenoid driver cylinder 7.

  • Measure the resistance between the injector solenoid driver cylinder 7 SIGNAL pin and the injector solenoid driver cylinder 7 RETURN pin at the injector solenoid driver cylinder 7 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to clear the fault codes.

Only Fault Code 1548 is active?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 7, 6, and 14 connectors from the engine harness connectors.

Action

Inspect the engine harness and injector solenoid driver cylinder 7, 6, and 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 7, 6, and 14 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 7 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 14 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the damaged injector(s).

Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 7, 6, and 14 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins, or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s)

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 7, 6, and 14 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 7 SIGNAL pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 6 SIGNAL and injector solenoid driver cylinder 14 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 7 RETURN pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 6 RETURN and injector solenoid driver cylinder 14 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 7, 6, and 14 connectors from the engine harness connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 7 SIGNAL pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 6 SIGNAL and injector solenoid driver cylinder 14 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 7 RETURN pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 6 RETURN and injector solenoid driver cylinder 14 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to 1A

Last Modified: 04-Jun-2019


FAULT CODE 1549 (QSK38) - Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1549, 1551, or 1553 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Only Fault Code 1549 is active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector solenoid driver cylinder 8 for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Only Fault Code 1549 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to clear the fault codes.

Fault Code 1549, 1551, or 1553 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1549 is active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 8 for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 8.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 8 SIGNAL pin and the injector solenoid driver cylinder 8 RETURN pin at the ECM 60 pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 8 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the damaged engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 8 connector.

Action

Check for continuity in the injector solenoid driver cylinder 8.

  • Measure the resistance between the injector solenoid driver cylinder 8 SIGNAL pin and the injector solenoid driver cylinder 8 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the damaged injector.

Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to clear the fault codes.

Only Fault Code 1549 is active?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 8, 10, and 12 connectors.

Action

Inspect the engine harness and injector solenoid driver cylinder 8, 10, and 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 8, 10, and 12 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 8 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 10 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 12 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver 8, 10, and 12 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 8, 10, and 12 from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 8 SIGNAL pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 10 SIGNAL and injector solenoid driver cylinder 12 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 8 RETURN pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 10 RETURN and injector solenoid driver cylinder 12 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 8, 10, and 12 connectors from the engine harness connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 8 SIGNAL pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 10 SIGNAL and injector solenoid driver cylinder 12 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 8 RETURN pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 10 RETURN and injector solenoid driver cylinder 12 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to 1A

Last Modified: 04-Jun-2019


FAULT CODE 1549 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine contril module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1557, 323, or 1549 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Only Fault Code 1549 is active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector solenoid driver cylinder 8 for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Only Fault Code 1549 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to clear the fault codes.

Fault Code 1549, 1557, or 323 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1549 is active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 8 for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 8.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 8 SIGNAL pin and the injector solenoid driver cylinder 8 RETURN pin at the ECM 60 pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 8 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 8 connector.

Action

Check for continuity in the injector solenoid driver cylinder 8.

  • Measure the resistance between the injector solenoid driver cylinder 8 SIGNAL pin and the injector solenoid driver cylinder 8 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the damaged injector.

Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual,, Bulletin 4021528.Refer to Procedure 006-026 in Section 6.

Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1549 is active?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 8, 16, and 5 connectors.

Action

Inspect the engine harness and injector solenoid driver cylinder 8, 16, and 5 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 8, 16, and 5 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 8 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 16 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver 8, 16, and 5 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 8, 16, and 5 from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 8 SIGNAL pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 16 SIGNAL and injector solenoid driver cylinder 5 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 8 RETURN pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 16 RETURN and injector solenoid driver cylinder 5 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 8, 16, and 5 connectors from the engine harness connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 8 SIGNAL pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 16 SIGNAL and injector solenoid driver cylinder 5 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 8 RETURN pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 16 RETURN and injector solenoid driver cylinder 5 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Jun-2019


FAULT CODE 1551 (QSK38) - Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1549, 1551, or 1553 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Only Fault Code 1551 is active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 10 for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Only Fault Code 1551 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1549, 1551, or 1553 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1551 is active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 10 for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 10.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 10 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 10 SIGNAL pin and the injector solenoid driver cylinder 10 RETURN pin at the ECM 60 pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 10 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 10 connector.

Action

Check for continuity in the injector solenoid driver cylinder 10.

  • Measure the resistance between the injector solenoid driver cylinder 10 SIGNAL pin and the injector solenoid driver cylinder 10 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1551 is active?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 8, 10, and 12 connectors.

Action

Inspect the engine harness and injector solenoid driver cylinder 8, 10, and 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 8, 10, and 12 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 10 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 8 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 12 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the damaged injector(s).

Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 8, 10, and 12 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 8, 10, and 12 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 10 SIGNAL pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 8 SIGNAL and injector solenoid driver cylinder 12 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 10 RETURN pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 8 RETURN and injector solenoid driver cylinder 12 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 8, 10, and 12 connectors from the engine harness connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 10 SIGNAL pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 8 SIGNAL and injector solenoid driver cylinder 12 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 10 RETURN pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 8 RETURN and injector solenoid driver cylinder 12 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Jun-2019


FAULT CODE 1551 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1551, 331, or 1552 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Only Fault Code 1551 is active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 10 for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 1551 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1551, 331, or 1552 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1551 is active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 10 for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 10.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness.Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 10 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 10 SIGNAL pin and the injector solenoid driver cylinder 10 RETURN pin at the ECM 60 pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 10 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 10 connector.

Action

Check for continuity in the injector solenoid driver cylinder 10.

  • Measure the resistance between the injector solenoid driver cylinder 10 SIGNAL pin and the injector solenoid driver cylinder 10 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1551 is active?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 10, 2, and 11 connectors.

Action

Inspect the engine harness and injector solenoid driver cylinder 10, 2, and 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 10, 2, and 11 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 10 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 11 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 10, 2, and 11 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 10, 2, and 11 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 10 SIGNAL pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL and injector solenoid driver cylinder 11 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 10 RETURN pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 11 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 10, 2, and 11 connectors from the engine harness connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 10 SIGNAL pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL and injector solenoid driver cylinder 11 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 10 RETURN pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 11 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a pin-to-pin short circuit.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 31-May-2019


FAULT CODE 1552 (QSK38) - Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1552, 1548, or 1622 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Only Fault Code 1552 is active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 11 for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Only Fault Code 1552 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1552, 1548, or 1622 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1552 is active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 11 for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 11.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 11 circuit.

  • Measure the resistance between the injector solenoid driver 11 SIGNAL pin and the injector solenoid driver 11 RETURN pin at the ECM 60 pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 11 connector.

Action

Inspect the engine harness and injector solenoid driver 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK60 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 11 connector.

Action

Check for continuity in the injector solenoid driver cylinder 11.

  • Measure the resistance between the injector solenoid driver cylinder 11 SIGNAL pin and the injector solenoid driver cylinder 11 RETURN pin at the injector solenoid driver cylinder 11 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector.

Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1552 is active?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector connectors for cylinders 11, 7, and 9.

Action

Inspect the engine harness and injector solenoid driver cylinder 11, 7, and 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 11, 7, and 9 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 11 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 7 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 9 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 11, 7, and 9 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 11 SIGNAL pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 7 SIGNAL and injector solenoid driver cylinder 9 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 11 RETURN pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 7 RETURN and injector solenoid driver cylinder 9 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 11, 7, and 9 connectors from the engine harness connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the injector solenoid driver cylinder 11 SIGNAL pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 7 SIGNAL and injector solenoid driver cylinder 9 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 11 RETURN pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 7 RETURN and injector solenoid driver cylinder 9 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 31-May-2019


FAULT CODE 1552 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1552, 331, or 1551 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Only Fault Code 1552 is active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 11 for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Only Fault Code 1552 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1552, 331, or 1551 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1552 is active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 11 for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 11.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 11 circuit.

  • Measure the resistance between the injector solenoid driver 11 SIGNAL pin and the injector solenoid driver 11 RETURN pin at the ECM 60 pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 11 connector.

Action

Inspect the engine harness and injector solenoid driver 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 11 connector.

Action

Check for continuity in the injector solenoid driver cylinder 11.

  • Measure the resistance between the injector solenoid driver cylinder 11 SIGNAL pin and the injector solenoid driver cylinder 11 RETURN pin at the injector solenoid driver cylinder 11 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the damaged injector.

Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1552 is active?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector connectors for cylinders 10, 2, and 11.

Action

Inspect the engine harness and injector solenoid driver cylinder 11, 2, and 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 11, 2, and 10 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 11 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 10 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528.Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector.

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 11, 2, and 10 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 11 SIGNAL pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL and injector solenoid driver cylinder 10 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 11 RETURN pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 10 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 11, 2, and 10 connectors from the engine harness connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 11 SIGNAL pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL and injector solenoid driver cylinder 10 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 11 RETURN pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 10 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 31-May-2019


FAULT CODE 1553 (QSK38) - Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1553, 1549, or 1551 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Only Fault Code 1553 is active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector solenoid driver cylinder 12 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Only Fault Code 1553 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1553, 1549, or 1551 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1553 is active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector solenoid driver cylinder 12 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 12.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 12 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 12 SIGNAL pin and the injector solenoid driver cylinder 12 RETURN pin at the ECM 60 pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 12 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 12 connector.

Action

Check for continuity in the injector solenoid driver cylinder 12.

  • Measure the resistance between the injector solenoid driver cylinder 12 SIGNAL pin and the injector solenoid driver cylinder 12 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1553 is active?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 12, 8, and 10 connectors from the engine harness connectors.

Action

Inspect the engine harness and injector solenoid driver cylinder 12, 8, and 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 12, 8 and 10 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 12 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 8 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 10 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 12, 8, and 10 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or injectors.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 4, 12, and 9 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 8 SIGNAL pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 12 SIGNAL and injector driver solenoid cylinder 10 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 8 RETURN pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 12 RETURN and injector solenoid driver cylinder 10 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 12, 8, and 10 connectors from the engine harness connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 8 SIGNAL pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 12 SIGNAL and injector solenoid driver cylinder 10 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 8 RETURN pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 12 RETURN and injector solenoid driver cylinder 10 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 31-May-2019


FAULT CODE 1553 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1553, 332, or 1622 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Only Fault Code 1553 is active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector solenoid driver cylinder 12 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Only Fault Code 1553 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332, 1553, or 1622 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1553 is active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector solenoid driver cylinder 12 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 12.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 12 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 12 SIGNAL pin and the injector solenoid driver cylinder 12 RETURN pin at the ECM 60 pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 12 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 12 connector.

Action

Check for continuity in the injector solenoid driver cylinder 12.

  • Measure the resistance between the injector solenoid driver cylinder 12 SIGNAL pin and the injector solenoid driver cylinder 12 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section19.

Repair

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1553 is active?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 4, 12, and 9 connectors from the engine harness connectors.

Action

Inspect the engine harness and injector solenoid driver cylinder 4, 12, and 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoid drivers for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 4, 12 and 9 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 12 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 9 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 4, 12, and 9 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or injectors.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 4, 12, and 9 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 12 SIGNAL and injector driver solenoid cylinder 9 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 12 RETURN and injector solenoid driver cylinder 9 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 4, 12, and 9 connectors from the engine harness connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 12 SIGNAL and injector solenoid driver cylinder 9 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 12 RETURN and injector solenoid driver cylinder 9 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Jun-2019


FAULT CODE 1554 - Injector Solenoid Driver Cylinder 13 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 and 1554 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Only Fault Code 1554 is active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector solenoid driver cylinder 13 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Only Fault Code 1554 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid driver for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 or 1554 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1554 is active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector solenoid driver cylinder 13 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 13.

Connectors properly connected?
YES | NO
No Repair | No Repair

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 69-pin connector.

Action

Inspect the engine harness and ECM 69-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Read the fault codes.

  • Measure the resistance between the injector solenoid driver cylinder 13 SIGNAL pin and the injector solenoid driver cylinder 13 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 13 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 13 connector.

Action

Check for continuity in the injector solenoid driver cylinder 13.

  • Measure the resistance between the injector solenoid driver cylinder 13 SIGNAL pin and the injector solenoid driver cylinder 13 RETURN pin at the injector solenoid driver connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes
  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1554 is active?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 3 and 13 connectors from the engine harness connectors.

Action

Inspect the engine harness and injector solenoid driver cylinder 3 and 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram fro all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 3 and 13 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver 3 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver 13 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 3 and 13 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in section 19.

Dirty or damaged pins, or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the damaged injector(s).

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 3 and 13 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 3 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 13 SIGNAL pin.
  • Measure the resistance from the injector solenoid driver cylinder 3 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 13 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater the 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pins connector.
  • Disconnect the injector solenoid driver cylinder 3 and 13 connectors from the engine harness connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 3 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 13 SIGNAL pin.
  • Measure the resistance from the injector solenoid driver cylinder 3 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 13 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Grater then 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Jun-2019


FAULT CODE 1555 - Injector Solenoid Driver Cylinder 14 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Codes 1555, 325, or 1548 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Only Fault Code 1555 is active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector solenoid driver cylinder 14 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Only Fault Code 1555 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1548, 325, or 1555 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1555 is active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector solenoid driver cylinder 14 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 14.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector(s).

  • Use the following procedure from the K38, K50, QSK3 8and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 14 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 14 SIGNAL pin and the injector solenoid driver cylinder 14 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 14 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector(s).

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 14 connector.

Action

Check for continuity in the injector solenoid driver cylinder 14.

  • Measure the resistance between the injector solenoid driver cylinder 14 SIGNAL pin and the injector solenoid driver cylinder 14 RETURN pin at the injector solenoid driver 14 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector(s).

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Only Fault Code 1555 is active?

YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 7, 6, and 14 connectors from the engine harness connectors.

Action

Inspect the engine harness and injector solenoid driver connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector(s).

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 7, 6, and 14 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 7 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 14 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 7, 6, and 14 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19

Dirty or damaged pins, or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector.

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 7, 6, and 14 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 7 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 6 SIGNAL and injector solenoid driver cylinder 14 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 7 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 6 RETURN and injector solenoid driver cylinder 14 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 7, 6, and 14 connectors from the engine harness connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 7 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 6 SIGNAL and injector solenoid driver cylinder 14 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 7 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 6 RETURN and injector solenoid driver cylinder 14 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Jun-2019


FAULT CODE 1556 - Injector Solenoid Driver Cylinder 15 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1556 or 322 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1556 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector solenoid driver cylinder 15 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 1556 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin to pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 or 1556 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1556 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector solenoid driver cylinder 15 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 15.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector.

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 15 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 15 SIGNAL pin and the injector solenoid driver cylinder 15 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 15 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 15 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure to replace the damaged section of the engine harness. Refer to Procedure 019-043 in Secstion 19.

Replace the injector.

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 15 connector.

Action

Check for continuity in the injector solenoid driver cylinder 15.

  • Measure the resistance between the injector solenoid driver cylinder 15 SIGNAL pin and the injector solenoid driver cylinder 15 RETURN pin at the injector solenoid driver cylinder 15 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Repair

Use the following procedure to replace the injector.

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1556 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 1 and 15 connectors from the engine harness connectors.

Action

Inspect the engine harness and injector solenoid driver connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Use the following procedure to replace the injector.

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 1 and 15 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 15 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Procedure Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Use the following procedure to replace the injector.

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 1 and 15 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connectorl ocking tab .

Use the following procedure for general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins, or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure to replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Use the following procedure to replace the injector.

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 1 and 15 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 15 SIGNAL pin.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver 15 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 1 and 15 connectors from the engine harness connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 15 SIGNAL pin.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 15 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 1557 - Injector Solenoid Driver Cylinder 16 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1557, 323, or 1549 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1557 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector solenoid driver cylinder 16 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 1557 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin to pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1557, 323, or 1549 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1557 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector solenoid driver cylinder 16 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 16.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector.

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 16 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 16 SIGNAL pin and the injector solenoid driver cylinder 16 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 16 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector.

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 16 connector.

Action

Check for continuity in the injector solenoid driver cylinder 16.

  • Measure the resistance between the injector solenoid driver cylinder 16 SIGNAL pin and the injector solenoid driver cylinder 16 RETURN pin at the injector solenoid driver cylinder 16 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Ssection 19.

Repair

Replace the injector.

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1557 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 8, 16 and 5 connectors from the engine harness connectors.

Action

Inspect the engine harness and injector solenoid driver cylinder 8, 6, and 5 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector.

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 8, 16 and 5 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 8 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 16 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 8, 16, and 5 connectors from the engine harness connectors
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector.

Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 8, 16, and 5 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 8 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 16 SIGNAL and injector solenoid driver cylinder 5 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 8 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 16 RETURN and injector solenoid driver cylinder 5 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 8, 16, and 5 connectors from the engine harness connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 8 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 16 SIGNAL and injector solenoid driver cylinder 5 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 8 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 16 RETURN and injector solenoid driver cylinder 5 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jun-2019


FAULT CODE 1595 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1595 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1361 active and Fault Code 1595 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness or engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1595 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1595 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Inspect the OEM harness and remote accelerator pedal or lever position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged remote accelerator pedal or lever position sensor.

Refer to the OEM service manual for repair or replacement instructions.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin to the remote accelerator pedal or lever position RETURN (sensor return 1) pin at the accelerator pedal or lever position sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1361 active and Fault Code 1595 inactive?
YES NO

Repair

Replace the remote accelerator pedal or lever position sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Harness connector to connector continuity, pin-to-pin continuity check:

  • Measure the resistance of the remote accelerator pedal or lever position RETURN (sensor return 1) pin between the engine harness ECM connector and the OEM harness remote accelerator pedal or lever position sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Short circuit on one connector-pin-to-pin check:

  • Measure the resistance between the SUPPLY (sensor supply 1) pin of the engine harness ECM connector and all other pins in the connector.
  • Measure the resistance between the SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1595 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jul-2012


FAULT CODE 1596 - Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1596 is inactive?
STEP 2. | Check the OEM temperature sensor and auxiliary temperature input 1 circuit. |
 | STEP 2A. Inspect the OEM temperature sensor and connector pins. | Dirty or damage pins?
 | STEP 2B. Check the circuit response. | Fault Code 1369 active and Fault Code 1596 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1596 is active?
STEP 3. | Check the ECM, OEM harness, or engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for a pin-to-ground short. | Greater then 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1596 is inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1596 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1596 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM temperature sensor and circuit.

Guided Step 2A - Inspect the OEM temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor connector from the OEM harness connector.

Action

Inspect the OEM harness and OEM temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.
  • Refer to OEM service manual for sensor repair instructions.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1369 active and Fault Code 1596 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Use INSITE™ electronic service tool to read the fault codes.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1596 is active?
YES NO

Repair

A damaged sensor has been detected.

  • Replace the OEM temperature sensor. Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the harnesses and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connect shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following proceure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or harnesses connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace the harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the OEM temperature sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the auxiliary temperature input 1 SIGNAL pin in the engine harness ECM connector and all other pins in the harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the auxiliary temperature input 1 SIGNAL wire has been detected in the harnesses connected in series. Refer to Procedure 019-071 in Section 19.

  • Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.
  • Repair or replace the harnesses. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the OEM temperature sensor connector from the OEM harness connector.

Action

Check for a pin to ground short.

  • Measure the resistance between the auxiliary temperature sensor input 1 SIGNAL pin in the engine harness ECM connector and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the auxiliary temperature sensor input 1 SIGNAL wire has been detected in the harnesses connected in series.

  • Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the harnesses. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1596 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1596 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 30-Jul-2012


FAULT CODE 1597 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM |
 | STEP 1A. Check the ECM | Fault Code 1597 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 1597 | Less than three counts?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code | Fault Code 1597 inactive?
 | STEP 2B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1597 active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 1597.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 1597.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 1597.

Are there less than three counts?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Repair complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1597 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jul-2012


FAULT CODE 1618 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1618 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 1 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 1 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 671 active and Fault Code 1618 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Code 1618 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1618 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 1 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 1 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 1.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the exhaust gas temperature sensor circuit. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to read the fault codes.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 671 active and Fault Code 1618 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and RETURN circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 1 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 1 RETURN (sensor return 3) pin at the exhaust gas temperature sensor circuit cylinder 1 connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 1 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 1.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to read the fault codes.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 active and Fault Code 1618 inactive?
YES | NO
No Repair | No Repair

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and RETURN circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 1 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 1 RETURN (sensor return 3) pin at the ECM 60-pin connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1618 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 30-Jul-2012


FAULT CODE 1618 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1618 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 1 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 1 and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 671 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1618 active?
STEP 3. | Inspect the ECM and check engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1618 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1618 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 1 and circuit.

Guided Step 2A - Check the exhaust gas temperature sensor cylinder 1 circuit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 1 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 1 connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged exhaust gas temperature sensor circuit cylinder 1 connector if repair is not possible. Refer to Procedure 019-013 in Section 19.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 1 connector from the engine harness.
  • Place a jumper between the exhaust gas temperature sensor 1 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading fault codes, switch off the engine.
  • Remove a jumper wire between the exhaust gas temperature sensor 1 SIGNAL and RETURN pin at the sensor connector of the engine harness.

Fault Code 671 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 1 to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 active?
YES NO

Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and check engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of harness if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold air temperatue sensor. Refer to Procedure 019-059 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 1 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 1 RETURN pin in the engine harness ECM 60-pin connector and the exhaust gas temperature sensor cylinder 1 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Use the following procedure for circuit diagram or wiring diagram connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 1 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 1 SIGNAL pin in the ECM 60-pin connector and the exhaust gas temperature sensor cylinder 1 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM-60 pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 1 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Check if an ECM calibration update is available.

Go to 3F

Go to 4A

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1618 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 1619 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

Caution: Too reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1619 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 4 and circuit. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 4 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 722 active and Fault Code 1619 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and sensor condition. | Fault Code 1619 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1619 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 4 and circuit.

Guided Step 2A - Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 4 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit cylinder 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 4 or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or the damaged exhaust gas temperature sensor circuit cylinder 4.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to read the fault codes.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 722 active and Fault Code 1619 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 4 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 4 RETURN (sensor return 3) pin at the exhaust gas temperature sensor circuit cylinder 4 connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor circuit cylinder 4 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 4.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to read the fault codes.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 active and Fault Code 1619 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and RETURN circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas temperature circuit cylinder 4 5 volt SUPPLY (sensor supply 3) pin to the exhaust gas temperature circuit cylinder 4 RETURN (sensor return 3) pin at the ECM 60-pin connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1619 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 30-Jul-2012


FAULT CODE 1619 (Thermistor) - Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead,and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1619 inactive?
STEP 2. | Check the exhaust gas temperature sensor cylinder 4 circuit and connector pins. |
 | STEP 2A. Inspect the engine harness and exhaust gas temperature sensor cylinder 4 and circuit. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 722 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1619 active?
STEP 3. | Inspect the ECM and check engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1619 inactive?
 | STEP 3F. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1619 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor cylinder 4 circuit and connector pins.

Guided Step 2A - Inspect the exhaust gas temperature sensor cylinder 4 circuit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor circuit cylinder 4 connector from the engine harness connector.

Action

Inspect the engine harness connector and exhaust gas temperature sensor cylinder 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor cylinder 4 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the damaged section of the engine harness or damaged exhaust gas temperature sensor cylinder 4 connector if repair is not possible.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor cylinder 4 connector from the engine harness.
  • Place a jumper between the exhaust gas temperature sensor 4 SIGNAL pin and RETURN pin at the sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.
  • After reading fault codes, switch off the engine.
  • Remove a jumper wire between the exhaust gas temperature 4 SIGNAL and RETURN pin at the sensor connector of the engine harness.

Fault Code 722 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 4 to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 2 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 active?
YES NO

Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and check engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, is possible.

Replace the damaged section of harness, if repair is not possible.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM if the ECM connector is damaged. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 4 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 4 RETURN pin in the engine harness ECM 60-pin connector and the exhaust gas temperature sensor cylinder 4 RETURN pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor circuit 4 from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor cylinder 4 SIGNAL pin in the ECM 60-pin connector and the exhaust gas temperature sensor cylinder 4 SIGNAL pin in the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin--to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the exhaust gas temperature sensor cylinder 4 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness.Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Operate the engine with an idle speed greater than 600 rpm for 2 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Check if an ECM calibration update is available.

Go to 3D

Go to 4A

Guided Step 3F - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Replace the malfunctioning ECM. Refer to Procedure 019-031 in Section 19.

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1619 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-Jul-2014


FAULT CODE 1622 (QSK38) - Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1622, 1548, or 1552 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1622 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 9 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 1622 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622, 1548, or 1552 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 9 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 9.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

  • Clean the connector and pins.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 9 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 9 SIGNAL pin and the injector solenoid driver cylinder 9 RETURN pin of the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 9 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged injector.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the injector(s). Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 9 connector.

Action

Check for continuity in the injector solenoid driver cylinder 9.

  • Measure the resistance between the injector solenoid driver cylinder 9 SIGNAL pin and the injector solenoid driver cylinder 9 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair

  • Replace the injector. Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622 is the only active fault code?

YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 9, 7, and 11 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the injector(s). Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 9, 7, and 11 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 9 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 7 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 11 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • Replace the injector(s). Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 9, 7, and 11 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

  • Replace the damaged section of the harness or damaged injector(s).
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the injector(s). Use the following procedure in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OF.F
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 9, 7, and 11 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 9 SIGNAL pin at the engine harness ECM connector to engine block ground. Repeat the check at the injector solenoid driver cylinder 7 SIGNAL and injector solenoid driver cylinder 11 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 9 RETURN pin at the engine harness ECM connector to engine block ground. Repeat the check for the injector solenoid driver cylinder 7 RETURN and injector solenoid driver cylinder 11 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • Troubleshoot all harnesses connected in series to determine which contains the short circuit.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector connectors from the engine harness connectors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the injector solenoid driver cylinder 9 SIGNAL pin at the engine harness ECM connector to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 7 SIGNAL and injector solenoid driver cylinder 11 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 9 RETURN pin at the engine harness ECM connector to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 7 RETURN and injector solenoid driver cylinder 11 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Procedure Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-May-2019


FAULT CODE 1622 (QSK50 and QSK60) - Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1622, 332, or 1553 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1622 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 9 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | 0.5 to 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | 0.5 to 5-ohms?
 | STEP 2E. Read the fault codes. | Fault Code 1622 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector solenoid driver connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoid drivers for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622, 332, or 1553 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple injector fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 9 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector solenoid driver cylinder 9.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check for continuity in the injector solenoid driver cylinder 9 circuit.

  • Measure the resistance between the injector solenoid driver cylinder 9 SIGNAL pin and the injector solenoid driver cylinder 9 RETURN pin at the ECM 60 pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5-ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 9 connector.

Action

Inspect the engine harness and injector solenoid driver cylinder 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Replace the injector, if necessary.

  • Use the following procedure in the K38, K50, and QSK50, Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the QSK45 and QSK60, Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 9 connector.

Action

Check for continuity in the injector solenoid driver cylinder 9.

  • Measure the resistance between the injector solenoid driver cylinder 9 SIGNAL pin and the injector solenoid driver cylinder 9 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 5 ohms?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.

Repair

Replace the injector.

  • Use the following procedure in the K38, K50, and QSK50, Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the QSK45 and QSK60, Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622 is the only active fault code?

YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to ecm

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 4, 12, and 9 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Replace the injector.

  • Use the following procedure in the K38, K50, and QSK50, Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the QSK45 and QSK60, Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the injector solenoid driver cylinder 9, 12, and 4 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 9 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 12 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the injector(s).

  • Use the following procedure in the K38, K50, and QSK50, Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the QSK45 and QSK60, Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector solenoid driver cylinder 9, 12, and 4 connectors from the engine harness connectors.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

Replace the damaged section of the harness or damaged injector(s).

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Replace the injector.

  • Use the following procedure in the K38, K50, and QSK50, Service Manual, Bulletin 4021528. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the QSK45 and QSK60, Service Manual, Bulletin 4021530. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector solenoid driver cylinder 9, 12, and 4 connectors from the engine harness connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 9 SIGNAL pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 12 SIGNAL and injector solenoid driver cylinder 4 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 9 RETURN pin at the ECM 60 pin connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 12 RETURN and injector solenoid driver cylinder 4 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the injector connectors from the engine harness connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the injector solenoid driver cylinder 9 SIGNAL pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 12 SIGNAL and injector solenoid driver cylinder 4 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 9 RETURN pin at the ECM 60 pin connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 12 RETURN and injector solenoid driver cylinder 4 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Same multiple injector fault codes active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-May-2019


FAULT CODE 1774 - Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1774 active?
STEP 2. | Check the engine oil priming pump circuit and sensors. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM pump switch input connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM pump switch input voltage. | 4.75 to 5.25-VDC?
STEP 3. | Check the engine oil priming pump. |
 | STEP 3A. Check the engine priming pump operation. | Pump operating?
STEP 4. | Clear the fault code. |
 | STEP 4A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1774 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine oil priming circuit and sensors

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the oil pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged oil pressure sensor.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM pump switch input connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the oil pressure sensor or harness connector.

Clean the connector and pins.

 No Repair

Go to 4A

Go to 3A

Guided Step 2C - Check the OEM pump switch input voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pump switch input connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the input voltage.

  • Measure the voltage between the OEM pump switch input pin and OEM pump switch return.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine oil priming pump

Guided Step 3A - Check the engine oil priming pump operation.

Conditions

  • Turn keyswitch ON.

Action

  • Check if the engine oil priming pump is operating.

Pump operating?
YES NO
No Repair

Repair

Troubleshoot the engine oil priming pump.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 31-Jul-2012


FAULT CODE 1843 - Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1843 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active and Fault Code 1843 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code |
 | STEP 4A. Disable the fault code. | Fault Code 1843 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the crankcase pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged crankcase pressure sensor.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-445 in section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor return 1) pin at the crankcase pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

Repair

A damaged crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit reaponse after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the crankcase pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor supply 1) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open crankcase pressure return (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1843 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 31-Jul-2012


FAULT CODE 1844 - Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1844 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active and Fault Code 1844 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1844 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1844 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the crankcase pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of engine harness or damaged crankcase pressure sensor.

Check harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-445 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor return 1) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin and the crankcase pressure SIGNAL pin at the crankcase pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 1844 active?
YES NO

Repair

A damaged crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor return 1) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit reaponse after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 1844 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A open or shorted crankcase pressure 5 volt SUPPLY (sensor supply 1) circuit has been detected in the engine harness.

Repair or replace the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin and the crankcase pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 1844 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the crankcase pressure SIGNAL wire of the engine harness.

Troubleshoot each section of harness to determine which contains the open or pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 1844 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Jul-2012


FAULT CODE 1845 - Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1845 active?
STEP 2. | Check the water in fuel indicator sensor and circuit. |
 | STEP 2A. Inspect the engine harness, and water in fuel indicator sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 82.4k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1845 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1846 active and Fault Code 1845 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1845 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1845 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel indicator sensor and circuit.

Guided Step 2A - Inspect the water in fuel indicator sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Inspect the engine harness, and water in fuel indicator sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the water in fuel indicator sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged water in fuel indicator sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-127 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Check the water in fuel indicator sensor resistance.

  • Measure the resistance between the water in fuel indicator SIGNAL pin and the water in fuel indicator RETURN (sensor return 1) pin at the water in fuel indicator sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 82.4k ohms?
YES NO

Repair

Replace the water in fuel indicator sensor. Refer to Procedure 019-127 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel indicator sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1846 active and Fault Code 1845 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM 60-pin connector water in fuel indicator sensor RETURN (sensor return 1) pin and the engine harness water in fuel indicator sensor connector RETURN (sensor return 1) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open water in fuel indicator RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM 60-pin connector water in fuel indicator sensor SIGNAL pin and the water in fuel indicator SIGNAL sensor connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open water in fuel indicator SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water in fuel indicator SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the water in fuel indicator SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. The cause of the fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1845 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Apr-2012


FAULT CODE 1846 - Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1846 active?
STEP 2. | Check the water-in-fuel indicator sensor and circuit. |
 | STEP 2A. Inspect the engine harness and water-in-fuel indicator sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1845 active and Fault Code 1846 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1846 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1845 active and Fault Code 1846 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1846 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1846 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel indicator sensor and circuit.

Guided Step 2A - Inspect the engine harness and water-in-fuel indicator sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Inspect the engine harness, and water-in-fuel indicator sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the water-in-fuel indicator sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged water-in-fuel indicator sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-127 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1845 active and Fault Code 1846 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel indicator sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 is active?
YES NO

Repair

A damaged water-in-fuel indicator sensor has been detected.

Replace the water-in-fuel indicator sensor.

Refer to Procedure 019-127 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the water-in-fuel indicator sensor connector.

Action

Inspect the engine harness, water-in-fuel indicator sensor, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active and Fault Code 1846 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the engine harness ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the water-in-fuel indicator SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin in the engine harness ECM 60-pin connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the water-in-fuel SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be checked again from the beginning. The cause of the fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1846 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Apr-2012


FAULT CODE 1847 - Engine Coolant Temperature - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1847. | Active or inactive counts of Fault Code 1847?
 | STEP 1B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1847.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1847.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1847?
YES NO

Repair

Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Section TS in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528 or in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Appropriate troubleshooting symptom tree

Repair complete

Guided Step 1B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Jul-2012


FAULT CODE 1888 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1888 is active?
STEP 2. | Check the OEM electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 datalink to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM electronic control unit multiplexing configuration?
STEP 3. | Monitor the accelerator pedal or lever position parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the accelerator pedal or lever idle validation switch and/or accelerator pedal or lever position parameters are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of zero?
 | STEP 3B. Determine if the accelerator pedal or lever idle validation switch and/or accelerator pedal or lever position are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than zero?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1888 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1888 is active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM electronic control unit multiplexing configuration component enables and OEM electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM electronic control unit multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM electronic control unit multiplexing configuration?
YES NO
No Repair

Repair

An incorrect setup has been detected in the ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM electronic control unit source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the accelerator pedal or lever position parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the accelerator pedal or lever idle validation switch and/or accelerator pedal or lever position parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Determine whether the accelerator pedal or lever idle validation switch and accelerator pedal or lever position sensor are multiplexed from the appropriate OEM troubleshooting and repair manual.
  • Make sure the accelerator pedal or lever position is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

NOTE: Monitored parameters can possibly not appear in INSITE™ electronic service tool exactly as listed above.

When the throttle is released, the Throttle Status/Idle Validation parameter must display "released" and Percent Throttle parameter must display a value of zero.

Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of zero?
YES NO
No Repair

Repair

There is an OEM issue with the accelerator pedal or lever idle validation switch or OEM electronic control unit.

Refer to Procedure 019-054 in Section 19.

Refer to the OEM service manual for further instructions.

Refer to Procedure 019-085 in Section 19.

Refer to Procedure 019-086 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the accelerator pedal or lever idle validation switch and/or accelerator pedal or lever position are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool
  • Determine whether the accelerator pedal or lever idle validation switch is multiplexed with the accelerator pedal or lever position sensor from the appropriate OEM.
  • Make sure the accelerator pedal or lever position is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

When the throttle is depressed, the Throttle Status/Idle Validation parameter must display "depressed" and Percent Throttle parameter must display a value greater than zero.

Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than zero?

YES NO
No Repair

Repair

There is an OEM issue with the accelerator pedal or lever idle validation switch, or the accelerator pedal or lever position, or with the OEM electronic control unit.

Refer to the OEM service manual for further instructions.

Refer to Procedure 019-054 in Section 19.

Refer to Procedure 019-085 in Section 19.

Refer to Procedure 019-086 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1888 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 1889 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1889 is active?
STEP 2. | Check the OEM electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 datalink to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM electronic control unit multiplexing configuration?
STEP 3. | Monitor the remote accelerator pedal or lever parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the remote accelerator pedal or lever switch and/or remote accelerator pedal or lever parameters are being received properly by the engine's ECM. | Remote Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of zero?
 | STEP 3B. Determine if the remote accelerator pedal or lever switch and/or remote accelerator pedal or lever parameters are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than zero?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1889 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1889 is active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM electronic control unit multiplexing configuration component enables and OEM electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM electronic control unit multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM electronic control unit multiplexing configuration?
YES NO
No Repair

Repair

An incorrect setup has been detected in the ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM electronic control unit source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the remote accelerator pedal or lever parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the remote accelerator pedal or lever switch and or remote accelerator pedal or lever parameters are being received properly by the engine's ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Determine whether the accelerator pedal or lever idle validation switch and accelerator pedal or lever position sensor are multiplexed from the appropriate OEM.
  • Make sure the remote accelerator pedal or lever is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

NOTE: Monitor parameters can possibly not appear in INSITE™ electronic service tool exactly as listed above.

When the accelerator pedal or lever is released, the Throttle Status/Idle Validation parameter must display “released" and Percent Throttle parameter must display a value of zero.

Remote Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of zero?
YES NO
No Repair

Repair

There is an OEM issue with the accelerator pedal or lever or accelerator pedal or lever idle validation switch or OEM electronic control unit.

Refer to Procedure 019-054 in Section 19.

Refer to the OEM for further instructions.

Refer to Procedure 019-085 in Section 19.

Refer to Procedure 019-086 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the remote accelerator pedal or lever switch and/or remote accelerator pedal or lever parameters are being received properly by the engine's ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Determine whether the remote accelerator pedal or lever idle validation switch is multiplexed with the accelerator pedal or lever position sensor from the appropriate OEM.
  • Make sure the remote accelerator pedal or lever is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

When the throttle is depressed, the Throttle Status/Idle Validation parameter must display “depressed” and Percent Throttle parameter must display a value greater than zero.

Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than zero?

YES NO
No Repair

Repair

There is an OEM issue with the accelerator pedal or lever idle validation switch or the accelerator pedal or lever with the OEM electronic control unit.

Refer to the OEM for further instructions.

Refer to Procedure 019-054 in Section 19.

Refer to Procedure 019-085 in Section 19.

Refer to Procedure 019-086 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1889 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 1891 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1891. | Fault Code 1891 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1891 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1891.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1891.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1891 active?
YES NO

Repair

Troubleshoot any additional fault codes. If necessary change the engine oil.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to reset the Centinel™ Missed Pulse Counts monitor.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1891 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Refer to the appropriate troubleshooting steps.

Last Modified: 31-Jul-2012


FAULT CODE 1911 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Fuel is flammable. Keep all cigarettes, flames, pilot lights, arcing equipment, and switches out of the work area and areas sharing ventilation to reduce the possibility of severe personal injury or death when working on the fuel system.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - Female Weather-Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 2311, 2261, 451, or 452 active or many inactive counts of Fault Code 271, 272, 2311, 2261, 451, or 452?
STEP 2. | Clear the operation of the low-pressure fuel system. |
 | STEP 2A. Check for air in fuel. | Air present in the fuel flow line?
 | STEP 2B. Check the first stage fuel filter inlet pressure. | Fuel pressure greater than 0.35 bar [5 psi]?
 | STEP 2C. Check the first stage fuel filter inlet pressure with the engine running. | Fuel pressure greater than 0.35 bar [5 psi]?
STEP 3. | Check the operation of the fuel pump pressurizing assembly. |
 | STEP 3A. Inspect the fuel pump pressurizing assembly o-ring. | O-ring cut or shaved?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 1911 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271, 272, 2311, 2261, 451, or 452 active or many inactive counts of Fault Code 271, 272, 2311, 2261, 451, or 452?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Clear the operation of the low-pressure fuel system.

Guided Step 2A - Check for air in fuel.

Conditions

  • Remove air bleed line from air bleed valve on the fuel drain manifold block.
  • Route the air bleed line into a suitable container to collect fuel.
  • Turn keyswitch ON.

Action

Inspect the fuel flow for air.

Use the following procedure in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-003 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-003 in Section 6.

Air present in the fuel flow line?
YES NO

Repair

Repair or replace the damaged line or loose connection.

  • Use the following procedure in Service Manual, K38, K50, and QSK50, Bulletin 4021528. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-024 in Section 6.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the first stage fuel filter inlet pressure with the engine stopped.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure gauge into the fuel filter head port at the inlet.

Action

Measure inlet pressure.

  • Measure the inlet pressure to the first stage fuel filter.

Fuel pressure greater than 0.35 bar [5 psi]?
YES NO

Repair

Refer to the equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the first stage fuel filter inlet pressure with the engine running.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure gauge into fuel filter head port at inlet.
  • Turn keyswitch ON.
  • Operate engine.

Action

Measure inlet pressure.

  • Measure the inlet pressure to the first stage fuel filter.

If the engine will not start, perform this test while cranking the engine.

Fuel pressure greater than 0.35 bar [5 psi]?
YES NO

Repair

Refer to the equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the operation of the fuel pump pressurizing assembly.

Guided Step 3A - Inspect the fuel pump pressurizing assembly o-ring.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump pressurizing assembly.

  • Remove the fuel pump pressurizing assembly.
  • Use the following procedure in Service Manual, K38, K50, and QSK50, Bulletin 4021528. Refer to Procedure 005-232 in Section 5.
  • Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 005-232 in Section 5.
  • Inspect the fuel pump pressurizing assembly o-ring.
  • If the o-ring is cut or shaved; fuel can be bypassing the fuel pump pressuring assembly and entering the high-pressure pump.

O-ring cut or shaved?
YES NO

Repair

Replace the damaged o-ring.

  • Use the following procedure in Service Manual, K38, K50, and QSK50, Bulletin 4021528. Refer to Procedure 005-232 in Section 5.
  • Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 005-232 in Section 5.

Repair

Replace the fuel pump pressurizing assembly and mechanical dump valve.

  • Use the following procedure in Service Manual, K38, K50, and QSK50, Bulletin 4021528. Refer to Procedure 005-232 in Section 5 and Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 005-232 in Section 5 and Refer to Procedure 006-061 in Section 6.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Disable the fault codes.

  • Use INSITE electronic service tool to verify the fault code is inactive.

Fault Code 1911 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Apr-2015


FAULT CODE 1978 - Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor Supply Fault Code 2185 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 1979 active and Fault Code 1978 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1978 is active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1978 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1978 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool, to read the fault codes.

Sensor supply Fault Code 2185 active?
YES | NO
No Repair | No Repair

Reference Fault Code 2185

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the load share equipment or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active and Fault Code 1978 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 1) pin and the generator speed/load governing bias RETURN (sensor return 1) pin at the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 is active?
YES NO

Repair

A damaged generator set has been detected.

Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harnesses from the ECM connectors.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector, OEM harness, or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator speed/load governing bias RETURN (sensor return 1) pin and the OEM harness connector generator speed/load governing bias RETURN (sensor return 1) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open generator speed/load governing bias RETURN (sensor return 1) circuit has been detected in the harnesses connected in series.

  • Troubleshoot each harness connected in series to determine which contains the open return circuit.
  • Repair or replace the harnesses. Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

  • Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted supply circuit.
  • Repair or replace the harnesses. Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1978 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Jul-2012


FAULT CODE 1979 - Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor Supply Fault Code 2186 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1978 active and Fault Code 1979 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1979 is active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1979 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1979 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service to tool read the fault codes.

Sensor Supply Fault Code 2186 active?
YES | NO
No Repair | No Repair

Reference Fault Code 2186

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 1) pin and the generator speed/load governing bias RETURN (sensor return 1) pin at the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 1) pin and the generator speed/load governing bias SIGNAL pin at the OEM 31-pin connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 active and Fault Code 1979 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 is active?
YES NO

Repair

An issue has been detected with the gen set controller.

Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator speed/load governing bias SIGNAL pin and the OEM 31-pin connector generator speed/load governing bias SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open generator speed/load governing bias signal circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disabel the fault code.

  • Start the engine let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1979 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Jul-2012


FAULT CODE 1984 - Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 2 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 2 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1984 inactive?
 | STEP 2B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 2 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 2 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 2 temperature sensor.

NOTE: The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ electronic service tool to the SAE J1939 data link.
  • Compare the intake manifold 2 temperature sensor reading on INSITE™ electronic service tool to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the intake manifold 2 temperature sensor reading in INSITE™ electronic service tool?
YES NO

Repair

Reference the Intake Manifold Air Temperature Above Specifications symptom tree in Section TS in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528 or in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530.

Repair

A damaged intake manifold 2 temperature sensor has been detected.

Replace the intake manifold 2 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1984 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronics service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronics service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Jul-2012


FAULT CODE 1985 - Intake Manifold 3 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 3 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 3 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 3 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1985 inactive?
 | STEP 2B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 3 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 3 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 3 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 3 temperature sensor.

NOTE: The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ electronic service tool to the SAE J1939 data link.
  • Compare the intake manifold 3 temperature sensor reading on INSITE™ electronic service tool to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the intake manifold 3 temperature sensor reading in INSITE™ electronic service tool?
YES NO

Repair

Follow the Intake Manifold Air Temperature Above Specifications symptom tree in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528 or in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530

Repair

A damaged intake manifold 3 temperature sensor has been detected.

Replace the intake manifold 3 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1985 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronics service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Jul-2012


FAULT CODE 1986 - Intake Manifold 4 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 4 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 4 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 4 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1986 inactive?
 | STEP 2B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 4 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 4 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 4 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 4 temperature sensor.

NOTE: The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ electronic service tool to the SAE J1939 data link.
  • Compare the intake manifold 4 temperature sensor reading on INSITE™ electronic service tool to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the intake manifold 4 temperature sensor reading in INSITE™ electronic service tool?
YES NO

Repair

Reference the Intake Manifold Air Temperature Above Specifications symptom tree in Section TS in Service Manual, K38, K50, and QSK50 Series Engines, Bulletin 4021528 or in Service Manual, QSK45 and QSK60 Series Engines, Bulletin 4021530.

Repair

A damaged intake manifold 4 temperature sensor has been detected.

Replace the intake manifold 4 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronics service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1986 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronics service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2012


FAULT CODE 1992 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed exceeds 115 percent rated rpm, the engine must be shut off immediately or engine generator equipment damage can occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault code at low engine rpm. | Active fault code at low rpm?
 | STEP 1E. Test the engine. | Fault Code 1992 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1992 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if an uncontrolled acceleration occurred where the engine rapidly accelerated to or past 15 percent above rated speed, followed by moderate deceleration to 15 percent above rated speed.

Alternate fuel source?
YES NO

Repair

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Operate engine.

Action

Check the engine rpm with INSITE™ electronic service tool.

NOTE: Compare the engine crankshaft speed/position sensor reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Repair

Inspect the engine crankshaft speed/position sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1C

Fault Codes 689 and 1376

Guided Step 1C - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the OEM harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine crankshaft speed/position sensor.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

  • Check for active Fault Code 1992 when the engine is not operating above 15 percent above rated speed.

Inactive fault code at low rpm?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON.

Action

Test the engine to check if the overspeed condition is still present.

  • Test the engine to check if the overspeed condition is still present.

Fault Code 1992 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1992 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2012


FAULT CODE 2121 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 1 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2121 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 1 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy, with an infrared thermometer.

  • Start engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 1 reading on the INSITE™ service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 1 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 1.

Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2121 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2012


FAULT CODE 2121 (Thermistor) - Exhaust Gas Temperature Cylinder 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 1 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2121 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 1 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 1 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 1 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 1 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 1 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree.

Go to 2A

Guided Step 2 - Dissable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2121 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2122 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 3 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 3 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2122 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 3 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy, with an infrared thermometer.

  • Start engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 3 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 3 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 3 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 3.

Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2122 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2012


FAULT CODE 2122 (Thermistor) - Exhaust Gas Temperature Cylinder 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 3 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 3 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2122 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 3 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 3 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 3 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 3 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 3 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 3 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 622 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2123 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 5 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 5 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 5 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2123 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 5 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy, with an infrared thermometer.

  • Start engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 5 reading on the service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 5 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 5 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 5.

Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2123 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2012


FAULT CODE 2123 (Thermistor) - Exhaust Gas Temperature Cylinder 5 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 5 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 5 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 634 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 5 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 5 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 5 accuracy.

  • Start the engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 5 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 5 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 5 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 5. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2123 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2124 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 7 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 7 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 7 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 7 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2124 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 7 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 7 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 7 accuracy, with an infrared thermometer .

  • Start engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 7 reading on the service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 7 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 7 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 7.

Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2124 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2012


FAULT CODE 2124 (Thermistor) - Exhaust Gas Temperature Cylinder 7 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 7 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 7 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 7 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 634 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 7 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 7 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 7 accuracy.

  • Start the engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 7 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 7 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 7 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 7. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2124 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2125 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 9 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 9 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 9 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 9 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2125 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 9 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 9 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 9 accuracy, with an infrared thermometer.

  • Start engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 9 reading on the service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 9 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 9 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 9.

Refer to Procedure 019-013 in Section 19.

Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2125 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2012


FAULT CODE 2125 (Thermistor) - Exhaust Gas Temperature Cylinder 9 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 9 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 9 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 9 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 634 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 9 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 9 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 9 accuracy.

  • Start the engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 9 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 9 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 9 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2125 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2126 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 11 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 11 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 11 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 11 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2126 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 11 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 11 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 11 accuracy, using an infrared thermometer.

  • Start engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 11 reading using INSITE™ service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 11 reading using INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 11 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 11. Refer to Procedure 019-013 in Section 19.

See the Engine Performance Troubleshooting Tree.

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2126 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2126 (Thermistor) - Exhaust Gas Temperature Cylinder 11 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 11 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 11 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 11 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 634 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 11 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 11 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 11 accuracy.

  • Start the engine
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 11 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 11 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 11 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2126 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2127 (QSK50 Marine) - Exhaust Gas Temperature Cylinder 13 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 13 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 13 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2127 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy using an infrared thermometer.

  • Start engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 13 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 13 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 13 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 13. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree.

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2127 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2127 (Thermistor) - Exhaust Gas Temperature Cylinder 13 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 13 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 13 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 634 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 13 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 13 accuracy.

  • Start the engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 13 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 13 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 13 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 13. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2127 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2128 (QSK50 Marine) - Exhaust Gas Temperature Cylinder 15 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 15 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 15 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2128 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 15 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy using an infrared thermometer.

  • Start engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 15 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 15 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 15 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 15. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2128 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2128 (Thermistor) - Exhaust Gas Temperature Cylinder 15 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 15 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 15 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 634 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 15 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 15 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 15 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 15 reading on INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 15 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 15 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 15.

  • Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2128 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2012


FAULT CODE 2131 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 2 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 2 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2131 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 2 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy using an infrared thermometer.

  • Start engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 2 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 2 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 2 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 2. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2131 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2131 (Thermistor) - Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 2 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 2 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 634 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 2 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 2 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 2 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 2 reading on INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 2 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 2 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 2.

  • Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2131 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2012


FAULT CODE 2132 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 4 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 4 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 4 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 4 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2132 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 4 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 4 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 4 accuracy using an infrared thermometer.

  • Start engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 4 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 4 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 4 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 4. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2132 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2132 (Thermistor) - Exhaust Gas Temperature Cylinder 4 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 4 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 4 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 4 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 634 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 4 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 4 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 4 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 4 reading on INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 4 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 4 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 4.

  • Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2132 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2012


FAULT CODE 2133 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 6 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 6 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 6 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 6 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2133 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 6 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 6 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 6 accuracy using an infrared thermometer.

  • Start engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 6 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 6 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 6 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 6. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2133 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-Aug-2012


FAULT CODE 2133 (Thermistor) - Exhaust Gas Temperature Cylinder 6 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 6 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 6 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 6 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 638 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 6 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 6 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 6 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 16 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 6 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 6 has been detected.

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 638 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2012


FAULT CODE 2134 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 8 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 8 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 8 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 8 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2134 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 8 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 8 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 8 accuracy using an infrared thermometer.

  • Start engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 8 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 8 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 8 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 8. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2134 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 02-Aug-2012


FAULT CODE 2134 (Thermistor) - Exhaust Gas Temperature Cylinder 8 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 8 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 8 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 8 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2134 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 8 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 8 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 8 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 8 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 8 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 8 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 8.

  • Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2134 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Aug-2012


FAULT CODE 2135 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 10 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 10 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 10 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2135 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 10 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy using an infrared thermometer.

  • Start engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 10 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 10 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 10 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 10. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2135 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Aug-2012


FAULT CODE 2135 (Thermistor) - Exhaust Gas Temperature Cylinder 10 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 10 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 10 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 638 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 10 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 10 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 10 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 10 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 10 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 10 has been detected.

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 638 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Aug-2012


FAULT CODE 2136 (QSK38 and QSK50 Marine) - Exhaust Gas Temperature Cylinder 12 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 12 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 12 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2136 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 12 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy using an infrared thermometer.

  • Start engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 12 reading on the service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 12 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 12 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 12. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2136 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Aug-2012


FAULT CODE 2136 (Thermistor) - Exhaust Gas Temperature Cylinder 12 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 12 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 12 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2136 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 12 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 12 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 12 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 12 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 12 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 12 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 12.

  • Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2136 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Aug-2012


FAULT CODE 2137 (QSK50 Marine) - Exhaust Gas Temperature Cylinder 14 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 14 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2137 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 14 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy using an infrared thermometer.

  • Start engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 14 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 1 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damaged.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 14 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 14. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2137 inactive?
YES NO
No Repair

Repair

Retun to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Aug-2012


FAULT CODE 2137 (Thermistor) - Exhaust Gas Temperature Cylinder 14 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 14 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 14 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 638 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 14 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 14 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 14 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 14 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 14 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 14 has been detected.

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 638 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Aug-2012


FAULT CODE 2138 (QSK50 Marine) - Exhaust Gas Temperature Cylinder 16 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 16 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 16 reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2138 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 16 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy using an infrared thermometer.

  • Start engine
  • Connect INSITE™ electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head

Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 16 reading using INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 16 reading using INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 16 has been detected.

Replace the exhaust gas temperature sensor circuit cylinder 16. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2138 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Aug-2012


FAULT CODE 2138 (Thermistor) - Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 16 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 16 reading with INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2138 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 16 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 16 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 16 reading on the INSITE™ electronic service tool monitor screen.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 16 reading with INSITE™ electronic service tool?

YES NO

Repair

Possible cylinder or injector damage must be investigated.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 16 has been detected.

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2138 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Aug-2012


FAULT CODE 2144 - Exhaust Gas Temperature Cylinder 16 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor circuit cylinder 16 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy. | Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 16 reading with INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2144 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor circuit cylinder 16 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit cylinder 16 accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder 16 accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder 16 reading on INSITE™ electronic service tool.

Is the temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder 16 reading with INSITE™ electronic service tool?

YES NO

Repair

Investigate possible cylinder or injector damage.

Repair

A damaged exhaust gas temperature sensor circuit cylinder 16 has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Reference the Engine Performance Troubleshooting Tree

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2144 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Aug-2012


FAULT CODE 2157 - Intake Manifold 2 Temperature - Abnormal Rate of Change

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 2 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 2 temperature sensor accuracy using a thermocouple or similar temperature probe. | Does the thermocouple reading agree with the intake manifold 2 temperature sensor reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2157 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 2 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 2 temperature sensor accuracy using a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 2 temperature sensor accuracy using a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 2 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 2 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe.

If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 2 temperature sensor reading using INSITE™ electronic service tool?

YES NO
No Repair

Repair

A damaged intake manifold 2 temperature sensor has been detected.

Replace the intake manifold 2 temperature sensor. Refer to Procedure 019-059 in Section 19.

Reference the Intake Manifold Air Temperature is High (Rapid Rise) troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2157 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Aug-2012


FAULT CODE 2158 - Intake Manifold 3 Temperature - Abnormal Rate of Change

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 3 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 3 temperature sensor accuracy using a thermocouple or similar temperature probe. | Does the thermocouple reading agree with the intake manifold 3 temperature sensor reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2158 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 3 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 3 temperature sensor accuracy using a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 3 temperature sensor accuracy using a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 3 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 3 temperature sensor reading to the reading from the temperature probe using INSITE™ electronic service tool.

If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 3 temperature sensor reading using INSITE™ electronic service tool?

YES NO
No Repair

Repair

A damaged intake manifold 3 temperature sensor has been detected.

Replace the intake manifold 3 temperature sensor. Refer to Procedure 019-059 in Section 19.

Reference the Intake Manifold Air Temperature is High (Rapid Rise) troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2158 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Aug-2012


FAULT CODE 2159 - Intake Manifold 4 Temperature - Abnormal Rate of Change

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 4 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 4 temperature sensor accuracy using a thermocouple or similar temperature probe. | Does the thermocouple reading agree with the intake manifold 4 temperature sensor reading using INSITE™ electronic service tool?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2159 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 4 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 4 temperature sensor accuracy using a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 4 temperature sensor accuracy using a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 4 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 4 temperature sensor reading to the reading from the temperature probe using INSITE™ electronic service tool.

If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 4 temperature sensor reading using INSITE™ electronic service tool?

YES NO
No Repair

Repair

A damaged intake manifold 4 temperature sensor has been detected.

Replace the intake manifold 4 temperature sensor. Refer to Procedure 019-059 in Section 19.

Reference the Intake Manifold Air Temperature is High (Rapid Rise) troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Disable and clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2159 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Aug-2012


FAULT CODE 2185 (Industrial) - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM, OEM harness, and engine harness. |
 | STEP 2A. Inspect the ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit in the battery 1 voltage power harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2185 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM, OEM harness, and engine harness.

Guided Step 2A - Inspect the ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the accelerator pedal or lever position sensor connector.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the 31-pin OEM connector.

Action

Inspect the engine harness and accelerator pedal or lever position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Refer to the OEM service manual for accelerator pedal or lever position sensor repair instructions.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 4-pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the accelerator pedal or lever position sensor SUPPLY 4 wire.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the battery 1 voltage power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Disconnect the engine power harness connector from the ECM 4-pin connector.

Action

Check for a short circuit to battery.

  • Measure the resistance between the sensor SUPPLY 4-pin in the engine harness ECM connector and the ECM battery 1 voltage pin on the power harness ECM 4-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A short circuit to battery has been detected in the OEM harness or engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2185 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Aug-2012


FAULT CODE 2185 (Power Generation) - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM, OEM harness, and engine harness. |
 | STEP 2A. Inspect the ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit in the battery 1 voltage power harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2185 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM, OEM harness, and engine harness.

Guided Step 2A - Inspect the ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the gain adjust potentiometer connector.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the 31-pin OEM connector.

Action

Inspect the engine harness and gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Refer to the OEM service manual for gain adjust potentiometer, generator output frequency adjust potentiometer, and droop adjust potentiometer repair instructions.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the gain adjust potentiometer connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY 4 pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the sensor SUPPLY 4 wire.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the battery 1 voltage power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the gain adjust potentiometer connector from the OEM harness connector.
  • Disconnect the engine power harness connector from the ECM 4-pin connector.

Action

Check for a short circuit to battery.

  • Measure the resistance between the sensor SUPPLY 4 pin in the engine harness ECM connector and the ECM battery 1 voltage pin on the power harness ECM 4-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A short circuit to battery has been detected in the OEM harness or engine harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2185 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Aug-2012


FAULT CODE 2186 (Industrial) - Sensor Supply 4 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ambient Air Pressure Sensor | Refer to Procedure 019-004 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Engine Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Engine Control Module | Refer to Procedure 019-031 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Intake Manifold Air Pressure Sensor | Refer to Procedure 019-061 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Fuel Supply Pressure Sensor | Refer to Procedure 019-398 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Post-Oil Filter Pressure Sensor | Refer to Procedure 019-447 | QSK38, QSK50, and QSK60 CM2150 | 4022102

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
 | STEP 1B. Check the service model name. | Engine a QSK38 CM2150?
 | STEP 1C. Check the service model name. | Engine a QSK50 CM2150?
 | STEP 1D. Check the service model name. | Engine a QSK60 CM2150?
STEP 2. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 2A. Check the circuit response. | Fault Code 2186 active?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
 | STEP 2C. Check the circuit response. | Fault Code 2186 active?
 | STEP 2D. Check the circuit response. | Fault Code 2186 active?
 | STEP 2E. Check the circuit response. | Fault Code 2186 active?
 | STEP 2F. Check the circuit response. | Fault Code 2186 active?
 | STEP 2G. Check the circuit response. | Fault code 2186 active?
STEP 3. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 3A. Check the circuit response. | Fault Code 2186 active?
 | STEP 3B. Check the circuit response. | Fault Code 2186 active?
 | STEP 3C. Check the circuit response. | Fault Code 2186 active?
 | STEP 3D. Check the circuit response. | Fault Code 2186 active?
 | STEP 3E. Check the circuit response. | Fault Code 2186 active?
 | STEP 3F. Check the circuit response. | Fault Code 2186 active?
 | STEP 3G. Check the circuit response. | Fault Code 2186 active?
 | STEP 3H. Check the circuit response. | Fault Code 2186 active?
 | STEP 3I. Check the circuit response. | Fault Code 2186 active?
STEP 4. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 4A. Check the circuit response. | Fault Code 2186 active?
 | STEP 4B. Check the circuit response. | Fault Code 2186 active?
 | STEP 4C. Check the circuit response. | Fault Code 2186 active?
 | STEP 4D. Check the circuit response. | Fault Code 2186 active?
 | STEP 4E. Check the circuit response. | Fault Code 2186 active?
 | STEP 4F. Check the circuit response. | Fault Code 2186 active?
 | STEP 4G. Check the circuit response. | Fault Code 2186 active?
 | STEP 4H. Check the circuit response. | Fault Code 2186 active?
 | STEP 4I. Check the circuit response. | Fault Code 2186 active?
 | STEP 4J. Check the circuit response. | Fault Code 2186 active?
STEP 5. | Check the ECM and engine harness. |
 | STEP 5A. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 5B. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the service model name.

Conditions

  • Not Applicable

Action

  • Verify the service model name of the engine.

Engine a QSK38 CM2150?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the service model name.

Conditions

  • Not Applicable

Action

  • Verify the service model name of the engine.

Engine a QSK50 CM2150?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1D

Guided Step 1D - Check the service model name.

Conditions

  • Not Applicable

Action

  • Verify the service model name of the engine.

Engine a QSK60 CM2150?
YES | NO
No Repair | No Repair

Go to 4A

Repair complete

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2B

Go to 6A

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the camshaft speed sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 2C

Go to 6A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

Go to 2D

Go to 6A

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Replace the intake manifold air pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 2E

Go to 6A

Guided Step 2E - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 2F

Go to 6A

Guided Step 2F - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2G

Go to 6A

Guided Step 2G - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the fuel supply pressure sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 3 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 3A - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the camshaft speed sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Replace the intake manifold air pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 3E

Go to 6A

Guided Step 3E - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3F

Go to 6A

Guided Step 3F - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 3G

Go to 6A

Guided Step 3G - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the ambient air pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3H

Go to 6A

Guided Step 3H - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the fuel supply pressure sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 3I

Go to 6A

Guided Step 3I - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-filter oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the pre-filter oil pressure sensor. Refer to Procedure 019-126 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 4 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 4A - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 4B

Go to 6A

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the camshaft speed sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

Go to 4D

Go to 6A

Guided Step 4D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Replace the intake manifold air pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 4F

Go to 6A

Guided Step 4F - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 4G

Go to 6A

Guided Step 4G - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the ambient air pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 4H

Go to 6A

Guided Step 4H - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the fuel supply pressure sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 4I

Go to 6A

Guided Step 4I - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-filter oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the pre-filter oil pressure sensor. Refer to Procedure 019-126 in the Associated Procedures Table.

Go to 4J

Go to 6A

Guided Step 4J - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-filter oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the post-filter oil pressure sensor. Refer to Procedure 019-447 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and engine harness.

Guided Step 5A - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Disconnect the intake manifold air temperature and pressure sensor from the engine harness.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the engine coolant pressure sensor from the engine harness.
  • Disconnect the pre-filter oil pressure sensor sensor from the engine harness.
  • Disconnect the post-oil filter pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the resistance and check for a short circuit between the sensor supply 4 ECM harness connector pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5B

Go to 6A

Guided Step 5B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Disconnect the intake manifold air temperature and pressure sensor from the engine harness.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the engine coolant pressure sensor from the engine harness.
  • Disconnect the pre-filter oil pressure sensor sensor from the engine harness.
  • Disconnect the post-oil filter pressure sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the resistance and check for a short circuit between the sensor supply 4 ECM harness connector pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or call for assistance.

Last Modified: 23-Mar-2017


FAULT CODE 2186 (Power Generation) - Sensor Supply 4 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ambient Air Pressure Sensor | Refer to Procedure 019-004 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Engine Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Intake Manifold Air Pressure Sensor | Refer to Procedure 019-061 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Fuel Supply Pressure Sensor | Refer to Procedure 019-398 | QSK38, QSK50, and QSK60 CM2150 | 4022102
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK38, QSK50, and QSK60 CM2150 | 4022102

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
 | STEP 1B. Check the service model name. | Engine a QSK38 CM2150?
 | STEP 1C. Check the service model name. | Engine a QSK50 CM2150?
 | STEP 1D. Check the service model name. | Engine a QSK60 CM2150?
STEP 2. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 2A. Check the circuit response. | Fault Code 2186 active?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
 | STEP 2C. Check the circuit response. | Fault Code 2186 active?
 | STEP 2D. Check the circuit response. | Fault Code 2186 active?
 | STEP 2E. Check the circuit response. | Fault Code 2186 active?
 | STEP 2F. Check the circuit response. | Fault Code 2186 active?
 | STEP 2G. Check the circuit response | Fault Code 2186 active?
 | STEP 2H. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 3A. Check the circuit response. | Fault Code 2186 active?
 | STEP 3B. Check the circuit response. | Fault Code 2186 active?
 | STEP 3C. Check the circuit response. | Fault Code 2186 active?
 | STEP 3D. Check the circuit response. | Fault Code 2186 active?
 | STEP 3E. Check the circuit response. | Fault Code 2186 active?
 | STEP 3F. Check the circuit response. | Fault Code 2186 active?
 | STEP 3G. Check the circuit response. | Fault Code 2186 active?
 | STEP 3H. Check the circuit response. | Fault Code 2186 active?
STEP 4. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 4A. Check the circuit response. | Fault Code 2186 active?
 | STEP 4B. Check the circuit response. | Fault Code 2186 active?
 | STEP 4C. Check the circuit response. | Fault Code 2186 active?
 | STEP 4D. Check the circuit response. | Fault Code 2186 active?
 | STEP 4E. Check the circuit response. | Fault Code 2186 active?
 | STEP 4F. Check the circuit response. | Fault Code 2186 active?
 | STEP 4G. Check the circuit response. | Fault Code 2186 active?
 | STEP 4H. Check the circuit response. | Fault Code 2186 active?
 | STEP 4I. Check the circuit response. | Fault Code 2186 active?
STEP 5. | Check the ECM and engine harness. |
 | STEP 5A. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 5B. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the service model name.

Conditions

  • Not Applicable

Action

  • Verify the service model name of the engine.

Engine a QSK38 CM2150?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the service model name.

Conditions

  • Not Applicable

Action

  • Verify the service model name of the engine.

Engine a QSK50 CM2150?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1D

Guided Step 1D - Check the service model name.

Conditions

  • Not Applicable

Action

  • Verify the service model name of the engine.

Engine a QSK60 CM2150?
YES | NO
No Repair | No Repair

Go to 4A

Repair complete

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2B

Go to 6A

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the camshaft speed sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 2C

Go to 6A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

Go to 2D

Go to 6A

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Replace the intake manifold air pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 2E

Go to 6A

Guided Step 2E - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 2F

Go to 6A

Guided Step 2F - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2G

Go to 6A

Guided Step 2G - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the fuel supply pressure sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 2H

Go to 6A

Guided Step 2H - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the ambient air pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 3 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 3A - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the camshaft speed sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Replace the intake manifold air pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 3E

Go to 6A

Guided Step 3E - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3F

Go to 6A

Guided Step 3F - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 3G

Go to 6A

Guided Step 3G - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the ambient air pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3H

Go to 6A

Guided Step 3H - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the fuel supply pressure sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 4 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 4A - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 4B

Go to 6A

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the camshaft speed sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

Go to 4D

Go to 6A

Guided Step 4D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Replace the intake manifold air pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 4F

Go to 6A

Guided Step 4F - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 4G

Go to 6A

Guided Step 4G - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the ambient air pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 4H

Go to 6A

Guided Step 4H - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the fuel supply pressure sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and engine harness.

Guided Step 5A - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Disconnect the intake manifold air temperature and pressure sensor from the engine harness.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the engine coolant pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the resistance and check for a short circuit between the sensor supply 4 ECM harness connector pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5B

Go to 6A

Guided Step 5B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft speed sensor from the engine harness.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Disconnect the intake manifold air temperature and pressure sensor from the engine harness.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Disconnect the engine coolant pressure sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Inspect the sensor pins and engine harness connector for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the resistance and check for a short circuit between the sensor supply 4 ECM harness connector pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Mar-2017


FAULT CODE 2195 - Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify if the engine stop button is in the stop position. |
 | STEP 1A. Verify if the engine stop button is in the stop position. | Engine stop button in the stop position?
 | STEP 1B. Check Diesel Control Unit (DCU) information. | DCU shows a stop button event or witness test?
 | STEP 1C. Check for other fault codes. | Active or inactive fault codes?
STEP 2. | Check for correct position of the air shutoff valves. |
 | STEP 2A. Check for correct position of the air shutoff valves. | Air shutoff valves in the open position?
STEP 3. | Check plunger switch for a short circuit. |
 | STEP 3A. Check plunger switch for short circuit. | Greater than 100k ohms?
STEP 4. | Check the engine stop button for short circuit. |
 | STEP 4A. Check the engine stop button for short circuit. | Greater than 100k ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 5B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 5C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 6. | Check the OEM harness. |
 | STEP 6A. Inspect the OEM harness and 23-pin connectors. | Dirty or damaged pins?
 | STEP 6B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 6C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 7. | Check the Customer Interface Box (CIB) internal wiring. |
 | STEP 7A. Check the Customer Interface Box (CIB) internal wiring between the E-stop button and the 23-pin OEM connector. | Dirty or damaged pins?
 | STEP 7B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 7C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 8. | Clear the fault codes and check for progressive damage. |
 | STEP 8A. Confirm conditions. | Snapshot data shows Fault Code 2195 was set at or below idle and 10 percent torque?
 | STEP 8B. Complete checks with engine OFF. | Hump hoses and turbochargers meet specifications?
 | STEP 8C. Disable the fault code. | Fault Code 2195 inactive?
 | STEP 8D. Check gaskets at load. | Damage to gaskets detected?
 | STEP 8E. Disable the fault code. | Fault Code 2195 inactive?
 | STEP 8F. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the engine stop button is in the stop position.

Guided Step 1A - Verify the engine stop button is in the stop position.

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Verify the engine stop button is in the stop position.

Engine stop button in the stop position?
YES NO

Repair

Reset the engine stop button.

 No Repair

Go to 8A

Go to 1B

Guided Step 1B - Check Diesel Control Unit (DCU) information.

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Check DCU information.

Check the event log in the DCU for an engine stop button event or an engine protection overspeed witness test. Use the following procedure in the Marine C Command Elite™ and C Command Elite Plus™ Panel Systems Master Repair Manual, Bulletin 4021617. Refer to Procedure 101-013 in Section 1.

DCU shows a stop button event or witness test?
YES NO

Repair

Reset the engine stop button or move out of test mode. Use the following procedure in the Marine C Command Elite™ and C Command Elite Plus™ Panel Systems Master Repair Manual, Bulletin 4021617. Refer to Procedure 101-013 in Section 1.

No Repair

Go to 8A

Go to 1C

Guided Step 1C - Check for other fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault code.

Active or inactive fault codes?
YES | NO
No Repair | No Repair

Troubleshoot other fault codes and return to this fault code.

Go to 2A

Guided Step 2 - Check for correct position of the air shutoff valves.

Guided Step 2A - Check for correct position of the air shutoff valves.

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Check that all of the air shutoff valves are in the open position.

Air shutoff valves in the open position?
YES NO
No Repair

Repair

Replace the air shutoff valve. Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 010-143 in Section 10.

Go to 3A

Go to 8A

Guided Step 3 - Check plunger switch for short circuit.

Guided Step 3A - Check the plunger switch for short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the plunger switches one at a time.

Action

Check for a short circuit.

  • Measure the resistance between the switch terminals.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the plunger switch sensor. Refer to Procedure 019-468 in Section 19.

Go to 4A

Go to 8A

Guided Step 4 - Check the engine stop button for short a circuit.

Guided Step 4A - Check the engine stop button for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect wires from NO (Normally Open) engine stop switch terminals. The NO engine stop switch is the middle switch of the three terminals.

Action

Check for a short circuit.

  • Measure the resistance between the NO (Normally Open) switch terminals.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the engine stop button. Use the procedure in the Marine C Command Elite™ and C Command Elite Plus™ Panel Systems Master Repair Manual, Bulletin 4021617. Refer to Procedure 015-023 in Section 15.

Go to 5A

Go to 8A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 8A

Go to 5B

Guided Step 5B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin O of the engine harness connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 5C

Go to 8A

Guided Step 5C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin O of the engine harness connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 8A

Guided Step 6 - Check the OEM harness.

Guided Step 6A - Inspect the OEM harness and 23-pin connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.

Action

Inspect the OEM harness and 23-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 8A

Go to 6B

Guided Step 6B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin O of the 23-pin OEM harness connector, OEM side, to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6C

Go to 8A

Guided Step 6C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin O of the 23-pin OEM harness connector, OEM side, to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the Customer Interface Box (CIB) internal wiring.

Guided Step 7A - Check the CIB internal wiring between the E-stop button and the 23-pin OEM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.

Action

Inspect the 23-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 8A

Go to 7B

Guided Step 7B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin O of the 23-pin OEM harness connector, OEM side, to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the CIB harness. Refer to Procedure 019-071 in Section 19.

Go to 7C

Go to 8A

Guided Step 7C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the CIB at the 23-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin O of the 23-pin OEM harness connector, OEM side, to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the CIB harness. Refer to Procedure 019-071 in Section 19.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes and check for progressive damage.

Guided Step 8A - Confirm conditions.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Confirm the conditions of the engine.

  • Use INSITE™ electronic service tool to view the fault code snapshot data to verify the conditions of the engine when Fault Code 2195 occured.

Snapshot data shows that Fault Code 2195 was set at or below idle and 10 percent torque?
YES NO
No Repair

Repair

Check the engine for progressive damage.

Go to 8E

Go to 8B

Guided Step 8B - Complete checks with engine OFF.

Conditions

  • Turn keyswitch OFF.

Action

Perform the following inspections:

  • Inspect the hump hoses for signs of damage or leakage.
  • Check the turbocharger shaft end clearance. Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 010-033 in Section 10.
  • Inspect the turbocharger compressor impeller wheel.

Hump hoses and turbochargers meet specifications?
YES NO
No Repair

Repair

Replace the damged components. Use the following procedures in the QSK45 and QSK60 Service Manual, Bulletin 4021530:

  • Refer to Procedure 010-034 in Section 10.
  • Refer to Procedure 010-035 in Section 10.

Go to 8C

Go to 8C

Guided Step 8C - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2195 is inactive.

Fault Code 2195 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 8D

Go to 1A

Guided Step 8D - Check gaskets at load.

Conditions

  • Turn keyswitch ON.

Action

Operate the engine with load and check the gaskets.

  • Start the engine and load it.
  • Check and listen for any noise associated with aftercooler gasket or head gasket leaks.

Damage to gaskets detected?
YES NO

Repair

Replace gaskets as necessary. Use the following procedures in the QSK45 and QSK60 Service Manual, Bulletin 4021530:

  • For head gasket repair: Refer to Procedure 002-021 in Section 2.
  • For aftercooler gasket repair: Refer to Procedure 010-002 in Section 10.
No Repair

Go to 8E

Go to 8E

Guided Step 8E - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic serivce tool to verify Fault Code 2195 is inactive.

Fault Code 2195 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 8F

Go to 1A

Guided Step 8F - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting tree

Last Modified: 07-Aug-2012


FAULT CODE 2215 - Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check if engine will start or engine starts and dies. |
 | STEP 1A. Attempt to start the engine. | Engine starts and continues operating?
STEP 2. | Check the low pressure side of the fuel system. |
 | STEP 2A. Check for external fuel leaks. | Fuel leaking externally?
 | STEP 2B. Check for air in the fuel. | Air present in fuel flow?
 | STEP 2C. Check the fuel supply pressure sensor. | INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
 | STEP 2D. Inspect the original equipment manufacturer (OEM) fuel supply hose and fuel tank. | Stage 1 inlet restriction greater than specification?
 | STEP 2E. Check the Stage 1 filter restriction. | Stage 1 filter restriction less than specification?
STEP 3. | Disable and clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2215 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check if engine will start or engine starts and dies.

Guided Step 1A - Attempt to start engine.

Conditions

  • Start engine.

Action

Attempt to start the engine.

Check if the engine will not start or if the engine starts and stalls.

Engine starts and continues operating?

YES | NO
No Repair | No Repair

Go to 2A

Reference the Engine Performance troubleshooting symptom tree

Guided Step 2 - Check the low pressure side of the fuel system.

Guided Step 2A - Check for external fuel leaks.

Conditions

  • Operate the engine at idle.

Action

Start the engine and check for external fuel leaks.

Check for external fuel leaks.

Fuel leaking externally?
YES NO

Repair

Repair all fuel leaks.

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-024 in Section 6.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air in fuel.

Conditions

  • Remove air bleed line from air bleed valve on the fuel drain manifold block.
  • Route the air bleed line into a suitable container to collect fuel.
  • Turn keyswitch ON.

Action

Direct the fuel flow from the air bleed line into a container.

Inspect fuel flow for air.

Use the following procedure in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-003 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-003 in Section 6.

Air present in the fuel flow?
YES NO

Repair

Repair or replace the damaged line or loose connection.

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528.Refer to Procedure 006-024 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-024 in Section 6.
No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel supply pressure sensor.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor accuracy.

Start and operate the engine at high idle.

Record the fuel supply sensor reading in INSITE™ electronic service tool.

Shut the engine down and remove the fuel supply pressure sensor. Refer to Procedure 019-398 in Section 19.

Install a pressure gauge.

Start and operate the engine at high idle.

Record the fuel supply pressure reading on a pressure gauge installed in place of the fuel supply pressure sensor.

INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
YES NO

Repair

Install the fuel supply pressure sensor that was removed. Refer to Procedure 019-398 in Section 19.

Repair

Replace the fuel supply pressure sensor. Refer to Procedure 019-398 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM fuel supply hose and fuel tank.

Conditions

  • Turn keyswitch OFF.

Action

Measure fuel inlet restriction at the Stage 1 fuel filter inlet.

  • For K38, K50, and QSK50 Series Engines, use the following procedure in Bulletin 4021528. Refer to Procedure 006-020 in Section 6.
  • For QSK45 and QSK60 Series Engines, use the following procedure in Bulletin 4021530. Refer to Procedure 006-020 in Section 6.

Stage 1 inlet restriction greater than specification?
YES NO

Repair

Refer to the equipment manufacturer service information for repair instructions.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the Stage 1 filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the Stage 1 fuel filter restriction.

  • For K38, K50, and QSK50 Series Engines, use the following procedure in Bulletin 4021528. Refer to Procedure 006-020 in Section 6.
  • For QSK45 and QSK60 Series Engines, use the following procedure in Bulletin 4021530. Refer to Procedure 006-020 in Section 6.

Stage 1 filter restriction less than specification?
YES NO

Repair

Replace the high pressure pump assembly.

  • For K38, K50, and QSK50 Series Engines, use the following procedure in Bulletin 4021528. Refer to Procedure 005-016 in Section 5.
  • For QSK45 and QSK60 Series Engines, use the following procedure in Bulletin 4021530. Refer to Procedure 005-016 in Section 5.

Repair

Replace the Stage 1 fuel filter.

  • For K38, K50, and QSK50 Series Engines, use the following procedure in Bulletin 4021528. Refer to Procedure 006-075 in Section 6.
  • For QSK45 and QSK60 Series Engines, use the following procedure in Bulletin 4021530. Refer to Procedure 006-075 in Section 6.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2215 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 07-Apr-2015


FAULT CODE 2216 - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | K38, K50, QSK38, and QSK50 | 4021528
Fuel Pump | Refer to Procedure 005-016 | QSK38 and QSK50 | 4021530
Fuel Filter Head | Refer to Procedure 006-017 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Filter Head | Refer to Procedure 006-017 | QSK45 and QSK60 | 4021530
Fuel Inlet Restriction | Refer to Procedure 006-020 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSK45 and QSK60 | 4021530
Fuel Supply Lines | Refer to Procedure 006-024 | K38, K50, QSK38, and QSK50 | 4021528
Fuel Supply Lines | Refer to Procedure 006-024 | QSK45 and QSK60 | 4021530
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | K38, K50, QSK38, and QSK50 | 4021528
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK45 and QSK60 | 4021530
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK19 | 4022094
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK38, QSK50, and QSK60 | 4022102

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the low-pressure fuel system. |
 | STEP 1A. Check the fuel supply pressure sensor. | INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
 | STEP 1B. Check the fuel supply lines. | Any fuel lines damaged, kinked, or restricted?
 | STEP 1C. Check the Stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within specification?
 | STEP 1C-1. Check the fuel filter head. |
 | STEP 1D. Check the fuel supply pressure at the fuel inlet manifold. | Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2216 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the low-pressure fuel system.

Guided Step 1A - Check the fuel supply pressure sensor.

Conditions

  • Connect the Compuchek™ tool.
  • INSITE™ electronic service tool.

Action

  • Record the fuel supply pressure reading on a pressure gauge installed in place of the fuel supply pressure sensor.
  • Use the following procedure for Stage 2 filters in the Measure section of the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-024 in the Associated Procedures Table.
  • Use the following procedure for Stage 2 filters in the Measure section in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-024 in the Associated Procedures Table.

INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2psia] of each other?
YES NO
No Repair

Repair

Replace the fuel supply pressure sensor.

  • Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the fuel supply lines.

Conditions

  • Turn keyswitch OFF.

Action

  • Refer to Procedure 006-024 in the Associated Procedures Table.

Any fuel lines damaged, kinked, or restricted?
YES NO

Repair

Replace the damaged fuel line(s).

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

  • Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in in the Associated Procedures Table.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Repair

Replace the Stage 2 fuel filters.

  • Use the following procedure in the K38,K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-076 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Check the fuel filter head.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

  • Use the following procedure in the K38, K50,QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in Associated Procedures Table.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Repair

Replace the Stage 2 fuel filter head.

  • Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 1D - Check the fuel supply pressure at the fuel inlet manifold.

Conditions

  • Turn keyswitch OFF.

Action

  • Close the fuel supply valve.
  • Remove the M14 STOR plug from the fuel inlet manifold.
  • Install a Compuchek™ fitting, Part Number 3824844, or equivalent, in the fuel inlet manifold.
  • Connect the vacuum gauge and adapter, Part Number 3164491, or equivalent, and digital multimeter, Part Number 3164488 or 3164489,or equivalent, to the Compuchek™ fitting.
  • Open the fuel supply valve.
  • Start and operate the engine at low idle and high idle.
  • Record the fuel inlet pressure readings.

Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
YES NO

Repair

Replace the fuel pump.

  • Use the following procedure the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 005-016 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in the Associated Procedures Table.

Repair

Refer to the equipment manufacturer service information to reduce fuel inlet pressure.

Go to 2A

Go to 2A

Guided Step 2 - Disable and clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2216 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 02-May-2017


FAULT CODE 2261 - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Pump | Refer to Procedure 005-016 | QSK38 and QSK50 | 4021530
Fuel Filter Head | Refer to Procedure 006-017 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Filter Head | Refer to Procedure 006-017 | QSK38 and QSK50 | 4021530
Fuel Inlet Restriction | Refer to Procedure 006-020 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSK38 and QSK50 | 4021530
Fuel Supply Lines | Refer to Procedure 006-024 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Supply Lines | Refer to Procedure 006-024 | QSK38 and QSK50 | 4021530
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK45 and QSK60 | 4021530
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK19 | 4022094
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK38, QSK50, and QSK60 | 4022102

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the low-pressure fuel system. |
 | STEP 1A. Check for active fault codes. | INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
 | STEP 1B. Check the fuel supply lines. | Any fuel lines damaged, kinked, or restricted?
 | STEP 1C. Check the Stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within specification?
 | STEP 1C-1. Check the fuel filter head. |
 | STEP 1D. Check the fuel supply pressure at the fuel inlet manifold. | Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2261 inactive?
 | STEP 2B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the fuel supply pressure fuel system.

Guided Step 1A - Check the fuel supply pressure sensor.

Conditions

  • Connect the Compuchek™ tool.
  • Connect INSITE™ electronic service tool.

Action

Start and operate the engine at high idle.

Record the fuel supply sensor reading in INSITE™ electronic service tool.

Record the fuel supply pressure reading on a pressure gauge installed in place of the fuel supply pressure sensor.

Use the following procedure for Stage 2 filters in the Measure section of the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-024 in in the Associated Procedures Table.

Use the following procedure for Stage 2 filters in the Measure section in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-024 in the Associated Procedures Table.

INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2psia] of each other?
YES NO
No Repair

Repair

Replace the fuel supply pressure sensor.

  • Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the fuel supply lines.

Conditions

  • Turn keyswitch OFF.

Action

  • Refer to Procedure 006-024 in the Associated Procedures Table.

Any fuel lines damaged, kinked, or restricted?
YES NO

Repair

Replace the damaged fuel line(s).

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

  • Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in in the Associated Procedures Table.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Repair

Replace the Stage 2 fuel filters.

  • Use the following procedure in the K38,K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-076 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Check the fuel filter head.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

  • Use the following procedure in the K38, K50,QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in Associated Procedures Table.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Repair

Replace the Stage 2 fuel filter head.

  • Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 1D - Check the fuel supply pressure at the fuel inlet manifold.

Conditions

  • Turn keyswitch OFF.

Action

  • Close the fuel supply valve.
  • Remove the M14 STOR plug from the fuel inlet manifold.
  • Install a Compuchek™ fitting, Part Number 3824844, or equivalent, in the fuel inlet manifold.
  • Connect the vacuum gauge and adapter, Part Number 3164491, or equivalent, and digital multimeter, Part Number 3164488 or 3164489,or equivalent, to the Compuchek™ fitting.
  • Open the fuel supply valve.
  • Start and operate the engine at low idle and high idle.
  • Record the fuel inlet pressure readings.

Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
YES NO

Repair

Replace the fuel pump.

  • Use the following procedure the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 005-016 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in the Associated Procedures Table.

Repair

Refer to the equipment manufacturer service information to reduce fuel inlet pressure.

Go to 2A

Go to 2A

Guided Step 2 - Disable and clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and operate the engine.

Action

Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2261 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 19-Apr-2017


FAULT CODE 2262 - Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check if engine will start or engine starts and dies. |
 | STEP 1A. Attempt to start engine. | Engine starts and continues running?
STEP 2. | Check the low-pressure side of the fuel system. |
 | STEP 2A. Check for external fuel leaks. | Fuel leaking externally?
 | STEP 2B. Check for air in fuel. | Air present in fuel flow?
 | STEP 2C. Check the fuel supply pressure sensor. | INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
 | STEP 2D. Inspect the original equipment manufacturer (OEM) fuel supply hose and fuel tank. | Stage 1 inlet restriction greater than specification?
 | STEP 2E. Check the Stage 1 filter restriction. | Stage 1 inlet restriction less than specification?
STEP 3. | Disable and clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2262 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check if engine will not start or engine starts and dies.

Guided Step 1A - Attempt to start engine.

Conditions

  • Start engine.

Action

Attempt to start the engine.

Check if the engine will not start or if the engine starts and stalls.

Engine starts and continues operating?

YES | NO
No Repair | No Repair

Go to 2A

Reference the Engine Performance troubleshooting symptom tree

Guided Step 2 - Check the low-pressure side of the fuel system.

Guided Step 2A - Check for external fuel leaks.

Conditions

  • Operate engine at idle.

Action

Start the engine and check for external fuel leaks.

Check for external fuel leaks.

Fuel leaking externally?
YES NO

Repair

Repair all fuel leaks.

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-024 in Section 6.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air in fuel.

Conditions

  • Remove air bleed line from air bleed valve on the fuel drain manifold block.
  • Route the air bleed line into a suitable container to collect fuel.
  • Turn keyswitch ON.

Action

Direct the fuel flow from the air bleed line into a container.

Inspect the fuel flow for air.

Use the following procedure in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-003 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-003 in Section 6.

Air present in the fuel flow?
YES NO

Repair

Repair or replace the damaged line or loose connection.

  • Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-024 in Section 6.
No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel supply pressure sensor.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor accuracy.

Start and operate the engine at high idle.

Record the fuel supply sensor reading in INSITE™ electronic service tool.

Shut the engine down and remove the fuel supply pressure sensor. Refer to Procedure 019-398 in Section 19.

Install a pressure gauge.

Start and operate the engine at high idle.

Record the fuel supply pressure reading on a pressure gauge installed in place of the fuel supply pressure sensor.

INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
YES NO

Repair

Install the fuel supply pressure sensor that was removed. Refer to Procedure 019-398 in Section 19.

Repair

Replace the fuel supply pressure sensor. Refer to Procedure 019-398 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM fuel supply hose and fuel tank.

Conditions

  • Turn keyswitch OFF.

Action

Measure fuel inlet restriction at the Stage 1 fuel filter inlet.

  • For K38, K50, and QSK50 Series Engines, use the following procedure in Bulletin 4021528. Refer to Procedure 006-020 in Section 6.
  • For QSK45 and QSK60 Series Engines, use the following procedure in Bulletin 4021530. Refer to Procedure 006-020 in Section 6.

Stage 1 inlet restriction greater than specification?
YES NO

Repair

Refer to the equipment manufacturer service information for repair instructions.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the Stage 1 filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the Stage 1 fuel filter restriction.

  • For K38, K50, and QSK50 Series Engines, use the following procedure in Bulletin 4021528. Refer to Procedure 006-020 in Section 6.
  • For QSK45 and QSK60 Series Engines, use the following procedure in Bulletin 4021530. Refer to Procedure 006-020 in Section 6.

Stage 1 filter restriction less than specification?
YES NO

Repair

Replace the high-pressure pump assembly.

  • For K38, K50, and QSK50 Series Engines, use the following procedure in Bulletin 4021528. Refer to Procedure 005-016 in Section 5.
  • For QSK45 and QSK60 Series Engines, use the following procedure in Bulletin 4021530. Refer to Procedure 005-016 in Section 5.

Repair

Replace the Stage 1 fuel filter.

  • For K38, K50, and QSK50 Series Engines, use the following procedure in Bulletin 4021528. Refer to Procedure 006-075 in Section 6.
  • For QSK45 and QSK60 Series Engines, use the following procedure in Bulletin 4021530. Refer to Procedure 006-075 in Section 6.

Go to 3A

Go to 3A

Guided Step 3 - Disable and clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2262 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 07-Apr-2015


FAULT CODE 2265 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2265 active?
STEP 2. | Check the electric lift pump for engine fuel supply. |
 | STEP 2A. Inspect the engine harness and electric lift pump for engine fuel supply connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the electric lift pump for engine fuel supply. | Resistance less than 20 ohms?
 | STEP 2C. Check for an open circuit in the electric lift pump for engine fuel supply return circuit. | Resistance less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Resistance less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Resistance greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault code 2265 inactive?
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2265 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the electric lift pump for engine fuel supply.

Guided Step 2A - Inspect the engine harness and electric lift pump for engine fuel supply connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the electric lift pump for engine fuel supply connector.

Action

Inspect the engine harness and electric lift pump for engine fuel supply connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged section of harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the electric lift pump for engine fuel supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the electric lift pump engine fuel supply connector.

Action

Check for an open circuit in the electric lift pump for engine fuel supply.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL pin and the electric lift pump for engine fuel supply RETURN pin at the electric lift pump for engine fuel supply connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance less than 20 ohms?
YES NO
No Repair

Repair

Replace the electric lift pump for engine fuel supply.

Use the following procedure from the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 005-045 in Section 5.

Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-045 in Section 5.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the electric lift pump for engine fuel supply return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric lift pump for engine fuel supply connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness electric lift pump for engine fuel supply RETURN pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot each harness connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and electric lift pump for engine fuel supply connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the electric lift pump for engine fuel supply connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL pin at the electric lift pump for engine fuel supply connector and the electric lift pump for engine fuel supply SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot each harness connected in series to determine which contain the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the electric lift pump for engine fuel supply connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2265 inactive?
YES NO

Repair

NOTE: The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2265 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 07-Aug-2012


FAULT CODE 2266 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2266 active?
STEP 2. | Check the electric lift pump for engine fuel supply. |
 | STEP 2A. Inspect the engine harness and electric lift pump for engine fuel supply connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2265 is active and Fault Code 2266 is inactive?
 | STEP 2C. Check the fault codes and verify electric lift pump for engine fuel supply condition. | Fault Code 2266 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM circuit response. | Fault Code 2265 active and Fault Code 2266 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Resistance greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Resistance greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2266 is inactive?
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2266 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the electric lift pump for engine fuel supply.

Guided Step 2A - Inspect the engine harness and electric lift pump for engine fuel supply connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the electric lift pump for engine fuel supply connector.

Action

Inspect the engine harness and electric lift pump for engine fuel supply connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness or damaged electric lift pump for engine fuel supply connector.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric lift pump for engine fuel supply for engine fuel supply connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 is active and Fault Code 2266 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify electric lift pump for engine fuel supply condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the electric lift pump for engine fuel supply to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 is active?
YES NO

Repair

A damaged electric lift pump for engine fuel supply has been detected.

Replace the damaged electric lift pump.

  • Use the following procedure from the K38, K50, and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 005-045 in Section 5.
  • Use the following procedure from the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-045 in Section 5.

Repair

NOTE: Removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2265 is active and Fault Code 2266 is inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the electric lift pump for engine fuel supply connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the electric lift pump for engine fuel supply SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the electric lift pump for engine fuel supply connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the electric lift pump for fuel supply SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2266 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 07-Aug-2012


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the fuel pump pressurizing assembly 1. |
 | STEP 2A. Inspect the fuel pump pressurizing assembly 1 and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel pump pressurizing assembly 1 resistance. | Resistance less than 5 ohms?
 | STEP 2C. Check the fuel pump pressurizing assembly 1 for a short to ground. | Resistance greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Resistance less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Resistance greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Codes 2311, 271, and/or 272 become active?
STEP 4. | Disable and clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the fuel pump pressurizing assembly 1 is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel pump pressurizing assembly 1.

Guided Step 2A - Inspect the fuel pump pressurizing assembly 1 and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Inspect the fuel pump pressurizing assembly 1, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair

Repair the connector and pins.

Replace the damaged section of the harness or damaged fuel pump pressurizing assembly 1.

Refer to the wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel pump pressurizing assembly 1 resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check the fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin and the fuel pump pressurizing assembly 1 RETURN pin at the fuel pump pressurizing assembly 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance less than 5 ohms?
YES NO
No Repair

Repair

Replace the fuel pump pressurizing assembly 1. Refer to Procedure 019-117 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump pressurizing assembly 1 for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check the fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair

Replace the fuel pump pressurizing assembly 1. Refer to Procedure 019-117 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump pressurizing assembly 1 connector to the engine harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin and the fuel pump pressurizing assembly 1 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance less than 5 ohms?
YES NO
No Repair

Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check the engine harness and fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the fuel pump pressurizing assembly 1.

If a short or open circuit is induced while the engine is running, the mechanical dump valve will open.

Fault Codes 2311, 271, and/or 272 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the fuel pump pressurizing assembly 1. Refer to Procedure 019-117 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Disable and clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 21-Apr-2012


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2377 is inactive?
STEP 2. | Check the fan control and circuit. |
 | STEP 2A. Inspect the fan control and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control. | Does the resistance meet the manufacturer's specification?
 | STEP 2C. Check the fan control diagnostic supply voltage, supply wire and return circuit. | Greater than 5.0-VDC?
STEP 3. | Check the ECM OEM harness and engine harness. |
 | STEP 3A. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2377 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fan control and circuit.

Guided Step 2A - Inspect the fan control and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the OEM harness connector.

Action

Inspect the OEM and engine harnesses and fan control connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the fan control or harness connector.

Clean the connector and pins.

Replace the damaged section of harness connected in series or damaged fan control.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-045 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the OEM harness connector.

Action

Check fan control resistance.

  • Measure the resistance between the fan control SIGNAL pin and the fan control RETURN (sensor return 1) pin at the fan control connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Does the resistance meet the manufacturer's specification?
YES NO
No Repair

Repair

An open circuit in the fan control has been detected.

Replace the fan control.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the fan control return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the fan control RETURN (sensor return 1) pin in the engine harness and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the fan control RETURN (sensor return 1) wire has been detected. Refer to the OEM wiring diagram for the fan control RETURN (sensor return 1) wire configuration.

If the fan control RETURN (sensor return 1) wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect all OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connector connections.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM, OEM or engine harness connector.

Clean the connector and pins.

Replace the damaged section of any harness connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the fan control connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM fan control SIGNAL pin and the OEM harness fan control connector fan control SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the foolowing procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open fan control SIGNAL circuit has been detected in the OEM harness.

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the fan control connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fan control SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the fan control SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all interconnections. Replace the damaged section of harness.

  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2377 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Apr-2012


FAULT CODE 2474 - Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2474 inactive?
STEP 2. | Check the engine harness |
 | STEP 2A. Inspect the engine harness and turbocharger 1 speed sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code. | Fault Code 2474 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2474 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness

Guided Step 2A - Inspect the engine harness and turbocharger 1 speed sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector for the ECM 60-pin connector.
  • Disconnect the engine harness connector from the turbocharger 1 speed sensor connector.

Action

Inspect the engine harness connector, ECM connector, and turbocharger 1 speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or ECM connector or turbocharger 1 speed sensor connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or turbocharger 1 speed sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-390 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the turbocharger 1 speed sensor connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger 1 speed SIGNAL pin and the engine harness sensor connector turbocharger 1 speed SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector turbocharger 1 speed RETURN pin and the engine harness sensor connector turbocharger 1 speed RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open turbocharger 1 speed SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the turbocharger 1 speed sensor connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger 1 speed SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the turbocharger 1 speed SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the turbocharger 1 speed sensor connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the turbocharger 1 speed SIGNAL pin in the ECM engine harness connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground on the turbocharger 1 speed SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the short circuit to ground.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code in inactive.

Fault Code 2474 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Apr-2012


FAULT CODE 2557 - Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 2. | Check the pulse width modulated (PWM) OEM device. |
 | STEP 2A. Inspect the pulse width modulated OEM device and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the pulse width modulated OEM device. | Resistance is within OEM specification?
 | STEP 2C. Check for an open circuit in the output device driver return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect all OEM, ECM, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness or engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2557 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the pulse width modulated OEM device and circuit.

Guided Step 2A - Inspect the pulse width modulated OEM device and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulated OEM device from the OEM harness.

Action

Inspect the OEM and engine harnesses and the pulse width modulated OEM device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the OEM device or harness connector.

Clean the connector and pins.

Replace the damaged section of harnesses connected in series or damaged solenoid.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the pulse width modulated OEM device.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulated OEM device connector from the OEM harness connector.

Action

Check the pulse width modulated OEM device resistance.

  • Measure the resistance between the auxiliary PWM driver 1 SIGNAL pin and the RETURN pin at the pulse width modulated OEM device connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance is within OEM specification?
YES NO
No Repair

Repair

Replace the pulse width modulated OEM device.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the output device driver return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulated OEM device from the OEM harness connector.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the output device driver RETURN pin at the pulse width modulated OEM device connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the RETURN wire has been detected.

Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the harnesses connected in series.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean and repair, or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect all OEM, ECM, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connector connections.

Action

Inspect the OEM and engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harnesses connected in series.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the pulse width modulated OEM device from the OEM harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the auxiliary PWM driver 1 SIGNAL pin at the PWM actuated OEM device connector and the auxiliary PWM driver 1 SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the auxiliary PWM driver 1 SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the pulse width modulated OEM device from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the auxiliary PWM driver 1 SIGNAL pin in the engine ECM connector and all other pins in the engine ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the auxiliary PWM driver 1 SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2557 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-Aug-2012


FAULT CODE 2558 - Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2558 inactive?
STEP 2. | Check the pulse width modulated (PWM) OEM device and circuit. |
 | STEP 2A. Inspect the pulse width modulated OEM device and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the pulse width modulated OEM device. | Resistance is within OEM specification?
 | STEP 2B-1. Check for a short to ground in the pulse width modulated OEM device. |
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect all ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2558 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2558 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the pulse width modulated OEM device and circuit.

Guided Step 2A - Inspect the pulse width modulated OEM device and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulated OEM device from the OEM harness.

Action

Inspect the OEM and engine harnesses and pulse width modulated OEM device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the OEM device or harness connector.

Clean the connector and pins.

Replace the damaged section of harnesses connected in series or damaged OEM device.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the pulse width modulated OEM device.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulated OEM device connector from the OEM harness connector.

Action

Check the modulator actuated OEM device resistance.

  • Measure the resistance between the auxiliary pulse width modulated driver 1 SIGNAL pin and the RETURN pin at the pulse width modulated OEM device connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance is within OEM specification?
YES NO
No Repair

Repair

Replace the pulse width modulated OEM device. Refer to the OEM service manual.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a short to ground in the pulse width modulated OEM device.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulated OEM device connector from the OEM harness connector.

Action

Check for a modulator actuated OEM device output short to ground.

  • Measure the resistance between the auxiliary pulse width modulated driver 1 SIGNAL pin and ground at the pulse width modulated OEM device connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the pulse width modulated OEM device. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect all ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the ECM, OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM, OEM harness, or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness connected in series or damaged ECM.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the PWM actuated OEM device from the OEM harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the auxiliary pulse width modulated driver 1 SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the auxiliary pulse width modulated driver 1 SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the pulse width modulated actuated OEM device from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the auxiliary PWM driver 1 SIGNAL pin in the engine ECM connector and all other pins in the engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the auxiliary pulse width modulated driver 1 SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2558 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-Aug-2012


FAULT CODE 2619 - Auxiliary Equipment Sensor Input 1 Engine Protection Critical - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify if the engine stop button is in the STOP position. |
 | STEP 1A. Verify if the engine stop button is in the STOP position. | Engine stop button in the STOP position?
 | STEP 1B. Check Diesel Control Unit (DCU) information. | DCU shows a stop button event or witness test?
 | STEP 1C. Check for other fault codes. | Active or inactive fault codes?
STEP 2. | Check for correct position of the air shutoff valves. |
 | STEP 2A. Check for correct position of the air shutoff valves. | Air shutoff valves in the OPEN position?
STEP 3. | Check the engine stop button for short circuit. |
 | STEP 3A. Check the engine stop button for short circuit. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 4C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Inspect the OEM harness and 23-pin connectors. | Dirty or damaged pins?
 | STEP 5B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 5C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 6. | Check the Customer Interface Box (CIB) internal wiring. |
 | STEP 6A. Check the Customer Interface Box (CIB) internal wiring between the E-stop button and the 23-pin OEM connector. | Dirty or damaged pins?
 | STEP 6B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 6C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 7. | Clear the fault codes and check for progressive damage. |
 | STEP 7A. Confirm conditions. | Snapshot data shows Fault Code 2619 was set at or below idle and 10 percent torque?
 | STEP 7B. Complete checks with engine off. | Hump hoses and turbochargers meet specifications?
 | STEP 7C. Disable the fault code. | Fault Code 2619 inactive?
 | STEP 7D. Check gaskets at load. | Damage to gaskets detected?
 | STEP 7E. Disable the fault code. | Fault Code 2619 inactive?
 | STEP 7F. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the engine stop button is in the STOP position.

Guided Step 1A - Verify the engine stop button is in the STOP position.

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Verify the engine stop button is in the STOP position.

Engine stop button in the STOP position?
YES NO

Repair

Reset the engine stop button.

 No Repair

Go to 8A

Go to 1B

Guided Step 1B - Check Diesel Control Unit (DCU) information (marine only).

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Check DCU information.

Check the event log in the DCU for an engine stop button event or an engine protection overspeed witness test. Use the following procedure in the Marine C Command Elite™ and C Command Elite Plus™ Panel Systems Master Repair Manual, Bulletin 4021617. Refer to Procedure 101-013 in Section 1.

DCU shows a stop button event or witness test?
YES NO

Repair

Reset the engine stop button or move out of test mode. Use the following procedure in the Marine C Command Elite™ and C Command Elite Plus™ Panel Systems Master Repair Manual, Bulletin 4021617. Refer to Procedure 101-013 in Section 1.

No Repair

Go to 7A

Go to 1C

Guided Step 1C - Check for other fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault code.

Active or inactive fault codes?
YES | NO
No Repair | No Repair

Troubleshoot other fault codes and return to this fault code.

Go to 2A

Guided Step 2 - Check for correct position of the air shutoff valves.

Guided Step 2A - Check for correct position of the air shutoff valves.

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Check that all of the air shutoff valves are in the OPEN position.

Air shutoff valves in the OPEN position?
YES NO
No Repair

Repair

Refer to the OEM service manual.

Go to 3A

Go to 7A

Guided Step 3 - Check the engine stop button for short a circuit.

Guided Step 3A - Check the engine stop button for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect wires from NO (Normally Open) engine stop switch terminals. The NO engine stop switch is the middle switch of the three terminals.

Action

Check for a short circuit.

  • Measure the resistance between the NO (Normally Open) switch terminals.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the engine stop button. Use the procedure in the Marine C Command Elite™ and C Command Elite Plus™ Panel Systems Master Repair Manual, Bulletin 4021617. Refer to Procedure 015-023 in Section 15.

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 7A

Go to 5B

Guided Step 4B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the OEM switch/dual output B pin of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the OEM switch/dual output B-pin of the engine harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Inspect the OEM harness and 23-pin connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.

Action

Inspect the OEM harness and 23-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from the OEM switch/dual output B pin of the 23-pin OEM harness connector, OEM side, to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the OEM switch/dual output B-pin of the 23-pin OEM harness connector, OEM side, to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the Customer Interface Box (CIB) internal wiring.

Guided Step 6A - Check the CIB internal wiring between the E-stop button and the 23-pin OEM connector (Marine).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.

Action

Inspect the 23-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 7A

Go to 6B

Guided Step 6B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from the OEM switch/dual output B pin of the 23-pin OEM harness connector, OEM side, to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the CIB harness. Refer to Procedure 019-071 in Section 19.

Go to 6C

Go to 7A

Guided Step 6C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the CIB at the 23-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the OEM switch/dual output B pin of the 23-pin OEM harness connector, OEM side, to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the CIB harness. Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes and check for progressive damage.

Guided Step 7A - Confirm conditions.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Confirm the conditions of the engine.

  • Use INSITE™ electronic service tool to view the fault code snapshot data to verify the conditions of the engine when Fault Code 2619 occured.

Snapshot data shows that Fault Code 2619 was set at or below idle and 10 percent torque?
YES NO
No Repair

Repair

Check the engine for progressive damage.

Go to 7E

Go to 7B

Guided Step 7B - Complete checks with engine OFF.

Conditions

  • Turn keyswitch OFF.

Action

Perform the following inspections:

  • Inspect the hump hoses for signs of damage or leakage.
  • Check the turbocharger shaft end clearance. Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 010-033 in Section 10. Use the following procedure in the QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 010-033 in Section 10.
  • Inspect the turbocharger compressor impeller wheel.

Hump hoses and turbochargers meet specifications?
YES NO
No Repair

Repair

Replace the damaged components. Use the following procedures in the QSK45 and QSK60 Service Manual, Bulletin 4021530:

  • Refer to Procedure 010-034 in Section 10.
  • Refer to Procedure 010-035 in Section 10.

Go to 7C

Go to 7C

Guided Step 7C - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2619 is inactive.

Fault Code 2619 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 7D

Go to 1A

Guided Step 7D - Check gaskets at load.

Conditions

  • Turn keyswitch ON.

Action

Operate the engine with load and check the gaskets.

  • Start the engine and load it.
  • Check and listen for any noise associated with head gasket or aftercooler gasket leaks.

Damage to gaskets detected?
YES NO

Repair

Replace gaskets as necessary. Use the following procedures in the QSK45 and QSK60 Service Manual, Bulletin 4021530:

  • For head gasket repair: Refer to Procedure 002-021 in Section 2.
  • For aftercooler gasket repair: Refer to Procedure 010-002 in Section 10.

Use the following procedures in the QSK38 and QSK50 Service Manual, Bulletin 4021528:

  • For head gasket repair: Refer to Procedure 002-021 in Section 2.
  • For aftercooler gasket repair: Refer to Procedure 010-002 in Section 10.
No Repair

Go to 7E

Go to 7E

Guided Step 7E - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic serivce tool to verify Fault Code 2619 is inactive.

Fault Code 2619 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 7F

Go to 1A

Guided Step 7F - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting tree

Last Modified: 07-Aug-2012


FAULT CODE 2651 - Engine Exhaust Gas Temperature - Right Manifold Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2651 inactive?
STEP 2. | Check the exhaust gas temperature right manifold sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature right manifold sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 84.6 to 465.7l ohms?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C-1. Check for an open circuit in the engine harness. |
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2651 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins
 | STEP 3B. Check the ECM response. | Fault Code 2652 active and Fault Code 2651 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2651 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2651 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature right manifold sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature right manifold sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the exhaust gas temperature right manifold sensor connector.
  • Disconnect the engine harness connector pins for the following:

Action

Inspect the exhaust gas temperature right manifold sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature right manifold sensor connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature right manifold sensor connector from the engine harness connector.

Action

Check the exhaust gas right manifold sensor temperature sensor 2 (right bank) resistance.

  • Measure the resistance between the exhaust gas temperature right manifold sensor SIGNAL pin and exhaust gas temperature right manifold sensor RETURN (sensor return 1) pin at the exhaust gas temperature right manifold sensor 1 (right bank).

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

84.6 to 465.7k ohms?
YES NO
No Repair

Repair

A damaged exhaust gas temperature right manifold sensor has been detected.

  • Replace the exhaust gas temperature right manifold sensor. Refer to Procedure 019-013 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature right manifold sensor from the engine harness connector.
  • Disconnect the engine harness from the 47-pin right bank harness connector.

Action

Check the exhaust gas right manifold sensor temperature sensor 2 (right bank) resistance.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature right manifold sensor RETURN (sensor return 1) wire in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C-1

Go to 4A

Guided Step 2C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature right manifold sensor from the engine harness connector.
  • Disconnect the engine harness from the 47-pin right bank harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature right manifold sensor SIGNAL pin in the exhaust gas temperature right manifold sensor engine harness connector to the exhaust gas temperature right manifold sensor circuit SIGNAL pin in the 47-pin right bank harness connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature right manifold sensor SIGNAL wire in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to read the fault codes.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 active?
YES NO
No Repair

Repair

None. the removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector form the ECM 60-pin connector.
  • Disconnect the engine harness from the 47-pin right bank harness connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed bank or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas temperature right manifold sensor SIGNAL pin and exhaust gas temperature right manifold sensor RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2652 active and Fault Code 2651 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness from the 47-pin right bank harness connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the exhaust gas temperature right manifold sensor RETURN (sensor return 1) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature right manifold sensor RETURN (sensor return 1) pin in the 47-pin right bank harness connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature right manifold sensor RETURN (sensor return 1) wire in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness from the 47-pin right bank harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature right manifold sensor SIGNAL pin in the engine harness ECM 60-pin connector to the exhaust gas temperature right manifold sensor SIGNAL pin in the 47-pin right bank harness connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature right manifold sensor SIGNAL wire in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness from the 47-pin right bank harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature right manifold sensor SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected on the exhaust gas temperature right manifold sensor SIGNAL wire in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

The troubleshooting steps need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Diable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2651 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Aug-2012


FAULT CODE 2652 - Engine Exhaust Gas Temperature - Right Manifold Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2652 active?
STEP 2. | Check the exhaust gas temperature right manifold sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature right manifold sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 2651 active and Fault Code 2652 inactive?
 | STEP 2E. Check the fault codes and verify the sensor condition. | Fault Code 2652 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2551 active and Fault Code 2652 inactive?
 | STEP 3C. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2652 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2652 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2652 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature right manifold sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature right manifold sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the exhaust gas temperature right manifold sensor connector.
  • Disconnect the engine harness from the 47-pin right bank harness connector.

Action

Inspect the exhaust gas temperture sensor right manifold sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or on the connector
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature right manifold sensor connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section harness.

Check all harnesses connected in series.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature right manifold sensor connector from the engine harness connector.
  • Disconnect the engine harness from the 47-pin right bank harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature right manifold sensor SIGNAL pin of the 47-pin right bank harness connector and all other pins in the 47-pin right bank harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the exhaust gas temperature right manifold sensor SIGNAL wire has been detected in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature left manifold sensor connector from the engine harness connector.
  • Disconnect the engine harness from the 47-pin left bank harness connector.

Action

Check for a ground short.

  • Measure the resistance between the exhaust gas temperature left manifold sensor signal pin of the 47-pin left bank harness connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the exhaust gas temperature 1 (left bank) SIGNAL wire has been detected in the engine harness.

Replace the damaged section of engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature right manifold sensor circuit connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 active and 2652 inactive?
YES | NO
No Repair | No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the apprpriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2652 active?
YES NO

Repair

A damaged exhaust gas temperature right manifold sensor has been detected.

Replace the exhaust gas temperature right manifold sensor. Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness from the 47-pin right bank harness connector.

Action

Inspect the engine harness and ECM connector pins for the follwoing:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or on the connector
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas temperature right manifold sensor SIGNAL pin and exhaust gas temperature right manifold sensor RETURN (sensor return pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the exhaust gas temperature right manifold sensor SIGNAL wire has been detected in the engine harness.

Replace the damaged section of the engine harness harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the 47-pin right bank harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature right manifold sensor SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram from connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the exhaust gas temperature right manifold sensor RETURN (sensor return 1) wire has been detected in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2652 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

The troubleshooting steps need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2652 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Aug-2012


FAULT CODE 2653 - Engine Exhaust Gas Tempertature - Right Manifold - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine exhaust gas temperature right manifold sensor accuracy. |
 | STEP 1A. Verify the engine exhaust gas temperature right manifold sensor accuracy. | Engine exhaust gas temperature right manifold sensor reading is correct?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2653 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine exhaust gas temperature right manifold sensor accuracy.

Guided Step 1A - Verify the engine exhaust gas temperature right manifold sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor accuracy.

  • Start engine.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port of the exhaust gas temperature right manifold sensor.

Compare the infrared thermometer temperature measurement with the engine exhaust gas temperature right manifold sensor reading on the service tool monitor screen.

Engine exhaust gas temperature right manifold sensor reading is correct?
YES NO

Repair

Possible cylinder or injector damage must be investigated.

  • Reference the appropriate troubleshooting symptom tree in Section TS.

Repair

A damaged exhaust gas temperature sensor 2 (right bank) has been detected.

  • Replace the engine exhaust gas temperature right manifold sensor. Refer to Procedure 019-013 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2653 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Aug-2012


FAULT CODE 2654 - Engine Exhaust Gas Temperature - Right Manifold - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine exhaust gas temperature right manifold sensor circuit accuracy. |
 | STEP 1A. Verify the engine exhaust gas temperature right manifold sensor circuit accuracy. | Engine exhaust gas temperature right manifold sensor circuit reading is correct?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2654 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine exhaust gas temperature right manifold sensor circuit accuracy.

Guided Step 1A - Verify the engine exhaust gas temperature right manifold sensor circuit accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor accuracy.

  • Start engine.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port of the exhaust gas temperature right manifold sensor.

Compare the infrared thermometer temperature measurement with the exhaust gas temperature right manifold sensor reading on the service tool monitor screen.

Engine exhaust gas temperature right manifold sensor circuit reading is correct?
YES NO

Repair

Possible cylinder or injector damage must be investigated.

Reference the appropriate troubleshooting symptom tree in Section TS.

Repair

A damaged exhaust gas temperature right manifold sensor has been detected.

  • Replace the engine exhaust gas temperature right manifold sensor. Refer to Procedure 019-013 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2654 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Aug-2012


FAULT CODE 2655 - Engine Exhaust Gas Temperature - Left Manifold Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2655 inactive?
STEP 2. | Check the exhaust gas temperature left manifold sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature left manifold sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 84.6 to 465.7l ohms?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C-1. Check for an open circuit in the engine harness. |
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2655 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins
 | STEP 3B. Check the ECM response. | Fault Code 2656 active and Fault Code 2655 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2655 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2655 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature left manifold sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature left manifold sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the exhaust gas temperature left manifold sensor connector.
  • Disconnect the engine harness connector pins for the following:

Action

Inspect the exhaust gas temperature left manifold sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature left manifold sensor connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature left manifold sensor connector from the engine harness connector.

Action

Check the exhaust gas left manifold sensor temperature sensor 2 (right bank) resistance.

  • Measure the resistance between the exhaust gas temperature left manifold sensor SIGNAL pin and exhaust gas temperature left manifold sensor RETURN (sensor return 1) pin at the exhaust gas temperature left manifold sensor 1 (left bank).

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

84.6 to 465.7k ohms?
YES NO
No Repair

Repair

A damaged exhaust gas temperature left manifold sensor has been detected.

  • Replace the exhaust gas temperature left manifold sensor. Refer to Procedure 019-013 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature left manifold sensor from the engine harness connector.
  • Disconnect the engine harness from the 47-pin left bank harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature left manifold sensor RETURN (sensor return 1) pin in the exhaust gas temperature left manifold sensor circuit engine harness connector to the exhaust gas temperature left manifold sensor RETURN (sensor return 1) pin in the 47-pin left bani harness connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature left manifold sensor RETURN (sensor return 1) wire in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C-1

Go to 4A

Guided Step 2C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature left manifold sensor from the engine harness connector.
  • Disconnect the engine harness from the 47-pin left bank harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature left manifold sensor SIGNAL pin in the exhaust gas temperature left manifold sensor engine harness connector to the exhaust gas temperature left manifold sensor circuit SIGNAL pin in the 47-pin left bank harness connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature left manifold sensor SIGNAL wire in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to read the fault codes.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 active?
YES NO
No Repair

Repair

None. the removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector form the ECM 60-pin connector.
  • Disconnect the engine harness from the 47-pin left bank harness connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed bank or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the ECM or OEM or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas temperature left manifold sensor SIGNAL pin and exhaust gas temperature left manifold sensor RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2656 active and Fault Code 2655 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness from the 47-pin left bank harness connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the exhaust gas temperature left manifold sensor RETURN (sensor return 1) pin in the engine harness ECM 60-pin connector to the exhaust gas temperature left manifold sensor RETURN (sensor return 1) pin in the 47-pin left bank harness connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature left manifold sensor RETURN (sensor return 1) wire in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness from the 47-pin left bank harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature left manifold sensor SIGNAL pin in the engine harness ECM 60-pin connector to the exhaust gas temperature left manifold sensor SIGNAL pin in the 47-pin left bank harness connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected on the exhaust gas temperature left manifold sensor SIGNAL wire in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness from the 47-pin left bank harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature left manifold sensor SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected on the exhaust gas temperature left manifold sensor SIGNAL wire in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

The troubleshooting steps need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Diable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2655 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Aug-2012


FAULT CODE 2656 - Engine Exhaust Gas Temperature - Left Manifold Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2656 active?
STEP 2. | Check the exhaust gas temperature left manifold sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature left manifold sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 2655 active and Fault Code 2656 inactive?
 | STEP 2E. Check the fault codes and verify the sensor condition. | Fault Code 2656 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2555 active and Fault Code 2656 inactive?
 | STEP 3C. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2656 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2656 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2656 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature left manifold sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature left manifold sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the exhaust gas temperature left manifold sensor connector.
  • Disconnect the engine harness from the 47-pin left bank harness connector.

Action

Inspect the exhaust gas temperture sensor left manifold sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or on the connector
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature left manifold sensor connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section harness.

Check all harnesses connected in series.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature left manifold sensor connector from the engine harness connector.
  • Disconnect the engine harness from the 47-pin left bank harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature left manifold sensor SIGNAL pin of the 47-pin left bank harness connector and all other pins in the 47-pin left bank harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the exhaust gas temperature left manifold sensor SIGNAL wire has been detected in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature left manifold sensor connector from the engine harness connector.
  • Disconnect the engine harness from the 47-pin left bank harness connector.

Action

Check for a ground short.

  • Measure the resistance between the exhaust gas temperature left manifold sensor signal pin of the 47-pin left bank harness connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the exhaust gas temperature 1 (left bank) SIGNAL wire has been detected in the engine harness.

Replace the damaged section of engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the foolowing procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature left manifold sensor circuit connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 active and 2656 inactive?
YES | NO
No Repair | No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2656 active?
YES NO

Repair

A damaged exhaust gas temperature left manifold sensor has been detected.

Replace the exhaust gas temperature left manifold sensor.

Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness from the 47-pin left bank harness connector.

Action

Inspect the engine harness and ECM connector pins for the follwoing:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or on the connector
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas temperature left manifold sensor SIGNAL pin and exhaust gas temperature left manifold sensor RETURN (sensor return pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2655 active and Fault Code 2656 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the 47-pin left bank harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the exhaust gas temperature 1 (left bank) SIGNAL pin of the ECM 60-pin engine harness connector to and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the exhaust gas temperature 1 (left bank) SIGNAL wire has been detected in the engine harness.

Replace the damaged section of engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the 47-pin left bank harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature left manifold sensor SIGNAL pin in the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or the wiring diagram from connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the exhaust gas temperature left manifold sensor RETURN (sensor return 1) wire has been detected in the engine harness.

Replace the damaged section of the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2656 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

The troubleshooting steps need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2656 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Aug-2012


FAULT CODE 2657 - Engine Exhaust Gas Temperature - Left Manifold - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine exhaust gas temperature left manifold sensor circuit accuracy. |
 | STEP 1A. Verify the engine exhaust gas temperature left manifold sensor circuit accuracy. | Engine exhaust gas temperature left manifold sensor circuit reading is correct?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2657 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine exhaust gas temperature left manifold sensor circuit accuracy.

Guided Step 1A - Verify the engine exhaust gas temperature left manifold sensor circuit accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor accuracy.

  • Start engine.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port of the exhaust gas temperature left manifold sensor.

Compare the infrared thermometer temperature measurement with the exhaust gas temperature left manifold sensor reading on the service tool monitor screen.

Engine exhaust gas temperature left manifold sensor circuit reading is correct?
YES NO

Repair

Possible cylinder or injector damage must be investigated.

  • Reference the appropriate troubleshooting symptom tree in Section TS.

Repair

A damaged exhaust gas temperature sensor has been detected. Replace the engine exhaust gas temperature left manifold sensor.

  • Refer to Procedure 019-013 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2657 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Aug-2012


FAULT CODE 2658 - Engine Exhaust Gas Temperature - Left Manifold - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine exhaust gas temperature left manifold sensor circuit accuracy. |
 | STEP 1A. Verify the engine exhaust gas temperature left manifold sensor circuit accuracy. | Engine exhaust gas temperature left manifold sensor reading is correct?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2658 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine exhaust gas temperature left manifold sensor circuit accuracy.

Guided Step 1A - Verify the engine exhaust gas temperature left manifold sensor circuit accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor accuracy.

  • Start engine.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port of the exhaust gas temperature left manifold sensor.

Compare the infrared thermometer temperature measurement with the engine exhaust gas temperature left manifold sensor reading on the service tool monitor screen.

Engine exhaust gas temperature left manifold sensor reading is correct?
YES NO

Repair

Possible cylinder or injector damage must be investigated.

  • Reference the appropriate troubleshooting symptom tree in Section TS.

Repair

A damaged exhaust gas temperature left manifold sensor has been detected. Replace the engine exhaust gas temperature left manifold sensor.

  • Refer to Procedure 019-013 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2658 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Aug-2012


FAULT CODE 2661 - At Least One Unacknowledged Most Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2661 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive fault codes?
YES NO

Repair

Troubleshoot other fault codes before acknowledging this fault code.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM-supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2661 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Aug-2012


FAULT CODE 2662 - At Least One Unacknowledged Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2662 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive fault codes?
YES NO

Repair

Troubleshoot other fault codes before acknowledging this fault code.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM-supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2662 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Aug-2012


FAULT CODE 2697 - Accelerator Pedal or Lever Idle Validation Switch Circuit - Out of Calibration

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2697 active?
STEP 2. | Check the fault codes. |
 | STEP 2A. Perform the fault code disable procedure. | Fault Code 2697 active?
STEP 3. | Check the OEM harness and the engine harness. |
 | STEP 3A. Inspect all OEM harness and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the accelerator pedal or lever position sensor resistance. | 1500 to 3000 ohms (released), 250 to 1500 ohms (depressed)?
 | STEP 3B-1. Check the resistance of the accelerator pedal or lever position sensor. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2697 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2697 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fault codes.

Guided Step 2A - Perform the fault code disable procedure.

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Perform the fault code disable procedure.

  • Slowly depress the accelerator pedal or lever to the full throttle position and release it completely three times.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2697 active?
YES NO
No Repair

Repair

Replace the accelerator pedal or lever assembly. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness and engine harness.

Guided Step 3A - Inspect the OEM harness and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the OEM or engine harness.

Clean the connector and pins.

Repair or replace the damaged section of the harness.

Refer to the OEM service manual.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the accelerator pedal position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect all harness connections.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor resistance.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position 5-volt SUPPLY (sensor supply 4) pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin for identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 ohms (released) or 250 to 1500 ohms (depressed)?

NOTE: Released value must be at least 1000 ohms greater than depressed value.

YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check the resistance of the accelerator pedal position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check the resistance.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position 5-volt SUPPLY (sensor supply 4) pin at the sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin for identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 ohms (released) or 250 to 1500 ohms (depressed)?

NOTE: Released value must be at least 1000 ohms greater than depressed value.

YES NO

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the accelerator pedal or lever assembly. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Short circuit on one connector pin-to-pin check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

  • Accelerator pedal or lever position 5-volt SUPPLY (sensor supply 4) pin
  • Accelerator pedal or lever position SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Replace the damaged section of the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever 3 times.
  • Turn the keyswitch OFF for 30 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 432 is inactive.

Fault Code 2697 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Aug-2012


FAULT CODE 2727 - SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2727 active?
STEP 2. | Check the original equipment manufacturer (OEM) power harness and engine harness. |
 | STEP 2A. Inspect the 4-pin power connector and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the battery power circuits. | Voltage between 10.0 to 15.0-VDC for 12 volt system or 21 to 27-VDC for 24 volt system?
 | STEP 2C. Check the battery supply for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive (+) battery terminal. | Damaged wires?
 | STEP 2E. Check the ignition input-to-ECM wire. | Ignition wire uninterrupted?
 | STEP 2F. Check the ignition input circuit. | Less than 5 ohms?
STEP 3. | Check the Society of Automotive Engineering (SAE) J1939 data link 2 circuit. |
 | STEP 3A. Inspect all engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link 2 engine network resistance in the engine harness. | Between 54 to 66 ohms?
 | STEP 3C. Check the SAE J1939 data link 2 engine network terminator resistor. | Between 108 to 132 ohms?
 | STEP 3D. Check for ECM communication to INSITE™ electronic service tool. | Does the ECM communicate?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2727 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2727 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM power harness and engine harness.

Guided Step 2A - Inspect the 4-pin power connector and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power connector from the ECM.

Action

Inspect the ECM harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the battery power circuits.

Conditions

  • Reference the circuit diagram or wiring diagram for connector pin for identification.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage between the battery voltage SUPPLY pin in the 4-pin power connector to engine block ground.
  • Reference the circuit diagram or wiring diagram for connector pin for identification.

Voltage between 10.0 to 15.0 VDC for 12 volt system or 21 to 27 VDC for 24 volt system?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the battery supply for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 4-pin power harness connector from the ECM connector.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from a battery voltage SUPPLY pin in the 4-pin power connector to all other pins in the connector.
  • Measure the resistance from a battery voltage RETURN pin in the 4-pin power connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) battery terminal.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) battery terminal.

  • Starting at the positive (+) battery terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ignition input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the ignition input-to-ECM wire.

  • Inspect the ignition wire from the ignition post in the ignition assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch wire uninterrupted?
YES NO
No Repair

Repair

Correct the wiring so the wire is uninterrupted.

Go to 2F

Go to 4A

Guided Step 2F - Check the ignition input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Check the ignition input circuit.

  • Measure the resistance from the ignition post in the ignition assembly to the ignition input SUPPLY pin of the 50-pin engine harness connector.

Less than 5 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the SAE J1939 data link 2 circuit.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 60-pin connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector or ECM connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Replace the damaged section of the engine harness or the ECM. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to Procedure Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3D

Go to 3B

Guided Step 3B - Check the SAE J1939 data link 2 engine network resistance in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check the SAE J1939 data link 2 engine network resistance.

  • Measure the resistance between the SAE J1939 data link 2 engine network SUPPLY pin and the SAE J1939 data link 2 engine network RETURN pin in the ECM engine harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin for identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 54 to 66 ohms?
YES NO

Repair

The SAE J1939 data link 2 engine network resistance is within specification.

There is a problem in the calibration.

Check to make sure the appropriate calibrations are installed in the ECMs.

 No Repair

Go to 3D

Go to 3C

Guided Step 3C - Check the SAE J1939 data link 2 engine network terminator resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect one of the SAE J1939 data link 2 engine network terminator resistors from the engine harness.

Action

Check the SAE J1939 data link 2 engine network resistance.

Measure the resistance between the SAE J1939 data link 2 engine network SUPPLY pin and the SAE J1939 data link 2 engine network RETURN pin in the ECM engine harness connector.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 108 to 132 ohms?
YES NO

Repair

The removed SAE J1939 data link 2 engine network terminator resistor is damaged.

  • Replace the SAE J1939 data link 2 engine network terminator resistor. Refer to Procedure 019-428 in Section 19.

Repair

An open or shorted engine SAE J1939 data link 2 circuit or damaged terminator resistor still connected to the harness has been detected.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the teminator resistor. Refer to Procedure 019-428 in Section 19.

Go to 3D

Go to 3D

Guided Step 3D - Check for ECM communication to INSITE™ electronic service tool.

Conditions

  • INSITE™ electronic service tool connected to the vehicle.
  • Turn keyswitch ON.

Action

Check for communication between INSITE™ electronic service tool and the ECM.

Use INSITE™ electronic service tool to check for communication with the ECM.

Does the ECM communicate?
YES | NO
No Repair | No Repair

Go to 4A

Reference the ECM - No Communication Troubleshooting Tree in Section TT.

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2727 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Sep-2015


FAULT CODE 2734 - Start Enable Device 1 Canister Empty (Ether Injection) - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Disable the fault code. | Fault Code 2734 inactive?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Replace the ether bottle.
  • Use INSITE™ electronic service tool reset the ether injection value, found under ECM diagnostic test.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2734 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1B

Go to 1A

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Aug-2012


FAULT CODE 2963 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2963. | Active or inactive counts of Fault Code 2963?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2963 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2963.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 2963.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2963?
YES NO

Repair

Reference the Engine Coolant Temperature Above Normal symptom tree in:

  • K38, K50, and QSK50 Service Manual, Bulletin 4021528
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
 No Repair

Appropriate troubleshooting symptom tree

Repair complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE electronic service tool to verify that the fault code is inactive.

Fault Code 2963 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Aug-2012


FAULT CODE 2998 - Engine Torque Limit Feature - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine power. |
 | STEP 1A. Check for low engine power. | Fault associated with low engine power?
STEP 2. | Check if the high idle adjustment is too high. |
 | STEP 2A. High idle adjustment is too high. | Fault associated with high idle adjustment being too high?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2998 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for engine power.

Guided Step 1A - Check for low engine power.

Conditions

  • Turn keyswitch ON.

Action

Interview the operator.

  • Interview the operator to determine if there are any reports of low power.

Is fault associated with low engine power?
YES | NO
No Repair | No Repair

Reference the Engine Performance Troubleshooting Tree in Section TT

2A

Guided Step 2 - Check if the high idle adjustment is too high.

Guided Step 2A - High idle adjustment is too high.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check rated speed.

  • Check if the alternate idle speed or intermediate speed control is not beyond the rated speed.

Is the fault associated with high idle adjustment being too high?
YES NO

Repair

Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2998 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-Aug-2012


FAULT CODE 3694 - Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 2. | Check the gain adjust potentiometer circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1418 active and Fault Code 3694 active?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 3694 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect the ECM, OEM harness, and engine harness connector. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3694 inactive?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault codes. | Fault Code 3694 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Reference Fault Code 187.

Go to 2A

Guided Step 2 - Check the gain adjust potentiomemter circuit

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the gain adjust potentiometer 5-volt SUPPLY (sensor supply 2) pin and the gain adjust potentiometer RETURN (sensor return 2) pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the gain adjust potentiometer 5-volt SUPPLY (sensor supply2) and the gain adjust potentiometer SIGNAL pin at the OEM 31-pin connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1418 active and Fault Code 3694 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3694 active?
YES NO

Repair

An issue has been detected with the generator set controller. Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector gain adjust potentiometer SIGNAL pin and the OEM 31-pin connector gain adjust potentiometer SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open gain adjust potentiometer SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Secion 19.

Greater than 100k ohms?
YES NO

Repair

A damaged generator drive harness or potentiometer is detected. Refer to the OEM service manual for repair instructions.

Repair

A pin-to-pin short circuit on the gain adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A damaged generator drive harness or potentiometer has been detected. Refer to the OEM service manual for repair instructions.

Repair

A pin-to-ground short circuit on the gain adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3694 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 3694 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 09-Aug-2012


FAULT CODE 3695 - Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 352 active?
STEP 2. | Check the generator output frequency adjust potentiometer. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response.. | Fault Code 1411 active and Fault Code 3695 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3695 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect the ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3695 inactive?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault codes. | Fault Code 1411 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor Supply Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference Fault Code 352

Go to 2A

Guided Step 2 - Check the generator output frequency adjust potentiometer circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator output frequency adjust potentiometer 5 volt SUPPLY (sensor supply 1) pin and the generator output frequency adjust potentiometer RETURN (sensor return 1) pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the generator output frequency adjust potentiometer 5 volt SUPPLY (sensor supply1) and the generator output frequency adjust potentiometer SIGNAL pin at the OEM 31-pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1411 active and Fault Code 3695 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3695 active?
YES NO

Repair

An issue has been detected with the generator set controller.

Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator output frequency adjust potentiometer SIGNAL pin and the OEM 31-pin connector generator output frequency adjust potentiometer SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open generator output frequency adjust potentiometer SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the generator output frequency adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the generator output frequency adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3695 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 3695 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 09-Aug-2012


FAULT CODE 3696 - Droop Adjustment Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor Supply Fault Code 352 active?
STEP 2. | Check the droop adjustment potentiometer circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1412 active and Fault Code 3696 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3696 is active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3696 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 3696 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference Fault Code 352

Go to 2A

Guided Step 2 - Check the droop adjustment potentiometer circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the droop adjust potentiometer SUPPLY pin and the droop adjust potentiometer RETURN pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general mulitmeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector or 23-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the droop adjust potentiometer SUPPLY pin and the droop adjust potentiometer SIGNAL pin at the OEM 31-pin connector or 23-pin connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 active and Fault Code 3696 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the OEM 31-pin connector or 23-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 is active?
YES NO

Repair

An issue has been detected with the gen set controller.

Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector droop adjust potentiometer SIGNAL pin and the OEM 31-pin connector or 23-pin connector droop adjust potentiometer SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open generator droop adjust potentiometer SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the droop adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the droop adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 3696 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Aug-2012


FAULT CODE 3722 - Intake Manifold Pressure Bank Imbalance - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine for air filter restriction. |
 | STEP 1A. Check for engine air filter restriction. | Air filter restricted?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check the engine control module (ECM) for active fault codes. | Fault Code 1433, 3131, or 5291 active?
STEP 3. | Check air shutoff valve. |
 | STEP 3A. Check air shutoff valve position | Air shutoff valve closed?
STEP 4. | Check for a boost leak. |
 | STEP 4A. Inspect the air intake system for leaks. | Air leak found?
STEP 5. | Check the turbochargers. |
 | STEP 5A. Check turbocharger impellers for damage. | Damaged impeller blades?
STEP 6. | Validate the boost pressure sensor. |
 | STEP 6A. Validate the boost pressure sensor readings. | INSITE™ electronic service tool reading is within 102 mm-Hg [4 in-Hg] of the mechanical gauge pressure?
STEP 7. | Check the injectors. |
 | STEP 7A. Check for malfunctioning injectors. | Multiple low exhaust gas temperature readings on same bank?
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the engine for air filter restriction.

Guided Step 1A - Check for engine air filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Turn run/stop/auto switch to STOP position.

Action

Check the engine air filter restriction or damage that may cause excessive restriction.

  • Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 010-059 in Section 10.

Air filter restricted?
YES NO

Repair

Replace the air cleaner elements. Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 010-014 in Section 10.

No Repair

Go to 2A

Go to 6A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check the engine control module (ECM) for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • INSITE™ electronic service tool found Fault Code 1433, 3131 or 5291 active?

Fault Code 1433, 3131, or 5291 active?
YES NO

Repair

Troubleshoot the active fault code(s)

 No Repair

Refer to the appropriate fault code troubleshooting procedure within Section TF.

Go to 3A

Guided Step 3 - Check air shut off valve.

Guided Step 3A - Check the air shut off valve position.

Conditions

  • Turn keyswitch OFF.
  • Run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the air shut off valve position.

  • Is there a closed air shut off valve?

Air shut off valve closed?
YES NO

Repair

Open air shut off valve. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check for a boost leak.

Guided Step 4A - Inspect the air intake system for leaks.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Run/stop/auto switch in the RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Inspect the air intake system for leaks.

  • Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 010-024 in Section 10.

Air leak found?
YES NO

Repair

Repair the leak. Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 010-024 in Section 10.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check the turbochargers.

Guided Step 5A - Check turbocharger impellers for damage.

Conditions

  • Turn keyswitch OFF.
  • Run/stop/auto switch in the STOP mode.
  • Intake tubing removed from both turbochargers.

Action

Inspect the turbocharger impellers.

  • Inspect the turbocharger impeller blades for signs of damage.

Damaged impeller blades?
YES NO

Repair

Replace the damaged turbocharger. Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Validate the boost pressure sensor.

Guided Step 6A - Validate the boost pressure sensor readings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a mechanical pressure gauge to the intake manifold.
  • Operate the engine.

Action

Use INSITE™ electronic service tool to monitor the intake manifold 1 and 2 pressure.

  • Operate the engine under load.
  • Compare INSITE™ electronic service tool intake manifold pressure readings with the mechanical gauge pressure.

INSITE™ electronic service tool reading is within 102 mm-Hg [4 in-Hg] of the mechanical gauge pressure?
YES NO
No Repair

Repair

Replace intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Check the injectors.

Guided Step 7A - Check for malfunctioning injectors.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Run/stop/auto switch in the RUN mode.

Action

Use INSITE™ electronic service tool to monitor all exhaust gas temperature sensor readings.

  • Look for multiple low exhaust gas temperature readings on the same bank.

Multiple low exhaust gas temperature readings on same bank?
YES NO

Repair

Confirm the injectors are functioning correctly.

No Repair

Go to the appropriate fault code troubleshooting procedure within Section TT.

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 25-Jun-2015


FAULT CODE 3732 - Exhaust Gas Temperature Bank Imbalance - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the temperature difference. |
 | STEP 1A. Use INSITE™ electronic service tool to check the temperature difference between left bank and right bank. | Does EGT_Bank_Differential_Temperature in INSITE™ electronic service tool show a positive (+ ve) value?
 | STEP 1B. Check if the right bank air shutoff valves in open position. | Are right bank air shutoff valves completely open?
 | STEP 1C. Check if the left bank air shutoff valves in open position. | Are left bank air shutoff valves completely open?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 3732 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the temperature difference.

Guided Step 1A - Use INSITE™ electronic service tool to check the temperature difference between left bank and right bank.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Attempt to start the engine by engaging the starter for at least 10 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Does EGT_Bank_Differential_Temperature in INSITE™ electronic service tool show a positive (+ ve) value?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1C

Guided Step 1B - Check if the right bank air shutoff valves are in open position.

Conditions

  • Turn keyswitch OFF.
  • All components connected except the hump hoses.

Action

Check that the right bank air shutoff valves are in the open position.

Are right bank air shutoff valves completely open?
YES NO

Repair

No Repair. Reference the Engine Performance Troubleshooting Tree Procedure in Section TT, Step 2 to see the troubleshooting steps linked with the low power symptom disregarding the Exhaust Gas Temperature imbalance fault code procedure.

Repair

Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 010-143 in Section 10.

Repair complete

Go to 2A

Guided Step 1C - Check if the left bank air shutoff valves are in open position.

Conditions

  • Turn keyswitch OFF.
  • All components connected except the hump hoses.

Action

Check that the left bank air shutoff valves are in the open position.

Are left bank air shutoff valves completely open?
YES NO

Repair

No Repair. Reference the Engine Performance Troubleshooting Tree Procedure in Section TT, Step 2 to see the troubleshooting steps linked with the low power symptom disregarding the Exhaust Gas Temperature imbalance fault code procedure.

Repair

Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 010-143 in Section 10.

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start the engine and let it idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 3732 is inactive.

Fault Code 3732 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troublshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Aug-2012


FAULT CODE 4615 - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Pump | Refer to Procedure 005-016 | QSK38 and QSK50 | 4021530
Fuel Filter Head | Refer to Procedure 006-017 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Filter Head | Refer to Procedure 006-017 | QSK45 and QSK60 | 4021530
Fuel Inlet Restriction | Refer to Procedure 006-020 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSK45 and QSK60 | 4021530
Fuel Supply Lines | Refer to Procedure 006-024 | K38, K50, QSK38, and QSK50 | 4021528
Fuel Supply Lines | Refer to Procedure 006-024 | QSK45 and QSK60 | 4021530
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | K38, K50, QSK38, and QSK50 | 4021528
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK45 and QSK60 | 4021530
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK19 | 4022094
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK38, QSK50, and QSK60 | 4022102

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the low-pressure fuel system. |
 | STEP 1A. Check the fuel supply pressure sensor. | INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psi] of each other?
 | STEP 1B. Check the fuel supply lines. | Any fuel lines damaged, kinked, or restricted?
 | STEP 1C. Check the Stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within specification?
 | STEP 1C-1. Check the fuel filter head. |
 | STEP 1D. Check the fuel supply pressure at the fuel inlet manifold. | Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 4615 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel supply pressure fuel system.

Guided Step 1A - Check the fuel supply pressure sensor.

Conditions

  • Connect the Compuchek™ tool.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor.

  • Start and operate the engine at high idle.
  • Record the fuel supply sensor reading in INSITE™ electronic service tool.
  • Record the fuel supply pressure reading on a pressure gauge installed in place of the fuel supply pressure sensor.
  • Use the following procedure for Stage 2 filters in the Measure section of the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-024 in in the Associated Procedures Table.
  • Use the following procedure for Stage 2 filters in the Measure section in the QSK45 and QSK60 Service Manual, Bulletin 4021530, . Refer to Procedure 006-024 in the Associated Procedures Table.

INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2psia] of each other?
YES NO
No Repair

Repair

Replace the fuel supply pressure sensor.

  • Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the fuel supply lines.

Conditions

  • Turn keyswitch OFF.

Action

Examine the fuel supply lines for damages, kinks, or restrictions.

  • Refer to Procedure 006-024 in the Associated Procedures Table.

Any fuel lines damaged, kinked, or restricted?
YES NO

Repair

Replace the damaged fuel line(s).

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the Stage 2 filter restriction.

  • Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in in the Associated Procedures Table.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Repair

Replace the Stage 2 fuel filters.

  • Use the following procedure in the K38,K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-076 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Check the fuel filter head.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the Stage 2 fuel filter restriction.

  • Use the following procedure in the K38, K50,QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in Associated Procedures Table.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Repair

Replace the Stage 2 fuel filter head.

  • Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 1D - Check the fuel supply pressure at the fuel inlet manifold.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel supply pressure at the fuel manifold.

  • Close the fuel supply valve.
  • Remove the M14 STOR plug from the fuel inlet manifold.
  • Install a Compuchek™ fitting, Part Number 3824844, or equivalent, in the fuel inlet manifold.
  • Connect the vacuum gauge and adapter, Part Number 3164491, or equivalent, and digital multimeter, Part Number 3164488 or 3164489,or equivalent, to the Compuchek™ fitting.
  • Open the fuel supply valve.
  • Start and operate the engine at low idle and high idle.
  • Record the fuel inlet pressure readings.

Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
YES NO

Repair

Replace the fuel pump.

  • Use the following procedure the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 005-016 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in the Associated Procedures Table.

Repair

Refer to the equipment manufacturer service information to reduce fuel inlet pressure.

Go to 2A

Go to 2A

Guided Step 2 - Disable and clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 4615 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 04-Mar-2015


FAULT CODE 4688 - Water in Fuel Indicator 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4688 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the water in fuel indicator sensor and circuit. |
 | STEP 2A. Inspect the engine harness and water in fuel indicator sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 82.4k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4688 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 4689 active and Fault Code 4688 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 4688 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 4688 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel indicator sensor and circuit.

Guided Step 2A - Inspect the water in fuel indicator sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Inspect the engine harness and water in fuel indicator sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the water in fuel indicator sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged water in fuel indicator sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to the original engine manufacturer (OEM) service manual.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Check the water in fuel indicator sensor resistance.

  • Measure the resistance between the water in fuel indicator SIGNAL pin and the water in fuel indicator RETURN (sensor return 1) pin at the water in fuel indicator sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 82.4k ohms?
YES NO

Repair

Replace the water in fuel indicator sensor. Refer to the original engine manufacturer (OEM) service manual.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel indicator sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 4689 active and Fault Code 4688 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM 60 pin connector water in fuel indicator sensor RETURN (sensor return 1) pin and the engine harness water in fuel indicator sensor connector RETURN (sensor return 1) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open water in fuel indicator RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM 60 pin connector water in fuel indicator sensor SIGNAL pin and the water in fuel indicator SIGNAL sensor connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open water in fuel indicator SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water in fuel indicator SIGNAL pin in the engine harness ECM 60-pin connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the water in fuel indicator SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. The cause of the fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 4688 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Jan-2017


FAULT CODE 4689 - Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4689 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the water in fuel indicator sensor and circuit. |
 | STEP 2A. Inspect the engine harness and water in fuel indicator sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4688 active and Fault Code 4689 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4689 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 4688 active and Fault Code 4689 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 4689 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 4689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel indicator sensor and circuit.

Guided Step 2A - Inspect the engine harness and water in fuel indicator sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Inspect the engine harness and water in fuel sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the water in fuel indicator sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged water in fuel indicator sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

See equipment manufacturer service information for water in fuel indicator sensor location.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active and Fault Code 4689 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel indicator sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes and verify sensor condition.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 active?
YES NO

Repair

A damaged water in fuel indicator sensor has been detected.

Replace the water in fuel indicator sensor.

See equipment manufacturer service information.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness connector from the water in fuel indicator sensor connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Reference the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active and Fault Code 4689 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water in fuel indicator SIGNAL pin in the engine harness ECM 60 pin connector and all other pins in the engine harness ECM 60 pin connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the water in fuel indicator SIGNAL pin in the engine harness ECM 60 pin connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the water in fuel SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the short circuit to ground.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be checked again from the beginning. The cause of the fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 4689 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 07-Dec-2016


FAULT CODE 5119 - Fuel Pump Lubricating Oil Pressure Sensor Circuit- Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
STEP 2. | Check the fuel pump lubricating oil pressure sensor and circuit. |
 | STEP 2A. Inspect the pins and connectors for damage. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. Fuel pump lubricating oil pressure sensor circuit check. | Fault Code 5121 active?
STEP 3. | Fuel pump lubricating oil pressure sensor circuit check. |
 | STEP 3A. Fuel pump lubricating oil pressure sensor open circuit check. | Resistance less than 10 ohms?
 | STEP 3B. Fuel pump lubricating oil pressure sensor circuit pin to pin check. | Resistance less than 100k ohms?
STEP 4. | Check ECM calibraion and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the fuel pump lubricating oil pressure sensor and circuit.

Guided Step 2A - Inspect the fuel pump lubricating oil pressure sensor and engine wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure sensor connector from the engine wiring harness connector.

Action

Inspect the pins and connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Missing or damaged connector seals
  • Connector or shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in Section 19.
  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure sensor connector from the engine wiring harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the fuel pump oil pressure, 5-volt SUPPLY pin to the fuel pump pressure RETURN pin at the sensor connector of the engine wiring harness.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pump lubricating oil pressure sensor connector from the engine wiring harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5121 active?
YES NO

Repair

A damaged fuel pump lubricating oil pressure sensor has been detected.

  • Replace the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in Section 19.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Fuel pump lubricating oil pressure sensor circuit check.

Guided Step 3A - Fuel pump lubricating oil pressure sensor open circuit check.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pump lubricating oil pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Measure the resistance between the fuel pump lubricating oil pressure sensor SIGNAL pin at the fuel pump lubricating oil pressure sensor wiring harness connector and the fuel pump lubricating oil pressure sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the fuel pump lubricating oil pressure sensor RETURN pin at the fuel pump lubricating oil pressure sensor wiring harness connector and the fuel pump lubricating oil pressure sensor RETURN pin at the engine wiring harness ECM connector.

Resistance less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Fuel pump lubricating oil pressure sensor circuit pin to pin check.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pump lubricating oil pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Measure the resistance between the fuel pump lubricating oil pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins at the engine wiring harness ECM connector.

Resistance less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revision listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-May-2020


FAULT CODE 5121 - Fuel Pump Lubricating Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2186 active?
STEP 2. | Check the fuel pump lubricating oil pressure sensor and circuit. |
 | STEP 2A. Inspect the pins and connectors for damage. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. Fuel pump lubricating oil pressure sensor circuit check. | Fault Code 5119 active?
STEP 3. | Fuel pump lubricating oil pressure sensor circuit check. |
 | STEP 3A. Fuel pump lubricating oil pressure sensor circuit pin to ground check. | Resistance less than 100k ohms?
 | STEP 3B. Fuel pump lubricating oil pressure sensor circuit pin to pin check. | Resistance less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the fuel pump lubricating oil pressure sensor and circuit.

Guided Step 2A - Inspect the fuel pump lubricating oil pressure sensor and engine wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure sensor connector from the engine wiring harness connector.

Action

Inspect the pins and connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Missing or damaged connector seals
  • Connector or shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in Section 19.
  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure sensor connector from the engine wiring harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the Fuel pump oil pressure, 5 volt SUPPLY pin to the Fuel pump oil pressure RETURN pin at the sensor connector of the engine wiring harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure sensor connector from the engine wiring harness connector.

Action

Place a jumper wire between the fuel pump lubricating oil pressure sensor SUPPLY pin and the fuel pump lubricating oil pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.

Turn keyswitch ON.

Connect the INSITE™ electronic service tool or equivalent.

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5119 active?
YES NO

Repair

A damaged fuel pump lubricating oil pressure sensor has been detected.

  • Replace the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in Section 19.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Fuel pump lubricating oil pressure sensor circuit check.

Guided Step 3A - Fuel pump lubricating oil pressure sensor circuit pin to ground check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Measure the resistance between the fuel pump lubricating oil pressure sensor SIGNAL pin at the engine wiring harness ECM connector and ground.

Resistance less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Fuel pump lubricating oil pressure sensor circuit pin to pin check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Measure the resistance between the fuel pump lubricating oil pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins at the engine wiring harness ECM connector.

Resistance less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-May-2020


FAULT CODE 6719 - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Pump | Refer to Procedure 005-016 | QSK38 and QSK50 | 4021530
Fuel Inlet Restriction | Refer to Procedure 006-020 | K38, K50, QSK38 and QSK50 | 4021528
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSK45 and QSK60 | 4021530
Fuel Supply Lines | Refer to Procedure 006-024 | K38, K50, QSK38, and QSK50 | 4021528
Fuel Supply Lines | Refer to Procedure 006-024 | QSK45 and QSK60 | 4021530
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | K38, K50, QSK38, and QSK50 | 4021528
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK45 and QSK60 | 4021530
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK19 | 4022094
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK38, QSK50, and QSK60 | 4022102

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the low-pressure fuel system. |
 | STEP 1A. Check the fuel supply pressure sensor. | INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
 | STEP 1B. Check the fuel supply lines. | Any fuel lines damaged, kinked, or restricted?
 | STEP 1C. Check the Stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within specification?
 | STEP 1C-1. Check the fuel filter head |
 | STEP 1D. Check the fuel supply pressure at the fuel inlet manifold. | Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
STEP 2. | Disable and clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 6719 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel supply pressure fuel system.

Guided Step 1A - Check the fuel supply pressure sensor.

Conditions

  • Connect the Compuchek™ tool.
  • Connect the INSITE™ electronic service tool.

Action

  • Start and operate the engine at high idle.
  • Record the fuel supply sensor reading in INSITE™ electronic service tool.
  • Record the fuel supply pressure reading on a pressure gauge installed in place of the fuel supply pressure sensor.
  • Use the following procedure for Stage 2 filters in the Measure section of the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-024 in in the Associated Procedures Table.
  • Use the following procedure for Stage 2 filters in the Measure section in the QSK45 and QSK60 Service Manual, Bulletin 4021530 . Refer to Procedure 006-024 in the Associated Procedures Table.

INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2psia] of each other?
YES NO
No Repair

Repair

Replace the fuel supply pressure sensor.

  • Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the fuel supply lines.

Conditions

  • Turn keyswitch ON.

Action

  • Refer to Procedure 006-024 in the Associated Procedures Table.

Any fuel lines damaged, kinked, or restricted?
YES NO

Repair

Replace the damaged fuel line(s).

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

  • Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in the Associated Procedures Table.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Repair

Replace the Stage 2 fuel filters.

  • Use the following procedure in the K38,K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-076 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Check the fuel filter head.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

  • Use the following procedure in the K38, K50,QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in Associated Procedures Table.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Repair

Replace the Stage 2 fuel filter head.

  • Use the following procedure in the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 006-020 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 006-020 in Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 1D - Check the fuel supply pressure at the fuel inlet manifold

Conditions

  • Turn keyswitch OFF.

Action

  • Close the fuel supply valve.
  • Remove the M14 STOR plug from the fuel inlet manifold.
  • Install a Compuchek™ fitting, Part Number 3824844, or equivalent, in the fuel inlet manifold.
  • Connect the vacuum gauge and adapter, Part Number 3164491, or equivalent, and digital multimeter, Part Number 3164488 or 3164489,or equivalent, to the Compuchek™ fitting.
  • Open the fuel supply valve.
  • Start and operate the engine at low idle and high idle.
  • Record the fuel inlet pressure readings.

Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
YES NO

Repair

Replace the fuel pump.

  • Use the following procedure the K38, K50, QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 005-016 in the Associated Procedures Table.
  • Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 005-016 in the Associated Procedures Table.

Repair

Refer to the equipment manufacturer service information to reduce fuel inlet pressure.

Go to 2A

Go to 2A

Guided Step 2 - Disable and clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and operate engine.

Action

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 6719 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Apr-2017


FAULT CODE 7313 - Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump Drive Lubricating Oil Filter | Refer to Procedure 007-110 | QSK45 and QSK60 | 4021530

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for primary fault codes. | Fault Code 143, 415,1362 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Fuel pump lubricating oil pressure sensor stuck in-range. |
 | STEP 2A. Visually inspect the sensor for damage. | Damage found on the fuel pump lubricating oil pressure sensor, connectors, or engine wiring harness?
 | STEP 2B. Verify fuel pump lubricating oil pressure sensor's accuracy. | Sensor reading between the recommended CumminsⓇ electronic service tool or equivalent and the mechanical gauge is within specification?
STEP 3. | Check the fuel pump drive lubricating oil filter. |
 | STEP 3A. Check for damage on the fuel pump drive lubricating oil filter. | Damaged or plugged fuel pump drive lubricating oil filter?
STEP 4. | Check Fuel Pump Oil Pressure. |
 | STEP 4A. Verify oil pressure at the outlet of the fuel pump drive lubricating oil filter head. | Fuel pump oil pressure is above the minimum oil pressure?
 | STEP 4B. Verify oil pressure at the outlet of the fuel pump drive lubricating oil filter head with new oil filter installed. | Fuel pump oil pressure is above the minimum oil pressure?
STEP 5. | Check ECM Calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for primary fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 143, 415, 1362 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Troubleshoot the appropriate fault codes.

Go to 2A

Guided Step 2 - Fuel pump lubricating oil pressure sensor stuck in-range.

Guided Step 2A - Visually inspect the sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure sensor from the engine wiring harness.

Action

Inspect the harness connector and fuel pump lubricating oil pressure sensor connector.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damage found on the fuel pump lubricating oil pressure sensor, connectors, or engine wiring harness?
YES NO

Repair

Repair or replace only the component that were found to be out of specification.

Replace the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in Section 19.

Repair or replace the engine wiring harness or connectors. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Verify fuel pump lubricating oil pressure sensor's accuracy.

Conditions

  • Turn keyswitch OFF

Action

  • Check the fuel pump oil pressure at the outlet of the fuel pump oil filter head.
  • Refer to Procedure 019-679 in Section 19.

Sensor reading between the recommended Cummins electronic service tool or equivalent and the mechanical gauge is within specification?
YES NO
No Repair

Repair

Replace the fuel pump lubricating oil pressure sensor.

Refer to Procedure 019-679 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the fuel pump drive lubricating oil filter.

Guided Step 3A - Check for damage on the fuel pump drive lubricating oil filter.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the fuel pump drive lubricating oil filter.
  • Refer to Procedure 007-110 in the Associated Procedures Table.

Damage found on the fuel pump drive lubricating oil filter?
YES NO

Repair

Replace the fuel pump drive lubricating oil filter.

Refer to Procedure 007-110 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check Fuel Pump Oil Pressure.

Guided Step 4A - Verify oil pressure at the outlet of the fuel pump drive lubricating oil filter head.

Conditions

  • Turn keyswitch OFF.

Action

  • Verify oil pressure at the outlet of the fuel pump drive lubricating oil filter head. Refer to Procedure 007-110 in the Associated Procedures Table.

Fuel pump oil pressure is above the minimum oil pressure?
YES NO
No Repair

Repair

Replace the fuel pump drive lubricating oil filter. Refer to Procedure 007-110 in the Associated Procedures Table.

Go to 5A

Go to 4B

Guided Step 4B - Verify oil pressure at the outlet of the fuel pump drive lubricating oil filter head with new oil filter installed.

Conditions

  • Turn keyswitch OFF.

Action

  • Verify oil pressure at the outlet of the fuel pump oil filter head. Refer to Procedure 007-110 in the Associated Procedures Table.

Fuel pump oil pressure is above the minimum oil pressure?
YES | NO
No Repair | No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step - 5A Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step - 5B Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Go to
Escalate or call for assistance.

Last Modified: 21-May-2020


FAULT CODE 7314 - Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range- Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump Drive Lubricating Oil Filter | Refer to Procedure 007-110 | QSK45 and QSK60 | 4021530

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for primary fault codes. | Fault Code 143, 415, 1362 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Fuel pump lubricating oil pressure sensor stuck in-range. |
 | STEP 2A. Visually inspect the sensor for damage. | Damage found on the fuel pump lubricating oil pressure sensor, connectors, or engine wiring harness?
 | STEP 2B. Verify fuel pump lubricating oil pressure sensor's accuracy. | Sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge is within specification?
STEP 3. | Check the fuel pump drive lubricating oil filter for damage. |
 | STEP 3A. Check for damage on the fuel pump drive lubricating oil filter. | Damaged or plugged fuel pump drive lubricating oil filter?
STEP 4. | Check Fuel Pump Oil Pressure. |
 | STEP 4A. Verify oil pressure at the outlet of the fuel pump drive lubricating oil filter head. | Fuel pump oil pressure is above the minimum oil pressure?
 | STEP 4B. Verify oil pressure at the outlet of the fuel pump drive lubricating oil filter head with the new oil filter installed. | Fuel pump oil pressure is above the minimum oil pressure?
STEP 5. | Check ECM calibration and clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for primary fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 143, 415, 1362 active or inactive with more than one count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Troubleshoot the appropriate fault codes.

Go to 2A

Guided Step 2 - Fuel pump lubricating oil pressure sensor stuck in-range.

Guided Step 2A - Visually inspect the sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel pump lubricating oil pressure sensor from the engine wiring harness.

Action

Inspect the harness connector and fuel pump lubricating oil pressure sensor connector.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damage found on the fuel pump lubricating oil pressure sensor, connectors or engine wiring harness?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

Replace the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in Section 19.

Repair or replace the engine wiring harness or connectors. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Verify fuel pump lubricating oil pressure sensor's accuracy.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the fuel pump oil pressure at the outlet of the fuel pump oil filter head.
  • Refer to Procedure 019-679 in Section 19.

Sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge is within specification?
YES NO
No Repair

Repair

Replace the fuel pump lubricating oil pressure sensor.

Refer to Procedure 019-679 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the fuel pump drive lubricating oil filter for damage.

Guided Step 3A - Check for damage on the fuel pump drive lubricating oil filter.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the fuel pump drive lubricating oil filter.
  • Refer to Procedure 007-110 in the Associated Procedures Table.

Damage found on the fuel pump drive lubricating oil filter?
YES NO

Repair

Replace the fuel pump drive lubricating oil filter.

Refer to Procedure 007-110 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check Fuel Pump Oil Pressure.

Guided Step 4A - Verify oil pressure at the outlet of the fuel pump drive lubricating oil filter head.

Conditions

  • Turn keyswitch OFF.

Action

  • Verify oil pressure at the outlet of the fuel pump oil filter head. Refer to Procedure 007-110 in the Associated Procedures Table.

Fuel pump oil pressure is above the minimum oil pressure?
YES NO
No Repair

Repair

Replace the fuel pump drive lubricating oil filter. Refer to Procedure 007-110 in the Associated Procedures Table.

Go to 5A

Go to 4B

Guided Step 4B - Verify oil pressure at the outlet of the fuel pump drive lubricating oil filter head with new oil filter installed.

Conditions

  • Turn keyswitch OFF.

Action

  • Verify oil pressure at the outlet of the fuel pump oil filter head. Refer to Procedure 007-110 in the Associated Procedures Table.

Fuel pump oil pressure is above the minimum oil pressure?
YES | NO
No Repair | No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or Call for assistance.

Last Modified: 21-May-2020


INDEX
122-fc111.htm

122-t05-111.htm

122-fc115.htm

122-t05-115.htm

122-fc122.htm

122-t05-122.htm

122-fc123.htm

122-t05-123.htm

122-fc135.htm

122-t05-135.htm

122-fc141.htm

122-t05-141.htm

122-fc143.htm

122-t05-143.htm

122-fc144.htm

122-t05-144.htm

122-fc145.htm

122-t05-145.htm

122-fc146.htm

122-t05-146.htm

122-fc151.htm

122-t05-151.htm

122-fc153.htm

122-t05-153.htm

122-fc154.htm

122-t05-154.htm

122-fc155.htm

122-t05-155.htm

122-fc156.htm

122-t05-156.htm

122-fc157.htm

122-t05-157.htm

122-fc158.htm

122-t05-158.htm

122-fc159.htm

122-t05-159.htm

122-fc161.htm

122-t05-161.htm

122-fc162.htm

122-t05-162.htm

122-fc163.htm

122-t05-163.htm

122-fc164.htm

122-t05-164.htm

122-fc165.htm

122-t05-165.htm

122-fc187.htm

122-fc187sa00.htm

122-t05-187sa00.htm

122-fc187sa01.htm

122-t05-187sa01.htm

122-fc195.htm

122-t05-195.htm

122-fc196.htm

122-t05-196.htm

122-fc197.htm

122-t05-197.htm

122-fc212.htm

122-t05-212.htm

122-fc213.htm

122-t05-213.htm

122-fc214.htm

122-t05-214.htm

122-fc221.htm

122-t05-221.htm

122-fc222.htm

122-t05-222.htm

122-fc223.htm

122-t05-223.htm

122-fc224.htm

122-t05-224.htm

122-fc227.htm

122-fc227sa00.htm

122-t05-227sa00.htm

122-fc227sa01.htm

122-t05-227sa01.htm

122-fc228.htm

122-t05-228.htm

122-fc231.htm

122-t05-231.htm

122-fc232.htm

122-t05-232.htm

122-fc234.htm

122-t05-234.htm

122-fc235.htm

122-t05-235.htm

122-fc237.htm

122-t05-237.htm

122-fc238.htm

122-fc238sa00.htm

122-t05-238sa00.htm

122-fc238sa01.htm

122-t05-238sa01.htm

122-fc245.htm

122-t05-245.htm

122-fc261.htm

122-t05-261.htm

122-fc263.htm

122-t05-263.htm

122-fc265.htm

122-t05-265.htm

122-fc266.htm

122-t05-266.htm

122-fc271.htm

122-t05-271.htm

122-fc272.htm

122-t05-272.htm

122-fc285.htm

122-t05-285.htm

122-fc286.htm

122-t05-286.htm

122-fc322.htm

122-fc322qsk38.htm

122-t05-322qsk38.htm

122-fc322qsk50-60.htm

122-t05-322qsk50-60.htm

122-fc323.htm

122-fc323qsk38.htm

122-t05-323qsk38.htm

122-fc323qsk50-60.htm

122-t05-323qsk50-60.htm

122-fc324.htm

122-fc324qsk38.htm

122-t05-324qsk38.htm

122-fc324qsk50-60.htm

122-t05-324qsk50-60.htm

122-fc325.htm

122-fc325qsk38.htm

122-t05-325qsk38.htm

122-fc325qsk50-60.htm

122-t05-325qsk50-60.htm

122-fc327.htm

122-t05-327.htm

122-fc331.htm

122-fc331qsk38.htm

122-t05-331qsk38.htm

122-fc331qsk50-60.htm

122-t05-331qsk50-60.htm

122-fc332.htm

122-fc332qsk38.htm

122-t05-332qsk38.htm

122-fc332qsk50-60.htm

122-t05-332qsk50-60.htm

122-fc342.htm

122-t05-342.htm

122-fc349.htm

122-t05-349.htm

122-fc351.htm

122-fc351sa00.htm

122-t05-351sa00.htm

122-fc351sa01.htm

122-t05-351sa01.htm

122-fc351sa144.htm

122-t05-351sa144.htm

122-fc352.htm

122-fc352ind.htm

122-t05-352ind.htm

122-fc352pg.htm

122-t05-352pg.htm

122-fc386.htm

122-fc386ind.htm

122-t05-386ind.htm

122-fc386pg.htm

122-t05-386pg.htm

122-fc415.htm

122-t05-415.htm

122-fc418.htm

122-t05-418.htm

122-fc419.htm

122-t05-419.htm

122-fc421.htm

122-t05-421.htm

122-fc426.htm

122-t05-426.htm

122-fc431.htm

122-fc431iss.htm

122-t05-431iss.htm

122-fc431niss.htm

122-t05-431niss.htm

122-fc441.htm

122-fc441sa00.htm

122-t05-441sa00.htm

122-fc441sa01.htm

122-t05-441sa01.htm

122-fc441sa144.htm

122-t05-441sa144.htm

122-fc442.htm

122-t05-442.htm

122-fc449.htm

122-t05-449.htm

122-fc451.htm

122-t05-451.htm

122-fc452.htm

122-t05-452.htm

122-fc479.htm

122-t05-479.htm

122-fc488.htm

122-t05-488.htm

122-fc489.htm

122-t05-489.htm

122-fc497.htm

122-t05-497.htm

122-fc521.htm

122-t05-521.htm

122-fc522.htm

122-t05-522.htm

122-fc527.htm

122-t05-527.htm

122-fc529.htm

122-t05-529.htm

122-fc546.htm

122-t05-546.htm

122-fc547.htm

122-t05-547.htm

122-fc556.htm

122-t05-556.htm

122-fc559.htm

122-t05-559.htm

122-fc595.htm

122-t05-595.htm

122-fc599.htm

122-t05-599.htm

122-fc611.htm

122-t05-611.htm

122-fc621.htm

122-fc621qsk38-50mar.htm

122-t05-621qsk38-50mar.htm

122-fc621thermistor.htm

122-t05-621thermistor.htm

122-fc622.htm

122-fc622qsk38-50mar.htm

122-t05-622qsk38-50mar.htm

122-fc622thermistor.htm

122-t05-622thermistor.htm

122-fc623.htm

122-fc623qsk38-50mar.htm

122-t05-623qsk38-50mar.htm

122-fc623thermistor.htm

122-t05-623thermistor.htm

122-fc624.htm

122-fc624qsk38-50mar.htm

122-t05-624qsk38-50mar.htm

122-fc624thermistor.htm

122-t05-624thermistor.htm

122-fc625.htm

122-fc625qsk38-50mar.htm

122-t05-625qsk38-50mar.htm

122-fc625thermistor.htm

122-t05-625thermistor.htm

122-fc626.htm

122-fc626qsk38-50mar.htm

122-t05-626qsk38-50mar.htm

122-fc626thermistor.htm

122-t05-626thermistor.htm

122-fc627.htm

122-fc627qsk50mar.htm

122-t05-627qsk50mar.htm

122-fc627thermistor.htm

122-t05-627thermistor.htm

122-fc628.htm

122-fc628qsk50mar.htm

122-t05-628qsk50mar.htm

122-fc628thermistor.htm

122-t05-628thermistor.htm

122-fc631.htm

122-fc631qsk38-50mar.htm

122-t05-631qsk38-50mar.htm

122-fc631thermistor.htm

122-t05-631thermistor.htm

122-fc632.htm

122-fc632qsk38-50mar.htm

122-t05-632qsk38-50mar.htm

122-fc632thermistor.htm

122-t05-632thermistor.htm

122-fc633.htm

122-fc633qsk38-50mar.htm

122-t05-633qsk38-50mar.htm

122-fc633thermistor.htm

122-t05-633thermistor.htm

122-fc634.htm

122-fc634qsk38-50mar.htm

122-t05-634qsk38-50mar.htm

122-fc634thermistor.htm

122-t05-634thermistor.htm

122-fc635.htm

122-fc635qsk38-50mar.htm

122-t05-635qsk38-50mar.htm

122-fc635thermistor.htm

122-t05-635thermistor.htm

122-fc636.htm

122-fc636qsk38-50mar.htm

122-t05-636qsk38-50mar.htm

122-fc636thermistor.htm

122-t05-636thermistor.htm

122-fc637.htm

122-fc637qsk50mar.htm

122-t05-637qsk50mar.htm

122-fc637thermistor.htm

122-t05-637thermistor.htm

122-fc638.htm

122-fc638qsk50mar.htm

122-t05-638qsk50mar.htm

122-fc638thermistor.htm

122-t05-638thermistor.htm

122-fc641.htm

122-t05-641.htm

122-fc642.htm

122-t05-642.htm

122-fc643.htm

122-t05-643.htm

122-fc644.htm

122-t05-644.htm

122-fc645.htm

122-t05-645.htm

122-fc646.htm

122-t05-646.htm

122-fc647.htm

122-t05-647.htm

122-fc648.htm

122-t05-648.htm

122-fc652.htm

122-t05-652.htm

122-fc653.htm

122-t05-653.htm

122-fc654.htm

122-t05-654.htm

122-fc655.htm

122-t05-655.htm

122-fc656.htm

122-t05-656.htm

122-fc657.htm

122-t05-657.htm

122-fc658.htm

122-t05-658.htm

122-fc671.htm

122-fc671qsk38-50mar.htm

122-t05-671qsk38-50mar.htm

122-fc671thermistor.htm

122-t05-671thermistor.htm

122-fc672.htm

122-fc672qsk38-50mar.htm

122-t05-672qsk38-50mar.htm

122-fc672thermistor.htm

122-t05-672thermistor.htm

122-fc673.htm

122-fc673qsk38-50mar.htm

122-t05-673qsk38-50mar.htm

122-fc673thermistor.htm

122-t05-673thermistor.htm

122-fc674.htm

122-fc674qsk38-50mar.htm

122-t05-674qsk38-50mar.htm

122-fc674thermistor.htm

122-t05-674thermistor.htm

122-fc675.htm

122-fc675qsk38-50mar.htm

122-t05-675qsk38-50mar.htm

122-fc675thermistor.htm

122-t05-675thermistor.htm

122-fc676.htm

122-fc676qsk38-50mar.htm

122-t05-676qsk38-50mar.htm

122-fc676thermistor.htm

122-t05-676thermistor.htm

122-fc677.htm

122-fc677qsk50mar.htm

122-t05-677qsk50mar.htm

122-fc677thermistor.htm

122-t05-677thermistor.htm

122-fc678.htm

122-fc678qsk50mar.htm

122-t05-678qsk50mar.htm

122-fc678thermistor.htm

122-t05-678thermistor.htm

122-fc689.htm

122-t05-689.htm

122-fc721.htm

122-fc721qsk38-50mar.htm

122-t05-721qsk38-50mar.htm

122-fc721thermistor.htm

122-t05-721thermistor.htm

122-fc722.htm

122-fc722qsk38-50mar.htm

122-t05-722qsk38-50mar.htm

122-fc722thermistor.htm

122-t05-722thermistor.htm

122-fc723.htm

122-fc723qsk38-50mar.htm

122-t05-723qsk38-50mar.htm

122-fc723thermistor.htm

122-t05-723thermistor.htm

122-fc724.htm

122-fc724qsk38-50mar.htm

122-t05-724qsk38-50mar.htm

122-fc724thermistor.htm

122-t05-724thermistor.htm

122-fc725.htm

122-fc725qsk38-50mar.htm

122-t05-725qsk38-50mar.htm

122-fc725thermistor.htm

122-t05-725thermistor.htm

122-fc726.htm

122-fc726qsk38-50mar.htm

122-t05-726qsk38-50mar.htm

122-fc726thermistor.htm

122-t05-726thermistor.htm

122-fc727.htm

122-fc727qsk50mar.htm

122-t05-727qsk50mar.htm

122-fc727thermistor.htm

122-t05-727thermistor.htm

122-fc728.htm

122-fc728qsk50mar.htm

122-t05-728qsk50mar.htm

122-fc728thermistor.htm

122-t05-728thermistor.htm

122-fc731.htm

122-t05-731.htm

122-fc783.htm

122-t05-783.htm

122-fc1117.htm

122-fc1117sa00.htm

122-t05-1117sa00.htm

122-fc1117sa01.htm

122-t05-1117sa01.htm

122-fc1117sa144.htm

122-t05-1117sa144.htm

122-fc1256.htm

122-fc1256sa00.htm

122-t05-1256sa00.htm

122-fc1256sa01.htm

122-t05-1256sa01.htm

122-fc1256sa144.htm

122-t05-1256sa144.htm

122-fc1257.htm

122-fc1257sa00.htm

122-t05-1257sa00.htm

122-fc1257sa01.htm

122-t05-1257sa01.htm

122-fc1257sa144.htm

122-t05-1257sa144.htm

122-fc1357.htm

122-t05-1357.htm

122-fc1358.htm

122-t05-1358.htm

122-fc1359.htm

122-t05-1359.htm

122-fc1361.htm

122-t05-1361.htm

122-fc1362.htm

122-t05-1362.htm

122-fc1367.htm

122-t05-1367.htm

122-fc1368.htm

122-t05-1368.htm

122-fc1369.htm

122-t05-1369.htm

122-fc1373.htm

122-t05-1373.htm

122-fc1376.htm

122-t05-1376.htm

122-fc1377.htm

122-t05-1377.htm

122-fc1378.htm

122-t05-1378.htm

122-fc1381.htm

122-t05-1381.htm

122-fc1383.htm

122-t05-1383.htm

122-fc1384.htm

122-t05-1384.htm

122-fc1385.htm

122-t05-1385.htm

122-fc1386.htm

122-t05-1386.htm

122-fc1411.htm

122-t05-1411.htm

122-fc1412.htm

122-t05-1412.htm

122-fc1418.htm

122-t05-1418.htm

122-fc1427.htm

122-t05-1427.htm

122-fc1428.htm

122-t05-1428.htm

122-fc1429.htm

122-t05-1429.htm

122-fc1431.htm

122-t05-1431.htm

122-fc1432.htm

122-t05-1432.htm

122-fc1514.htm

122-t05-1514.htm

122-fc1517.htm

122-t05-1517.htm

122-fc1518.htm

122-t05-1518.htm

122-fc1519.htm

122-t05-1519.htm

122-fc1521.htm

122-fc1521qsk38-50mar.htm

122-t05-1521qsk38-50mar.htm

122-fc1521thermistor.htm

122-t05-1521thermistor.htm

122-fc1522.htm

122-fc1522qsk38-50mar.htm

122-t05-1522qsk38-50mar.htm

122-fc1522thermistor.htm

122-t05-1522thermistor.htm

122-fc1523.htm

122-fc1523qsk38-50mar.htm

122-t05-1523qsk38-50mar.htm

122-fc1523thermistor.htm

122-t05-1523thermistor.htm

122-fc1524.htm

122-fc1524qsk38-50mar.htm

122-t05-1524qsk38-50mar.htm

122-fc1524thermistor.htm

122-t05-1524thermistor.htm

122-fc1525.htm

122-fc1525qsk38-50mar.htm

122-t05-1525qsk38-50mar.htm

122-fc1525thermistor.htm

122-t05-1525thermistor.htm

122-fc1526.htm

122-fc1526qsk38-50mar.htm

122-t05-1526qsk38-50mar.htm

122-fc1526thermistor.htm

122-t05-1526thermistor.htm

122-fc1527.htm

122-fc1527qsk50mar.htm

122-t05-1527qsk50mar.htm

122-fc1527thermistor.htm

122-t05-1527thermistor.htm

122-fc1529.htm

122-fc1529qsk38-50mar.htm

122-t05-1529qsk38-50mar.htm

122-fc1529thermistor.htm

122-t05-1529thermistor.htm

122-fc1531.htm

122-fc1531qsk38-50mar.htm

122-t05-1531qsk38-50mar.htm

122-fc1531thermistor.htm

122-t05-1531thermistor.htm

122-fc1532.htm

122-fc1532qsk38-50mar.htm

122-t05-1532qsk38-50mar.htm

122-fc1532thermistor.htm

122-t05-1532thermistor.htm

122-fc1533.htm

122-fc1533qsk38-50mar.htm

122-t05-1533qsk38-50mar.htm

122-fc1533thermistor.htm

122-t05-1533thermistor.htm

122-fc1534.htm

122-fc1534qsk38-50mar.htm

122-t05-1534qsk38-50mar.htm

122-fc1534thermistor.htm

122-t05-1534thermistor.htm

122-fc1535.htm

122-fc1535qsk50mar.htm

122-t05-1535qsk50mar.htm

122-fc1535thermistor.htm

122-t05-1535thermistor.htm

122-fc1536.htm

122-fc1536qsk50mar.htm

122-t05-1536qsk50mar.htm

122-fc1536thermistor.htm

122-t05-1536thermistor.htm

122-fc1542.htm

122-t05-1542.htm

122-fc1543.htm

122-t05-1543.htm

122-fc1544.htm

122-t05-1544.htm

122-fc1548.htm

122-fc1548qsk38.htm

122-t05-1548qsk38.htm

122-fc1548qsk50-60.htm

122-t05-1548qsk50-60.htm

122-fc1549.htm

122-fc1549qsk38.htm

122-t05-1549qsk38.htm

122-fc1549qsk50-60.htm

122-t05-1549qsk50-60.htm

122-fc1551.htm

122-fc1551qsk38.htm

122-t05-1551qsk38.htm

122-fc1551qsk50-60.htm

122-t05-1551qsk50-60.htm

122-fc1552.htm

122-fc1552qsk38.htm

122-t05-1552qsk38.htm

122-fc1552qsk50-60.htm

122-t05-1552qsk50-60.htm

122-fc1553.htm

122-fc1553qsk38.htm

122-t05-1553qsk38.htm

122-fc1553qsk50-60.htm

122-t05-1553qsk50-60.htm

122-fc1554.htm

122-t05-1554.htm

122-fc1555.htm

122-t05-1555.htm

122-fc1556.htm

122-t05-1556.htm

122-fc1557.htm

122-t05-1557.htm

122-fc1595.htm

122-t05-1595.htm

122-fc1596.htm

122-t05-1596.htm

122-fc1597.htm

122-t05-1597.htm

122-fc1618.htm

122-fc1618qsk38-50mar.htm

122-t05-1618qsk38-50mar.htm

122-fc1618thermistor.htm

122-t05-1618thermistor.htm

122-fc1619.htm

122-fc1619qsk38-50mar.htm

122-t05-1619qsk38-50mar.htm

122-fc1619thermistor.htm

122-t05-1619thermistor.htm

122-fc1622.htm

122-fc1622qsk38.htm

122-t05-1622qsk38.htm

122-fc1622qsk50-60.htm

122-t05-1622qsk50-60.htm

122-fc1774.htm

122-t05-1774.htm

122-fc1843.htm

122-t05-1843.htm

122-fc1844.htm

122-t05-1844.htm

122-fc1845.htm

122-t05-1845.htm

122-fc1846.htm

122-t05-1846.htm

122-fc1847.htm

122-t05-1847.htm

122-fc1852.htm

00-t05-1852.htm

122-fc1888.htm

122-t05-1888.htm

122-fc1889.htm

122-t05-1889.htm

122-fc1891.htm

122-t05-1891.htm

122-fc1911.htm

122-t05-1911.htm

122-fc1978.htm

122-t05-1978.htm

122-fc1979.htm

122-t05-1979.htm

122-fc1984.htm

122-t05-1984.htm

122-fc1985.htm

122-t05-1985.htm

122-fc1986.htm

122-t05-1986.htm

122-fc1992.htm

122-t05-1992.htm

122-fc2121.htm

122-fc2121qsk38-50mar.htm

122-t05-2121qsk38-50mar.htm

122-fc2121thermistor.htm

122-t05-2121thermistor.htm

122-fc2122.htm

122-fc2122qsk38-50mar.htm

122-t05-2122qsk38-50mar.htm

122-fc2122thermistor.htm

122-t05-2122thermistor.htm

122-fc2123.htm

122-fc2123qsk38-50mar.htm

122-t05-2123qsk38-50mar.htm

122-fc2123thermistor.htm

122-t05-2123thermistor.htm

122-fc2124.htm

122-fc2124qsk38-50mar.htm

122-t05-2124qsk38-50mar.htm

122-fc2124thermistor.htm

122-t05-2124thermistor.htm

122-fc2125.htm

122-fc2125qsk38-50mar.htm

122-t05-2125qsk38-50mar.htm

122-fc2125thermistor.htm

122-t05-2125thermistor.htm

122-fc2126.htm

122-fc2126qsk38-50mar.htm

122-t05-2126qsk38-50mar.htm

122-fc2126thermistor.htm

122-t05-2126thermistor.htm

122-fc2127.htm

122-fc2127qsk50mar.htm

122-t05-2127qsk50mar.htm

122-fc2127thermistor.htm

122-t05-2127thermistor.htm

122-fc2128.htm

122-fc2128qsk50mar.htm

122-t05-2128qsk50mar.htm

122-fc2128thermistor.htm

122-t05-2128thermistor.htm

122-fc2131.htm

122-fc2131qsk38-50mar.htm

122-t05-2131qsk38-50mar.htm

122-fc2131thermistor.htm

122-t05-2131thermistor.htm

122-fc2132.htm

122-fc2132qsk38-50mar.htm

122-t05-2132qsk38-50mar.htm

122-fc2132thermistor.htm

122-t05-2132thermistor.htm

122-fc2133.htm

122-fc2133qsk38-50mar.htm

122-t05-2133qsk38-50mar.htm

122-fc2133thermistor.htm

122-t05-2133thermistor.htm

122-fc2134.htm

122-fc2134qsk38-50mar.htm

122-t05-2134qsk38-50mar.htm

122-fc2134thermistor.htm

122-t05-2134thermistor.htm

122-fc2135.htm

122-fc2135qsk38-50mar.htm

122-t05-2135qsk38-50mar.htm

122-fc2135thermistor.htm

122-t05-2135thermistor.htm

122-fc2136.htm

122-fc2136qsk38-50mar.htm

122-t05-2136qsk38-50mar.htm

122-fc2136thermistor.htm

122-t05-2136thermistor.htm

122-fc2137.htm

122-fc2137qsk50mar.htm

122-t05-2137qsk50mar.htm

122-fc2137thermistor.htm

122-t05-2137thermistor.htm

122-fc2138.htm

122-fc2138qsk50mar.htm

122-t05-2138qsk50mar.htm

122-fc2138thermistor.htm

122-t05-2138thermistor.htm

122-fc2144.htm

122-t05-2144.htm

122-fc2157.htm

122-t05-2157.htm

122-fc2158.htm

122-t05-2158.htm

122-fc2159.htm

122-t05-2159.htm

122-fc2185.htm

122-fc2185ind.htm

122-t05-2185ind.htm

122-fc2185pg.htm

122-t05-2185pg.htm

122-fc2186.htm

122-fc2186ind.htm

122-t05-2186ind.htm

122-fc2186pg.htm

122-t05-2186pg.htm

122-fc2195.htm

122-t05-2195.htm

122-fc2215.htm

122-t05-2215.htm

122-fc2216.htm

122-t05-2216.htm

122-fc2261.htm

122-t05-2261.htm

122-fc2262.htm

122-t05-2262.htm

122-fc2265.htm

122-t05-2265.htm

122-fc2266.htm

122-t05-2266.htm

122-fc2311.htm

122-t05-2311.htm

122-fc2377.htm

122-t05-2377.htm

122-fc2474.htm

122-t05-2474.htm

122-fc2557.htm

122-t05-2557.htm

122-fc2558.htm

122-t05-2558.htm

122-fc2562.htm

00-t05-2562.htm

122-fc2619.htm

122-t05-2619.htm

122-fc2651.htm

122-t05-2651.htm

122-fc2652.htm

122-t05-2652.htm

122-fc2653.htm

122-t05-2653.htm

122-fc2654.htm

122-t05-2654.htm

122-fc2655.htm

122-t05-2655.htm

122-fc2656.htm

122-t05-2656.htm

122-fc2657.htm

122-t05-2657.htm

122-fc2658.htm

122-t05-2658.htm

122-fc2661.htm

122-t05-2661.htm

122-fc2662.htm

122-t05-2662.htm

122-fc2697.htm

122-t05-2697.htm

122-fc2727.htm

122-t05-2727.htm

122-fc2734.htm

122-t05-2734.htm

122-fc2963.htm

122-t05-2963.htm

122-fc2998.htm

122-t05-2998.htm

122-fc3694.htm

122-t05-3694.htm

122-fc3695.htm

122-t05-3695.htm

122-fc3696.htm

122-t05-3696.htm

122-fc3722.htm

122-t05-3722.htm

122-fc3732.htm

122-t05-3732.htm

122-fc4615.htm

122-t05-4615.htm

122-fc4642.htm

00-t05-4642.htm

122-fc4688.htm

122-t05-4688.htm

122-fc4689.htm

122-t05-4689.htm

122-fc5119.htm

122-t05-5119.htm

122-fc5121.htm

122-t05-5121.htm

122-fc5366.htm

00-t05-5366.htm

122-fc5367.htm

00-t05-5367.htm

122-fc5633.htm

122-fc5633aux.htm

00-t05-5633.htm

122-fc5633prop.htm

00-t05-5633.htm

122-fc5634.htm

122-fc5634aux.htm

00-t05-5634.htm

122-fc5634prop.htm

00-t05-5634.htm

122-fc5635.htm

122-fc5635aux.htm

00-t05-5635.htm

122-fc5635prop.htm

00-t05-5635.htm

122-fc5932.htm

00-t05-5932.htm

122-fc5946.htm

00-t05-5946.htm

122-fc6719.htm

122-t05-6719.htm

122-fc7313.htm

122-t05-7313.htm

122-fc7314.htm

122-t05-7314.htm