QSK19 CM2150 MCRS, QSK19 CM2150 MCRS Power Gen, QSK19/23 CM2350 MCRS K114/K115/K127, QST30 CM2350 T101/T102, QST30 CM2350 T101/T102,

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: SPN: 612 FMI: 2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect | Fueling to the injectors is disabled and the engine can not be started.
QSK19 CM2150 Industrial/ - Engine Crankshaft Speed/Position and Engine Camshaft Speed/Position Sensor Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Engine Crankshaft Speed/Position and Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine crankshaft speed/position sensor and the engine camshaft speed/position sensor are connected to the engine wiring harness.

Component Location

The engine crankshaft speed/position sensor reads a tone wheel mounted to the engine crankshaft. The sensor is located on the left side of the cylinder block toward the flywheel. The engine camshaft speed/position sensor reads a tone wheel inside the front gear cover. The sensor is located on the left side of the engine on the back of the gear housing.

Shop Talk

The engine crankshaft speed/position sensor and engine camshaft speed/position sensor use the same style sensor and the connector keys are the same. It is possible to connect the wiring harness to the incorrect sensors. If this occurs, the ECM will detect the problem and the engine will not start. Once the connector problem is corrected, the engine can be started and the fault code will become inactive.

Refer to Troubleshooting Fault Code t05-115.

Last Modified: 20-Jan-2011
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: SPN: 102 FMI: 3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Engine power derate to no air setting for industrial applications. None on performance for power generation applications.
QSK19 CM2150 Industrial - Intake Manifold 1 Pressure Sensor Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The intake manifold 1 pressure sensor monitors intake manifold pressure and passes information to the ECM through the engine harness. If the intake manifold 1 pressure sensor circuit voltage becomes too high, it will cause a derate condition on automotive applications. For marine applications, no derate condition occurs. There is no engine protection for a circuit or a malfunctioning sensor.

Component Location

The intake manifold 1 pressure sensor is located in the air intake. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold 1 pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-122.

Last Modified: 20-Jan-2011


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: SPN: 102 FMI: 4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the intake manifold pressure circuit. | Engine power derate to no air setting for industrial applications. None on performance for power generation applications.
QSK19 CM2150 Industrial - Intake Manifold 1 Pressure Sensor Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The intake manifold 1 pressure sensor monitors intake manifold pressure and passes information to the ECM through the engine harness. If the intake manifold 1 pressure sensor circuit voltage becomes too low, it will cause a derate condition.

Component Location

The intake manifold 1 pressure sensor is located in the air intake. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold 1 pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-123.

Last Modified: 20-Jan-2011


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: SPN: 100 FMI: 3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
QSK19 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts it to a pressure value.

Component Location

The engine oil rifle pressure 1 sensor is located on the left side of the engine block. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine oil rifle pressure 1 sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-135.

Last Modified: 20-Jan-2011


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: SPN: 100 FMI: 4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
QSK19 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts it to a pressure value.

Component Location

The engine oil rifle pressure 1 sensor is located on the left side of the engine block. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine oil rifle pressure 1 sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-141.

Last Modified: 20-Jan-2011


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: SPN: 100 FMI: 18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Calibration dependent progressive power derate and engine shutdown with increasing time after alert.
QSK19 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the SIGNAL pin and converts it to a pressure value.

Component Location

The engine oil rifle pressure 1 sensor is located on the left side of the engine block. Refer to Procedure 100-002 in Section E.

Refer to Troubleshooting Fault Code t05-143.

Last Modified: 20-Jan-2011


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for engine coolant temperature.
QSK19 CM2150 - Engine Coolant Temperature 1 Sensor Circuit
QSK19 CM2150 Power Generation - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and for engine emissions control.

Component Location

The engine coolant temperature 1 sensor is located on the thermostat housing.

Refer to Procedure 100-002 in Section E.

Shop Talk

Before troubleshooting Fault Code 144, check for multiple faults.

The engine coolant temperature 1 sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
40 | 104 | 4.9k to 5.8k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code t05-144.

Last Modified: 20-Jan-2011


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: SPN: 110 FMI: 4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for engine coolant temperature.
QSK19 CM2150 - Engine Coolant Temperature 1 Sensor Circuit
QSK19 CM2150 Power Generation - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature 1 sensor is located on the thermostat housing. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine coolant temperature 1 sensor shares RETURN wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code t05-145.

Last Modified: 20-Jan-2011


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine coolant temperature signal indicates engine coolant temperature is above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
QSK19 CM2150 - Engine Coolant Temperature 1 Sensor Circuit
QSK19 CM2150 Power Generation - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature 1 sensor is located in the thermostat housing. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592.

Refer to Troubleshooting Fault Code t05-146.

Last Modified: 20-Jan-2011


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: SPN: 110 FMI: 0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Calibration-dependent progressive power derate and engine shutdown with increasing time after alert.
QSK19 CM2150 - Engine Coolant Temperature 1 Sensor Circuit
QSK19 CM2150 Power Generation - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emission control.

Component Location

The engine coolant temperature 1 sensor is located on the thermostat housing. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code t05-151.

Last Modified: 20-Jan-2011


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold air temperature.
QSK19 CM2150 - Intake Manifold 1 Temperature Sensor Circuit
QSK19 CM2150 Power Generation - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold 1 temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold 1 temperature sensor shares RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
40 | 104 | 4.9k to 5.8k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code t05-153.

Last Modified: 20-Jan-2011


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold 1 temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold air temperature.
QSK19 CM2150 - Intake Manifold 1 Temperature Sensor Circuit
QSK19 CM2150 Power Generation - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 1 temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold 1 temperature sensor shares RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
40 | 104 | 4.9k to 5.8k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code t05-154.

Last Modified: 20-Jan-2011


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Intake manifold 1 temperature above engine protection critical limit. | Industrial: Calibration dependent progressive power derate and engine shutdown with increasing time after alert. Power Generation: Calibration dependent possible engine shutdown.
QSK19 CM2150 Industrial - Intake Manifold 1 Temperature Sensor Circuit
QSK19 CM2150 Power Generation - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 1 temperature sensor is located in the air intake manifold. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersize charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-155.

Last Modified: 20-Jan-2011


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 2 circuit. | Loss of some sensor functionality.
QSK19 CM2150 Industrial - Sensor Supply 2 Circuit
QSK19 CM2150 Marine - Sensor Supply 2 Circuit
QSK19 CM2150 Power Generation - Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the ECM provides a 5 volt supply for the engine camshaft speed/position sensor, intake manifold 1 pressure sensor, fuel delivery pressure sensor, barometric pressure sensor, and injector metering rail 1 pressure sensor.

Component Location

The sensor supply 2 is located in the ECM. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a SUPPLY wire, a short circuit between a SUPPLY wire or a RETURN wire, a damaged sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code t05-187.

Last Modified: 20-Jan-2011


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
QSK19 CM2150 Industrial - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Marine with C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Power Generation - Coolant Level Sensor 1 Circuit

Circuit Description

The ECM supplies a 5 volt supply to the engine coolant level sensor 1 using a common sensor supply circuit. The ECM also provides a ground on the engine coolant level sensor 1 return circuit. The coolant level sensor 1 monitors the engine coolant level within the coolant system and passes information to the ECM through the OEM harness and engine harness.

Component Location

The coolant level sensor 1 is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for location.

Shop Talk

Some engines are equipped with a 2-wire sensor instead of a 3-wire sensor. The 2-wire sensors do not have the 5 volt supply wire in the circuit.

Possible causes of this fault code include:

  • Open return or return circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage (3-wire sensors only).
Refer to Troubleshooting Fault Code t05-195.

Last Modified: 20-Jan-2011


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
QSK19 CM2150 Industrial - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Marine with C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Power Generation - Coolant Level Sensor 1 Circuit

Circuit Description

The ECM supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant level sensor 1 monitors the engine coolant level within the coolant system and passes information to the ECM through the OEM harness and engine harness.

Component Location

The coolant level sensor 1 is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for location.

Shop Talk

Some engines are equipped with a 2-wire sensor instead of a 3-wire sensor. The 2-wire sensors do not have the 5 volt supply wire in the circuit.

Possible causes of this fault code include:

  • Signal circuit shorted to ground or return in the harness, sensor, or connectors
  • Open supply circuit.
Refer to Troubleshooting Fault Code t05-196.

Last Modified: 20-Jan-2011


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low engine coolant level detected. | None on performance.
QSK19 CM2150 Industrial - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Marine with C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Power Generation - Coolant Level Sensor 1 Circuit

Circuit Description

The ECM supplies a 5 volt supply to the engine coolant level sensor using a common sensor SUPPLY circuit. The ECM also provides a ground on the sensor RETURN circuit. The coolant level sensor 1 monitors the engine coolant level within the coolant system and passes information to the ECM through the OEM harness and engine harness.

Component Location

The coolant level sensor 1 is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for location.

Shop Talk

Some engines are equipped with a 2-wire sensor instead of a 3-wire sensor. The 2-wire sensors do not have the 5 volt supply wire in the circuit.

Possible causes of this fault code include:

  • Open RETURN or SIGNAL circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage
  • Open SUPPLY circuit in the harness (on 3-wire sensors only).
Refer to Troubleshooting Fault Code t05-197.

Last Modified: 20-Jan-2011


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | Power derate can occur depending on application and calibration.
QSK19 CM2150 Industrial - Barometric Pressure Sensor Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor is used by the ECM to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness, on the fuel pump side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

The barometric pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

Possible causes of this fault code include:

  • Open RETURN circuit in the harness, connectors, or sensor
  • SIGNAL circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-221.

Last Modified: 20-Jan-2011


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at barometric pressure circuit. | Power derate can occur depending on application and calibration.
QSK19 CM2150 Industrial - Barometric Pressure Sensor Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor is used by the ECM to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness, on the fuel pump side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

The barometric pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple fault codes.

Possible causes of this fault code include:

  • SIGNAL circuit open or shorted to ground in the engine harness or sensor
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-222.

Last Modified: 20-Jan-2011


Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 223

Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 223 PID: SPN: 1265 FMI: 4 LAMP: Amber SRT: | Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source. The Centinel™ burn valve solenoid circuit is shorted. Less than 18-VDC detected at the Centinel™ burn valve solenoid SUPPLY pin of the 60-pin harness connector, or resistance of the solenoid has dropped below specifications. | ECM turns off the burn valve solenoid driver supply voltage and the system is disabled.
QSK19 CM2150 Marine - Engine Oil Burn Valve Solenoid Driver Circuit
QSK19 CM2150 Industrial - Engine Oil Burn Valve Solenoid Driver Circuit
QSK19 CM2150 Power Generation - Engine Oil Burn Valve Solenoid Driver Circuit

Circuit Description

The engine oil burn valve solenoid driver controls the flow of engine oil in the oil control valve during the burn cycle.

Component Location

Refer to the OEM service manual for a detailed component location view.

Shop Talk

Possible causes of this fault code include:

  • Damaged Centinel™ burn valve
  • Short circuit to ground on the output device driver wire
  • Pin-to-pin short circuit in the output device driver wire.
Refer to Troubleshooting Fault Code t05-223.

Last Modified: 20-Jan-2011


Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 224

Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 224 PID: SPN: 1265 FMI: 3 LAMP: Amber SRT: | Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source. High voltage has been detected at the Centinel™ burn valve solenoid driver pin in the engine harness 60-pin connector, or resistance of the solenoid is above specifications. | ECM turns off the burn valve solenoid driver supply voltage and the system is disabled.
QSK19 CM2150 Marine - Engine Oil Burn Valve Solenoid Driver Circuit
QSK19 CM2150 Industrial - Engine Oil Burn Valve Solenoid Driver Circuit
QSK19 CM2150 Power Generation - Engine Oil Burn Valve Solenoid Driver Circuit

Circuit Description

The engine oil burn valve solenoid driver controls the flow of engine oil in the oil control valve during the burn cycle.

Component Location

Refer to the OEM service manual for a detailed component location view.

Shop Talk

Possible causes of this fault code include:

  • Damaged Centinel™ burn valve
  • Open circuit in the output device driver return wire
  • Pin-to-pin short in the output device driver wire.
Refer to Troubleshooting Fault Code t05-224.

Last Modified: 20-Jan-2011


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply 2 circuit. | Loss of some sensor functionality.
QSK19 CM2150 Industrial - Sensor Supply 2 Circuit
QSK19 CM2150 Marine - Sensor Supply 2 Circuit
QSK19 CM2150 Power Generation - Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the ECM provides 5 volts for the engine camshaft speed/position sensor, intake manifold 1 pressure sensor, fuel delivery pressure sensor, barometric pressure sensor, and injector metering rail 1 pressure sensor.

Component Location

The sensor supply voltage 2 is located inside the ECM. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to battery voltage in engine harness or connectors
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-227.

Last Modified: 20-Jan-2011


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: SPN: 190 FMI: 0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Fuel injection disabled until engine speed falls below the overspeed limit.
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine crankshaft speed/position sensor and the engine camshaft speed/position sensor provide engine speed and position information to the electronic control module (ECM) through the engine harness.

Component Location

The engine crankshaft speed/position sensor is located on the intake side of the engine, near cylinder 6 at the crankshaft centerline. The engine camshaft speed/position sensor is located above the fuel pump, in the back of the gear housing.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-234.

Last Modified: 20-Jan-2011


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: SPN: 111 FMI: 1 LAMP: Red SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level. Low engine coolant level detected. | Industrial: Calibration dependent progressive derate and possible engine shutdown with increasing time after alert.
QSK19 CM2150 Industrial - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Marine with C Command™ Panel System - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Coolant Level Sensor 1 Circuit
QSK19 CM2150 Power Generation - Coolant Level Sensor 1 Circuit

Circuit Description

The coolant level sensor 1 monitors the engine coolant level within the coolant system and passes information to the ECM through the OEM harness and engine harness.

Component Location

The coolant level sensor 1 is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for a detailed component location view.

Shop Talk

This fault code becomes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-235.

Last Modified: 20-Jan-2011


External Speed Command Input (Multiple-Unit Synchronization) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 237

External Speed Command Input (Multiple-Unit Synchronization) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 237 PID: SPN: 644 FMI: 2 LAMP: Amber SRT: | External Speed Command Input (Multiple-Unit Synchronization) - Data Erratic, Intermittent, or Incorrect. Duty cycle of input throttle signal pin of the engine harness is less than 3 percent or more than 97 percent. | The primary engine and secondary engines are shut down with increasing time after the alert if hard-coupled. Only the secondary engine(s) are shut down with increasing time after the alert, if soft-coupled.
QSK19 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Multiple Unit Synchronization Switch 1 Circuit
QSK19 CM2150 Marine Propulsion with C Command™ Panel System - Multiple Unit Synchronization Switch 1 Circuit

Circuit Description

The primary engine outputs a throttle duty cycle signal on the original equipment manufacturer (OEM) actuator pulse width modulated (PWM) output supply pin. This signal is received by the secondary engine(s) and is used as the throttle input. To complete this circuit, a 5 volt supply is provided by the OEM and connected to the intermediate speed control/validate switch pin of the secondary engine(s).

Component Location

The PWM output supply is located in the engine harness 60-pin OEM port connector.

Shop Talk

The secondary engine(s) expect to see a duty cycle signal that varies between 3 and 97 percent. A signal less than 3 percent or greater than 97 percent will generate Fault Code 237 in the secondary engine(s).

Refer to Troubleshooting Fault Code 237.

Last Modified: 08-Jul-2010


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: SPN: 3511 FMI: 4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 3 circuit. | Loss of some sensor functionality. Possible hard starting and rough running.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 pin of the electronic control module (ECM) provides 5 volts for the engine crankshaft speed/position sensor.

Component Location

The sensor supply 3 is located in the ECM. Refer to Procedure 100-002 in Section E.

Shop Talk

Low voltage on the 5 volt SUPPLY wire can be caused by a short circuit to ground in a SUPPLY wire, a short between a SUPPLY wire or RETURN wire, a damaged engine crankshaft speed/position sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code t05-238.

Last Modified: 27-Jan-2011


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can possibly stay on continuously or not run at all.
QSK19 CM2150 Industrial - Fan Control Circuit

Circuit Description

The electronic control module (ECM) provides a signal to the fan control solenoid to turn the engine fan ON and OFF. There are two types of fans supported by this signal; variable speed and ON/OFF. Using INSITE™ electronic service tool, the fan type presently set up for use can be determined. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEM's will use a solenoid return that is wired to the ECM or use a return that goes to engine block or chassis ground.

Component Location

The fan control location varies by OEM. Refer to the OEM service manual.

Shop Talk

The fan control logic can be adjusted with INSITE™ electronic service tool. There are two choices: 12 or 24 volt ON, or 0 volt ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Refer to Troubleshooting Fault Code 245.

Last Modified: 28-Jun-2010


Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 248

Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 248 PID: SPN: 173 FMI: 16 LAMP: Amber SRT: | Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Exhaust gas temperature is above engine protection limit. | Calibration dependent progressive power derate and engine shutdown with increasing time after alert.
QSK19 CM2150 Marine - Exhaust Gas Temperature Sensor 1 Circuit

Circuit Description

The exhaust gas temperature sensor 1 circuit monitors exhaust gas temperature and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The exhaust gas temperature sensor 1 is located in the 90 degree exhaust elbow, after the turbocharger. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensor 1 measures the temperature of the exhaust air as it passes through the exhaust manifold. This fault code indicates that exhaust gas temperature has exceeded the warning threshold limits for high exhaust gas temperature.

Exhaust Gas Temperature
Temperature (°C) | Temperature [°F] | Resistance (ohms)
50 | 122 | 2,326,245
100 | 212 | 289,445 to 481,411
200 | 392 | 25,922 to 35,567
300 | 572 | 5,297 to 6,608
400 | 752 | 1,634 to 1,926
500 | 932 | 681 to 771
600 | 1112 | 347 to 379
700 | 1292 | 197 to 219
800 | 1472 | 124 to 139
900 | 1652 | 84.2 to 94.9
1000 | 1832 | 64.5
Refer to Troubleshooting Fault Code 248.

Last Modified: 10-Mar-2015


Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 261

Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: SPN: 174 FMI: 16 LAMP: Amber SRT: | Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine fuel temperature signal indicates engine fuel temperature is above engine protection warning limit. | Calibration dependent progressive power and speed derate and engine shutdown with increasing time after alert.
QSK19 CM2150 Marine Auxiliary - Engine Fuel Temperature Sensor 1 Circuit
QSK19 CM2150 Power Generation - Engine Fuel Temperature Sensor 1 Circuit

Circuit Description

The engine fuel temperature 1 sensor is used by the electronic control module (ECM) to monitor engine fuel supply temperature. The ECM monitors the voltage on the fuel supply temperature signal pin and converts it to a temperature value. The fuel supply temperature value is used by the ECM for the engine protection system.

Component Location

The engine fuel temperature 1 sensor is located above the second-stage filter head. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with the engine fuel temperature. If the sensor is operating properly, the observed reading will be comparable to the values in the following table.

Engine Fuel Temperature and Corresponding Sensor Resistance
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-261.

Last Modified: 27-Jan-2011


Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: SPN: 174 FMI: 3 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. Greater than 4.95-VDC detected at the fuel temperature signal pin of the engine harness 60-pin OEM port connector. | Electronic control module (ECM) will set a default value for fuel temperature. No other action taken by ECM.
QSK19 CM2150 Marine - Engine Fuel Temperature Sensor 1 Circuit
QSK19 CM2150 Industrial - Engine Fuel Temperature Sensor 1 Circuit
QSK19 CM2150 Power Generation - Engine Fuel Temperature Sensor 1 Circuit

Circuit Description

The engine fuel temperature sensor 1 is used by the ECM to monitor engine fuel temperature. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage on the fuel temperature signal pin. The ECM expects the voltage to vary between 0.5 and 4.95-VDC. If the voltage is above 4.95-VDC, the ECM will log Fault Code 263.

Voltage above 4.95-VDC on the fuel temperature signal pin can be caused by an open in the SIGNAL or RETURN wires, voltage shorts to the SIGNAL or RETURN wires, or a damaged open sensor.

Component Location

The engine fuel temperature sensor 1 is located above the second-stage filter head. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with the temperature. If the sensor is operating properly, the observed reading will be comparable to the values in the following table.

Engine Fuel Temperature
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-263.

Last Modified: 27-Jan-2011


Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: SPN: 174 FMI: 4 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Less than 0.21-VDC detected at the fuel temperature signal pin of the engine harness. | Electronic control module (ECM) will set a default value for fuel temperature. No other action taken by ECM.
QSK19 CM2150 Marine - Engine Fuel Temperature Sensor 1 Circuit
QSK19 CM2150 Industrial - Engine Fuel Temperature Sensor 1 Circuit
QSK19 CM2150 Power Generation - Engine Fuel Temperature Sensor 1 Circuit

Circuit Description

The engine fuel temperature sensor 1 is used by the ECM to monitor the temperature of the fuel. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage at the sensor SIGNAL pin. The ECM expects to see the voltage vary between 0.5 and 4.5-VDC. If the voltage is below 0.21-VDC, the ECM will log Fault Code 265. Voltage below 0.21-VDC on the sensor SIGNAL pin can be caused by a short to ground on the SUPPLY or RETURN wires or an internally grounded, damaged sensor.

Component Location

The engine fuel temperature sensor 1 is located on the left side of the engine, on the fuel filter head. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with the temperature. If the sensor is operating properly, the observed reading will be comparable to the values in the following table.

Engine Fuel Temperature
Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-265.

Last Modified: 27-Jan-2011


Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 266

Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 266 PID: SPN: 174 FMI: 0 LAMP: Red SRT: | Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. | Power derate and possible engine shutdown protection feature is enabled.
QSK19 CM2150 Marine Propulsion - Engine Fuel Temperature Sensor 1 Circuit
QSK19 CM2150 Industrial - Engine Fuel Temperature Sensor 1 Circuit

Circuit Description

The engine fuel temperature sensor 1 is used by the electronic control module (ECM) to monitor engine fuel supply temperature. The ECM monitors the voltage on the engine fuel temperature signal pin and converts this to a temperature value. The engine fuel temperature value is used by the ECM for the engine protection system.

Component Location

The engine fuel temperature sensor 1 is located on the fuel filter housing. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with the temperature. If the sensor is operating properly, the observed reading will be comparable to the values in the following table.

Engine Fuel Temperature
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code 266.

Last Modified: 06-Jul-2010


Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: SPN: 1347 FMI: 4 LAMP: Amber SRT: | Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel pump pressurizing assembly 1 circuit. | Engine will run poorly at idle. Engine will have low power. Fuel pressure will be higher than commanded.
QSK19 CM2150 Industrial - Fuel Pump Pressurizing Assembly 1 Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Fuel Pump Pressurizing Assembly 1 Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the electronic control module (ECM) that controls the fuel pump pressurizing assembly 1. The fuel pump pressurizing assembly 1 is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the high-pressure pump based on engine operating conditions. The fuel pump pressurizing assembly 1 valve is a normally open valve. The PWM duty cycle to the fuel pump pressurizing assembly 1 depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump pressurizing assembly 1 is located on the engine-mounted fuel pump housing. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the fuel pump pressurizing assembly 1 circuit.

Possible causes for this fault code include:

  • Short circuit to ground
  • Low resistance (fuel pump pressurizing assembly 1 coil is shorted internally).

When excessive current or a short circuit is detected, the ECM driver to the fuel pump pressurizing assembly 1 is turned OFF to protect the circuit. It is necessary to cycle the keyswitch OFF and then back on before the ECM will retest for the cause of the fault code. The ECM driver is activated at key ON. If the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors. Since the QSK19 CM2150 engines utilize a two-stage mechanical dump valve, malfunction of the fuel pump pressurizing assembly 1 will result in operation with the mechanical dump valve open. Extended operation with the mechanical dump valve open can damage the pressure relief valve.

Fault Code 2311 can have high counts if the fault condition is or was intermittent.

Refer to Troubleshooting Fault Code t05-271.

Last Modified: 27-Jan-2011


Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: SPN: 1347 FMI: 3 LAMP: Amber SRT: | Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the fuel pump pressurizing assembly 1. | Engine will not run or engine will run poorly.
QSK19 CM2150 Industrial - Fuel Pump Pressurizing Assembly 1 Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Fuel Pump Pressurizing Assembly 1 Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the electronic control module (ECM) that controls the fuel pump pressurizing assembly 1. The fuel pump pressurizing assembly 1 is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the high-pressure pump based on engine operating conditions. The fuel pump pressurizing assembly 1 valve is a normally open valve. The PWM duty cycle to the fuel pump pressurizing assembly 1 depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump pressurizing assembly 1 is located on the engine-mounted fuel pump housing. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault becomes active when the ECM detects an open fuel pump pressurizing assembly 1 circuit.

Possible causes of this fault code include:

  • Short circuit to a positive voltage
  • Open circuit in the fuel pump pressurizing assembly 1 circuit.

If there is a high harness resistance or an intermittent open circuit, Fault Code 2311 could have high inactive counts. If the fault code is intermittent, look for causes of an intermittent open circuit such as loose pins and bad connections. If the fault code is intermittent, look closely for loose wire connections at the ECM connector and wiggle the harness and/or the fuel pump pressurizing assembly 1.

Refer to Troubleshooting Fault Code t05-272.

Last Modified: 27-Jan-2011


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: SPN: 639 FMI: 9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The Cummins® ECM did not receive a multiplexed message from an OEM vehicle electronic control unit within the time limit or did not receive it at all. | One or more multiplexed devices will not operate properly. One or more symptoms will occur.
QSK19 CM2150 Industrial - SAE J1939 Multiplexing Configuration
QSK19 CM2150 Marine - SAE J1939 Multiplexing Configuration
QSK19 CM2150 Power Generation - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit or transmission electronic control unit in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM vehicle electronic control unit to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from an OEM vehicle electronic control unit or transmission electronic control unit are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM vehicle electronic control unit(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. The SAE J1939 data link wiring and vehicle electronic control unit location varies by OEM.

Shop Talk

Possible causes of this fault code include:

  • When the ECM is set up properly (components enabled and OEM vehicle electronic control unit source addressed correctly) to receive information from an OEM vehicle electronic control unit, but the OEM vehicle electronic control unit can possibly not actually be transmitting the message for that component. This can be caused when a multiplexed component is enabled in the Cummins® engine ECM, but the OEM vehicle electronic control unit source address of the vehicle electronic control unit transmitting the component message is incorrect in the Cummins® ECM, or the OEM vehicle electronic control unit is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a bad SAE J1939 data link connection between the OEM vehicle electronic control unit and Cummins® ECM, a bad connection between the component and the OEM vehicle electronic control unit, bad OEM vehicle electronic control unit, or bad Cummins® ECM. Contact the OEM for proper multiplexing configuration.

INSITE™ electronic service tool can monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-285.

Last Modified: 27-Jan-2011


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: SPN: 639 FMI: 13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
QSK19 CM2150 Industrial - SAE J1939 Multiplexing Configuration
QSK19 CM2150 Marine - SAE J1939 Multiplexing Configuration
QSK19 CM2150 Power Generation - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators and other components are connected to the electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit or transmission electronic control unit in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM vehicle electronic control unit to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from an OEM vehicle electronic control unit or transmission electronic control unit are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM vehicle electronic control unit(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. The SAE J1939 data link wiring and vehicle electronic control unit location varies by OEM.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM vehicle electronic control unit source addressed correctly) to receive information from an OEM vehicle electronic control unit, but the OEM vehicle electronic control unit is actually transmitting a message that says that component is not available for multiplexing. Use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-286.

Last Modified: 27-Jan-2011


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: SPN: 651 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector number 1 circuit or no current detected at number 1 injector driver or RETURN pin when the voltage supply at the harness is ON. | Engine can misfire or run rough.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. The injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injector above the rocker cover.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the damaged cylinder(s).
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the damaged condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of this single injector fault code include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.

Possible causes of multiple injector fault codes include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-322.

Last Modified: 27-Jan-2011


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: SPN: 655 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector cylinder 5 circuit or no current detected at cylinder 5 injector driver or RETURN pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. The injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injector, above the rocker cover.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the damaged cylinder(s).
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the damage is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector fault code include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-323.

Last Modified: 27-Jan-2011


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: SPN: 653 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector number 3 circuit, or no current detected at number 3 injector or RETURN pin when the voltage supply at the harness is ON. | Engine can misfire or run rough.
Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. The injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injector, above the rocker cover.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the damaged cylinder(s).
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the damage is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector fault code include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-324.

Last Modified: 27-Jan-2011


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: SPN: 656 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector cylinder 6 circuit or no current detected at cylinder 6 injector SIGNAL or RETURN pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. The injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injector, above the rocker cover.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the damaged cylinder(s).
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the damage is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector fault code include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.

Possible causes of multiple injector fault codes in the same bank include:

  • Short circuit in the engine harness(es) - either short to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-325.

Last Modified: 27-Jan-2011


Fuel Consumption Rate - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 327

Fuel Consumption Rate - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 327 PID: SPN: 183 FMI: 16 LAMP: Amber SRT: | Fuel Consumption Rate - Data Valid But Above Normal Operating Range - Moderately Severe Level. Adaptive power limiter feature - engine is producing power above rating. | Fueling is derated only to limit power to the appropriate rating.
Electronic Control Module

Circuit Description

The electronic control module (ECM) uses the adaptive power limiter feature to detect when the engine is producing power greater than the appropriate engine rating.

Component Location

The ECM is located on the left bank side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code is most often caused by over-fueling. This can cause excessive exhaust temperatures, turbocharger speed, and boost pressures. The ECM will limit fueling to bring these readings back to a normal range. Fault Code 3132 will log after excessive counts of Fault Code 327 have occurred.

Refer to Troubleshooting Fault Code 327.

Last Modified: 16-Jun-2010


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: SPN: 652 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector cylinder 2 circuit, or no current detected at cylinder 2 injector driver or RETURN pin when the voltage supply at the harness is on. | Engine can misfire or run rough.
Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. The injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injector, above the rocker cover.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the damaged cylinder(s).
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the damage is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector fault code include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.

Possible causes of multiple injector fault codes in the same bank include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-331.

Last Modified: 27-Jan-2011


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: SPN: 654 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. High resistance detected on injector cylinder 4 circuit or no current detected at cylinder 4 injector driver or RETURN pin when the voltage supply at the harness is on. | Engine can misfire or possibly run rough.
QSK19 CM2150 Power Generation - Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The ECM energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. The injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injector, above the rocker cover.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the damaged cylinder(s).
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is operating. If an injector circuit fault is active and the damage is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Possible causes of a single injector fault code include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.

Possible causes of multiple injector fault codes in the same bank include:

  • Short circuit in the engine harness(es) - shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-332.

Last Modified: 27-Jan-2011


Transmission Output Shaft Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 349

Transmission Output Shaft Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 349 PID: P191 SPN: 191 FMI: 0/16 LAMP: Amber SRT: | Transmission Output Shaft Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Engine will run off of a default auxiliary speed.
QSK19 CM2150 Industrial - External Speed Command Input Circuit
QSK19 CM2150 Marine Propulsion with C Command™ Panel System - External Speed Command Input Circuit
QSK19 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - External Speed Command Input Circuit

Circuit Description

The external speed command input circuit provides a means to govern the engine independent of engine speed. This circuit controls output shafts or other devices downstream of a torque convertor.

Component Location

The external speed command input circuit location varies with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Shop Talk

This fault can only be caused by a high-frequency input into the external speed command input circuit.

Refer to Troubleshooting Fault Code 349.

Last Modified: 08-Jul-2010


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: SPN: 627 FMI: 12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The ECM measured injector boost voltage is low. | Possible smoke, low power, engine misfire, and/or engine will not start.
QSK19 CM2150 Power Generation - Injector Circuit

Circuit Description

Between each injection event, the ECM attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors. This power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Shop Talk

This fault code will become active when the engine is operating, the primary engine speed sensor signal is present, the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

This fault code will become inactive when the keyswitch is turned ON.

This fault code will become inactive when the engine is operating and measured injector power supply voltage reaches the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code t05-351.

Last Modified: 28-Jan-2011


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: SPN: 3509 FMI: 4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply 1 circuit. | Loss of some sensor functionality.
QSK19 CM2150 Industrial - Sensor Supply 1 Circuit
QSK19 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK19 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK19 CM2150 Marine Propulsion with C Command™ Panel System - Sensor Supply 1 Circuit
QSK19 CM2150 Marine Auxiliary with C Command™ Panel System - Sensor Supply 1 Circuit
QSK19 CM2150 Power Generation - Sensor Supply 1 Circuit

Circuit Description

Sensor supply 1 from the ECM provides 5 volt supply for the engine oil rifle pressure 1 sensor on the engine harness. This 5 volt supply also powers two optional original equipment manufacturer (OEM) devices. The two devices are the remote accelerator pedal or lever position sensor, and the OEM pressure sensor.

Component Location

The sensor supply 1 is located in the ECM. The supply voltage is spliced off in the engine and OEM harness to each sensor it supports.

Shop Talk

Low voltage on the 5 volt SUPPLY wire can be caused by a short to ground in a SUPPLY wire, a short circuit between a SUPPLY wire and a RETURN wire, a damaged sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code t05-352.

Last Modified: 28-Jan-2011


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: SPN: 3509 FMI: 3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply 1 circuit. | Loss of some sensor functionality.
QSK19 CM2150 Industrial - Sensor Supply 1 Circuit
QSK19 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK19 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Sensor Supply 1 Circuit
QSK19 CM2150 Marine Propulsion with C Command™ - Sensor Supply 1 Circuit
QSK19 CM2150 Marine Auxiliary with C Command™ Panel System - Sensor Supply 1 Circuit
QSK19 CM2150 Power Generation - Sensor Supply 1 Circuit

Circuit Description

Sensor supply 1 of the ECM provides positive (+) 5 volts for the engine oil rifle pressure 1 sensor on the engine harness. This 5 volt supply also powers two original equipment manufacturer (OEM) devices. The two devices are the remote accelerator pedal or lever position sensor, and the OEM pressure sensor.

Component Location

The sensor supply 1 is located in the ECM. The supply voltage is spliced off in the engine and OEM harness to each sensor it supports.

Shop Talk

High voltage on the sensor wire can be caused by an individual sensor SUPPLY wire in the harness shorted to battery voltage or a damaged ECM power supply.

Refer to Troubleshooting Fault Code t05-386.

Last Modified: 28-Jan-2011


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: SPN: 100 FMI: 1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operating Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Calibration - dependent progressive power and speed derate and engine shutdown with increasing time after alert.
QSK19 CM2150 Industrial - Engine Oil Rifle Pressure 1 Sensor Circuit
QSK19 CM2150 Power Generation - Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, it will cause Fault Code 415 to log.

Component Location

The engine oil rifle pressure 1 sensor is located on the left side of the engine, on the block. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level.
Refer to Troubleshooting Fault Code t05-415.

Last Modified: 27-Jan-2011


Water In Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water In Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water in Fuel Indicator Sensor Circuit - Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
QSK19 CM2150 Industrial - Water In Fuel Indicator Sensor Circuit
QSK19 CM2150 Marine - Water In Fuel Indicator Sensor Circuit
QSK19 CM2150 Power Generation - Water In Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator sensor is attached to the first stage fuel filter. The water in fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator sensor circuit contains two wires; a water in fuel indicator RETURN (sensor RETURN 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator sensor is integrated into the bottom of the first stage fuel filter. The first stage fuel filter is located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.

The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.

The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

Drain the Stage 1 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active, and there is no water in the fuel filter then, a malfunctioning water in fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code t05-418

Last Modified: 17-Nov-2015


SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: SPN: 639 FMI: 2 LAMP: None SRT: | SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect. Communication between the ECM and another device on the SAE J1939 data link has been lost. | None on performance. SAE J1939 data link devices possibly do not operate.
QSK19 CM2150 Industrial - SAE J1939 Data Link Circuit
QSK19 CM2150 Power Generation - SAE J1939 Data Link Circuit
QSK19 CM2150 Marine - SAE J1939 Data Link Circuit

Circuit Description

Devices such as automatic braking system controllers, autoshift transmissions, vehicle ECM, automatic slip reduction systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) can communicate with the ECM over the SAE J1939 Data Link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 Data Link.

Component Location

The ECM is located on the intake side of the engine. The SAE J1939 data link wiring and the SAE J1939 data link devices vary by OEM options.

Shop Talk

This fault occurs whenever the ECM starts communicating with any other device using the SAE J1939 data link and then can no longer transmit on the data link. Possible causes of this fault include: Unplugging an electronic service tool before keying OFF the ECM, the SAE J1939 data link having an intermittent electrical problem, and the ECM (or another SAE J1939 data link device) tying up communications because of an electrical problem or by sending too many messages without stopping.

Refer to Troubleshooting Fault Code t05-426

Last Modified: 28-Jan-2011


Fault Code Path Selection

FAULT CODE 431
Fault Code Path Selection

Do you have an Integrated Sensor Switch (ISS) throttle pedal? | Go to 123-fc431iss
Do you have a Nonintegrated Sensor Switch (NISS) throttle pedal? | Go to 123-fc431niss

Last Modified: 01-Jun-2010


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine can stop operating or be difficult to start.
QSK19 CM2150 Industrial - Battery 1 Voltage
QSK19 CM2150 Marine Propulsion - Battery 1 Voltage
QSK19 CM2150 Marine Auxiliary - Battery 1 Voltage
QSK19 CM2150 Power Generation - Battery 1 Voltage

Circuit Description

The ECM receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is one 10-ampere fuse in the battery 1 voltage wires to protect the original equipment manufacturer (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery 1 voltage RETURN wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the intake side of the engine. The ECM is connected to the batteries by the OEM harness and engine harness. This direct link provides a constant power supply for the ECM. The location of the batteries will vary with the OEM. Refer to the OEM service manual for battery location.

Shop Talk

This fault code is logged when the ECM battery supply voltage drops below 6-VDC.

  • Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code t05-441.

Last Modified: 28-Jan-2011


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to all electrical components.
QSK19 CM2150 Industrial - Battery 1 Voltage Circuit
QSK19 CM2150 Marine Propulsion - Battery 1 Voltage Circuit
QSK19 CM2150 Marine Auxiliary - Battery 1 Voltage Circuit
QSK19 CM2150 Power Generation - Battery 1 Voltage Circuit

Circuit Description

The ECM receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is one 10-ampere fuse in the battery 1 voltage wire to protect the OEM harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery 1 voltage RETURN wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the intake side of the engine. The ECM is connected to the batteries by the engine and OEM harnesses. This direct link provides a constant power supply for the ECM. The location of the batteries will vary with the OEM. Refer to the OEM service manual for battery location.

Shop Talk

This fault code is logged when the ECM battery 1 voltage exceeds 36 volts.

Possible causes of this fault code include:

  • Damaged alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code t05-442.

Last Modified: 28-Jan-2011


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: SPN: 157 FMI: 0/0 LAMP: Red SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The ECM detects that injector metering rail 1 pressure has exceeded mechanical dump valve. | Fuel injection noise.
QSK19 CM2150 Industrial - Injector Metering Rail 1 Pressure Sensor Circuit
QSK19 CM2150 Power Generation - Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the gerotor pump. The ECM monitors the rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening or closing of the fuel pump pressurizing assembly 1.

The mechanical dump valve is set to trip at 1950 bar [28,282 psi]. After it trips, it then regulates at 900 to 1,300 bar [13,053 to 18,854 psi].

NOTE: Mechanical dump valve has not popped.

Component Location

The high-pressure fuel pump is mounted to the gear housing, on the intake side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

Replace the mechanical dump valve, even if the fault becomes inactive.

Refer to Troubleshooting Fault Code t05-449.

Last Modified: 28-Jan-2011


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: SPN: 157 FMI: 3 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at rail injector metering rail 1 pressure sensor circuit. | Power and or speed derate.
QSK19 CM2150 Industrial - Injector Metering Rail 1 Pressure Sensor Circuit
QSK19 CM2150 Power Generation - Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The injector metering rail 1 pressure sensor is used by the ECM to monitor the fuel pressure in the fuel pump pressurizing assembly 1. The sensor receives 5 volts from the ECM and is grounded by a RETURN pin. A third pin is the SIGNAL pin. The power and RETURN pins are shared with other devices on the engine.

Component Location

The injector metering rail 1 pressure sensor is installed in the fuel pump pressurizing assembly 1. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code will become active if there is an open circuit on any of the three pins (5 volt SUPPLY, SIGNAL, or RETURN) that connect the sensor or ECM to the wiring harness. This fault will also be active if the SIGNAL wire is shorted to a source of voltage. This fault code will become inactive any time the keyswitch is ON and the signal returns to a valid in-range voltage.

Possible causes for this fault code include:

  • Voltage (5-VDC or higher shorted to the SIGNAL wire)
  • Open circuit on the SIGNAL wire
  • Open circuit on the 5 volt SUPPLY wire
  • Open circuit on the RETURN wire
  • Damaged sensor
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-451.

Last Modified: 28-Jan-2011


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: SPN: 157 FMI: 4 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the rail fuel pressure sensor circuit. | Power and or speed derate.
QSK19 CM2150 Industrial - Injector Metering Rail 1 Pressure Sensor Circuit
QSK19 CM2150 Power Generation - Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The injector metering rail 1 pressure sensor is used by the ECM to monitor the fuel pressure in the fuel pump pressurizing assembly 1. The sensor receives 5 volts from the ECM and is grounded by a RETURN pin. A third pin is the SIGNAL pin. The power and RETURN pins are shared with other devices on the engine.

Component Location

The injector metering rail 1 pressure sensor is installed in the fuel pump pressurizing assembly 1. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code will become active any time the keyswitch is ON and the SIGNAL pin voltage of the ECM is too low. This can be caused by a short circuit to ground on the (+) 5 volt SUPPLY or SIGNAL wire. This fault will also become active if a device that is powered by the common (+) 5 volt power supply is shorted to ground. This fault code will become inactive any time the keyswitch is ON and the signal returns to a valid in-range voltage.

Possible causes for this fault code include:

  • Engine harness - the SUPPLY or SIGNAL wire is shorted to ground
  • Other components - any component connected to the common power supply is shorted to ground
  • Damaged sensor
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-452.

Last Modified: 28-Jan-2011


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: SPN: 105 FMI: 16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Intake manifold air temperature above engine protection limit. | For Industrial application: Calibration-dependent progressive power derate and engine shutdown with increasing time after alert. For Power Generation application: Calibration-dependent possible engine shutdown.
QSK19 CM2150 Industrial/QSK19 CM2150 Marine - Intake Manifold 1 Temperature Sensor Circuit
QSK19 CM2150 Power Generation - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold 1 temperature and passes information to the ECM through the engine harness.

Component Location

The intake manifold 1 temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersize charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-488.

Last Modified: 01-Apr-2011


Transmission Output Shaft Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 489

Transmission Output Shaft Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 489 PID: SPN: 191 FMI: 18 LAMP: Amber SRT: | Transmission Output Shaft Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level. Auxiliary speed frequency input signal (external speed command input) indicates the frequency is below a calibration-dependent threshold. | ECM changes engine speed to a calibration-dependent set point.
QSK19 CM2150 Industrial - External Speed Command Input Circuit
QSK19 CM2150 Marine Propulsion with C Command™ Panel System - External Speed Command Input Circuit
QSK19 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - External Speed Command Input Circuit

Circuit Description

The transmission output shaft input is a frequency signal from an auxiliary speed or pressure pickup. It is sent to the electronic control module (ECM) and is used to control the engine speed. Auxiliary reference speed is based on the accelerator position.

Component Location

The transmission output shaft or pressure pickup device location is dependent on the original equipment manufacturer (OEM) application. Refer to the OEM service manual for component location.

Shop Talk

The transmission output shaft governor controls engine speed based on a measured auxiliary speed or pressure.

Refer to Troubleshooting Fault Code 489.

Last Modified: 29-Jun-2010


Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 497

Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 497 PID: SPN: 1377 FMI: 2 LAMP: Amber SRT: | Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect | The multiple unit synchronization switch is disabled.
QSK19 CM2150 Industrial - Multiple Unit Synchronization Switch Circuit
QSK19 CM2150 Marine Propulsion with C Command™ Panel System - Multiple Unit Synchronization Switch Circuit
QSK19 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Multiple Unit Synchronization Switch Circuit

Circuit Description

The multiple unit synchronization switch 1 uses a complimentary switch to provide two opposite signals into the electronic control module (ECM).

Component Location

The multiple unit synchronization switch 1 is cab-mounted. Refer to the original equipment manufacturer (OEM) service manual for specific location.

Refer to Troubleshooting Fault Code 497.

Last Modified: 08-Jul-2010


Transmission Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 521

Transmission Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 521 PID: SPN: 175 FMI: 3 LAMP: Amber SRT: | Transmission (Gear) Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at transmission (gear) oil temperature sensor circuit. | No engine protection for transmission oil temperature.
Transmission (Gear) Oil Temperature Sensor Circuit

Circuit Description

The transmission (gear) oil temperature sensor is used by the engine control module (ECM) to monitor the transmission oil temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The transmission (gear) oil temperature sensor is located in the transmission.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Before troubleshooting Fault Code 521, check for multiple faults.

The transmission (gear) oil temperature sensor share RETURN wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes for this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 521.

Last Modified: 07-Dec-2016


Transmission Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 522

Transmission Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 522 PID: SPN: 175 FMI: 4 LAMP: Amber SRT: | Transmission Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at transmission (gear) oil temperature circuit. | No engine protection for transmission oil temperature.
Transmission (Gear) Oil Temperature Sensor Circuit

Circuit Description

Transmission (gear) oil temperature sensor is used by the engine control module (ECM) to monitor the transmission oil temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The transmission (gear) oil temperature sensor is located in the transmission.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The transmission (gear) oil temperature sensor shares RETURN wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 522, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 522.

Last Modified: 02-Jan-2017


Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 527

Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 527 PID: SPN: 702 FMI: 3 LAMP: Amber SRT: | Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source. The auxiliary input/output signal pin of the engine harness indicates an open or short circuit. | No action taken by the ECM.
QSK19 CM2150 Industrial/QSK19 CM2150 Marine Propulsion with C Command™ Panel System - Auxiliary Input/Output 2 Circuit
QSK19 CM2150 Marine Propulsion with C Command Elite™ and Elite Plus™ Panel System - Auxiliary Input/Output 2 Circuit

Circuit Description

The electronic control module (ECM) provides a signal to the original equipment manufacturer (OEM) output control solenoid to turn the OEM supplied accessory ON and OFF. The OEM output control circuit varies by OEM. They can use a solenoid return that is wired to the ECM or use a return that goes to the engine block or chassis ground.

Component Location

The solenoid driver is an OEM device and the location of the solenoid is dependent upon the OEM. Refer to the OEM service manual for component location.

Shop Talk

The ECM monitors the voltage level on this circuit. When the ECM commands the OEM output signal low, it expects the voltage level to be approximately 0.0-VDC. If it detects a high voltage, this fault is recorded. If Fault Code 527 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the OEM output device for an open circuit or short to ground.

Possible causes of this fault include:

  • Open circuit in the engine harness or OEM output control solenoid
  • Short circuit to voltage source in the OEM harness
  • Damaged ECM.
Refer to Troubleshooting Fault Code 527.

Last Modified: 16-Jun-2010


Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 529

Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 529 PID: SPN: 703 FMI: 3 LAMP: Amber SRT: | Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source. The auxiliary input/output 3 signal pin of the engine harness indicates an open or short circuit. | No action taken by the ECM.
QSK19 CM2150 Industrial/QSK19 CM2150 Marine Propulsion with C Command™ Panel System - Auxiliary Input/Output 3 Circuit
QSK19 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Auxiliary Input/Output 3 Circuit

Circuit Description

The electronic control module (ECM) provides a signal to the original equipment manufacturer (OEM) output control solenoid to turn the OEM supplied accessory ON and OFF. The OEM output control circuit varies by OEM. They can use a solenoid return that is wired to the ECM or use a return that goes to the engine block or chassis ground.

Component Location

The solenoid driver is an OEM device and the location of the solenoid is dependent upon the OEM.

Shop Talk

The ECM monitors the voltage level on this circuit. When the ECM commands the OEM output signal low, it expects the voltage level to be approximately 0.0-VDC. If it detects a high voltage, this fault is recorded. If Fault Code 529 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the OEM output device for an open circuit or short to ground.

Possible causes of this fault include:

  • Open circuit in the engine harness or OEM output control solenoid
  • Short circuit to voltage source in the OEM harness
  • Damaged ECM.
Refer to Troubleshooting Fault Code 529.

Last Modified: 08-Jul-2010


Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 546

Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: SPN: 94 FMI: 3 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No action taken by the ECM.
QSK19 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor monitors the inlet fuel pressure and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The fuel delivery pressure sensor is located above the second stage fuel filter head. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel delivery pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 546, check for multiple fault codes.

Possible causes of this fault include:

  • Open return circuit in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-546.

Last Modified: 27-Jan-2011


Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 547

Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: SPN: 94 FMI: 4 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No action taken by the ECM.
QSL19 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor monitors the inlet fuel pressure and passes information to the electronic control module (ECM) through the engine harness.

Component Location

The fuel delivery pressure sensor is located above the second stage fuel filter head. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel delivery pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 547, check for multiple fault codes.

Possible causes of this fault code include:

  • SIGNAL circuit open or shorted to ground in the engine harness or sensor
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-547.

Last Modified: 27-Jan-2011


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: SPN: 101 FMI: 0 LAMP: Red SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level | Ramps to full derate in 20 seconds.
QSK19 CM2150 Marine - Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used by the electronic control module (ECM) to monitor the engine crankcase pressure. The ECM monitors the voltage on the crankcase pressure signal pin and converts it to a pressure value. The crankcase pressure value is used by the ECM for the engine protection system.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The crankcase pressure sensor is used in the engine protection section of the calibration. When the ECM detects that the crankcase pressure is above the engine protection limit in the calibration for at least 5 seconds, it will log Fault Code 556 and light a red lamp indicating that the engine must be shut down.

Possible causes of this fault code include:

  • Damaged piston rings
  • Oil level too high
  • Damaged turbocharger seals
  • Damaged power cylinder
  • Damaged air compressor piston rings.

Confirm that the crankcase breathers and breather tubes are not obstructed.

Refer to Troubleshooting Fault Code 556.

Last Modified: 28-Jun-2010


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: SPN: 157 FMI: 18 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level. The ECM has detected the fuel pressure is lower than commanded. | Low power, possible shutdown, or no start.
QSK19 CM2150 Industrial - Injector Metering Rail 1 Pressure Sensor Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the gerotor pump. The ECM monitors the injector pressure rail 1 pressure and engine operating conditions and changes the flow command to maintain the proper injector pressure rail 1 pressure. Changes to the flow command result in opening or closing of the fuel pump pressurizing assembly 1.

Component Location

The high-pressure fuel pump is mounted to the gear housing on the intake side of the engine. Reference the following procedure for detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • Fuel inlet restriction
  • Fuel filter plugging
  • Gerotor pump output low
  • Gerotor pump pressure regulator sticking or leaking
  • High-pressure pump capacity decay
  • Mechanical dump valve leaks to drain
  • Mechanical dump opens at to of low of pressure
  • High-pressure injector supply line inner wall leak.
Refer to Troubleshooting Fault Code t05-559.

Last Modified: 10-Mar-2011


Auxiliary Commanded Dual Output Shutdown - Special Instructions

FAULT CODE 599

Auxiliary Commanded Dual Output Shutdown - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 599 PID: SPN: 640 FMI: 14 LAMP: Red SRT: | Auxiliary Commanded Dual Output Shutdown - Special Instructions. The engine protection limit has been exceeded for the dual outputs calibrated limits. | Engine will shut down.
QSK19 CM2150 Industrial/QSK19 CM2150 Marine Propulsion with C Command™ Panel System - Auxiliary Input/Output Circuit
QSK19 CM2150 Marine Propulsion with C Command™ Panel System and C Command Elite Plus™ Panel System - Auxiliary Input/Output Circuit

Circuit Description

Dual outputs based on sensed parameters provide up to two independent switched outputs for the OEM use. The state of each switched output can be determined by different inputs to the ECM, depending on the engine platform. The ECM can provide different outputs to the OEM devices if any of the inputs are above or below calibrated thresholds. Each switched output is independent of the other with respect to the control parameter input and threshold settings.

Component Location

The dual outputs features are OEM dependent. Refer to the OEM service manual for component location. The dual output pins for auxiliary input/output 2 SIGNAL and auxiliary input/output 3 SIGNAL can be located at the 23-pin OEM connector at A and E respectively.

Shop Talk

This fault code is activated when one of the OEM defined inputs has exceeded a calibrated limit. The triggers for shutdown are OEM dependent. The parameters that can be used for the dual output feature are the following:

  • Engine speed
  • Fuel command
  • Boost pressure
  • Auxiliary speed input
  • Oil pressure
  • Coolant temperature
  • Fuel temperature
  • Command throttle
  • OEM sensor
  • OEM temperature
  • OEM pressure
  • OEM supplied switch
  • ISC 2 status
  • Intake manifold temperature.
Refer to Troubleshooting Fault Code 599.

Last Modified: 25-Jun-2010


Engine Shut Down Hot - Condition Exists

FAULT CODE 611

Engine Shut Down Hot - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 611 PID: SPN: 1383 FMI: 11/31 LAMP: None SRT: | Engine Shut Down Hot - Condition Exists. The engine was shut down with the keyswitch before proper engine cool down, resulting in a load factor above the maximum shut down threshold. | No action taken by ECM. Possible loss of performance. Possible damage to the engine can occur. Fault code will be logged.
Electronic Control Module (ECM)

Circuit Description

Not applicable for this fault code.

Component Location

Not applicable for this fault code.

Refer to Troubleshooting Fault Code 611.

Last Modified: 16-Jun-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: SPN: 190 FMI: 2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Loss of signal from crankshaft sensor. | Engine can run rough. Possibly poor starting capability. Engine runs using backup speed sensor. Engine power is reduced.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine crankshaft speed/position sensor provides engine speed information to the ECM. The sensor is powered by 5-VDC. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

The engine crankshaft speed/position sensor is located on the intake side of the engine, between number 5 and number 6 cylinders at the crankshaft level. Reference the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code is recorded when the ECM does not receive a signal from the engine crankshaft speed/position sensor, or the signal it receives is degraded.

Possible causes of this fault code include:

  • Open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM
  • Short circuits to ground or return circuits in the sensor, engine harness, or ECM
  • Short circuits to a voltage source in the sensor, engine harness, or ECM
  • Damage to the sensor target teeth or tone wheel.

INSITE™ electronic service tool monitor parameter associated with this fault code and sensor:

  • Engine crankshaft speed/position sensor state.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections, such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code t05-689.

Last Modified: 28-Jan-2011


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: SPN: 723 FMI: 7 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment. Mechanical misalignment between the crankshaft and camshaft engine speed sensors. | Engine will run derated. Excessive smoke, hard start, and rough idle possible.
QSK19 CM2150 Industrial - Engine Crankshaft Speed/Position Sensor and Engine Camshaft Speed/Position Sensor Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Engine Crankshaft Speed/Position Sensor and Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The crankshaft speed/position sensor and engine camshaft speed/position sensor provide an engine speed and position signal to the ECM through the engine harness.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault is logged when the ECM determines that a mechanical misalignment between the engine camshaft and the engine crankshaft speed/position sensors has occurred.

Refer to Troubleshooting Fault Code t05-731.

Last Modified: 27-Jan-2011


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: SPN: 627 FMI: 2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below 6.2-VDC momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
QSK19 CM2150 Industrial - Battery 1 Voltage Circuit
QSK19 CM2150 Marine Propulsion - Battery 1 Voltage Circuit
QSK19 CM2150 Marine Auxiliary - Battery 1 Voltage Circuit
QSK19 CM2150 Power Generation - Battery 1 Voltage Circuit

Circuit Description

The ECM receives constant voltage from the batteries through the battery 1 voltage wires that are connected directly to the positive (+) battery post. There is a 10 ampere fuse in the battery 1 voltage wires to protect the OEM harness from overheating. The ECM receives power supply through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery 1 voltage return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the 4-pin connector on the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Shop Talk

  • If the ECM battery 1 voltage supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 1117.
  • Inspect for an intermittent keyswitch or fast keyswitch cycling.

Note: If a battery disconnect switch is turned OFF after the keyswitch is turned OFF, but before the ECM completely powers down (up to 30 seconds), this fault can register.

Verify the ECM unswitched power is coming from the batteries and not the starter or other device. Check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 1117.

Corrupted voltage (short interruptions or other spikes that can only be seen with an oscilloscope) on the keyswitch wire can cause this fault code.

Refer to Troubleshooting Fault Code t05-1117.

Last Modified: 27-Jan-2011


Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1357

Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1357 PID: SPN: 1380 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Level Remote Reservoir - Data Valid but Below Normal Operating Range - Moderately Severe Level. The remote engine oil reservoir is below the normal operating level. | No action taken by ECM. Possible damage to engine if left unresolved.
QSK19 CM2150 Industrial - Engine Oil Level Remote Reservoir
QSK19 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Engine Oil Level Remote Reservoir
QSK19 CM2150 Marine with C Command™ Panel System - Engine Oil Level Remote Reservoir
QSK19 CM2150 Power Generation - Engine Oil Level Remote Reservoir

Circuit Description

None

Component Location

The location of the remote engine oil reservoir is dependent on the OEM. Refer to the OEM service manual.

Shop Talk

None

Refer to Troubleshooting Fault Code t05-1357.

Last Modified: 10-Mar-2011


Accelerator Pedal or Lever Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1358

Accelerator Pedal or Lever Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1358 PID: SPN: 91 FMI: 3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position circuit. | Industrial: Calibration dependent power and speed derate.
QSK19 CM2150 Industrial - Accelerator Pedal or Lever Position Sensor Circuit
QSK19 CM2150 Marine Propulsion - Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator pedal or lever position sensor is attached to the accelerator pedal. The accelerator pedal or lever position sensor sends a signal to the ECM when the accelerator pedal is depressed and released. The accelerator pedal or lever position circuit contains three wires: accelerator pedal or lever position 5 volt supply (sensor supply 4), accelerator pedal or lever position return (sensor return 4), and accelerator pedal or lever position signal.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal. Refer to the OEM service manual.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

  • Accelerator pedal or lever position signal circuit shorted to battery or 5 VDC supply
  • Open accelerator pedal or lever position return (sensor return 4) circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Damaged accelerator pedal or lever position sensor.

The three wires in the accelerator pedal or lever position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1358.

Last Modified: 16-Jun-2010


Accelerator Pedal or Lever Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1359

Accelerator Pedal or Lever Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1359 PID: SPN: 91 FMI: 4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal or lever position signal circuit. | Industrial: Calibration dependent power and speed derate.
QSK19 CM2150 Industrial - Accelerator Pedal or Lever Position Sensor Circuit
QSK19 CM2150 Marine Propulsion - Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator pedal or lever position sensor is attached to the accelerator pedal. The accelerator pedal or lever position sensor sends a signal to the ECM when the accelerator pedal is depressed and released. The accelerator pedal or lever position sensor circuit contains three wires: accelerator pedal or lever supply, accelerator pedal or lever position return, and accelerator pedal or lever position signal.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault code include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor.
  • Damaged accelerator pedal or lever position sensor
  • Open circuit in the signal or supply wire in the harness or connectors

The three wires in the accelerator pedal or lever position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1359.

Last Modified: 16-Jun-2010


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1361

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1361 PID: SPN: 974 FMI: 4/4 LAMP: Amber SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the remote accelerator pedal or lever position sensor SIGNAL. | Calibration dependent power and speed derate.
QSK19 CM2150 Industrial - Remote Accelerator Pedal or Lever Position Sensor Circuit
QSK19 CM2150 Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Remote Accelerator Pedal or Lever Position Sensor Circuit
QSK19 CM2150 Marine Propulsion with C Command™ Panel System - Remote Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The remote accelerator pedal or lever position sensor provides the operator's accelerator command to the ECM through the OEM harness and engine harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote accelerator pedal or lever position sensor varies with each OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

If troubleshooting an intermittent remote accelerator problem, the remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while working the harness to locate the intermittent connection.

Possible causes of this fault code include:

  • Remote accelerator signal shorted to engine ground or return wires in the OEM harness, engine harness, or sensor
  • Open remote accelerator signal, supply, or return in the harness or connectors
  • Malfunctioned remote accelerator pedal or lever position sensor
  • The remote throttle enable switch must be turned on for the remote throttle to operate.
Refer to Troubleshooting Fault Code 1361.

Last Modified: 02-Jul-2010


Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1369

Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1369 PID: SPN: 441 FMI: 3 LAMP: Maintenance SRT: | Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the auxiliary temperature sensor input 1 circuit. | None on performance.
QSK19 CM2150 Industrial - Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The OEM has the option of wiring an auxiliary temperature sensor input 1 to the ECM. A specific calibration is then created to recognize this auxiliary temperature sensor input 1.

Component Location

The OEM temperature sensor input will vary, depending on application. Refer to the OEM service manual for sensor location.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 1369.

Last Modified: 23-Jun-2010


Start Enable Device 1 Circuit (ether injection) - Root Cause Not Known

FAULT CODE 1373

Start Enable Device 1 Circuit (ether injection) - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1373 PID: SPN: 626 FMI: 11 LAMP: Maintenance SRT: QU-373 | Start Enable Device 1 Circuit (ether injection) - Root Cause Not Known. The start enable device 1 circuit (ether injection) solenoid circuit is open or shorted in the engine harness. | Start enable device 1 circuit (ether injection) feature is disabled. Possible white smoke, engine hard to start in cold temperatures.
QSK19 CM2150 Industrial - Start Enabled Device 1 Circuit (ether injection)

Circuit Description

The start enable device 1 circuit (ether injection) solenoid is a device used by the ECM to control the start enable device 1 circuit (ether injection) system during cold starts.

Component Location

The start enable device 1 circuit (ether injection) solenoid location is dependent on the OEM. Refer to the OEM service manual.

Shop Talk

Possible causes of this fault code include:

  • Open circuit on the supply, signal, or return circuits in the solenoid, harness, or ECM
  • Short circuits to ground or return circuits in the solenoid, harness, or ECM
  • Short circuits to voltage source in the solenoid, harness, or ECM.
Refer to Troubleshooting Fault Code 1373.

Last Modified: 16-Jun-2010


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1376

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1376 PID: SPN: 723 FMI: 2 LAMP: Maintenance SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine camshaft speed/position sensor signal. | Possible poor starting. Engine power derate.
QSK19 CM2150 Industrial - Engine Camshaft Speed/Position Sensor Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine camshaft speed/position sensor provides engine position information to the ECM. The engine camshaft speed/position sensor is powered by 5-VDC. The engine camshaft speed/position sensor generates the signal by sensing the movement of target teeth machined into the camshaft gear.

Component Location

The engine camshaft speed/position sensor is located above the fuel pump, in back of the gear housing. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code is recorded when the ECM does not receive a signal from the engine camshaft speed/position sensor, or the signal it receives is degraded.

Possible causes of this fault code include:

  • Open circuit on the supply, signal, or return circuits in the engine camshaft speed/position sensor, engine harness, or ECM
  • Short circuits to ground or return circuits in the engine camshaft speed/position sensor, engine harness, or ECM
  • Short circuits to a voltage source in the engine camshaft speed/position sensor, engine harness, or ECM
  • Damage to the engine camshaft speed/position sensor target teeth or camshaft gear.

INSITE™ electronic service tool monitor parameter associated with this fault code and engine camshaft speed/position sensor:

  • Engine camshaft speed/position sensor state.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections, such as loose or worn pins in the engine harness connectors.

If this fault code occurs intermittently, Fault Code 2322 will also be active or have high counts.

Refer to Troubleshooting Fault Code t05-1376.

Last Modified: 08-Feb-2011


Auxiliary Temperature Sensor Input 1 - Special Instructions

FAULT CODE 1381

Auxiliary Temperature Sensor Input 1 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1381 PID: SPN: 441 FMI: 14 LAMP: Maintenance SRT: | Auxiliary Temperature Sensor Input 1 - Special Instructions. OEM temperature out-of-range has been detected. Voltage signal at the auxiliary temperature sensor input 1 pin indicates OEM temperature beyond the OEM-specified threshold. | Calibration-dependent progressive power and speed derate and engine shutdown with increasing time after alert.
QSK19 CM2150 Industrial - Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The OEM resistive signal is used by the ECM to monitor an OEM temperature. The OEM temperature is used by the ECM for the engine protection system.

Component Location

The location varies with the OEM. Refer to the OEM service manual.

Shop Talk

The resistance of all temperature sensors varies with the ambient temperature.

Refer to Troubleshooting Fault Code 1381.

Last Modified: 23-Jun-2010


Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1411

Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1411 PID: SPN: 4182 FMI: 3 LAMP: Amber SRT: | Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source. | The generator output frequency adjust potentiometer will go to the default value.
QSK19 CM2150 Marine Auxiliary with C Command™ Panel System - Generator Output Frequency Adjust Potentiometer Circuit
QSK19 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Generator Output Frequency Adjust Potentiometer Circuit
QSK19 CM2150 Power Generation - Generator Output Frequency Adjust Potentiometer Circuit

Circuit Description

The generator output frequency adjust potentiometer is used to regulate the generator frequency. The operator can adjust the breakpoint frequency for the 100 percent 0.8 power factor load acceptance. This is the frequency at which the generator set output voltage starts to drop. The ECM monitors the voltage and expects to see the voltage vary between 0.5 and 4.5 VDC during normal operation. High voltage will trip Fault Code 1411 and can be caused by shorts in the signal wire, an open in the return wire, or a malfunctioning potentiometer.

Component Location

Refer to the OEM service manual.

Shop Talk

Potentiometers are very sensitive to the environment. Clean the potentiometer and check its resistance first.

Refer to Troubleshooting Fault Code t05-1411.

Last Modified: 08-Feb-2011


Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1412

Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1412 PID: SPN: 4183 FMI: 3 LAMP: Amber SRT: | Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source. | The droop adjust potentiometer will go to the default value.
QSK19 CM2150 Marine Auxiliary with C Command™ Panel System - Droop Adjust Potentiometer Circuit
QSK19 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Droop Adjust Potentiometer Circuit
QSK19 CM2150 Power Generation - Droop Adjust Potentiometer Circuit

Circuit Description

The droop adjust potentiometer is used to regulate the engine droop.

Component Location

The droop adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Shop Talk

Possible causes of the fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted or sensor supply or battery voltage
  • 5 VDC reference circuit shorted to high source.
Refer to Troubleshooting Fault Code t05-1412.

Last Modified: 08-Feb-2011


Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1418

Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1418 PID: SPN: 4184 FMI: 3 LAMP: Amber SRT: | Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source. | The ECM gain adjust potentiometer will go to the default value.
Gain Adjust Potentiometer Circuit

Circuit Description

The gain adjust potentiometer is used to regulate the governor gains.

Component Location

The gain adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Shop Talk

Possible causes of the fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted or sensor supply or battery voltage
  • 5 VDC reference circuit shorted to high source.
Refer to Troubleshooting Fault Code t05-1418.

Last Modified: 08-Feb-2011


Overspeed Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

FAULT CODE 1427

Overspeed Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1427 PID: SPN: 4185 FMI: 31 LAMP: Amber SRT: | Overspeed Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists. | The overspeed shutdown lamp will not turn ON.
QSK19 CM2150 Marine Auxiliary - Overspeed Shutdown Circuit
QSK19 CM2150 Power Generation - Overspeed Shutdown Circuit

Circuit Description

The overspeed shutdown lamp will indicate when the engine has reached overspeed. Fault Code 1992 will trigger the overspeed shutdown lamp.

Component Location

The overspeed shutdown lamp is located on the generator control panel. Refer to the OEM service manual for the overspeed shutdown lamp location.

Shop Talk

If Fault Code 1992 goes active and the overspeed shutdown lamp does not go ON, Fault Code 1427 will become active.

Possible causes of this fault code include:

  • Open signal circuit or shorted to voltage source
  • Signal circuit shorted to ground in the harness
  • Open return circuit in the OEM harness, connectors, or overspeed shutdown lamp.
Refer to Troubleshooting Fault Code t05-1427.

Last Modified: 08-Feb-2011


Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

FAULT CODE 1428

Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1428 PID: SPN: 4186 FMI: 31 LAMP: Amber SRT: | Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists | The low oil pressure (LOP) shutdown lamp will not turn on.
QSK19 CM2150 Marine Auxiliary with C Command™ Panel System - Low Oil Pressure (LOP) Shutdown Circuit
QSK19 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Low Oil Pressure (LOP) Shutdown Circuit
QSK19 CM2150 Power Generation - Low Oil Pressure (LOP) Shutdown Circuit

Circuit Description

The low oil pressure (LOP) shutdown lamp will indicate when the engine has reached a low oil pressure most severe condition. Fault Code 415 will trigger the low oil pressure (LOP) shutdown lamp.

Component Location

The low oil pressure (LOP) shutdown lamp is located on the generator control panel. Refer to the OEM service manual for lamp location.

Shop Talk

If Fault Code 415 goes active and the low oil pressure (LOP) shutdown lamp does not go on, Fault Code 1428 will become active.

Possible causes of this fault code include:

  • Open signal circuit or shorted to voltage source
  • Signal circuit shorted to ground in the harness
  • Open return circuit in the OEM harness, connectors, or low oil pressure (LOP) shutdown lamp.
Refer to Troubleshooting Fault Code t05-1428.

Last Modified: 27-Jan-2011


Accelerator Pedal or Lever Position Sensor 1 Circuit Frequency - Abnormal Frequency, Pulse Width, or Period

FAULT CODE 1514

Accelerator Pedal or Lever Position Sensor 1 Circuit Frequency - Abnormal Frequency, Pulse Width, or Period

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1514 PID: SPN: 091 FMI: 8 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit Frequency - Abnormal Frequency, Pulse Width, or Period. A frequency of more than 1500 Hz or less than 500 Hz has been detected at the frequency accelerator signal pin of the engine harness. | Engine operates at idle.
QSK19 CM2150 Industrial - Accelerator Pedal or Lever Position Sensor Circuit
QSK19 CM2150 Marine Propulsion - Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator or lever position sensor provides the driver's accelerator command to the ECM through the OEM harness and the engine harness. The ECM uses this signal to determine the fueling command.

Component Location

Accelerator location varies with each OEM. Refer to the OEM service manual.

Shop Talk

This fault code is usually caused when the ECM is receiving a frequency signal that is out of range. If the frequency is not between 500 to 1500 Hz or 5 to 95 percent of the frequency throttle, the fault code will be logged.

The accelerator or lever position sensor can be used either in conjunction with a voltage accelerator or by itself.

Refer to Troubleshooting Fault Code 1514.

Last Modified: 16-Jun-2010


Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1542

Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1542 PID: P443 SPN: 1388 FMI: 3 LAMP: Amber SRT: | Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the OEM pressure circuit. | None on performance.
QSK19 CM2150 Industrial - Auxiliary Pressure Sensor Input 1 Circuit
QSK19 CM2150 Marine - Auxiliary Pressure Sensor Input 1 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure sensor input to the Cummins® electronic control module (ECM). A specific calibration is then created to recognize this pressure sensor input.

Component Location

The OEM pressure sensor input will vary depending on application. Refer to the OEM service manual for sensor location.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1542.

Last Modified: 24-Jun-2010


Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1543

Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1543 PID: P443 SPN: 1388 FMI: 4 LAMP: Amber SRT: | Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the OEM pressure circuit. | None on performance.
QSK19 CM2150 Industrial - Auxiliary Pressure Sensor Input 1 Sensor Circuit
QSK19 CM2150 Marine - Auxiliary Pressure Sensor Input 1 Sensor Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure sensor input to the Cummins® electronic control module (ECM). A specific calibration is then created to recognize this pressure sensor input.

Component Location

The OEM pressure sensor input will vary depending on application. Refer to the OEM service manual for sensor location.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the OEM harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code 1543.

Last Modified: 28-Jun-2010


Auxiliary Pressure Sensor Input 1 - Special Instructions

FAULT CODE 1544

Auxiliary Pressure Sensor Input 1 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1544 PID: SPN: 1387 FMI: 14 LAMP: Maintenance SRT: | Auxiliary Pressure Sensor Input 1 - Special Instructions | Possible engine power derate.
QSK19 CM2150 Industrial - Auxiliary Pressure Sensor Input 1 Sensor Circuit
QSK19 CM2150 Marine- Auxiliary Pressure Sensor Input 1 Sensor Circuit

Circuit Description

The OEM has the option of wiring a pressure sensor input to the electronic control module (ECM). A specific calibration is then created to recognize this pressure sensor input. This fault code is activated when the pressure input from the OEM sensor exceeds the engine protection limit defined by the OEM. In marine applications, this sensor monitors gear oil pressure and the fault code is activated when the pressure falls below a threshold which is an INSITE™ electronic service tool adjustable parameter. Depending on the OEM requirements, an engine protection derate can be associated with the fault code.

Component Location

The OEM pressure sensor input will vary, depending on application. Refer to the OEM service manual for sensor location.

Shop Talk

This fault code is activated when the pressure input from the OEM sensor exceeds the engine protection limit defined by the OEM. An engine power derate is possible, depending on the OEM application.

In marine applications, the default setting is intentionally set higher than any possible gear oil pressure. This is so the fault code will become active immediately after recalibration where the adjustable parameters were not overlaid on the new calibration. This prevents the customer from the assumption that he is protected by this lamp when the parameters were not adjusted properly. When the gear oil pressure sensor is not installed, the factory installed resistor is designed to signal to the ECM that gear oil pressure conditions are satisfactory at all times.

Note: The fault code will only go inactive if the ECM sees a known condition for a period (about five seconds) and with the engine running above 1000 RPM.

Refer to Troubleshooting Fault Code 1544.

Last Modified: 17-Jan-2012


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1595

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1595 PID: SPN: 974 FMI: 3/3 LAMP: Amber SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the remote accelerator pedal or lever position signal circuit. | Calibration dependent power and speed derate.
QSK19 CM2150 Industrial - Remote Accelerator Pedal or Lever Position Sensor Circuit
QSK19 CM2150 Marine Propulsion/Marine with C Command Elite™ and C Command Elite Plus™ Panel System - Remote Accelerator Pedal or Lever Position Sensor Circuit
QSK19 CM2150 Marine Propulsion/Marine with C Command™ Panel System - Remote Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The remote accelerator pedal or lever provides the operator's accelerator command to the electronic control module (ECM) through the OEM harness and engine harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote accelerator pedal or lever location varies with each OEM. Refer to the OEM service manual.

Shop Talk

If troubleshooting an intermittent accelerator problem, the remote accelerator pedal or lever position signal voltage can be monitored with the INSITE™ electronic service tool, while working the harness to locate the intermittent connection.

Possible causes of this fault code include:

  • Remote accelerator pedal or lever position signal shorted to supply wire, battery, or 5-VDC
  • Open remote accelerator pedal or lever position sensor return (sensor return 1) circuit into the OEM harness or connectors
  • Damaged remote accelerator pedal or lever position sensor
  • The remote throttle enable switch must be turned ON for the remote throttle to operate.
Refer to Troubleshooting Fault Code 1595.

Last Modified: 28-Jun-2010


Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1596

Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1596 PID: SPN: 441 FMI: 4 LAMP: Maintenance SRT: | Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at OEM auxiliary temperature circuit. | None on performance.
QSK19 CM2150 Industrial - Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The OEM has the option of wiring a temperature sensor input to the Cummins® electronic control module (ECM). A specific calibration is then created to recognize this temperature sensor input.

Component Location

The OEM temperature sensor input will vary, depending on application. Refer to the OEM service manual for sensor location.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 1596.

Last Modified: 23-Jun-2010


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 1597

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1597 PID: SPN: 629 FMI: 12 LAMP: Maintenance SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the ECM related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine will possibly not start.
ECM Microprocessor

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the fuel system side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-1597.

Last Modified: 27-Jan-2011


Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1774

Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1774 PID: SPN: 3589 FMI: 3 LAMP: Amber SRT: | Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source. High SIGNAL voltage detected in the engine oil priming pump circuit. | None on performance.
QSK19 CM2150 - Engine Oil Priming Pump Control Circuit

Circuit Description

The ECM monitors the engine oil priming circuit. If the ECM sees the engine oil priming pump is activated and oil pressure does not build to a pre-set level, Fault Code 1774 will become active and the amber lamp will illuminate.

Component Location

The engine oil priming pump can be located on either side of the engine block.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when the INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The engine oil priming pump circuit monitors oil pressure and OEM pump switch input.

Possible causes of this fault code include:

  • Open RETURN circuit in the engine harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage
  • Engine oil priming pump not operating.
Refer to Troubleshooting Fault Code t05-1774.

Last Modified: 10-Dec-2010


Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: SPN: 101 FMI: 3/3 LAMP: Amber SRT: | Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure sensor circuit. | None on performance.
QSK19 CM2150 Marine - Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor monitors crankcase pressure and passes information to the electronic control module (ECM) through the engine harness. If the crankcase pressure sensor circuit voltage becomes too high, Fault Code 1843 will become active and the amber lamp will illuminate.

Component Location

The crankcase pressure sensor is located in the right bank front cylinder head deck. The crankcase pressure sensor is located in a right bank hand hole cover. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The crankcase pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1843, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • SIGNAL wire shorted to sensor SUPPLY or battery voltage.
Refer to Troubleshooting Fault Code 1843.

Last Modified: 22-Jun-2010


Crankcase Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | None on performance.
QSK19 CM2150 Marine - Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor monitors crankcase pressure and passes information to the electronic control module (ECM) through the engine harness. If the crankcase pressure sensor circuit voltage becomes too low, Fault Code 1844 will become active and the amber light will illuminate.

Component Location

The crankcase pressure sensor is located in the right bank front cylinder head deck. The crankcase pressure sensor is located in a right bank hand hole cover. Refer to Procedure 100-002 in Section E.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

The crankcase pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1844, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1844.

Last Modified: 23-Jun-2010


Water-In-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1845

Water-In-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1845 PID: SPN: 97 FMI: 3 LAMP: Maintenance SRT: | Water-In-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
QSK19 CM2150 Industrial - Water-In-Fuel Indicator Sensor Circuit
QSK19 CM2150 Marine - Water-In-Fuel Indicator Sensor Circuit
QSK19 CM2150 Power Generation - Water-In-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the first stage fuel filter. The water-in-fuel sensor sends a signal to the ECM when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires; a RETURN ground and a SIGNAL wire.

Component Location

The water-in-fuel sensor is integrated into the bottom of the suction fuel filter. The first stage fuel filter is located on the intake side of the engine.

Shop Talk

The water-in-fuel sensor is integrated into the fuel filter. It is automatically replaced whenever the fuel filter is replaced.

Possible causes for this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-1845.

Last Modified: 27-Jan-2011


Water-In-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1846

Water-In-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1846 PID: SPN: 97 FMI: 4 LAMP: Maintenance SRT: | Water-In-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
QSK19 CM2150 Industrial - Water-In-Fuel Indicator Sensor Circuit
QSK19 CM2150 Marine - Water-In-Fuel Indicator Sensor Circuit
QSK19 CM2150 Power Generation - Water-In-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel indicator sensor is attached to the first stage fuel filter. The water-in-fuel indicator sensor sends a signal to the ECM when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires; a RETURN ground and a SIGNAL wire.

Component Location

The water-in-fuel indicator sensor is integrated into the bottom of the suction fuel filter. The first stage fuel filter is located on the intake side of the engine.

Shop Talk

The water-in-fuel indicator sensor is integrated into the fuel filter. It is automatically replaced whenever the fuel filter is replaced.

Possible causes for this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
Refer to Troubleshooting Fault Code t05-1846.

Last Modified: 27-Jan-2011


Engine Coolant Temperature - Special Instructions

FAULT CODE 1847

Engine Coolant Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1847 PID: SPN: 110 FMI: 14 LAMP: Red SRT: | Engine Coolant Temperature - Special Instructions. Engine coolant temperature 1 signal indicates engine coolant temperature is above engine protection warning limit. | Power-Generation Only - Engine will be disconnected from the grid and idle only.
QSK19 CM2150- Power Generation - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value. The engine coolant temperature 1 value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature 1 sensor is located in the thermostat housing. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Go to the Engine Coolant Temperature Above Normal symptom troubleshooting tree in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592.

Refer to Troubleshooting Fault Code t05-1847.

Last Modified: 27-Jan-2011


Water In Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water In Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: SPN: 97 FMI: 16 LAMP: Amber SRT: | Water In Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting. Engine derate will occur on Marine engines if optional engine protection feature is enabled.
QSK19 CM2150 Industrial - Water In Fuel Indicator Sensor Circuit
QSK19 CM2150 Marine - Water In Fuel Indicator Sensor Circuit
QSK19 CM2150 Power Generation - Water In Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator sensor is attached to the first stage fuel filter. The water in fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel circuit contains two wires; a ground wire and SIGNAL wire.

Component Location

The water in fuel indicator sensor is integrated into the bottom of the first stage fuel filter. The first stage fuel filter is located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • On Marine Propulsion engines, if the optional engine protection feature has been enabled, a torque derate will occur.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

Drain the Stage 1 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active and there is no water in the fuel filter then a malfunctioning water in fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code t05-1852.

Last Modified: 24-Sep-2015


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

FAULT CODE 1888

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1888 PID: SPN: 91 FMI: 19 LAMP: Maintenance SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error. The OEM vehicle electronic control unit detected a fault with the accelerator pedal. | Engine could possibly only idle or engine will not accelerate to full speed.
QSK19 CM2150 Industrial - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System
QSK19 CM2150 Marine - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit or transmission electronic control unit (ECU) in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM vehicle electronic control unit to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM vehicle electronic control units or transmissions ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM vehicle electronic control units must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. The SAE J1939 data link wiring and vehicle electronic control unit location varies by OEM.

Shop Talk

This fault can occur when the OEM vehicle electronic control unit detects an error on the accelerator and or idle validation switch. The ECM has been set up properly (components enabled and OEM vehicle electronic control unit source addressed correctly) to receive multiplexed information for the idle validation switch states and accelerator position over the SAE J1939 data link from an OEM vehicle electronic control unit, and the OEM vehicle electronic control unit is transmitting the message for that component.

The three types of errors that can occur for this fault are:

  • When the accelerator is depressed and the OEM vehicle electronic control unit reads accelerator position as greater than 0 percent, but the idle validation switch indicates it is in the idle position. This fault status is transmitted to the Cummins® ECM on the SAE J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • When the accelerator is released and the OEM vehicle electronic control unit reads accelerator position as 0 percent, but the idle validation switch indicates it is not in the idle position. This fault status is transmitted to the Cummins® ECM on the SAE J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • The OEM vehicle electronic control unit determines that the accelerator signal wire is shorted high or shorted low.

Note: It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM vehicle electronic control unit or Cummins® ECM, for other components, or the accelerator and idle validation switch, or if the data link is damaged. OEM configurations must multiplex the accelerator and idle validation switch inputs together to allow the use of the J1939 multiplexing and limp home feature for these components. INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code 1888.

Last Modified: 06-Jul-2010


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

FAULT CODE 1889

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1889 PID: SPN: 974 FMI: 2/19 LAMP: Maintenance SRT: | SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error. The OEM vehicle electronic control unit detected a fault with the remote accelerator. | The engine will not respond to the remote throttle. Engine could possibly only idle. The primary or cab accelerator could possibly be able to be used.
QSK19 CM2150 Industrial - SAE J1939 Data Link Multiplexing Remote Accelerator Pedal or Lever Position Sensor System
QSK19 CM2150 Marine - SAE J1939 Data Link Multiplexing Remote Accelerator Pedal or Lever Position Sensor System

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM vehicle electronic control unit vehicle electronic control unit or transmission electronic control unit (ECU) in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM vehicle electronic control unit to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM vehicle electronic control units or transmissions ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM vehicle electronic control units must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. The SAE J1939 data link wiring and vehicle electronic control unit location varies by OEM.

Shop Talk

This fault can occur when the OEM vehicle electronic control unit detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM vehicle electronic control unit source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the SAE J1939 data link from an OEM vehicle electronic control unit, and the OEM vehicle electronic control unit is transmitting the message for that component. Most OEMs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

  • The OEM vehicle electronic control unit determines that the remote throttle signal wire is shorted high or shorted low. This fault status is transmitted to the Cummins® ECM on the SAE J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM vehicle electronic control unit. This fault status is transmitted to the ECM on the SAE J1939 data link, which causes this fault to occur in the ECM. Most OEMs will not incorporate fault detection on a switch.

Note: It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM vehicle electronic control unit or Cummins® ECM for other components, or the remote throttle and remote throttle switch, or the data link is damaged. OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the SAE J1939 data link multiplexing feature for these components. The INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code 1889.

Last Modified: 06-Jul-2010


Engine Oil Change Interval - Condition Exists

FAULT CODE 1891

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1891 PID: SPN: 1378 FMI: 31 LAMP: Amber SRT: | Engine Oil Change Interval - Condition Exists. | Engine oil burn valve solenoid unable to inject oil.
QSK19 CM2150 Industrial - Engine Oil Change Interval - Condition Exists
QSK19 CM2150 Marine - Engine Oil Change Interval - Condition Exists
QSK19 CM2150 Power Generation - Engine Oil Change Interval - Condition Exists

Circuit Description

The engine oil burn valve solenoid driver controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The engine oil burn valve solenoid is located on the rear of the engine, on the aftercooler cover. On Marine applications, it is mounted on the OEM connector bracket. Refer to Procedure 100-002 in Section E.

Shop Talk

When the solenoid tries to inject oil and can not, it generates a miss count. When these counts reach a predefined level, Fault Code 1891 goes active. Check for the presence of engine oil burn valve solenoid driver circuit Fault Codes 223 and 224.

Check for counts of engine oil rifle pressure sensor circuit Fault Codes 135 and 141, and coolant temperature sensor circuit Fault Codes 144 and 145. When active, these faults will prevent oil injection.

If an oil make up tank is used, check for Fault Code 1357. If an oil make up tank is not used, it is recommended to change the engine oil at the next maintenance interval.

Refer to Troubleshooting Fault Code t05-1891.

Last Modified: 27-Jan-2011


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1911

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1911 PID: SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. Mechanical dump valve has tripped. | Engine performance derate.
QSK19 CM2150 Industrial - Injector Metering Rail 1 Pressure Sensor Circuit
QSK19 CM2150 Marine and Power Generation - Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the gerotor pump. The ECM monitors the rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening or closing of the fuel pump actuator.

The mechanical dump valve is set to trip at 1950 bar [28,282 psi]. After it trips, it then regulates at 900 to 1300 bar [13,053 to 18,854 psi].

Component Location

The high-pressure fuel pump is mounted to the gear housing, on the intake side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

Fuel drain flow and drain fuel temperature will increase due to the following possible causes:

  • Fuel pump pressurizing assembly o-ring leaking
  • High gerotor outlet pressure
  • High gerotor inlet pressure
  • Air in fuel.
Refer to Troubleshooting Fault Code t05-1911.

Last Modified: 27-Jan-2011


Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1978

Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1978 PID: SPN: 3938 FMI: 3 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source | Engine will not synchronize with the grid if connected.
QSK19 CM2150 Marine/Marine Auxiliary - Generator Speed/Load Governing Bias Circuit
QSK19 CM2150 Power Generation - Generator Speed/Load Governing Bias Circuit

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the generator set controller on the generator set. Refer to the OEM service manual for component location.

Shop Talk

Possible causes of this fault code include:

  • Open RETURN circuit in the harness, connectors, or sensor
  • SIGNAL circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-1978.

Last Modified: 27-Jan-2011


Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1979

Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1979 PID: SPN: 3938 FMI: 4 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will not synchronize with the grid if connected.
QSK19 CM2150 Marine /Marine Auxiliary - Generator Speed/Load Governing Bias Circuit
QSK19 CM2150 Power Generation - Generator Speed/Load Governing Bias Circuit

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the generator set controller on the generator drive or corporate generator set. Refer to OEM service manual for component location.

Shop Talk

Possible causes of this fault code include:

  • SIGNAL circuit open or shorted to ground in the OEM harness or engine harness
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-1979.

Last Modified: 27-Jan-2011


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: SPN: 190 FMI: 16 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine crankshaft speed/position signal indicates engine speed above engine protection limit. | Engine shutdown.
QSK19 CM2150 Power Generation - Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine crankshaft speed/position sensor and the engine camshaft speed/position sensor provide engine speed and position information to the ECM through the engine harness.

Component Location

The engine crankshaft speed/position sensor is located on the ECM side of the engine, behind the oil filters. The engine camshaft speed/position sensor is located above the fuel pump, in back of the gear housing. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-1992.

Last Modified: 01-Apr-2011


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: SPN: 3512 FMI: 3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at 5 volt sensor SUPPLY circuit to the accelerator pedal position sensor. | Loss of some sensor functionality.
QSK19 CM2150 Industrial - Sensor Supply 4 Circuit
QSK19 CM2150 Marine/Marine Propulsion - Sensor Supply 4 Circuit
QSK19 CM2150 Marine/Marine Auxiliary - Sensor Supply 4 Circuit
QSK19 CM2150 Power Generation - Sensor Supply 4 Circuit

Circuit Description

The ECM supplies the accelerator pedal or lever position sensor with 5-VDC.

Component Location

The accelerator pedal or lever assembly is located in the cab.

Shop Talk

This fault code is logged when the ECM senses more than 5.25-VDC on the accelerator pedal or lever position 5 volt SUPPLY wire. This can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator SIGNAL circuit that is greater than 5-VDC.

Refer to Troubleshooting Fault Code t05-2185.

Last Modified: 27-Jan-2011


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply 4 circuit. | Loss of some sensor functionality.
QSK19 CM2150 Industrial - Sensor Supply 4 Circuit
QSK19 CM2150 Marine/Marine Propulsion - Sensor Supply 4 Circuit
QSK19 CM2150 Marine/Marine Auxiliary - Sensor Supply 4 Circuit
QSK19 CM2150 Power Generation - Sensor Supply 4 Circuit

Circuit Description

The sensor supply 4 circuit of the electronic control module (ECM) provides 5 volts for the accelerator pedal or lever position sensor. If the supply circuit to the accelerator is damaged, the accelerator will not work properly.

Component Location

The sensor supply 4 is located in the ECM.

Refer to the OEM service manual for a detailed location of the accelerator pedal or lever position sensor.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire or a return wire, a damaged accelerator, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code t05-2186.

Last Modified: 28-Jan-2011


Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2215

Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2215 PID: SPN: 94 FMI: 18 LAMP: Amber SRT: | Fuel Pump Delivery Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level. | Low power.
QSK19 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the electronic control module (ECM) to monitor fuel delivery pressure directly before the second stage filter. The ECM monitors the voltage on the signal pin and converts it to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the second stage fuel filter head. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes:

  • High stage 1 fuel filter restriction
  • High fuel inlet restriction
  • Low fuel flow from the gerotor
  • Stuck mechanical dump valve in the gerotor housing
  • Stuck low-pressure regulator in the high-pressure fuel pump
  • Air in fuel.
Refer to Troubleshooting Fault Code t05-2215.

Last Modified: 10-Mar-2011


Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2261

Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2261 PID: SPN: 94 FMI: 15 LAMP: Maintenance SRT: | Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. The fuel pump supply pressure is high. | Low power or engine smoke.
QSK19 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Marine- Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the ECM to monitor fuel delivery pressure directly before the second stage filter. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the second stage fuel filter head. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • Stage 2 fuel filter restriction
  • Pinched or damaged fuel supply line
  • Stuck rotor pump fuel pressure regulator located in the high-pressure pump.
Refer to Troubleshooting Fault Code t05-2261.

Last Modified: 10-Mar-2011


Fuel Pump Delivery Pressure - Data Valid But Below Operating Range - Least Severe Level

FAULT CODE 2262

Fuel Pump Delivery Pressure - Data Valid But Below Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2262 PID: SPN: 94 FMI: 17 LAMP: Maintenance SRT: | Fuel Pump Delivery Pressure - Data Valid but Below Operating Range - Least Severe Level. | Engine hard to start or will not start. Possible low power.
QSK19 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Marine - Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the ECM to monitor fuel delivery pressure directly before the second stage filter. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the second stage fuel filter head. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code includes:

  • High stage 1 fuel filter restriction
  • High fuel inlet restriction
  • Low fuel flow from gerotor
  • Stuck mechanical dump valve in the gerotor housing
  • Stuck low-pressure regulator in the high-pressure fuel pump
  • Air in the fuel.
Refer to Troubleshooting Fault Code t05-2262.

Last Modified: 10-Mar-2011


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: SPN: 1075 FMI: 3 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source. High voltage or open detected at the fuel lift pump signal circuit. | Engine can be difficult to start.
QSK19 CM2150 Industrial - Electric Lift Pump for Engine Fuel Supply Circuit
QSK19 CM2150 Marine - Electric Lift Pump for Engine Fuel Supply Circuit
QSK19 CM2150 Power Generation - Electric Lift Pump for Engine Fuel Supply Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the ECM that controls the electric lift pump for the engine fuel supply. The lift pump is grounded in the ECM.

Component Location

The electric lift pump for the engine fuel supply is located below the ECM cooling plate, on the intake side of the engine. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault becomes active if the ECM detects an open circuit at key ON. The cause of this fault code is an open circuit in the electric lift pump for the engine fuel supply circuit.

If the fault code is intermittent, look for the cause of an intermittent open circuit, such as loose pins and bad connections. At key ON, the electric lift pump for the engine fuel supply duty cycle ramps to 100 percent. This fault code can detect open circuit conditions only at key ON. The electric lift pump for the engine fuel supply only runs at key ON and during cranking to aid in priming of the gear pump.

Refer to Troubleshooting Fault Code t05-2265.

Last Modified: 08-Feb-2011


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: SPN: 1075 FMI: 4 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel lift pump circuit. | Engine can be difficult to start.
QSK19 CM2150 Industrial - Electric Lift Pump for Engine Fuel Supply Circuit
QSK19 CM2150 Marine - Electric Lift Pump for Engine Fuel Supply Circuit
QSK19 CM2150 Power Generation - Electric Lift Pump for Engine Fuel Supply Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the ECM that controls the electric lift pump for the engine fuel supply. The lift pump is grounded in the ECM and runs at 100-percent duty cycle for approximately 30 seconds following key ON.

Component Location

The electric lift pump for the engine fuel supply is located below the ECM cooling plate, on the intake side of the engine. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code becomes active whenever the ECM detects a short circuit to ground or high current in the electric lift pump circuit. Causes for this fault code are a short circuit to ground or low resistance (lift pump partially shorted).

During cold weather, gelled fuel can plug the lift pump and cause this fault code. Listen to the lift pump to be sure it is running during cold ambient temperatures (less than -29°C [-20°F]). This fault code can also become active if the lift pump rotor stalls or seizes. When the fault condition is detected, the ECM driver to the lift pump is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will retest for the cause of the fault code. The ECM driver is re-enabled at key ON, and if the cause is no longer present, the fault code will become inactive and can be cleared.

Note: This fault code will also become active if the electric lift pump for the engine fuel supply motor stalls. Stall current for the electric lift pump for the engine fuel supply motor is approximately 9 amperes. A good electric lift pump for the engine fuel supply typically runs with less than 3 amperes. If the fault code is intermittent, observe the snapshot data priming pump measured current. If the current was near 9 amperes when the fault condition occurred, conclude that the rotor has stalled and replace the electric lift pump for the engine fuel supply.

Refer to Troubleshooting Fault Code t05-2266.

Last Modified: 08-Feb-2011


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. Fuel pump actuator circuit resistance too high or too low. | Possible low power.
QSK19 CM2150 Industrial - Fuel Pump Pressurizing Assembly 1 Circuit
QSK19 CM2150 Marine/QSK19 CM2150 Power Generation - Fuel Pump Pressurizing Assembly 1 Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the ECM that controls the fuel pump pressurizing assembly 1. The fuel pump pressurizing assembly 1 is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the high-pressure pump, based on engine operating conditions. The fuel pump pressurizing assembly 1 valve is a normally open valve. High circuit resistance can cause fuel pressure to be higher than commanded at light loads and Fault Code 1911 can be logged.

Component Location

The fuel pump pressurizing assembly 1 valve is located on the engine mounted fuel pump housing. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

If this fault code occurs during road test, verify that all connectors are clean and free of corrosion before replacing components. Possible causes of this fault code include:

  • Fuel pump pressurizing assembly 1 high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Fuel pump pressurizing assembly 1 with low internal resistance
  • Fuel pump pressurizing assembly 1 or engine harness that has shorted to ground
  • Intermittent circuit malfunctions that cause the fuel pressure to exceed the fuel rail pressure relief valve opening pressure.

If an intermittent electrical circuit problem of the fuel pump pressurizing assembly 1 circuit exists, it is possible for the fault code to become active, and then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty, causing the fuel rail pressure relief valve to open. Following the event that caused the fuel rail pressure relief valve to open, the ECM will attempt to reset the fuel rail pressure relief valve, provided the fuel pump pressurizing assembly 1 circuit is not still malfunctioning.

Following any event that opens the fuel rail pressure relief valve, the fuel rail pressure relief valve will regulate the fuel pressure at approximately 900 bar [13,053 psi]. If the ECM is still capable of controlling fuel pressure, the following will occur:

  • The measured fuel pressure will reduce to 600 bar [8702 psi] as the ECM prepares to seat the fuel rail pressure relief valve.
  • Once pressure is 600 bar [8702 psi] and engine speed is greater than 1200 rpm, the ECM will momentarily close the fuel pump pressurizing assembly 1. This action will reduce the fuel rail pressure (to less than 20 bar [290 psi] for a fraction of a second) so that the fuel rail pressure relief valve will reset. At light engine loads, especially if the engine is sped while the driveline is not engaged, engine power interruption will be noticeable while the ECM attempts to reset the fuel rail pressure relief valve.
  • Once the ECM detects that the fuel rail pressure relief valve is reset, normal engine operation will resume and Fault Code 2311 will become inactive.
Refer to Troubleshooting Fault Code t05-2311.

Last Modified: 08-Feb-2011


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: SPN: 647 FMI: 3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
QSK19 CM2150 Industrial - Fan Control Circuit
QSK19 CM2150 Marine Propulsion with C Command™ Panel System - Fan Control Circuit
QSK19 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System- Fan Control Circuit

Circuit Description

The electronic control module (ECM) provides a signal to the fan control to turn the engine fan ON and OFF. There are two types of fans supported by this signal, variable speed and ON/OFF. The INSITE™ electronic service tool can be used to determine which fan type is presently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to engine block or chassis ground.

Component Location

The fan control location varies by OEM. Refer to the OEM service manual to determine the location.

Shop Talk

The ECM monitors the voltage level on this circuit. When the ECM commands the fan signal low, it expects the voltage level to be approximately 0-VDC. If it detects a high voltage, this fault is recorded.

If Fault Code 2377 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control device for an open circuit or short circuit to ground.

Possible causes of this fault include:

  • Open circuit in the engine harness or fan control
  • Short circuit to voltage source in the OEM harness
  • Damaged ECM.
Refer to Troubleshooting Fault Code 2377.

Last Modified: 28-Jun-2010


Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2474

Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2474 PID: SPN: 103 FMI: 2 LAMP: Maintenance SRT: | Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect | No effect on performance. At high altitude the engine will go to default derate value.
QSK19 CM2150 - Turbocharger 1 Speed Sensor Circuit

Circuit Description

The turbocharger 1 speed sensor monitors the turbocharger speed and passes the information to the electronic control module (ECM). The ECM compares this input to a calculated value based on the intake manifold pressure, barometric pressure, and engine speed. This fault becomes active when the calculated value does not coincide with the turbocharger 1 speed SIGNAL.

Component Location

The turbocharger 1 speed sensor is mounted in the center housing of the turbocharger.

Shop Talk

This fault can become active if the ECM senses boost pressure and engine speed, while at the same time a turbocharger speed is not present.

Items that can cause this fault code include:

  • Turbocharger speed sensor
  • Engine harness
  • Barometric pressure sensor
  • Intake manifold pressure sensor
  • ECM

This fault becomes inactive any time the speed signal from the turbocharger speed sensor returns.

If the fault occurs intermittently, look for causes of intermittent open shorts or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code 2474.

Last Modified: 22-Jun-2010


Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2557

Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2557 PID: SPN: 697 FMI: 3 LAMP: Amber SRT: | Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the pulse width modulation actuated OEM device. | Can not control pulse width modulation actuated OEM device.
QSK19 CM2150 Industrial - Auxiliary Pulse Width Modulation Driver 1 Circuit
QSK19 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Auxiliary Pulse Width Modulation Driver 1 Circuit
QSK19 CM2150 Marine Propulsion with C Command™ Panel System - Auxiliary Pulse Width Modulation Driver 1 Circuit

Circuit Description

The pulse width modulation (PWM) actuated original equipment manufacturer (OEM) device uses this signal from the electronic control module (ECM). The return circuit uses the engine oil burn valve RETURN, which is the common return for all pulse width modulated signals coming from the ECM 60-pin connector.

Component Location

Refer to the OEM service manual for the location of the pulse width modulation actuated OEM device.

Shop Talk

This fault can be caused by the following:

  • A malfunctioning pulse width modulation actuated OEM device
  • An open circuit in the auxiliary pulse width modulation driver 1 return line
  • A pin-to-pin short in the auxiliary pulse width modulation driver 1 line.
Refer to Troubleshooting Fault Code 2557.

Last Modified: 23-Jun-2010


Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2558

Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2558 PID: SPN: 697 FMI: 4/4 LAMP: Amber SRT: | Auxiliary pulse width modulation (PWM) Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the pulse width modulated actuated OEM device. | Can not control the pulse width modulated actuated OEM device.
QSK19 CM2150 Industrial - Auxiliary Pulse Width Modulation Driver Number 1 Circuit
QSK19 CM2150 Marine Propulsion with C Command Elite™ and C Command Elite Plus™ Panel System - Auxiliary Pulse Width Modulation Driver Number 1 Circuit
QSK19 CM2150 Marine Propulsion with C Command™ Panel System - Auxiliary Pulse Width Modulation Driver Number 1 Circuit

Circuit Description

A PWM actuated original equipment manufacturer (OEM) device uses this signal from the electronic control module (ECM). The return circuit uses the engine oil burn valve RETURN, which is the common return for all pulse width modulated signals coming from the ECM 60-pin connector.

Component Location

Refer to the OEM service manual for the location of the pulse width modulated actuated OEM device.

Shop Talk

This fault can be caused by the following:

  • A faulty pulse width modulated actuated OEM device
  • A malfunctioning circuit to ground on the auxiliary pulse width modulated driver 1 line
  • A pin-to-pin short in the auxiliary pulse width modulated driver 1 line.
Refer to Troubleshooting Fault Code 2558.

Last Modified: 10-Mar-2011


Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2562

Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2562 SPN: 175 FMI: 0 LAMP: Red SRT: | Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Transmission ( or gearbox) oil temperature sensor indicates the transmission (or gearbox) oil temperature is above the protection limit. | No engine protection for transmission oil temperature.
Transmission (or Gearbox) Oil Temperature Sensor Circuit

Circuit Description

Transmission (or gearbox) oil temperature sensor is used by the engine control module (ECM) to monitor the transmission oil temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The transmission (or gearbox) oil temperature sensor is located in the transmission.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code indicates that the transmission (or gearbox) temperature has exceeded the protection limits for high transmission (or gearbox) temperature.

Refer to Troubleshooting Fault Code 2562.

Last Modified: 12-Dec-2016


Auxiliary Equipment Sensor Input 1 Engine Protection Critical - Special Instructions

FAULT CODE 2619

Auxiliary Equipment Sensor Input 1 Engine Protection Critical - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2619 PID: SPN: 701 FMI: 31 LAMP: Amber SRT: | Auxiliary Equipment Sensor Input 1 Engine Protection Critical - Special Instructions. The air shutoff is activated from engine overspeed or operator’s E-stop. | Engine shuts down if engine protection shutdown feature is enabled.
Air Shutoff (OEM Switch/Dual Output) and E-stop Circuit

Circuit Description

The circuit uses the OEM E-stop signal or engine overspeed to activate the air shutoff.

Component Location

The E-Stop button is located on the door of the customer interface box (CIB) panel.

Shop Talk

This is for engines with one or more OEM supplied air shutoff valves.

The air shutoff uses the OEM switch input for the emergency air shutoff stop. A switch closure from either the operator's E-stop or engine overspeed will cause the air shutoff to activate. Causes of this fault code are:

  • Operator pushes engine stop button.
  • Overspeed shutdown event as commanded by the ECM.
Refer to Troubleshooting Fault Code t05-2619

Last Modified: 23-Sep-2010


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. | No effect on performance.
QSK19 CM2150 - Unacknowledged Fault

Circuit Description

Not applicable for this fault code.

Component Location

The reset button or switch location depends on the OEM. Refer to the OEM service manual for component location.

Shop Talk

This fault code occurs as a result of other fault codes becoming active or inactive. Fault Code 2661 will remain active until reset by the operator. Fault Code 2661 is designed to latch onto other fault codes that have become active or have gone inactive. The light is an indicator that will remain illuminated to inform the operator that there has been a fault code generated. This fault code has no effect on engine performance.

Refer to Troubleshooting Fault Code t05-2661.

Last Modified: 28-Jan-2011


At Least One Unacknowledged Moderately Severe Fault - Condition Exists

FAULT CODE 2662

At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2662 PID: SPN: 629 FMI: 31 LAMP: Amber SRT: | At Least One Unacknowledged Moderately Severe Fault - Condition Exists. | No effect on performance.
QSK19 CM2150 - Unacknowledged Fault

Circuit Description

Not applicable for this fault code.

Component Location

The reset button or switch location depends on the OEM. Refer to the OEM service manual for component location.

Shop Talk

This fault code occurs as a result of other fault codes becoming active or inactive. Fault Code 2662 will remain active until reset by the operator. Fault Code 2662 is designed to latch onto other fault codes that have become active or have gone inactive. The light is an indicator that will remain illuminated to inform the operator that there has been a fault code generated. This fault code has no effect on engine performance.

Refer to Troubleshooting Fault Code t05-2662.

Last Modified: 28-Jan-2011


Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

FAULT CODE 2697

Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2697 PID: SPN: 558 FMI: 13 LAMP: Maintenance SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration. Voltage at accelerator pedal or lever idle validation switch on and accelerator pedal or lever idle validation off circuit does not match accelerator pedal position. | Engine will only idle or can revert to other throttle input if available.
QSK19 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Circuit
QSK19 CM2150 Marine Propulsion - Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The accelerator pedal or lever idle validation position switch is attached to the accelerator pedal or lever position sensor. The accelerator pedal or lever idle validation position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal or lever is depressed and released. The accelerator pedal or lever position circuit contains three wires: accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4), accelerator pedal or lever position RETURN (sensor return 4), and accelerator pedal or lever position SIGNAL. The accelerator pedal or lever position RETURN (sensor return 4) circuit has a shared return with other original equipment manufacturer (OEM) switches.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal.

Shop Talk

This fault is logged when both the accelerator pedal or lever idle validation switch on SIGNAL and accelerator pedal or lever idle validation switch off SIGNAL disagree with the accelerator pedal or position SIGNAL. Turning the keyswitch ON while partially depressing the accelerator pedal or lever can cause this fault code to go active. This fault will stay active until the accelerator pedal is cycled through its full travel.

It is important to note, while troubleshooting this fault code, the INSITE™ electronic service tool will display the default throttle position, not the actual accelerator pedal or lever position when this fault code is logged. A digital multimeter must be used to read accelerator pedal or lever position and not the INSITE™ electronic service tool.

Possible causes of this fault code are:

  • Accelerator pedal is not calibrated properly
  • Accelerator pedal position sensor malfunctioned
  • Both idle validation switches disagree with the accelerator pedal position.
Refer to Troubleshooting Fault Code 2697.

Last Modified: 22-Jun-2010


Start Enable Device 1 Canister Empty (Ether Injection) - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2734

Start Enable Device 1 Canister Empty (Ether Injection) - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2734 PID: SPN: 626 FMI: 17 LAMP: None SRT: | Start Enable Device 1 Canister Empty (Ether Injection) - Data Valid But Below Normal Operating Range - Least Severe Level. The ether canister for the Start Enable Device 1 Canister (Ether Injection) is empty. | The Start Enable Device 1 Canister Empty (Ether Injection) is disabled.
QSK19 CM2150 Industrial - Start Enable Device 1 Canister Empty (Ether Injection) System

Circuit Description

Not applicable for this fault code.

Component Location

The ether injection canister location depends on the original equipemnt manufacturer (OEM). Refer to the OEM service manual for component location.

Shop Talk

This fault code occurs when the ether injection canister is empty.

Refer to Troubleshooting Fault Code 2734.

Last Modified: 01-Apr-2011


Exhaust Gas Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2735

Exhaust Gas Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2735 PID: SPN: 173 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor 1 circuit. | None on performance.
QSK19 CM2150 Marine - Exhaust Gas Temperature Sensor 1 Circuit

Circuit Description

The exhaust gas temperature sensor 1 circuit monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor 1 is located in the 90 degree exhaust elbow, after the turbocharger.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
50 | 122 | 2,326,245
100 | 212 | 289,445 to 481,411
200 | 392 | 25,922 to 35,567
300 | 572 | 5,297 to 6,608
400 | 752 | 1,634 to 1,926
500 | 932 | 681 to 771
600 | 1112 | 347 to 379
700 | 1292 | 197 to 219
800 | 1472 | 124 to 139
900 | 1652 | 84.2 to 94.9
1000 | 1832 | 64.5
Refer to Troubleshooting Fault Code 2735.

Last Modified: 28-Jun-2010


Exhaust Gas Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2736

Exhaust Gas Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2736 PID: SPN: 173 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at exhaust gas temperature sensor 1 circuit. | No engine protection for exhaust gas temperature.
QSK19 CM2150 Marine - Exhaust Gas Temperature Sensor 1 Circuit

Circuit Description

The exhaust gas temperature sensor 1 circuit monitors exhaust gas temperature and passes information to the ECM through the engine harness.

Component Location

The exhaust gas temperature sensor 1 is located in the 90 degree exhaust elbow, after the turbocharger.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness.
  • Signal circuit shorted to return or ground in the sensor.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
50 | 122 | 2,326,245
100 | 212 | 289,445 to 481,411
200 | 392 | 25,922 to 35,567
300 | 572 | 5,297 to 6,608
400 | 752 | 1,634 to 1,926
500 | 932 | 681 to 771
600 | 1112 | 347 to 379
700 | 1292 | 197 to 219
800 | 1472 | 124 to 139
900 | 1652 | 84.2 to 94.9
1000 | 1832 | 64.5
Refer to Troubleshooting Fault Code 2736.

Last Modified: 28-Jun-2010


Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2737

Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2737 PID: SPN: 173 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Exhaust gas temperature sensor 1 signal indicates exhaust gas temperature above engine protection critical limit. | Calibration dependent progressive power derate and engine shutdown with increasing time after alert.
QSK19 CM2150 Marine - Exhaust Gas Temperature Sensor 1 Circuit

Circuit Description

The exhaust gas temperature sensor 1 is used by the ECM to monitor the exhaust gas temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The exhaust gas temperature value is used by the ECM for the engine protection system and engine emission control.

Component Location

The exhaust gas temperature sensor 1 is located in the exhaust elbow, after the turbocharger.

Shop Talk

This fault code indicates that the exhaust temperature has exceeded the engine protection limits for high exhaust temperature.

Refer to Troubleshooting Fault Code 2737.

Last Modified: 01-Apr-2011


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. Engine coolant temperature signal indicates coolant temperature is above the engine coolant temperature engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
QSK19 CM2150 - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The engine coolant temperature 1 sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature 1 sensor is located on the exhaust side of the engine, near the thermostat housing.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree.

Refer to Troubleshooting Fault Code 2963.

Last Modified: 01-Apr-2011


Engine Torque Limit Feature - Special Instructions

FAULT CODE 2998

Engine Torque Limit Feature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2998 PID: SPN: 1632 FMI: 14 LAMP: Amber SRT: | Engine Torque Limit Feature - Special Instructions. Engine overloaded. | Possible engine derate if enabled.
ECM CM2150

Circuit Description

N/A

Component Location

N/A

Shop Talk

This fault code is designed to keep the engine from overloading.

The fault code is triggered when the engine speed fails to attain the commanded speed.

Potential causes of this fault code are:

  • Low engine power
  • High idle adjustment is too high
  • Excessive hull fouling
  • Incorrect transmission or propeller.

Refer to the OEM service manual for causes associated with excessive hull fouling and incorrect transmission or propeller, as these are external to engine.

Refer to Troubleshooting Fault Code 2998.

Last Modified: 20-Aug-2010


Instantaneous Estimated Brake Power - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3132

Instantaneous Estimated Brake Power - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3132 PID: SPN: 1242 FMI: 18 LAMP: Amber SRT: | Instantaneous Estimated Brake Power - Data Valid But Above Normal Operating Range - Moderately Severe Level - Fault Code 327 has occurred beyond calibrated limit. | Fueling is derated only to limit power to the appropriate rating.
QSK19 CM2150 - ECM

Circuit Description

The electronic control module (ECM) uses the Adaptive Power Limiter Feature to detect when engine is producing power greater than the appropriate engine rating.

Component Location

The ECM is located on the left bank side of the engine.

Shop Talk

Fault Code 3132 will log after the number of Fault Code 327 counts has exceeded the calibrated limit. Fault Code 327 is for the Adaptive Power Limiter feature. It is used to detect when the engine is producing power greater than the appropriate engine rating. The fault code is most often caused by overfueling. This can cause excessive exhaust temperatures, turbocharger speed, and boost pressures. The ECM will limit fueling to bring these readings back into normal ranges.

Refer to Troubleshooting Fault Code 3132.

Last Modified: 22-Jun-2010


Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3694

Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3694 PID: SPN: 4184 FMI: 4 LAMP: Amber SRT: | Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source. | The ECM gain adjust potentiometer will go to the default value.
QSK19 CM2150 Power Generation - Gain Adjust Potentiometer Circuit

Circuit Description

The gain adjust potentiometer is used to regulate the governor gains.

Component Location

The gain adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Shop Talk

Possible causes of the fault code include:

  • SIGNAL wire open or shorted to ground
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-3694.

Last Modified: 08-Feb-2011


Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3695

Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3695 PID: SPN: 4182 FMI: 4 LAMP: Amber SRT: | Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source. | The generator output frequency adjust potentiometer will go to the default value.
QSK19 CM2150 Marine Auxiliary with C Command™ Panel System - Generator Output Frequency Adjust Potentiometer Circuit
QSK19 CM2150 Marine Auxiliary with C Command Elite™ and C Command Elite Plus™ Panel System - Generator Output Frequency Adjust Potentiometer Circuit
QSK19 CM2150 Power Generation

Circuit Description

The generator output frequency adjust potentiometer circuit provides an analog (0 to 5-VDC) input for commanding a speed offset to the base-rated speed to regulate the generator frequency. An external generator set controller can supply an analog signal with a potentiometer to this input to modify the generator set operating speed for synchronization or droop operations. The commanded engine speed offset is linearly proportional to the input voltage and nominal voltage of 2.5-VDC commands a speed offset of 0 rpm.

Component Location

The generator output frequency adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Shop Talk

If Fault Code 3695 goes active, the generator output frequency adjust potentiometer will not respond.

Possible causes of the fault code include:

  • SIGNAL wire open or shorted to ground.
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-3695.

Last Modified: 08-Feb-2011


Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3696

Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3696 PID: SPN: 4183 FMI: 4 LAMP: Amber SRT: | Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source. | The droop adjust potentiometer will go to the default value.
QSK19 CM2150 Power Generation -Droop Adjust Potentiometer Circuit

Circuit Description

The droop adjust potentiometer is used to regulate the engine droop.

Component Location

The droop adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Shop Talk

Possible causes of the fault code include:

  • SIGNAL wire open or shorted to ground
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-3696.

Last Modified: 08-Feb-2011


Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4615

Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4615 PID: SPN: 94 FMI: 0/0 LAMP: Amber SRT: | Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The fuel pump supply pressure is very high. | Low power or engine smoke.
QSK19 CM2150 Industrial - Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Marine- Fuel Delivery Pressure Sensor Circuit
QSK19 CM2150 Power Generation - Fuel Delivery Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor is used by the engine control module (ECM) to monitor fuel delivery pressure directly before the Stage 2 filter. The ECM monitors the voltage on the SIGNAL pin and converts this to a pressure value.

Component Location

The fuel delivery pressure sensor is located in the Stage 2 fuel filter head. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • Stage 2 fuel filter restriction
  • Pinched or damaged fuel supply line
  • Stuck gerotor pump fuel pressure regulator located in the high-pressure pump.
Refer to Troubleshooting Fault Code t05-4615.

Last Modified: 09-Mar-2015


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4642

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4642 PID: SPN: 97 FMI: 0 LAMP: Red SRT: | Water in Fuel Indicator - Data Valid But Above Normal Operating Rage - Most Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting. Engine derate will occur on marine engines if optional engine protection feature is enabled.
QSK19 CM2150 Industrial - Water In Fuel Indicator Sensor Circuit
QSK19 CM2150 Marine - Water In Fuel Indicator Sensor Circuit
QSK19 CM2150 Power Generation - Water In Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator sensor is attached to the first stage fuel filter. The water in fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator sensor circuit contains two wires; a water in fuel indicator return (sensor return 1) ground wire and a water in fuel indicator signal wire.

Component Location

The water in fuel indicator sensor is integrated into the bottom of the first stage fuel filter. The first stage fuel filter is located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • On marine propulsion engines, if the optional engine protection feature has been enabled, a speed derate will occur.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

Drain the Stage 1 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active and there is no water in the fuel filter then a malfunctioning water in fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code t05-4642.

Last Modified: 25-Sep-2015


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4688

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4688 PID: SPN: 97 FMI: 3 LAMP: Maintenance SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water in fuel indicator circuit. | None on performance. No water in fuel warning available.
QSK19 CM2150 Marine - Water In Fuel Indicator 2 Sensor Circuit

Circuit Description

The water-in-fuel indicator sensor is fitted by the original equipment manufacturer (OEM). The water in fuel indicator 2 sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator 2 sensor circuit contains two wires; a water in fuel indicator RETURN (sensor return 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator sensor is mounted by the OEM. Refer to the OEM service manual.

Shop Talk

The water in fuel sensor is integrated into the fuel filter. It is automatically replaced whenever the fuel filter is replaced.

Possible causes for this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-4688.

Last Modified: 02-Jan-2017


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4689

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4689 PID: SPN: 97 FMI: 4 LAMP: Maintenance SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water in fuel indicator sensor circuit. | None on performance. No water in fuel warning available.
Water in Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator sensor is installed by the original equipment manufacturer (OEM). The water in fuel indicator sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator sensor circuit contains two wires: a water in fuel indicator RETURN (sensor return 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator sensor is mounted by the OEM. See equipment manufacturer service information.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM or circuit is affected.

Possible causes for this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
Refer to Troubleshooting Fault Code t05-4689.

Last Modified: 12-Dec-2016


Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5366

Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5366 PID: SPN: 6301 FMI: 16 LAMP: Amber SRT: | Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting. Engine derate will occur on Marine engines if optional engine protection feature is enabled.
Water In Fuel 2 Indicator Sensor Circuit

Circuit Description

The water in fuel indicator 2 sensor is attached to the Stage 0 (original equipment manufacturer (OEM)) fuel filter for Marine applications. The water in fuel indicator 2 sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator 2 sensor circuit contains two wires; a water in fuel indicator RETURN (sensor RETURN 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator 2 sensor is installed as an option into the Stage 0 (OEM) fuel filter housing which is mounted off-engine. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Water in the fuel can do extensive damage to the fuel system due to the tight tolerances of the fuel system components.

Drain the Stage 0 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active and there is no water in the fuel filter, then a malfunctioning water in fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code 5366.

Last Modified: 02-Jan-2017


Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 5367

Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4642 PID: SPN: 6301 FMI: 0 LAMP: Red SRT: | Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Most Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting. Engine derate will occur on Marine engines if optional engine protection feature is enabled.
Water In Fuel 2 Indicator Sensor Circuit

Circuit Description

The water in fuel indicator 2 sensor is attached to the Stage 0 (original equipment manufacturer (OEM)) fuel filter for Marine applications. The water in fuel indicator 2 sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator 2 sensor circuit contains two wires; a water in fuel indicator RETURN (sensor RETURN 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator 2 sensor is installed as an option into the Stage 0 (OEM) fuel filter housing which is mounted off-engine. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Water in the fuel can do extensive damage to the fuel system due to the tight tolerances of the fuel system components.

Drain the Stage 0 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active and there is no water in the fuel filter, then a malfunctioning water in fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code 5367.

Last Modified: 02-Jan-2017


Fault Code Path Selection

FAULT CODE 5633
Fault Code Path Selection

Is engine used for propulsion application? | Go to 123-fc5633prop
Is engine used for auxiliary application? | Go to 123-fc5633aux

Last Modified: 07-Nov-2016


Fault Code Path Selection

FAULT CODE 5634
Fault Code Path Selection

Is engine used for propulsion application? | Go to 123-fc5634prop
Is engine used for auxiliary application? | Go to 123-fc5634aux

Last Modified: 08-Oct-2015


Fault Code Path Selection

FAULT CODE 5635
Fault Code Path Selection

Is engine used for propulsion application? | Go to 123-fc5635prop
Is engine used for auxiliary application? | Go to 123-fc5635aux

Last Modified: 06-Oct-2015


Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5932

Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5932 PID: SPN: 6301 FMI: 15 LAMP: Maintenance SRT: | Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
Water in Fuel Indicator Sensor Circuit

Circuit Description

The water in fuel indicator 2 sensor is attached to the Stage 0 original equipment manufacturer (OEM) fuel filter for Marine applications. The water in fuel indicator 2 sensor sends a signal to the engine control module (ECM) when a set volume of water has accumulated in the fuel filter. The water in fuel indicator 2 sensor circuit contains two wires; a water in fuel indicator return (sensor RETURN 1) ground wire and a water in fuel indicator SIGNAL wire.

Component Location

The water in fuel indicator 2 sensor is installed as an option into the Stage 0 (OEM) fuel filter housing which is mounted off-engine. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected water in fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

Drain the Stage 0 and/or duplex fuel filters.

Bulk fuel supply may be contaminated.

If this fault code is active and there is no water in the fuel filter, a malfunctioning water in fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code 5932.

Last Modified: 12-Dec-2016


Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5946

Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5946 PID: SPN: 175 FMI: 0 LAMP: Red SRT: | Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The transmission (or gearbox) oil temperature sensor indicates the transmission (or gearbox) oil temperature is above the protection limit. | No engine protection for engine oil temperature.
Engine Oil Temperature 1 Sensor Circuit

Circuit Description

The transmission (or gearbox) oil temperature sensor is used by the engine control module (ECM) to monitor the transmission oil temperature. The ECM monitors the voltage on the SIGNAL pin and converts it to a temperature value.

Component Location

The transmission (or gearbox) oil temperature sensor is located in the transmission.

Shop Talk

There are multiple ECMs for the engine models included in this manual. Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

This fault code indicates that the transmission (or gearbox) temperature has exceeded the protection limits for high transmission (or gearbox) temperature.

Refer to Troubleshooting Fault Code 5946.

Last Modified: 03-Jan-2017


Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 431 (Integrated Sensor Switch)

Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | Engine will only idle.
QSK19 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Switch Circuit
QSK19 CM2150 Marine Propulsion - Accelerator Pedal or Lever Idle Validation Switch Circuit

Circuit Description

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The integrated sensor switch (ISS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by an open circuit on either the accelerator pedal or lever idle validation switch on signal or accelerator pedal or lever idle validation switch off signal circuit, a loose connection, uncalibrated accelerator pedal assembly, or incorrectly wired idle validation switch.
  • The ISS has a different internal resistance specification (125 ohms) than the nonintegrated sensor switch (NISS).
  • When installing a new accelerator pedal assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code 431 (Integrated Sensor Switch).

Last Modified: 16-Jun-2010


Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 431 (Nonintegrated Sensor Switch)

Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | Engine will only idle.
QSK19 CM2150 Industrial - Accelerator Pedal or Lever Idle Validation Circuit
QSK19 CM2150 Marine Propulsion - Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The nonintegrated sensor switch (NISS) is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by an open circuit on either the accelerator pedal or lever idle validation switch ON signal or accelerator pedal or lever idle validation switch OFF signal circuits, a loose connection, uncalibrated accelerator pedal assembly, or mis-wired idle validation switch.
  • The NISS has a different internal resistance specification (10 ohms) than the integrated sensor switch (ISS).
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to ON position and fully depress and release the pedal or lever three times.
Refer to Troubleshooting Fault Code 431 (Nonintegrated Sensor Switch).

Last Modified: 16-Jun-2010


Marine Low Load Protection - Condition Exists

FAULT CODE 5633 (Auxiliary)

Marine Low Load Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5633 PID: SPN: 520891 FMI: 31 LAMP: Maintenance SRT: | Marine Low Load Protection - Condition Exists. Low load condition has been detected by the engine control module (ECM). | None on performance.

Circuit Description

Marine Low Load Protection monitors the engine operating in a low load condition of less than 15 percent of rated torque. This feature is needed to limit engine exposure in such working conditions by alerting the operator.

Component Location

Not Applicable

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque falls below the low load threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the low load region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in the normal operating region during a sea trial.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the white MAINTENANCE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • This is an information-only fault code that becomes active if the engine torque falls below the low load threshold for a calibratable time.
  • High counts of inactive Fault Code 5633 can indicate the engine is often operated below the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.
  • No repairs are necessary.
Refer to Troubleshooting Fault Code 5633.

Last Modified: 03-Nov-2016


Marine Low Load Protection - Condition Exists

FAULT CODE 5633 (Propulsion)

Marine Low Load Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5633 PID: SPN: 520891 FMI: 31 LAMP: Maintenance SRT: | Marine Low Load Protection - Condition Exists. Low load condition has been detected by the engine control module (ECM). | None on performance.

Circuit Description

Marine Low Load Protection monitors the engine operating in a low load condition of less than 15 percent of rated torque. This feature is needed to limit engine exposure in such working conditions by alerting the operator.

Component Location

Not Applicable

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque falls below the low load threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the low load region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in the normal operating region during a sea trial.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the white MAINTENANCE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • This is an information-only fault code that becomes active if the engine torque falls below the low load threshold for a calibratable time.
  • High counts of inactive Fault Code 5633 can indicate the engine is often operated below the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.
  • No repairs are necessary.
Refer to Troubleshooting Fault Code 5633.

Last Modified: 03-Nov-2016


Marine Overload Protection - Condition Exists

FAULT CODE 5634

Marine Overload Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5634 PID: SPN: 520892 FMI: 14 LAMP: Amber SRT: | Marine Overload Protection - Condition Exists. Overload condition has been detected by the engine control module (ECM). | None on performance.
Typical Overload Region for Auxiliary Application

Circuit Description

X - Engine Speed

Y - Torque

1 - Fuel Limited Torque Curve

2 - Overload Region

3 - 100 Percent Torque

4 - 110 Percent Torque.

The shaded region in the graph above corresponds to the calibratable overload region. Marine Overload Protection monitors the engine operating in an overload condition. This feature is needed to limit engine exposure in such working conditions by alerting the operator and, in some cases, by limiting fueling to the engine.

Component Location

N/A

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque exceeds the overload threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the overload region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in the normal operating region for more than a calibratable time.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This is an information-only fault code that becomes active if the engine torque exceeds the overload threshold for a calibratable time.

High counts of inactive Fault Code 5634 can indicate the engine is often operated beyond the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.

No repairs are necessary.

Reference the Marine Application Bulletin – 0.19.00 – Electronic Engine Controls for more information on this diagnostic.

Refer to Troubleshooting Fault Code 5634.

Last Modified: 03-Sep-2015


Marine Overload Protection - Condition Exists

FAULT CODE 5634

Marine Overload Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5634 PID: SPN: 520892 FMI: 14 LAMP: Amber SRT: | Marine Overload Protection - Condition Exists. Overload condition has been detected by the engine control module (ECM). | None on performance.
Typical Overload Region for Propulsion Application

Circuit Description

X - Engine Speed

Y - Torque

1 - Fuel Limited Torque Curve

2 - Propeller Curve

3 - Overload Region.

The shaded region in the graph above corresponds to the calibratable overload region. Marine Overload Protection monitors the engine operating in an overload condition. This feature is needed to limit engine exposure in such working conditions by alerting the operator.

Component Location

N/A

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque exceeds the overload threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the overload region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in the normal operating region for more than a calibratable time.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • This is an information-only fault code that becomes active if the engine torque exceeds the overload threshold for a calibratable time.
  • High counts of inactive Fault Code 5634 can indicate the engine is often operated beyond the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.
  • No repairs are necessary.
  • Reference the Marine Application Bulletin – 0.19.00 – Electronic Engine Controls for more information on this diagnostic.
Refer to Troubleshooting Fault Code 5634.

Last Modified: 03-Sep-2015


Marine Overload Protection - Special Instructions

FAULT CODE 5635

Marine Overload Protection - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5635 PID: SPN: 520892 FMI: 14 LAMP: Amber SRT: | Marine Overload Protection - Special Instructions. Overload condition has been detected by the engine control module (ECM). | Reduction in engine torque.
Typical Overload Region for Auxiliary Application

Circuit Description

X - Engine Speed

Y - Torque

1 - Fuel Limited Torque Curve

2 - Overload Region

3 - 100 Percent Torque

4 - 110 Percent Torque.

The shaded region in the graph above corresponds to the calibratable overload region. Marine Overload Protection monitors the engine operating in an overload condition. This feature is needed to limit engine exposure in such working conditions by alerting the operator and, in some cases, by limiting fueling to the engine.

Component Location

N/A

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque exceeds the overload threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the overload region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in the normal operating region for more than a calibratable time.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This is an information-only fault code that becomes active if the engine torque exceeds the overload threshold for a calibratable time.

High counts of inactive Fault Code 5635 can indicate the engine is often operated beyond the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.

No repairs are necessary.

Reference the Marine Application Bulletin – 0.19.00 – Electronic Engine Controls for more information on this diagnostic.

Refer to Troubleshooting Fault Code 5635.

Last Modified: 28-Sep-2015


Marine Overload Protection - Special Instructions

FAULT CODE 5635

Marine Overload Protection - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5635 PID: SPN: 520892 FMI: 14 LAMP: Amber SRT: | Marine Overload Protection - Special Instructions. Overload condition has been detected by the engine control module (ECM). | None on performance.
Typical Overload Region for Propulsion Application

Circuit Description

X - Engine Speed

Y - Torque

1 - Fuel Limited Torque Curve

2 - Propeller Curve

3 - Overload Region.

The shaded region in the graph above corresponds to the calibratable overload region. Marine Overload Protection monitors the engine operating in an overload condition. This feature is needed to limit engine exposure in such working conditions by alerting the operator.

Component Location

N/A

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine torque exceeds the overload threshold.

Conditions for Setting the Fault Codes

  • The ECM detected speed and torque values in the overload region for more than a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM detected speed and torque values in the normal operating region for more than a calibratable time.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • This is an information-only fault code that becomes active if the engine torque exceeds the overload threshold for a calibratable time.
  • High counts of inactive Fault Code 5635 can indicate the engine is often operated beyond the normal expected region. Vessel operating duty cycle or equipment may need to be investigated to understand fault condition.
  • No repairs are necessary.
  • Reference the Marine Application Bulletin – 0.19.00 – Electronic Engine Controls for more information on this diagnostic.
Refer to Troubleshooting Fault Code 5635.

Last Modified: 03-Sep-2015


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 1852 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1852?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1852.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1852?
YES NO

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion. Clean or replace the connector or sensor, as necessary.

No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Oct-2015


Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2562 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2562 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2562 active?
YES NO

Refer to Engine Oil Temperature Above Normal troubleshooting symptom tree in Section TS, in the appropriate service manual.

 No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2562 is inactive.

Fault Code 2562 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Dec-2016


FAULT CODE 4642 - Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 4642?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 4642.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 4642?
YES NO

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion.

Clean or replace the connector or sensor, as necessary.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Mar-2015


FAULT CODE 5366 - Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 5366?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 5366.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 5366?
YES NO

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion.

Clean or replace the connector or sensor, as necessary.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jan-2017


FAULT CODE 5367 - Water in Fuel Indicator 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 5367?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 5367.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 5367?
YES NO

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion.

Clean or replace the connector or sensor, as necessary.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jan-2017


FAULT CODE 5633 - Marine Low Load Protection - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5633 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 5633.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 5633 active?
YES NO

This is an information-only fault code that will only become active if the engine torque exceeds the overload threshold for a calibratable time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Follow the technical escalation process.

Last Modified: 02-Nov-2016


FAULT CODE 5634 - Marine Overload Protection - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5634 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 5634.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 5634 active?
YES NO

This is an information-only fault code that will only become active if the engine torque exceeds the overload threshold for a calibratable time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Sep-2015


FAULT CODE 5635 - Marine Overload Protection - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5635 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 5635.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 5635 active?

This is an information-only fault code that will only become active if the engine torque exceeds the overload threshold for a calibratable time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Sep-2015


FAULT CODE 5932 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 4642?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 4642.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 4642?
YES NO

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion.

Clean or replace the connector or sensor, as necessary.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jan-2017


FAULT CODE 5946 - Transmission (or Gearbox) Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5946 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 5946 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5946 active?
YES NO

Verify transmission (or gearbox) oil level is correct. See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 214 is inactive.

Fault Code 5946 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Jan-2017


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both or Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Determine if Fault Code 115 becomes active during cranking. | Fault Code 115 becomes active during cranking?
 | STEP 1B. Inspect the engine harness. | Harness connectors connected to correct sensors?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Determine if Fault Code 115 becomes active during cranking.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Attempt to start the engine by engaging the starter for at least 10 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 becomes active during cranking?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Inspect the engine harness.

Conditions

  • Turn the keyswitch OFF.

Action

Inspect the engine harness connectors for correct connections.

  • Make sure the engine crankshaft speed/position sensor and engine camshaft speed/position sensor are connected to the engine wiring harness correctly.

Harness connectors connected to correct sensors?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn the keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 115 is inactive.

Fault Code 115 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn the keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the intake manifold 1 pressure 5 volt supply (sensor supply 2) and intake manifold 1 pressure return (sensor return 2) circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify intake manifold 1 pressure sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the intake manifold 1 pressure 5 volt supply (sensor supply 2) and intake manifold 1 pressure return (sensor return 2) circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

See Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Check all harnesses connected in series.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connector. Refer to Procedure 019-209 in Section 19.
  • Repair or replace the sensor. Refer to Procedure 019-066 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the intake manifold 1 pressure 5 volt supply (sensor supply 2) and intake manifold 1 pressure return (sensor return 2) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold 1 pressure sensor. Refer to Procedure 019-061 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connectors. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

A pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Troubleshoot all harnesses to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the harness.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connectors. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connectors. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the intake manifold 1 pressure 5 volt supply (sensor supply 2) and intake manifold 1 pressure return (sensor return 2) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open RETURN circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connectors. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the intake manifold 1 pressure 5 volt supply (sensor supply 2) and intake manifold 1 pressure return (sensor return 2) circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the intake manifold 1 pressure 5 volt supply (sensor supply 2) and intake manifold 1 pressure return (sensor return 2) circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

See Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of engine harness or damaged sensor.

Check harnesses connected in series.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the sensor. Refer to Procedure 019-066 in Section 19.
  • Repair or replace the connector. Refer to Procedure 019-209 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the intake manifold 1 pressure 5 volt supply (sensor supply 2) and intake manifold 1 pressure return (sensor return 2) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold 1 pressure SIGNAL pin at the intake manifold 1 pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold 1 pressure sensor Refer to Procedure 019-061 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the intake manifold 1 pressure 5 volt supply (sensor supply 2) and intake manifold 1 pressure return (sensor return 2) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the intake manifold 1 pressure RETURN (sensor return 2) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

A open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the intake manifold 1 pressure 5 volt SUPPLY (sensor supply 2) pin and the intake manifold 1 pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open circuit or a pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Troubleshoot each section of harness to determine which contains the open or pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 123 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the engine oil rifle pressure 1 sensor and circuit. |
 | STEP 2A. Inspect the engine oil rifle pressure 1 sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault code 135 inactive?
 | STEP 2C. Check the engine oil rifle pressure 1 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the engine oil rifle pressure 1 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

See Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 135 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil rifle pressure 1 sensor and circuit.

Guided Step 2A - Inspect the engine oil rifle pressure 1 sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Check all harnesses connected in series.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the sensor. Refer to Procedure 019-066 in Section 19.
  • Repair or replace the connector. Refer to Procedure 019-209 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the engine oil rifle pressure 1 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine oil rifle pressure 1 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil rifle pressure 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

  • Replace the engine oil rifle pressure 1 sensor. Refer to Procedure 019-066 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

A pin-to-pn short circuit has been detected on the signal wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of the engine harness.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine oil rifle pressure 1 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine oil rifle pressure 1 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 135 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins®Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement. Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the engine oil rifle pressure 1 sensor and circuit. |
 | STEP 2A. Inspect the engine oil rifle pressure 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine oil rifle pressure 1 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine oil rifle pressure 1 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

See Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil rifle pressure 1 sensor and circuit.

Guided Step 2A - Inspect the engine oil rifle pressure 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and engine oil rifle pressure 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-066 in Section 19.
  • Refer to Procedure 019-209 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from engine oil rifle pressure 1 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the engine oil rifle pressure 1 5 volt SUPPLY (sensor supply 1) pin and the engine oil rifle pressure 1 SIGNAL pin at the engine oil rifle pressure 1 sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil rifle pressure 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil rifle pressure 1 sensor. Refer to Procedure 019-066 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine oil rifle pressure 1 - 5 volt supply (sensor supply 1) and engine oil rifle pressure 1 return (sensor return 1) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine oil rifle pressure 1 5 volt SUPPLY (sensor supply 1) pin to the engine oil rifle pressure 1 RETURN (sensor return 1) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short or open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the engine oil rifle pressure 1 5 volt SUPPLY (sensor supply 1) pin and the engine oil rifle pressure 1 SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open circuit or a pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or pin-to-pin short.

Replace the damaged section of the engine harness.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 141 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 10-Mar-2015


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

See the Lubricating Oil Pressure - Low troubleshooting tree in the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Series Engines, Bulletin 4021592.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 10-Mar-2011


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature 1 sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature 1 sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin and engine coolant temperature 1 RETURN (sensor return 1) pin at the engine coolant temperature 1 sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following rocedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature 1 sensor. Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the malfunction.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine coolant temperature 1 SIGNAL pin and engine coolant temperature 1 RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector, the engine coolant temperature 1 RETURN (sensor return 1) pin, and the engine harness engine coolant temperature 1 RETURN (sensor return 1) connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature 1 SIGNAL pin and the engine harness engine coolant temperature 1 SIGNAL connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature 1 sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature 1 sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature 1 sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 is active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature 1 sensor. Refer to Procedure 019-019 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine coolant temperature 1 sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature 1 SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 146. | Active or inactive counts of Fault Code 146?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 146.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 146.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 146?
YES NO

Reference the Engine Coolant Temperature Above Normal symptom tree in Section TS in the Service Manual QSK19 and QSK19 CM850 and CM2150 Modular Common Rail System Series Engines, Bulletin 4021592.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 10-Mar-2011


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 151. | Active or inactive counts of Fault Code 151?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 151.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 151?
YES NO

Reference the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Section TS in the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Series Engines, Bulletin 4021592.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 10-Mar-2011


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold 1 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 1 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold 1 temperature SIGNAL pin and intake manifold 1 temperature RETURN (sensor return 1) pin at the intake manifold 1 temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the malfunction.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 1 temperature SIGNAL pin and the intake manifold 1 temperature RETURN (sensor return 1) pin at the ECM connector.
  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 1 temperature (sensor return 1) RETURN pin and the engine harness intake manifold 1 temperature (sensor return 1) RETURN connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold 1 temperature SIGNAL pin and the engine harness intake manifold 1 temperature SIGNAL connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damagged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 1 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold 1 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 1 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or the damaged sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 1 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-059 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 1 temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the intake manifold 1 temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold 1 temperature SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector and pin location.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 155 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Connect INSITE™ electronic service tool.
  • Compare the intake manifold 1 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the sensor reading in INSITE™?
YES NO
No Repair

A fault intake manifold 1 temperature sensor has been detected.

Replace the intake manifold 1 temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Intake Manifold 1 Temperature Above Specification troubleshooting symptom tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 155 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2011


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 2 and return. |
 | STEP 2A. Inspect the engine camshaft speed/position sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the intake manifold 1 pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the injector metering rail 1 pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the fuel delivery pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 187 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 2 and return.

Guided Step 2A - Inspect the engine camshaft speed/position sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE ™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the engine camshaft speed/position sensor. Refer to Procedure 019-363 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake manifold 1 pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-209 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold 1 pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the injector metering rail 1 pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-215 in Section 19.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the injector metering rail 1 pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.
  • Refer to Procedure 019-390 in Section 19.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged barometric pressure sensor has been detected. Replace the barometric pressure sensor.

  • Refer to Procedure 019-004 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the fuel delivery pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-209 in Section 19.
  • Refer to Procedure 019-390 in Section 19.

No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged fuel delivery pressure sensor has been detected. Replace the fuel delivery pressure sensor.

  • Refer to Procedure 019-398 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit art or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


Fault Code 195 - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824811 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the coolant level sensor 1 and circuit. |
 | STEP 2A. Inspect the coolant level sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 800k ohms?
STEP 3. | Check the engine harness and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the coolant level sensor 1 and OEM harness connector.

Guided Step 2A - Inspect the coolant level sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the coolant level sensor 1 connector.

Action

Inspect the OEM harness connector and coolant level sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or OEM harness connector.

Clean the connector and pins.

  • Repair the damaged harness and the connections. Refer to Procedure 019-071 in Section 19.
  • Replace the coolant sensor. Refer to Procedure 019-017 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.

Action

Check the sensor resistance.

  • Measure the resistance between the coolant level SIGNAL pin and the coolant level RETURN pin at the coolant level sensor 1 connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 800k ohms?
YES NO

Replace the coolant level sensor 1. Refer to Procedure 019-017 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness and OEM harness.

Guided Step 3A - Inspect the engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the OEM harness from the engine harness.

Action

Inspect the OEM harness connector and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness, or the ECM.

Check all harnesses connected in series.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the wiring harness and connections. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the coolant level sensor 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector coolant level sensor 1 RETURN pin and the OEM harness coolant level sensor 1 connector RETURN pin.

Use the following procedure ofr general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness or engine harness.

Troubleshoot each section of the engine and OEM harnesses to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness or OEM harness.

  • Repair the OEM harness and the connections. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the coolant level SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness or OEM harness.

  • Repair the OEM harness and the connections. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM 60-pin OEM port.
  • Disconnect the engine coolant level sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM 60-pin OEM port and all other pins in the OEM harness ECM 60-pin OEM port.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Troubleshoot each section of the OEM harness to determine which contains the pin-to-pin short.

Check all harnesses connected in the series.

Replace the damaged section of the engine harness or OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the coolant level sensor 1 and OEM connector. |
 | STEP 2A. Inspect the coolant level sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the OEM harness, engine harness, and ECM. |
 | STEP 3A. Inspect the ECM, OEM harness and engine harness connector pins, and engine harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the coolant level sensor 1 and OEM connector.

Guided Step 2A - Inspect the coolant level sensor 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, or replace the coolant level sensor 1.

  • Replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace or repair the sensor. Refer to Procedure 019-017 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant level sensor 1 connector to the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged coolant level sensor 1 has been detected.

Replace the coolant level sensor 1. Refer to Procedure 019-017 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness, engine harness, and ECM.

Guided Step 3A - Inspect the ECM, OEM harness, and engine harness connector pins, and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the OEM harness connector from the sensor connector.
  • Disconnect the OEM harness connector from the engine harness connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness, the engine harness, or the ECM.

Clean the connector and pins.

Replace the damaged section of the OEM harness, the engine harness, or the ECM.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine coolant level sensor connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the coolant level 1 5-volt (sensor supply 1) SUPPLY pin in the OEM harness ECM 60-pin OEM port connector and the coolant level 1 5-volt supply (sensor supply 1) SUPPLY pin in the OEM harness engine coolant level sensor 1 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY wire has been detected in the OEM harness.

Troubleshoot each section of the OEM harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness or OEM harness.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 60-pin OEM port connector
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-362 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the OEM harness or engine harness.

Troubleshoot each of the harness sections to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM 60-pin OEM port connector
  • Disconnect the coolant level sensor 1 connector from the OEM harness connector.

Action

Check for a pin short to ground.

  • Measure the resistance and check for a short circuit between the coolant level sensor 1 SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness or engine harness.

Troubleshoot each of the harness sections to determine which contains the open circuit.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 196 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
 | STEP 1B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 1C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 197 inactive?
 | STEP 2B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete

Guided Step 1B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM 60-pin port connector.
  • Disconnect the engine coolant level sensor connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the coolant level 1 5 volt (sensor supply 1) SUPPLY pin in the OEM harness ECM 60-pin port connector and the coolant level 1 5 volt supply (sensor supply 1) SUPPLY pin in the OEM harness engine coolant level sensor 1 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY wire has been detected in the OEM harness.

Troubleshoot each section of the OEM harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness or OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM 60-pin port connector.
  • Disconnect the engine coolant level sensor 1 from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine coolant level 1 SIGNAL pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

See the Coolant Loss troubleshooting symptom tree in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each section of the OEM harness to determine which contains the pin-to-pin short circuit.

  • Replace the damaged section of the engine harness or OEM harness. Refer to Procedure 019-071 in Section 19.

Appropriate troubleshooting steps

Repair complete

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 197 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227, on the same source address as Fault Code 221, active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the barometric pressure 5 volt SUPPLY (sensor supply 2) and barometric pressure RETURN (sensor supply 2). | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227, on same source address as Fault Code 221, active?
YES | NO
No Repair | No Repair

Reference Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-004 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-218 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

A pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Check each section of harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the barometric pressure 5 volt SUPPLY (sensor supply 2) and barometric pressure RETURN (sensor return 2).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open RETURN circuit has been detected in the engine harness.

Check each section of harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 221 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187, on same source address as Fault Code 222, active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the barometric pressure 5 volt SUPPLY (sensor supply 2) and barometric pressure RETURN (sensor return 2) circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the barometric pressure 5 volt SUPPLY (sensor supply 2) and barometric pressure RETURN (sensor return 2) circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187, on same source address as Fault Code 222, active?
YES | NO
No Repair | No Repair

Reference Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-004 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the barometric pressure 5 volt SUPPLY (sensor supply 2) pin and the barometric pressure RETURN (sensor return 2) pin at the barometric pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor.

  • Refer to Procedure 019-004 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the barometric pressure 5 volt SUPPLY (sensor supply 2) and barometric pressure RETURN (sensor return 2) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY (sensor supply 2) pin to the barometric pressure RETURN (sensor return 2) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Check each section of engine harness to determine which contains the open or short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the barometric pressure 5 volt SUPPLY (sensor supply 2) pin and the barometric pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open RETURN or a pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Check each section of the engine harness to determine which contains the open or pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 222 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 223 - Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823995 - male Weather Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil burn valve solenoid driver. |
 | STEP 1A. Verify the engine oil burn valve solenoid driver is connected to the engine harness. | Solenoid is connected?
 | STEP 1B. Inspect the engine oil burn valve solenoid driver and harness connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the engine oil burn valve solenoid driver for a short circuit to engine block ground. | Between 18 to 22 ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 223 inactive?

Guided Step 1 - Check the engine oil burn valve solenoid driver.

Guided Step 1A - Verify the engine oil burn valve solenoid driver is connected to the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the engine oil burn valve solenoid driver is connected to the engine harness.

Solenoid is connected?
YES NO
No Repair

Connect the solenoid to the engine harness.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the engine oil burn valve solenoid driver and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.

Action

Inspect the engine oil burn valve solenoid driver and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the engine oil burn valve solenoid driver connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of the harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil burn valve solenoid driver. Refer to Procedure 019-138 in Section 19.

Go to 3A

Go to 1C

Guided Step 1C - Check the engine oil burn valve solenoid driver for a short circuit to engine block ground.

Conditions

  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.

Action

Check for a short circuit to ground in the engine oil burn valve solenoid driver.

  • Measure the resistance from the engine oil burn valve SIGNAL pin of the engine oil burn valve solenoid driver to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 18 to 22 ohms?
YES NO
No Repair

  • Replace the engine oil burn valve solenoid driver. Refer to Procedure 019-138 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or ECM.

Clean the connector and pins.

Replace the damaged section of the harness or damaged solenoid.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the connectors. Refer to Procedure 019-199 in Section 19.
  • Replace the connectors. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine oil burn valve SIGNAL pin of the engine harness 60-pin OEM port connector to engine block ground.
  • Measure the resistance from the engine oil burn valve RETURN pin of the engine harness 60-pin OEM port connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the connectors. Refer to Procedure 019-199 in Section 19.
  • Replace the connectors. Refer to Procedure 019-202 in Section 19.
  • Replace the connectors. Refer to Procedure 019-204 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine oil burn valve SIGNAL pin of the engine harness 60-pin OEM port connector to all other pins in the connector, excluding the following pins: the engine oil burn valve RETURN pin, the accelerator or lever position RETURN (sensor return 4), the OEM temperature RETURN pin, the idle validation switch RETURN pin, and the external speed command input RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Repair the connectors. Refer to Procedure 019-199 in Section 19.
  • Replace the connectors. Refer to Procedure 019-204 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 30 seconds.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to verify that Fault Code 223 is inactive.

Fault Code 223 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-May-2012


FAULT CODE 224 - Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3823995 - male Weather Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 224 is active?
STEP 2. | Check the engine oil burn valve solenoid driver. |
 | STEP 2A. Inspect the engine harness and engine oil burn valve solenoid driver. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine oil burn valve solenoid driver. | Between 18 to 22 ohms?
 | STEP 2C. Check for engine oil burn valve solenoid driver supply voltage and return circuit. | Greater than 6.0-VDC?
 | STEP 2D. Check for an open circuit in the engine oil burn valve solenoid driver return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM engine oil burn valve solenoid driver diagnostic supply voltage. | Greater than 6.0-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 224 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 224 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 224 is active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil burn valve solenoid driver.

Guided Step 2A - Inspect the engine harness and engine oil burn valve solenoid driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Inspect the engine harness connector and solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or solenoid.

Clean the connector and pins.

Replace the damaged section of the harness or damaged solenoid.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged solenoid. Refer to Procedure 019-138 in Section 19.
  • Replace the damaged connector. Refer to Procedure 019-202 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine oil burn valve solenoid driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.

Action

Check for an open circuit in the engine oil burn valve solenoid driver.

  • Measure the resistance from the engine oil burn valve SIGNAL pin to the engine oil burn valve RETURN pin at the engine oil burn valve solenoid driver.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 18 to 22 ohms?
YES NO
No Repair

Replace the engine oil burn valve solenoid driver. Refer to Procedure 019-138 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for engine oil burn valve solenoid driver supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure between the engine oil burn valve SIGNAL pin and the engine oil burn valve RETURN pin at the engine oil burn valve solenoid driver connector of the engine harness.

Greater than 6.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the engine oil burn valve solenoid driver return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine oil burn valve solenoid driver connector.

Action

Check for an open circuit.

  • Measure the resistance from the engine oil burn valve solenoid driver engine harness connector RETURN pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged connector. Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or ECM connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged connector. Refer to Procedure 019-199 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM engine oil burn valve solenoid driver diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the engine oil burn valve SIGNAL pin and the engine oil burn valve RETURN pin at the ECM 60-pin OEM port connector port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 6.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine oil burn valve solenoid driver connector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil burn valve solenoid driver harness connector SUPPLY pin and the engine oil burn valve solenoid driver 60-pin OEM port connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged connector. Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine oil burn valve solenoid driver from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil burn valve SIGNAL pin in the engine harness 60-pin OEM port connector and all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged connector. Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 224 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 30 seconds.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 224 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ECM response. | Fault Code 227 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 10-Mar-2015


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins® has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT A CUMMINS® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 2450 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating0 conditions. | Engine motoring downhill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1E. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1F. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Engine motoring downhill?
YES NO
No Repair

Check for engine damage.

Electronics are OK?

Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 2350 rpm, followed by moderate deceleration to 2350 rpm.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the engine crankshaft speed/position sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1D

Fault Codes 689 and 1376.

Guided Step 1D - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged section of the harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-218 in Section 19.

No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not running above 2000 rpm.

–

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1F

Go to 2A

Guided Step 1F - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test to check if the overspeed condition is still present.

–

Fault Code 234 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 234 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 235. | Active or inactive counts of Fault Code 235?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 235.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 235?
YES NO

Reference the Coolant Loss troubleshooting symptom tree in the Service Manual QSK19 CM850 and QSK19 CM2150 Modular Common Rail System Series Engines, Bulletin 4021592.

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

Go to the appropriate troubleshooting steps.

Repair complete.

Last Modified: 17-Oct-2011


FAULT CODE 237 - External Speed Command Input (Multiple-Unit Synchronization) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Determine which engine is shutting down. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 426 and 497 active?
 | STEP 1B. Determine which engine is shutting down. | Secondary engine(s) shutting down? Primary engine shutting down?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the output driver supply voltage. | Voltage between 11.75-VDC and 12.25-VDC?
 | STEP 2C. Check the 5 volt supply. | Voltage between 4.75-VDC and 5.25-VDC?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness 60-pin OEM port connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 237 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Determine which engine is shutting down.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 426 and 497 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting steps.

Go to 1B

Guided Step 1B - Determine which engine is shutting down.

Conditions

  • Turn keyswitch ON.

Action

Determine which engine is shutting down.

  • Is the secondary engine shutting down or is the primary engine shutting down?
  • Use INSITE™ electronic service tool to monitor the secondary or primary engine.

Secondary engine(s) shutting down? Primary engine shutting down?
YES NO
No Repair

Primary engine is shutting down.

Determine cause for primary engine shutdown.

Go to 2A

Reference the appropriate troubleshooting tree.

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM 60-pin OEM port connector from the ECM connector on the secondary engine.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the output driver supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness 60-pin OEM port connector from the ECM on the secondary engine.

Action

Check the output driver supply voltage.

  • Measure the voltage from the external speed command input SIGNAL pin of the engine harness ECM 60-pin OEM port connector to engine block ground.

Voltage between 11.75-VDC and 12.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the 5 volt supply.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness ECM 60-pin OEM port connector from the ECM connector on the secondary engine.

Action

Check the 5 volt supply.

  • Measure the voltage from the external speed input RETURN pin of the engine harness ECM 60-pin OEM port connector to engine block ground.

Voltage between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM 60-pin OEM port connector from the ECM connector on the secondary engine.
  • Disconnect the engine harness ECM 31-pin connector from the OEM harness connector on the secondary engine.

Action

Check for an open circuit.

  • Measure the resistance from the external speed command input SIGNAL pin of the engine harness ECM 60-pin OEM port connector to the external speed command input SIGNAL pin of the 31-pin OEM connector B.
  • Measure the resistance from the frequency input RETURN (VSS)/auxiliary governor pin of the engine harness 60-pin OEM port connector to the external speed command input RETURN pin of the 31-pin OEM connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM 60-pin OEM connector from the ECM connector on the secondary engine.
  • Disconnect the engine harness ECM 31-pin connector from the OEM harness connector on the secondary engine.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the external speed command input SIGNAL pin of the engine harness ECM 60-pin OEM connector to all other pins in the connector.
  • Measure the resistance from the external speed command input RETURN pin of the engine harness ECM 60-pin OEM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 2F

Go to 5A

Guided Step 2F - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM 60-pin OEM connector from the ECM connector on the secondary engine.
  • Disconnect the engine harness ECM 60-pin OEM connector from the OEM harness connector on the secondary engine.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the external speed command input SIGNAL pin of the engine harness ECM 60-pin OEM connector to engine block ground.
  • Measure the resistance from the external speed command input RETURN pin of the engine harness ECM 60-pin OEM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness connector on the secondary engine.
  • Disconnect the engine harness connector from the OEM harness connector on the primary engine.

Action

Inspect the OEM harness connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23-pin OEM connector A from the engine harness on the primary engine.
  • Disconnect the 31-pin OEM connector B from the engine harness on the secondary engine.

Action

Check for an open circuit.

  • Measure the resistance from the auxiliary PWM driver SIGNAL pin on the 23-pin OEM connector A of the primary engine to the external speed command input SIGNAL pin on the 31-pin OEM connector B of the secondary engine.
  • Measure the resistance from the OEM-provided 5 volt SUPPLY to the external speed command input RETURN pin on the 31-pin OEM connector B of the secondary engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23-pin OEM connector A from the engine harness on the primary engine.
  • Disconnect the 31-pin OEM connector B from the engine harness on the secondary engine.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the auxiliary PWM driver SIGNAL pin on the 23-pin OEM connector A of the primary engine to all other pins in the connector.
  • Measure the resistance from the OEM-provided 5 volt SUPPLY to all other pins in the 23-pin OEM connector A of the primary engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the OEM harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the OEM service manual.

Replace the damaged section of the harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23-pin OEM connector A from the engine harness on the primary engine.
  • Disconnect the 31-pin OEM connector B from the engine harness on the secondary engine.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the OEM actuator pulse width modulation output pin on the 23-pin OEM connector A of the primary engine to engine block ground.
  • Measure the resistance from the OEM-provided 5 volt SUPPLY to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness 60-pin OEM port connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness connector on the primary engine.
  • Disconnect the engine harness ECM 60-pin OEM port connector from the ECM connector on the primary engine.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Clean the connector and pins.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-204 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23-pin OEM connector A from the engine harness on the primary engine.
  • Disconnect the engine harness ECM 60-pin OEM port connector from the ECM on the primary engine.

Action

Check for an open circuit.

  • Measure the resistance from the auxiliary PWM driver 1 SIGNAL pin on the 23-pin OEM connector A to the auxiliary PWM driver 1 SIGNAL pin on the ECM 60-pin OEM port connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23-pin OEM connector A from the engine harness connector on the primary engine.
  • Disconnect the engine harness ECM 60-pin OEM port connector from the ECM connector on the primary engine.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the auxiliary PWM driver 1 SIGNAL pin on the engine harness ECM 60-pin OEM port connector all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 23-pin OEM connector A from the engine harness connector on the primary engine.
  • Disconnect the engine harness ECM 60-pin OEM port connector from the ECM connector on the primary engine.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the auxiliary PWM driver 1 SIGNAL pin on the ECM 60-pin OEM port connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 237 is inactive.

Fault Code 237 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 10-Mar-2015


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 3 and return. |
 | STEP 2A. Inspect the engine crankshaft speed/position sensor and circuit connected to the sensor supply 3 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 238 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 3 and return.

Guided Step 2A - Inspect the engine crankshaft speed/position sensor and circuit connected to the sensor supply 3 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-218 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the engine crankshaft speed/position sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Troubleshoot each section of the harnesses connected in series to determine which contains the short circuit to ground or pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control circuit. |
 | STEP 2A. Inspect the fan control connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control. | Within the OEM resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control. |
 | STEP 2C. Check the fan control diagnostic supply voltage and supply wire. | Greater than 5-VDC?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 245 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 245 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control circuit.

Guided Step 2A - Inspect the fan control connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the OEM harness connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged sensor.

Check all harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the OEM harness connector or engine harness connector.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the fan control switch SIGNAL and RETURN pin of the fan control connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to the OEM service manual for resistance specifications.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Replace the fan control. Refer to the OEM service manual.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the OEM harness connector or engine harness connector.

Action

Short circuit on one connector pin-to-ground check:

Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fan control. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control diagnostic supply voltage and supply wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the OEM harness connector or engine harness connector.
  • Turn keyswitch ON.

Action

Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM, engine harness, and OEM harness.

Guided Step 3A - Inspect all OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the all harness connections.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Replace the damaged section of the harness.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the fan control circuit. Refer to Procedure 019-045 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fan control connector from the OEM harness connector or engine harness connector.

Action

Short circuit on one connector pin-to-ground check:

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the ECM 60-pin OEM port connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fan control connector from the OEM harness connector or engine harness connector.

Action

Short circuit on one connector pin-to-pin check:

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the ECM 60-pin OEM port connector pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 inactive?
YES NO

None: The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Disconnect the fan control connector from the engine harness connector or OEM harness connector.
  • Turn the keyswitch OFF.
  • Connect the fan control connector to the engine harness connector or OEM harness connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault Code 245 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-May-2012


FAULT CODE 248 - Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor 1 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor 1 accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the exhaust gas temperature sensor 1 reading in INSITE™ electronic service tool
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 248 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor 1 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor 1 accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the exhaust gas temperature sensor 1.

NOTE: The probe must extend into the exhaust flow and must not touch the exhaust manifold, except at the probe threads.

  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Compare the exhaust gas temperature sensor 1 reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer yes to this step.

Does the thermocouple agree with the exhaust gas temperature sensor 1 reading in INSITE™ electronic service tool?
YES NO
No Repair

A damaged exhaust gas temperature sensor 1 has been detected.

Replace the exhaust gas temperature sensor 1. Refer to Procedure 019-013 in Section 19.

Reference the Exhaust Gas Temperature Above Normal troubleshooting tree in the OEM service manual

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Turn the keyswitch OFF for 30 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 248 is inactive.

Fault Code 248 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 26-May-2010


FAULT CODE 261 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - Metri-Pack™ 2-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine fuel temperature sensor 1 accuracy. |
 | STEP 1A. Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe. | Engine fuel temperature sensor 1 reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 261 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine fuel temperature sensor 1 accuracy.

Guided Step 1A - Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the bottom-side of the control valve body, nearest the fuel temperature sensor.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Compare the fuel temperature reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer Yes to this step.

Engine fuel temperature sensor 1 reading is correct?
YES NO
No Repair

Replace the engine fuel temperature sensor 1. Refer to Procedure 019-119 in Section 19.

Reference the Fuel Temperature Above Normal troubleshooting tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and run it to normal operating temperature.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 261 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 26-May-2010


FAULT CODE 263 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - Metri-Pack™ 2-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine fuel temperature sensor 1 and circuit. |
 | STEP 1A. Inspect the harness and engine fuel temperature sensor 1 connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the sensor resistance. | Resistance between 600 ohms and 36k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit from the signal and return pins to all other pins. | Greater than 100k ohms?
STEP 3. | Check for ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 263 inactive and Fault Code 265 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 263 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine fuel temperature sensor 1 and circuit.

Guided Step 1A - Inspect the harness and engine fuel temperature sensor 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine fuel temperature sensor 1 connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine fuel temperature sensor 1 connector.

Action

Check the resistance of the engine fuel temperature sensor 1.

  • Measure the resistance between the SIGNAL and RETURN pin on the sensor side of the engine fuel temperature sensor 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 ohms and 36k ohms?
YES NO
No Repair

Replace the engine fuel temperature sensor 1. Refer to Procedure 019-119 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the engine fuel temperature sensor 1 connector.

Action

Check for an open in the signal and return wires.

  • Measure the resistance from the SIGNAL pin of the engine harness connector to the RETURN pin on the harness-side of the engine fuel temperature sensor 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal or return circuit has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the engine fuel temperature sensor. Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from the signal and return pins to all other pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the engine fuel temperature sensor 1 connector.
  • Disconnect the OEM harness connector from the coolant level sensor connector.
  • Disconnect the OEM harness connector from the remote accelerator pedal or lever position sensor.
  • Disconnect the OEM harness connector from the OEM temperature sensor.

Action

Check for a short circuit from the signal and return pins in the engine harness connector to all other pins in the connector.

  • Measure the resistance from the RETURN pin in the engine harness connector to all other pins in the ECM 60-pin OEM port connector.
  • Measure the resistance from the SUPPLY pin in the engine harness connector to all other pins in the ECM 60-pin OEM port connector.

Refer to the circuit diagram and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short signal or return circuit has been detected in the engine harness.

Troubleshoot each section of harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the engine fuel temperature sensor. Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector

Action

Check for appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 inactive and Fault Code 265 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 263 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 10-Mar-2015


FAULT CODE 265 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - Metri-Pack™ two-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 141, 145, 154, 196, 1361, 1596, or 1846 inactive?
STEP 2. | Check the engine fuel temperature sensor 1. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the engine fuel temperature sensor 1. | Resistance between 600 ohms and 36k ohms?
 | STEP 2C. Check for a short circuit to ground in the engine fuel temperature sensor 1. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to engine block ground in the signal and supply wires. | Greater than 100k ohms?
STEP 4. | Check for the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 265 inactive and Fault Code 263 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 265 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 141, 145, 154, 196, 1361, 1596, or 1846 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Go to the appropriate troubleshooting steps.

Guided Step 2 - Check the engine fuel temperature sensor 1.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine fuel temperature sensor 1 connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the engine fuel temperature sensor 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine fuel temperature sensor 1 connector.

Action

Check the resistance of the engine fuel temperature sensor 1.

  • Measure the resistance between the two pins on the sensor side of the engine fuel temperature sensor 1 connector.

Refer to the circuit diagram or wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 ohms and 36K ohms?
YES NO
No Repair

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the engine fuel temperature sensor 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine fuel temperature sensor 1 connector.

Action

Check for a short circuit to ground in sensor.

  • Measure the resistance from one of the pins of the engine fuel temperature sensor 1 connector, sensor side, to the engine block.

Refer to the circuit diagram or wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the engine harness connector from the engine fuel temperature sensor 1 connector
  • Disconnect the engine harness connector from the intake manifold 1 air temperature sensor connector
  • Disconnect the engine harness connector from the engine oil rifle pressure 1 sensor connector
  • Disconnect the engine harness connector from the water in fuel indicator sensor connector
  • Disconnect the engine harness connector from the coolant level sensor 1 connector
  • Disconnect the engine harness connector from the remote accelerator pedal or lever position sensor connector
  • Disconnect the engine harness connector from the engine coolant temperature 1 sensor
  • Disconnect the OEM harness connector from the OEM temperature sensor.

Action

Check for a short circuit from the signal and return pins to all other pins in the connector.

  • Measure the resistance from the SIGNAL pin of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from the RETURN pin of the engine harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the engine fuel temperature sensor. Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to engine block ground in the supply and signal wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine fuel temperature sensor 1 connector.
  • Disconnect the ECM 60-pin OEM port connector.

Action

Check for a short circuit to engine block ground in the supply and signal wires.

  • Measure the resistance from RETURN pin of the engine harness ECM connector to engine block ground.
  • Measure the resistance from SIGNAL pin of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each section of the harness to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the engine fuel temperature sensor. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for the ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the 31-pin OEM connector B.

Action

Place a jumper wire between the engine fuel temperature sensor 1 SIGNAL pin and the engine fuel temperature sensor 1 RETURN pin at the engine harness connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 265 inactive and Fault Code 263 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 265 is inactive.

Fault Code 265 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 10-Mar-2015


FAULT CODE 266 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - Metri-Pack™ 2-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine fuel temperature sensor 1 accuracy. |
 | STEP 1A. Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe. | Readings are correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 266 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine fuel temperature sensor 1 accuracy.

Guided Step 1A - Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Compare the engine fuel temperature sensor 1 reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer Yes to this step.

NOTE: Readings will possibly need to be checked while engine is operating at normal temperature conditions 82°C or 180°F.

Readings are correct?
YES NO

Make sure the fuel tanks are adequately filled.

Sensor reading is incorrect. Replace the fuel supply temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and operate it to normal operating temperature.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 266 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 26-May-2010


FAULT CODE 271 - Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - male Bosch® test lead, Part Number 3164111 - female Bosch® test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 271 active?
STEP 2. | Check the fuel pump pressurizing assembly 1 and circuit. |
 | STEP 2A. Inspect the fuel pump pressurizing assembly 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 271 inactive and Fault Code 272 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 271 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 271 inactive and Fault Code 272 active?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 271 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 271 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump pressurizing assembly 1 and circuit.

Guided Step 2A - Inspect the fuel pump pressurizing assembly 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Inspect the engine harness and fuel pump pressurizing assembly 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the engine harness or fuel pump pressurizing assembly 1.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 272 active and Fault Code 271 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump pressurizing assembly 1 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES NO

A damaged fuel pump pressurizing assembly 1 has been detected.

Replace the fuel pump pressurizing assembly 1. Refer to Procedure 019-117 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active and Fault Code 271 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the engine harness.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short on the signal wire has been detected in the engine harness.

Troubleshoot each section of the harness to determine which contains the pin-to-ground short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 272 - Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - male Bosch® test lead, Part Number 3164111 - female Bosch® test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 272 active?
STEP 2. | Check the fuel pump pressurizing assembly 1 and circuit. |
 | STEP 2A. Inspect the fuel pump pressurizing assembly 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel pump pressurizing assembly 1. | Less than 5 ohms?
 | STEP 2C. Check the diagnostic signal voltage and return circuit. | Greater than 3.0-VDC?
 | STEP 2D. Check for an open circuit in the fuel pump pressurizing assembly 1 return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel pump pressurizing assembly 1 diagnostic signal voltage. | Greater than 3.0-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 272 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 272 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump pressurizing assembly 1 and circuit.

Guided Step 2A - Inspect the fuel pump pressurizing assembly 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Inspect the engine harness and fuel pump pressurizing assembly 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or the fuel pump pressurizing assembly 1.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel pump pressurizing assembly 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Control valve continuity pin-to-pin continuity check:

  • Measure the resistance and check for an open circuit between the fuel pump pressurizing assembly 1 SIGNAL pin and the fuel pump pressurizing assembly 1 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the fuel pump pressurizing assembly 1. Refer to Procedure 019-117 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the diagnostic signal voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the signal voltage and return circuit.

  • Measure the voltage between the fuel pump pressurizing assembly 1 SIGNAL pin and the fuel pump pressurizing assembly 1 RETURN pin at the engine harness control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 3.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the fuel pump pressurizing assembly 1 return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness fuel pump pressurizing assembly 1 RETURN pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open pin-to-ground circuit has been detected in the engine harness.

Troubleshoot each section of the harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel pump pressurizing assembly 1 diagnostic signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the voltage from the fuel pump pressurizing assembly 1 SIGNAL pin to the fuel pump pressurizing assembly 1 RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 3.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin at the ECM connector of the engine harness and the fuel pump pressurizing assembly 1 SIGNAL pin at the fuel pump pressurizing assembly 1 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Short circuit on one connector pin-to-pin check:

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the SAE J1939 data link harness. | Resistance between 50 ohms and 70 ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM SAE J1939 data link harness. | Resistance between 50 ohms and 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM SAE J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 285 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service SAE J1939 data link harness.

Guided Step 4A - Inspect the service SAE J1939 data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link adapter from the 9-pin service data link connector.

Action

Inspect the service SAE J1939 data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service SAE J1939 data link cable.

Clean the connector and pins.

Repair or replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-205 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter connector from the 9-pin service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the service data link connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the SAE J1939 data link.

Troubleshoot harnesses connected in series to determine which contains the open or short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-205 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the SAE J1939 data link connector or harness.

Clean the connector and pins.

Repair or replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM SAE J1939 datalink harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the appropriate Cummins® ECM connection to the SAE J1939 data link harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the Cummins® ECM connection to all other pins in the OEM connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link SUPPLY and the SAE J1939 data link RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check for appropriate circuit response.

Fault Code 285 inactive?
YES NO

NOTE: The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the SAE J1939 data link, a damaged ECM, or calibration is causing the fault code.

Go to 6A

Reference the ECM No Communication (tt-ECM) symptom tree

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 11-Jun-2010


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 286 active?
STEP 3. | Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the SAE J1939 data link harness. | Resistance between 50 ohms and 70 ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM SAE J1939 data link harness. | Resistance between 50 ohms and 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM SAE J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 286 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 286 inactive?
 | STEP 6B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service SAE J1939 data link harness.

Guided Step 4A - Inspect the service SAE J1939 data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link connector adapter from the 9-pin service data link connector.

Action

Inspect the service SAE 1939 data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service SAE J1939 data link cable or connector.

Clean the connector and pins.

Repair or replace the damaged section of the service SAE J1939 data link harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the data link circuit. Refer to Procedure 019-165 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-205 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 data link connector adapter from the 9-pin service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the service data link connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service SAE J1939 data link connector or harness connection to the SAE J1939 data link.

Troubleshoot all harness connected in series to determine which contains the open or short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the data link circuit. Refer to Procedure 019-165 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-205 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the SAE J1939 data link connector or harness.

Clean the connector and pins.

Repair or replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the data link circuit. Refer to Procedure 019-165 in Section 19.

Repair the connectors. Refer to Procedure 019-204 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the appropriate Cummins® ECM engine connection to the SAE J1939 data link harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the data link circuit. Refer to Procedure 019-165 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the data link connector adapter from the 9-pin service data link connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link SUPPLY wire and the SAE J1939 data link RETURN wire on the Cummins® ECM connection to all other pins in the connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link SUPPLY and the SAE J1939 data link RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the data link circuit. Refer to Procedure 019-165 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 inactive?
YES NO

NOTE: The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, a damaged ECM, or calibration is causing the fault code.

Go to 6A

Reference to the appropriate ECM No Communication (tt-ECM) symptom tree.

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 286 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 11-Jun-2010


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322, 324, or 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 1 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 322 the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple (same bank) injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 324, or 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

Fault Code 322 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 1 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and the injector solenoid driver cylinder 1 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 1 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 1 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 1 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and the injector solenoid driver cylinder 1 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the harness or replace the injector solenoid driver cylinder 1 connector.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

Replace the injector. Use the following procedure in the QSK19 and QSK19 Modular Common Rail System Series Engines Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 is the only active fault code?

YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver cylinder 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 1 connectors corresponding to the cylinders that are on the front bank.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the harness or replace the injector solenoid driver cylinder 1 connector.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector(s). Use the following procedure in the QSK19 and QSK19 Modular Common Rail System Series Engines Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector connectors from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 1 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL and injector solenoid driver cylinder 3 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 3 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damage section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin to pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL and injector solenoid driver cylinder 3 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 3 RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin to pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™Metri-Pack test lead and Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323, 325, or 332 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector solenoid cylinder 5 driver circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 323 the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuits to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple (same bank) injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323, 325, or 332 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

–

Fault Code 323 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and the injector solenoid driver cylinder 5 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 5 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and the injector solenoid driver cylinder 5 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 5 connector.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

Replace the injector. Use the following procedure in the QSK19 and QSK19 Modular Common Rail System Series Engines Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes..

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 the only active fault code?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector solenoid driver cylinder 5 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector connectors corresponding to the cylinders that are on the rear bank.

Action

Inspect the engine harness connector and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 5 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector(s). Use the following procedure in the QSK19 and QSK19 Modular Common Rail System Series Engines Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector connectors from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins, or damaged wire insulation?
YES NO

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 5 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 5 SIGNAL and injector solenoid driver cylinder 6 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 5 RETURN and injector solenoid driver cylinder 6 RETURN pins.

Note: Repeat the steps as outlined above for each injector in the front bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 5 SIGNAL and injector solenoid driver cylinder 6 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 5 RETURN and injector solenoid driver cylinder 6 RETURN pins.

None. Repeat the steps as outlined above for each injector in the front bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle engine for one minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322, 324, or 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 3 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 324 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple (same bank) injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 324, or 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

–

Fault Code 324 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

–

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and the injector solenoid driver cylinder 3 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector.

Action

Inspect the engine harness connector and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 3 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and the injector solenoid driver cylinder 3 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 3 connector.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

Replace the injector. Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 is the only active fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector connectors corresponding to the cylinders that are on the front bank.

Action

Inspect the engine harness connector and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 3 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector(s).Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector connectors from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins, or damaged wire insulation?
YES NO

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 3 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL and injector solenoid driver cylinder 3 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 3 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL and injector solenoid driver cylinder 3 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 3 RETURN pins.

Note: Repeat the steps as outlined above for each injector in the rear bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 1B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323, 325, or 332 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 6 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 325 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple (same bank) injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323, 325, or 332 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

–

Fault Code 325 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

–

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and the injector solenoid driver cylinder 6 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector.

Action

Inspect the engine harness connector and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 6 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and the injector solenoid driver cylinder 6 RETURN pin at the injector connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the harness or replace the injector solenoid driver cylinder 6 connector.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-214 in Section 19.

No Repair

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 is the only active fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector and injector solenoid driver cylinder 6 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector connectors corresponding to the cylinders that are on the rear bank.

Action

Inspect the engine harness connector and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 6 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector(s). Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector connectors from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins, or damaged wire insulation?
YES NO

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 6 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 5 SIGNAL and injector solenoid driver cylinder 6 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 5 RETURN and injector solenoid driver cylinder 6 RETURN pins.

Note: Repeat the steps as outlined above for each injector in the rear bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness.

Refer to Procedure 019-043 in Section 19. Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 5 SIGNAL and injector solenoid driver cylinder 6 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 5 RETURN and injector solenoid driver cylinder 6 RETURN pins.

Note: Repeat the steps as outlined above for each injector in the rear bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle engine for one minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-May-2012


FAULT CODE 327 - Fuel Consumption Rate - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes other than Fault Code 327 found?
STEP 2. | Check the injectors. |
 | STEP 2A. Perform a single cylinder cutout test. | Miss or excessive smoke attributed to a single cylinder?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 327 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes other than Fault Code 327 found?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the injectors.

Guided Step 2A - Perform a single cylinder cutout test.

Conditions

  • Turn keyswitch ON.
  • Operate engine at low idle.
  • Connect INSITE™ electronic service tool.

Action

Perform the single cylinder cutout test.

  • Operate the engine at load.
  • Use INSITE™ electronic service tool to perform the single cylinder cutout test to disable individual injectors.
  • Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

Miss or excessive smoke attributed to a single cylinder?
YES NO

Inspect for power cylinder damage or camshaft lobe wear.

If no damage is found, replace the fuel injector in the cylinder that was identified by the single cylinder cutout test.

  • Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

Replace all injectors. Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

Go to 6A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Calibrate all ECMs. Refer to Procedure 019-032 in Section 19.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 327 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 10-Mar-2011


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322, 324, or 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 2 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 331 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for a short circuit to ground. |
 | STEP 3C-2. Check the engine harness for a pin-to-pin short circuit. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple (same bank) injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 324, or 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

Fault Code 331 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 2 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Repair the connectors. Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and the injector solenoid driver cylinder 2 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 2 circuit connector.

Action

Inspect the engine harness connector and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 2 connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 2 circuit connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and the injector solenoid driver cylinder 2 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the harness or injector solenoid driver cylinder 2 connector.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-214 in Section 19.

No Repair

4A

Go to 2E

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 is the only active fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector and injector solenoid driver cylinder 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector connectors corresponding to the cylinders that are on the front bank.

Action

Inspect the engine harness connector and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 2 connectors.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector(s). Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector connectors from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins, or damaged wire insulation?
YES NO

Repair or replace the damaged section of the harness or damaged injector solenoid driver cylinder 2 connectors.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-214 in Section 19.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 2 SIGNAL and injector solenoid driver cylinder 3 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 3 RETURN pins.

NOTE: Repeat the steps as outlined above for each injector in the rear bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for a pin-to-pin short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector solenoid driver cylinder 1 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 2 driver and injector solenoid driver cylinder 3 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 1 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 2 RETURN and injector solenoid driver cylinder 3 RETURN pins.

Note: Repeat the steps as outlined above for each injector in the rear bank.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19. Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle engine for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 1B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323, 325, or 332 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 only active?
 | STEP 1C. Read the fault codes with INSITE™ electronic service tool. | Multiple injector (same bank) fault codes active?
STEP 2. | Check the injector and injector solenoid driver cylinder 4 circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2A-1. Inspect the engine harness and ECM connector pins. |
 | STEP 2B. Check for an open circuit. | Is resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the injector harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Is resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 332 is the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3C-1. Check the engine harness for short circuit to ground. |
 | STEP 3C-2. Check the engine harness for pin-to-pin short circuits. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Same multiple (same bank) injector fault codes active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323, 325, or 332 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 332 only active?

YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the active fault codes.

Multiple injector (same bank) fault codes active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector solenoid driver cylinder 4 circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine harness connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and the injector solenoid driver cylinder 4 RETURN pin at the ECM connector of the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is resistance between 0.5 and 5 ohms?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2C

Guided Step 2C - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 4 connector.

Action

Inspect the engine harness connector and injector connector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Clean the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-204 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the injector solenoid driver cylinder 4 connector.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and the injector solenoid driver cylinder 4 RETURN pin at the injector connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is resistance between 0.5 and 5 ohms?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-214 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector(s).

Use the following procedure in Service Manual, QSK19, QSK19CM850 MCRS, QSK19 CM2150, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

4A

Go to 4A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 is the only active fault code?

YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector and injector solenoid driver cylinder 4 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector connectors corresponding to the cylinders that are on the rear bank.

Action

Inspect the engine harness connector and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-214 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector solenoid driver cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector solenoid driver cylinder 6 SIGNAL pin and engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector(s).

Use the following procedure in Service Manual, QSK19, QSK19CM850 MCRS, QSK19 CM2150, Bulletin 4021592. Refer to Procedure 006-026 in Section 6.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector connectors from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19. Refer to Procedure 019-214 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the engine harness for short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector solenoid driver cylinder 5 SIGNAL and injector solenoid driver cylinder 6 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector solenoid driver cylinder 5 RETURN and injector solenoid driver cylinder 6 RETURN pins.

Note: Repeat the steps as outlined above for each injector in the front bank.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the injector connectors from the engine harness connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the injector solenoid driver cylinder 4 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector solenoid driver cylinder 5 SIGNAL and injector solenoid driver cylinder 6 SIGNAL pins.
  • Measure the resistance from the injector solenoid driver cylinder 4 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector solenoid driver cylinder 5 RETURN and injector solenoid driver cylinder 6 RETURN pins.

Note: Repeat the steps as outlined above for each injector in the front bank.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle engine for one minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 1B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 349 - Transmission Output Shaft Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check external speed command input signal sending unit. |
 | STEP 1A. Verify external speed command input signal sending unit accuracy. | External speed command input signal sending unit output is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 349 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check external speed command input signal sending unit.

Guided Step 1A - Verify external speed command input signal sending unit accuracy.

Conditions

  • Turn keyswitch ON.

Action

Verify external speed command input signal sending unit accuracy.

  • Refer to the OEM troubleshooting and repair manual for testing procedures.

External speed command input signal sending unit output is correct?
YES NO
No Repair

Repair or replace the OEM external speed command input signal sending unit. Refer to the OEM service manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.

NOTE: If the fault occurred at a particular rpm, operate the engine at that rpm to verify the problem is corrected.

Fault Code 349 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts.

Last Modified: 10-Mar-2011


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 322, 323, 324, 325, 331, and 332 active during engine operation?
STEP 2. | Check the battery 1 voltage. |
 | STEP 2A. Inspect the battery 1 voltage connectors and fuses. | Damage observed?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the battery 1 voltage circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate the engine and determine if fault code condition exists. | Fault Code 351 reoccurs during engine operation, while injector Fault Codes 322, 323, 324, 325, 331, and 332 do not occur?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 351 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect the INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 322, 323, 324, 325, 331, and 332 active during engine operation?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the battery 1 voltage.

Guided Step 2A - Inspect the ECM 4-pin power connector and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector from the ECM.

Action

Inspect the ECM 4-pin power connector and fusess for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damage observed?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the battery 1 voltage pins at the ECM 4-pin power connector SUPPLY harness and the battery positive (+) pins at the battery positive (+) connection.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders, or clean the battery terminal connections.

  • Refer to Procedure 019-206 in Section 19.
  • Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the battery 1 voltage circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector harness from the ECM.
  • Disconnect the battery 1 voltage harness from the battery terminals.

Action

Check for an open circuit in the ECM power supply circuit.

  • Measure the resistance between the battery negative (-) pins at the ECM 4-pin power connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders, or clean the battery terminal connections.

  • Refer to Procedure 019-206 in Section 19.
  • Refer to Procedure 019-198 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: INSITE™ electronic service tool can also be used to monitor ECM power supply and injector power supply voltages.

Fault Code 351 reoccurs during engine operation, while injector Fault Codes 322, 323, 324, 325, 331, and 332 do not occur?

YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

A marginal battery voltage condition is possible. Make sure that the batteries are fully charged.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 351 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to sensor 1 supply and return. |
 | STEP 2A. Inspect the engine oil rifle pressure 1 sensor and circuit connected to the sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the auxiliary pressure sensor and circuit connected to the sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the remote accelerator pedal or lever position sensor and circuit connected to the sensor supply 1 and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
 | STEP 3C. Inspect the vehicle for optional OEM devices. | OEM devices installed?
 | STEP 3D. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the OEM and engine harness for short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check the OEM and engine harness for short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 3G. Check for a short circuit in the OEM harness ECM battery negative (-) circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 352 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 1 and return.

Guided Step 2A - Inspect the engine oil rifle pressure 1 sensor and circuit connected to the sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Replace the engine oil rifle pressure 1 sensor.

  • Refer to Procedure 019-066 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure 1 sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine oil rifle pressure 1 sensor. Refer to Procedure 019-066 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the auxiliary pressure sensor and circuit connected to the sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Inspect the OEM, engine harness, and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Replace the damaged section of the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Refer to the OEM service manual for sensor repair instructions.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the OEM pressure sensor. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the remote accelerator pedal or lever position sensor and circuit connected to the sensor supply 1 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Disconnect the engine harness connector from the 23-pin OEM connector.

Action

Inspect the OEM, engine harness, and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Replace the damaged section of the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Refer to the OEM service manual for remote accelerator pedal or lever position sensor repair instructions.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the remote accelerator pedal or lever position sensor. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port and 60-pin connectors.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

There is a short circuit in the engine harness pulling the sensor supply voltage down.

Troubleshoot each section of harness to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the vehicle for optional devices.

Conditions

  • Turn keyswitch OFF.

Action

OEM devices, remote accelerator pedal or lever position sensor, and OEM pressure sensor share a 5-VDC SUPPLY with sensors on the engine harness.

  • Check the vehicle for a remote accelerator pedal or lever position sensor, or an OEM pressure sensor.

OEM devices installed?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Inspect all OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the OEM and engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Replace the damaged section of the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the OEM harness or engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 60-pin OEM port connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector.

Action

Check the harnesses connected in series for a short to ground.

  • Measure the resistance between the OEM 5-VDC SUPPLY pin at the OEM harness connector and engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the OEM harness or engine harness.

Troubleshoot the harness connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness or damaged sensor.

  • Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Replace the damaged section of the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the OEM harness and engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 60-pin OEM port connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector.

Action

Check the harnesses connected in series for a pin-to-pin short circuit.

  • Measure the resistance between the OEM 5-VDC SUPPLY pin at the OEM 60-pin OEM port harness connector to all other pins in the connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot the harness connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness or damaged sensor.

  • Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Replace the damaged section of the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for a short circuit in the OEM harness ECM battery negative (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness battery supply ECM 4-pin power connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Disconnect the auxiliary pressure sensor connector from the OEM harness connector.

Action

Check for a short circuit

  • Measure the resistance between the OEM 5-VDC SUPPLY pin at the engine harness ECM connector and the ECM battery negative (-) pins in the ECM power connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Troubleshoot the harness connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness or damaged sensor.

  • Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Replace the damaged section of the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify that fault code is inactive.

Fault Code 352 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check the OEM 5-VDC supply. |
 | STEP 3A. Inspect the vehicle for optional OEM devices. | OEM pressure sensor or remote accelerator pedal or lever position sensor installed?
 | STEP 3B. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the OEM harness or engine harness for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit in the OEM harness ECM battery positive (+) circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 386 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply 1.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM connector and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port and 60-pin connectors.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO
No Repair

There is a short in the engine harness causing the sensor 5 volt supply wire to have to high a voltage.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of the wiring harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM 5 volt supply.

Guided Step 3A - Inspect the vehicle for optional OEM devices.

Conditions

  • Turn keyswitch OFF.

Action

OEM devices, OEM pressure sensor, and remote accelerator pedal or lever position sensor share a 5 volt SUPPLY with sensors on the engine harness.

  • Check the vehicle for an OEM pressure sensor or remote accelerator pedal or lever position sensor.

OEM pressure sensor or remote accelerator pedal or lever position sensor installed?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Repair complete.

Guided Step 3B - Inspect all OEM, ECM, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the OEM, ECM, and engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of harness or damaged connector. Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the OEM harness or engine harness for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector (if equipped).
  • Disconnect the OEM pressure sensor connector from the OEM harness connector (if equipped).

Action

Check the OEM or engine harness for a pin-to-pin short circuit.

  • Measure the resistance between the OEM 5 volt SUPPLY pin at the engine harness ECM 60-pin OEM port connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit in the OEM harness ECM battery positive (+) circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the engine harness battery supply ECM 4-pin power connector
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector
  • Disconnect the OEM pressure sensor connector from the OEM harness connector.

Action

Check for a short circuit to ECM battery positive (+) in the OEM harness or engine harness.

  • Measure the resistance between the OEM 5 volt SUPPLY pin at the engine harness ECM connector to the ECM battery positive (+) pins at the ECM 4-pin power connector on the engine harness battery supply.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault code 415. | Active or inactive counts of Fault Code 415?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 415.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Reference the Lubricating Oil Pressure Low troubleshooting tree in Service Manual, QSK19, QSK19 CM850 MCRS, QSK19 CM2150 MCRS, Bulletin 4021592.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 27-May-2010


FAULT CODE 418 – Water In Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for Fault Code 418. | Active or inactive counts of Fault Code 418?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for Fault Code 418.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 418?
YES NO

Drain the water from the fuel filter.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all the steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 17-Nov-2015


FAULT CODE 426 - SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement: Part Number 3163151 - ECM Bench Top Calibration Harness and Part Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SAE J1939 data link communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | Does INSITE™ electronic service tool communicate with the ECM?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 426 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the SAE J1939 data link communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection. Use INSITE™ electronic service tool to communicate with the ECM.

Does INSITE™ electronic service tool communicate with the ECM?

YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Reference the OEM service manual for information on troubleshooting the vehicle SAE J1939 data link network.

 No Repair

Reference the OEM service manual for information on troubleshooting and vehicle SAE J1939 data link network

Go to 1B

Guided Step 1B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 60-pin OEM port connector.

Action

Inspect the OEM harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connectors and pins.

Replace the damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect the INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Reference the OEM service manual for information on troubleshooting the vehicle SAE J1939 data link network.

 No Repair

Refer to the OEM service manual

Reference the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Verify Fault Code 426 is inactive.

Fault Code 426 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 431 (Integrated Sensor Swtich) - Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ISS. |
 | STEP 1A. Verify the ISS is connected to the OEM harness. | ISS connected to the OEM harness?
 | STEP 1B. Inspect the ISS and connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the ISS for an open circuit. | Less than 125 ohms?
 | STEP 1D. Check the ISS for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 2. | Check the OEM harness and engine harness. |
 | STEP 2A. Check the OEM harness and engine harness for an open circuit. | Greater than 4.0-VDC?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness or engine harness for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness and engine harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness or the engine harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the engine battery 1 voltage circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ISS.

Guided Step 1A - Verify the ISS is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the ISS is connected to the harness.

Verify the ISS is connected to the OEM harness.

ISS is connected to the OEM harness?
YES NO
No Repair

Connect the ISS to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the ISS connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS connector from the OEM harness connector.

Action

Inspect the OEM harness connector and ISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ISS or OEM harness connector.

Clean the connector and pins.

Repair or replace the damaged section of the harness or the damaged ISS.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the ISS. Refer to Procedure 019-086 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the ISS for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the accelerator pedal or lever idle validation switch on SIGNAL pin and switch RETURN pin of the ISS connector with the pedal released.
  • Measure the resistance between the accelerator pedal or lever idle validation switch on SIGNAL pin and idle validation switch RETURN pin of the ISS connector with the pedal depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 125 ohms?
YES NO
No Repair

Replace the ISS.

Refer to the OEM service manual.

Go to 1D

Go to 3A

Guided Step 1D - Check the ISS for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS connector from the OEM harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator pedal or lever idle validation switch on SIGNAL pin and accelerator pedal or lever idle validation switch off SIGNAL pin of the ISS connector with the pedal released and depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the ISS.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness and engine harness.

Guided Step 2A - Check the OEM harness and engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the accelerator pedal or lever idle validation switch on SIGNAL pin in the ISS connector of the OEM harness to the idle validation switch RETURN pin in the ISS connector of the OEM harness.
  • Measure the voltage from the accelerator pedal or lever idle validation switch on SIGNAL pin in the ISS connector of the OEM harness to the idle validation switch RETURN pin in the ISS connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the engine harness connector and ECM 60-pin OEM port connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness or engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the ISS connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance of the accelerator pedal or lever idle validation switch ON wire in all harnesses connected in series between the ECM connector and the ISS connector.
  • Measure the resistance of the accelerator pedal or lever idle validation switch OFF wire in all harnesses connected in series between the ECM connector and the ISS connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness and engine harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the ISS connector from the OEM harness connector.

Action

Check for an open switch return circuit.

  • Measure the resistance of the idle validation switch RETURN wire in the harnesses connected in series between the ECM connector and the ISS connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness or the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the ISS connector from the OEM harness connector.

Action

Short circuit on one connector pin-to-pin check:

Measure the resistance and check for a short circuit between the following ECM 60-pin OEM port connector pins and all other pins in the connector:

  • Accelerator pedal or lever idle validation switch ON SIGNAL pin
  • Accelerator pedal or lever idle validation switch OFF SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the engine battery 1 voltage circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the ISS connector from the OEM harness connector.
  • Disconnect the ECM 4-pin power connector.

Action

Short circuit on two connectors pin-to-pin check.

  • Measure the resistance between the accelerator pedal or lever idle validation switch ON SIGNAL pin in the ECM 60-pin OEM port connector and the battery 1 voltage pins in the ECM 4-pin power connector.
  • Measure the resistance between the accelerator pedal or lever idle validation switch OFF SIGNAL pin in the ECM 60-pin OEM port connector and the battery 1 voltage pins in the ECM 4-pin power connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Troubleshoot each section of harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Repair complete.

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal three times.
  • Use INSITE™ electronic service tool to verify Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 431 (Nonintegrated Sensor Switch) - Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the nonintegrated sensor switch. |
 | STEP 1A. Verify the nonintegrated sensor switch is connected to the OEM harness. | Nonintegrated sensor switch connected to the OEM harness?
 | STEP 1B. Inspect the nonintegrated sensor switch and connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the nonintegrated sensor switch for an open circuit. | Less than 10 ohms?
 | STEP 1D. Check the nonintegrated sensor switch for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 2. | Check the OEM and engine harness. |
 | STEP 2A. Check the OEM and engine harness for an open circuit. | Greater than 4.0-VDC?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the engine harness battery 1 voltage circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the nonintegrated sensor switch.

Guided Step 1A - Verify the nonintegrated sensor switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the NISS is connected to the OEM harness.

Check the nonintegrated sensor switch.

Nonintegrated sensor switch is connected to the OEM harness?
YES NO
No Repair

Connect the nonintegrated sensor switch to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the nonintegrated sensor switch and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the nonintegrated sensor switch connector from the OEM harness connector.

Action

Inspect the OEM harness and NISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the nonintegrated sensor switch or OEM harness connector.

Clean the connector and pins.

Repair or replace the damaged section of the harness or the damaged ISS.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-201 in Section 19.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the nonintegrated sensor switch for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the nonintegrated sensor switch connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the accelerator pedal or lever idle validation switch ON SIGNAL pin and idle validation switch RETURN pin of the nonintegrated sensor switch connector with the pedal or lever released.
  • Measure the resistance between the accelerator pedal or lever idle validation switch OFF SIGNAL pin and idle validation switch RETURN pin of the nonintegrated sensor switch connector with the pedal or lever depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the nonintegrated sensor switch.

Refer to the OEM service manual.

Go to 1D

Repair complete.

Guided Step 1D - Check the nonintegrated sensor switch for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the nonintegrated sensor switch connector from the OEM harness connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the accelerator pedal or lever idle validation switch ON SIGNAL pin and accelerator pedal or lever idle validation switch OFF SIGNAL pin of the nonintegrated sensor switch connector with the pedal or lever released and depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the nonintegrated sensor switch.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM and engine harness.

Guided Step 2A - Check the OEM and engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the nonintegrated sensor switch connector from the OEM harness connector
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the accelerator pedal or lever idle validation switch ON SIGNAL pin in the nonintegrated sensor switch connector of the OEM harness to the idle validation switch RETURN pin in the nonintegrated sensor switch connector of the OEM harness.
  • Measure the voltage from the accelerator pedal or lever idle validation switch OFF SIGNAL pin in the nonintegrated sensor switch connector of the OEM harness to the idle validation switch RETURN pin in the nonintegrated sensor switch connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the nonintegrated sensor switch connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance of the accelerator pedal or lever idle validation switch ON SIGNAL wire in all harnesses connected in series between the ECM connector and the nonintegrated sensor switch connector.
  • Measure the resistance of the accelerator pedal or lever idle validation switch OFF SIGNAL wire in all harnesses connected in series between the ECM connector and the nonintegrated sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness switch return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the nonintegrated sensor switch connector from the OEM harness connector.

Action

Check for an open switch return circuit.

  • Measure the resistance of the OEM harness idle validation switch RETURN wire in the OEM harness between the ECM connector and the nonintegrated sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the nonintegrated sensor switch connector from the OEM harness connector.

Action

Short circuit on one connector pin-to-pin check:

Measure the resistance and check for a short circuit between the following ECM 60-pin OEM port connector pins and all other pins in the connector:

  • Accelerator pedal or lever idle validation switch ON SIGNAL pin
  • Accelerator pedal or lever idle validation switch OFF SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each section harness connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the engine harness ECM battery (+) circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the nonintegrated sensor switch connector from the OEM harness connector
  • Disconnect the ECM 4-pin power connector from the ECM.

Action

Short circuit on two connectors pin-to-pin check:

  • Measure the resistance between the accelerator pedal or lever idle validation switch ON SIGNAL pin in the ECM 60-pin OEM port connector and the battery 1 voltage pins in the ECM 4-pin power connector.
  • Measure the resistance between the accelerator pedal or lever idle validation switch OFF SIGNAL pin in the ECM 60-pin OEM port connector and the battery 1 voltage pins in the ECM 4-pin power connector.

Check to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the damaged section of the OEM harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Repair complete.

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Use INSITE™ electronic service tool to verify Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the ECM 4-pin power connector and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals.

Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least 12-VDC (12 volt systems)
  • At least 24-VDC (24 volt systems).

Cranking conditions:

  • At least 6.2-VDC (12 volt systems)
  • At least 12-VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 10-ampere fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 10-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the ECM 4-pin power connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector from the ECM.

Action

Inspect the power harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-206 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery 1 voltage pins, one at a time, in the ECM 4-pin power ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery 1 voltage RETURN pins, one at a time, in the ECM 4-pin power connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Refer to Procedure 019-206 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery 1 voltage pins in the harness ECM 4-pin power connector to the ECM battery 1 voltage RETURN pins.

Refer to the circuit diagram or wiring diagram for connector identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery 1 voltage pins in the ECM 4-pin power connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector.
  • Disconnect the ECM 60-pin OEM port connector.
  • Disconnect the battery.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from one of the ECM battery 1 voltage pins in the ECM 4-pin power connector to all pins in the ECM 60-pin OEM port connector.
  • Measure the resistance from the second ECM battery 1 voltage pin in the ECM 4-pin power connector to all pins in the ECM 60-pin OEM port connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 11-Jun-2010


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 inactive
STEP 2. | Check the equipment battery system. |
 | STEP 2A. Check the battery voltage. | Less than 20-VDC for 12-VDC system. Less than 32 VDC for 24-VDC system
 | STEP 2B. Check the alternator. | Alternator charging within OEM specifications?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 442 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the equipment battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the ECM 4-pin power connector.

Action

Check the battery voltage.

  • Measure the battery voltage from one of the ECM battery 1 voltage pins in the ECM 4-pin power connector to engine block ground.
  • Repeat above step for the second battery 1 voltage pin in the ECM 4-pin power connector.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Less than 20-VDC for 12-VDC system and less than 32-VDC for 24-VDC system?
YES NO
No Repair

Install the battery system correctly. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

NOTE: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 442 is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault code.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-May-2010


FAULT CODE 449 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Depending on the circumstance, fuel is flammable. When performing any or all of the following procedures to remove fuel supply lines and related components, keep all cigarettes, flames, pilot lights, arcing equipment, and switches out of the work area and areas sharing ventilation to reduce the possibility of severe personal injury or death when working on the fuel system.
WARNING

Fuel is flammable. Keep all cigarettes, flames, pilot lights, arcing equipment, and switches out of the work area and areas sharing ventilation to reduce the possibility of severe personal injury or death when working on the fuel system. Do not bleed the fuel system of a hot engine; this can result in fuel spilling onto a hot exhaust manifold, which can cause a fire.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 2311, 2261, 451, or 452 active or many inactive counts of fault code 271, 272, 2311, 2261, 451, or 452?
STEP 2. | Replace the mechanical dump valve. |
 | STEP 2A. Check for air in fuel. | Air present in the fuel flow line?
 | STEP 2B. Check the first stage fuel filter inlet pressure. | Fuel pressure greater than 0.35 bar [5 psi]?
STEP 3. | Check the operation of the fuel pump pressurizing assembly 1. |
 | STEP 3A. Inspect the fuel pump pressurizing assembly 1 o-ring. | O-ring cut or shaved?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 449 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 271, 272, 2311, 2261, 451, or 452 active or many inactive counts of fault code 271, 272, 2311, 2261, 451, or 452?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Clear the operation of the low pressure fuel system.

WARNING

Fuel is flammable. Keep all cigarettes, flames, pilot lights, arcing equipment, and switches out of the work area and areas sharing ventilation to reduce the possibility of severe personal injury or death when working on the fuel system. Do not bleed the fuel system of a hot engine; this can result in fuel spilling onto a hot exhaust manifold, which can cause a fire.
Guided Step 2A - Check for air in fuel.

Conditions

  • Remove air bleed line from air bleed valve on the fuel drain manifold block.
  • Route the air bleed line into a suitable container to collect fuel.
  • Turn keyswitch ON.

Action

Inspect the fuel flow for air.

Use the following procedure in Service Manual, QSK19, QSK19 CM850 Modular Common Rail System, QSK19 CM2150 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 006-003 in Section 6.

Air present in the fuel flow line?
YES NO

Repair or replace the damaged line or loose connection.

Replace the mechanical high pressure relief valve.

Use the following procedure in Service Manual, QSK19, QSK19 CM850 Modular Common Rail System, QSK19 CM2150 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the first stage fuel filter inlet pressure.

Conditions

  • Turn keyswitch OFF.
  • Install the pressure gauge into fuel filter head port at inlet.

Action

Measure inlet pressure.

  • Measure the inlet pressure to the first stage fuel filter.

If the engine will not start, perform this test while cranking the engine.

Fuel pressure greater than 0.35 bar [5 psi]?
YES NO

Refer to the equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the operation of the fuel pump pressurizing assembly 1.

Guided Step 3A - Inspect the fuel pump pressurizing assembly 1 o-ring.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump pressurizing assembly 1.

  • Remove the fuel pump pressurizing assembly 1.
  • Use the following procedure in Service Manual, QSK19, QSK19 CM850 Modular Common Rail System, QSK19 CM2150 MCRS, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • Inspect the fuel pump pressurizing assembly 1 o-ring.
  • If the o-ring is cut or shaved, fuel can be bypassing the fuel pump pressurizing assembly 1 and entering the high pressure pump.

O-ring cut or shaved?
YES NO

Replace the damaged o-ring.

  • Use the following procedure in Service Manual, QSK19, QSK19 CM850 Modular Common Rail System, QSK19 CM2150 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Apr-2015


FAULT CODE 451 - Injector Metering Rail 1 Pressure - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the injector metering rail 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the injector metering rail 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) and return circuit. | 4.75-VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) and injector metering rail 1 pressure RETURN (sensor return 2) circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 451 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the injector metering rail 1 pressure sensor and circuit.

Guided Step 2A - Inspect the injector metering rail 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector metering rail 1 pressure sensor from the engine harness.

Action

Inspect the engine harness connector and fuel rail pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Replace the damaged sensor.

  • Refer to Procedure 019-115 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) pin and the injector metering rail 1 pressure SIGNAL pin at the injector metering rail 1 pressure sensor connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) and injector metering rail 1 pressure RETURN (sensor return 2) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the injector metering rail 1 pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector metering rail 1 pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 is active?
YES NO

A damaged sensor has been detected.

Replace the injector metering rail 1 pressure sensor. Refer to Procedure 019-115 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Replace the damaged sensor.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) pin and the injector metering rail 1 pressure SIGNAL pin at the ECM engine connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

A pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Replace the damaged sensor.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the injector metering rail 1 pressure RETURN (sensor return 2) pin at the ECM engine harness connector.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open RETURN circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 451 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 is inactive?
STEP 2. | Check the injector metering rail 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the injector metering rail 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) and return circuit. | 4.75-vDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 452 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the injector metering rail 1 pressure sensor and circuit.

Guided Step 2A - Inspect the injector metering rail 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and injector metering rail 1 pressure sensor pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector metering rail 1 pressure sensor connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the injector metering rail 1 pressure sensor. Refer to Procedure 019-115 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector metering rail 1 pressure sensor from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the injector metering rail 1 pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector metering rail 1 pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector metering rail 1 pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 is active?
YES NO

A damaged sensor has been detected.

Replace the injector metering rail 1 pressure sensor. Refer to Procedure 019-115 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector metering rail 1 pressure sensor connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the injector metering rail 1 pressure 5 volt SUPPLY (sensor supply 2) pin to the injector metering rail 1 pressure RETURN (sensor return 2) pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector metering rail 1 pressure sensor connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open return circuit or a pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 452 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 1 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 488 inactive?
 | STEP 2B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 1 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor.

Note: The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Compare the intake manifold 1 temperature sensor reading on the service tool monitor screen to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer YES to this step.

Does the thermocouple agree with the sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

A damaged intake manifold 1 temperature sensor has been detected.

Replace the intake manifold 1 temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Reference the Intake Manifold Air Temperature Above Specifications symptom tree in Service Manual, QSK19, QSK19 CM850 MCRS, QSK19 CM2150 MCR, Bulletin 4021592.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

DIsable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 488 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-May-2010


FAULT CODE 489 - Transmission Output Shaft Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, and Part Number 3823255 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and engine harness connectors. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 10 ohms?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 489 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the 31-pin OEM connector B.

Action

Inspect the OEM harness and connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the harness connection.

Clean the connectors and pins. Repair or replace the damaged section of harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 1B

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the 31-pin OEM connector B.
  • Disconnect the OEM harness connector from the external speed command input SIGNAL sending unit.

Action

Check for an open circuit.

  • Measure the resistance from the external speed command input SIGNAL pin of the 31-pin OEM connector B, OEM interface harness side, to the input pin of the OEM harness frequency signal sending unit side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot each section of the harness to determine which contains the open circuit.

Refer to the OEM service manual for repair information.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the 31-pin OEM connector B.
  • Disconnect the OEM harness connector from the external speed command input SIGNAL sending unit.

Action

Check for a short circuit to ground.

  • Measure the resistance from the external speed command input SIGNAL pin of the 31-pin OEM connector B to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each section of the harness to determine which contains the short circuit to ground.

Refer to the OEM service manual for repair information.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the 31-pin OEM connector B.
  • Disconnect the OEM harness connector from the external speed command input SIGNAL sending unit.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the external speed command input SIGNAL pin of the harness 31-pin OEM connector B to all other pins in the connector except for external speed command input RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each section of the harness to determine which contains the pin-to-pin short circuit.

Refer to the OEM service manual for repair information.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness connections.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the harness connection.

Clean the connectors and pins.

Refer to the circuit diagram or wiring diagram for all interconnections.

Repair or replace the damaged section of the harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness interconnections.

Action

Check for an open circuit.

  • Measure the resistance from the external speed command input SIGNAL pin of the ECM 60-pin OEM port connector to the frequency accelerator pin of the engine harness, OEM harness side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot each section of the harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Repair or replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness interconnections.

Action

Check for a short circuit to ground.

  • Measure the resistance from the external speed command input SIGNAL pin of the ECM 60-pin OEM port connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each section of the harness to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Repair or replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness interconnections.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the external speed command input SIGNAL pin of the engine harness to all other pin in the connector except for external speed command input RETURN pin.

Check to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each section of the harness to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Repair or replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 489 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 497 - Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the multiple unit synchronization switch. |
 | STEP 1A. Check the resistance from the multiple unit synchronization switch 1 pin-to-ground. | Less than 10 ohms?
 | STEP 1B. Check the resistance from the multiple synchronization switch 2 SIGNAL pin-to-ground. | Greater than 100k ohms?
 | STEP 1C. Check the resistance from the multiple unit synchronization switch 1 pin-to-ground. | Greater than 100k ohms?
 | STEP 1D. Check the resistance from the multiple unit synchronization switch 2 SIGNAL pin-to-ground. | Less than 10 ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect OEM harness and engine harness 60-pin OEM port connector for damaged pins. | Dirty or damaged pins?
 | STEP 2B. Check the OEM harness for a short to ground. | Greater than 100k ohms?
 | STEP 2C. Check the OEM harness for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector for damaged pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check the engine harness for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness to OEM harness connectors, and ECM connectors for damaged pins. | Dirty or damaged pins?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 497 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the multiple unit synchronization switch.

Guided Step 1A - Check the resistance from the multiple unit synchronization switch 1 pin-to-ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiple unit synchronization switch 1 ON.
  • Disconnect the OEM harness connector from the engine harness 23-pin OEM connector A.

Action

Check the resistance.

  • Measure the resistance from the multiple unit synchronization switch 1 pin of the OEM harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the OEM harness/multiple unit synchronization switch 1.

Refer to the OEM service manual.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance from the multiple unit synchronization switch 2 SIGNAL pin-to-ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiple unit synchronization switch 2 ON.
  • Disconnect the OEM harness connector from the engine harness 23-pin OEM connector A.

Action

Check the resistance from the multiple synchronization switch 2 pin to engine block ground.

  • Measure the resistance from the multiple synchronization switch 2 SIGNAL pin of the OEM harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the OEM harness/multiple unit synchronization switch 2.

Refer to the OEM service manual.

Go to 1C

Go to 5A

Guided Step 1C - Check the resistance from the multiple unit synchronization switch 1 pin-to-ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiple unit synchronization switch 1 OFF.
  • Disconnect the OEM harness connector from the engine harness 23-pin OEM connector A.

Action

Check the resistance from the multiple unit synchronization switch 1 pin to engine block ground.

  • Measure the resistance from the multiple unit synchronization switch 1 pin of the OEM harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the OEM harness/multiple unit synchronization switch 1 .

Refer to the OEM service manual.

Go to 1D

Go to 5A

Guided Step 1D - Check the resistance from the multiple unit synchronization switch 2 SIGNAL pin-to-ground.

Conditions

  • Turn keyswitch OFF.
  • Turn multiple unit synchronization switch OFF.
  • Disconnect the OEM harness connector from the engine 23-pin OEM connector A.

Action

Check the resistance from the multiple unit synchronization switch 2 SIGNAL pin to engine block ground.

  • Measure the resistance from the multiple unit synchronization switch 2 pin of the OEM harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the OEM harness/multiple unit synchronization switch 2.

Refer to the OEM service manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness connector and engine harness connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 23-pin OEM connector A.

Action

Inspect the OEM harness and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 2B

Guided Step 2B - Check the OEM harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the multiple unit synchronization switch 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness 23-pin OEM connector A.

Action

Check the OEM harness for a short to ground.

  • Measure the resistance from the multiple unit synchronization switch 1 pin of the OEM harness to engine block ground.
  • Measure the resistance from the multiple unit synchronization switch 2 SIGNAL of the OEM harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the OEM service manual.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check the OEM harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the multiple unit synchronization switch 1 from the OEM harness.
  • Disconnect the OEM harness connector from the engine harness 23-pin OEM connector A.

Action

Check the OEM harness for a short from pin to pin.

  • Measure the resistance from the multiple unit synchronization switch 1 pin of the OEM harness to all other pins in the connector.
  • Measure the resistance from the multiple unit synchronization switch 2 SIGNAL pin of the OEM harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the OEM harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the OEM service manual.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness connector and ECM connectors for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Check the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the harness connector.

Clean the connector pins.

Replace the damaged section of harness.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 5A

Go to 3B

Guided Step 3B - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Check the engine harness for an open circuit.

  • Measure the resistance from the multiple unit synchronization switch 1 pin of the engine harness to the multiple unit synchronization switch 1 pin of the engine harness ECM 60-pin OEM port connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Check the engine harness for a short to ground.

  • Measure the resistance from the multiple unit synchronization switch 1 pin of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the OEM harness.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Check the engine harness for a pin-to-pin short.

  • Measure the resistance from the multiple unit synchronization switch 1 pin of the engine harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness connector to OEM harness connectors, and ECM connectors for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM harness.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the engine harness connector to OEM harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram and wiring diagram for all harness interconnections.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect all components.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 497 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 11-Jun-2010


Fault Code 521 - Transmission Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, and Part Number 3823256 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 521 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the transmission (gear) oil temperature sensor and circuit. |
 | STEP 2A. Inspect the transmission (gear) oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 521 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 522 active and Fault Code 521 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 521 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 521 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connection INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 521 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the transmission (gear) oil temperature sensor and circuit.

Guided Step 2A - Inspect the transmission (gear) oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness.

Action

Check the transmission (gear) oil temperature sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector or shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the transmission (gear) oil temperature sensor or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged transmission (gear) oil temperature sensor. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.

Action

Check sensor resistance.

  • Measure the resistance between the transmission (gear) oil temperature sensor SIGNAL pin and transmission (gear) oil temperature sensor RETURN (sensor return 1) pin at the transmission (gear) oil temperature sensor.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the damaged transmission (gear) oil temperature sensor. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the transmission (gear) oil temperature sensor connector to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 521 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Check the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector or shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the transmission (gear) oil temperature sensor SIGNAL pin and transmission (gear) oil temperature sensor RETURN (sensor return 1) pin at the ECM 60 pin engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 522 active and Fault Code 521 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the transmission (gear) oil temperature sensor RETURN (sensor return 1) pin of the engine harness connector and the transmission (gear) oil temperature sensor RETURN (sensor return 1) pin of the engine harness ECM 60 pin connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open transmission (gear) oil temperature sensor return (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the transmission (gear) oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the transmission (gear) oil temperature sensor SIGNAL pin of the engine harness ECM 60 pin connector and the transmission (gear) oil temperature sensor SIGNAL pin of the engine harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open transmission (gear) oil temperature sensor signal circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the transmission (gear) oil temperature sensor SIGNAL pin in the engine harness ECM 60 pin connector and all other pins in the engine harness ECM 60 pin connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the transmission (gear) oil temperature sensor SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 521 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 521 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate fault code troubleshooting steps.

Last Modified: 05-Dec-2016


FAULT CODE 522 - Transmission Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 522 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the transmission (gear) oil temperature sensor and circuit. |
 | STEP 2A. Inspect the transmission (gear) oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 521 active and Fault Code 522 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 522 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 521 active and Fault Code 522 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 522 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 522 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service too.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 522 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil temperature sensor 1 and circuit.

Guided Step 2A - Inspect the transmission (gear) oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.

Action

Inspect the transmission (gear) oil temperature sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the transmission (gear) oil temperature sensor or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the damaged transmission (gear) oil temperature sensor. See equipment manufacturer service information.

 No Repair

  • 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 521 active and Fault Code 522 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 522 active?
YES NO

A damaged transmission (gear) oil temperature sensor has been detected.

  • Replace the damaged transmission (gear) oil temperature sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the ECM and engine harness connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 521 active and Fault Code 522 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the transmission (gear) oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the transmission (gear) oil temperature sensor SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the harness to determine which contains the short to open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the transmission (gear) oil temperature sensor connector from the engine harness connector.

Action

Check for a short circuit.

  • Measure the resistance between the transmission (gear) oil temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the transmission (gear) oil temperature sensor SIGNAL wire has been detected in the engine harness

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harness connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 522 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode will have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 522 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to clear the inactive fault codes.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 02-Jan-2017


FAULT CODE 527 - Auxiliary Input/Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | Extra wires?
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean?
 | STEP 1C. Check the solenoid resistance. | 28 to 32 ohms for 24-VDC solenoids?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the engine harness and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the OEM harness to ground. | More than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage at the ECM. | More than 17-VDC?
 | STEP 3C. Check for a short in the solenoid supply wire to ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 527 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.

  • Check for extra wires on the solenoid post.

Extra wires?
YES NO

Remove the extra wires.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.

Solenoid post clean?
YES NO
No Repair

Repair the ring terminal or replace the solenoid.

Repair the ring terminal. Refer to Procedure 019-197 in Section 19.

Replace the solenoid. Refer to the OEM service manual for procedure.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the solenoid.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.

Use a wiring diagram for connector pin identification and the following procdure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

28 to 32 ohms for 24-VDC solenoids?
YES NO
No Repair

Replace the solenoid.

Refer to the OEM service manual for procedure.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the 23-pin OEM Connector A.

Action

Check the engine harness connector and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connection.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the OEM harness to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the 23-pin OEM connector A.
  • Disconnect the OEM harness connector from the solenoid.

Action

Check for a short circuit in the OEM harness to ground.

  • Measure the resistance from the solenoid supply wire to engine block ground.

Use a wiring diagram for connector pin identification and the following procdure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the 23-pin OEM connector A.
  • Disconnect the OEM harness connector from the solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between auxiliary input/output 2 SIGNAL pin in the 23-pin OEM connector A to all other pins in the connector.

Use a wiring diagram for connector pin identification and the following procdure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check the ECM connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the harness connection.

Clean the connector pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 3B

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch ON.
  • Confirm auxiliary input/output 2 SIGNAL voltage is turned on.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM harness at the 23-pin OEM connector A.
  • Connect the female end of jumper wire to the auxiliary input/output 2 SIGNAL pin in the ECM connector.
  • Attach the clip end of the jumper wire to the ECM housing for completion of the ground circuit.

Action

Check the supply voltage at the ECM.

  • Measure the voltage from auxiliary input/output 2 SIGNAL pin on the ECM side of the OEM harness connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

More than 17-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short in the solenoid supply wire to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the 23-pin OEM connector A.

Action

Check for a short in the solenoid supply wire to ground.

  • Measure the resistance from auxiliary input/output 2 SIGNAL pin to engine block ground.

Use a wiring diagram for connector pin identification and the following procdure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A damaged connection has been detected in the harness connection.

Clean the connector pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the damaged section of the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the 23-pin OEM connector A.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from auxiliary input/output 2 SIGNAL pin of the engine harness connector to all other wires in the connector.

Use a wiring diagram for connector pin identification and the following procdure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness connections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 527 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear all of the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 529 - Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solenoid. |
 | STEP 1A. Check for extra wires on the solenoid post. | Extra wires?
 | STEP 1B. Clean the solenoid post and the wiring terminal. | Solenoid post clean?
 | STEP 1C. Check the solenoid resistance. | Resistance between 28 and 32 ohms for 24 volt solenoids?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the engine harness and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the OEM harness to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a pin-to-pin short circuit. | Greater than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage at the ECM. | Greater than 17-VDC?
 | STEP 3C. Check for a short in the solenoid supply wire to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 529 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the solenoid.

Guided Step 1A - Check for extra wires on the solenoid post.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires on the solenoid post.

  • Check for extra wires on the solenoid post.

Extra wires?
YES NO

Remove the extra wires.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Clean the solenoid post and the wiring terminal.

Conditions

  • Turn keyswitch OFF
  • Disconnect the control wire from the solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the post of the solenoid and the terminal for the solenoid control wire of the OEM harness.

Solenoid post clean?
YES NO
No Repair

Repair the ring terminal or replace the solenoid.

Repair the ring terminal. Refer to Procedure 019-197 in Section 19.

Replace the solenoid. Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the solenoid resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the solenoid.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid to engine block ground.

Refer to the circuit diagram or wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 28 and 32 ohms for 24 volt solenoids?
YES NO
No Repair

Replace the solenoid. Refer to the OEM service manual for procedure.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the engine harness connector and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the 23-pin OEM connector A.

Action

Inspect the engine harness connector and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connection.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Clean the connector and pins.

Repair or replace the damaged section of harness.

Refer to the OEM service manual.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the OEM harness to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the 23-pin OEM connector A
  • Disconnect the OEM harness connector from the solenoid.

Action

Check for a short circuit from the OEM harness to ground.

  • Measure the resistance from the solenoid SUPPLY wire to engine block ground.

Refer to the circuit diagram or wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit .

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the 23-pin OEM connector A
  • Disconnect the OEM harness connector from the solenoid.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the auxiliary input/output 3 SIGNAL pin in the 23-pin OEM connector A and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the ECM connector and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the ECM connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the harness connection.

Clean the connector pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 3B

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch ON.
  • Confirm auxiliary input/output 3 SIGNAL voltage is turned on.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the 23-pin OEM connector A.
  • Connect the female end of jumper wire to the auxiliary input/output 3 SIGNAL pin in the ECM connector.
  • Attach the clip end of the jumper wire to the ECM housing for completion of the ground circuit.

Action

Check the supply voltage at the ECM.

  • Measure the voltage from auxiliary input/output 3 SIGNAL pin on the ECM side of the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 17-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short in the solenoid supply wire to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the 23-pin OEM connector A.

Action

Check for a short in the solenoid supply wire to ground.

  • Measure the resistance from auxiliary input/output 3 SIGNAL pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the 23-pin OEM connector A.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from auxiliary input/output 3 SIGNAL pin of the engine harness connector to all other wires in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Repair the connectors. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 529 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear all inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 03-May-2012


FAULT CODE 546 - Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault code. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 546 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 547 active and Fault code 546 inactive?
 | STEP 2C. Check the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) and fuel delivery pressure RETURN (sensor return 2). | 4.7VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault code 546 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) and fuel delivery pressure RETURN (sensor return 2). |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 546 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel delivery pressure sensor connector or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness or damaged sensor. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Replace the fuel delivery pressure sensor. Refer to Procedure 019-398 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 547 active and Fault code 546 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) and fuel delivery pressure RETURN (sensor return 2).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

Measure the voltage from the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin to the fuel delivery pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Use a wiring diagram for connector pin identificaton and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 active?
YES NO

A damaged sensor has been detected.

Replace the fuel delivery pressure sensor. Refer to Procedure 019-398 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel delivery pressure sensor connector or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness or damaged sensor. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 547 active and Fault code 546 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds..

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 active?
YES NO

A pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel delivery pressure sensor connector or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness or damaged sensor. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) and fuel delivery pressure RETURN (sensor return 2).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin to the fuel delivery pressure RETURN (sensor return 2) pin at the ECM engine connector.

Use a wiring diagram for connector pin identificaton and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 inactive?
YES NO

  • None. The removal and installation of the connector corrected the malfunction.

An open return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 546 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Return to the appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 547 - Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault code. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 547 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) voltage and fuel delivery pressure RETURN (sensor return 2). | Resistance between 4.75-VDC and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault code 546 active and fault code 547 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 547 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) and fuel delivery pressure RETURN (sensor return 2). |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 547 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 187.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-209 in Section 19.

Replace the fuel delivery pressure sensor. Refer to Procedure 019-398 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) and fuel delivery pressure RETURN (sensor return 2).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin to the fuel delivery pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin and the fuel delivery pressure SIGNAL pin at the fuel delivery sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active and Fault Code 547 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify fuel delivery pressure sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES NO

A damaged sensor has been detected.

Replace the fuel delivery pressure sensor. Refer to Procedure 019-398 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-209 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) and fuel delivery pressure RETURN (sensor return 2).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin to the fuel delivery pressure RETURN (sensor supply 2) pin at the ECM 60-pin connector.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance between 4.75-VDC and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open or shorted supply circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit, short to ground, or pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-209 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin and the fuel delivery pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 546 active and Fault Code 547 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open or short signal circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit or pin-to-pin short or short to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the connector. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 547 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 10-Mar-2015


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check sensor accuracy. |
 | STEP 1A. Verify the crankcase pressure sensor. | Does the crankcase pressure sensor agree with the mechanical gauge?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 556 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the crankcase pressure sensor.

Conditions

  • Connect a water manometer gauge to the engine.
  • Connect INSITE™ electronic service tool and service harness to the SAE J1939 datalink connector on the engine harness.
  • Start engine.

Action

Verify the crankcase pressure sensor accuracy with a gauge.

  • NOTE: Operate the engine at rated rpm and full load (wide open throttle) until a steady reading is obtained.

Does the crankcase pressure sensor agree with the mechanical gauge?
YES NO

Replace the crankcase pressure sensor.

 No Repair

Go to 2A

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Service Manual QSK19, QSK19 CM850 MCRS, QSK19 CM2150 MCRS, Bulletin 4021592.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code 556 is inactive.

Is Fault Code 556 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 28-May-2010


FAULT CODE 559 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK19, QSK19 CM850 MCRS, QSK19 CM2150 MCRS | 4021592
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSK19, QSK19 CM850 MCRS, QSK19 CM2150 MCRS | 4021592
Fuel Supply Lines | Refer to Procedure 006-024 | QSK19, QSK19 CM850 MCRS, QSK19 CM2150 MCRS | 4021592
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSK19, QSK19 CM850 MCRS, QSK19 CM2150 MCRS | 4021592
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK19, QSK19 CM850 MCRS, QSK19 CM2150 MCRS | 4021592
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK19, QSK19 CM850 MCRS, QSK19 CM2150 MCRS | 4021592

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 451, 452, 2215, 2261, or 2262 active or many inactive counts of Fault Code 451, 452, 2215, 2261, or 2262?
STEP 2. | Clear the operation of the high pressure fuel system. |
 | STEP 2A. Check for external leak. | External fuel leaks?
 | STEP 2B. Check for air in fuel. | Air present in the fuel flow line?
 | STEP 2C. Check the Stage 1 fuel filter restriction. | Fuel filter restriction less than specifications?
 | STEP 2D. Check the Stage 2 fuel filter restriction. | Fuel filter restriction less than specifications?
 | STEP 2E. Check the operation of the mechanical dump valve. | Mechanical dump valve leaking?
 | STEP 2E. Check the operation of the fuel pump pressurizing assembly. | Fault Code 559 become active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 559 inactive?
 | STEP 3A. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451, 452, 2215, 2261, or 2262 active or many inactive counts of Fault Code 451, 452, 2261, or 2262?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Clear the operation of the high pressure fuel system.

Guided Step 2A - Check for external leak.

Conditions

  • Operate engine.

Action

Check for external fuel leaks.

  • Start the engine and let engine idle.
  • Inspect for external fuel leaks.

External fuel leaks?
YES NO

Repair all fuel leaks.

Reference the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air in fuel.

Conditions

  • Remove air bleed line from air bleed valve on the fuel drain manifold block.
  • Route the air bleed line into a suitable container to collect fuel.
  • Turn keyswitch ON

Action

Inspect the fuel flow for air.

Use the following procedure in Service Manual, QSK19, QSK19 CM850 Modular Common Rail System, QSK19 CM2150 Modular Common Rail System, Bulletin 4021592. Refer to Procedure 006-003 in Section 6.

Air present in the fuel flow line?
YES NO

Repair or replace the damaged line or loose connection. Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the fuel restriction.

  • Operate the engine at idle and measure the restriction across the first stage fuel filters.
  • Refer to Procedure 006-020 in Section 6.

Fuel filter restriction less than specifications?
YES NO
No Repair

The restriction across the first stage filter is above specification. Replace the first stage fuel filter. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the fuel restriction.

  • Operate the engine at high idle and measure the restriction across the second stage fuel filters.
  • Refer to Procedure 006-020 in Section 6.

Fuel filter restriction less than specifications?
YES NO
No Repair

The restriction across the second stage filter is above specification. Replace the second stage fuel filter. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the operation of the mechanical dump valve.

Conditions

  • Disconnect the mechanical dump valve drain hose from the fuel drain manifold.
  • Place the relief drain hose into a clean container.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Start the engine.

  • Use INSITE™ electronic service tool high pressure Common Rail pressure test to raise the injector metering rail 1 pressure.
  • Measure the fuel leakage from the mechanical dump valve.
  • Install and M18 plug into the fuel drain manifold.

If the engine will not start, reference the Engine Performance Troubleshooting Tree in Section TT.

Mechanical dump valve leaking?
YES NO

Replace the mechanical dump valve and fuel pump pressurizing assembly. Refer to Procedure 006-061 in the Associated Procedures Table. Refer to Procedure 005-016 in the Associated Procedures Table.

Replace the fuel pump pressurizing assembly. Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 2F

Go to 2F

Guided Step 2F - Check the operation of the fuel pump pressurizing assembly.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool high pressure Common Rail pressure test to raise the injector metering rail 1 pressure.

Fault Code 559 become active?
YES NO

Replace the high pressure fuel pump assembly. Refer to Procedure 005-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the inactive fault codes.

Fault code 559 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Apr-2015


FAULT CODE 599 - Auxiliary Commanded Dual Output Shutdown - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 599. | Active or inactive counts of Fault Code 599?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 599 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault code 599.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 599?
YES NO

  • The engine protection limit has been exceeded for the OEM supplied auxiliary device. Refer to the OEM service manual.

 No Repair

OEM service manual

Repair complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 599 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Jun-2010


FAULT CODE 611 - Engine Shut Down Hot - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | No action required. |
 | STEP 1A. No action required. | Was the engine shut down before proper cool down?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 611 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - No action required.

Guided Step 1A - No action required.

Conditions

None

Action

Engine Hot Shutdown - Condition Exists.

The engine was shut down with the keyswitch before proper engine cool down, resulting in a load factor above the maximum shut down threshold.

Was the engine shut down before proper cool down?
YES | NO
No Repair | No Repair

Go to None

Go to None

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 611 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Jun-2010


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for engine crankshaft speed/position sensor supply fault codes. | Fault Code 238 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine crankshaft speed/position sensor and circuit. |
 | STEP 2A. Inspect the engine crankshaft speed/position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine crankshaft speed/position sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Engine crankshaft speed/position sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the engine crankshaft speed/position sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate engine crankshaft speed/position sensor air gap. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor engine crankshaft speed/position sensor state equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for engine crankshaft speed/position sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Fault Code 238

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • While engine idles, monitor the fault code status.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 689 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine crankshaft speed/position sensor and circuit.

Guided Step 2A - Inspect the engine crankshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine crankshaft speed/position sensor connector from the engine harness connector.

Action

Inspect the engine harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or the damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-042 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine crankshaft speed/position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine harness connector .
  • Turn keyswitch ON.

Action

Measure the voltage at the sensor connector.

  • Measure the voltage between the engine crankshaft speed/position 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed/position RETURN (sensor return 3) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool monitor mode to read the engine crankshaft speed/position sensor state.

Engine crankshaft speed/position sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the engine crankshaft speed/position 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed/position SIGNAL pin at the sensor connector of the engine harness.
  • Use INSITE™ electronic service tool monitor mode to read the engine crankshaft speed/position sensor state.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Engine crankshaft speed/position sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the engine crankshaft speed/position sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine crankshaft speed/position sensor from the engine. Refer to Procedure 019-042 in Section 19.

Action

Inspect the engine crankshaft speed/position sensor for the following:

  • Damaged sensor tip.
  • Physical signs of the engine crankshaft speed/position sensor touching the speed teeth.

Damaged sensor tip?
YES NO

Replace the engine crankshaft speed/position sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine crankshaft speed/position sensor from the engine. Refer to Procedure 019-042 in Section 19.
  • Make sure the engine crankshaft speed/position sensor is connected to the harness.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response.

  • Use the ratchet drive side of the socket tool that was used to remove the sensor from the engine. Place it flush on the sensor so that the edge of the socket is on the edge of the sensor. Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.
  • Use INSITE™ electronic service tool monitor mode to read the engine crankshaft speed/position sensor state.

Engine crankshaft speed/position sensor state transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Replace the engine crankshaft speed/position sensor. Refer to Procedure 019-042 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate engine crankshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch ON
  • Install the engine crankshaft speed/position sensor to the engine. Refer to Procedure 019-042 in Section 19.
  • Connect INSITE™ electronic service tool
  • Momentarily engage the starter but do not start the engine. Repeat this as many times as necessary.

Action

Monitor the engine crankshaft speed/position sensor state of the engine crankshaft speed/position sensor for the following:

  • Change of state from high to low or low to high, or the state shows triggered.

Engine crankshaft speed/position sensor transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Inspect the crankshaft tone wheel for damage or spinning.

Use the following procedure in the Service Manual QSK19 and QSK19 CM850 & CM2150 Modular Common Rail System Series Engines, Bulletin 4021592. Refer to Procedure 001-069 in Section 1.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

  • Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool monitor mode to read the engine crankshaft speed/position sensor state.

Monitor engine crankshaft speed/position sensor state equals low?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine crankshaft speed/position 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed/position sensor SIGNAL pin at the ECM port.

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool monitor mode to read the engine crankshaft speed/position sensor state.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Monitor engine crankshaft speed/position sensor state equals high?
YES NO

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Measure the voltage between the engine crankshaft speed/position 5 volt SUPPLY (sensor supply 3) pin and the engine crankshaft speed/position RETURN (sensor return 3) pin at the ECM engine harness port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 689 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 731 - Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the tone wheels and crankshaft speed/position sensor and engine camshaft speed/position sensor. |
 | STEP 1A. Inspect the crankshaft speed/position sensor and engine camshaft speed/position sensor for damage. | Any damage?
 | STEP 1B. Inspect the tone wheels for any damage. | Any damage?
STEP 2. | Check for correct engine static timing. |
 | STEP 2A. Check static timing. | Are the camshaft and crankshaft gears properly installed?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | Are all grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 731 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Inspect the tone wheels and crankshaft speed/position sensor and engine camshaft speed/position sensor.

Guided Step 1A - Inspect the crankshaft speed/position sensor and engine camshaft speed/position sensor for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for damage.

Inspect the crankshaft speed/position sensor and engine camshaft speed/position sensor for damage.

Any damage?
YES NO

Replace the crankshaft speed/position sensor. Refer to Procedure 019-042 in Section 19.

Replace the engine camshaft speed/position sensor. Refer to Procedure 019-363 in Section 19.

No Repair

Go to 4A

Go to 1B

Guided Step 1B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for damage.

Inspect the camshaft gear and the crankshaft tone wheel for damage.

Any damage?
YES NO

Use the following procedures in the Service Manual QSK19 and QSK19 CM850 & CM2150 Modular Common Rail System Series Engines, Bulletin 4021592.

Replace the camshaft gear or the crankshaft tone wheel.

  • Refer to Procedure 001-012 in Section 1.
  • Refer to Procedure 001-069 in Section 1.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check for correct engine static timing.

Guided Step 2A - Check static timing.

Conditions

  • Remove the gear cover.
  • Rotate the engine to top dead center for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned. Use the folloowing procedure in the Service Manual QSK19 and QSK19 CM850 & CM2150 Modular Common Rail System Series Engines, Bulletin 4021592. Refer to Procedure 001-008 in Section 1.

Action

Check the timing.

Inspect the engine static timing.

Are the camshaft and crankshaft gears properly installed?
YES NO
No Repair

Install the camshaft and crankshaft gears correctly.

Use the following procedures in the Service Manual QSK19 and QSK19 CM850 & CM21250 Modular Common Rail System Series Engines, Bulletin 4021592.

  • Refer to Procedure 001-008 in Section 1.
  • Refer to Procedure 001-018 in Section 1.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

Are all grounds present, properly grounded, free of corrosion, and tight?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 731 is inactive.

Fault Code 731 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gasses. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3824811 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 1C. Check the resistance of the OEM power harness and engine harness. | Less than 10 ohms?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness and engine harness. |
 | STEP 3A. Inspect the ECM 4-pin power connector and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuits. | 10.0 to 15.0-VDC?
 | STEP 3C. Check battery 1 voltage supply for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check battery 1 voltage return for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3E. Check battery 1 voltage supply for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or accessory wiring at the positive (+) battery terminal. | Damaged wires?
 | STEP 3G. Check the power supply to ECM wire. | Power supply wire uninterrupted?
 | STEP 3H. Check the power supply circuit. | Less than 5 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1117 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections, and clean the terminals. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.

Normal conditions:

  • At least +12 VDC (12-volt systems).
  • At least +24 VDC (24-volt systems).

During Cranking:

  • At least +6.2 VDC (12-volt systems).
  • At least +12 VDC (24-volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the resistance of the OEM power harness and engine harness.

Conditions

  • Turn keyswitch off
  • Disconnect the ECM 4-pin power connector
  • Disconnect the positive terminal from the battery.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery 1 voltage SUPPLY pin and the positive (+) battery connector.
  • Measure the resistance between the ECM battery 1 voltage RETURN pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the fuse is installed correctly.

  • Inspect the 10-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for blown fuse.

  • Inspect the 10-ampere fuse to see if it has blown.

Fuse blown?
YES NO

Replace the fuse.

Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness and engine harness.

Guided Step 3A - Inspect the ECM 4-pin power connector and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage between the battery 1 voltage SUPPLY pin in the ECM 4-pin power connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

10.0 to 15.0-VDC?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check battery supply for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector from the ECM.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from a battery 1 voltage SUPPLY pin in the ECM 4-pin power connector to all other pins in the connector, except the other battery 1 voltage SUPPLY pins.
  • Measure the resistance from a battery 1 voltage RETURN pin in the ECM 4-pin power connector to all other pins in the connector, except the other battery 1 voltage RETURN pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check battery 1 voltage return for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector from the ECM.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ECM battery 1 voltage RETURN pin in the ECM 4-pin power connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check battery 1 voltage supply for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 4-pin power connector from the ECM.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ECM battery 1 voltage SUPPLY pin in the ECM 4-pin power connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) battery terminal.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) battery terminal.

  • Starting at the positive (+) battery terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3G

Guided Step 3G - Check the power supply to ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the power supply to ECM wire.

Inspect the power supply wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is no solenoids or relays.

Power supply wire uninterrupted?
YES NO
No Repair

Correct the wiring so the wire is uninterrupted.

Go to 4A

Go to 3H

Guided Step 3H - Check the power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Check the power supply circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to power supply SIGNAL pin of the 60-pin OEM port engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1117 is inactive.

Fault Code 1117 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 1357 - Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check all fault codes. |
 | STEP 1A. Check for Fault Code 1357. | Active or inactive counts of Fault Code 1357?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1357 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check all the fault codes.

Guided Step 1A - Check for Fault Code 1357.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1357?
YES NO

Fill remote engine oil reservoir to appropriate level.

 No Repair

Appropriate troubleshooting symptom tree

Repair Complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1357 is inactive.

Fault Code 1357 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Appropriate troubleshooting steps

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2011


FAULT CODE 1358 - Accelerator Pedal or Lever Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1358 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal or lever position supply (sensor supply 4) voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1359 active and Fault Code 1358 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1358 is active?
STEP 3. | Check the engine harness and OEM harness. |
 | STEP 3A. Inspect engine harness and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the OEM harness. |
 | STEP 3A-2. Check for a pin-to-pin short circuit in the OEM harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 1358 inactive?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4A-1. Check for an open circuit in the engine harness. |
 | STEP 4A-2. Check for a pin-to-pin short circuit in the engine harness. |
 | STEP 4B. Check for an inactive fault code. | Fault Code 1358 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1358 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Fault Code 2185

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for an active fault code.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Secction 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the accelerator pedal or lever position or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-085 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the accelerator pedal or lever position supply (sensor supply 4) voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the accelerator pedal or lever position supply (sensor supply 4) voltage and return circuit.

Measure the voltage from the accelerator pedal or lever position SUPPLY (sensor supply 4) pin to the accelerator pedal or lever position RETURN (sensor return 4) pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 active and Fault Code 1358 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal or lever position sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever position sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 active?
YES NO

A damaged accelerator pedal or lever position sensor has been detected. Contact the OEM or dealership for repair instructions.

Replace accelerator pedal or lever position sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the malfunction.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness and OEM harness.

Guided Step 3A - Inspect the engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin OEM connector B.

Action

Inspect the OEM harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the accelerator pedal or lever position or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-085 in Section 19.

No Repair

Go to 5A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin OEM connector B.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness to engine harness connector accelerator pedal or lever position RETURN (sensor return 4) pin and the OEM harness accelerator pedal or lever position RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Refer to the OEM service manual.

Refer to Procedure 019-071 in Section 19.

Go to 3A-2

Go to 5A

Guided Step 3A-2 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin OEM connector B.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin in the OEM harness to engine harness connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Refer to the OEM service manual.

Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

No Repair

Go to 5A

Go to 4A-1

Guided Step 4A-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the OEM harness connector from the engine harness 31-pin OEM connector B.

Action

Check for an open circuit

  • Measure the resistance between the engine harness ECM connector accelerator pedal or lever position RETURN (sensor return 4) pin and the engine harness accelerator pedal or lever position RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which section contains the open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Check for a pin-to-pin short circuit in the engine harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the OEM harness connector from the engine harness 31-pin OEM connector B.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected on the SIGNAL line of the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1358 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1358 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 1359 - Accelerator Pedal or Lever Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test leadPart Number 3823996 - female Weather Pack™ test lead; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1359 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1358 active and Fault Code 1359 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1359 active?
STEP 3. | Check the engine harness and OEM harness. |
 | STEP 3A. Inspect the engine harness and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the OEM harness |
 | STEP 3A-2. Check for an open circuit in the OEM harness. |
 | STEP 3A-3. Check for a pin-to-pin short circuit in the OEM harness. |
 | STEP 3A-4. Check for a pin short circuit to ground in the OEM harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 1359 inactive?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4A-1. Check for an open circuit in the engine harness. |
 | STEP 4A-2. Check for an open circuit in the engine harness.. |
 | STEP 4A-3. Check for a pin-to-pin short circuit in the engine harness. |
 | STEP 4B. Check for an inactive fault code. | Fault Code 1359 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1359 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Fault Code 2186

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Chect for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Inspect the OEM harness connector and accelerator pedal or lever position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19 .

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the accelerator pedal or lever position sensor or harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins if possible.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-085 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the accelerator pedal or lever position sensor supply voltage and return circuit.

Measure the voltage from the accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin to the accelerator pedal or lever position RETURN (sensor supply 4) pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin and the accelerator pedal or lever position SIGNAL pin at the sensor connector of the OEM harness.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1358 active and Fault Code 1359 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 active?
YES NO

A damaged accelerator pedal has been detected. Contact the OEM or dealership for repair instructions.

Replace the accelerator pedal. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the malfunction.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness and OEM harness.

Guided Step 3A - Inspect the engine harness and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin OEM connector B.

Action

Inspect the OEM harness connector and engine harness connector pins for fhe following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell damage
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged OEM harness or replace the engine harness section, whichever has the damaged harness, connector, or pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin OEM connector B.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness to engine harness connector accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin and the OEM harness accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Refer to the OEM service manual for repair instructions.

Refer to Procedure 019-071 in Section 19.

Go to 3A-2

Go to 5A

Guided Step 3A-2 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin OEM connector B.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness to engine harness connector accelerator pedal or lever position SIGNAL pin and the OEM harness accelerator pedal or lever position SIGNAL connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.Use the following procedure for general resistance measurement techniques. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Refer to the OEM service manual for repair instructions.

Refer to Procedure 019-071 in Section 19.

Go to 3A-2

Go to 5A

Guided Step 3A-3 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin OEM connector B.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin in the OEM harness to engine harness connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Refer to the OEM service manual.

Refer to Procedure 019-071 in Section 19.

Go to 3A-4

Go to 5A

Guided Step 3A-4 - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine harness 31-pin OEM connector B.
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the OEM harness to engine harness connector accelerator pedal or lever position SIGNAL pin ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Refer to the OEM service manual.

Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • .Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM and Engine Harness

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the 60-pin OEM port connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

No Repair

Go to 5A

Go to 4A-1

Guided Step 4A-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the accelerator pedal or lever position sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector accelerator pedal or lever position sensor SUPPLY (sensor supply 4) pin and the engine harness accelerator pedal or lever position sensor SUPPLY (sensor supply 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which section contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector accelerator pedal or lever position sensor SUPPLY (sensor supply 4) pin and the engine harness accelerator pedal or lever position sensor SUPPLY (sensor supply 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which section contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

or .

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected on the SIGNAL wire of the engine harness.

Troubleshoot each section of engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

Go to 4A-4

Go to 5A

Guided Step 4A-4 - Check for a pin short circuit to ground in the OEM engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the accelerator pedal or lever position sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the harness to determine which section contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3B

Go to 5A

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1359 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1359 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 1361 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3823995 - male Weather Pack™ test lead; Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1361 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1595 active and Fault Code 1361 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM harness and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness or engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground in the OEM harness or engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1361 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1361 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Inspect the OEM and remote accelerator pedal or lever position sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged remote accelerator pedal or lever position sensor.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) and remote accelerator pedal or lever position RETURN (sensor return 1).

  • Measure the voltage from the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin on the OEM harness sensor connector to the remote accelerator pedal or lever position RETURN (sensor return 1) pin on the OEM harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin and the remote accelerator pedal or lever position SIGNAL pin at the remote accelerator pedal or lever position sensor OEM harness connector.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1595 active and Fault Code 1361 inactive?
YES NO

Replace the remote accelerator pedal or lever position sensor. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM harness and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the engine harness connector and the ECM 60-pin OEM port connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector and the ECM 60-pin OEM port connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness connector.

Action

Check for an open circuit in the OEM harness or engine harness.

  • Measure the resistance from the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin in the 60-pin OEM port engine harness to the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin in the harness sensor connector.
  • Measure the resistance from the remote accelerator pedal or lever position SIGNAL pin in the 60-pin OEM port engine harness connector to the remote accelerator pedal or lever position SIGNAL pin in the harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness connector.

Action

Check for a pin-to-pin short circuit in the OEM harness or engine harness.

  • Measure the resistance and check for a short circuit from the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin in the 60-pin OEM port engine harness connector to all other pins in the connector.
  • Measure the resistance from the remote accelerator pedal or lever position SIGNAL pin in the 60-pin OEM port engine harness connector to all the other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness connector.
  • Disconnect the tachograph (if equipped).

Action

Check for a pin short circuit to ground.

  • Measure the resistance and check for a short circuit from the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin in the 60-pin OEM port engine harness connector to engine block ground.
  • Measure the resistance and check for a short circuit from the remote accelerator pedal or lever position SIGNAL pin in the 60-pin OEM port engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1361 is inactive.

Fault Code 1361 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 03-May-2012


FAULT CODE 1369 - Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1369 inactive?
STEP 2. | Check the auxiliary temperature sensor input 1 and circuit. |
 | STEP 2A. Inspect the auxiliary temperature sensor input 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the auxiliary temperature sensor input 1 resistance. | 180 ohms to 160K ohms?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness or engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness or engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1369 inactive?
STEP 4. | Clear the fault code |
 | STEP 4A. Disable the fault code. | Fault Code 1369 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1369 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the auxiliary temperature sensor input 1 and circuit.

Guided Step 2A - Inspect the auxiliary temperature sensor input 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary temperature sensor input 1 and connector pins.

Action

Inspect the OEM harness and auxiliary temperature sensor input 1 connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins.
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the auxiliary temperature sensor input 1 or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the auxiliary temperature sensor input 1 resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the auxiliary temperature sensor input 1 from the OEM harness connector.

Action

Check the auxiliary temperature sensor input 1 resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the auxiliary temperature sensor input 1 connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160K ohms?

Refer to the OEM service manual for additional specifications.
YES NO
No Repair

Replace the auxiliary temperature sensor input 1.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A 60-pin OEM port connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector pins if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the auxiliary temperature sensor 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector auxiliary temperature sensor RETURN pin and OEM harness auxiliary temperature sensor RETURN connector pin.

Refer to the circuit diagram or the wiring diagram connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit. Repair or replace the harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the auxiliary temperature sensor input 1 connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector auxiliary temperature sensor SIGNAL pin and the OEM harness auxiliary temperature sensor SIGNAL connector pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the auxiliary temperature sensor input 1 connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the auxiliary temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1369 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1369 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 04-May-2012


FAULT CODE 1373 - Start Enable Device 1 Circuit (Ether Injection) - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the start enable device 1 circuit (ether injection) solenoid. |
 | STEP 1A. Inspect the injection solenoid connector post and OEM harness connector. | Dirty or damaged pins?
 | STEP 1B. Check the supply voltage at the start enable device 1 circuit (ether injection) solenoid. | More than 17.0-VDC?
 | STEP 1C. Check the resistance of the start enable device 1 circuit (ether injection) solenoid. | Resistance is within OEM specifications?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and engine harness connector for damaged pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short to ground in the OEM harness. | More than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connectors for damage. | Dirty or damaged pins?
 | STEP 3B. Check for a short to ground in the engine harness. | More than 100k ohms?
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3D. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check the supply voltage at the ECM. |
 | STEP 4A. Check the supply voltage at the ECM. | More than 17.0-VDC?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1373 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the start enable device 1 circuit (ether injection) solenoid.

Guided Step 1A - Inspect the injection solenoid connector post and OEM harness connector.

Conditions

  • Turn keyswitch OFF
  • Disconnect the start enable device 1 circuit (ether injection) solenoid from the OEM harness.

Action

Inspect the injection solenoid connector post and OEM harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
  • Multiple wires on the terminal post.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged solenoid.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-197 in Section 19.

Go to 5A

Go to 1B

Guided Step 1B - Check the supply voltage at the start enable device 1 circuit (ether injection) solenoid.

Conditions

  • Turn keyswitch ON.
  • Disconnect the start enable device 1 circuit (ether injection) solenoid from the OEM harness.

Action

Check the supply voltage at the start enable device 1 circuit (ether injection) solenoid.

  • Measure the voltage from the OEM wiring harness connector to engine block ground.

More than 17.0-VDC?
YES NO

Replace the start enable device 1 circuit (ether injection) solenoid. Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 1C

Guided Step 1C - Check the resistance of the start enable device 1 circuit (ether injection) solenoid.

Conditions

  • Turn keyswitch OFF
  • Disconnect the start enable device 1 circuit (ether injection) solenoid from the OEM harness.

Action

Check the resistance of the start enable device 1 circuit (ether injection) solenoid.

  • Measure the resistance from the connector post to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance is within OEM specifications?
YES NO
No Repair

Replace the start enable device 1 circuit (ether injection) solenoid. Refer to the OEM service manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and engine harness connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the start enable device 1 circuit (ether injection) solenoid.
  • Disconnect the OEM harness connector from the engine harness at the 23-pin OEM connector A.

Action

Inspect the OEM harness connector and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
  • Missing or damaged connector seals.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the OEM or engine harness.

Clean the connector and pins.

Replace the damaged section of the harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the start enable device 1 circuit (ether injection) solenoid.
  • Disconnect the OEM harness connector from the engine harness at the 23-pin OEM connector A.

Action

Check for a short to ground in the OEM harness.

  • Measure the resistance from the start enable device 1 circuit (ether injection) solenoid harness connector (ring terminal) to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the start enable device 1 circuit (ether injection) solenoid.
  • Disconnect the OEM harness connector from the engine harness at the 23-pin OEM connector A.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from start enable device 1 circuit (ether injection) pin of the 23-pin OEM connector A, engine harness side, to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the start enable device 1 circuit (ether injection) solenoid.
  • Disconnect the OEM harness connector from the engine harness at the 23-pin OEM connector A.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between the OEM harness solenoid connector to the start enable device 1 circuit (ether injection) pin of the OEM harness 23-pin OEM connector A side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connectors for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Check for a short to ground in the engine harness.

  • Measure the resistance from start enable device 1 circuit (ether injection) pin of the engine harness ECM 60-pin connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Troubleshoot each section of the engine harness to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness connectors

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from start enable device 1 circuit (ether injection) pin on the ECM side to all other pins in the ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Troubleshoot each section of the engine harness to determine which contains the pin to pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connectors.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from start enable device 1 circuit (ether injection) pin of the 23-pin OEM connector A to start enable device 1 circuit (ether injection) pin of the engine harness connector, ECM 60-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the supply voltage at the ECM 60-pin connector.

Guided Step 4A - Check the supply voltage at the ECM 60-pin connector.

Conditions

  • Turn keyswitch ON
  • Start enable device 1 circuit (ether injection) system enabled
  • Coolant temperature below the ECM calibrated threshold
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check the supply voltage at the ECM.

  • Measure the supply voltage from the start enable device 1 circuit (ether injection) pin of the ECM 60-pin connector to engine block ground.

More than 17.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1373 is inactive.

Fault Code 1373 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 1376 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for engine camshaft speed/position 5 volt supply (sensor supply 2) fault codes. | Fault Code 187 or 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1376 active?
STEP 2. | Check the engine camshaft speed/position sensor and circuit. |
 | STEP 2A. Inspect the engine camshaft speed/position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine camshaft speed/position 5 volt supply (sensor supply 2) voltage and engine camshaft speed/position return (sensor return 2) circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Engine camshaft speed/position sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the engine camshaft speed/position sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate engine camshaft speed/position sensor air gap. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor engine camshaft speed/position sensor state equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for engine camshaft speed/position 5 volt supply (sensor supply 2) fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 or 227 active?
YES | NO
No Repair | No Repair

Fault Code 187 or 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 1376 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine camshaft speed/position sensor and circuit.

Guided Step 2A - Inspect the engine camshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor from the engine harness.

Action

Inspect the engine harness and engine camshaft speed/position sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged engine camshaft speed/position sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-363 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine camshaft speed/position 5 volt supply (sensor supply 2) and engine camshaft speed/position return (sensor return 2) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector .
  • Turn keyswitch ON.

Action

Measure the voltage at the engine camshaft speed/position sensor connector.

  • Measure the voltage between the engine camshaft speed/position 5 volt SUPPLY (sensor supply 2) pin and the engine camshaft speed/position RETURN (sensor return 2) pin at the engine camshaft speed/position sensor connector of the engine harness.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool Monitor Mode to read the engine camshaft speed/position sensor state.

Engine camshaft speed/position sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine camshaft speed/position sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the engine camshaft speed/position 5 volt SUPPLY (sensor supply 2) pin and the engine camshaft speed/position SIGNAL pin at the engine camshaft speed/position sensor connector of the engine harness.
  • Use INSITE™ electronic service tool Monitor Mode to read the engine camshaft speed/position sensor state.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Engine camshaft speed/position sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the engine camshaft speed/position sensor.

Conditions

  • Turn keyswitch OFF
  • Remove the engine camshaft speed/position sensor from the engine. Refer to Procedure 019-363 in Section 19.

Action

Inspect the engine camshaft speed/position sensor.

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed teeth.

Damaged sensor tip?
YES NO

Replace the engine camshaft speed/position sensor. Refer to Procedure 019-363 in Section 19.

No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine camshaft speed/position sensor from the engine. Refer to Procedure 019-363 in Section 19.
  • Make sure the engine camshaft speed/position sensor is connected to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine camshaft speed/position sensor.

  • Use the ratchet drive side of the socket tool that was used to remove the engine camshaft speed/position sensor from the engine. Place it flush on the engine camshaft speed/position sensor so that the edge of the socket is on the edge of the engine camshaft speed/position sensor. Slowly slide the socket in a perpendicular direction to the marked line on the engine camshaft speed/position sensor or in a perpendicular direction to the mounting bracket of the engine camshaft speed/position sensor.
  • Check for the appropriate ECM response.
  • Use INSITE™ electronic service tool Monitor Mode to read the engine camshaft speed/position sensor state .

Engine camshaft speed/position sensor state transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Replace the engine camshaft speed/position sensor. Refer to Procedure 019-363 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate engine camshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Install the engine camshaft speed/position sensor to the engine and connect it to the harness. Refer to Procedure 019-363 in Section 19.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Momentarily engage the starter but do not start the engine. Repeat this as many times as necessary.

Action

Monitor the engine camshaft speed/position sensor state of the engine camshaft speed/position sensor for the following:

  • Change of state from high to low or low to high, or the state shows triggered.

Engine camshaft speed/position sensor transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Inspect the camshaft gear teeth for damage or spinning.

Use the following procedure in the Service Manual QSK19 and QSK19 CM850 & CM2150 Modular Common Rail System Series Engines, Bulletin 4021592. Refer to Procedure 001-018 in Section 1.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM 60-pin connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • USe INSITE™ electronic service tool Monitor Mode to raead the engine camshaft speed/position sensor state.

Monitor engine camshaft speed/position sensor state equals low?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connection ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the engine camshaft speed/position 5 volt SUPPLY (sensor supply 2) pin and the engine camshaft speed/position SIGNAL pin at the ECM port.
  • Use INSITE™ electronic service tool Monitor Mode to read the engine camshaft speed/position sensor state.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Monitor engine camshaft speed/position sensor state equals high?
YES NO

Troubleshoot all harnesses connected in series to determine which contains the damaged section.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine camshaft speed/position 5 volt supply (sensor supply 2) and engine camshaft speed/position return (return sensor 2) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the ECM engine camshaft speed/position 5 volt SUPPLY (sensor supply 2) pin and the engine camshaft speed/position RETURN pin circuit.

Measure the voltage between the engine camshaft speed/position 5 volt SUPPLY (sensor supply 2) pin and the engine camshaft speed/position RETURN pin at the ECM engine harness port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1376 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 1381 - Auxiliary Temperature Sensor Input 1 - Special Instructions

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 1369 and 1596 are inactive
STEP 2. | Check the auxiliary temperature sensor. |
 | STEP 2A. Check the auxiliary temperature sensor using INSITE™ electronic service tool. | Auxiliary temperature sensor reading (INSITE™ electronic service tool reading) equals actual temperature?
 | STEP 2B. Check the auxiliary temperature sensor thresholds using INSITE™ electronic service tool. | Auxiliary temperature sensor readings are not greater or less than the auxiliary temperature sensor thresholds?
 | STEP 2C. Inspect the auxiliary temperature sensor and the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check the resistance of the auxiliary temperature sensor. | Auxiliary temperature sensor resistance?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1381 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1369 and 1596 are inactive?
YES | NO
No Repair | No Repair

Inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the auxiliary temperature sensor.

Guided Step 2A - Check the auxiliary temperature sensor using INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the OEM temperature.

  • Use a thermocouple or similar temperature probe to verify the actual temperature. Refer to OEM service manual for temperature-checking procedures.
  • Use INSITE™ electronic service tool to check the temperature.

Auxiliary temperature sensor reading (INSITE™ electronic service tool reading) equals actual temperature?
YES NO
No Repair

Replace the auxiliary temperature sensor.

Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the auxiliary temperature sensor thresholds using INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the OEM temperature thresholds.

  • Refer to the OEM troubleshooting and repair manual for temperature thresholds' specifications.
  • Use INSITE™ electronic service tool to check the temperature thresholds.

Auxiliary temperature sensor readings are not greater or less than the auxiliary temperature sensor thresholds?

YES NO
No Repair

Replace the auxiliary temperature sensor.

Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the auxiliary temperature sensor and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the auxiliary temperature sensor connector.

Action

Check the auxiliary temperature sensor and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness or auxiliary temperature sensor connector.

Clean the connector and pins.

Refer to Procedure 019-071 in Section 19.

Refer to the OEM service manual for repair or replacement information.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the resistance of the auxiliary temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the auxiliary temperature sensor connector.

Action

Check the resistance of the auxiliary temperature sensor.

Refer to the OEM service manual.

Sensor resistance?
YES NO
No Repair

Replace the auxiliary temperature sensor.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1381 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Refer to the appropriate troubleshooting steps.

Last Modified: 02-Jun-2010


FAULT CODE 1411 - Generator Output Frequency Adjust Potentiometer Circuit -Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the generator output frequency adjust potentiometer. |
 | STEP 1A. Inspect the generator output frequency adjust potentiometer assembly for damage to pins. | No damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 5k ohms?
 | STEP 1C. Check the resistance range of the generator output frequency adjust potentiometer. | Resistance varies?
STEP 2. | Check the generator interface harness. |
 | STEP 2A. Inspect the generator interface harness and the ECM connector pins. | No damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault codes. | Fault Code 1411 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the generator output frequency adjust potentiometer.

Guided Step 1A - Inspect the generator output frequency adjust potentiometer assembly for damage to pins.

Conditions

  • Run/Stop switch in the Stop position.

Action

Inspect the generator output frequency adjust potentiometer assembly for damage to pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

Replace the generator output frequency adjust potentiometer. Refer to the OEM service manual.

Repair the generator interface harness.

  • Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the generator interface harness. Refer to Procedure 019-043 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Run/stop switch in the stop position.
  • Disconnect the generator output frequency adjust potentiometer connector from the harness connector.

Action

Check the generator output frequency adjust potentiometer resistance.

  • Measure the resistance between the generator output frequency adjust potentiometer pins using a multimeter.

1C
YES NO
No Repair

Replace the generator output frequency adjust potentiometer. Refer to the OEM service manual.

Less than 5k ohms?

Less than 5k ohms?

Guided Step 1C - Check the resistance range of the generator output frequency adjust potentiometer.

Conditions

  • Run/Stop switch in the STOP position.
  • Disconnect the generator output frequency adjust potentiometer connector from the harness connector.
  • Adjust the generator output frequency adjust potentiometer throughout its entire range.

Action

Check the resistance range of the generator output frequency adjust potentiometer.

  • Measure the resistance between the generator output frequency adjust potentiometer pins using a multimeter.

1C
YES NO
No Repair

Replace the generator output frequency adjust potentiometer. Refer to the OEM service manual.

Resistance varies?

Resistance varies?

Guided Step 2 - Check the generator interface harness.

Guided Step 2A - Inspect the generator interface harness and the ECM connector pins.

Conditions

  • Run/Stop switch in the STOP position.
  • Disconnect the generator interface harness from the ECM.

Action

Inspect the generator interface harness and the ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

Repair the generator interface harness.

  • Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the generator interface harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the STOP position.
  • Disconnect the generator interface harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the generator interface harness.

Repair the generator interface harness.

  • Refer to Procedure 019-213 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Run/Stop switch in the STOP position.
  • Disconnect the generator interface harness from the ECM.
  • Disconnect the bulb from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-043 in Section 19.

A pin-to-pin short circuit on the optional gain adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE electronic service tool to verify that the fault code is inactive.

Fault Code 1411 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 04-May-2012


FAULT CODE 1412 - Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1412 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault codes. | Fault Code 1412 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM 60-pin OEM port and 60-pin connectors.
  • Disconnect the OEM harness connectors from the engine harness connectors.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or OEM harness connector or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness or the ECM.

Check all harnesses connected in series.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open optional gain adjust potentiometer RETURN (sensor return 4) circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port and 60-pin connector.
  • Disconnect the engine harness connector from the 31-pin connector.

Action

Check for pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the optional gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunction in the generator drive harness or potentiometer has occurred. Refer to the OEM service manual.

A pin-to-pin short circuit on the droop adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1412 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 04-May-2012


FAULT CODE 1418 - Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1418 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault codes. | Fault Code 1418 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1418 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the OEM harness connector from the engine harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or OEM harness connector or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness or the ECM.

Check all harnesses connected in series.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness from the 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open optional gain adjust potentiometer RETURN (sensor return 4) circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness from the 31-pin connector.

Action

Check for pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunction in the generator drive harness or Potentiometer has occurred. Refer to the OEM service manual.

A pin-to-pin short circuit on the gain adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1418 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummin® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 04-May-2012


FAULT CODE 1427 - Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1427 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1427 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1427 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the OEM harness connector from the engine harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or OEM harness connector or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, OEM harness, or the ECM.

Check all harnesses connected in series.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector overspeed shutdown SIGNAL pin and the OEM harness connector overspeed shutdown SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open overspeed shutdown SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the overspeed shutdown SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

No repair

A pin-to-pin short circuit on the overspeed shutdown SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-199 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin to ground short.

  • Measure the resistance and check for a short circuit between the overspeed shutdown SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunction in the generator drive harness or lamp has occurred. Refer to the OEM service manual.

A short circuit to ground has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1427 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 1428 - Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1428 inactive?
STEP 2. | Check the engine harness and OEM harness |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1428 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1428 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the OEM harness 31-pin connector from the engine harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or OEM harness connector or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness or the ECM.

Check all harnesses connected in series.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector low oil pressure (LOP) shutdown SIGNAL pin and the OEM harness connector low oil pressure (LOP) shutdown SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open low oil pressure (LOP) shutdown SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the low oil pressure (LOP) shutdown SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

No repair

A pin-to-pin short circuit on the low oil pressure (LOP) shutdown SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the engine harness connector from the OEM harness 31-pin connector.

Action

Check for a pin to short ground

  • Measure the resistance and check for a short circuit between the low oil pressure (LOP) shutdown SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A malfunction in the generator drive harness or lamp has occurred. Refer to the service manual.

A short circuit to ground has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1428 inactive?
YES NO

No repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 1514 - Accelerator Pedal or Lever Position Sensor 1 Circuit Frequency -Abnormal Frequency, Pulse Width, or Period

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM harness and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 10 ohms?
 | STEP 1C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2E. Check the OEM devices for frequency signal supply. | Correct OEM frequency signal?
STEP 3. | Check for an ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 1514 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1514 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM harness and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the engine harness at the 31-pin OEM connector B.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness or engine harness connector.

Clean the connector and pins.

Replace the damaged sections of harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness connector at the 31-pin OEM connector B.
  • Disconnect the accelerator or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the OEM harness 31-pin connector B to the SIGNAL pin on the pedal connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness connector at the 31-pin OEM connector B.
  • Connect the accelerator or lever position sensor to the OEM harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the SIGNAL pin on the 31-pin OEM connector B harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness connector at the 31-pin OEM connector B.
  • Connect the accelerator or lever position sensor to the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the SIGNAL pin on the 31-pin OEM connector B harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the OEM harness.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

A damaged connection has been detected in the engine harness or ECM connector.

Clean the connector and pins.

Replace the damaged sections of harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness connector at the 31-pin OEM connector B.
  • Disconnect the engine harness from the ECM 60-pin OEM port connector.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the ECM 60-pin OEM port connector of the engine harness ECM connector to the SIGNAL pin on the 31-pin connector engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness connector at the 31-pin OEM connector B.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the SIGNAL pin on the ECM 60-pin OEM port connector engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the engine harness connector at the 31-pin OEM connector B
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the SIGNAL pin on the ECM 60-pin OEM port engine harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check the OEM devices for frequency signal supply.

Conditions

  • Turn keyswitch ON.

Action

Check the frequency signal of the OEM device(s).

  • Refer to the OEM service manual.

Correct frequency signal?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM device. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check for an ECM response.

Guided Step 3A - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1514 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1514 is inactive.

Fault code 1514 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 04-May-2012


FAULT CODE 1542 - Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Fault Code 386 active?
STEP 2. | Check the original equipment manufacturer (OEM) pressure sensor and circuit. |
 | STEP 2A. Inspect the OEM pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1543 active and Fault Code 1542 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Voltage between 4.75-VDC and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1542 is active?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1542 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1542 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

See the troubleshooting tree for Fault Code 386.

Go to 2A

Guided Step 2 - Check the OEM pressure sensor and circuit.

Guided Step 2A - Inspect the OEM pressure sensor and connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1543 active and Fault Code 1542 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the OEM pressure +5 volt SUPPLY pin and the OEM pressure RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Voltage between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1542 active?
YES NO

A damaged sensor has been detected.

Replace the OEM pressure sensor. Refer to OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure RETURN pin and the OEM harness OEM pressure sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the open return circuit.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SUPPLY pin in the OEM harness ECM connector and all other pins in the ECM OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted supply circuit.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SUPPLY pin in the OEM harness ECM connector and all other pins in the ECM OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1542 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1542 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Go to the appropriate troubleshooting steps.

Repair complete.

Go to 1A

Last Modified: 05-Nov-2013


FAULT CODE 1543 - Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
STEP 2. | Check the original equipment manufacturer (OEM) pressure sensor and circuit. |
 | STEP 2A. Inspect the OEM pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1542 active and Fault Code 1543 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1543 active?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1543 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1543 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352 troubleshooting tree

Go to 2A

Guided Step 2 - Check the OEM pressure sensor and circuit.

Guided Step 2A - Inspect the OEM pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM pressure sensor from the OEM harness
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the OEM pressure +5 volt SUPPLY pin and the OEM pressure RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the OEM pressure SUPPLY pin and the OEM pressure SIGNAL pin at the OEM pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1542 active and Fault Code 1543 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1543 active?
YES NO

A damaged sensor has been detected.

Replace the OEM pressure sensor. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure RETURN pin and the OEM harness OEM pressure sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure SIGNAL pin and the OEM harness OEM pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Grater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1543 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check for fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1543 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Nov-2013


FAULT CODE 1544 - Auxiliary Pressure Sensor Input 1 - Special Instructions

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for Fault Code 1544. | Active or inactive counts of Fault Code 1544?
STEP 2. | Check the gear oil pressure alarm/derate setting. |
 | STEP 2A. Check the gear oil pressure alarm/derate setting. | Parameter set to OEM specifications?
 | STEP 2B. Check the fault codes and verify sensor condition. | Fualt Code 1544 active?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for Fault Code 1544.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1544?
YES NO

The engine protection limit has been exceeded for the OEM supplied pressure input. Refer to OEM service manual.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the gear oil pressure alarm/derate setting.

Guided Step 2A - Check the gear oil pressure alarm/derate setting.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the gear oil pressure alarm/derate setting.

  • Use INSITE™ electronic service tool to read the parameter "OEM Auxiliary Pressure Threshold".

Parameter set to OEM specifications?
YES NO

The engine protection limit has been exceeded for the OEM supplied pressure input. Refer to OEM service manual for repair instructions.

No Repair

Refer to the OEM service manual.

Go to 2B

Guided Step 2B - Check the fault codes and verify sensor condition

Conditions

  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Operate engine above 1000 RPM.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: The fault code will only go inactive if the ECM sees a known good condition for a period of time (about 5 seconds) and with the engine running above 1000 RPM.

Parameter set to OEM specifications?
YES NO

The engine protection limit has been exceeded for the OEM supplied pressure input. Refer to OEM service manual for repair instructions.

No Repair

Refer to the OEM service manual.

Go to 2B

Last Modified: 17-Jan-2012


FAULT CODE 1595 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1595 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position 5 volt supply (sensor supply 1) and the remote accelerator pedal or lever position return (sensor return 1). | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1361 active and Fault Code 1595 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness or engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1595 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1595 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged section of the harness or damaged remote accelerator pedal or lever. Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position 5 volt supply (sensor supply 1) and the remote accelerator pedal or lever position return (sensor return 1).

Conditions

  • Turn keyswitch OFF
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin to the remote accelerator pedal or lever position RETURN (sensor return 1) pin at the sensor connector of the OEM harness.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1361 active and Fault Code 1595 inactive?
YES NO

Replace the remote accelerator pedal or lever position sensor. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM prot connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Harness connector to connector continuity, pin to pin continuity check:

  • Measure the resistance of the following pin between the engine harness ECM connector and the OEM harness remote accelerator pedal or lever position sensor connector:
  • Remote accelerator pedal or lever position RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the remote accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Short circuit on one connector - pin-to-pin check:

  • Measure the resistance and check for a short circuit between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

Remote accelerator pedal or lever position 5 volt SUPPLY (sensor supply 1) pin and remote accelerator pedal or lever position SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1595 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 04-May-2012


FAULT CODE 1596 - Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1596 inactive?
STEP 2. | Check the OEM temperature sensor and circuit. |
 | STEP 2A. Inspect the OEM temperature sensor and connector pins. | Dirty or damage pins?
 | STEP 2B. Check the circuit response. | Fault Code 1369 active and Fault Code 1596 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1596 active?
STEP 3. | Check the ECM, OEM harness or engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater then 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1596 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1596 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 1596 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM temperature sensor and circuit.

Guided Step 2A - Inspect the OEM temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM temperature sensor connector from the OEM harness connector.

Action

Inspect the OEM harness and OEM temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

Replace the OEM temperature sensor. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM temperature sensor connector from the OEM harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1369 active and Fault Code 1596 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Use INSITE™ electronic service tool to read the fault codes.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1596 active?
YES NO

A damaged sensor has been detected.

Replace the OEM temperature sensor. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the engine harness connector from the 31-pin OEM connector B

Action

Inspect the harnesses and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or harnesses connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the OEM temperature sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM temperature SIGNAL pin in the engine harness ECM connector and all other pins in the harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from ECM 60-pin OEM port connector
  • Disconnect the OEM temperature sensor connector from the OEM harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the OEM temperature SIGNAL pin in the engine harness ECM connector and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1596 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1596 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 04-May-2012


FAULT CODE 1597 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM |
 | STEP 1A. Check the ECM | Fault Code 1597 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 1597 | Less than three counts?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code | Fault Code 1597 inactive?
 | STEP 2B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components
  • Turn keyswitch OFF and wait 5 seconds
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to check fault code status.

Fault Code 1597 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 1597.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 1597

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 1597.

Are there less than three counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Repair complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1597 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 1774 - Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for active fault codes. | Fault Code 1774 active?
STEP 2. | Check the engine oil priming pump circuit and sensors |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM pump switch input connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM pump switch input voltage. | 4.75-5.25-VDC?
STEP 3. | Check the engine oil priming pump |
 | STEP 3A. Check engine priming pump operation. | Pump operating?
STEP 4. | Clear the fault code |
 | STEP 4A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1774 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine oil priming circuit and sensors

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oil pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the oil pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged oil pressure sensor.

Check all harnesses connected in series.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM pump switch input connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM pump switch input connector from the engine harness connector.

Action

Inspect the engine harness and OEM pump switch input connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM pump switch input connector pins or harness connector.

Clean the connector and pins.

 No Repair

Go to 4A

Go to 3A

Guided Step 2C - Check the OEM pump switch input voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pump switch input connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the input voltage.

  • Measure the voltage between the OEM pump switch input pin and OEM pump switch return.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine priming pump.

Guided Step 3A - Check the engine oil priming pump.

Conditions

  • Turn keyswitch ON.

Action

  • Check if the enigne oil priming pump is operating.

Pump operating?
YES NO
No Repair

Troubleshoot the engine oil priming pump.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 10-Dec-2010


FAULT CODE 1843 - Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1843 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active and Fault Code 1843 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code |
 | STEP 4A. Disable the fault code. | Fault Code 1843 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the crankcase pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged crankcase pressure sensor.

Check all harnesses connected in series.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the crankcase pressure sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the crankcase pressure sensor connector from the engine harness connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor return 1) pin at the crankcase pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the crankcase pressure sensor connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

A malfunctioning crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

A pin-to-pin short circuit has been detected on the crankcase pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor supply 1) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open crankcase pressure RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Check all harnesses connected in series.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 1843 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 1844 - Crankcase Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1844 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active and Fault Code 1844 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1844 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1844 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the crankcase pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the crankcase pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of engine harness or damaged crankcase pressure sensor.

Check harnesses connected in series.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the crankcase pressure sensor connector from the engine harness connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor return 1) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the crankcase pressure sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin and the crankcase pressure SIGNAL pin at the crankcase pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the crankcase pressure sensor connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

A malfunctioning crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor return 1) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

A open or shorted crankcase pressure 5 volt SUPPLY (sensor supply 1) circuit has been detected in the engine harness.

Repair or replace the engine harness.

Troubleshoot each section of harness to determine which contains the short or open circuit.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin and the crankcase pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open circuit or a pin-to-pin short circuit has been detected on the crankcase pressure SIGNAL wire of the engine harness.

Troubleshoot each section of harness to determine which contains the open or pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 1845 - Water-In-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1845 active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the engine harness, and water-in-fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the water-in-fuel sensor resistance. | Greater than 100k ohms?
 | STEP 2C. Check the fault codes and verify water-in-fuel sensor condition. | Fault Code 1845 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1846 active and Fault Code 1845 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1845 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1845 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Inspect the engine harness and water-in-fuel sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the connector(s).

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin and the water-in-fuel indicator RETURN (sensor return 1) pin at the water-in-fuel sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the water-in-fuel sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1846 active and Fault Code 1845 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel indicator RETURN (sensor return 1) pin and the engine harness water-in-fuel indicator sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the water-in-fuel indicator sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel indicator SIGNAL pin and the engine water-in-fuel indicator SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the water-in-fuel indicator sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1845 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and chaecked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clearthe inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 1846 - Water-In-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1846 active?
STEP 2. | Check the water-in-fuel indicator sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1845 active and Fault Code 1846 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1846 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1845 active and Fault Code 1846 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1846 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1846 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel indicator sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Inspect the engine harness and water-in-fuel indicator sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the water-in-fuel indicator sensor. Refer to Procedure 019-127 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active and Fault Code 1846 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify water-in-fuel indicator sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the water-in-fuel indicator sensor connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 active?
YES NO

A malfunctioning water-in-fuel indicator sensor has been detected.

Replace the water-in-fuel indicator sensor. Refer to Procedure 019-127 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness from the water-in-fuel indicator sensor.

Action

Inspect the engine harness, water-in-fuel indicator sensor, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM connector or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active and Fault Code 1846 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the water-in-fuel indicator sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the water-in-fuel indicator sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1846 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 1847 - Engine Coolant Temperature - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1847. | Active or inactive counts of Fault Code 1847?
 | STEP 1B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1847.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1847.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1847?
YES NO

See the Engine Coolant Temperature Above Normal symptom troubleshooting tree in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Guided Step 1B - Clear the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Jun-2010


FAULT CODE 1888 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1888 is active?
STEP 2. | Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Monitor the accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the idle validation switch and or accelerator parameters are being received properly by the engine ECM. | Throttle status/idle validation parameter displays released and percent throttle parameter displays a value of zero?
 | STEP 3B. Determine if the idle validation switch and or accelerator are being received properly by the engine ECM. | Throttle status/idle validation parameter displays depressed and percent throttle parameter displays a value greater than zero?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1888 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1888 is active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the idle validation switch and or accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Determine whether the idle validation switch and accelerator position sensor are multiplexed from the appropriate OEM
  • Make sure the accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle status/idle validation

NOTE: Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the throttle is released, the throttle status/idle validation parameter must display “released” and percent throttle parameter must display a value of zero.

Throttle status/idle validation parameter displays released and percent throttle parameter displays a value of zero?
YES NO
No Repair

There is an OEM issue with the accelerator or idle validation switch or OEM vehicle electronic control unit.

Refer to the OEM service manual for further instructions.

Refer to Procedure 019-054 in Section 19.

Refer to Procedure 019-085 in Section 19.

Refer to Procedure 019-086 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the idle validation switch and or accelerator are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Determine whether the idle validation switch is multiplexed with the accelerator position sensor from the appropriate OEM
  • Make sure the accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle status/idle validation

When the throttle is depressed, the throttle status/idle validation parameter must display “depressed” and percent throttle parameter must display a value greater than zero.

Throttle status/idle validation parameter displays depressed and percent throttle parameter displays a value greater than zero?

YES NO
No Repair

There is an OEM issue with the accelerator or idle validation switch or OEM vehicle electronic control unit.

Refer to the OEM service manual for further instructions.

Refer to Procedure 019-054 in Section 19.

Refer to Procedure 019-085 in Section 19.

Refer to Procedure 019-086 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1888 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Jun-2010


FAULT CODE 1889 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1889 is active?
STEP 2. | Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Monitor the remote accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM. | Remote throttle switch parameter displays ON and percent throttle parameter displays a value of zero?
 | STEP 3B. Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM. | Remote throttle switch parameter displays ON and percent throttle parameter displays a value greater than zero?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1889 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1889 is active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM service manual, or from a saved job image
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Use INSITE™ electronic service tool to verify the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration.

Does the ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the remote accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Make sure the remote throttle switch is ON and the remote accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent throttle
  • Remote throttle status/idle validation

NOTE: Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the remote throttle is released, the remote throttle switch parameter must display ON and the percent throttle parameter must display a value of zero.

Remote throttle switch parameter displays ON and percent throttle parameter displays a value of zero?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, the remote throttle, or with the OEM vehicle electronic control unit.

Refer to the OEM service manual for further instructions.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Make sure the remote throttle switch is ON and the remote accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent throttle
  • Remote throttle switch status

NOTE: Monitor parameters can possibly not appear in the electronic service tool exactly as shown above.

When the remote throttle is depressed, the remote throttle switch parameter must display ON and the percent throttle parameter must display a value greater than zero.

Remote throttle switch parameter displays ON and percent throttle parameter displays a value greater than zero?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, or the remote throttle, or with the OEM vehicle electronic control unit.

Refer to the OEM service manual for further instructions.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1889 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool the clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Jun-2010


FAULT CODE 1891 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1891. | Fault Code 1891 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1891 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1891.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1891.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1891 active?
YES NO

Troubleshoot any additional fault codes. If necessary, change the engine lubricating oil and filter.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to reset the Centinel™ missed pulse counts monitor.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1891 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Refer to the appropriate troubleshooting steps.

Last Modified: 01-Jun-2010


FAULT CODE 1911 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Fuel is flammable. Keep all cigarettes, flames, pilot lights, arcing equipment, and switches out of the work area and areas sharing ventilation to reduce the possibility of severe personal injury or death when working on the fuel system.
WARNING

Depending on the circumstance, diesel fuel is flammable. When inspecting or performing service or repairs on the fuel system, to reduce the possibility of fire and resulting personal injury, death or property damage, never smoke or allow sparks or flames (such as pilot lights, electrical switches, or welding equipment) in the work area.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 2311, 2261, 451, or 452 active or many inactive counts of Fault Code 271, 272, 2311, 2261, 451, or 452?
STEP 2. | Clear the operation of the low pressure fuel system. |
 | STEP 2A. Check for air in fuel. | Air present in the fuel flow line?
 | STEP 2B. Check the first stage fuel filter inlet pressure. | Fuel pressure greater than 0.35 bar [5 psi]?
STEP 3. | Check the operation of the fuel pump pressurizing assembly. |
 | STEP 3A. Inspect the fuel pump pressurizing assembly o-ring. | O-ring cut or shaved?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 1911 inactive?
 | STEP 4B. Clear the inactive fault codes. | Are fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 217, 272, 2311, 2261, 451, or 452 active or many inactive counts of Fault Code 217, 272, 2311, 2261, 451, or 452?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Clear the operation of the low pressure fuel system.

Guided Step 2A - Check for air in fuel.

Conditions

  • Remove air bleed line from air bleed valve on the fuel drain manifold block.
  • Route the air bleed line into a suitable container to collect fuel.
  • Turn keyswitch ON.

Action

Inspect the fuel flow for air.

Use the following procedure in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-003 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-003 in Section 6.

Air present in the fuel flow line?
YES NO

Repair or replace the damaged line or loose connection.

Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System, and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the first stage fuel filter inlet pressure.

Conditions

  • Turn keyswitch OFF
  • Install the pressure gauge into fuel filter head port at inlet.

Action

Measure inlet pressure.

  • Measure the inlet pressure to the first stage fuel filter.

If the engine will not start, perform this test while cranking the engine.

Fuel pressure greater than 0.35 bar [5 psi]?
YES NO

Refer to the equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the operation of the fuel pump pressurizing assembly.

Guided Step 3A - Inspect the fuel pump pressurizing assembly o-ring.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump actuator.

  • Remove the fuel pump actuator.
  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System, and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.
  • Inspect the fuel pump actuator o-ring.
  • If the o-ring is cut or shaved, fuel can be bypassing the fuel pump actuator and entering the high-pressure pump.

O-ring cut or shaved?
YES NO

Replace the damaged o-ring. Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System, and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the inactive fault codes.

Fault Code 1911 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Are fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 07-Apr-2015


FAULT CODE 1978 - Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor Supply Fault Code 2185 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 1979 active and Fault Code 1978 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1978 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1978 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1978 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor Supply Fault Code 2185 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 2185.

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch ON
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector B
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active and Fault Code 1978 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector B.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 4) pin and the generator speed/load governing bias RETURN (sensor return 4) pin at the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine harness connector to the OEM 31-pin connector B.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 is active?
YES NO

A malfunction on the generator set side has been detected.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port and 60-pin connectors
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator speed/load governing bias RETURN (sensor return 4) pin and the OEM harness connector generator speed/load governing bias RETURN (sensor return 4) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator speed/load governing bias RETURN (sensor return 4) circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin to pin shorted supply circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1978 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete.

Appropriate troubleshooting steps.

Last Modified: 04-May-2012


FAULT CODE 1979 - Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor Supply Fault Code 2186 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1978 active and Fault Code 1979 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1979 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1979 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1979 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service to tool read the fault codes.

Sensor Supply Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to Fault Code 2186.

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector B
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 4) pin and the generator speed/load governing bias RETURN (sensor return 4) pin at the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the OEM 31-pin connector B
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 4) pin and the generator speed/load governing bias SIGNAL pin at the OEM 31-pin B connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 active and Fault Code 1979 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine harness connector to the OEM 31-pin connector B
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active?
YES NO

A malfunction on the generator set side has been detected.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector and 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator speed/load governing bias SIGNAL pin and the OEM 31-pin connector B generator speed/load governing bias SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator speed/load governing bias SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1979 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 04-May-2012


FAULT CODE 1992 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and over speeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of over speeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONTACT A CUMMINS® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 15 percent of rated speed, the engine must be shut off immediately or engine generator equipment damage can occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the engine. | Fault Code 1992 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1992 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if a fuel-controlled event occurred where the engine rapidly accelerated to or past 15 percent above rated speed, followed by moderate deceleration to 15 percent above rated speed.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

NOTE: Compare the engine crankshaft speed/position sensor reading with INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the engine crankshaft speed/position sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1C

Fault Codes 689 and 1376.

Guided Step 1C - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the OEM harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine crankshaft speed/position sensor.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-042 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-218 in Section 19.

No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

  • Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON.

Action

Test the engine to check if the overspeed condition is still present.

  • Test the engine to check if the overspeed condition is still present.

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1992 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes using.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 05-Oct-2015


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM, OEM harness, and engine harness. |
 | STEP 2A. Inspect the ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit in the unswitched battery supply power harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2185 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM, OEM harness, and engine harness.

Guided Step 2A - Inspect the ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness connector from the accelerator pedal or lever position sensor connector
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the engine harness connector from the 31-pin OEM connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to the OEM service manual for accelerator pedal or lever position sensor repair instructions.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) wire.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the unswitched battery supply power harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector
  • Disconnect the engine power harness connector from the ECM connector.

Action

Check for a short circuit to battery.

  • Measure the resistance between the accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin in the engine harness ECM connector and the ECM battery SUPPLY (+) pin or the power harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

A short circuit to the battery has been detected in the OEM harness or engine harness.

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2185 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 4 and return. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and circuit connected to the sensor supply 4 and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2186 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 4 and return.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and circuit connected to the sensor supply 4 and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector
  • Disconnect the engine harness connector from the 31-pin OEM connector.

Action

Inspect the harness connectors and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or damaged sensor.

Refer to circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-085 in Section 19.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the accelerator pedal or lever position sensor.

  • Refer to Procedure 019-085 in Section 19.
  • Refer to Procedure 019-086 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness.

Clean the connector and pins.

Replace the damaged section of harness.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) wire.

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

A short circuit has been detected in the accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) wire.

Troubleshoot harnesses connected in series to determine which contains the short circuit to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2186 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 2215 - Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check if engine will not start or engine starts and dies. |
 | STEP 1A. Attempt to start the engine. | Engine starts and continues running?
STEP 2. | Check the low pressure side of the fuel system. |
 | STEP 2A. Check for external fuel leaks. | Fuel leaking externally?
 | STEP 2B. Check for air in the fuel. | Air present in the fuel flow?
 | STEP 2C. Check the fuel supply pressure sensor. | Fuel inlet restriction greater than 102 mm-Hg [4 in-Hg]?
 | STEP 2D. Inspect the original equipment manufacturer (OEM) fuel supply hose and fuel tank. | Stage 1 filter restriction greater than specification?
 | STEP 2E. Check the Stage 1 filter restriction. | Stage 1 filter restriction less than specification?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2215 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check if engine will not start or engine starts and dies.

Guided Step 1A - Attempt to start the engine.

Conditions

  • Start engine.

Action

Try to start the engine.

Check if engine will not start or engine starts and stalls.

Engine starts and continues running?
YES | NO
No Repair | No Repair

Go to 2A

Reference the Engine Performance TT Symptom tree

Guided Step 2 - Check the low pressure side of the fuel system.

Guided Step 2A - Check for external fuel leaks.

Conditions

  • Operate engine.

Action

Check for external fuel leaks.

  • Check for external fuel leaks or evidence of leaks.

Fuel leaking externally?
YES NO

Repair all fuel leaks.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air in fuel.

Conditions

  • Remove air bleed line from air bleed valve on the fuel drain manifold block.
  • Route the air bleed line into a suitable container to collect fuel.
  • Turn keyswitch ON.

Action

Inspect the fuel flow for air.

Use the following procedure in Service Manual, K38, K50, QSK38 and QSK50, Bulletin 4021528. Refer to Procedure 006-003 in Section 6.

Use the following procedure in Service Manual, QSK45 and QSK60, Bulletin 4021530. Refer to Procedure 006-003 in Section 6.

Air present in the fuel flow?
YES NO

Repair all fuel leaks.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System, and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel supply pressure sensor.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor accuracy.

Start and operate the engine at high idle.

Record the fuel supply sensor reading in INSITE™ electronic service tool.

Shut the engine down and remove the fuel supply pressure sensor. Refer to Procedure 019-398 in Section 19.

Install a pressure gauge.

Start and operate the engine at high idle.

Record the fuel supply pressure reading on a pressure gauge installed in place of the fuel supply pressure sensor.

INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
YES NO

Install the fuel supply pressure sensor that was removed. Refer to Procedure 019-398 in Section 19.

Replace the fuel supply pressure sensor. Refer to Procedure 019-398 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM fuel supply hose and fuel tank.

Conditions

  • Turn keyswitch OFF.

Action

Measure fuel inlet restriction at the Stage 1 fuel filter inlet.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 006-020 in Section 6.

Stage 1 inlet restriction greater than specification?
YES NO

Refer to the equipment manufacturer service information for repair instructions.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the Stage 1 filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the Stage 1 fuel filter restriction.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 006-020 in Section 6.

Stage 1 filter restriction less than specification?
YES NO

Replace the high-pressure pump assembly.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.

Replace the Stage 1 fuel filter.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 006-075 in Section 6.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2215 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Apr-2015


FAULT CODE 2261 - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the low-pressure fuel system. |
 | STEP 1A. Check the fuel supply pressure sensor. | INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
 | STEP 1B. Check the fuel supply lines. | Any fuel lines damaged, kinked, or restricted?
 | STEP 1C. Check the stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within specification?
 | STEP 1C-1. Check the fuel filter head. |
 | STEP 1D. Check the fuel supply pressure at the fuel manifold. | Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2261 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the low- pressure fuel system.

Guided Step 1A - Check the fuel supply pressure sensor.

Conditions

  • Connect the Compuchek™ tool.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor.

  • Start and operate the engine at high idle.
  • Record the fuel supply sensor reading in INSITE™ electronic service tool.
  • Record the fuel supply pressure reading on a pressure gauge installed in place of the fuel supply pressure sensor.
  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592, for the stage 2 filters in the Measure section. Refer to Procedure 006-024 in Section 6.

INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
YES NO
No Repair

Replace the fuel supply pressure sensor.

  • Refer to Procedure 019-398 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the fuel supply lines.

Conditions

  • Turn keyswitch OFF.

Action

Examine the fuel supply lines for damages, kinks, restrictions.

  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592. Refer to Procedure 006-024 in Section 6.

Any fuel lines damaged, kinked, or restricted?
YES NO

Replace the fuel line(s).

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the stage 2 filter restriction.

  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592. Refer to Procedure 006-020 in Section 6.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Replace the stage 2 fuel filters.

  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592. Refer to Procedure 006-076 in Section 6.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Check the fuel filter head.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the stage 2 fuel filter restriction.

  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592. Refer to Procedure 006-020 in Section 6.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Replace the stage 2 fuel filter head.

  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592. Refer to Procedure 006-017 in Section 6.

Go to 2A

Go to 2A

Guided Step 1D - Check the fuel supply pressure at the fuel manifold.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel supply pressure at the fuel manifold.

  • Close the fuel supply valve.
  • Remove the M14 STOR plug from the fuel inlet manifold.
  • Install a Compuchek™ fitting, Part Number 3824844, or equivalent, in the fuel inlet manifold.
  • Connect the vacuum gauge and adapter, Part Number 3164491, or equivalent, and digital multimeter, Part Number 3164488 or 3164489, or equivalent, to the Compuchek™ fitting.
  • Open the fuel supply valve.
  • Start and operate the engine at low idle and high idle.
  • Record the fuel inlet pressure readings.

Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
YES NO

Replace the fuel pump.

  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.

Refer to the original equipment manufacturer (OEM) service manual to reduce fuel inlet pressure.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2261 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Dec-2012


FAULT CODE 2262 - Fuel Pump Delivery Pressure - Data Valid But Below Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check if engine will not start or engine starts and dies. |
 | STEP 1A. Attempt to start the engine. | Engine starts and continues running?
STEP 2. | Check the low pressure side of the fuel system. |
 | STEP 2A. Check for external fuel leaks. | Fuel leaking externally?
 | STEP 2B. Check for air in the fuel. | Air present in the fuel flow?
 | STEP 2C. Check the fuel supply pressure sensor. | INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
 | STEP 2D. Inspect the original equipment manufacturer (OEM) fuel supply hose and fuel tank. | Stage 1 inlet restriction greater than specification?
 | STEP 2E. Check the Stage 1 filter restriction. | Stage 1 inlet restriction less than specification?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2262 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check if engine will not start or engine starts and dies.

Guided Step 1A - Attempt to start the engine.

Conditions

  • Operate engine.

Action

Try to start the engine.

Check if engine will not start or engine starts and stalls.

Engine starts and continues running?
YES | NO
No Repair | No Repair

Go to 2A

Reference the Engine Performance TT Symptom tree.

Guided Step 2 - Check the low pressure side of the fuel system.

Guided Step 2A - Check for external fuel leaks.

Conditions

  • Operate engine.

Action

Check for external fuel leaks.

  • Check for external fuel leaks or evidence of leaks.

Fuel leaking externally?
YES NO

Repair all fuel leaks. Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System, and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air in fuel.

Conditions

  • Remove air bleed line from air bleed valve on the fuel drain manifold block.
  • Route the air bleed line into a suitable container to collect fuel.
  • Turn keyswitch ON.

Action

Check for air in fuel.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System, and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 006-003 in Section 6.

Air present in the fuel flow?
YES NO

Repair all fuel leaks.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System, and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel supply pressure sensor.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor accuracy.

Start and operate the engine at high idle.

Record the fuel supply sensor reading in INSITE™ electronic service tool.

Shut the engine down and remove the fuel supply pressure sensor. Refer to Procedure 019-398 in Section 19.

Install a pressure gauge.

Start and operate the engine at high idle.

Record the fuel supply pressure reading on a pressure gauge installed in place of the fuel supply pressure sensor.

INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
YES NO

Install the fuel supply pressure sensor that was removed. Refer to Procedure 019-398 in Section 19.

Replace the fuel supply pressure sensor. Refer to Procedure 019-398 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM fuel supply hose and fuel tank.

Conditions

  • Turn keyswitch OFF.

Action

Measure fuel inlet restriction at the Stage 1 fuel filter inlet.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 006-020 in Section 6.

Is the Stage 1 inlet restriction greater than specification?
YES NO

Refer to the equipment manufacturer service information for repair instructions.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the Stage 1 filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the Stage 1 fuel filter restriction.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 006-020 in Section 6.

Stage 1 filter restriction less than specification?
YES NO

Replace the high-pressure pump assembly.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 005-016 in Section 5.

Replace the Stage 1 fuel filter.

  • Use the following procedure in the QSK19, QSK19 CM850 Modular Common Rail System and QSK19 CM2150 Modular Common Rail System Service Manual, Bulletin 4021592. Refer to Procedure 006-075 in Section 6.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2262 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Apr-2015


FAULT CODE 2265 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2265 active?
STEP 2. | Check the electric lift pump for engine fuel supply. |
 | STEP 2A. Inspect the engine harness and electric lift pump for engine fuel supply connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the electric lift pump for engine fuel supply. | Less than 20 ohms?
 | STEP 2C. Check the electric lift pump for engine fuel supply diagnostic supply voltage and return circuit. | Greater than 6.0-VDC?
 | STEP 2D. Check for an open circuit in the electric lift pump for engine fuel supply return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM electric lift pump for engine fuel supply diagnostic supply voltage. | Greater than 6.0-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault code 2265 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2265 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the electric fuel control electric lift pump for engine fuel supply.

Guided Step 2A - Inspect the engine harness connector and fuel control electric lift pump for engine fuel supply connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the electric lift pump for engine fuel supply connector.

Action

Inspect the engine harness and electric lift pump for engine fuel supply connector pins for the following:

  • Loose connectors
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the electric lift pump for engine fuel supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the electric lift pump for engine fuel supply connector.

Action

Check for an open circuit in the electric lift pump for engine fuel supply connector.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL and the electric lift pump for engine fuel supply RETURN pin at the electric lift pump for engine fuel supply connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 20 ohms?
YES NO
No Repair

Replace the electric lift pump for engine fuel supply.

Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 005-045 in Section 5.

Go to 2C

Go to 4A

Guided Step 2C - Check the electric lift pump for engine fuel supply diagnostic supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the electric lift pump for engine fuel supply connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the electric lift pump for engine fuel SUPPLY pin and the electric lift pump for engine fuel supply RETURN pin at the electric lift pump for engine fuel supply connector of the engine harness.

Greater than 6.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the electric lift pump for engine fuel supply return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric lift pump for engine fuel supply connector from the engine harness connector.

Action

Measure the resistance between the engine harness electric lift pump for engine fuel supply RETURN pin and ground.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the open circuit.

Refer to the wiring harness for connector pin identification.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connectors
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM electric lift pump for engine fuel supply diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the electric lift pump for engine fuel SUPPLY pin and the electric lift pump for engine fuel supply RETURN pin at the engine harness ECM connector port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 6.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the electric lift pump for engine fuel supply from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL pin at the electric lift pump for engine fuel supply connector and the fuel lift pump SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the electric lift pump for engine fuel supply from the ECM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE electronic service tool to read the fault codes.

Fault code 2265 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2265 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 2266 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2266 active?
STEP 2. | Check the electric lift pump for engine fuel supply. |
 | STEP 2A. Inspect the engine harness and electric lift pump for engine fuel supply connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2265 is active and Fault Code 2266 is inactive?
 | STEP 2C. Check the fault codes and verify electric lift pump for engine fuel supply condition. | Fault Code 2266 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2265 active and Fault Code 2266 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2266 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2266 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the electric lift pump for engine fuel supply.

Guided Step 2A - Inspect the engine harness and electric lift pump for engine fuel supply connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the electric lift pump for engine fuel supply connector.

Action

Inspect the engine harness and electric lift pump for engine fuel supply connector pins for the following:

  • Loose connectors
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness or damaged lift pump connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electric lift pump for engine fuel supply connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 is active and Fault Code 2266 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify electric lift pump for engine fuel supply condition.

Conditions

  • Turn keyswitch OFF
  • Connect the electric lift pump for engine fuel supply connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 is active?
YES NO

A damaged electric lift pump for engine fuel supply has been detected.

Replace the electric lift pump for engine fuel supply. Use the following procedure in the QSK19, QSK19 CM850 MCRS, and QSK19 CM2150 MCRS Service Manual, Bulletin 4021592. Refer to Procedure 005-045 in Section 5.

None. Removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connectors
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged section of the harness.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2265 is active and Fault Code 2266 is inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the electric lift pump for engine fuel supply connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the electric lift pump for engine fuel supply connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the electric lift pump for engine fuel supply SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SUPPLY wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 is inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2266 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2311 active high inactive counts?
STEP 2. | Check the fuel pump pressurizing assembly 1. |
 | STEP 2A. Inspect the fuel pump pressurizing assembly 1 and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel pump pressurizing assembly 1 resistance. | Less than 5 ohms?
 | STEP 2C. Check the fuel pump pressurizing assembly 1 for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness failure. | Fault Codes 2311, 271, and/or 272 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the fuel pump pressurizing assembly 1 is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel pump pressurizing assembly 1.

Guided Step 2A - Inspect the fuel pump pressurizing assembly 1 and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Inspect the fuel pump pressurizing assembly 1, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the connector and pins.

Replace the damaged section of the harness or damaged actuator.

Refer to the wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the fuel pump pressurizing assembly 1. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel pump pressurizing assembly 1 resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check the fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin and the fuel pump pressurizing assembly 1 RETURN pin at the actuator connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the fuel pump pressurizing assembly 1. Refer to Procedure 019-117 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump pressurizing assembly 1 for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.

Action

Check the fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel pump pressurizing assembly 1. Refer to Procedure 019-117 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Reconnect the fuel pump pressurizing assembly 1 connector to the engine harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin and the fuel pump pressurizing assembly 1 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressurizing assembly 1 connector from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Check the engine harness and fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the fuel pump pressurizing assembly 1 SIGNAL pin and the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the pin to pin short.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or failure.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the fuel pump pressurizing assembly 1.

If a short or open circuit is induced while the engine is running, the fuel rail pressure relief valve will open.

Fault Codes 2311, 271, and/or 272 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the fuel pump pressurizing assembly 1. Refer to Procedure 019-117 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2377 is inactive?
STEP 2. | Check the fan control and circuit. |
 | STEP 2A. Inspect the fan control and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control. | Less than 10k ohms?
 | STEP 2C. Check the fan control diagnostic supply voltage, supply wire and return circuit. | Greater than 5.0-VDC?
 | STEP 2D. Check for an open circuit in the fan control return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM OEM harness and engine harness. |
 | STEP 3A. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2377 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fan control and circuit.

Guided Step 2A - Inspect the fan control and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fan control connector from the OEM harness connector.

Action

Inspect the OEM and engine harnesses and fan control connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness connected in series or damaged.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-045 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fan control connector from the OEM harness connector.

Action

Check fan control resistance.

  • Measure the resistance between the fan control SIGNAL and fan control RETURN pin at the fan control connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open circuit in the fan control has been detected.

Replace the fan control. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control diagnostic supply voltage, supply wire and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fan control connector from the OEM harness connector
  • Turn keyswitch ON.

Action

Check the fan control diagnostic supply voltage and return circuit.

  • Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin at the fan control connector of the OEM harness.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fan control return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fan control connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the fan control RETURN pin in the engine harness and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the fan control RETURN wire has been detected. Refer to the OEM wiring diagram for fan control RETURN wire configuration.

If the fan control RETURN is wired to the ECM, repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

If the fan control RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

  • Clean, repair or replace the OEM harness.
  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect all OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness connections.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM, OEM or engine harness connector.

Clean the connector and pins.

Replace the damaged section of any harness connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the fan control connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM fan control SIGNAL pin and the OEM harness fan control connector fan control SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control SIGNAL circuit has been detected in the OEM harness.

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector
  • Disconnect the fan control connector from the OEM harness connector.

Action

Check for a pin to pin short.

  • Measure the resistance between the fan control SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fan control SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2377 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 2474 - Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2474 inactive?
STEP 2. | Check the engine harness |
 | STEP 2A. Inspect the engine harness and turbocharger 1 speed sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code. | Fault Code 2474 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 2474 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness

Guided Step 2A - Inspect the engine harness and turbocharger 1 speed sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector for the ECM 60-pin connector
  • Disconnect the engine harness connector from the turbocharger 1 speed sensor connector.

Action

Inspect the engine harness connector, ECM connector, and turbocharger 1 speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or ECM connector or turbocharger 1 speed sensor connector.

Clean the connector and pins.

Repair or replace the damaged section of the engine harness or turbocharger 1 speed sensor.

Check all harnesses connected in series.

  • Refer to Procedure 019-390 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the turbocharger 1 speed sensor connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger 1 speed SIGNAL pin and the engine harness sensor connector turbocharger 1 speed SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector turbocharger 1 speed RETURN pin and the engine harness sensor connector turbocharger 1 speed RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open turbocharger 1 speed SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the turbocharger 1 speed sensor connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger 1 speed SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the turbocharger 1 speed SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Repair or replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the turbocharger 1 speed sensor connector.

Action

Check for a short circuit to ground..

  • Measure the resistance between the turbocharger 1 speed SIGNAL pin in the ECM engine harness connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground on the turbocharger 1 speed SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Repair or replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE electronic service tool to verify that the fault code is inactive.

Fault Code 2474 inactive?
YES NO
No Repair

Return to the appropriate fault code troubleshooting steps

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to erase the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 2557 - Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 2. | Check the pulse width modulation actuated OEM device and circuit. |
 | STEP 2A. Inspect the pulse width modulation actuated OEM device and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the pulse width modulation actuated OEM device. | Resistance within OEM specifications?
 | STEP 2C. Check the pulse width modulation actuated OEM device shift modulator diagnostic supply voltage, supply line, and return circuit. | Greater than 5-VDC?
 | STEP 2D. Check for an open circuit in the output device driver return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM OEM harness and engine harness. |
 | STEP 3A. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness or engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2557 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the pulse width modulation actuated OEM device shift modulator and circuit.

Guided Step 2A - Inspect the pulse width modulation actuated OEM device and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulation actuated OEM device connector from the OEM harness connector.

Action

Inspect the OEM and engine harnesses and pulse width modulation actuated OEM device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM device or harness connector.

Clean the connector and pins.

Replace the damaged section of harnesses connected in series or damaged solenoid.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the pulse width modulation actuated OEM device.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulation actuated OEM device connector from the OEM harness connector.

Action

Check the pulse width modulation actuated OEM device resistance.

  • Measure the resistance between the auxiliary pulse width modulation driver 1 SIGNAL pin and the auxiliary pulse width modulation driver 1 RETURN pin at the pulse width modulation actuated OEM device connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance within OEM specifications?
YES NO
No Repair

Replace the pulse width modulation actuated OEM device. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the pulse width modulation actuated OEM device diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulation actuated OEM device connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the pulse width modulation actuated OEM device diagnostic supply voltage and return circuit.

  • Measure the voltage between the auxiliary pulse width modulation driver 1 SIGNAL pin and the engine oil burn valve RETURN pin at the pulse width modulation actuated OEM device connector of the OEM harness.

Greater than 5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the output device driver return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulation actuated OEM device connector from the OEM harness connector.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Check for an open circuit.

  • Measure the resistance between the output device driver RETURN pin at the pulse width modulation actuated OEM device connector to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the harnesses connected in series.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the damaged connection.

  • Clean and repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect all OEM, ECM, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the OEM and engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harnesses connected in series.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the pulse width modulation actuated OEM device connector from the OEM harness connector.

Action

Check for a pin to ground short.

  • Measure the resistance between the auxiliary pulse width modulation driver 1 SIGNAL pin at the pulse width modulation actuated OEM device connector and the auxiliary pulse width modulation driver 1 SIGNAL pin at the engine harness ECM 60-pin OEM port connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the auxiliary pulse width modulation driver 1 SIGNAL line has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the auxiliary pulse width modulation driver 1 connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the auxiliary pulse width modulation driver 1 SIGNAL pin in the ECM 60-pin OEM port connector and all other pins in the engine 60-pin OEM port connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the auxiliary pulse width modulation driver 1 SIGNAL line has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the pin to pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2557 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 2558 - Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2558 is inactive?
STEP 2. | Check the pulse width modulated actuated OEM device and circuit. |
 | STEP 2A. Inspect the pulse width modulated actuated OEM device and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the pulse width modulated actuated OEM device. | Resistance is within OEM specifications?
 | STEP 2B-1. Check for a short to ground in the pulse width modulated actuated OEM device. |
 | STEP 2C. Check the pulse width modulated actuated OEM device diagnostic supply voltage, supply line, and return circuit. | Greater than 5-VDC?
STEP 3. | Check the ECM, OEM harness and engine harness. |
 | STEP 3A. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2558 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2558 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the pulse width modulated actuated OEM device and circuit.

Guided Step 2A - Inspect the pulse width modulated actuated OEM device and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulated actuated OEM device connector from the OEM harness connector.

Action

Inspect the OEM and engine harnesses and pulse width modulated actuated OEM device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM device or harness connector.

Clean the connector and pins.

Replace the damaged section of harnesses connected in series or damaged solenoid.

Refer to the appropriate circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-409 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the pulse width modulated actuated OEM device.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulated actuated OEM device connector from the OEM harness connector.

Action

Check the pulse width modulated actuated OEM device resistance.

  • Measure the resistance between the output auxiliary pulse width modulated driver 1 SIGNAL pin and the device driver RETURN pin at the pulse width modulated actuated OEM device connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance is within OEM specifications?
YES NO
No Repair

Replace the pulse width modulated actuated OEM device.

Refer to the OEM service manual.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a short to ground in the pulse width modulated actuated OEM device.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulated actuated OEM device connector from the OEM harness connector.

Action

Check for a pulse width modulated actuated OEM device output short to ground.

  • Measure the resistance between the auxiliary pulse width modulated device SIGNAL pin and ground at the pulse width modulated actuated OEM device connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the pulse width modulated actuated OEM device.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the pulse width modulated actuated OEM device diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pulse width modulated actuated OEM device connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the pulse width modulated actuated OEM device diagnostic supply voltage and return circuit.

  • Measure the voltage between the output auxiliary pulse width modulated driver 1 SIGNAL pin and the engine oil burn valve RETURN pin at the pulse width modulated actuated OEM device connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM, OEM harness and engine harness.

Guided Step 3A - Inspect all OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all harness connections.

Action

Inspect the OEM and engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM device harness connector.

Clean the connector and pins.

Replace the damaged section or harnesses connected in series or damaged solenoid.

Refer to the appropriate circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the pulse width modulated actuated OEM device from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the auxiliary pulse width modulated driver 1 SIGNAL pin in the engine ECM 60-pin OEM port connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the auxiliary pulse width modulated driver 1 SIGNAL line has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Refer to the appropriate circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.
  • Disconnect the pulse width modulated actuated OEM device from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the auxiliary pulse width modulated driver 1 SIGNAL pin in the engine ECM 60-pin OEM port connector and all other pins in the engine 60-pin OEM port connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the auxiliary pulse width modulated driver 1 SIGNAL line has been detected in the OEM harness or engine harness.

Troubleshoot harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the appropriate circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2558 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 2619 - Auxiliary Equipment Sensor Input 1 Engine Protection Critical - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify if the engine stop button is in the STOP position. |
 | STEP 1A. Verify if the engine stop button is in the STOP position. | Engine stop button in the STOP position?
 | STEP 1B. Check Diesel Control Unit (DCU) information. | DCU shows a stop button event or witness test?
 | STEP 1C. Check for other fault codes. | Active or inactive fault codes?
STEP 2. | Check for correct position of the air shutoff valves. |
 | STEP 2A. Check for correct position of the air shutoff valves. | Air shutoff valves in the OPEN position?
STEP 3. | Check the engine stop button for short circuit. |
 | STEP 3A. Check the engine stop button for short circuit. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 4C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Inspect the OEM harness and 23-pin connectors. | Dirty or damaged pins?
 | STEP 5B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 5C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 6. | Check the Customer Interface Box (CIB) internal wiring. |
 | STEP 6A. Check the Customer Interface Box (CIB) internal wiring between the E-stop button and the 23-pin OEM connector. | Dirty or damaged pins?
 | STEP 6B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 6C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 7. | Clear the fault codes and check for progressive damage. |
 | STEP 7A. Confirm conditions. | Snapshot data shows Fault Code 2619 was set at or below idle and 10 percent torque?
 | STEP 7B. Complete checks with engine off. | Hump hoses and turbochargers meet specifications?
 | STEP 7C. Disable the fault code. | Fault Code 2619 inactive?
 | STEP 7D. Check gaskets at load. | Damage to gaskets detected?
 | STEP 7E. Disable the fault code. | Fault Code 2619 inactive?
 | STEP 7F. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the engine stop button is in the STOP position.

Guided Step 1A - Verify the engine stop button is in the STOP position.

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Verify the engine stop button is in the STOP position.

Engine stop button in the STOP position?
YES NO

Reset the engine stop button.

 No Repair

Go to 8A

Go to 1B

Guided Step 1B - Check Diesel Control Unit (DCU) information (marine only).

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Check DCU information.

Check the event log in the DCU for an engine stop button event or an engine protection overspeed witness test. Use the following procedure in the Marine C Command Elite™ and C Command Elite Plus™ Panel Systems Master Repair Manual, Bulletin 4021617. Refer to Procedure 101-013 in Section 1.

DCU shows a stop button event or witness test?
YES NO

Reset the engine stop button or move out of test mode. Use the following procedure in the Marine C Command Elite™ and C Command Elite Plus™ Panel Systems Master Repair Manual, Bulletin 4021617. Refer to Procedure 101-013 in Section 1.

No Repair

Go to 7A

Go to 1C

Guided Step 1C - Check for other fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault code.

Active or inactive fault codes?
YES | NO
No Repair | No Repair

Troubleshoot other fault codes and return to this fault code.

Go to 2A

Guided Step 2 - Check for correct position of the air shutoff valves.

Guided Step 2A - Check for correct position of the air shutoff valves.

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Check that all of the air shutoff valves are in the OPEN position.

Air shutoff valves in the OPEN position?
YES NO
No Repair

Refer to the OEM service manual.

Go to 3A

Go to 7A

Guided Step 3 - Check the engine stop button for short a circuit.

Guided Step 3A - Check the engine stop button for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect wires from NO (Normally Open) engine stop switch terminals. The NO engine stop switch is the middle switch of the three terminals.

Action

Check for a short circuit.

  • Measure the resistance between the NO (Normally Open) switch terminals.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine stop button. Use the procedure in the Marine C Command Elite™ and C Command Elite Plus™ Panel Systems Master Repair Manual, Bulletin 4021617. Refer to Procedure 015-023 in Section 15.

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 7A

Go to 5B

Guided Step 4B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the OEM switch/dual output B pin of the engine harness connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the OEM switch/dual output B pin of the engine harness connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Inspect the OEM harness and 23-pin connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.

Action

Inspect the OEM harness and 23-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from the OEM switch/dual output B pin of the 23-pin OEM harness connector, OEM side, to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the OEM switch/dual output B pin of the 23-pin OEM harness connector, OEM side, to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the Customer Interface Box (CIB) internal wiring.

Guided Step 6A - Check the CIB internal wiring between the E-stop button and the 23-pin OEM connector (Marine).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.

Action

Inspect the 23-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 7A

Go to 6B

Guided Step 6B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23-pin connector.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from the OEM switch/dual output B pin of the 23-pin OEM harness connector, OEM side, to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the CIB harness. Refer to Procedure 019-071 in Section 19.

Go to 6C

Go to 7A

Guided Step 6C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the CIB at the 23-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the OEM switch/dual output B pin of the 23-pin OEM harness connector, OEM side, to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the CIB harness. Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes and check for progressive damage.

Guided Step 7A - Confirm conditions.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Confirm the conditions of the engine.

  • Use INSITE™ electronic service tool to view the fault code snapshot data to verify the conditions of the engine when Fault Code 2619 occured.

Snapshot data shows that Fault Code 2619 was set at or below idle and 10 percent torque?
YES NO
No Repair

Check the engine for progressive damage.

Go to 7E

Go to 7B

Guided Step 7B - Complete checks with engine OFF.

Conditions

  • Turn keyswitch OFF.

Action

Perform the following inspections:

  • Inspect the hump hoses for signs of damage or leakage.
  • Check the turbocharger shaft end clearance. Use the following procedure in the QSK45 and QSK60 Service Manual, Bulletin 4021530. Refer to Procedure 010-033 in Section 10. Use the following procedure in the QSK38 and QSK50 Service Manual, Bulletin 4021528. Refer to Procedure 010-033 in Section 10.
  • Inspect the turbocharger compressor impeller wheel.

Hump hoses and turbochargers meet specifications?
YES NO
No Repair

Replace the damaged components. Use the following procedures in the QSK45 and QSK60 Service Manual, Bulletin 4021530:

  • Refer to Procedure 010-034 in Section 10.
  • Refer to Procedure 010-035 in Section 10.

Go to 7C

Go to 7C

Guided Step 7C - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2619 is inactive.

Fault Code 2619 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 7D

Go to 1A

Guided Step 7D - Check gaskets at load.

Conditions

  • Turn keyswitch ON.

Action

Operate the engine with load and check the gaskets.

  • Start the engine and load it.
  • Check and listen for any noise associated with head gasket or aftercooler gasket leaks.

Damage to gaskets detected?
YES NO

Replace gaskets as necessary. Use the following procedures in the QSK45 and QSK60 Service Manual, Bulletin 4021530:

  • For head gasket repair: Refer to Procedure 002-021 in Section 2.
  • For aftercooler gasket repair: Refer to Procedure 010-002 in Section 10.

Use the following procedures in the QSK38 and QSK50 Service Manual, Bulletin 4021528:

  • For head gasket repair: Refer to Procedure 002-021 in Section 2.
  • For aftercooler gasket repair: Refer to Procedure 010-002 in Section 10.

No Repair

Go to 7E

Go to 7E

Guided Step 7E - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic serivce tool to verify Fault Code 2619 is inactive.

Fault Code 2619 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 7F

Go to 1A

Guided Step 7F - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting tree

Last Modified: 04-May-2012


FAULT CODE 2661 - At Least One Unacknowledged Most Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Clear the fault code. |
 | STEP 1A. Disable the fault code. | Fault Code 2261 inactive?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Clear the fault code.

Guided Step 1A - Disable the fault code.

Conditions

  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2261 inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1A

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
  • Turn keyswitch ON.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Jun-2010


FAULT CODE 2662 - At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Clear the fault code. |
 | STEP 1A. Disable the fault code. | Fault Code 2262 inactive?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Clear the fault code.

Guided Step 1A - Disable the fault code.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2262 inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1A

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
  • Turn keyswitch ON.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 06-Jun-2010


FAULT CODE 2697 - Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2697 active?
STEP 2. | Check the fault codes. |
 | STEP 2A. Perform the fault code disable procedure. | Fault Code 2697 active?
STEP 3. | Check the OEM harness and the engine harness. |
 | STEP 3A. Inspect all OEM harness and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the accelerator pedal or lever position sensor resistance. | 1500 to 3000 ohms (released), 250 to 1500 ohms (depressed)?
 | STEP 3B-1. Check the resistance of the accelerator pedal or lever position sensor. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2697 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2697 active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fault codes.

Guided Step 2A - Perform the fault code disable procedure.

Conditions

  • Turn keyswitch ON
  • All components connected.

Action

Perform the fault code disable procedure.

  • Slowly depress the accelerator pedal or lever to the full throttle position and release it completely three times.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2697 active?
YES NO
No Repair

Replace the accelerator pedal or lever assembly.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness and engine harness.

Guided Step 3A - Inspect all OEM harness and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect all harness connections.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM or engine harness.

Clean the connector and pins.

Repair or replace the damaged section of the harness.

Refer to the OEM service manual.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-071 in Section 19. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the accelerator pedal position sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Connect all harness connections
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector.

Action

Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin for identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 ohms (released) [250 to 1500 ohms (depressed)]?

Released value must be at least 1000 ohms greater than depressed value.

YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check the resistance of the accelerator pedal position sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin at the sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 ohms (released) [250 to 1500 ohms (depressed)]?

Released value must be at least 1000 ohms greater than depressed value.

YES NO

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of the harness.

Refer to Procedure 019-071 in Section 19. Refer to Procedure 019-043 in Section 19. Refer to Procedure 019-199 in Section 19.

Replace the accelerator pedal or lever assembly.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the accelerator pedal or lever position sensor connector from the OEM harness connector.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

  • Accelerator pedal or lever position 5 volt SUPPLY (sensor supply 4) pin
  • Accelerator pedal or lever position SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short circuit.

Refer to the circuit diagram or wiring diagram.

Replace the damaged section of the harness.

Refer to Procedure 019-071 in Section 19. Refer to Procedure 019-043 in Section 19. Refer to Procedure 019-199 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Turn the keyswitch OFF for 30 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 2697 is inactive.

Fault Code 2697 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Jun-2010


FAULT CODE 2734 - Start Enable Device 1 Canister Empty (Ether Injection) - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Clear the fault codes. |
 | STEP 1A. Disable fault code. | Fault Code 2734 inactive?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Clear the fault codes.

Guided Step 1A - Disable the fault code.

Conditions

Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Replace the ether canister.
  • Use INSITE™ electronic service tool to reset the ether injection value, found under ECM diagnostic test.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2734 inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1A

Guided Step 1B - Clear the inactive fault codes.

Conditions

Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2011


FAULT CODE 2735 - Exhaust Gas Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2735 inactive?
STEP 2. | Check the exhaust gas temperature sensor 1 circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor 1 circuit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor 1 resistance. | Within specification (see chart in Shop Talk)?
 | STEP 2C. Check the fault codes and verify exhaust gas temperature sensor 1 condition. | Fault Code 2735 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2736 active and Fault Code 2735 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2735 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2735 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2735 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor 1 circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor 1 circuit and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor 1 circuit connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas tepmerature sensor 1 circuit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 1 connector or harness connector.

Clean the connector and pins.

Repair or replace the damaged section of harness or damaged exhaust gas temperature sensor 1 circuit.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-013 in Section 19.
  • Refer to Procedure 019-218 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor 1 connector from the engine harness connector.

Action

Check the exhaust gas temperature sensor 1 resistance.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin and exhaust gas temperature sensor 1 circuit RETURN (sensor return 1) pin at the exhaust gas temperature sensor 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within specification (see chart in Shop Talk)?
YES NO
No Repair

Replace the exhaust gas temperature sensor 1 circuit. Refer to Procedure 019-013 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify exhaust gas temperature sensor 1 condition.

Conditions

  • Turn keyswitch OFF
  • Connect the exhaust gas temperature sensor 1 to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2735 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the malfunction.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair or replace the damaged section of harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas temperature sensor 1 SIGNAL pin and the exhaust gas temperature sensor 1 RETURN (sensor return 1) pin at the ECM connector.
  • Check for the circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 2736 active and Fault Code 2735 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port
  • Disconnect the exhaust gas temperature sensor 1 circuit connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 RETURN (sensor return 1) pin in the engine harness ECM connector and the exhaust gas temperature sensor 1 RETURN (sensor return 1) pin in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open exhaust gas temperature sensor 1 RETURN (sensor return 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port
  • Disconnect the exhaust gas temperature sensor 1 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open in the exhaust gas temperature sensor 1 SIGNAL circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port
  • Disconnect the exhaust gas temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the exhaust gas temperature sensor 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2735 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2735 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 2736 - Exhaust Gas Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2736 inactive?
STEP 2. | Check the exhaust gas temperature sensor 1 circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor 1 circuit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature sensor 1 circuit response. | Fault Code 2735 active and Fault Code 2736 inactive?
 | STEP 2C. Check the fault codes and verify exhaust gas temperature sensor 1 condition. | Fault Code 2736 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2735 active and Fault Code 2736 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2736 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2736 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2736 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor 1 circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor 1 circuit and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor 1 circuit connector from the engine harness connector.

Action

Inspect the engine harness and exhaust gas temperature sensor circuit 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 1 connector or harness connector.

Clean the connector and pins.

Replace the damaged section of the harness or the damaged exhaust gas temperature sensor 1.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.

Replace the exhaust gas temperature sensor 1. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor circuit cylinder 1 connector from the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2735 active and Fault Code 2736 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify exhaust gas temperature sensor 1 circuit condition.

Conditions

  • Turn keyswitch OFF
  • Connect the exhaust gas temperature sensor 1 connector to the engine harness connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2736 active?
YES NO

A damaged exhaust gas temperature sensor 1 has been detected.

Replace the exhaust gas temperature sensor 1. Refer to Procedure 019-013 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of the harness.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2735 active and Fault Code 2736 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port
  • Disconnect the exhaust gas temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the exhaust gas temperature sensor 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port
  • Disconnect the exhaust gas temperature sensor 1 connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector and pin location.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the exhaust gas temperature sensor 1 SIGNAL wire has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2736 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2736 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2015


FAULT CODE 2737 - Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2737. | Active or inactive counts of Fault Code 2737?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2737.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2737?
YES NO

Refer to the Exhaust Gas Temperature Above Normal symptom troubleshooting tree.

 No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 10-Mar-2011


FAULT CODE 2963 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2963. | Active or inactive counts of Fault Code 2963?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2963.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for Fault Code 2963.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2963?
YES NO

Refer to the Engine Coolant Temperature Above Normal symptom tree.

 No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 10-Mar-2011


FAULT CODE 2998 - Engine Torque Limit Feature - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine power. |
 | STEP 1A. Check for low engine power. | Fault associated with low engine power?
STEP 2. | Check if the high idle adjustment is too high. |
 | STEP 2A. High idle adjustment is too high. | Fault associated with high idle adjustment being too high?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2998 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for engine power.

Guided Step 1A - Check for low engine power.

Conditions

  • Turn keyswitch ON.

Action

Interview the operator.

  • Interview the operator to determine if there are any reports of low power.

Is fault associated with low engine power?
YES | NO
No Repair | No Repair

Reference the Engine Performance Troubleshooting Tree in Section TT

2A

Guided Step 2 - Check if the high idle adjustment is too high.

Guided Step 2A - High idle adjustment is too high.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check rated speed.

  • Check if the alternate idle speed or intermediate speed control is not beyond the rated speed.

Is the fault associated with high idle adjustment being too high?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2998 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Sep-2010


FAULT CODE 3132 - Instantaneous Estimated Brake Power - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Are there any active counts of Fault Code 3132 and/or Fault Code 327?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Are there any active counts of Fault Code 3132 and/or Fault Code 327?
YES NO

Follow troubleshooting steps for Fault Code 327.

 No Repair

Reference Fault Code 327 (Fuel Consumption Rate - Data Valid But Above Normal Operational Range - Moderately Severe Level in Section TF.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Mar-2011


FAULT CODE 3694 - Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 2. | Check the gain adjust potentiometer circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1418 active and Fault Code 3694 active?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 3694 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect the ECM, OEM harness, and engine harness connector. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3694 inactive?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault codes. | Fault Code 3694 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Reference Fault Code 187.

Go to 2A

Guided Step 2 - Check the gain adjust potentiomemter circuit

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the gain adjust potentiometer 5-volt SUPPLY (sensor supply 4) pin and the gain adjust potentiometer RETURN (sensor return 4) pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the gain adjust potentiometer 5-volt SUPPLY (sensor supply 4) and the gain adjust potentiometer SIGNAL pin at the OEM 31-pin connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1418 active and Fault Code 3694 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3694 active?
YES NO

An issue has been detected with the generator set controller. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector gain adjust potentiometer SIGNAL pin and the OEM 31-pin connector gain adjust potentiometer SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open gain adjust potentiometer SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Secion 19.

Greater than 100k ohms?
YES NO

A damaged generator drive harness or potentiometer is detected. Refer to the OEM service manual.

A pin-to-pin short circuit on the gain adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted SIGNAL circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged generator drive harness or potentiometer has been detected. Refer to the OEM service manual.

A pin-to-ground short circuit on the gain adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3694 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 3694 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 04-May-2012


FAULT CODE 3695 - Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 352 active?
STEP 2. | Check the generator output frequency adjust potentiometer. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit.. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response.. | Fault Code 1411 active and Fault Code 3695 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3695 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect the ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3695 inactive?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault codes. | Fault Code 1411 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor Supply Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Reference Fault Code 352

Go to 2A

Guided Step 2 - Check the generator output frequency adjust potentiometer circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the OEM 31-pin connector or 23-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector or 23-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator output frequency adjust potentiometer 5 volt SUPPLY (sensor supply 1) pin and the generator output frequency adjust potentiometer RETURN (sensor return 1) pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector or 23-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the generator output frequency adjust potentiometer 5 volt SUPPLY (sensor supply 1) and the generator output frequency adjust potentiometer SIGNAL pin at the OEM 31-pin connector of the engine harness.
  • Check for appropriate response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1411 active and Fault Code 3695 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the OEM 31-pin connector or 23-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3695 active?
YES NO

A malfunction on the generator set side has been detected. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin or 23-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator output frequency adjust potentiometer SIGNAL pin and the OEM 31-pin connector generator output frequency adjust potentiometer SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator output frequency adjust potentiometer SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator output frequency adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground .

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the generator output frequency adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3695 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 3695 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.

Last Modified: 10-Mar-2015


FAULT CODE 3696 - Droop Adjustment Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 352 active?
STEP 2. | Check the droop adjustment potentiometer circuit. |
 | STEP 2A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Voltage between 4.75-VDC and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1412 active and Fault Code 3696 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3696 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k Ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k Ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3696 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 3696 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 352.

Go to 2A

Guided Step 2 - Check the droop adjustment potentiometer circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the droop adjust potentiometer SUPPLY pin and the droop adjust potentiometer RETURN pin at the OEM harness connector.

Use the circuit art or a wiring diagram for connector pin identification.

Use the following procedure for general mulitmeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector or 23-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the droop adjust potentiometer SUPPLY pin and the droop adjust potentiometer SIGNAL pin at the OEM 31-pin connector or 23-pin connector of the engine harness.

Use the circuit art or a wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 active and Fault Code 3696 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the OEM 31-pin connector or 23-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 active?
YES NO

An issue has been detected with the generator set controller. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector droop adjust potentiometer SIGNAL pin and the OEM 31-pin connector or 23-pin connector droop adjust potentiometer SIGNAL pin.

Use the circuit art or a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator droop adjust potentiometer SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the circuit art or a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the droop adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector or 23-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit art or a wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the droop adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 3696 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 4615 - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK19 | 4021592
Fuel Filter Head | Refer to Procedure 006-017 | QSK19 | 4021592
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSK19 | 4021592
Fuel Supply Lines | Refer to Procedure 006-024 | QSK19 | 4021592
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK19 | 4021592
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK19 | 4022094

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the low-pressure fuel system. |
 | STEP 1A. Check the fuel supply pressure sensor. | INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2 psia] of each other?
 | STEP 1B. Check the fuel supply lines. | Any fuel lines damaged, kinked, or restricted?
 | STEP 1C. Check the Stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within specification?
 | STEP 1C-1. Check the fuel filter head. |
 | STEP 1D. Check the fuel supply pressure at the fuel inlet manifold. | Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 4615 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the low- pressure fuel system.

Guided Step 1A - Check the fuel supply pressure sensor.

Conditions

  • Connect the Compuchek™ tool.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply delivery pressure sensor.

  • Start and operate the engine at high idle.
  • Record the fuel supply sensor reading in INSITE™ electronic service tool.
  • Record the fuel supply pressure reading on a pressure gauge installed in place of the fuel supply pressure sensor.
  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592, for the stage 2 filters in the Measure section. Refer to Procedure 006-024 in the Associated Procedures Table.

INSITE™ electronic service tool and pressure gauge readings within 14 kPa [2psia] of each other?
YES NO
No Repair

Replace the fuel supply pressure sensor.

  • Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the fuel supply lines.

Conditions

  • Turn keyswitch OFF.

Action

Examine the fuel supply lines for damages, kinks, or restrictions.

  • Refer to Procedure 006-024 in the Associated Procedures Table.

Any fuel lines damaged, kinked, or restricted?
YES NO

Replace the damaged fuel line(s).

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the Stage 2 filter restriction.

  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592. Refer to Procedure 006-020 in the Associated Procedures Table.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Replace the Stage 2 fuel filters.

  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 1D

Go to 1C-1

Guided Step 1C-1 - Check the fuel filter head.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Measure the Stage 2 fuel filter restriction.

  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592. Refer to Procedure 006-020 in the Associated Procedures Table.

Stage 2 fuel filter restriction within specification?
YES NO
No Repair

Replace the Stage 2 fuel filter head.

  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592. Refer to Procedure 006-017 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 1D - Check the fuel supply pressure at the fuel inlet manifold.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel supply pressure at the fuel manifold.

  • Close the fuel supply valve.
  • Remove the M14 STOR plug from the fuel inlet manifold.
  • Install a Compuchek™ fitting, Part Number 3824844, or equivalent, in the fuel inlet manifold.
  • Connect the vacuum gauge and adapter, Part Number 3164491, or equivalent, and digital multimeter, Part Number 3164488 or 3164489, or equivalent, to the Compuchek™ fitting.
  • Open the fuel supply valve.
  • Start and operate the engine at low idle and high idle.
  • Record the fuel inlet pressure readings.

Fuel inlet pressure always less than 34.5 kPaG [5 psig]?
YES NO

Replace the fuel pump.

  • Use the following procedure the Service Manual QSK19 and QSK19 CM850 Modular Common Rail System Engines, Bulletin 4021592. Refer to Procedure 005-016 in the Associated Procedures Table.

Refer to the equipment manufacturer service information to reduce fuel inlet pressure.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 4615 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 04-Mar-2015


FAULT CODE 4688 - Water in Fuel Indicator 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4688 active?
STEP 2. | Check the water in fuel sensor and circuit. |
 | STEP 2A. Inspect the engine harness and water in fuel indicator sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 100k ohms?
 | STEP 2C. Check the fault codes and verify water in fuel sensor condition. | Fault Code 4688 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 4689 active and Fault Code 4688 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 4688 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 4688 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Inspect the water in fuel sensor and circuit.

Guided Step 2A - Inspect the water in fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Inspect the engine harness and water in fuel sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-205 in Section 19.

Replace the water in fuel sensor. Refer to the OEM service manual.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check the water in fuel indicator sensor resistance.

  • Measure the resistance between the water in fuel indicator SIGNAL pin and the water in fuel indicator RETURN (sensor return 1) pin at the water in fuel sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the water in fuel sensor.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes and verify sensor condition.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 4689 active and Fault Code 4688 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM 60-pin connector water in fuel indicator sensor RETURN (sensor return 1) pin and the engine harness water in fuel indicator sensor connector RETURN (sensor return 1) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water in fuel indicator sensor from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM 60 pin connector water in fuel indicator sensor SIGNAL pin and the water in fuel indicator SIGNAL sensor connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the water in fuel indicator sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. The cause of the fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 4688 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 10-Jan-2017


FAULT CODE 4689 - Water In Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4689 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the water in fuel indicator sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4688 active and Fault Code 4689 inactive?
 | STEP 2C. Check the fault codes and verify water in fuel indicator sensor condition. | Fault Code 4689 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 4688 active and Fault Code 4689 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 4689 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 4689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel indicator sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged sensor.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the water in fuel indicator sensor. Refer to Procedure 019-127 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel indicator sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active and Fault Code 4689 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify water in fuel indicator sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel indicator sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes and verify water in fuel indicator sensor condition.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 active?
YES NO

A malfunctioning water in fuel indicator sensor has been detected.

Replace the water in fuel indicator sensor.

  • Refer to Procedure 019-127 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the engine harness from the water in fuel indicator sensor.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM connector or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-205 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 in connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active and Fault Code 4689 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the water in fuel indicator sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water in fuel indicator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Reference the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Disconnect the water in fuel indicator sensor from the engine harness.

Action

Check for a pin short circuit to ground.

  • Measure the resistance between the water in fuel indicator SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 4689 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Troubleshoot any remaining active fault codes.

Last Modified: 12-Dec-2016


INDEX
123-fc115.htm

123-t05-115.htm

123-fc122.htm

123-t05-122.htm

123-fc123.htm

123-t05-123.htm

123-fc135.htm

123-t05-135.htm

123-fc141.htm

123-t05-141.htm

123-fc143.htm

123-t05-143.htm

123-fc144.htm

123-t05-144.htm

123-fc145.htm

123-t05-145.htm

123-fc146.htm

123-t05-146.htm

123-fc151.htm

123-t05-151.htm

123-fc153.htm

123-t05-153.htm

123-fc154.htm

123-t05-154.htm

123-fc155.htm

123-t05-155.htm

123-fc187.htm

123-t05-187.htm

123-fc195.htm

123-t05-195.htm

123-fc196.htm

123-t05-196.htm

123-fc197.htm

123-t05-197.htm

123-fc221.htm

123-t05-221.htm

123-fc222.htm

123-t05-222.htm

123-fc223.htm

123-t05-223.htm

123-fc224.htm

123-t05-224.htm

123-fc227.htm

123-t05-227.htm

123-fc234.htm

123-t05-234.htm

123-fc235.htm

123-t05-235.htm

123-fc237.htm

123-t05-237.htm

123-fc238.htm

123-t05-238.htm

123-fc245.htm

123-t05-245.htm

123-fc248.htm

123-t05-248.htm

123-fc261.htm

123-t05-261.htm

123-fc263.htm

123-t05-263.htm

123-fc265.htm

123-t05-265.htm

123-fc266.htm

123-t05-266.htm

123-fc271.htm

123-t05-271.htm

123-fc272.htm

123-t05-272.htm

123-fc285.htm

123-t05-285.htm

123-fc286.htm

123-t05-286.htm

123-fc322.htm

123-t05-322.htm

123-fc323.htm

123-t05-323.htm

123-fc324.htm

123-t05-324.htm

123-fc325.htm

123-t05-325.htm

123-fc327.htm

123-t05-327.htm

123-fc331.htm

123-t05-331.htm

123-fc332.htm

123-t05-332.htm

123-fc349.htm

123-t05-349.htm

123-fc351.htm

123-t05-351.htm

123-fc352.htm

123-t05-352.htm

123-fc386.htm

123-t05-386.htm

123-fc415.htm

123-t05-415.htm

123-fc418.htm

123-t05-418.htm

123-fc426.htm

123-t05-426.htm

123-fc431.htm

123-fc431iss.htm

123-t05-431iss.htm

123-fc431niss.htm

123-t05-431niss.htm

123-fc441.htm

123-t05-441.htm

123-fc442.htm

123-t05-442.htm

123-fc449.htm

123-t05-449.htm

123-fc451.htm

123-t05-451.htm

123-fc452.htm

123-t05-452.htm

123-fc488.htm

123-t05-488.htm

123-fc489.htm

123-t05-489.htm

123-fc497.htm

123-t05-497.htm

123-fc521.htm

123-t05-521.htm

123-fc522.htm

123-t05-522.htm

123-fc527.htm

123-t05-527.htm

123-fc529.htm

123-t05-529.htm

123-fc546.htm

123-t05-546.htm

123-fc547.htm

123-t05-547.htm

123-fc556.htm

123-t05-556.htm

123-fc559.htm

123-t05-559.htm

123-fc599.htm

123-t05-599.htm

123-fc611.htm

123-t05-611.htm

123-fc689.htm

123-t05-689.htm

123-fc731.htm

123-t05-731.htm

123-fc1117.htm

123-t05-1117.htm

123-fc1357.htm

123-t05-1357.htm

123-fc1358.htm

123-t05-1358.htm

123-fc1359.htm

123-t05-1359.htm

123-fc1361.htm

123-t05-1361.htm

123-fc1369.htm

123-t05-1369.htm

123-fc1373.htm

123-t05-1373.htm

123-fc1376.htm

123-t05-1376.htm

123-fc1381.htm

123-t05-1381.htm

123-fc1411.htm

123-t05-1411.htm

123-fc1412.htm

123-t05-1412.htm

123-fc1418.htm

123-t05-1418.htm

123-fc1427.htm

123-t05-1427.htm

123-fc1428.htm

123-t05-1428.htm

123-fc1514.htm

123-t05-1514.htm

123-fc1542.htm

123-t05-1542.htm

123-fc1543.htm

123-t05-1543.htm

123-fc1544.htm

123-t05-1544.htm

123-fc1595.htm

123-t05-1595.htm

123-fc1596.htm

123-t05-1596.htm

123-fc1597.htm

123-t05-1597.htm

123-fc1774.htm

123-t05-1774.htm

123-fc1843.htm

123-t05-1843.htm

123-fc1844.htm

123-t05-1844.htm

123-fc1845.htm

123-t05-1845.htm

123-fc1846.htm

123-t05-1846.htm

123-fc1847.htm

123-t05-1847.htm

123-fc1852.htm

00-t05-1852.htm

123-fc1888.htm

123-t05-1888.htm

123-fc1889.htm

123-t05-1889.htm

123-fc1891.htm

123-t05-1891.htm

123-fc1911.htm

123-t05-1911.htm

123-fc1978.htm

123-t05-1978.htm

123-fc1979.htm

123-t05-1979.htm

123-fc1992.htm

123-t05-1992.htm

123-fc2185.htm

123-t05-2185.htm

123-fc2186.htm

123-t05-2186.htm

123-fc2215.htm

123-t05-2215.htm

123-fc2261.htm

123-t05-2261.htm

123-fc2262.htm

123-t05-2262.htm

123-fc2265.htm

123-t05-2265.htm

123-fc2266.htm

123-t05-2266.htm

123-fc2311.htm

123-t05-2311.htm

123-fc2377.htm

123-t05-2377.htm

123-fc2474.htm

123-t05-2474.htm

123-fc2557.htm

123-t05-2557.htm

123-fc2558.htm

123-t05-2558.htm

123-fc2562.htm

00-t05-2562.htm

123-fc2619.htm

123-t05-2619.htm

123-fc2661.htm

123-t05-2661.htm

123-fc2662.htm

123-t05-2662.htm

123-fc2697.htm

123-t05-2697.htm

123-fc2734.htm

123-t05-2734.htm

123-fc2735.htm

123-t05-2735.htm

123-fc2736.htm

123-t05-2736.htm

123-fc2737.htm

123-t05-2737.htm

123-fc2963.htm

123-t05-2963.htm

123-fc2998.htm

123-t05-2998.htm

123-fc3132.htm

123-t05-3132.htm

123-fc3694.htm

123-t05-3694.htm

123-fc3695.htm

123-t05-3695.htm

123-fc3696.htm

123-t05-3696.htm

123-fc4615.htm

123-t05-4615.htm

123-fc4642.htm

00-t05-4642.htm

123-fc4688.htm

123-t05-4688.htm

123-fc4689.htm

123-t05-4689.htm

123-fc5366.htm

00-t05-5366.htm

123-fc5367.htm

00-t05-5367.htm

123-fc5633.htm

123-fc5633aux.htm

00-t05-5633.htm

123-fc5633prop.htm

00-t05-5633.htm

123-fc5634.htm

123-fc5634aux.htm

00-t05-5634.htm

123-fc5634prop.htm

00-t05-5634.htm

123-fc5635.htm

123-fc5635aux.htm

00-t05-5635.htm

123-fc5635prop.htm

00-t05-5635.htm

123-fc5932.htm

00-t05-5932.htm

123-fc5946.htm

00-t05-5946.htm