G5.9, G855, GTA855 and G8.3 CM558/CM2358 Electronic Control System K

Last Modified: 30 October 2018

Copyright © 2018
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change

FAULT CODE 121

Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10 LAMP: Yellow SRT: | Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change. Invalid engine speed signal detected on the engine speed sensor signal pins at the ECM connector. | Engine is shutdown and will not start.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor monitors the engine speed, then passes this information to the engine control module (ECM) through the engine harness.

Component Location

The engine speed sensor is located on the flywheel housing on the left side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine speed sensor is a magnetic sensor that senses the ring gear teeth on the flywheel to determine engine speed.

Refer to Troubleshooting Fault Code t05-121.

Last Modified: 28-Aug-2012
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the engine oil pressure sensor pin at the engine control module (ECM). | No engine protection for engine oil rifle pressure 1.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil pressure sensor is located on the left side of the block, below the ignition control module. Refer to Procedure 100-002 in Section E.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault goes inactive.
  • Engines operating in altitudes above 1524 m [5000 ft] with auxiliary lubricating oil filtering devices can experience low lubricating oil pressure faults at idle conditions.
Refer to Troubleshooting Fault Code t05-135.

Last Modified: 28-Aug-2012


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the engine oil pressure sensor pin at the engine control module (ECM). | No engine protection for engine oil rifle pressure 1.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The engine oil rifle pressure 1 sensor is used by the ECM to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The lubricating oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil pressure sensor is located on the left side of the block, below the ignition control module. Refer to Procedure 100-002 in Section E.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault code goes inactive.
  • Engines operating in altitudes above 1524 m [5000 ft] with auxiliary lubricating oil filtering devices can experience low lubricating oil pressure faults at idle conditions.
Refer to Troubleshooting Fault Code t05-141.

Last Modified: 28-Aug-2012


Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 142

Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 142 PID: P100 SPN: 100 FMI: 16 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure above the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the left side of the block, below the ignition control module. Refer to Procedure 100-002 in Section E.

Shop Talk

Does the fault occur only in cold weather? If so, allow the lubricating oil to warm up and see if the fault goes inactive.

Refer to Troubleshooting Fault Code t05-142.

Last Modified: 28-Aug-2012


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure below the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure 1 Sensor Circuit

Circuit Description

The oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the left side of the block, below the ignition control module. Refer to Procedure 100-002 in Section E.

Shop Talk

Verify with the driver the engine speed at which the fault occurs. If the engine is being operated at too low of a speed, the oil pressure can drop below the engine protection limits.

Possible causes of this fault code include:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be changed.
Refer to Troubleshooting Fault Code t05-143.

Last Modified: 28-Aug-2012


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No engine protection for coolant temperature 1.
Engine Coolant Temperature Sensor 1 Circuit

Circuit Description

The engine control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the wiring diagram sensor specifications if the sensor is functioning properly.
  • This fault code can log in extremely cold weather.
Refer to Troubleshooting Fault Code t05-144.

Last Modified: 28-Aug-2012


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4 LAMP: Amber SRT: | Engine Coolant Temperature 1 SensorCircuit - Voltage Below Normal or Shorted to Low Source. | No engine protection for engine coolant temperature 1.
Engine Coolant Temperature Sensor 1 Circuit

Circuit Description

The engine control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the wiring diagram sensor specifications if the sensor is functioning properly.
Refer to Troubleshooting Fault Code t05-145.

Last Modified: 28-Aug-2012


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High coolant temperature warning. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the wiring diagram sensor specifications if the sensor is functioning properly.
Refer to Troubleshooting Fault Code t05-146.

Last Modified: 28-Aug-2012


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. High coolant temperature critical. | Engine is shutdown.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the right side of the block, in the thermostat housing. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed will compare to the wiring diagram sensor specifications if the sensor is functioning properly.

The engine protection shutdown for the coolant temperature is a customer feature and will only be enabled at the customer's request. This sensor will deactivate the fuel control valve if this feature is utilized by the original equipment manufacturer (OEM).

Refer to Troubleshooting Fault Code t05-151.

Last Modified: 28-Aug-2012


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold air temperature sensor pin at the engine control module (ECM). | Possible reduced engine performance.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with pressure). Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the wiring diagram sensor specification if the sensor is functioning properly.
Refer to Troubleshooting Fault Code t05-153.

Last Modified: 28-Aug-2012


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The ECM uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with pressure). Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature.
  • See sensor specifications on wiring diagram.
Refer to Troubleshooting Fault Code t05-154.

Last Modified: 28-Aug-2012


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold temperature above engine protection critical limit. | Engine is shutdown.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure). Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature
  • See the wiring diagram for sensor specifications.

This sensor can control the engine fan if the OEM utilizes this feature within the ECM. The engine protection shutdown feature is customer-enabled and will require enabling at the customer's request.

Refer to Troubleshooting Fault Code t05-155.

Last Modified: 28-Aug-2012


Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1665

Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1665 PID: S326 SPN: 3241 FMI: 4/4 LAMP: SRT: | Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the catalyst inlet sensor circuit. | No effect on performance.
Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment catalyst inlet temperature sensor is located in the aftertreatment system. It is located at the inlet of the aftertreatment catalyst. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment catalyst inlet temperature sensor signal voltage is less than 0.1-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment catalyst inlet temperature sensor reading is used.
  • Active regeneration of the aftertreatment particulate trap is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

The aftertreatment catalyst inlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return wire can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-1665.

Last Modified: 28-Aug-2012


Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1666

Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1666 PID: S326 SPN: 3241 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst inlet temperature sensor circuit. | None on performance.
Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment catalyst inlet temperature sensor is located in the aftertreatment system. It is located at the inlet of the aftertreatment catalyst. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment catalyst inlet temperature signal voltage is greater than 4.97-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber warning light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment catalyst inlet temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber warning light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

The aftertreatment catalyst inlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return wire can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-1666.

Last Modified: 28-Aug-2012


Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1674

Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1674 PID: S327 SPN: 3249 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment outlet temperature sensor circuit. | Loss of performace may occur.
Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor or thermistor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment outlet temperature signal voltage is less than 0.1-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber warning light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment outlet temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber warning light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

The aftertreatment outlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-1674.

Last Modified: 28-Aug-2012


Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1675

Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1675 PID: S327 SPN: 3249 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source. Possible loss of engine performance. | Active aftertreatment diesel particulate filter regeneration will be disabled.
Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment outlet temperature signal voltage is greater than 4.97-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber warning light immediately when the diagnostic runs and fails
  • A default value is used for the aftertreatment outlet temperature reading
  • Active regeneration of the aftertreatment diesel particulate filter is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber warning light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-1675.

Last Modified: 20-Aug-2014


Engine Throttle Control Actuator - Condition Exists

FAULT CODE 1739

Engine Throttle Control Actuator - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1739 PID: SPN: 3464 FMI: 31 LAMP: Amber SRT: | Engine Throttle Control Actuator - Condition Exists. Problem detected in the engine throttle actuator or the circuitry connected to it. | Possible reduced engine performance, engine shut down, or engine will possibly not start.
Engine Throttle Control Actuator Circuit
F-Series Governor Engine Throttle Control Actuator Circuit

Circuit Description

The circuit covered in this procedure sends power and command signals to the engine throttle control actuator, and also receives a return back from it.

Component Location

The GTA855 CM558/CM2358 engine throttle control actuator is located on the top of the engine between the turbocharger crossover connection and the aftercooler housing.

The G5.9, G8.3, G855 CM558/CM2358 engine throttle control actuator is located on the top of the engine between the intake manifold and the carburator. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code commonly occurs in parallel with other faults regarding the engine throttle control actuator. If this troubleshooting does not resolve the fault, the cause can be related to another engine system.

Refer to Troubleshooting Fault Code t05-1739.

Last Modified: 23-Jan-2014


Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 177

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 177 PID: S58 SPN: 698 FMI: 7 LAMP: Red SRT: | Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment. The throttle plate has moved unexpectedly. | Engine will shut down.
L Series - Electronic Throttle Control Actuator Circuit
F Series - Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the electronic throttle control actuator; it is both an input and output device.

Component Location

The electronic throttle control actuator is located after the fuel housing and before the intake manifold inlet. Use the engine diagrams for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The electronic throttle control actuator is a pulse-width modulated component. Within the actuator is the throttle position sensor circuit. This is a non-repairable sensor and requires replacement of the actuator when damaged.

Refer to Troubleshooting Fault Code t05-177.

Last Modified: 28-Aug-2012


Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1776

Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1776 PID: SPN: 2634 FMI: 3 LAMP: Amber SRT: | Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Short to ground detected on power relay driver circuit ECM connector B. | Engine will possibly not start or will possibly be hard to start.
Power Relay Driver Circuit

Circuit Description

The ECM uses the power relay driver circuit to send power to the exhaust oxygen sensor heater circuit.

Component Location

The power relay driver circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The power relay driver circuit can be used by the OEM control panel, so issues with the panel can activate this fault code.

Refer to Troubleshooting Fault Code t05-1776.

Last Modified: 28-Aug-2012


Power Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1777

Power Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1777 PID: SPN: 2634 FMI: 4 LAMP: Amber SRT: | Power Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. Short to ground detected on power relay driver circuit ECM connector B battery conservation relay supply. | Engine is shutdown.
Power Relay Driver Circuit

Circuit Description

The ECM uses the power relay driver circuit to send power to the exhaust oxygen sensor heater circuit.

Component Location

The power relay driver circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The power relay driver circuit can be used by the OEM control panel, so issues with the panel can activate this fault code.

Refer to Troubleshooting Fault Code t05-1777.

Last Modified: 28-Aug-2012


Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

FAULT CODE 1791

Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1791 PID: SPN: 1204 FMI: 31 LAMP: Red SRT: | Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists. The engine was unable to meet the required speed or load demand. | Engine is shut down.
Electrical Load

Circuit Description

N/A

Component Location

N/A

Shop Talk

This fault code will commonly occur in parallel with other faults. If this troubleshooting does not resolve the fault, the cause could be related to another engine system. A misfire in the ignition system is a common cause for this fault as the unburned fuel will enter the exhaust and cause the exhaust oxygen sensor to sense a rich mixture and command the air/fuel to lean out, which will then result in a loss of power and cause the engine to shut down.

Refer to Troubleshooting Fault Code t05-1791.

Last Modified: 28-Aug-2012


Engine Oil Temperature Sensor 1 Circuit, Too Cold For High Idle - Condition Exists

FAULT CODE 1824

Engine Oil Temperature Sensor 1 Circuit, Too Cold For High Idle - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1824 PID: 175 SPN: 175 FMI: 31 LAMP: SRT: | Engine Oil Temperature Sensor 1 Circuit, Too Cold For High Idle - Condition Exists. The oil has not warmed up sufficiently for the engine to increase speed. | Engine will not operate at high idle.
Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block on the fuel system side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

For temperature sensor information please reference the appropriate wiring diagram.

Refer to Troubleshooting Fault Code t05-1824.

Last Modified: 28-Aug-2012


Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1858

Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1858 PID: None SPN: 3217 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance.
Inlet Oxygen Sensor

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The oxygen concentration sensors are located on either side of the three-way catalyst. Refer to Procedure 100-002 in Section E.

Shop Talk

The oxygen sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed loop operation of the engine.

Refer to Troubleshooting Fault Code t05-1858.

Last Modified: 28-Aug-2012


Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1859

Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1859 PID: None SPN: 3217 FMI: 4 LAMP: Amber SRT: | Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced performance.
Aftertreatment Inlet Oxygen Concentration Sensor

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The aftertreatment inlet oxygen concentration sensors are located on either side of the three-way catalyst. Refer to Procedure 100-002 in Section E.

Shop Talk

The aftertreatment inlet oxygen concentration sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed loop operation of the engine.

Refer to Troubleshooting Fault Code t05-1859.

Last Modified: 28-Aug-2012


Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1861

Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1861 PID: None SPN: 3217 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Data Erratic, Intermittent, or Incorrect | Possible reduced performance.
Aftertreatment Inlet Oxygen Concentration Sensor

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The aftertreatment inlet oxygen concentration sensors are located in the exhaust, on both sides of the three-way catalyst. Refer to Procedure 100-002 in Section E.

Shop Talk

The oxygen sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed-loop operation of the engine.

Refer to Troubleshooting Fault Code t05-1861.

Last Modified: 28-Aug-2012


Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1862

Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1862 PID: None SPN: 3227 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced performance.
Aftertreatment Outlet Oxygen Concentration Sensor

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The outlet heated aftertreatment outlet oxygen concentration sensor is located in the exhaust tubing after the catalyst. Refer to Procedure 100-002 in Section E.

Shop Talk

The aftertreatment outlet oxygen concentration sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed loop operation of the engine.

Refer to Troubleshooting Fault Code t05-1862.

Last Modified: 28-Aug-2012


Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1863

Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1863 PID: None SPN: 3227 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced performance.
Aftertreatment Outlet Oxygen Concentration Sensor

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The aftertreatment outlet oxygen concentration sensor is located in the exhaust tubing after the catalyst. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

The oxygen sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed loop operation of the engine.

Refer to Troubleshooting Fault Code t05-1863.

Last Modified: 29-Aug-2012


Aftertreatment Outlet Oxygen Concentration - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1864

Aftertreatment Outlet Oxygen Concentration - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1864 PID: None SPN: 3217 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Concentration - Data Erratic, Intermittent, or Incorrect | Possible reduced performance.
Aftertreatment Outlet Oxygen Concentration Sensor

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The aftertreatment outlet oxygen concentration sensor is located in the exhaust tubing after the catalyst. Refer to Procedure 100-002 in Section E.

Shop Talk

The aftertreatment outlet oxygen concentration sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed-loop operation of the engine.

Refer to Troubleshooting Fault Code t05-1864.

Last Modified: 28-Aug-2012


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 3510 FMI: 4 LAMP: Yellow SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance, shutdown or loss of engine protection.
Sensor Supply 2 Circuit

Circuit Description

This circuit is the voltage supply for engine oil temperature/pressure sensor and the pre- and post-catalyst temperature sensors.

Component Location

The sensor supply 2 circuit is contained in the wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The voltage supply on the engine is broken up into Sensor Supply 1, Sensor Supply 2, and Sensor Supply 3.

Refer to Troubleshooting Fault Code t05-187.

Last Modified: 28-Aug-2012


Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1965

Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1965 PID: S326 SPN: 3241 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Possible catalyst damage.
Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5-volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment catalyst outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is operating in closed loop mode.

Conditions for Setting the Fault Codes

The aftertreatment catalyst outlet temperature sensor reading exceeds a specified temperature for a specified amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp and the fault code will be set to inactive when the keyswitch is cycled or the temperature drops below the specified temperature.

Shop Talk

Possible causes of this fault code include:

  • Aftertreatment catalyst outlet temperature sensor failed in-range
  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • The engine is operating too rich.
Refer to Troubleshooting Fault Code t05-1965.

Last Modified: 04-Aug-2014


Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1966

Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1966 PID: 326 SPN: 3241 FMI: 0 LAMP: Red SRT: | Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level. Engine exhaust gas temperatures entering the aftertreatment system are above the engine protection limits. | Possible catalyst damage.
Exhaust Gas Temperature Sensors

Circuit Description

The exhaust gas temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The exhaust gas temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5-volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The exhaust gas temperature sensors are located in the aftertreatment system, before and after the catalyst. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating in a closed loop mode.

Conditions for Setting the Fault Codes

The ECM detects exhaust gas temperatures in the aftertreatment system are above a calibratible value for a calibratible amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp after the diagnostic runs and fails.
  • The engine will shut down if the high temperature condition exists for a specified amount of time.
  • The engine will shut down if the high temperature condition continues to exist.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE lamp and the fault code will be set to inactive when the temperatures in the aftertreatment system drop below a calibratible temperature value. The fault code will also be set inactive following a key cycle or if the high temperature condition no longer exists.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system. The catalyst may be located too close to the engine exhaust outlet.

Possible causes of this fault code include:

  • Excessive engine oil being introduced into the exhaust system from the engine

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the package for potential malfunction and inspect for reuse.

Refer to Troubleshooting Fault Code t05-1966.

Last Modified: 04-Aug-2014


Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1968

Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1968 PID: 327 SPN: 3249 FMI: 16 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Possible catalyst damage.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is low. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a high temperature. When the exhaust gas temperature is high, the sensor resistance is high. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a low temperature.

Component Location

The post catalyst temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst. See equipment manufacturer service information for a detailed component location view.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously.

Conditions for Setting the Fault Codes

  • The post catalyst temperature sensor reading exceeds a specified temperature for a specified amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp and the fault code will be set to inactive when the keyswitch is cycled or the temperature drops below a specified temperature.

Shop Talk

Possible causes of this fault code include:

  • Post catalyst outlet temperature sensor malfunctioned in-range
  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • The engine is operating too rich.
Refer to Troubleshooting Fault Code t05-1968.

Last Modified: 04-Aug-2014


Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1969

Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1969 PID: SPN: FMI: 16 LAMP: Red SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level. | Possible catalyst damage.
Aftertreatment Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is low. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or high temperature. When the exhaust gas temperature is high, the sensor resistance is high. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a low temperature.

Component Location

The post catalyst temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst. See equipment manufacturer service information for a detailed component location view.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously.

Conditions for Setting the Fault Codes

  • The post catalyst temperature sensor reading exceeds a specified temperature for a specified amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp after the diagnostic runs and fails.
  • The engine will shut down if the high temperature condition continues to exist.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red CHECK ENGINE lamp and the fault code will be set to inactive when the keyswitch is cycled or the temperature drops below a specified temperature.

Shop Talk

Possible causes of this fault code include:

  • Post catalyst outlet temperature sensor malfunctioned in-range.
Refer to Troubleshooting Fault Code t05-1969.

Last Modified: 15-Aug-2014


Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1978

Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1978 PID: SPN: 3938 FMI: 3 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source. Above normal voltage detected in the generator speed/load governing bias circuit. | Possible reduced engine performance.
Generator Speed/Load Governing Bias Circuit

Circuit Description

The ECM uses the signal from this circuit to determine the commanded engine speed, and equates this to a throttle position, which it commands to the throttle.

Component Location

Not applicable.

Shop Talk

This is a 0 to 5 volt engine speed signal circuit that is controlled by a customer supplied voltage governing device, such as a speed potentiometer, or a digital controller (PLC). This 0 to 5 volt signal is them sent to the ECM, which uses it to determine a commanded engine speed. The ECM then sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue the ECM, engine wiring, customer interface box wiring, OEM wiring, and the customer supplied voltage governing device will need to be checked.

Refer to Troubleshooting Fault Code t05-1978.

Last Modified: 28-Aug-2012


Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1979

Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1979 PID: SPN: 3938 FMI: 4 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source. Below normal voltage detected in the generator speed/load governing bias circuit. | Possible reduced engine performance.
Generator Speed/Load Governing Bias Circuit

Circuit Description

The ECM uses the signal from this circuit to determine the commanded engine speed, and equates this to a throttle position, which it commands to the throttle.

Component Location

Not applicable

Shop Talk

This is a 0 to 5 volt engine speed signal circuit that is controlled by a customer supplied voltage governing device, such as a speed potentiometer, or a digital controller (PLC). This 0 to 5 volt signal is them sent to the ECM, which uses it to determine a commanded engine speed. The ECM then sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue the ECM, engine wiring, customer interface box wiring, OEM wiring, and the customer supplied voltage governing device will need to be checked.

Refer to Troubleshooting Fault Code t05-1979.

Last Modified: 28-Aug-2012


Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1982

Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1982 PID: None FMI: 0 LAMP: Red SRT: | Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Most Severe Level | Engine shutdown. Possible catalyst damage.
Pre and Post Catalyst Temperature Sensors

Circuit Description

The electronic control module (ECM) uses the aftertreatment exhaust gas inlet and outlet temperature sensors to determine the temperature difference between the inlet and outlet of the three-way catalyst.

Component Location

The Aftertreatment Exhaust Gas Inlet and Outlet Temperature Sensors are located in the exhaust tubing on each side of the three-way catalyst. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

It is normal for the temperature of the exhaust gases increase as they flow through the three-way catalyst element. If there is too great of a rise, catalyst damage may result.

Conditions for Setting the Fault Codes

The difference between the aftertreatment catalyst outlet temperature sensor reading and the aftertreatment catalyst inlet temperature reading exceeds 10°C [50°F] for 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will shut down if the high temperature condition exists for a calibratible amount of time.

Conditions for Clearing the Fault Code

N/A

Shop Talk

Possible causes of this fault code include:

  • One or more cylinders may be misfiring
  • Engine may be operating too rich.
Refer to Troubleshooting Fault Code t05-1982.

Last Modified: 28-Aug-2012


Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1983

Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1983 PID: None SPN: 3050 FMI: 16 LAMP: Amber SRT: | Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level | Engine shutdown. Possible catalyst damage.
Pre and Post Catalyst Temperature Sensors

Circuit Description

The electronic control module (ECM) uses the aftertreatment exhaust gas inlet and outlet temperature sensors to determine the temperature difference between the inlet and outlet of the three-way catalyst.

Component Location

The aftertreatment exhaust gas inlet and outlet temperature sensors are located in the exhaust tubing on each side of the three-way catalyst. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

It is normal for the temperature of the exhaust gases to increase as they flow through the three-way catalyst element. If there is too great of a rise, catalyst damage may result.

Conditions for Setting the Fault Codes

The difference between the aftertreatment catalyst outlet temperature sensor reading and the aftertreatment catalyst inlet temperature reading exceeds 10°C [50°F] for 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will shut down if the high temperature condition exists for a calibratible amount of time.

Conditions for Clearing the Fault Code

Shop Talk

Possible causes of this fault code include:

  • One or more cylinders may be misfiring
  • Engine may be operating too rich.
Refer to Troubleshooting Fault Code t05-1983.

Last Modified: 28-Aug-2012


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the oil temperature signal pin at the ECM. | None on performance. No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block on the fuel system side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the wiring diagram specifications if the sensor is functioning properly.
Refer to Troubleshooting Fault Code t05-212.

Last Modified: 28-Aug-2012


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the oil temperature signal pin at the engine control module (ECM). | None on performance. No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The ECM uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block on the fuel system side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the wiring diagram specifications if the sensor is to function properly.
Refer to Troubleshooting Fault Code t05-213.

Last Modified: 28-Aug-2012


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0 LAMP: Red SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. | Progressive power derate increasing in severity from the time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red stop lamp starts flashing.
Engine Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block, on the fuel system side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the wiring diagram specifications if the sensor is functioning properly.

The engine protection shutdown for oil temperature is a customer feature and will only be enabled at the customer's request. This feature will deactivate or disable the fuel control valve if this feature is utilized by the OEM.

Refer to Troubleshooting Fault Code t05-214.

Last Modified: 28-Aug-2012


Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

FAULT CODE 2217

Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2217 PID: SPN: 630 FMI: 31 LAMP: Amber SRT: | Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists. Internal ECM error. | Possible engine shutdown, loss of performance, or engine will possibly not start.
Engine Control Module (ECM)

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-2217.

Last Modified: 28-Aug-2012


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: 232 SPN: 3510 FMI: 3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on sensor supply number 2 circuit. | Possible reduced engine performance, shutdown, or loss of engine protection.
Sensor Supply 2 Circuit

Circuit Description

This circuit is the voltage supply for the exhaust gas stack temperature sensor and the air intake humidity/temperature sensor.

Component Location

The sensor supply voltage 5 volt circuit is contained in the wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine voltage supplies is broken up into Sensor Supply 1, and Sensor Supply 2.

Refer to Troubleshooting Fault Code t05-227.

Last Modified: 28-Aug-2012


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: SPN: 633 FMI: 31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. | Possible reduced engine performance.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the ECM that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing in the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 in Section E.

Shop Talk

If this fault code occurs during a test, verify that all connectors are clean and free of corrosion before replacing components. This fault code can become active for any of the following reasons:

  • Electronic fuel control valve high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Electronic fuel control valve with low internal resistance
  • Electronic fuel control valve or engine harness that has shorted to ground.

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is malfunctioning.

Refer to Troubleshooting Fault Code t05-2311.

Last Modified: 28-Aug-2012


Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2315

Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2315 PID: SPN: 623 FMI: 3 LAMP: Amber SRT: | Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source. | Red lamp will not illuminate.
Red Stop Lamp Driver Circuit

Circuit Description

The ECM uses the diagnostic lamp to flash out active fault codes.

Component Location

The diagnostic lamp is an original equipment manufacturer (OEM) component that is located on the OEM control panel. Refer to Procedure 100-002 in Section E.

Shop Talk

Proper diagnostic lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code t05-2315.

Last Modified: 28-Aug-2012


Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2316

Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2316 PID: SPN: 624 FMI: 3 LAMP: Amber SRT: | Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on diagnostic lamp of the ECM connector. | Amber lamp will not illuminate.
ECM Diagnostic Lamp Circuit

Circuit Description

The ECM uses the amber warning lamp to inform the operator about active faults on the engine.

Component Location

The lamp is an original equipment manufacturer (OEM) component that is located on the OEM control panel.

Shop Talk

Proper lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code t05-2316.

Last Modified: 28-Aug-2012


Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2317

Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2317 PID: SPN: 624 FMI: 4 LAMP: Amber SRT: | Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected on the diagnostic lamp of the engine control module (ECM) connector. | Amber lamp will be illuminated constantly.
ECM Diagnostic Lamp Circuit

Circuit Description

The ECM uses the amber warning lamp to inform the operator about active faults on the engine.

Component Location

The lamp is an original equipment manufacturer (OEM) component that is located on the OEM control panel.

Shop Talk

Proper lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code t05-2317.

Last Modified: 28-Aug-2012


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: 190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Engine is shutdown.
Crankshaft Speed Sensors Circuit

Circuit Description

The crankshaft (primary) engine speed sensor provides engine speed information to the engine control module (ECM) through the engine harness.

Component Location

The crankshaft speed sensor is located on the flywheel housing on the left side of the engine, under the filter bracket. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • Engine governor damage
  • Tampering of the speed sensors

Make sure the correct operation conditions are followed when operating the engine as described in the operation and maintenance manual. To check for valid overspeed, check the fault code snapshot information for the speed reached. This fault will activate at 1980 rpm.

Refer to Troubleshooting Fault Code t05-234.

Last Modified: 28-Aug-2012


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: 232 SPN: 3511 FMI: 4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on sensor supply voltage +5-VDC (3). | Possible reduced performance.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

This is the voltage supply for the crankshaft speed/position sensor.

Component Location

The sensor supply circuit number 3 circuit is contained in the engine wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

When testing the resistance of the wires, make sure the ECM and OEM connectors are disconnected.

Refer to Troubleshooting Fault Code t05-238.

Last Modified: 28-Aug-2012


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 620 FMI: 3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 3 circuit. | Possible reduced performance.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

This is the voltage supply for the fuel control value.

Component Location

The sensor supply circuit number 3 circuit is contained in the engine wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

When testing the resistance of the wires, make sure the engine control module (ECM) and original equipment manufacturer (OEM) connectors are disconnected.

Refer to Troubleshooting Fault Code t05-239.

Last Modified: 28-Aug-2012


Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 244

Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 244 PID: S238 SPN: 623 FMI: 4 LAMP: Amber SRT: 00-313 | Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source. Short to ground detected on red stop lamp driver pin of engine control module (ECM) connector A. | Red lamp will light without fault code (always lit).
Red Stop Lamp Circuit

Circuit Description

The ECM uses the diagnostic lamp to indicate when there is a fault in the system.

Component Location

The diagnostic lamp is an original equipment manufacturer (OEM) component that is located on the OEM control panel. Refer to Procedure 100-002 in Section E.

Shop Talk

Proper diagnostic lamp operation can be verified by checking to see that the diagnostic lamp briefly lights when the unit is started.

Refer to Troubleshooting Fault Code t05-244.

Last Modified: 28-Aug-2012


External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

FAULT CODE 2455

External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2455 PID: SPN: 3938 FMI: 5 LAMP: Amber SRT: | External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit. Below normal current detected in the external generator speed or frequency bias circuit. | Possible reduced engine performance.
External Governor Speed or Frequency Bias Signal Circuit

Circuit Description

The ECM uses the signal from this circuit to determine the commanded engine speed, and equates this to a throttle position, which it commands to the throttle.

Component Location

Not applicable.

Shop Talk

This is a 4-20 milliampere engine speed signal circuit that is controlled by a customer supplied voltage governing device, such as a digital controller (PLC). This 4-20 mA signal is sent to the ECM, which uses it to determine a commanded engine speed. The ECM then sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue you will need to check the ECM, engine wiring, customer interface box wiring, OEM wiring, and the customer-supplied voltage governing device.

Refer to Troubleshooting Fault Code t05-2455.

Last Modified: 28-Aug-2012


External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

FAULT CODE 2456

External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2456 PID: S238 SPN: 3938 FMI: 6 LAMP: Amber SRT: 00-313 | External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit. Above normal current has been detected in the external governor speed or frequency bias circuit. | Possible reduced engine performance.
External Governor Speed or Frequency Bias Circuit

Circuit Description

The engine control module (ECM) uses the signal from this circuit to determine the commanded engine speed, and equates this to a throttle position, which it commands to the throttle.

Component Location

The diagnostic lamp is an original equipment manufacturer (OEM) component that is located on the vehicle dashboard.

Shop Talk

This is a 4-20 milliamp engine speed signal circuit that is controlled by a customer- supplied voltage governing device, such as a digital controller (PLC). This 4-20 milliamp signal is sent to the ECM, which uses it to determine a commanded engine speed. The ECM then sends a signal to the throttle to either open or close until the desired engine speed is met. In order to diagnose this issue, check the ECM, the engine wiring, the customer interface box wiring, the OEM wiring, and the customer-supplied voltage governing device.

Refer to Troubleshooting Fault Code t05-2456.

Last Modified: 29-Aug-2012


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S017 SPN: 632 FMI: 4 LAMP: Shutdown SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the signal return pin of the fuel control valve. | Engine is shutdown or engine will not start.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by the CM558/CM2358. The module outputs operate relays that power the respective solenoids in the fuel shutoff valve.

Component Location

Refer to Procedure 102-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two +24-VDC supplies and one ground connection.

The fuel shutoff valve is often connected as part of the OEM wiring. Make sure to check terminal connections at the valve.

Refer to Troubleshooting Fault Code t05-254.

Last Modified: 24-Sep-2013


Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2544

Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2544 PID: SPN: 1136 FMI: 0 LAMP: SRT: | Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The engine control module (ECM) internal temperature has exceeded the high shutdown threshold. | The engine is shut down.
Engine Control Module (ECM)

Circuit Description

The ECM contains an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-2544.

Last Modified: 29-Aug-2012


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. | The engine will possibly not start.
Unacknowledged Fault

Circuit Description

Not applicable for this fault code.

Component Location

The reset button or switch location depends on the original equipment manufacturer (OEM). Refer to the OEM service manual for component location.

Shop Talk

This fault code occurs as a result of other fault codes becoming active or inactive. Fault Code 2661 will remain active until reset by the operator. Fault Code 2661 is designed to latch onto other fault codes that have become active or have gone inactive. The light is an indicator that will remain lit to inform the operator that there has been a fault code generated.

This fault code is generated by RED/SHUTDOWN lamp faults. Other fault codes need to be corrected before acknowledging this fault code, otherwise this fault code will become active again after a calibrated period of time, if other fault codes are still active.

Refer to Troubleshooting Fault Code t05-2661.

Last Modified: 29-Aug-2012


Electronic Fuel Injection Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 277

Electronic Fuel Injection Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 277 PID: SPN: 633 FMI: 7 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment | Possible reduced engine performance or shutdown.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the engine control module (ECM) that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing in the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 in Section E.

Shop Talk

If this fault code occurs during a test, verify that all connectors are clean and free of corrosion before replacing components. This fault code can become active for any of the following reasons:

  • Electronic fuel control valve high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Electronic fuel control valve with low internal resistance
  • Electronic fuel control valve or engine harness that has shorted to ground
  • The electronic control valve being physically stuck or unable to move freely.

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty.

Refer to Troubleshooting Fault Code t05-277.

Last Modified: 28-Aug-2012


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2789

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2789 PID: 110 SPN: 110 FMI: 18 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine coolant temperature is below the normal operating temperature limits. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is located in different locations based on what engine model you are servicing. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is below a calibration limit set in the ECM.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set.

Conditions for Clearing the Fault Code

The fault code will be set inactive when the coolant temperature is detected to be within the normal operating temperature limits.

Shop Talk

This fault code indicates that coolant temperature is below a calibration limit set in the ECM.

Refer to Troubleshooting Fault Code t05-2789.

Last Modified: 29-Aug-2012


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2793

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2793 PID: 110 SPN: 110 FMI: 18 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level. The engine coolant temperature is below the normal operating temperature limits. | Engine is shut down.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is located in different locations based on what engine model you are servicing. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is below a calibration limit set in the ECM.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set.

Conditions for Clearing the Fault Code

The fault code will be set inactive when the coolant temperature is detected to be within the normal operating temperature limits.

Shop Talk

This fault code indicates that coolant temperature is below the minimum limit set in the ECM.

Refer to Troubleshooting Fault Code t05-2793.

Last Modified: 29-Aug-2012


Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2797

Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2797 PID: P190 SPN: 190 FMI: 10 LAMP: Yellow SRT: | Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage has been detected at the carburetor inlet gas differential pressure sensor circuit. | Possible reduced engine performance.
Carburetor Inlet Gas Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the carburetor inlet gas differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The carburetor inlet gas differential pressure sensor provides a signal to the ECM on the carburetor inlet gas differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure between the fuel pressure and the inlet air pressure entering the carburetors.

Component Location

The carburetor inlet gas differential pressure sensor is located on the right side of the engine near the rear end of the block by the carburetor. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Siganl circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-2797.

Last Modified: 29-Aug-2012


Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2798

Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2798 PID: S324 FMI: 4 LAMP: Amber SRT: | Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage has been detected at the carburetor inlet gas differential pressure sensor circuit. | Possible reduced engine performance.
Carburetor Inlet Gas Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the carburetor inlet gas differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The carburetor inlet gas differential pressure sensor provides a signal to the ECM on the carburetor inlet gas differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure between the fuel pressure and the inlet air pressure entering the carburetors.

Component Location

The carburetor inlet gas differential pressure sensor is located on the right side of the engine, near the rear end of the block, by the carburetor.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-2798.

Last Modified: 29-Aug-2012


Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2864

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2864 PID: SPN: 632 FMI: 3 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source. High voltage has been detected at the signal return pin of the fuel control valve. | Loss of engine protection.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by the engine control module (ECM). The module outputs operate relays that power the respective solenoids in the fuel shutoff valve.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two +24-VDC supplies and one ground connection.

The fuel shutoff valve is often connected as part of the original equipment manufacturer (OEM) wiring. Be sure to check terminal connections at the valve.

Refer to Troubleshooting Fault Code t05-2864.

Last Modified: 29-Aug-2012


Power Relay Driver Diagnostics Has Detected An Error - Condition Exists

FAULT CODE 2865

Power Relay Driver Diagnostics Has Detected An Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2865 PID: SPN: 2634 FMI: 31 LAMP: Amber SRT: | Power Relay Driver Diagnostics Has Detected An Error - Condition Exists. | Possible reduced engine performance, engine possibly hard to start or will not start.
Power Relay Driver Circuit

Circuit Description

The engine control module (ECM) uses the power relay driver circuit to send power to the exhaust oxygen sensor heater circuit.

Component Location

The power relay power circuit is located in the engine harness.

Shop Talk

The power relay power circuit can be used by the original equipment manufacturer (OEM) control panel, so issues within the panel can activate this fault code.

Refer to Troubleshooting Fault Code t05-2865.

Last Modified: 29-Aug-2012


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2866

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2866 PID: SPN: 1422 FMI: 3 LAMP: Amber SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. | No effect on engine performance.
Electronic Fuel Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the engine control module (ECM) that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

The electronic fuel control valve communicates its position by varying a resistance internal to the actuator. This resistance is sent to the ECM, which uses the resistance to calculate the valve position as a percentage between 0 and 100.

Component Location

The electronic fuel control valve is located fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 in Section E.

Shop Talk

The electronic fuel control valve is not repairable, so if the valve is determined to have malfunctioned after following the troubleshooting steps, it will be necessary to replace the entire electronic fuel control valve assembly.

Refer to Troubleshooting Fault Code t05-2866.

Last Modified: 29-Aug-2012


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2867

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2867 PID: SPN: 1422 FMI: 4 LAMP: Amber SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | No effect on engine performance.
Electronic Fuel Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the engine control module (ECM) that controls the electronic fuel control valve. The electronic fuel control valve is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the carburetors, based on engine operating conditions. The electronic fuel control valve is a normally open valve.

The electronic fuel control valve communicates its position by varying a resistance internal to the actuator. This resistance is sent to the ECM, which uses the resistance to calculate the valve position as a percentage between 0 and 100.

Component Location

The electronic fuel control valve is located in the fuel supply plumbing on the rear of the engine, just after the secondary fuel pressure regulator. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

The electronic fuel control valve is not repairable, so if the valve is determined to have malfunctioned after following the troubleshooting steps, it will be necessary to replace the entire electronic fuel control valve assembly.

Refer to Troubleshooting Fault Code t05-2867.

Last Modified: 29-Aug-2012


Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2995

Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2995 PID: SPN: 3563 FMI: 0 LAMP: Red SRT: | Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Most Severe Level. The intake manifold air pressure signal indicates the intake manifold pressure is above the engine protection critical limit. | Engine is shut down.
Intake Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature and pressure of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure). Refer to Procedure 100-002 in Section E for a detailed component location view.

This is used on the GTA855 CM558 (CM2358) G101 only.

Shop Talk

Possible causes of this fault code include:

  • Sensor malfunctions
  • Wiring harness malfunctioned high
  • Intake manifold overpressure event
  • Malfunction in the control system.
Refer to Troubleshooting Fault Code t05-2995.

Last Modified: 20-Aug-2014


Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2996

Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2996 PID: SPN: 3563 FMI: 16 LAMP: Amber SRT: | Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level. The intake manifold air pressure signal indicates the intake manifold pressure is above the engine protection normal limit. | Possible reduced engine performance.
Intake Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature and pressure of the fuel mixture.

Component Location

The intake pressure/temperature sensor is located in the left front intake manifold housing (combination sensor with absolute pressure). Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

Possible causes of this fault code include:

  • Sensor malfunctions
  • Wiring harness malfunctioned high
  • Malfunction in the control system.
Refer to Troubleshooting Fault Code t05-2996.

Last Modified: 29-Aug-2012


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: 254 SPN: 629 FMI: 12 LAMP: Yellow SRT: | Engine Control Module (ECM) Warning Internal Hardware Failure - Bad Intelligent Device or Component. | Possible reduced performance.
Engine Control Module (ECM)

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM.) Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-343.

Last Modified: 05-Aug-2013


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: 253 SPN: 630 FMI: 12 LAMP: Yellow SRT: | Engine Control Module (ECM) Calibration Memory Software - Bad Intelligent Device or Component. | Possible reduced performance.
Engine Control Module (ECM)

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM). Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by an internal ECM malfunction. This can also be caused if battery power is disconnected before the power-down sequence is completed. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-346.

Last Modified: 05-Aug-2013


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: 232 SPN: 3509 FMI: 4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced engine performance, shutdown, or loss of engine protection.
Sensor Supply 1 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor.

Component Location

The sensor supply voltage 5 volt (1) circuit is contained in the wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The voltage supply for these engines is broken up into Sensor Supply 1, Sensor Supply 2, and Sensor Supply 3.

Refer to Troubleshooting Fault Code t05-352.

Last Modified: 28-Aug-2012


Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 354

Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 354 PID: P106 SPN: 3563 FMI: 3 LAMP: Amber SRT: | Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the sensor signal pin at the ECM. | Possible reduced performance or shutdown, no engine protection for intake manifold pressure 1.
Intake Manifold Pressure 1 Sensor Circuit

Circuit Description

The engine control module (ECM) uses the intake manifold 1 pressure/temperature sensor input to determine the pressure of the air mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature) on the left front side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This sensor detects the pressure and temperature of the air/fuel mixture entering the engine. All pressure sensors on these engines are absolute sensors.

Refer to Troubleshooting Fault Code t05-354.

Last Modified: 28-Aug-2012


Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 355

Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 355 PID: P106 SPN: 3563 FMI: 4 LAMP: Amber SRT: | Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage (short to ground) detected on the sensor signal pin at the ECM. | Possible reduced performance or shutdown, no engine protection for intake manifold pressure 1.
Intake Manifold Pressure 1 Sensor Circuit

Circuit Description

The engine control module (ECM) uses the intake manifold 1 pressure/temperature sensor input to determine the pressure of the air mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature) on the left front side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This sensor detects the pressure and temperature of the air/fuel mixture entering the engine. All pressure sensors on the GTA855 CM558/CM3258 engine are absolute sensors.

Refer to Troubleshooting Fault Code t05-355.

Last Modified: 24-Sep-2013


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 3509 FMI: 3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. | Possible reduced engine performance, shutdown, or loss of engine protection.
Sensor Supply 1 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold 1 pressure/temperature sensor and the caruretor inlet gas differential pressure sensor.

Component Location

The sensor supply voltage 5 volt (1) circuit is contained in the wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The voltage supply for these engines is broken up into Sensor Supply 1, Sensor Supply 2, and Sensor Supply 3.

Refer to Troubleshooting Fault Code t05-386.

Last Modified: 28-Aug-2012


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: SPN: 100 FMI: 1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Engine is shut down.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 in Section E.

Shop Talk

Verify with the operator the engine speed at which the fault occurs. If the engine is being operated at too low of a speed, the oil pressure can drop below the engine protection limits.

Possible causes of this fault code include:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be changed.
Refer to Troubleshooting Fault Code t05-415.

Last Modified: 28-Aug-2012


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level | Progressive power derate increasing in severity from time of alert. If engine protection shutdown feature is enabled, engine will shut down 30 seconds after red stop lamp starts flashing.
Engine Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed should compare to the sesnor specifications given on the back of the appropriate wiring diagram, if the sensor is functioning properly.
Refer to Troubleshooting Fault Code t05-421.

Last Modified: 28-Aug-2012


J1939 Network Number 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

J1939 Network Number 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2 LAMP: None SRT: | J1939 Network Number 1 - Data Erratic, Intermittent, or Incorrect | No effect on engine performance, electronic service tool or other data link devices can not communicate with the engine control module (ECM).
SAE J1939 Datalink Circuit

Circuit Description

The SAE J1939 data link is a public data link that broadcasts engine operating data as well as fault codes.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The SAE J1939 data link is a network data link on which each ECM is attached via a network stub connection. Make sure that the electronic service tool is set up for J1939 communications (if applicable) when using this data link.

Refer to Troubleshooting Fault Code t05-426.

Last Modified: 28-Aug-2012


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine control module (ECM) supply voltage is below the minimum system voltage level. | ECM voltage supply approaching a level at which unpredictable operation will occur. Engine will possibly be hard to start.
Battery Supply 1 Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Refer to Troubleshooting Fault Code t05-441.

Last Modified: 28-Aug-2012


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine control module (ECM) supply voltage is above the maximum system voltage level. | ECM damage will occur. Possible electrical damage to all other electronic components.
Battery Supply 1 Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Refer to Troubleshooting Fault Code t05-442.

Last Modified: 28-Aug-2012


Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 477

Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 477 PID: P168 SPN: 444 FMI: 18 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine control module (ECM) supply voltage is below the minimum system voltage level. | Engine is shutdown.
Battery Supply 2 Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Refer to Troubleshooting Fault Code t05-477.

Last Modified: 28-Aug-2012


Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 478

Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 478 PID: P168 SPN: 444 FMI: 16 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine control module (ECM) supply voltage is above the maximum system voltage level. | ECM damage will occur.
Battery Supply 2 Circuit

Circuit Description

There are three battery inputs into the OEM connectors that are unswitched battery supply to the ECM.

Component Location

The battery voltage circuit is located in the wiring harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning. Battery voltage passes through relays on the OEM control panel before reaching the engine.

Refer to Troubleshooting Fault Code t05-478.

Last Modified: 28-Aug-2012


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 16 LAMP: None SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold temperature above engine protection critical limit. | Possible reduced engine performance.
Intake Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) uses the intake pressure/temperature sensor input to determine the temperature of the fuel mixture.

Component Location

The intake pressure/temperature sensor is located in the intake manifold housing (combination sensor with absolute pressure) on the left front side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed should compare to the appropriate wiring diagram specifications, if the sensor is functioning properly.
Refer to Troubleshooting Fault Code t05-488.

Last Modified: 28-Aug-2012


Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 512

Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 512 PID: P51 SPN: 51 FMI: 3 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the ECM. | Possible reduced performance.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the throttle actuator, which is both an input and output device.

Component Location

The throttle actuator is located after the fuel housing and before the intake manifold inlet. Refer to Procedure 100-002 in Section E.

Shop Talk

The fault will light if the throttle actuator shorts to a high source on either the positive (+) throttle command or throttle position signal circuits.

Refer to Troubleshooting Fault Code t05-512.

Last Modified: 28-Aug-2012


Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 513

Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 513 PID: P51 SPN: 51 FMI: 4 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage (shorted to ground) detected at the ECM. | Possible reduced performance.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the throttle actuator, which is both an input and output device.

Component Location

The throttle actuator is located after the fuel housing and before the intake manifold inlet. Refer to Procedure 100-002 in Section E.

Shop Talk

The fault will light if the throttle actuator has low voltage on the switched battery and this is detected by the ECM.

Refer to Troubleshooting Fault Code t05-513.

Last Modified: 28-Aug-2012


Propane Methane Spark Timing Adjustment Current Driver - Voltage Above Normal or Shorted to High Source

FAULT CODE 5835

Propane Methane Spark Timing Adjustment Current Driver - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5835 PID: SPN: 520951 FMI: 3 LAMP: Red SRT: | Propane Methane Spark Timing Adjustment Current Driver - Voltage Above Normal or Shorted to High Source. The engine control module (ECM) senses voltage shorted high or above normal. | Engine shutdown.

Circuit Description

This circuit is the current signal sent from the ECM to the ignition control module (ICM) to determine spark timing offset activation.

Component Location

The current driver circuit is contained in the main engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM senses voltage shorted low or below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will shut the engine down after a specified amount of time.

Conditions for Clearing the Fault Code

To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.

The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The ECM will turn OFF the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Proper automatic timing offset can be verified using a timing light to check spark timing for natural gas and propane fuels.

Refer to Troubleshooting Fault Code t05-5835.

Last Modified: 14-Jan-2015


Propane Methane Spark Timing Adjustment Current Driver - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5836

Propane Methane Spark Timing Adjustment Current Driver - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5836 PID: SPN: 520951 FMI: 3 LAMP: Red SRT: | Propane Methane Spark Timing Adjustment Current Driver - Voltage Below Normal or Shorted to Low Source. The engine control module (ECM) senses voltage shorted low or below normal. | Engine shutdown.

Circuit Description

This circuit is the current signal sent from the ECM to the ignition control module (ICM) to determine spark timing offset activation.

Component Location

The current driver circuit is contained in the main engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM senses voltage shorted low or below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will shut the engine down after a specified amount of time.

Conditions for Clearing the Fault Code

To validate the repair, perform a key cycle, start the engine, and let it idle for 1 minute.

The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The ECM will turn OFF the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Proper automatic timing offset can be verified using a timing light to check spark timing for natural gas and propane fuels.

Refer to Troubleshooting Fault Code t05-5836.

Last Modified: 14-Jan-2015


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The engine control module (ECM) has detected an error in the engine speed signal. | Possible reduced engine performance.
Crankshaft Speed/Position Sensor

Circuit Description

The ECM provides a 5-VDC supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies depending on the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the crankshaft speed/position sensor while the engine is running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The camshaft speed sensor is used to provide engine speed and position information to the ECM.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code:

  • Open or short circuit of the +5-VDC SUPPLY, SIGNAL, or RETURN wire in the engine harness
  • Damaged or malfunctioning engine speed sensor.
Refer to Troubleshooting Fault Code 689.

Last Modified: 03-Sep-2014


ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3 LAMP: Warning SRT: | ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. The internal signal for the ECM temperature is reading abnormally high voltage. | No effect on engine performance.
CM558/CM2358

Circuit Description

The CM558/CM2358 contains an internal air temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside the ECM. Refer to Procedure 100-002 in Section E.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-697.

Last Modified: 24-Sep-2013


ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4 LAMP: Warning SRT: | ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The internal signal for the ECM temperature is reading abnormally low voltage. | No effect on engine performance.
CM558/CM2358

Circuit Description

The CM558 contains an internal air temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside the ECM. Refer to Procedure 100-002 in Section E.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-698.

Last Modified: 24-Sep-2013


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 783

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 783 PID: SPN: 105 FMI: 10 LAMP: Red SRT: | Intake Manifold 1 Temperature - Abnormal Rate of Change | Engine is shutdown.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor monitors intake manifold air temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The intake manifold 1 temperature sensor is located in the left bank front air intake manifold. Refer to Procedure 100-002 in Section E.

Shop Talk

This feature provides protection for the engine when a rapid increase in intake manifold temperature occurs. Intake manifold temperature rapid rise monitors the change in the intake manifold 1 temperature sensor over a period of time and then logs a fault and requests a derate or shut down due to excessive temperature change.

Possible causes of this fault code include:

  • Restricted air flow through the charge air cooler (GTA855 only)
  • LTA cooling circuit temperature too high (GTA855 only)
  • Damaged valves
  • An air intake manifold overpressure event
  • High turbocharger compressor outlet temperature (GTA855 only).
Refer to Troubleshooting Fault Code t05-783.

Last Modified: 28-Aug-2012


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Speed Sensor | Refer to Procedure 019-042 | KTA38GC CM558/CM2358 | 4021656
Engine Speed Sensor | Refer to Procedure 019-042 | G5.9, G8.3, G855, and GTA855 CM558/CM2358 | 4021702
Engine Speed Sensor | Refer to Procedure 019-042 | QSL9G CM558/CM2358 | 2883471
Engine Speed Sensor | Refer to Procedure 019-042 | KTA19GC CM558/CM2358 | 4021655
Engine Speed Sensor | Refer to Procedure 019-042 | QSK19G | 4021352
Engine Speed Sensor | Refer to Procedure 019-042 | GTA8.3 CM558/CM2358 | 4021654
Engine Speed Sensor | Refer to Procedure 019-042 | QSK23 CM2250 K109 | 4367358
Engine Speed Sensor | Refer to Procedure 019-042 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | Marine QSB6.7 CM2250 | 4310611
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310846
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z101 | 4358364
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z102 | 4358369
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G110 | 4367323
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

No repair.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Some natural gas engines are referenced as the engine speed sensor. Refer to Proceduere 019-042 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

  • 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the air gap between the crankshaft position sensor and the tone wheel.
  • Refer to Procedure 001-071 in the Associated Procedures Table or Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?
YES NO
No Repair

Replace the component that is causing the out of specification reading.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Sep-2017


FAULT CODE 121 - Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | GTA855 CM558/CM2358 N101 | 4021702
Engine Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather Pack™ test lead, and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 121 active?
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the engine harness and engine speed sensor connector pins. | Damaged or dirty pins?
 | STEP 2B. Inspect the sensor for damage. | Damage found?
 | STEP 2C. Read the fault codes. | Fault Code 121 active?
 | STEP 2D. Check the resistance of the sensor. | Between 1000 and 2000 ohms?
 | STEP 2E. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Damaged or dirty pins?
 | STEP 3B. Read the fault codes. | Fault Code 121 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the engine harness and engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine harness and engine speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damage found?
YES NO

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 4B

Guided Step 2D - Check the resistance of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine speed sensor positive pin to the engine speed sensor negative pin in the engine speed sensor connector.
  • Measure the resistance from the engine speed sensor backup positive pin to the engine speed sensor backup negative pin in the engine speed sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 1000 and 2000 ohms?
YES NO
No Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensor
  • Make sure the sensor is installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine speed sensor positive pin in the engine speed sensor connector, sensor side, to engine block ground.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine speed sensor connector, sensor side, to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensor
  • Disconnect engine harness connector A from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness sensor connector to the engine speed sensor positive pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness sensor connector to the engine speed sensor backup positive pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor negative pin in the engine harness sensor connector to the engine speed sensor negative pin in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor backup negative pin in the engine harness sensor connector to the engine speed sensor backup negative pin in the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch off
  • Disconnect the engine harness from the engine speed sensor
  • Disconnect the engine harness connector A from the ECM.

Action

Check for short circuit to ground.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector to the engine block ground.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector to the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch off
  • Disconnect the engine harness from the engine speed sensor
  • Disconnect the engine harness connector A and connector B from the ECM.

Action

Check for short circuit from pin-to-pin.

  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector A to all other pins in the connector.
  • Measure the resistance from the engine speed sensor positive pin in the engine harness ECM connector A to all the pins in engine harness connector B.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector A to all other pins in the connector.
  • Measure the resistance from the engine speed sensor backup positive pin in the engine harness ECM connector A to all the pins in engine harness connector B.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 121 is inactive.

Fault Code 121 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 16-Jan-2014


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM559 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM559 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.5 and 5.25-VDC?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 386.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine oil pressure/temperature sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the oil pressure RETURN pin on the engine oil pressure sensor connector of the engine harness.

Between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine oil pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil pressure sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector A RETURN pin and the engine oil pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness and all other pins in the engine connector A.
  • Measure the resistance between the oil pressure SIGNAL pin in engine harness connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the oil pressure 5 volt SUPPLY pin in engine harness connector A and all other pins in the ECM connector A.
  • Measure the resistance between the oil pressure 5 volt SUPPLY pin in engine harness connector A and all other pins in the ECM connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 18-Apr-2014


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM558/CM2358 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.5 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine oil pressure/temperature sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the oil pressure RETURN pin on the engine oil pressure sensor connector of the engine harness.

Between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil pressure SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine oil pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil pressure/temperature sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A SUPPLY pin and the engine harness engine oil pressure sensor connector SUPPLY pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A SIGNAL pin and the engine harness engine oil pressure sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector A and all other pins in connector A.
  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector A and all other pins in connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector A and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO
No Repair

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 23-Jan-2014


FAULT CODE 142 - Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM558/CM2358 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1. Read the fault codes. | Fault Code 142 active?
STEP 2. | Check the oil pressure sensor accuracy. |
 | STEP 2A. Check the sensor accuracy. | Sensor reading is correct?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 142 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 142 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the oil pressure sensor accuracy.

Guided Step 2A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine
  • Connect INSITE™ electronic service tool to the vehicle datalink.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute, add atmospheric pressure to gauge reading.
  • If necessary, increase the engine rpm to make it easier to see differences in the readings.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if INSITE™ electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 142 is inactive.

If the fault occurred at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 142 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 23-Jan-2014


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM558/CM2358 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading is correct?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 143 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute, add atmospheric pressure to gauge reading.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if INSITE™ electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check the engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch on
  • Connect a mechanical oil pressure gauge
  • Connect INSITE™ electronic service tool
  • Engine running at idle speed.

Action

Check the engine oil pressure.

  • Reference Procedure 007-052 in Section 7 in the appropriate service manual.

Oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in the appropriate service manual.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 143 is inactive.

If the fault occurred at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 143 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 23-Jan-2014


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | GTA855 CM558/CM2358 N101 | 4021702
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 144 inactive?
STEP 2. | Check the coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 175 ohms and 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant temperature sensor and circuit.

Guided Step 2A - Inspect the coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the coolant temperature sensor connector.

Between 175 ohms and 274k ohms?
YES NO
No Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature RETURN pin and the ECM connector A RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature sensor SIGNAL pin and the ECM connector A SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the coolant temperature SIGNAL pin in engine harness to all other pins in the engine ECM connector A.
  • Measure the resistance between the coolant temperature SIGNAL pin in engine harness and all pins in engine ECM connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the signal pin has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 23-Jan-2014


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | GTA855 CM558/CM2358 N101 | 4021702
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault code and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine coolant temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine coolant temperature sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector A and all other pins in the engine connector A.
  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector A and all other pins in the engine connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector A and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 23-Jan-2014


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | GTA855 CM558/CM2358 N101 | 4021702
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 146 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the engine coolant temperature sensor. |
 | STEP 3A. Inspect the engine coolant temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 146 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 146 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine
  • Connect INSITE™ electronic service tool to the vehicle data link
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool, to the reading from the temperature probe.

If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine coolant temperature sensor.

Guided Step 3A - Inspect the engine coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine coolant temperature sensor.

Action

Inspect the engine coolant temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it run for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting tree in Section TS of the appropriate service manual.

 No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 146 is inactive.

Fault Code 146 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 23-Jan-2014


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | GTA855 CM558/CM2358 N101 | 4021702
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 151 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the engine coolant temperature sensor. |
 | STEP 3A. Inspect the engine coolant temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 151 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 151 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool to the reading from the temperature probe.

If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine coolant temperature sensor.

Guided Step 3A - Inspect the engine coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine coolant temperature sensor.

Action

Inspect the engine coolant temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it run for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 active?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting tree in Section TS in the appropriate service manual.

 No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 151 is inactive.

Fault Code 151 active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | GTA855 CM558/CM2358 N101 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold 1 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 175 ohms and 274 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 1 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold 1 temperature sensor.

Action

Inspect the engine harness and intake manifold 1 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-354 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the intake manifold 1 temperature sensor connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Between 175 ohms and 274 ohms?
YES NO

Reference the wiring diagram for resistance and temperature.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-354 in the Associated Procedure Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the temperature RETURN pin and the ECM connector A RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine intake manifold 1 temperature sensor SIGNAL pin and the ECM connector A SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the intake manifold 1 temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector A.
  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | GTA855 CM558/CM2358 N101 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 active?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and intake manifold air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake manifold air temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector A and all other pins in the engine connector A.
  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector A and all other pins in the engine connector B.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in engine harness ECM connector A to ground.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 18-Apr-2014


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | GTA855 CM558/CM2358 N101 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 155 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Does the temperature differ more than 3°C [5°F]?
STEP 3. | Check the intake manifold pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 155 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 155 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect the INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold temperature reading on INSITE™ electronic service tool to the reading from the probe.

If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C [5°F]?
YES NO

Replace the intake manifold intake pressure/temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the intake manifold intake pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold intake pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold intake pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES NO

Reference the Intake Manifold Air Temperature Above Normal troubleshooting symptom tree in Section TS of the appropriate service manual.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 155 is inactive.

Fault Code 155 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 177 - Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment.

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | GTA855 CM558/CM2358 N101 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test leads when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 177 active?
STEP 2. | Check the electronic throttle control actuator. |
 | STEP 2A. Inspect the electronic throttle control actuator and engine harness connector pins. | Damaged or dirty pins?
 | STEP 2B. Read the fault codes. | Fault Code 177 active?
STEP 3. | Verify the throttle operation. |
 | STEP 3A. Verify the throttle operation. | Did the gas throttle control pass the test?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Damaged or dirty pins?
 | STEP 4B. Read the fault codes. | Fault Code 177 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 4E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 4F. Check the throttle actuator for an obstruction or damage. | Obstruction or damage?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 177 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Read the fault codes.

Fault Code 177 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the electronic throttle control actuator.

Guided Step 2A - Inspect the electronic throttle control actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the electronic throttle control actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair or replace the engine harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the throttle actuator. Reference Procedure 005-052 in Section 5 of the appropriate service manual.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 177 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 5B

Guided Step 3 - Verify the throttle operation.

Guided Step 3A - Verify the throttle operation.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Verify proper throttle operation.

  • Use INSITE™ electronic service tool to activate the gas throttle control test.

Did the gas throttle control pass the test?
YES NO
No Repair

Replace the throttle actuator. Reference Procedure 005-052 in Section 5 of the appropriate service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 177 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the throttle actuator
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the throttle plate position feedback pin in the engine harness connector to the throttle plate position feedback pin in the engine harness actuator connector.
  • Measure the resistance from the throttle command supply pin in the engine harness connector to the throttle command supply pin in the engine harness actuator connector.
  • Measure the resistance from the throttle command return pin in the engine harness connector to the throttle command return pin in the engine harness actuator connector.
  • Measure the resistance from the throttle command return pin in the engine harness connector to the throttle command return pin in the engine harness actuator connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the throttle actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the throttle position (+) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance from the throttle actuator (+) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance from the throttle position (-) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance from the throttle actuator (-) pin in the engine harness ECM connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the throttle actuator.
  • Disconnect the engine harness from the OEM harness at the 47pin OEM connectors.
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the throttle position (+) pin in engine harness connector 1 and all pins in engine harness ECM connector 2.
  • Measure the resistance from the throttle actuator (+) pin in engine harness connector 1 and all pins in engine harness ECM connector 2.
  • Measure the resistance from the throttle position (-) pin in engine harness connector 1 and all pins in engine harness ECM connector 2.
  • Measure the resistance from the throttle actuator (-) pin in engine harness connector 1 and all pins in engine harness ECM connector 2.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check the throttle actuator for an obstruction or damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the throttle actuator for an obstruction or damage.

  • Check the throttle plate for straightness. If the plate is bent, replace the throttle actuator.

Obstruction or damage?
YES NO

Replace the throttle actuator. Reference Procedure 005-052 in Section 5 of the appropriate service manual.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 177 is inactive.

Fault Code 177 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | G5.9, G855, GTA855 and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, GTA855 and G8.3 CM558/CM2358 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | G5.9, G855, GTA855 and G8.3 CM558/CM2358 | 4021702
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | G5.9, G855, GTA855 and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault codes. | Fault Code 187 active?
STEP 2. | Check the oil rifle pressure/temperature sensors and sensor supply circuit. |
 | STEP 2A. Inspect the engine oil rifle pressure/temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Check the circuit response. | Fault Code 187 active?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the post catalyst temperature sensor and circuit connected to the sensor number 2 supply and return. |
 | STEP 2C-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the oil rifle pressure/temperature sensors and sensor supply circuit.

Guided Step 2A - Inspect the engine oil rifle pressure/temperature sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil rifle pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil rifle pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil rifle pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the oil rifle pressure/temperature sensor.

  • Replace the pre-catalyst temperature sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the pre-catalyst temperature connector and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the pre-catalyst temperature sensor from the engine harness.

Action

Inspect the engine harness and pre-catalyst temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector.

Repair or replace the engine harness with the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-catalyst temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

  • Replace the pre-catalyst temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the post-catalyst temperature connector and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF
  • Disconnect the post-catalyst temperature sensor from the engine harness.

Action

Inspect the engine harness and pre-catalyst temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the post-catalyst temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

  • Replace the post-catalyst temperature sensor. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harnes from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jan-2014


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM558/CM2358 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 175 ohms and 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 212 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil temperature sensor and circuit.

Guided Step 2A - Inspect the oil pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oil temperature sensor from the engine harness.

Action

Inspect the engine harness and oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the oil temperature sensor connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 175 and 274k ohms?
YES NO

Reference the table in shop talk for specifications.

Replace the engine oil temperature sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the oil temperature RETURN pin and the ECM connector A RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the ECM connector A SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the oil temperature SIGNAL pin in engine harness and all other pins in the ECM connector A.
  • Measure the resistance between the oil temperature SIGNAL pin in engine harness and all other pins in the ECM connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 212 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM558/CM2358 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 213 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine oil temperature sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil temperature sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature SIGNAL pin in engine harness ECM connector A and all other pins in the engine connector A.
  • Measure the resistance between the engine oil temperature SIGNAL pin in engine harness ECM connector A and all other pins in the engine connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the engine oil temperature SIGNAL pin in the engine harness ECM connector A and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedures for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to ground short circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 213 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM558/CM2358 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 214 active?
STEP 2. | Check the engine oil pressure/temperature sensor. |
 | STEP 2A. Inspect the engine harness and engine oil pressure/temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 214 active?
 | STEP 2C. Verify engine oil temperature sensor. | Does temperature differ more than 3°C [5°F]?
 | STEP 2D. Check the resistance of the sensor. | Between 300 and 90k ohms?
 | STEP 2E. Read the fault codes. | Fault Code 214 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 214 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil pressure/temperature sensor.

Guided Step 2A - Inspect the engine harness and engine oil pressure/temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine oil pressure/temperature sensor.

Action

Inspect the engine harness and engine oil pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Verify engine oil temperature sensor.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify engine oil temperature sensor.

  • Verify the engine oil temperature measurement by comparing the INSITE™ electronic service tool reading to the mechanical gauge measurement.

Does temperature differ more than 3°C [5°F]?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the resistance of the sensor.

Conditions

  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the engine oil pressure/temperature sensor from the engine harness.

Action

Check the resistance of the sensor.

  • Measure the resistance from the oil temperature SIGNAL pin to the oil pressure/temperature RETURN pin in the engine oil pressure/temperature sensor.

Between 300 and 90k ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active?
YES | NO
No Repair | No Repair

Go to

Go to 3B

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 214 is inactive.

Fault Code 214 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM558/CM2358 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Resistor Pack | Refer to Procedure 019-482 | GTA855 CM558/CM2358 N101 | 4021702
Resistor Pack | Refer to Procedure 019-482 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 227 active?
STEP 2. | Check the oil rifle pressure/temperature sensors and sensor supply circuit. |
 | STEP 2A. Inspect the engine oil rifle pressure/temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Check the 47-pin OEM connector. |
 | STEP 3A. Inspect the 47-pin OEM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check the catalyst extension harness. |
 | STEP 4A. Inspect the pre-catalyst temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 4A-1. Check the circuit response. |
 | STEP 4A-2. Check for a pin-to-ground short circuit. |
 | STEP 4B. Inspect the post-catalyst temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 4B-1. Check the circuit response. |
 | STEP 4B-2. Check for a pin-to-ground short circuit. |
 | STEP 4C. Check the customer terminal strip. | Greater than 100k ohms?
STEP 5. | Check the ECM and engine harness. |
 | STEP 5A. Check the ECM and engine harness. | Dirty or damaged pins?
 | STEP 5B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 5C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 5D. Inspect the engine harness and resistor pack connector pins. | Dirty or damaged pins?
 | STEP 5E. Check for an inactive fault code. | Fault Code 227 inactive?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil rifle pressure/temperature sensors and sensor supply circuit.

Guided Step 2A - Inspect the engine oil rifle pressure/temperature sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oil rifle pressure/temperature sensor from the engine harness.

Action

Inspect the oil rifle pressure/temperature sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the oil rifle pressure/temperature sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oil rifle pressure/temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO
No Repair

A damaged sensor has been detected.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Replace the oil rifle pressure/temperature sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the 47-pin OEM connector.

Guided Step 3A - Inspect the 47-pin OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 47-pin OEM connector from the engine harness.

Action

Inspect the 47-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector.

Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 47-pin OEM connector from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor SUPPLY 2 pin in the 47-pin OEM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply line number 2 line has been detected in the OEM connector.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the catalyst extension harness

Guided Step 4A - Inspect the pre-catalyst temperature sensor and connector pins connected to sensor SUPPLY number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the pre-catalyst temperature sensor from the OEM harness.

Action

Inspect the pre-catalyst temperature sensor harness and OEM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the pre-catalyst temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 6A

Go to 4A-1

Guided Step 4A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the pre-catalyst temperature sensor from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO
No Repair

A malfunctioning sensor has been detected.

  • Replace the pre-catalyst temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 4A-2

Go to 6A

Guided Step 4A-2 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 47-pin OEM connector from the engine harness
  • Disconnect the pre-catalyst temperature sensor from the extension harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor temperature SUPPLY pin and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply line 2 line has been detected in the OEM connector.

Repair or replace the engine harness

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4B

Go to 6A

Guided Step 4B - Inspect the post-catalyst temperature sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the post-catalyst temperature sensor from the OEM harness.

Action

Inspect the post-catalyst temperature sensor harness and OEM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-218 in Section 19.
  • Replace the harness. Refer to the OEM service manual.
  • Replace the post-catalyst temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 6A

Go to 4B-1

Guided Step 4B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the post-catalyst temperature sensor from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO
No Repair

A malfunctioning sensor has been detected.

  • Replace the post-catalyst temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 4B-2

Go to 6A

Guided Step 4B-2 - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 47-pin OEM connector from the engine harness
  • Disconnect the post-catalyst temperature sensor from the extension harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor temperature SUPPLY pin and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply line 2 line has been detected in the OEM connector

Repair or replace the engine harness

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4C

Go to 6A

Guided Step 4C - Check the customer terminal strip.

Conditions

  • Disconnect the 47-pin OEM connector from the engine harness
  • Disconnect the pre and post-catalyst oxygen and temperature sensors (four altogether) from the catalyst extension harnesses.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the pre-catalyst temperature supply (sensor SUPPLY 2) terminal on the customer terminal strip and ground.
  • Measure the resistance between the post-catalyst temperature supply (sensor SUPPLY 2) terminal on the customer terminal strip and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply line 2 line has been detected in the customer terminal strip.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the customer terminal strip. Refer to the OEM service manual.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM and engine harness.

Guided Step 5A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector B from the ECM
  • Disconnect the oil rifle pressure/temperature sensor from the engine harness
  • Disconnect the resistor pack from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector B and all other pins in the engine connector B.
  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector B and all other pins in the engine connector A.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply line number 2 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector B from the ECM
  • Disconnect the oil rifle pressure/temperature sensor from the engine harness
  • Disconnect the resistor pack from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector B and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the resistor pack. Refer to Procedure 019-482 in the Associated Procedures Table.

A pin-to-ground short circuit on the sensor supply line number 2 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5D

Go to 5E

Guided Step 5D - Inspect the engine harness and resistor pack connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the resistor pack from the engine harness connector.

Action

Check the resistor pack resistance. Inspect the engine harness and resistor pack connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the resistor pack connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the resistor pack, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the resistor pack. Refer to Procedure 019-482 in the Associated Procedures Table.

 No Repair

Go to 5E

Go to 6A

Guided Step 5E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

6B

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | GTA855 CM558/CM2358 N101 | 4021702
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

If the engine speed stays above 2000 rpm, the engine must be shut off immediately or engine damage will occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for governor fault codes. | Did a governor malfunction cause this issue?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine speed sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an inactive fault code at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed

Guided Step 1A - Check for governor fault codes.

Conditions

  • Turn keyswitch OFF

Action

Check for governor fault codes.

  • Reference the G8.3, G5.9, G855, and GTA8.3 CM558/CM2358, Master Repair Manual Bulletin 4021701, for information on how to complete this.

Did a governor malfunction cause this issue?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Engine is running
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with INSITE™ electronic service tool.

  • Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the panel tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor as outlined in Fault Code 121.

Go to 1C

Troubleshoot Fault Code 121.

Guided Step 1C - Inspect the engine harness and engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensors.

Action

Inspect the engine harness and engine speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Ben or broken pins
  • Pushed back or expanded pins
  • Moisture in or on connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged connector pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an inactive fault code at low engine rpm.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code at low engine rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Inactive fault code at low rpm?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Test the engine.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 234 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning. A failure mode had to have been detected.

Go to 2B

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 234 is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | GTA855 CM558/CM2358 N101 | 4021702
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the engine speed sensor and connector pins connected to sensor supply number 3. | Dirty or damaged pins?
 | STEP 2A-1. Check for circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a short circuit to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the gas mass flow sensor and connector pins connected to sensor supply number 3.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the engine speed sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine speed sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins.Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM
  • Disconnect the gas mass flow sensor from the engine harness
  • Make sure all components connected to sensor supply number 3 circuit are disconnected.

Action

Check for pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector 1 to all other pins in the engine connector 2.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 3 circuit line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM
  • Disconnect the gas mass flow sensor from the engine harness
  • Make sure all components connected to sensor supply number 3 circuit are disconnected.

Action

Check for a pin to ground short.

  • Measure the resistance between the sensor SUPPLY voltage number 3 pin in the engine harness ECM connector 1 and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the sensor supply number 3 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 239 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 239 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the crankshaft speed/position sensor from the engine harness
  • Make sure all components connected to sensor supply number 3 circuit are disconnected.

Action

Check for pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector 1 to all other pins in the engine connector 2.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 3 circuit line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 239 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 244 - Red Stop Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | GTA855 CM558/CM2358 N101 | 4021702
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 244 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair the OEM harness connector.

Reference to the G8.3, G5.9, G855, and GTA855, Panel System Master Repair Manual, Bulletin 4021701.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector.
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from red stop lamp driver on the OEM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relays.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector.
  • Remove the diagnostic lamp.

Action

Check the OEM control panel and relays.

  • Reference the G8.3, G5.9, G855, and GTA855, Panel System Master Repair Manual, Bulletin 4021701.

More than 100k ohms?
YES NO
No Repair

  • Reference the G8.3, G5.9, G855, and GTA855, Panel System Master Repair Manual, Bulletin 4021701.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

Replace the harness or ECM, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from red stop lamp driver in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector.
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 3 in the ECM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let it idle for 1 minute.

Fault Code 244 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 254 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Fuel Shutoff Valve | Refer to Procedure 019-050 | GTA855 CM558/CM2358 N101 | 4021702
Fuel Shutoff Valve | Refer to Procedure 019-050 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the valve supply voltage. | Greater than 20-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558/CM2358 response. |
 | STEP 4A. Check for the appropriate CM558/CM2358 response. | Fault Code 254 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 254 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Turn keyswitch ON
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect INSITE™ electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

Make sure that the engine is not performing a purge cycle when making this measurement.

Greater than 20-VDC?
YES NO
No Repair

Check the battery connections and the fuses in the harness. Reference the circuit diagram or wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Turn keyswitch OFF
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel shutoff valve and the CM558/CM2358.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Reference the circuit diagram or wiring diagram for connector pin identification.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558/CM2358 response.

Guided Step 4A - Check for the appropriate CM558/CM2358 response.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector from the fuel shutoff valve.
  • Place run/stop/auto switch in RUN mode and engine cranking.

Action

Check for the appropriate CM558/CM2358 response.

  • Install a jumper to power the fuel shutoff valve relays and then crank the engine. Refer to the circuit diagram or wiring diagram for the appropriate circuit.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 254 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 254 is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Jan-2014


FAULT CODE 277 - Electronic Fuel Injection Control Valve Circuit - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Fuel Shutoff Valve Circuit | Refer to Procedure 019-049 | GTA855 CM558/CM2358 N101 | 4021702
Fuel Shutoff Valve Circuit | Refer to Procedure 019-049 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 277 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
 | STEP 2D. Check the butterfly valve. | Debris found or valve difficult to move?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 277 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 277 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 277 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel control valve. Refer to Procedure 019-049 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the electronic fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-049 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-049 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the butterfly valve.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the butterfly valve.

Remove the electronic fuel control valve assembly from the engine fuel supply. Refer to Procedure 019-049 in Section 19.

Inspect the butterfly valve and housing for the following:

  • Debris
  • Mineral buildup
  • Difficult movement of the butterfly valve.

Debris found or valve difficult to move?
YES NO

Remove the blockage and clean the electronic fuel control valve, if possible. If the electronic fuel control valve is damaged or not repairable, replace the entire fuel control valve assembly. Refer to Procedure 019-049 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the electronic fuel control valve connector to the engine harness connector
  • Disconnect the engine harness connector from the ECM 47-pin connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector
  • Disconnect the engine harness connector from the ECM 47-pin connector.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Codes 277 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Refer to the circuit diagram or wiring harness for all harness interconnections.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the electronic fuel control valve. Refer to Procedure 019-049 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 277 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active?
 | STEP 1B. Check the power supply. | Constant +24-VDC power supply to the ECM?
 | STEP 1C. Check ECM for a short circuit to ground. | More than 100k ohms?
 | STEP 1D. Recalibrate the ECM. | ECM recalibrated successfully?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use the keyswitch to recycle the power to the ECM.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the OEM connector as a possible source of an intermittent power supply.

Constant +24-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 47-pin OEM connector. Reference the Master Repair Manual G8.3, G5.9, G855, and GTA855 Panel System, Bulletin 4021701.

Go to 1C

Go to 2A

Guided Step 1C - Check ECM for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

More than 100k ohms?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Recalibrate the ECM.

Conditions

  • Turn keyswitch OFF
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in the Associated Procedures Table.

ECM calibrated successfully?
YES NO
No Repair

Active fault codes present.

  • Calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 343 is inactive.

Fault Code 343 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 10-Mar-2017


FAULT CODE 346 - Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | GTA855 CM558/CM2358 N101 | 4021702
ECM Calibration Code | Refer to Procedure 019-032 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 346 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Check the ECM ground. | More than 100k ohms?
 | STEP 1D. Recalibrate the ECM. | Fault Code 346 active after recalibration?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 346 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 346 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2B

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the OEM connector as a possible source of an intermittent power supply.
  • Make certain the power supply to the ECM is constant and not intermittent.

Constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 47-pin OEM connector. Reference the Master Repair Manual G8.3, G5.9, G855 and GTA855 Panel System, Bulletin 4021701.

Go to 1C

Go to 2A

Guided Step 1C - Check the ECM ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

More than 100k ohms?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Recalibrate the ECM.

Conditions

  • Turn keyswitch OFF
  • Connect all components.

Action

Recalibrate the ECM.

  • Refer to Procedure 019-032 in the Associated Procedures Table.

Fault Code 346 active after calibration?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 346 is inactive.

Fault Code 346 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and chaecked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 04-Feb-2017


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | GTA855 CM558/CM2358 N101 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Carburetor Inlet Gas Differential Pressure Sensor | Refer to Procedure 019-457 | GTA855 CM558/CM2358 N101 | 4021702
Carburetor Inlet Gas Differential Pressure Sensor | Refer to Procedure 019-457 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure/temperature sensor and connector pins connected to the sensor supply number 1. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the carburetor inlet gas differential pressure sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure/temperature sensor and connector pins connected to the sensor supply number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold 1 pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

Go to 2B

Go to 4B

Guided Step 2B - Inspect the carburetor inlet gas differential pressure sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure/temperature sensor from the engine harness.

Action

Inspect the caruretor inlet gas differential pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake manifold 1 pressure/temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the carburetor inlet gas differential pressure sensor. Refer to Procedure 019-457 in the Associated Procedures Table.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and connector B from the ECM.
  • Disconnect the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor from the engine harness.
  • Disconnect all components connected to sensor supply 1.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector A to all other pins in the engine connector A.
  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector A to all other pins in the engine connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A from the ECM.
  • Disconnect the intake manifold 1 pressure/temperature sensor and the carburetor inlet gas differential pressure sensor from the engine harness.
  • Disconnect all components connected to sensor supply 1.

Action

Check for a pin short to ground.

  • Measure the resistance between the sensor supply number 1 pin in the engine harness ECM connector A and ground.

More than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault Code 352 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 354 - Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | GTA855 CM558/CM2358 N101 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 386. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 355 active and Fault Code 354 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.5 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 354 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 354 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor SUPPLY fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 386.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold 1 pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold 1 pressure sensor connector pins for the following:

  • Loose Connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, replace the sensor or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 355 active and Fault Code 354 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and RETURN circuit.

  • Measure the voltage between the 5-VDC SUPPLY pin and the intake manifold pressure RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the intake manifold pressure sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose Connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the intake manifold pressure sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness to all other pins in the engine connector A.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness connector A to all pins in engine harness ECM connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure sensor 5-VDC SUPPLY pin in engine harness connector A and all other pins in the ECM connector A.
  • Measure the resistance between the intake manifold pressure 5-VDC SUPPLY pin in engine harness connector A and all pins in engine harness ECM connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 354 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 18-Apr-2014


FAULT CODE 355 - Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | GTA855 CM558/CM2358 N101 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 355 inactive?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure 1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.5 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 354 active and Fault Code 355 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 355 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 355 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 355 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure 1 sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure 1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure 1 sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure 1 sensor connector pins for the following:

  • Loose Connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, replace the sensor or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure 1 sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and RETURN circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the intake manifold pressure RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure 1 sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake pressure SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active and Fault Code 355 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the intake manifold pressure 1 sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose Connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins.

Repair or replace the harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A SUPPLY pin and the intake manifold pressure sensor connector SUPPLY pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A SIGNAL pin and the intake manifold pressure sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in engine harness.

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector A and all other pins in the connector A.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector A and all pins in connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector A and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 355 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 386 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector A and connector B from the ECM.
  • Disconnect the intake manifold 1 pressure/temperature sensor and carburetor inlet gas differential pressure sensor from the harness.
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector A and all other pins in the engine connector A.
  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector B and all other pins in the engine connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techiques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor SUPPLY number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 386 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM558/CM2358 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading is correct?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Is oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 415 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute. Add atmospheric pressure to the gauge reading.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if the electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check the engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch on
  • Connect a mechanical oil pressure gauge
  • Connect INSITE™ electronic service tool
  • Engine running at idle speed.

Action

Check the engine oil pressure.

  • Reference Procedure 007-052 in Section 7 in the appropriate service manual.

Is oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 415 is inactive.

If the fault was at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 415 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM558/CM2358 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 421 active?
 | STEP 1B. Verify engine oil temperature is high. | Engine oil temperature high?
STEP 2. | Check the engine oil pressure/temperature sensor. |
 | STEP 2A. Inspect the engine harness and engine oil pressure/temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 421 active?
 | STEP 2C. Check the resistance of the sensor. | Between 300 and 90k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 421 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Read the fault codes.

Fault Code 421 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3B

Guided Step 1B - Verify engine oil temperature is high.

Conditions

  • Turn keyswitch ON.

Action

Verify engine oil temperature is high.

  • Verify engine oil temperature by using the mechanical gauge.

Engine oil temperature high?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine oil pressure/temperature sensor.

Guided Step 2A - Inspect the engine harness and engine oil pressure/temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the engine harness from the engine oil pressure/temperature sensor.

Action

Inspect the engine harness and oil pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 421 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the resistance of the sensor.

Conditions

  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the engine oil pressure/temperature sensor from the engine harness.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine oil temperature SIGNAL pin to the engine oil pressure/temperature RETURN pin in the engine oil pressure/temperature sensor.

Between 300 and 90k ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 421 is inactive.

Fault Code 421 inactive
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 426 - J1939 Network Number 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Refer to Procedure 019-165 in Section 19.

Go to the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 13-Aug-2012


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 2. | Check for a damaged voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
 | STEP 2B. Determine battery voltage. | Battery voltage between 11.5-VDC and 15.0-VDC?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Blown fuses?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between 11.5-VDC and 15.0-VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check for a damaged voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701 or equivalent, for details on how to perform this procedure.

Relay installed?
YES NO

Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Battery voltage between 11.5-VDC and 15.0-VDC?
YES NO
No Repair

A malfunctioning battery has been detected.

Replace the malfunctioning battery or batteries. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM harness and connector pins.

  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701 or equivalent, for information on how to perform this procedure.

Dirty or damaged pins?
YES NO

Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness panel.

Conditions

  • Turn keyswitch OFF

Action

Inspect the fuses in the engine harness panel.

  • Open the service panel by loosening the screw clamps
  • Inspect the circuit board and locate the glass fuses
  • Inspect the fuses for a black discoloration in the glass. This signifies the fuse is not good.

Damaged fuse?
YES NO

A damaged or blown fuse has been located. Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector A unswitched battery SUPPLY pins and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5-VDC and 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 4F

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector A and the 47 pin OEM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector A.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 2. | Check for a malfunctioning voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Blown fuses?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between 11.5-VDC and 15.0-VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check for a malfunctioning voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701 for details on how to perform this procedure.

Relay installed?
YES NO

Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701 for details on how to perform this procedure.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701 for details on how to perform this procedure.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness panel.

Conditions

  • Turn keyswitch OFF

Action

Inspect the fuses in the engine harness panel.

  • Open the service panel by loosening the screw clamps.
  • Inspect the circuit board and locate the glass fuses.
  • Inspect the fuses for a black discoloration in the glass. This indicates the fuse is not good.

Damaged fuse?
YES NO

A damaged or blown fuse has been located. Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector A unswitched battery SUPPLY pins and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5-VDC and 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 4F

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector A and the 47-pin OEM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector A.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 477 - Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 477 inactive?
STEP 2. | Check for a malfunctioning voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
 | STEP 2B. Determine battery voltage. | Battery voltage between 11.5-VDC and 15.0-VDC?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Blown fuses?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between 11.5-VDC and 15.0-VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 477 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 477 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 477 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check for a malfunctioning voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

Relay installed?
YES NO

Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Battery voltage between 11.5-VDC and 15.0-VDC?
YES NO
No Repair

A malfunctioning battery has been detected.

Replace the malfunctioning battery or batteries. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358 Master Repair Manual, Bulletin 4021701.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness panel.

Conditions

  • Turn keyswitch OFF

Action

Inspect the fuses in the engine harness panel.

  • Open the service panel by loosening the screw clamps.
  • Inspect the circuit board and locate the glass fuses.
  • Inspect the fuses for a black discoloration in the glass. This indicates the fuse is not good.

Damaged fuse?
YES NO

A damaged or blown fuse has been located. Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector A unswitched battery SUPPLY pins and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5-VDC and 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 4F

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector A and the 47-pin OEM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin to pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector A.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector B.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 477 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 477 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 478 - Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 478 inactive?
STEP 2. | Check for a damaged voltage source. |
 | STEP 2A. Determine if the OEM control panel has a battery voltage shutoff relay. | Relay installed?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the fuses in the engine harness service panel. | Blown fuses?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the voltage at the ECM. | Voltage between 11.5-VDC and 15.0-VDC?
 | STEP 4D. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4F. Check for an inactive fault code. | Fault Code 478 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 478 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 478 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check for a damaged voltage source.

Guided Step 2A - Determine if the OEM control panel has a battery voltage shutoff relay.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the OEM control panel has a battery voltage shutoff relay.

  • Reference G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701 for details on how to perform this procedure.

Relay installed?
YES NO

Reference G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701 for details on how to perform this procedure.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 47-pin OEM harness connector.

Action

Inspect the OEM harness and connector pins.

  • Reference G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701 for details on how to perform this procedure.

Dirty or damaged pins?
YES NO

Reference G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the fuses in the engine harness panel.

Conditions

  • Turn keyswitch OFF

Action

Inspect the fuses in the engine harness panel.

  • Open the service panel by loosening the screw clamps
  • Inspect the circuit board and locate the glass fuses
  • Inspect the fuses for a black discoloration in the glass. This indicates the fuse is not good.

Damaged fuse?
YES NO

A damaged or blown fuse has been located. Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector A unswitched battery SUPPLY pins and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5-VDC and 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 4F

Go to 4D

Guided Step 4D - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector A and the 47 pin OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector A and connector B from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector A.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector A and all other pins in the engine connector B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 478 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 478 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-354 | GTA855 CM558/CM2358 N101 | 4021702
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-354 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 488 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Temperature within 3°C [5°F]?
STEP 3. | Check the intake pressure/temperature sensor. |
 | STEP 3A. Inspect the intake pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 488 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 488 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold temperature reading from INSITE™ electronic service tool to the reading from the probe.

If no temperature measuring device is available, answer “NO” to this step.

Temperature within 3°C [5°F]?
YES NO

Replace the intake pressure/temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the intake manifold 1 pressure/temperature sensor.

Guided Step 3A - Inspect the intake pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 488 is inactive.

Fault Code 488 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 512 - Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Inspect the throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 512 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO

Refer to Procedure 019-362 in Section 19.

No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the throttle actuator and circuit.

Guided Step 2A - Inspect the throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair the damaged pins. Repair or replace the harness, or replace the throttle actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the throttle actuator. Reference Procedure 005-052 in Section 5 in the appropriate troubleshooting and repair manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ICM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle actuator SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle actuator SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator command supply line or position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 512 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 513 - Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Inspect the throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle actuator battery voltage and ground. | Greater than 12-VDC?
 | STEP 2C. Check the resistance in the switched battery and ground. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 513 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO

Refer to Procedure 019-362 in Section 19.

No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the throttle actuator and circuit.

Guided Step 2A - Inspect the throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair the damaged pins. Repair or replace the throttle actuator, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the throttle actuator. Reference Procedure 005-052 in Section 5 in the appropriate troubleshooting and repair manual.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the throttle actuator battery voltage and ground.

Conditions

  • Turn keyswitch OFF
  • Using a break-out harness or piercing probes so a load is on the voltage supply
  • Turn keyswitch ON.

Action

Check the throttle actuator battery voltage.

  • Check switched battery voltage on pins A and B for battery voltage (bad fuse or voltage drop will be shown by being hooked to actuator).

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 12-VDC?
YES NO
No Repair

Determine the root cause for no or insufficient switched battery voltage.

Go to 3B-1

Go to 2C

Guided Step 2C - Check the resistance in the throttle actuator battery voltage and ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the throttle actuator from the engine harness
  • Turn keyswitch ON.

Action

Check the throttle actuator battery voltage to ground.

  • Measure the resistance between the throttle actuator battery voltage pin and ground at the throttle actuator connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

Replace the throttle actuator.

Reference Procedure 005-052 in Section 5 in the appropriate troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness.

Repair the damaged pins. Repair or replace the harness, or replace the ECM,whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM
  • Disconnect the throttle actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 throttle actuator switched battery (+) pin and the throttle actuator connector switched battery (+) pin in the engine harness.
  • Measure the resistance between the engine harness ECM connector 1 throttle actuator RETURN pin and the throttle actuator connector RETURN pin of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM
  • Disconnect the throttle actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 throttle position (+) pin and the throttle position (+) pin of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open supply circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the throttle actuator switched battery (+) pin in the engine harness ECM connector 1 and ground.
  • Measure the resistance between the throttle position (+) pin in the engine harness ECM connector 1 and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the throttle actuator supply or the throttle position signal lines has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle actuator switched battery (+) pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle actuator switched battery (+) pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.
  • Measure the resistance between the throttle position (+) pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle position (+) pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator command supply line or position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 513 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 697 - ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 697 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 13-Aug-2012


FAULT CODE 698 - ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON
  • Place run/stop/auto switch in RUN mode and running for greater than 1 minute.Place

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 698 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 13-Aug-2012


FAULT CODE 783 - Intake Manifold 1 Temperature - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-354 | GTA855 CM558/CM2358 N101 | 4021702
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-354 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 1 temperature sensor accuracy. |
 | STEP 1A. Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Does the thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 783 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold 1 temperature sensor accuracy.

Guided Step 1A - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold except at the probe threads.
  • Compare the intake manifold 1 temperature sensor reading on INSITE™ service tool monitor screen to the reading from the temperature probe.
  • If a temperature measuring device is not available, answer YES to this step.

Does the thermocouple reading agree with the intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

A damaged intake manifold 1 temperature sensor has been detected.

Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

Go to

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 783 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 1665 - Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1665 inactive?
STEP 2. | Check the aftertreatment catalyst inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment catalyst inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1666 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1665 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1665 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1665 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment catalyst inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment catalyst inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment catalyst inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment catalyst inlet temperature sensor sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or connector.

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

Repair or replace the sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment catalyst inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment catalyst inlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 active?
YES NO

Replace the aftertreatment catalyst inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment catalyst inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment catalyst inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment catalyst inlet temperature sensor from the wiring harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the aftertreatment catalyst inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1665 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Aug-2012


FAULT CODE 1666 - Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1666 inactive?
STEP 2. | Check the aftertreatment catalyst inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment catalyst inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1665 active and Fault Code 1666 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1666 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1665 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1666 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment catalyst inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment catalyst inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment catalyst inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel oxidation catalyst inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replair or replace the sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment catalyst inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment catalyst inlet temperature SIGNAL pin and the aftertreatment catalyst inlet temperature RETURN pin at the sensor connector of the wiring harness.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 active and Fault Code 1666 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment catalyst inlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 active?
YES NO

A damaged aftertreatment catalyst inlet temperature sensor has been detected.

Replace the aftertreatment catalyst inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

  • Repair or replace the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment catalyst inlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment catalyst inlet temperature sensor RETURN pin and the wiring harness aftertreatment catalyst inlet temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment catalyst inlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment catalyst inlet temperature sensor SIGNAL pin and the wiring harness aftertreatment catalyst inlet temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment catalyst inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment catalyst inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1666 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Aug-2012


FAULT CODE 1674 - Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1674 inactive?
STEP 2. | Check the aftertreatment outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1675 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1674 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1674 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1674 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fautl codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 active?
YES NO

Replace the aftertreatment outlet temperature sensor. Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment outlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment outlet temperature sensor SIGNAL pin in the OEM harness ECM connector an all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment outlet temperature sensor from the wiring harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the aftertreatment outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1674 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Aug-2012


FAULT CODE 1675 - Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558 (CM2358) G101 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1675 inactive?
STEP 2. | Check the aftertreatment outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1674 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1675 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1675 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1675 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel particulate filter inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet temperature sensor from the wiring harness.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment outlet temperature SIGNAL pin and the aftertreatment outlet temperature RETURN pin at the sensor connector of the wiring harness.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES NO

A damaged aftertreatment outlet temperature sensor has been detected.

Replace the aftertreatment outlet temperature sensor. Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment outlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment outlet temperature sensor RETURN pin and the OEM harness aftertreatment outlet temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment outlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment outlet temperature sensor SIGNAL pin and the wiring harness aftertreatment outlet temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected n the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 1675 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1675 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 20-Aug-2014


FAULT CODE 1739 - Engine Throttle Control Actuator - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other issues |
 | STEP 1A. Check for active or inactive fault codes. | No active or inactive fault codes?
STEP 2. | Check for actuator issues. |
 | STEP 2A. Inspect the 16-pin connector pins. | Dirty or damaged pins?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1739 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for other issues.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive Fault Codes 177, 234, 441, 442, 512, 513, 1791, 1978, 1979, 2455, or 2456.

No active or inactive fault codes?
YES NO

Troubleshoot the active fault code identified.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check for actuator issues.

Guided Step 2A - Inspect the 16-pin connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 16-pin connector.

Action

Inspect the 16-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins. Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701, or equivalent.

Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701, or equivalent.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1739 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 1776 - Power Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1776 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Key switch in the OFF position.
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness connector or OEM harness connector, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the harness. Refer to Procedure 019-071 in Section 19.
  • Repair the ignition ground Deutsch connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position
  • Disconnect the OEM connector
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from Run/Stop switch on the OEM connector to the engine block ground.

More than 100k ohms?
YES NO

  • Replace the harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2A

Guided Step 1C - Check the OEM control panel and relay.

Conditions

  • Key switch in the OFF position.

Action

Check the OEM control panel and relay.

  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

Any issues?
YES NO

Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701, for instructions on how to resolve the issue.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Key switch in the OFF position
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Key switch in the OFF position
  • Disconnect the OEM connector
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from battery conservation relay supply ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Key switch in the OFF position
  • Disconnect the OEM connector
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from battery conservation relay supply ECM connector to the engine block ground.

More than 100k ohms?
YES NO

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 1776 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO

Troubleshoot any remaining active fault codes.

Troubleshoot any remaining active fault codes.

Appropriate Troubleshooting chart

Repair complete.

Last Modified: 24-Jan-2014


FAULT CODE 1777 - Power Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1777 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness connector or OEM harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section.
  • Repair the 21 pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from run/stop switch on the OEM connector to the engine block ground.

More than 100k ohms?
YES NO

  • Replace the OEM harness. Refer to Procedure 019-071 in Section.

No Repair

Go to 3A

Go to 2A

Guided Step 1C - Check the OEM control panel and relay.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel and relay.

  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

Any issues?
YES NO

Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701, for instructions on how to resolve the issue.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from ECM connector B battery conservation relay supply to all of the other pins in the connector.

More than 100k ohms?
YES NO

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from ECM connector B battery conservation relay supply to the engine block ground.

More than 100k ohms?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 1777 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Jan-2014


FAULT CODE 1791- Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1791 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive fault codes.

Active or inactive fault codes?
YES NO

One or more active fault codes.

Reference the appropriate troubleshooting tree.

Inspect the ignition system.

Reference the Engine Unable to Pull Load troubleshooting symptom tree in Section TS.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and idle for 1 minute.

Fault Code 1791 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 13-Aug-2012


FAULT CODE 1824 - Engine Oil Temperature Sensor 1 Circuit, Too Cold For High Idle - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM558/CM2358 N101 | 4021702
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | GTA855 CM558/CM2358 N101 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1824 inactive?
STEP 2. | Check the oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 175 and 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1824 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1824 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1824 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil temperature sensor and circuit.

Guided Step 2A - Inspect the oil pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oil temperature sensor from the engine harness.

Action

Inspect the engine harness and oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine oil temperature sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the oil temperature sensor connector.
  • Make sure the engine has idled for a sufficient amount of time to allow the oil to reach normal operating temperatures at idle.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 175 and 274k ohms?
YES NO

Reference the appropriate wiring diagram for sensor specifications.

Replace the engine oil temperature sensor. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the oil temperature RETURN pin and the ECM connector 1 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the ECM connector 1 SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the oil temperature SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the oil temperature SIGNAL pin in engine harness and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1824 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1824 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 1858 - Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | GTA855 CM558/CM2358 N101 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 1858 active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the heated oxygen sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1858 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1858 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1858 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Engine not running
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Measure the heated oxygen sensor heater supply voltage.

  • Measure the heated oxygen sensor heater SUPPLY voltage from the engine harness connector to chassis ground.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or short circuit to ground in the heated oxygen sensor SUPPLY wire. Check the OEM voltage supply and heated oxygen sensor relays. Repair or replace the heated oxygen heater line.

  • Refer to the OEM service manual and the note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the heated oxygen sensor heater.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the heated oxygen sensor heater.

  • Measure the resistance between the heated oxygen sensor heater positive and the heated oxygen sensor heater negative at the heated oxygen connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the heated oxygen sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1858 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the heated oxygen sensor heater negative pin on the heated oxygen sensor engine harness connector to the heated oxygen sensor heater negative pin on the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the heated oxygen heater negative pin in engine harness connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1858 is inactive.

Fault Code 1858 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 1859 - Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | GTA855 CM558/CM2358 N101 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

WARNING

Do not touch the aftertreatment inlet oxygen concentration sensor until it has cooled. The aftertreatment inlet oxygen concentration sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the aftertreatment inlet oxygen concentration sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1859 active?
STEP 2. | Check the aftertreatment inlet oxygen concentration sensor. |
 | STEP 2A. Inspect the OEM harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the aftertreatment inlet oxygen concentration sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1859 active?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1859 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1859 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment inlet oxygen concentration sensor.

Guided Step 2A - Inspect the OEM harness and aftertreatment inlet oxygen concentration sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment oxygen concentration sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness.Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Engine not running
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the OEM harness.

Action

Measure the aftertreatment inlet oxygen concentration sensor heater supply voltage.

  • Measure the aftertreatment inlet oxygen concentration sensor heater SUPPLY voltage from the engine harness connector to chassis ground.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or short circuit to ground in the aftertreatment inlet oxygen concentration sensor SUPPLY wire. Check the OEM voltage supply and aftertreatment inlet oxygen concentration sensor relays. Repair or replace the aftertreatment inlet oxygen concentration heater line.

  • Refer to the OEM service manual and the note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment inlet oxygen concentration sensor heater.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the OEM harness.

Action

Check the heated aftertreatment inlet oxygen concentration heater.

  • Measure the resistance between the aftertreatment inlet oxygen concentration sensor heater positive and the aftertreatment inlet oxygen concentration sensor heater negative at the aftertreatment inlet oxygen concentration connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment inlet oxygen concentration sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1859 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and panel connections.

Conditions

  • Disconnect the battery power after turning keyswitch to OFF.
  • Disconnect the aftertreatment inlet oxygen concentration leads from the customer panel strip.

Action

Inspect the OEM harness and wiring for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness.Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Disconnect the battery power after turning keyswitch to OFF.
  • Disconnect aftertreatment inlet oxygen concentration leads from the customer panel strip.
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment inlet oxygen concentration sensor heater negative pin on the aftertreatment inlet oxygen concentration sensor engine harness connector to the aftertreatment inlet oxygen concentration sensor heater negative pin on the OEM panel connector strip.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM engine harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment inlet oxygen concentration sensor leads from the OEM panel connector strip.
  • Disconnect the OEM harness from the aftertreatment inlet oxygen concentration sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the aftertreatment inlet oxygen concentration heater negative pin in OEM harness connector to ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1859 is inactive.

Fault Code 1859 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 1861 - Aftertreatment Inlet Oxygen Concentration Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | GTA855 CM558/CM2358 N101 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

WARNING

Do not touch the aftertreatment inlet oxygen concentration sensor until it has cooled. The aftertreatment inlet oxygen concentration sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the aftertreatment inlet oxygen concentration sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 1861 active?
STEP 2. | Check the aftertreatment inlet oxygen concentration sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the aftertreatment inlet oxygen concentration sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1861 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1861 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1861 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment inlet oxygen concentration sensor.

Guided Step 2A - Inspect the engine harness and aftertreatment inlet oxygen concentration sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment inlet oxygen concentration sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness.Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Engine not running
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the engine harness.

Action

Measure the aftertreatment inlet oxygen concentration sensor heater supply voltage.

  • Measure the aftertreatment inlet oxygen concentration sensor heater supply voltage from the engine harness connector to chassis ground.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or short circuit to ground in the aftertreatment inlet oxygen concentration sensor SUPPLY wire. Check the OEM voltage supply and aftertreatment inlet oxygen concentration sensor fuse. Repair or replace the aftertreatment inlet oxygen concentration heater line.

  • Refer to the OEM service manual and the note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment inlet oxygen concentration sensor heater.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the engine harness.

Action

Check the aftertreatment inlet oxygen concentration sensor heater.

  • Measure the resistance between the aftertreatment inlet oxygen concentration sensor heater positive and the aftertreatment inlet oxygen concentration sensor heater negative at the aftertreatment inlet oxygen concentration connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the aftertreatment inlet oxygen concentration sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment inlet oxygen concentration sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1861 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the aftertreatment inlet oxygen concentration sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment inlet oxygen concentration sensor heater negative pin on the aftertreatment inlet oxygen concentration sensor engine harness connector to the aftertreatment inlet oxygen concentration sensor heater negative pin on the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the aftertreatment inlet oxygen concentration sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the aftertreatment inlet oxygen concentration heater negative pin in engine harness connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1861 is inactive.

Fault Code 1861 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 1862 - Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | GTA855 CM558/CM2358 N101 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

WARNING

Do not touch the heated aftertreatment outlet oxygen concentration sensor until it has cooled. The heated aftertreatment outlet oxygen concentration sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated aftertreatment outlet oxygen concentration sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 1862 active?
STEP 2. | Check the heated aftertreatment outlet oxygen concentration sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the heated aftertreatment outlet oxygen concentration sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1862 active?
STEP 3. | Check the engine harness and OEM harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins and OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1862 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1862 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the heated aftertreatment outlet oxygen concentration sensor.

Guided Step 2A - Inspect the engine harness, OEM harness, and heated aftertreatment outlet oxygen concentration sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Inspect the OEM harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-071 in Section 19.
  • Replace the heated aftertreatment outlet oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Engine not running
  • Disconnect the heated aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Measure the heated oxygen sensor heater supply voltage.

  • Measure the heated aftertreatment outlet oxygen concentration sensor heater supply voltage from the OEM harness connector to chassis ground.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or a short circuit to ground in the heated aftertreatment outlet oxygen concentration sensor SUPPLY wire. Check the OEM voltage supply and heated aftertreatment outlet oxygen concentration sensor fuse. Repair or replace the heated oxygen heater wire.

  • Refer to the OEM service manual and the Note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the heated aftertreatment outlet oxygen concentration sensor heater.

Conditions

  • Turn keyswitch OFF
  • Disconnect the heated aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Check the heated oxygen sensor heater.

  • Measure the resistance between the heated aftertreatment outlet oxygen concentration sensor heater positive and the heated aftertreatment outlet oxygen concentration sensor heater negative at the heated oxygen connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the heated aftertreatment outlet oxygen concentration sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the heated aftertreatment outlet oxygen concentration sensor to the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1862 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the heated aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the heated aftertreatment outlet oxygen concentration sensor heater negative pin on the heated aftertreatment outlet oxygen concentration sensor engine harness connector to the heated aftertreatment outlet oxygen concentration sensor heater negative pin on the ECM connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine or OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.
  • Disconnect the OEM harness from the heated aftertreatment outlet oxygen concentration sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the heated oxygen heater negative pin in engine harness connector A to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1862 is inactive.

Fault Code 1862 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 1863 - Aftertreatment Outlet Oxygen Concentration Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | GTA855 CM558/CM2358 N101 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

WARNING

Do not touch the aftertreatment outlet oxygen concentration sensor until it has cooled. The aftertreatment outlet oxygen concentration sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the aftertreatment outlet oxygen concentration sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 1862 active?
STEP 2. | Check the aftertreatment outlet oxygen concentration sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the aftertreatment outlet oxygen concentration sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1862 active?
STEP 3. | Check the engine harness and OEM harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins and OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1862 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1862 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment outlet oxygen concentration sensor.

Guided Step 2A - Inspect the engine harness, OEM harness, and aftertreatment outlet oxygen concentration sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Inspect the OEM harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-071 in Section 19.
  • Replace the aftertreatment outlet oxygen concentration sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Engine not running
  • Disconnect the aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Measure the heated oxygen sensor heater supply voltage.

  • Measure the aftertreatment outlet oxygen concentration sensor heater supply voltage from the OEM harness connector to chassis ground.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or a short circuit to ground in the aftertreatment outlet oxygen concentration sensor SUPPLY wire. Check the OEM voltage supply and aftertreatment outlet oxygen concentration sensor fuse. Repair or replace the aftertreatment outlet oxygen concentration heater wire.

  • Refer to the OEM service manual and the Note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment outlet oxygen concentration sensor heater.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Check the heated oxygen sensor heater.

  • Measure the resistance between the aftertreatment outlet oxygen concentration sensor heater positive and the aftertreatment outlet oxygen concentration sensor heater negative at the aftertreatment outlet oxygen concentration connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the aftertreatment outlet oxygen concentration sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment outlet oxygen concentration sensor to the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1862 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment outlet oxygen concentration sensor heater negative pin on the aftertreatment outlet oxygen concentration sensor engine harness connector to the aftertreatment outlet oxygen concentration sensor heater negative pin on the ECM connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine or OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.
  • Disconnect the OEM harness from the aftertreatment outlet oxygen concentration sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the aftertreatment outlet oxygen concentration heater negative pin in engine harness connector 1 to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1862 is inactive.

Fault Code 1862 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 1864 - Aftertreatment Outlet Oxygen Concentration - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | GTA855 CM558/CM2358 N101 | 4021702
Heated Oxygen Sensor | Refer to Procedure 019-100 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

WARNING

Do not touch the aftertreatment outlet oxygen concentration sensor until it has cooled. The aftertreatment outlet oxygen concentration sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the aftertreatment outlet oxygen concentration sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 1864 active?
STEP 2. | Check the aftertreatment outlet oxygen concentration sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 12-VDC?
 | STEP 2C. Check the aftertreatment outlet oxygen concentration sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1864 active?
STEP 3. | Check the engine harness and OEM harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins and OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1864 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1864 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment outlet oxygen concentration sensor.

Guided Step 2A - Inspect the engine harness, OEM harness, and aftertreatment outlet oxygen concentration sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Inspect the OEM harness and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-071 in Section 19.
  • Replace the aftertreatment outlet oxygen concentration sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON
  • Engine not running
  • Disconnect the aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Measure the heated oxygen sensor heater supply voltage.

  • Measure the aftertreatment outlet oxygen concentration sensor heater SUPPLY voltage from the OEM harness connector to chassis ground.

Supply voltage is greater than 12-VDC?
YES NO
No Repair

There is an open circuit or short circuit to ground in the aftertreatment outlet oxygen concentration sensor SUPPLY line. Check the OEM voltage SUPPLY and aftertreatment outlet oxygen concentration sensor fuse. Repair or replace the oxygen heater line.

Refer to the OEM service manual and the Note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the aftertreatment outlet oxygen concentration sensor heater.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Check the heated oxygen sensor heater.

  • Measure the resistance between the aftertreatment outlet oxygen concentration sensor heater positive and the aftertreatment outlet oxygen concentration sensor heater negative at the oxygen connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the aftertreatment outlet oxygen concentration sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the aftertreatment outlet oxygen concentration sensor to the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1864 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A from the ECM
  • Disconnect the aftertreatment outlet oxygen concentration sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment outlet oxygen concentration sensor heater negative pin on the aftertreatment outlet oxygen concentration sensor engine harness connector to the aftertreatment outlet oxygen concentration sensor heater negative pin on the ECM connector A.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.
  • Disconnect the OEM harness from the aftertreatment outlet oxygen concentration sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the oxygen heater negative pin in engine harness connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1864 is inactive.

Fault Code 1864 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 1965 - Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1965 or 1966 are active?
STEP 2. | Check the turbocharger outlet or exhaust outlet. |
 | STEP 2A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil contamination found in the turbocharger exhaust outlet?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1965 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1965 or 1966 are active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the turbocharger outlet.

Guided Step 2A - Inspect the exhaust outlet or turbocharger exhaust outlet for oil.

Conditions

  • Remove the exhaust outlet plumbing.

Action

Look for signs of oil in the exhaust outlet.

  • Inspect the exhaust outlet for signs of oil being introduced into the aftertreatment system from the engine.

Engine oil contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1966 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 27-Aug-2012


FAULT CODE 1966 - Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes are active?
STEP 2. | Check base engine components. |
 | STEP 2A. Inspect the turbocharger exhaust outlet for oil. | Engine oil contamination found in the exhaust outlet?
 | STEP 2B. Inspect the turbocharger exhaust outlet for oil GTA855 only. | Engine oil contamination found in the turbocharger exhaust outlet?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1966 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes are active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check base engine components.

Guided Step 2A - Inspect the exhaust outlet for oil.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the exhaust outlet for signs of oil being introduced into the aftertreatment system from the engine.

  • Look for a sign of moisture in the exhaust outlet.

Engine oil contamination found in the exhaust outlet?
YES NO

Locate cause of possible engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage.

Inspect the engine for other sources of engine oil entering the aftertreatment system.

Go to 3A

Go to 3A

Guided Step 2B - Inspect the exhaust outlet for oil GTA855 only.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the exhaust outlet for signs of oil being introduced into the aftertreatment system from the engine.

  • Look for a sign of moisture in the exhaust outlet.

Engine oil contamination found in the turbocharger exhaust outlet?
YES NO

Locate cause of possible engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage.

Inspect the engine for other sources of engine oil or diesel fuel entering the aftertreatment system.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • Idle the engine until the aftertreatment system cools below the engine protection temperature limit.

Fault Code 1966 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 29-Aug-2012


FAULT CODE 1968 - Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1969 active?
STEP 2. | Check the turbocharger outlet or exhaust outlet. |
 | STEP 2A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil contamination found in the turbocharger exhaust outlet?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1968 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1969 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the turbocharger outlet.

Guided Step 2A - Inspect the exhaust outlet or turbocharger exhaust outlet for oil.

Conditions

  • Remove the exhaust outlet plumbing.

Action

Look for signs of oil in the exhaust outlet.

  • Inspect the exhaust outlet for signs of oil being introduced into the aftertreatment system from the engine.

Engine oil contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1968 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2013


FAULT CODE 1969 - Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the turbocharger outlet or exhaust outlet. |
 | STEP 1A. Inspect the turbocharger exhaust outlet for oil. | Engine oil contamination found in the turbocharger exhaust outlet?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1969 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the turbocharger outlet.

Guided Step 1A - Inspect the exhaust outlet or turbocharger exhaust outlet for oil.

Conditions

  • Remove the exhaust outlet plumbing.

Action

Look for signs of oil in the exhaust outlet.

  • Inspect the exhaust outlet for signs of oil being introduced into the aftertreatment system from the engine.

Engine oil contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1969 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2013


FAULT CODE 1978 - Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit in the wiring. | More than 100k ohms?
STEP 2. | Check the customer interface box. |
 | STEP 2A. Check the 47-pin OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the wiring. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1978 Inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins. Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check for a short circuit to the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Check for a short circuit to the wiring harness as follows:

  • Measure the resistance from pin-17 on the OEM connector to all other pins on the OEM connector.
  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

More than 100k ohms?
YES NO
No Repair

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the Customer Interface Box.

Guided Step 2A - Inspect the 47-pin OEM connector pins.

Conditions

  • Place the keyswitch in the OFF position
  • Disconnect the 47-pin OEM connector.

Action

Inspect the 35-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins. Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 47-pin OEM connector
  • Disconnect the OEM connector.

Action

Check for a short circuit to the wiring harness as follows:

  • Measure the resistance from pin-17 on the 47-pin OEM connector to the other pins on the 47-pin OEM connector.
  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

More than 100k ohms?
YES NO
No Repair

  • Repair the customer interface box. Reference the G8.3, G5.9, G855, and GTA8.3 CM558/CM2358, Master Repair Manual Bulletin 4021701.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin to pin as follows:

  • Measure the resistance from Speed Adjustment 4-20 Supply on connector A in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1978 is inactive.

Fault Code 1978 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 1979 - Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
STEP 2. | Check the customer interface box. |
 | STEP 2A. Check the 47-pin OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1979 Inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins. Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin-17 on the OEM connector to all other pins on the OEM connector.
  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

More than 100k ohms?
YES NO
No Repair

  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the Customer Interface Box.

Guided Step 2A - Inspect the 47-pin OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 47-pin OEM connector.

Action

Inspect the 35-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins. Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 47-pin OEM connector
  • Disconnect the OEM connector.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin-17 on the 47-pin OEM connector to the other pins on the 47-pin OEM connector.
  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

More than 100k ohms?
YES NO
No Repair

  • Repair the customer interface box. Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the ECM and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from Speed Adjustment 4-20 Milliampere Supply on Connector A in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from Speed Adjustment 4-20 Milliampere Supply on Connector A in the ECM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1979 is inactive.

Fault Code 1979 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 1982 - Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1665, 1666, 1674, 1675?
STEP 2. | Check the temperature of the catalyst inlet and outlet. |
 | STEP 2A. Check the temperature of the catalyst inlet and outlet. | Greater than 10°C [50°F]?
STEP 3. | Check the aftertreatment sensor harnesses. |
 | STEP 3A. Check the aftertreatment exhaust gas inlet and outlet temperature sensors and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the sensor resistance. | Within range?
 | STEP 3C. Check the ECM and the engine harness. | Dirty or damaged pins?
 | STEP 3D. Check the OEM harness. | Damaged harness?
 | STEP 3E. Check if the signals for the inlet and outlet are reversed. | Wiring reversed?
STEP 4. | Check for misfire in one or more cylinders. |
 | STEP 4A. Check for misfire in each cylinder. | Misfire indicated?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 1978 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool or check for faults on the Electronic Engine Display (ED3).

Action

Check for active fault codes.

  • Use INSITE electronic service tool or the ED3 to read the fault codes.

Fault Codes 1665, 1666, 1674, or 1675 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the temperature of the catalyst inlet and outlet.

Guided Step 2A - Check the temperature of the catalyst inlet and outlet.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery
  • Allow the aftertreatment system to cool.

Action

Remove the aftertreatment inlet and outlet temperature sensors.

Use air temperature probe, Part Number 3824967 or equivalent, together with a multimeter and thermocouple module to measure and record the exhaust gas temperature both before and after the catalyst.

Calculate the temperature rise (outlet temperature minus inlet temperature).

Greater than 10°C [50°F]?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3A

Guided Step 3 - Check the aftertreatment sensor harnesses.

Guided Step 3A - Check the aftertreatment exhaust gas inlet and outlet temperature sensors and connector pins.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment wiring harness and aftertreatmentexhaust gas inlet and outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES | NO
No Repair | No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment exhaust gas inlet and outlet temperature sensors from the harness connectors.

Action

Check the exhaust gas temperature sensors circuit resistances.

  • Measure the resistance between the aftertreatment exhaust gas inlet and outlet temperature circuit SIGNAL pin and aftertreatment exhaust gas inlet and outlet temperature circuit RETURN pin at the aftertreatment exhaust gas temperature sensor circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification and a range of resistances for the sensor.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within range?
YES NO
No Repair

A damaged aftertreatment exhaust gas temperature sensor has been detected.

Replace the sensor. Refer to Procedure 019-449 in Section 19.

Go to 5A

Go to 3C

Guided Step 3C - Check the ECM and the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery.

Action

Check the OEM harness.

  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

Damaged harness?
YES NO

Repair or replace the harness. Refer to Procedure 019-071 in Section 19.

Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check if the signals for the inlet and outlet are reversed.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery
  • Allow the aftertreatment system to cool.

Action

Check if the signals for the inlet and outlet are reversed.

  • Use the wiring diagram to check if the inlet and outlet wiring is reversed at the customer panel.
  • Check for continuity between sensor connector and panel terminal strip at appropriate locations based on wiring diagram for inlet and outlet wiring.

Wiring reversed?
YES NO

Correct the problem by connecting the harness ends to the appropriate connections in the terminal strip.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check for misfire in one or more cylinders.

Guided Step 4A - Check for misfire in each cylinder.

Conditions

  • Engine operating at rated in closed loop.

Action

Check if the signals for the inlet and outlet are reversed.

Misfire indicated?
YES NO

Reference the Engine Runs Rough or Misfires troubleshooting symptom tree in the appropriate operation and maintenance manual.

Reference the Engine Shuts Down or Runs Rough After 90 Seconds troubleshooting symptom tree in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1978 is inactive.

Fault Code 1978 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 1983 - Catalyst Over Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558 (CM2358) G101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558 (CM2358) | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823917 - female Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1665, 1666, 1674, or 1675 active?
STEP 2. | Check the temperature of the catalyst inlet and outlet. |
 | STEP 2A. Check the temperature of the catalyst inlet and outlet. | Greater than 10°C [50°F]?
STEP 3. | Check the aftertreatment sensor harnesses. |
 | STEP 3A. Check the aftertreatment exhaust gas inlet and outlet temperature sensors and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the sensor resistance. | Within range?
 | STEP 3C. Check the ECM and the engine harness. | Dirty or damaged pins?
 | STEP 3D. Check the OEM harness. | Damaged harness?
 | STEP 3E. Check if the signals for the inlet and outlet are reversed. | Wiring reversed?
STEP 4. | Check for misfire in one or more cylinders. |
 | STEP 4A. Check for misfire in each cylinder. | Misfire indicated?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 1978 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool or check for faults on the Electronic Engine Display (ED3).

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool or the ED3 to read the fault codes.

Fault Codes 1665, 1666, 1674, or 1675 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the temperature of the catalyst inlet and outlet.

Guided Step 2A - Check the temperature of the catalyst inlet and outlet.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery
  • Allow the aftertreatment system to cool.

Action

Remove the aftertreatment inlet and outlet temperature sensors.

Use air temperature probe, Part Number 3824967 or equivalent, together with a multimeter and thermocouple module to measure and record the exhaust gas temperature, both before and after the catalyst.

Calculate the temperature rise (outlet temperature minus inlet temperature).

Greater than 10°C [50°F]?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3A

Guided Step 3 - Check the aftertreatment sensor harnesses.

Guided Step 3A - Check the aftertreatment exhaust gas inlet and outlet temperature sensors and connector pins.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment wiring harness and aftertreatmentexhaust gas inlet and outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment exhaust gas inlet and outlet temperature sensors from the harness connectors.

Action

Check the exhaust gas temperature sensors circuit resistances.

  • Measure the resistance between the aftertreatment exhaust gas inlet and outlet temperature circuit SIGNAL pin and aftertreatment exhaust gas inlet and outlet temperature circuit RETURN pin at the aftertreatment exhaust gas temperature sensor circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification and a range of resistances for the sensor.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within range?
YES NO
No Repair

A damaged aftertreatment exhaust gas temperature sensor has been detected.

Replace the sensor. Refer to Procedure 019-449 in Section 19.

Go to 5A

Go to 3C

Guided Step 3C - Check the ECM and the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery.

Action

Check the OEM harness.

  • Reference the G8.3, G5.9, G855, and GTA855 CM558 (CM2358), Master Repair Manual, Bulletin 4021701.

Damaged harness?
YES NO

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Reference to the G8.3, G5.9, G855, and GTA855 CM558 (CM2358), Master Repair Manual, Bulletin 4021701.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check if the signals for the inlet and outlet are reversed.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery
  • Allow the aftertreatment system to cool.

Action

Check if the signals for the inlet and outlet are reversed.

  • Use the wiring diagram to check if the inlet and outlet wiring is reversed at the customer panel.
  • Check for continuity between sensor connector and panel terminal strip at appropriate locations based on wiring diagram for inlet and outlet wiring.

Wiring reversed?
YES NO

Correct the problem by connecting the harness ends to the appropriate connections in the terminal strip.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check for misfire in one or more cylinders.

Guided Step 4A - Check for misfire in each cylinder.

Conditions

  • Engine operating at rated in closed loop.

Action

Check if the signals for the inlet and outlet are reversed.

Misfire indicated?
YES NO

Reference the Engine Runs Rough or Misfires troubleshooting symptom tree in the appropriate operation and maintenance manual.

Reference the Engine Shuts Down or Runs Rough After 90 Seconds troubleshooting symptom tree in the G8.3, G5.9, G855, and GTA855 CM558 (CM2358), Master Repair Manual Bulletin 4021701.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1978 is inactive.

Fault Code 1978 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 20-Aug-2014


FAULT CODE 2217 - Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check for fault codes. | Fault Code 2217 active?
 | STEP 1B. Check the power supply. | Constant +24-VDC power supply to the ECM?
 | STEP 1C. Check ECM for a short circuit to ground. | More than 100k ohms?
 | STEP 1D. Recalibrate the ECM. | ECM recalibrated successfully?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2217 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use the keyswitch to recycle the power to the ECM.
  • Use INSITE™ electronic service tool to check for fault codes.

Fault Code 2217 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the OEM connector as a possible source of an intermittent power supply.

Constant +24-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 47-pin OEM connector. Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

Go to 1C

Go to 2A

Guided Step 1C - Check ECM for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector A and connector B from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

More than 100k ohms?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in the Associated Procedures Table.

ECM recalibrated successfully?
YES NO
No Repair

Active fault codes are present.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 2217 is inactive.

Fault Code 2217 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 07-Mar-2017


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Fuel Shutoff Valve Circuit | Refer to Procedure 019-049 | GTA855 CM558/CM2358 N101 | 4021702
Fuel Shutoff Valve Circuit | Refer to Procedure 019-049 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Codes 2311 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel control valve. Refer to Procedure 019-049 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the electronic fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-049 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve. 019-049 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 47-pin OEM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the electronic fuel control valve connector to the engine harness connector
  • Disconnect the engine harness connector from the ECM 47-pin OEM connector.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector
  • Disconnect the engine harness connector from the ECM 47-pin OEM connector.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

  • Refer to the circuit diagram or wiring diagram for all interconnections.
  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working over to the electronic fuel control valve.

Fault Codes 2311 active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

  • Refer to the circuit diagram or wiring harness for all harness interconnections.
  • Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the electronic fuel control valve. Refer to Procedure 019-049 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 2315 - Red Stop Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the ECM and the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2315 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

Repair the engine harness connector or OEM harness connector, whichever has the damaged pins.

  • Repair the 21-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from red stop lamp driver on the OEM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

  • Repair the OEM harness. Refer to manufacturer's instructions. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM harness. Refer to manufacturer's instructions. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relays.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel and relays.

  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701.

Any issues?
YES | NO
No Repair | No Repair

Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual, Bulletin 4021701 for instructions on how to resolve the issues.
Go to 3A

Go to 2A

Guided Step 2 - Check the ECM and the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from pin-3 in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin-3 in the ECM connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let idle for 1 minute.

Fault Code 2315 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 2316 - Amber Warning Lamp Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2316 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pin
  • Moisture in or on connector.
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair the OEM harness connector.

  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from Amber Lamp Driver pin on the OEM connector to the engine block ground.

More than 100k ohms?
YES NO

  • Repair the OEM harness. Refer to the OEM service manual
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2A

Guided Step 1C - Check the OEM control panel and relays.

Conditions

  • Turn keyswitch OFF

Action

Check the OEM control panel and relays.

  • Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

Any issues?
YES NO

Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701, for instructions on how to resolve the issue.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pin
  • Moisture in or on connector.
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from Amber Lamp Driver pin in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from Amber Lamp Driver pin in the ECM connector to the engine block ground.

More than 100k ohms?
YES NO

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components
  • Start the engine and let idle for 1 minute.

Fault Code 2316 inactive?
YES NO

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Go to the appropriate troubleshooting chart.

Repair complete.

Last Modified: 24-Jan-2014


FAULT CODE 2317 - Amber Warning Lamp Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2317 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pin
  • Moisture in or on connector.
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair the engine harness connector or OEM harness connector, whichever has the damaged pins.

  • Repair the 47-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from Amber Lamp Driver pin on the OEM connector to the engine block ground.

More than 100k ohms?
YES NO

  • Repair the OEM harness. Refer to the OEM instructions. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM harness. Refer to the OEM instructions. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2A

Guided Step 1C - Check the OEM control panel and relays.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel and relays.

  • Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

Any issues?
YES NO
No Repair

Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701, for instructions on how to resolve the issue.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pin
  • Moisture in or on connector.
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from Amber Lamp Driver pin in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO

Repair or replace the harness

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from Amber Lamp Driver pin in the ECM connector to the engine block ground.

More than 100k ohms?
YES NO

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components
  • Start the engine and let idle for 1 minute.

Fault Code 2317 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO

Troubleshoot any remaining active fault codes.

Troubleshoot any remaining active fault codes.

Go to the appropriate troubleshooting chart.

Repair complete.

Last Modified: 24-Jan-2014


FAULT CODE 2455 - External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement:Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit in the wiring. | More than 100k ohms?
STEP 2. | Check the customer interface box. |
 | STEP 2A. Check the 47-pin OEM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the wiring. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2455 Inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure ror general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check for a short circuit to the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Check for a short circuit to the wiring harness as follows:

  • Measure the resistance from OEM terminal connection on the OEM connector to all other pins on the OEM connector. Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701, for further troubleshooting.

More than 100k ohms?
YES NO
No Repair

  • Repair the OEM harness. Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

Go to 2A

Go to 4A

Guided Step 2 - Check the customer interface box.

Guided Step 2A - Inspect the 47-pin OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 47-pin OEM connector.

Action

Inspect the 47-pin OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 47-pin OEM connector
  • Disconnect the OEM connector.

Action

Check for a short circuit in the wiring harness.

  • Measure the resistance from speed adjustment 4-20 milli ampere supply on the 47-pin OEM connector to the other pins on the 47-pin OEM connector. Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701, for further troubleshooting.

More than 100k ohms?
YES NO
No Repair

  • Repair the customer interface box. Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701, for further troubleshooting.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the ECM and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from speed adjustment 4-20 milli ampere supply in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2455 is inactive.

Fault Code 2455 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 2456 - External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to the wiring harness. | More than 100k ohms?
STEP 2. | Check the customer interface box. |
 | STEP 2A. Inspect the 47-pin connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short in the wiring. | More than a 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2456 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

 No Repair

Go to 4

Go to 1B

Guided Step 1B - Check for a short circuit to the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Check for a short circuit to the wiring harness.

  • Inspect the OEM panel for short circuits.
  • Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

More than 100k ohms?
YES NO
No Repair

Repair the damaged OEM harness.

Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358 Master Repair Manual Bulletin 4021701.

Go to 2A

Go to 4A

Guided Step 2 - Check the customer interface box.

Guided Step 2A - Inspect the 47-pin connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the 47-pin connector
  • Disconnect the OEM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from a battery ground wire on the 47-pin connector to all other pins on the 47-pin connector.
  • Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

More than 100k ohms?
YES NO
No Repair

Repair the customer interface wiring.

Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358 Master Repair Manual Bulletin 4021701.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

  • Repair the damaged pins.
  • Replace the harness or ECM, whichever has the damaged pins.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 36 in the ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components.
  • Start the engine and let the engine idle for 1 minute.

Fault Code 2456 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes as follows:

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All inactive fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 2544 - Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2544 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Place run/stop/auto switch in RUN mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2544 active?
YES NO

Allow the ECM to cool and then restart the engine. If the fault reoccurs, contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 15-Aug-2012


FAULT CODE 2661 - At Least One Unacknowledged Most Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2661 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive fault codes?
YES NO

Troubleshoot other fault codes before acknowledging this fault code.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the OEM-supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2661 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Aug-2012


FAULT CODE 2789 - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | GTA855 CM558/CM2358 N101 | 4021702
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2789 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the Coolant Temperature value.

  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Mechanical Gas Fuel System Master Repair Manual, Bulletin 4021404.

Replace the coolant sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2789 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 2793 - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | GTA855 CM558/CM2358 N101 | 4021702

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2793 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the coolant temperature value.

  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Mechanical Gas Fuel System Master Repair Manual, Bulletin 4021404.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2793 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 2797 - Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Carburetor Inlet Gas Differential Pressure Sensor | Refer to Procedure 019-457 | GTA855 CM558/CM2358 N101 | 4021702
Carburetor Inlet Gas Differential Pressure Sensor | Refer to Procedure 019-457 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2797 active?
STEP 2. | Check the carburetor inlet gas differential pressure sensor and circuit. |
 | STEP 2A. Inspect the carburetor inlet gas differential pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2798 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2797 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2797 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 2797 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2797 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Inspect the carburetor inlet gas differential pressure sensor and circuit.

Guided Step 2A - Inspect the carburetor inlet gas differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and carburetor inlet gas differential pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Repair or replace the harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the carburetor inlet gas differential pressure sensor. Refer to Procedure 019-457 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2787 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the carburetor inlet gas differential pressure sensor SUPPLY pin and the carburetor inlet gas differential pressure sensor RETURN pin at the carburetor inlet gas differential pressure sensor connector of the OEM harness.
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the carburetor inlet gas differential pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2797 active?
YES NO

A damaged sensor has been detected.

Replace the carburetor inlet gas differential pressure sensor. Refer to Procedure 019-457 in the Associated Procedures Table.

None. Removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for an open short circuit.

  • Measure the resistance between the OEM harness ECM connector carburetor inlet gas differential pressure sensor RETURN pin and the OEM harness carburetor inlet gas differential pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the carburetor inlet gas differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the OEM harness ECM connector carburetor inlet gas differential pressure sensor SUPPLY pin and the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply wire has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2797 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be completed again from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault Code 2797 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 2798 - Carburetor Inlet Gas Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Carburetor Inlet Gas Differential Pressure Sensor | Refer to Procedure 019-457 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Carburetor Inlet Gas Differential Pressure Sensor | Refer to Procedure 019-457 | GTA855 CM558/CM2358 N101 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2798 inactive?
STEP 2. | Check the carburetor inlet gas differential pressure sensor and circuit. |
 | STEP 2A. Inspect the carburetor inlet gas differential pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2798 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2798 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2798 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Clear the fault code. | Disable the inactive fault codes.
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2798 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the carburetor inlet gas differential pressure sensor and circuit.

Guided Step 2A - Inspect the carburetor inlet gas differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and carburetor inlet gas differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2797 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the carburetor inlet gas differential pressure sensor SUPPLY pin and the carburetor inlet gas differential pressure sensor RETURN pin at the carburetor inlet gas differential pressure sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the carburetor inlet gas differential pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2798 active?
YES NO

A damaged sensor has been detected.

Replace the carburetor inlet gas differential pressure sensor. Refer to Procedure 019-457 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or OEM harness connector.

Clean the connector and pins.

Refer to Procedure 019-071 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector carburetor inlet gas differential pressure sensor RETURN pin and the OEM harness carburetor inlet gas differential pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the carburetor inlet gas differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the carburetor inlet gas differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the carburetor inlet gas differential pressure sensor SIGNAL pin in the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground on the signal wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2798 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be completed again from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2798 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Apr-2014


FAULT CODE 2864 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Shutoff Valve | Refer to Procedure 019-050 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Fuel Shutoff Valve | Refer to Procedure 019-050 | GTA855 CM558/CM2358 N101 | 4021702
Engine Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the valve supply voltage. | Greater than 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558/CM2358 response. |
 | STEP 4A. Check for the appropriate CM558/CM2358 response. | Fault Code 2864 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2864 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Keyswitch circuit energized
  • Place run/stop/auto switch in RUN mode and engine cranking
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect INSITE™ electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

Note: Make sure that the engine is not performing a purge cycle when making this measurement.

Greater than 24-VDC?
YES NO
No Repair

Check the battery connections and the fuses in the harness.

Refer to the circuit diagram or wiring diagram for component identification.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the fuel shutoff valve and the CM558/CM2358.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve SUPPLY pin on the engine harness connector to the fuel shutoff valve SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness connector to the fuel shutoff valve SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558/CM2358 response.

Guided Step 4A - Check for the appropriate CM558/CM2358 response.

Conditions

  • Keyswitch circuit energized
  • Disconnect the engine harness connector from the Fuel Shutoff Valve
  • Place run/stop/auto switch in Run mode and engine cranking.

Action

Check for the appropriate CM558/CM2358 response.

  • Install a jumper to power the fuel shutoff valve relays and then crank the engine.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 2864 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Place run/stop/auto switch in RUN mode and running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2864 is inactive.

Fault Code 2864 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Place run/stop/auto switch in STOP mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Jan-2014


FAULT CODE 2865 - Power Relay Driver Diagnostics Has Detected An Error - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead and Part Number 3823994 - female Deutsch™ test lead.
CAUTION

To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the OEM harness. |
 | STEP 1A. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any Issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2865 Inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the OEM harness.

Guided Step 1A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector.

Action

Inspect the OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness connector or OEM harness connector, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the 21-pin Deutsch™ connector. Refer to Procedure 019-207 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground.

  • Measure the resistance from the run/stop switch SIGNAL OEM connector to the engine block ground.

More than 100k ohms?
YES NO

  • Repair or replace the OEM harness. Refer to manufacturer's instructions. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the OEM panel and relays.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel and relays.

  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

Any issues?
YES NO

  • Reference the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701, for instruction on how to resolve the issue.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from run/stop switch SIGNAL ECM connector to all of the other pins in the connector.

More than 100k ohms?
YES NO

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM connector
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from run/stop switch SIGNAL ECM connector to the engine block ground.

More than 100k ohms?
YES NO

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Connect all components
  • Start the engine and let idle for 1 minute.

Fault Code 2865 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Go to the appropriate troubleshooting chart.

Repair complete.

Last Modified: 24-Jan-2014


FAULT CODE 2866 - Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Fuel Shutoff Valve | Refer to Procedure 019-050 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Fuel Shutoff Valve | Refer to Procedure 019-050 | GTA855 CM558/CM2358 N101 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2866 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 2866 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2866 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2866 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel control valve. Refer to Procedure 019-050 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the electronic fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector B.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the electronic fuel control valve connector to the engine harness connector
  • Disconnect the engine harness connector from the ECM connector B.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

  • Refer to the circuit diagram or wiring diagram for all interconnections.
  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector
  • Disconnect the engine harness connector from the ECM connector B.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

  • Refer to the circuit diagram or wiring diagram for all interconnections.
  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Code 2866 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

  • Refer to the circuit diagram or wiring harness for all harness interconnections.
  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the electronic fuel control valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2866 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Apr-2014


FAULT CODE 2867 - Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Fuel Shutoff Valve | Refer to Procedure 019-050 | GTA855 CM558/CM2358 N101 | 4021702
Fuel Shutoff Valve | Refer to Procedure 019-050 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2867 active or high inactive counts?
STEP 2. | Check the electronic fuel control valve. |
 | STEP 2A. Inspect the electronic fuel control valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the electronic fuel control valve resistance. | Less than 5 ohms?
 | STEP 2C. Check the electronic fuel control valve for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Code 2867 becomes active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2867 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the electronic fuel control valve is connected to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2867 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the electronic fuel control valve.

Guided Step 2A - Inspect the electronic fuel control valve and harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Inspect the electronic fuel control valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the electronic fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the electronic fuel control valve. Refer to Procedure 019-050 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the electronic fuel control valve resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the fuel pump pressurizing assembly 1 resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the electronic fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 2C - Check the electronic fuel control valve for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector.

Action

Check the electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the electronic fuel control valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM connector B.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF
  • Connect the electronic fuel control valve connector to the engine harness connector
  • Disconnect the engine harness connector from the ECM connector B.

Action

Check the engine harness resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin and the electronic fuel control valve RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

  • Refer to the circuit diagram or wiring diagram for all interconnections.
  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the electronic fuel control valve connector from the engine harness connector
  • Disconnect the engine harness connector from the ECM connector B.

Action

Check the engine harness and electronic fuel control valve resistance.

  • Measure the resistance between the electronic fuel control valve SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the short to ground.

  • Refer to the circuit diagram or wiring diagram for all interconnections.
  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the electronic fuel control valve.

Fault Code 2867 becomes active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

  • Refer to the circuit diagram or wiring harness for all harness interconnections.
  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the electronic fuel control valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2867 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Jan-2014


FAULT CODE 2995 - Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | GTA855 CM558/CM2358 N101 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor Circuit | Refer to Procedure 019-354 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2995 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge. | INSITE™ electronic service tool reading within 127 mm-Hg [5 in-Hg] of mechanical gauge reading?
STEP 3. | Check the intake pressure/temperature sensor. |
 | STEP 3A. Inspect the intake pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 2995 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2995 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2995 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge.

Conditions

  • Connect the INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Connect a mechanical intake pressure/temperature gauge to the engine, as close to the intake pressure/temperature sensor as possible.
  • Start the INSITE™ Data Monitor/Logger and compare the INSITE™ electronic service tool reading for intake pressur/temperature to the mechanical gauge.

INSITE™ electronic service tool reading within 127 mm-Hg [5 in-Hg] of mechanical gauge reading?
YES NO

Replace the intake pressure/temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the intake pressure/temperature sensor.

Guided Step 3A - Inspect the intake pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Intake Pressure/Temperature Sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake pressure/temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2995 active?
YES NO

Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

 No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2995 is inactive.

Fault Code 2995 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jan-2014


FAULT CODE 2996 - Intake Manifold Pressure 1 - Data Valid But Above Normal Operating Range

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | GTA855 CM558/CM2358 N101 | 4021702
Engine Wiring Harness | Refer to Procedure 019-043 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-354 | GTA855 CM558/CM2358 N101 | 4021702
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-354 | G5.9, G855, and G8.3 CM558/CM2358 | 4021702

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2996 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge. | INSITE™ electronic service tool reading within 127 mm-Hg [5 in-Hg] of mechanical gauge reading?
STEP 3. | Check the intake manifold pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 2996 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2996 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2996 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a mechanical intake manifold pressure gauge or similar gauge.

Conditions

  • Connect the INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Connect a mechanical intake pressure/temperature gauge to the engine, as close to the intake pressure/temperature sensor as possible.
  • Start the INSITE™ Data Monitor/Logger and compare the INSITE™ electronic service tool reading for intake pressure/temperature to the mechanical gauge.

INSITE™ electronic service tool reading within 127 mm-Hg [5 in-Hg] of mechanical gauge reading?
YES NO

Replace the intake pressure/temperature sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the intake pressure/temperature sensor.

Guided Step 3A - Inspect the intake pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the sensor. Refer to Procedure 019-354 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2996 active?
YES NO

Reference the in the G8.3, G5.9, G855, and GTA855 CM558/CM2358, Master Repair Manual Bulletin 4021701.

 No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2996 is inactive.

Fault Code 2996 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 18-Apr-2014


FAULT CODE 5835 - Propane Methane Spark Timing Adjustment Current Driver – Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5835 active?
STEP 2. | Check the engine harness and ECM connector pins. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5835 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control module (ICM) connector from the engine harness.

Action

Inspect the wires and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the harness.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the ICM connector to the engine harness connector.
  • Disconnect the engine harness connector from the ECM 37-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the SIGNAL pin at the ICM and the SIGNAL pin at the ECM connector of the engine harness.
  • Measure the resistance between the RETURN pin at the ICM and the RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICM connector from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 37-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness.

Repair or replace the engine harness.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICM connector from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 37-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the SIGNAL pin in the ECM connector and all other pins in the connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected.

Repair or replace the engine harness.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Feb-2017


FAULT CODE 5836 - Propane Methane Spark Timing Adjustment Current Driver - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5836 active?
STEP 2. | Check the engine harness and ECM connector pins. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for short to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5836 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control module (ICM) connector from the engine harness.

Action

Inspect the wires and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the harness.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the ICM connector to the engine harness connector.
  • Disconnect the engine harness connector from the ECM 37-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the SIGNAL pin at the ICM and the SIGNAL pin at the ECM connector of the engine harness.
  • Measure the resistance between the RETURN pin at the ICM and the RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICM connector from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 37-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance between the SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness.

Repair or replace the engine harness.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ICM connector from the engine harness connector.
  • Disconnect the engine harness connector from the ECM 37-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the SIGNA:L pin in the ECM connector and all other pins in the connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected.

Repair or replace the engine harness.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Feb-2017


INDEX
121-fc121.htm

121-t05-121.htm

121-fc135.htm

121-t05-135.htm

121-fc141.htm

121-t05-141.htm

121-fc142.htm

121-t05-142.htm

121-fc143.htm

121-t05-143.htm

121-fc144.htm

121-t05-144.htm

121-fc145.htm

121-t05-145.htm

121-fc146.htm

121-t05-146.htm

121-fc151.htm

121-t05-151.htm

121-fc153.htm

121-t05-153.htm

121-fc154.htm

121-t05-154.htm

121-fc155.htm

121-t05-155.htm

121-fc177.htm

121-t05-177.htm

121-fc187.htm

121-t05-187.htm

121-fc212.htm

121-t05-212.htm

121-fc213.htm

121-t05-213.htm

121-fc214.htm

121-t05-214.htm

121-fc227.htm

121-t05-227.htm

121-fc234.htm

121-t05-234.htm

121-fc238.htm

121-t05-238.htm

121-fc239.htm

121-t05-239.htm

121-fc244.htm

121-t05-244.htm

121-fc254.htm

121-t05-254.htm

121-fc277.htm

121-t05-277.htm

121-fc343.htm

121-t05-343.htm

121-fc346.htm

121-t05-346.htm

121-fc352.htm

121-t05-352.htm

121-fc354.htm

121-t05-354.htm

121-fc355.htm

121-t05-355.htm

121-fc386.htm

121-t05-386.htm

121-fc415.htm

121-t05-415.htm

121-fc421.htm

121-t05-421.htm

121-fc426.htm

121-t05-426.htm

121-fc441.htm

121-t05-441.htm

121-fc442.htm

121-t05-442.htm

121-fc477.htm

121-t05-477.htm

121-fc478.htm

121-t05-478.htm

121-fc488.htm

121-t05-488.htm

121-fc512.htm

121-t05-512.htm

121-fc513.htm

121-t05-513.htm

121-fc689.htm

00-t05-689.htm

121-fc697.htm

121-t05-697.htm

121-fc698.htm

121-t05-698.htm

121-fc783.htm

121-t05-783.htm

121-fc1665.htm

121-t05-1665.htm

121-fc1666.htm

121-t05-1666.htm

121-fc1674.htm

121-t05-1674.htm

121-fc1675.htm

121-t05-1675.htm

121-fc1739.htm

121-t05-1739.htm

121-fc1776.htm

121-t05-1776.htm

121-fc1777.htm

121-t05-1777.htm

121-fc1791.htm

121-t05-1791.htm

121-fc1824.htm

121-t05-1824.htm

121-fc1858.htm

121-t05-1858.htm

121-fc1859.htm

121-t05-1859.htm

121-fc1861.htm

121-t05-1861.htm

121-fc1862.htm

121-t05-1862.htm

121-fc1863.htm

121-t05-1863.htm

121-fc1864.htm

121-t05-1864.htm

121-fc1965.htm

121-t05-1965.htm

121-fc1966.htm

121-t05-1966.htm

121-fc1968.htm

121-t05-1968.htm

121-fc1969.htm

121-t05-1969.htm

121-fc1978.htm

121-t05-1978.htm

121-fc1979.htm

121-t05-1979.htm

121-fc1982.htm

121-t05-1982.htm

121-fc1983.htm

121-t05-1983.htm

121-fc2217.htm

121-t05-2217.htm

121-fc2311.htm

121-t05-2311.htm

121-fc2315.htm

121-t05-2315.htm

121-fc2316.htm

121-t05-2316.htm

121-fc2317.htm

121-t05-2317.htm

121-fc2455.htm

121-t05-2455.htm

121-fc2456.htm

121-t05-2456.htm

121-fc2544.htm

121-t05-2544.htm

121-fc2661.htm

121-t05-2661.htm

121-fc2789.htm

121-t05-2789.htm

121-fc2793.htm

121-t05-2793.htm

121-fc2797.htm

121-t05-2797.htm

121-fc2798.htm

121-t05-2798.htm

121-fc2864.htm

121-t05-2864.htm

121-fc2865.htm

121-t05-2865.htm

121-fc2866.htm

121-t05-2866.htm

121-fc2867.htm

121-t05-2867.htm

121-fc2995.htm

121-t05-2995.htm

121-fc2996.htm

121-t05-2996.htm

121-fc5835.htm

121-t05-5835.htm

121-fc5836.htm

121-t05-5836.htm